Installation/Removal fails because of package which could not be located (failure in apt.Cache.required_download)

Reported by diego1907 on 2010-10-12
This bug affects 1853 people
Affects Status Importance Assigned to Milestone
Aptdaemon
Critical
Unassigned
apt (Ubuntu)
High
Unassigned
Maverick
Undecided
Unassigned
aptdaemon (Ubuntu)
Critical
Michael Vogt
Maverick
Undecided
Unassigned
python-apt (Ubuntu)
Undecided
Unassigned
Maverick
Undecided
Unassigned

Bug Description

Steps to reproduce:

1. Run apt-get nstall ms-ttcorefonts-installer in a terminal
2. Close the terminal window at the EULA question (apt-get/dpkg/debconf) will sting hang in the background and lock the system)
3. Reboot

Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 768, in simulate
    return self._simulate_helper(trans, status_path)
  File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 936, in _simulate_helper
    return depends, status, self._cache.required_download, \
  File "/usr/lib/python2.6/dist-packages/apt/cache.py", line 218, in required_download
    pm.get_archives(fetcher, self._list, self._records)
SystemError: E:I wasn't able to locate file for the liblua50 package. This might mean you need to manually fix this package.

summary: - error en el software para instalar aplicaciones
+ Installation/Removal fails because of package which could not be located
+ (faiulre in apt.Cache.required_download)
security vulnerability: yes → no
visibility: private → public
Changed in aptdaemon:
status: New → Confirmed
importance: Undecided → Critical

Have you queued several installations/removals at the same time?

Changed in aptdaemon:
status: Confirmed → Incomplete

I did an update on ubuntu and was then able to install my programs.

Helping people naturally alleviate pain without
crazy treatments or surgery

Sent from my iPhone

On Oct 20, 2010, at 6:55 AM, "Sebastian Heinlein -
<email address hidden>"
<>
wrote:

> Have you queued several installations/removals at the same time?
>
> ** Changed in: aptdaemon
> Status: Confirmed => Incomplete
>
> --
> Installation/Removal fails because of package which could not be located (faiulre in apt.Cache.required_download)
> https://bugs.launchpad.net/bugs/659438
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (663425).
>
> Status in Aptdaemon: Incomplete
>
> Bug description:
> Traceback (most recent call last):
> File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 768, in simulate
> return self._simulate_helper(trans, status_path)
> File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 936, in _simulate_helper
> return depends, status, self._cache.required_download, \
> File "/usr/lib/python2.6/dist-packages/apt/cache.py", line 218, in required_download
> pm.get_archives(fetcher, self._list, self._records)
> SystemError: E:I wasn't able to locate file for the liblua50 package. This might mean you need to manually fix this package.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/aptdaemon/+bug/659438/+subscribe
>

FuzyToes (fuzytoes) wrote :

As did I. Now she blows! :) Thanks man. /P

On Wed, 2010-10-20 at 13:21 +0000, Hfolmt wrote:
> I did an update on ubuntu and was then able to install my programs.
>
> Helping people naturally alleviate pain without
> crazy treatments or surgery
>
> Sent from my iPhone
>
>
> On Oct 20, 2010, at 6:55 AM, "Sebastian Heinlein -
> <email address hidden>"
> <>
> wrote:
>
> > Have you queued several installations/removals at the same time?
> >
> > ** Changed in: aptdaemon
> > Status: Confirmed => Incomplete
> >
> > --
> > Installation/Removal fails because of package which could not be located (faiulre in apt.Cache.required_download)
> > https://bugs.launchpad.net/bugs/659438
> > You received this bug notification because you are a direct subscriber
> > of a duplicate bug (663425).
> >
> > Status in Aptdaemon: Incomplete
> >
> > Bug description:
> > Traceback (most recent call last):
> > File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 768, in simulate
> > return self._simulate_helper(trans, status_path)
> > File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 936, in _simulate_helper
> > return depends, status, self._cache.required_download, \
> > File "/usr/lib/python2.6/dist-packages/apt/cache.py", line 218, in required_download
> > pm.get_archives(fetcher, self._list, self._records)
> > SystemError: E:I wasn't able to locate file for the liblua50 package. This might mean you need to manually fix this package.
> >
> > To unsubscribe from this bug, go to:
> > https://bugs.launchpad.net/aptdaemon/+bug/659438/+subscribe
> >
>

Thanks my friend!

When I did a sudo dpkg --configure -a and then did the update mgr, the
thing seems to have been fixed.

Question: (If you care to answer) Lately, when I leave the system on for
some hours, it hangs. No blinking kbd, nothing. just plain stuck. A
driver issue? Any ideas why it halts after a period of time? If I move
the mouse, the screen lights up but no response. Hard kill only option.
That's not UNIX!? ;)

Thanks for your effort! Apreciated!

/P

On Wed, 2010-10-20 at 10:31 +0000, Sebastian Heinlein wrote:
> Have you queued several installations/removals at the same time?
>
> ** Changed in: aptdaemon
> Status: Confirmed => Incomplete
>

FuzyToes: Please focus only on this bug in this discussion. You should open a new support question.

Ken Johnson (pebmich-comcast) wrote :

I did sudo dpkg --configure -a update..sudo apt-get update and sudo apt-get upgrade and still get the same error.

was gibt hier?

sorry dude, i just have give of linux, becouse donot suport my games, even
in wine, i tried al but just not woth for it, i just prefire an pirate
windows, becouse sounds like i am not usig all the power of my pc becouse
the games not stay in max, i have an 9600Gt, 3 gb of memory and with linux
sounds like my pc is top too powerful, this is just an opnion, creat an
beatter design thats make the user fell powerful, and try to make some game
store like steam but put hard games with good graphics, just an other
question, with i creat an concepet to an design you guys maybe wold used?
sorry for the english becouse i from brazil. thanks for your atention
.
2010/10/22 Ken Johnson <email address hidden>

> I did sudo dpkg --configure -a update..sudo apt-get update and sudo apt-
> get upgrade and still get the same error.
>
> was gibt hier?
>
> --
> Installation/Removal fails because of package which could not be located
> (faiulre in apt.Cache.required_download)
> https://bugs.launchpad.net/bugs/659438
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (664210).
>
> Status in Aptdaemon: Incomplete
> Status in “aptdaemon” package in Ubuntu: New
> Status in “python-apt” package in Ubuntu: New
>
> Bug description:
> Traceback (most recent call last):
> File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 768, in
> simulate
> return self._simulate_helper(trans, status_path)
> File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 936, in
> _simulate_helper
> return depends, status, self._cache.required_download, \
> File "/usr/lib/python2.6/dist-packages/apt/cache.py", line 218, in
> required_download
> pm.get_archives(fetcher, self._list, self._records)
> SystemError: E:I wasn't able to locate file for the liblua50 package. This
> might mean you need to manually fix this package.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/aptdaemon/+bug/659438/+subscribe
>

Changed in aptdaemon:
status: Incomplete → Confirmed
status: Confirmed → Incomplete
Robert Roth (evfool) on 2010-11-11
Changed in aptdaemon:
status: Incomplete → Confirmed

Sudo apt get remove
Sudo apt get update
Then
Sudo apt get upgrade
Then try to install again

regards,

Alberto Ochoa
On Nov 18, 2010 5:41 PM, "abhishek" <email address hidden> wrote:
> so...what is the solution?
>
> --
> Installation/Removal fails because of package which could not be located
(faiulre in apt.Cache.required_download)
> https://bugs.launchpad.net/bugs/659438
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Aptdaemon: Confirmed
> Status in “aptdaemon” package in Ubuntu: New
> Status in “python-apt” package in Ubuntu: New
>
> Bug description:
> Traceback (most recent call last):
> File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 768, in
simulate
> return self._simulate_helper(trans, status_path)
> File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 936, in
_simulate_helper
> return depends, status, self._cache.required_download, \
> File "/usr/lib/python2.6/dist-packages/apt/cache.py", line 218, in
required_download
> pm.get_archives(fetcher, self._list, self._records)
> SystemError: E:I wasn't able to locate file for the liblua50 package. This
might mean you need to manually fix this package.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/aptdaemon/+bug/659438/+subscribe

andres@ubuntu:~$ sudo apt get remove
sudo: apt: command not found

I'm new using linux.
What can I do now?

Robert Roth (evfool) wrote :

@Andres Lincango: the commands are mistyped, 'apt get' should be 'apt-get' instead everywhere.

Whitwat10 (whitwat10) on 2010-11-29
Changed in aptdaemon:
assignee: nobody → Whitwat10 (whitwat10)
assignee: Whitwat10 (whitwat10) → Sebastian Heinlein (glatzor)
Sebastian Heinlein (glatzor) wrote :

Seems to be a race with the apt cron job, which checks for updates regularly.

Changed in aptdaemon (Ubuntu):
status: New → Confirmed
importance: Undecided → Critical
Sebastian Heinlein (glatzor) wrote :

An unittest which tiggers the error.

Sebastian Heinlein (glatzor) wrote :

A small patch which requires the lists lock before calling the simulate method. Otherwise we raise a faild lock error.

tags: added: patch
uday kuwar (udaykuwar) wrote :

HI FRIENDS IAM NEW TO UBUNTU KINDLY HELP ME TO COME OUT OF PROBLEM....PLEASE..

eis (pierrehenri-legros) wrote :

ok thank you,
i have did apt-get --configure -a and apt-get update and apt-get upgrade (?) and all work properperly.

Jonathan Riddell (jr) wrote :

In maverick-proposed unapproved queue
Bug needs debdiff attached
ubuntu-sru subcribed for review

Martin Pitt (pitti) wrote :

Please fix this in Natty ASAP, so that this can progress to -updates.

Changed in aptdaemon (Ubuntu Maverick):
status: New → Fix Committed
tags: added: verification-needed

Accepted aptdaemon into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

I did an update on ubuntu and was then able to install my programs.
Thanks

Martin Pitt (pitti) wrote :

Paul, did you test the aptdaemon package from maverick-proposed? Thanks!

kiobzm (samarathari) on 2010-12-20
Changed in aptdaemon (Ubuntu):
status: Confirmed → Fix Committed

Hi Martin

I am very new to Ubuntu, still need to learn a lot.

What I did to solve my problem was to do an update with Update Manager
and once that was done the concern was resolved.

I then ran Ubuntu Software Center and was able to install programs as
per normal.

Thanks for your assistance.

Regards
Paul

Hello All,

I had the same issue which I have resolved by updating atpdaemon with the
synaptic package manager.
It works now.

JF

On Mon, Dec 20, 2010 at 9:13 PM, Paul Goosen <email address hidden>wrote:

> Hi Martin
>
> I am very new to Ubuntu, still need to learn a lot.
>
> What I did to solve my problem was to do an update with Update Manager
> and once that was done the concern was resolved.
>
> I then ran Ubuntu Software Center and was able to install programs as
> per normal.
>
> Thanks for your assistance.
>
> Regards
> Paul
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (676655).
> https://bugs.launchpad.net/bugs/659438
>
> Title:
> Installation/Removal fails because of package which could not be located
> (faiulre in apt.Cache.required_download)
>
> Status in Aptdaemon:
> Confirmed
> Status in “aptdaemon” package in Ubuntu:
> Fix Committed
> Status in “python-apt” package in Ubuntu:
> New
> Status in “aptdaemon” source package in Maverick:
> Fix Committed
> Status in “python-apt” source package in Maverick:
> New
>
> Bug description:
> Traceback (most recent call last):
> File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 768, in
> simulate
> return self._simulate_helper(trans, status_path)
> File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 936, in
> _simulate_helper
> return depends, status, self._cache.required_download, \
> File "/usr/lib/python2.6/dist-packages/apt/cache.py", line 218, in
> required_download
> pm.get_archives(fetcher, self._list, self._records)
> SystemError: E:I wasn't able to locate file for the liblua50 package. This
> might mean you need to manually fix this package.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/aptdaemon/+bug/659438/+subscribe
>

王平 (soft-for-java) wrote :
Download full text (3.4 KiB)

I've already solved, thank you

> Date: Tue, 21 Dec 2010 17:06:23 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: Re: [Bug 659438] Re: Installation/Removal fails because of package which could not be located (faiulre in apt.Cache.required_download)
>
> Hello All,
>
> I had the same issue which I have resolved by updating atpdaemon with the
> synaptic package manager.
> It works now.
>
> JF
>
> On Mon, Dec 20, 2010 at 9:13 PM, Paul Goosen
> <email address hidden>wrote:
>
> > Hi Martin
> >
> > I am very new to Ubuntu, still need to learn a lot.
> >
> > What I did to solve my problem was to do an update with Update Manager
> > and once that was done the concern was resolved.
> >
> > I then ran Ubuntu Software Center and was able to install programs as
> > per normal.
> >
> > Thanks for your assistance.
> >
> > Regards
> > Paul
> >
> > --
> > You received this bug notification because you are a direct subscriber
> > of a duplicate bug (676655).
> > https://bugs.launchpad.net/bugs/659438
> >
> > Title:
> > Installation/Removal fails because of package which could not be located
> > (faiulre in apt.Cache.required_download)
> >
> > Status in Aptdaemon:
> > Confirmed
> > Status in “aptdaemon” package in Ubuntu:
> > Fix Committed
> > Status in “python-apt” package in Ubuntu:
> > New
> > Status in “aptdaemon” source package in Maverick:
> > Fix Committed
> > Status in “python-apt” source package in Maverick:
> > New
> >
> > Bug description:
> > Traceback (most recent call last):
> > File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 768, in
> > simulate
> > return self._simulate_helper(trans, status_path)
> > File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 936, in
> > _simulate_helper
> > return depends, status, self._cache.required_download, \
> > File "/usr/lib/python2.6/dist-packages/apt/cache.py", line 218, in
> > required_download
> > pm.get_archives(fetcher, self._list, self._records)
> > SystemError: E:I wasn't able to locate file for the liblua50 package. This
> > might mean you need to manually fix this package.
> >
> > To unsubscribe from this bug, go to:
> > https://bugs.launchpad.net/aptdaemon/+bug/659438/+subscribe
> >
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (691064).
> https://bugs.launchpad.net/bugs/659438
>
> Title:
> Installation/Removal fails because of package which could not be located (faiulre in apt.Cache.required_download)
>
> Status in Aptdaemon:
> Confirmed
> Status in “aptdaemon” package in Ubuntu:
> Fix Committed
> Status in “python-apt” package in Ubuntu:
> New
> Status in “aptdaemon” source package in Maverick:
> Fix Committed
> Status in “python-apt” source package in Maverick:
> New
>
> Bug description:
> Traceback (most recent call last):
> File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 768, in simulate
> return self._simulate_helper(trans, status_path)
> File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 936, in _simulate_helper
> return depends, status, self._cache.required_download, \
> File "/usr/lib/python2.6/dist-packages/apt/cache.py", line ...

Read more...

Martin Pitt (pitti) on 2010-12-22
tags: added: verification-done
removed: verification-needed
Changed in aptdaemon:
status: Confirmed → Incomplete

This bug was fixed in the package aptdaemon - 0.40+bzr529-0ubuntu3

---------------
aptdaemon (0.40+bzr529-0ubuntu3) natty; urgency=low

  [ Sebastian Heinlein ]
  * debian/patches/09_fix_index_race_659438.patch:
    - If the background cron job rebuilds the apt indexes the
      apt.Cache.required_download method fails, since it tries to access
      the not available indexes. This patch is a workaround since it
      is requires a lock on the indexes before caluclating the size
      (LP: #659438)
 -- Michael Vogt <email address hidden> Mon, 03 Jan 2011 12:26:48 +0100

Changed in aptdaemon (Ubuntu):
status: Fix Committed → Fix Released

Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 768, in simulate
    return self._simulate_helper(trans, status_path)
  File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 938, in _simulate_helper
    return depends, status, self._cache.required_download, \
  File "/usr/lib/python2.6/dist-packages/apt/cache.py", line 218, in required_download
    pm.get_archives(fetcher, self._list, self._records)
SystemError: E:I wasn't able to locate file for the rar package. This might mean you need to manually fix this package.

1 comments hidden view all 166 comments

I've already solved, thank you

> Date: Mon, 3 Jan 2011 11:30:12 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 659438] Re: Installation/Removal fails because of package which could not be located (faiulre in apt.Cache.required_download)
>
> This bug was fixed in the package aptdaemon - 0.40+bzr529-0ubuntu3
>
> ---------------
> aptdaemon (0.40+bzr529-0ubuntu3) natty; urgency=low
>
> [ Sebastian Heinlein ]
> * debian/patches/09_fix_index_race_659438.patch:
> - If the background cron job rebuilds the apt indexes the
> apt.Cache.required_download method fails, since it tries to access
> the not available indexes. This patch is a workaround since it
> is requires a lock on the indexes before caluclating the size
> (LP: #659438)
> -- Michael Vogt <email address hidden> Mon, 03 Jan 2011 12:26:48 +0100
>
> ** Branch linked: lp:~aptdaemon-developers/aptdaemon/ubuntu-natty
>
> ** Changed in: aptdaemon (Ubuntu)
> Status: Fix Committed => Fix Released
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (691064).
> https://bugs.launchpad.net/bugs/659438
>
> Title:
> Installation/Removal fails because of package which could not be located (faiulre in apt.Cache.required_download)
>
> Status in Aptdaemon:
> Incomplete
> Status in “aptdaemon” package in Ubuntu:
> Fix Released
> Status in “python-apt” package in Ubuntu:
> New
> Status in “aptdaemon” source package in Maverick:
> Fix Committed
> Status in “python-apt” source package in Maverick:
> New
>
> Bug description:
> Traceback (most recent call last):
> File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 768, in simulate
> return self._simulate_helper(trans, status_path)
> File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 936, in _simulate_helper
> return depends, status, self._cache.required_download, \
> File "/usr/lib/python2.6/dist-packages/apt/cache.py", line 218, in required_download
> pm.get_archives(fetcher, self._list, self._records)
> SystemError: E:I wasn't able to locate file for the liblua50 package. This might mean you need to manually fix this package.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/aptdaemon/+bug/659438/+subscribe

This bug was fixed in the package aptdaemon - 0.31+bzr506-0ubuntu5

---------------
aptdaemon (0.31+bzr506-0ubuntu5) maverick-proposed; urgency=low

  * debian/patches/09_fix_index_race_659438.patch:
    - If the background cron job rebuilds the apt indexes the
      apt.Cache.required_download method fails, since it tries to access
      the not available indexes. This patch is a workaround since it
      is requires a lock on the indexes before caluclating the size
      (LP: #659438)
 -- Sebastian Heinlein <email address hidden> Sat, 11 Dec 2010 11:00:50 +0100

Changed in aptdaemon (Ubuntu Maverick):
status: Fix Committed → Fix Released
Changed in aptdaemon (Ubuntu Maverick):
assignee: nobody → pradeep (pradeep197301dec)
Changed in aptdaemon:
assignee: Sebastian Heinlein (glatzor) → pradeep (pradeep197301dec)
status: Incomplete → Fix Released
Changed in aptdaemon:
status: Fix Released → Fix Committed
Robert McKay (mckay) wrote :

Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 769, in simulate
    return self._simulate_helper(trans, status_path)
  File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 948, in _simulate_helper
    return depends, status, self._cache.required_download, \
  File "/usr/lib/python2.6/dist-packages/apt/cache.py", line 218, in required_download
    pm.get_archives(fetcher, self._list, self._records)
SystemError: E:I wasn't able to locate file for the sun-java6-jre package. This might mean you need to manually fix this package.

Installing Java, failed.

Changed in aptdaemon:
status: Fix Committed → Opinion
status: Opinion → Fix Committed
description: updated
Changed in aptdaemon:
status: Fix Committed → Fix Released
Changed in aptdaemon:
assignee: pradeep (pradeep197301dec) → Sebastian Heinlein (glatzor)
status: Fix Released → In Progress

sudo bash
(your password)

apt-get update & & apt-get upgrade

Many thanks, Mr. Conradie. Will enter in terminal when I return home from
work. I'm sure this will fix my Ubuntu lappy.

-M

On Thu, Feb 10, 2011 at 7:51 AM, Johann-jlconradie <
<email address hidden>> wrote:

> sudo bash
> (your password)
>
> apt-get update & & apt-get upgrade
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (695221).
> https://bugs.launchpad.net/bugs/659438
>
> Title:
> Installation/Removal fails because of package which could not be
> located (faiulre in apt.Cache.required_download)
>
> Status in Aptdaemon:
> In Progress
> Status in “aptdaemon” package in Ubuntu:
> Fix Released
> Status in “python-apt” package in Ubuntu:
> New
> Status in “aptdaemon” source package in Maverick:
> Fix Released
> Status in “python-apt” source package in Maverick:
> New
>
> Bug description:
> Traceback (most recent call last):
> File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 768,
> in simulate
> return self._simulate_helper(trans, status_path)
> File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 936,
> in _simulate_helper
> return depends, status, self._cache.required_download, \
> File "/usr/lib/python2.6/dist-packages/apt/cache.py", line 218, in
> required_download
> pm.get_archives(fetcher, self._list, self._records)
> SystemError: E:I wasn't able to locate file for the liblua50 package. This
> might mean you need to manually fix this package.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/aptdaemon/+bug/659438/+subscribe
>

Changed in aptdaemon:
status: In Progress → Fix Committed

thanks for your help
JPDW

On 11/02/11 06:30, javiier portillogordillo wrote:
> ** Changed in: aptdaemon
> Status: In Progress => Fix Committed
>

JP DW (jeanpierre-dewinter) wrote :

Thanks for your help
JPDW

On 11/02/11 06:13, Alex wrote:
> Thank you, Johann-jlconradie, everething works fine!
>

JP DW (jeanpierre-dewinter) wrote :

Thanks for your help
JPDW

On 10/02/11 17:12, Seamus MacGillicuddy wrote:
> Many thanks, Mr. Conradie. Will enter in terminal when I return home from
> work. I'm sure this will fix my Ubuntu lappy.
>
> -M
>
>
>
>
>
> On Thu, Feb 10, 2011 at 7:51 AM, Johann-jlconradie<
> <email address hidden>> wrote:
>
>> sudo bash
>> (your password)
>>
>> apt-get update& & apt-get upgrade
>>
>> --
>> You received this bug notification because you are a direct subscriber
>> of a duplicate bug (695221).
>> https://bugs.launchpad.net/bugs/659438
>>
>> Title:
>> Installation/Removal fails because of package which could not be
>> located (faiulre in apt.Cache.required_download)
>>
>> Status in Aptdaemon:
>> In Progress
>> Status in “aptdaemon” package in Ubuntu:
>> Fix Released
>> Status in “python-apt” package in Ubuntu:
>> New
>> Status in “aptdaemon” source package in Maverick:
>> Fix Released
>> Status in “python-apt” source package in Maverick:
>> New
>>
>> Bug description:
>> Traceback (most recent call last):
>> File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 768,
>> in simulate
>> return self._simulate_helper(trans, status_path)
>> File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 936,
>> in _simulate_helper
>> return depends, status, self._cache.required_download, \
>> File "/usr/lib/python2.6/dist-packages/apt/cache.py", line 218, in
>> required_download
>> pm.get_archives(fetcher, self._list, self._records)
>> SystemError: E:I wasn't able to locate file for the liblua50 package. This
>> might mean you need to manually fix this package.
>>
>> To unsubscribe from this bug, go to:
>> https://bugs.launchpad.net/aptdaemon/+bug/659438/+subscribe
>>

adam jones (tym2liv3) on 2011-02-16
Changed in aptdaemon (Ubuntu Maverick):
assignee: pradeep (pradeep197301dec) → adam jones (tym2liv3)
Changed in aptdaemon:
status: Fix Committed → Fix Released
Changed in aptdaemon (Ubuntu):
status: Fix Released → In Progress
Changed in aptdaemon:
status: Fix Released → In Progress

Think you! I'm sovilded

> Date: Sat, 19 Feb 2011 09:31:44 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 659438] Re: Installation/Removal fails because of package which could not be located (faiulre in apt.Cache.required_download)
>
> ** Changed in: aptdaemon (Ubuntu)
> Status: Fix Released => In Progress
>
> ** Changed in: aptdaemon
> Status: Fix Released => In Progress
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (691064).
> https://bugs.launchpad.net/bugs/659438
>
> Title:
> Installation/Removal fails because of package which could not be
> located (faiulre in apt.Cache.required_download)
>
> Status in Aptdaemon:
> In Progress
> Status in “aptdaemon” package in Ubuntu:
> In Progress
> Status in “python-apt” package in Ubuntu:
> New
> Status in “aptdaemon” source package in Maverick:
> Fix Released
> Status in “python-apt” source package in Maverick:
> New
>
> Bug description:
> Traceback (most recent call last):
> File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 768, in simulate
> return self._simulate_helper(trans, status_path)
> File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 936, in _simulate_helper
> return depends, status, self._cache.required_download, \
> File "/usr/lib/python2.6/dist-packages/apt/cache.py", line 218, in required_download
> pm.get_archives(fetcher, self._list, self._records)
> SystemError: E:I wasn't able to locate file for the liblua50 package. This might mean you need to manually fix this package.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/aptdaemon/+bug/659438/+subscribe

dragon (dragon-hell) on 2011-02-22
Changed in aptdaemon:
status: In Progress → Fix Committed
Changed in aptdaemon (Ubuntu):
status: In Progress → Fix Committed
Changed in aptdaemon (Ubuntu):
status: Fix Committed → In Progress
Changed in aptdaemon:
assignee: Sebastian Heinlein (glatzor) → atul kumar (aatishrocks4778)
Changed in aptdaemon:
status: Fix Committed → Incomplete
Martin Pitt (pitti) on 2011-03-03
Changed in aptdaemon:
status: Incomplete → Fix Committed
assignee: atul kumar (aatishrocks4778) → Sebastian Heinlein (glatzor)
adam jones (tym2liv3) on 2011-03-03
Changed in aptdaemon:
assignee: Sebastian Heinlein (glatzor) → adam jones (tym2liv3)
Martin Pitt (pitti) on 2011-03-03
Changed in aptdaemon:
assignee: adam jones (tym2liv3) → Sebastian Heinlein (glatzor)
Changed in aptdaemon (Ubuntu Maverick):
assignee: adam jones (tym2liv3) → Sebastian Heinlein (glatzor)
Jeremy W (zigblazer) wrote :

This is what fixed my problem;

Sudo apt-get remove
Sudo apt-get update
Sudo apt-get upgrade

Then retry install.

Thanks for the help

Ryan (kuzan-r) on 2011-03-10
Changed in aptdaemon:
status: Fix Committed → Fix Released
summary: Installation/Removal fails because of package which could not be located
- (faiulre in apt.Cache.required_download)
+ (failure in apt.Cache.required_download)
david brooks (odb1958) on 2011-03-17
Changed in aptdaemon (Ubuntu Maverick):
assignee: Sebastian Heinlein (glatzor) → david brooks (odb1958)
Changed in aptdaemon (Ubuntu):
status: In Progress → Fix Released
Changed in aptdaemon (Ubuntu Maverick):
assignee: david brooks (odb1958) → Dmitry Shachnev (mitya57)
assignee: Dmitry Shachnev (mitya57) → nobody
Changed in python-apt (Ubuntu):
status: New → Invalid
description: updated
Changed in aptdaemon (Ubuntu):
status: Fix Released → In Progress
Changed in aptdaemon:
status: Fix Released → In Progress
Changed in aptdaemon (Ubuntu Maverick):
status: Fix Released → In Progress
Changed in apt (Ubuntu):
status: New → Triaged
importance: Undecided → High
Changed in python-apt (Ubuntu Maverick):
status: New → Invalid
tags: removed: verification-done
tags: added: verification-done
Changed in aptdaemon (Ubuntu Maverick):
status: In Progress → Fix Released
devilophio (devipuchi) on 2011-07-17
Changed in aptdaemon:
status: In Progress → Fix Committed
Changed in aptdaemon (Ubuntu):
status: In Progress → Fix Committed
Changed in aptdaemon (Ubuntu):
assignee: nobody → Mohammed Alkhater (hamod1406)
Changed in aptdaemon (Ubuntu):
assignee: Mohammed Alkhater (hamod1406) → Michael Vogt (mvo)
Changed in apt (Ubuntu):
status: Triaged → Confirmed
Changed in apt (Ubuntu Maverick):
status: New → Confirmed
88 comments hidden view all 166 comments

am very new to ubuntu, I migrated from the WINDOWS XP and WINDOWS 7 for the only reason this OS is very fast and has got all that is needed (of-course leaving some unwanted bugs), problem now is there are many a bugs and some codec for the media missing, and , all the patch available are in commands which am not versed with so, is there not any GUI patchs for the Ubuntu OS,

Thanks,
Surya

surcouf (jc4) wrote :
Download full text (3.3 KiB)

Hi Surya

Sorry but I'm in hollydays now , it's why i dont looking my email since times.
Anyway i have the same trouble of you, my problem coming from the packet "customiz...etc.deb" (i dont remember exactly it's name), it was installed when i make a update and stay in the cache and i cant delete it, i try every command from the terminal i can find on the net, ask help but nothing work then after about 10 days i reinstall the OS on my old OS,
When you reinstall, ( don't format) you have a choice to install the new OS on the old one and keep all your config, softs etc... and it control if all your softs is rigth for the OS 11.04 if not it delete it (if you have make a update and you keep all your softs from 10.10) it's a very good option.
It take long time do do this job, for me all the night until afternoon but it do it very well, no problem but make a copy first of all your important things you have on this OS, in case!!!

Ubuntu 11.04 have still some bug somewhere but it's a very good OS with softwares for about everythings, very fast, light, easy to do and all for free...
I hope this info help you, let me know.

Have a good day.

Le 14 août 2011 à 17:24, Suray Prakash N Jha <email address hidden> a écrit :

> am very new to ubuntu, I migrated from the WINDOWS XP and WINDOWS 7 for
> the only reason this OS is very fast and has got all that is needed (of-
> course leaving some unwanted bugs), problem now is there are many a bugs
> and some codec for the media missing, and , all the patch available are
> in commands which am not versed with so, is there not any GUI patchs for
> the Ubuntu OS,
>
> Thanks,
> Surya
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (811081).
> https://bugs.launchpad.net/bugs/659438
>
> Title:
> Installation/Removal fails because of package which could not be
> located (failure in apt.Cache.required_download)
>
> Status in Aptdaemon:
> Fix Committed
> Status in “apt” package in Ubuntu:
> Confirmed
> Status in “aptdaemon” package in Ubuntu:
> Fix Committed
> Status in “python-apt” package in Ubuntu:
> Invalid
> Status in “apt” source package in Maverick:
> Confirmed
> Status in “aptdaemon” source package in Maverick:
> Fix Released
> Status in “python-apt” source package in Maverick:
> Invalid
>
> Bug description:
> Steps to reproduce:
>
> 1. Run apt-get nstall ms-ttcorefonts-installer in a terminal
> 2. Close the terminal window at the EULA question (apt-get/dpkg/debconf) will sting hang in the background and lock the system)
> 3. Reboot
>
>
> Traceback (most recent call last):
> File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 768, in simulate
> return self._simulate_helper(trans, status_path)
> File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 936, in _simulate_helper
> return depends, status, self._cache.required_download, \
> File "/usr/lib/python2.6/dist-packages/apt/cache.py", line 218, in required_download
> pm.get_archives(fetcher, self._list, self._records)
> SystemError: E:I wasn't able to locate file for the liblua50 package. This might mean you need to manually fix th...

Read more...

Steve Langasek (vorlon) on 2011-09-30
Changed in apt (Ubuntu):
status: Confirmed → Triaged
Chowdhury, Helal (helalme) wrote :

Thank you so much!

BR,

________________________________
From: Steve Langasek <email address hidden>
To: <email address hidden>
Sent: Friday, September 30, 2011 2:59 AM
Subject: [Bug 659438] Re: Installation/Removal fails because of package which could not be located (failure in apt.Cache.required_download)

** Changed in: apt (Ubuntu)
      Status: Confirmed => Triaged

--
You received this bug notification because you are subscribed to a
duplicate bug report (830252).
https://bugs.launchpad.net/bugs/659438

Title:
  Installation/Removal fails because of package which could not be
  located (failure in apt.Cache.required_download)

Status in Aptdaemon:
  Fix Committed
Status in “apt” package in Ubuntu:
  Triaged
Status in “aptdaemon” package in Ubuntu:
  Fix Committed
Status in “python-apt” package in Ubuntu:
  Invalid
Status in “apt” source package in Maverick:
  Confirmed
Status in “aptdaemon” source package in Maverick:
  Fix Released
Status in “python-apt” source package in Maverick:
  Invalid

Bug description:
  Steps to reproduce:

  1. Run apt-get nstall ms-ttcorefonts-installer in a terminal
  2. Close the terminal window at the EULA question (apt-get/dpkg/debconf) will sting hang in the background and lock the system)
  3. Reboot

  Traceback (most recent call last):
    File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 768, in simulate
      return self._simulate_helper(trans, status_path)
    File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 936, in _simulate_helper
      return depends, status, self._cache.required_download, \
    File "/usr/lib/python2.6/dist-packages/apt/cache.py", line 218, in required_download
      pm.get_archives(fetcher, self._list, self._records)
  SystemError: E:I wasn't able to locate file for the liblua50 package. This might mean you need to manually fix this package.

To manage notifications about this bug go to:
https://bugs.launchpad.net/aptdaemon/+bug/659438/+subscriptions

1 comments hidden view all 166 comments

> Date: Fri, 30 Sep 2011 05:15:36 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: Re: [Bug 659438] Re: Installation/Removal fails because of package which could not be located (failure in apt.Cache.required_download)
>
> Hi my problem it's been fixed sucefully, nad the reson for thie e-mail is that I allready unsuscribe to this bug but I still resive this mails and I want you to know it once again thank you very much for your atencion

@Irwing Aguilar
If you are experiencing problems unsubscribing from this bug or performing any other action on Launchpad, please ask for help by posting a question at https://answers.launchpad.net/launchpad/+addquestion.

Actually I'm going to put them over into spam...this is ridiculous! (Also
switching to redhat/windows 7/server 2008) - not dealing with this OS
anymore - to buggy, but thanks!
On Oct 23, 2011 6:25 PM, "Eliah Kagan" <email address hidden> wrote:

> @Irwing Aguilar
> If you are experiencing problems unsubscribing from this bug or performing
> any other action on Launchpad, please ask for help by posting a question at
> https://answers.launchpad.net/launchpad/+addquestion.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (746855).
> https://bugs.launchpad.net/bugs/659438
>
> Title:
> Installation/Removal fails because of package which could not be
> located (failure in apt.Cache.required_download)
>
> Status in Aptdaemon:
> Fix Committed
> Status in “apt” package in Ubuntu:
> Triaged
> Status in “aptdaemon” package in Ubuntu:
> Fix Committed
> Status in “python-apt” package in Ubuntu:
> Invalid
> Status in “apt” source package in Maverick:
> Confirmed
> Status in “aptdaemon” source package in Maverick:
> Fix Released
> Status in “python-apt” source package in Maverick:
> Invalid
>
> Bug description:
> Steps to reproduce:
>
> 1. Run apt-get nstall ms-ttcorefonts-installer in a terminal
> 2. Close the terminal window at the EULA question (apt-get/dpkg/debconf)
> will sting hang in the background and lock the system)
> 3. Reboot
>
>
> Traceback (most recent call last):
> File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 768,
> in simulate
> return self._simulate_helper(trans, status_path)
> File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 936,
> in _simulate_helper
> return depends, status, self._cache.required_download, \
> File "/usr/lib/python2.6/dist-packages/apt/cache.py", line 218, in
> required_download
> pm.get_archives(fetcher, self._list, self._records)
> SystemError: E:I wasn't able to locate file for the liblua50 package. This
> might mean you need to manually fix this package.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/aptdaemon/+bug/659438/+subscriptions
>

Actually, what the problem is has to do with launchpad and its failure
to terminate due to resolution. Blaming Ubuntu for launchpad is like
blaming the roadway if a bus hits a pedestrian. I understand your
frustration, but don't blame Ubuntu for it.

John Weintraub
#333-7451 Moffatt Rd.
Richmond BC Canada
V6Y 3W3
<email address hidden>

On 11-10-23 06:11 PM, Michael D Stigers wrote:
> Actually I'm going to put them over into spam...this is ridiculous! (Also
> switching to redhat/windows 7/server 2008) - not dealing with this OS
> anymore - to buggy, but thanks!
> On Oct 23, 2011 6:25 PM, "Eliah Kagan"<email address hidden> wrote:
>
>> @Irwing Aguilar
>> If you are experiencing problems unsubscribing from this bug or performing
>> any other action on Launchpad, please ask for help by posting a question at
>> https://answers.launchpad.net/launchpad/+addquestion.
>>
>> --
>> You received this bug notification because you are subscribed to a
>> duplicate bug report (746855).
>> https://bugs.launchpad.net/bugs/659438
>>
>> Title:
>> Installation/Removal fails because of package which could not be
>> located (failure in apt.Cache.required_download)
>>
>> Status in Aptdaemon:
>> Fix Committed
>> Status in “apt” package in Ubuntu:
>> Triaged
>> Status in “aptdaemon” package in Ubuntu:
>> Fix Committed
>> Status in “python-apt” package in Ubuntu:
>> Invalid
>> Status in “apt” source package in Maverick:
>> Confirmed
>> Status in “aptdaemon” source package in Maverick:
>> Fix Released
>> Status in “python-apt” source package in Maverick:
>> Invalid
>>
>> Bug description:
>> Steps to reproduce:
>>
>> 1. Run apt-get nstall ms-ttcorefonts-installer in a terminal
>> 2. Close the terminal window at the EULA question (apt-get/dpkg/debconf)
>> will sting hang in the background and lock the system)
>> 3. Reboot
>>
>>
>> Traceback (most recent call last):
>> File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 768,
>> in simulate
>> return self._simulate_helper(trans, status_path)
>> File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 936,
>> in _simulate_helper
>> return depends, status, self._cache.required_download, \
>> File "/usr/lib/python2.6/dist-packages/apt/cache.py", line 218, in
>> required_download
>> pm.get_archives(fetcher, self._list, self._records)
>> SystemError: E:I wasn't able to locate file for the liblua50 package. This
>> might mean you need to manually fix this package.
>>
>> To manage notifications about this bug go to:
>> https://bugs.launchpad.net/aptdaemon/+bug/659438/+subscriptions
>>

In addition to being useful for technical support about Launchpad itself, https://answers.launchpad.net/launchpad/+addquestion is also appropriate for reporting problems with Launchpad. If someone posts a question about these problems, they might get solved. (Bugs can be reported against Launchpad itself as well, but it is often a good idea to post a question first; questions tend to get answered rapidly and, for this kind of question, by Canonical employees charged with maintaining, supporting, and developing Launchpad.)

Before posting a question there reporting that Launchpad is not working right, I recommend both browsing and searching at https://answers.launchpad.net/launchpad to see if it's already been posted.

1 comments hidden view all 166 comments
Steve Langasek (vorlon) wrote :

Bug #903269 shows that this issue is still happening in precise. Sebastian, was this thought to be fixed already in aptdaemon? Can you help with this bug?

Changed in aptdaemon (Ubuntu):
status: Fix Committed → Triaged
Brian Murray (brian-murray) wrote :

I've tried recreating this bug on Ubuntu 12.04 using the steps provided in the description regarding the ttf-mscorefonts-installer package and was unsuccessful.

Brian Murray (brian-murray) wrote :

Duplicate bug 903269 has the same error message as this bug but is from a system running 12.04.

Nithin C (nithin-aneesh) wrote :

I having the same bug in 11.10. The bug is not yet fixed.

Brian Murray (brian-murray) wrote :

@nithin_aneesh: Do you have any information about how we can reliablely recreate this bug? Additionally, what version of aptdaemon do you have installed?

Nithin C (nithin-aneesh) wrote :

The error I am experiencing is something different. I am sorry for my previous comment.
The bug I experience is as that if I reject EULA then also the package is marked as installed.

I ran the command sudo apt-get install ttf-mscorefonts-installer and declined the EULA . I have attached the screenshots. I rerun the command but I am getting output "ttf-mscorefonts-installer is already the newest version". But actually it is not installed. It is not taking me to EULA page to accept it. How to fix this?

1. Output of first run of sudo apt-get install ttf-mscorefonts-installer (declined EULA):
>
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
  ttf-mscorefonts-installer
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/34.8 kB of archives.
After this operation, 209 kB of additional disk space will be used.
Preconfiguring packages ...
Selecting previously deselected package ttf-mscorefonts-installer.
(Reading database ... 259348 files and directories currently installed.)
Unpacking ttf-mscorefonts-installer (from .../ttf-mscorefonts-installer_3.3ubuntu4_all.deb) ...
user did not accept the mscorefonts-eula license
Setting up ttf-mscorefonts-installer (3.3ubuntu4) ...
user did not accept the mscorefonts-eula license

2. Output of subsequent run of sudo apt-get install ttf-mscorefonts-installe
>
Reading package lists... Done
Building dependency tree
Reading state information... Done
ttf-mscorefonts-installer is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Nithin C (nithin-aneesh) wrote :

Regarding the version of installed apt:
0.8.16~exp5ubuntu13(oneric)

z03l (rad1tz-z03l) on 2012-04-05
Changed in aptdaemon:
assignee: Sebastian Heinlein (glatzor) → nobody
Changed in apt (Ubuntu):
assignee: nobody → z03l (rad1tz-z03l)
assignee: z03l (rad1tz-z03l) → nobody
Download full text (3.6 KiB)

tanks for the answer,

the pakage ttf-mscorefonts-installer exist, it sems to be installed,
anyway the answer on the the terminal is :

E: Impossible d'obtenir le verrou /var/lib/dpkg/lock - open (11: Ressource
temporairement non disponible)
E: Impossible de verrouiller le répertoire d'administration
(/var/lib/dpkg/). Il est possible qu'un autre processus l'utilise.

with synaptic everything is blocked, because the system want's to execute
all the installations or desinstallation

you have programed. And I can't install or desinstall the pakages with
java,

the same events occurs with the terminal as you can see and the
restauration possibility at the loading system.
 this is the action wanted by the system

gsfonts-x11 (version 0.21) sera mis à niveau vers la version 0.21
sun-java6-bin (version 6.21dlj-0ubuntu1~maverick1~ppa1) sera mis à niveau
vers la version 6.21dlj-0ubuntu1~maverick1~ppa1
sun-java6-jre (version 6.21dlj-0ubuntu1~maverick1~ppa1) sera mis à niveau
vers la version 6.21dlj-0ubuntu1~maverick1~ppa1
sun-java6-plugin (version 6.21dlj-0ubuntu1~maverick1~ppa1) sera mis à
niveau vers la version 6.21dlj-0ubuntu1~maverick1~ppa1

this is the response

E:
/var/cache/apt/archives/sun-java6-jre_6.21dlj-0ubuntu1~maverick1~ppa1_all.deb:
impossible de créer le fichier contenant la liste mise à jour des fichiers
du paquet sun-java6-jre
E:
/var/cache/apt/archives/sun-java6-bin_6.21dlj-0ubuntu1~maverick1~ppa1_i386.deb:
impossible de créer le fichier contenant la liste mise à jour des fichiers
du paquet sun-java6-bin
E: /var/cache/apt/archives/gsfonts-x11_0.21_all.deb: impossible de créer le
fichier contenant la liste mise à jour des fichiers du paquet gsfonts-x11
E:
/var/cache/apt/archives/sun-java6-plugin_6.21dlj-0ubuntu1~maverick1~ppa1_i386.deb:
impossible de créer le fichier contenant la liste mise à jour des fichiers
du paquet sun-java6-plugin

well, tanks for help
Marc

Le 5 avril 2012 05:43, z03l <email address hidden> a écrit :

> ** Changed in: aptdaemon
> Assignee: Sebastian Heinlein (glatzor) => (unassigned)
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (957144).
> https://bugs.launchpad.net/bugs/659438
>
> Title:
> Installation/Removal fails because of package which could not be
> located (failure in apt.Cache.required_download)
>
> Status in Aptdaemon:
> Fix Committed
> Status in “apt” package in Ubuntu:
> Triaged
> Status in “aptdaemon” package in Ubuntu:
> Triaged
> Status in “python-apt” package in Ubuntu:
> Invalid
> Status in “apt” source package in Maverick:
> Confirmed
> Status in “aptdaemon” source package in Maverick:
> Fix Released
> Status in “python-apt” source package in Maverick:
> Invalid
>
> Bug description:
> Steps to reproduce:
>
> 1. Run apt-get nstall ms-ttcorefonts-installer in a terminal
> 2. Close the terminal window at the EULA question (apt-get/dpkg/debconf)
> will sting hang in the background and lock the system)
> 3. Reboot
>
>
> Traceback (most recent call last):
> File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 768,
> in simulate
> return self._simulate_helper(trans, status_path)
> File "/usr/lib/pyth...

Read more...

Changed in aptdaemon:
status: Fix Committed → Incomplete
status: Incomplete → Fix Committed

Sent from my LG phone

Launchpad Bug Tracker <email address hidden> wrote:

>** Branch linked: lp:aptdaemon
>
>--
>You received this bug notification because you are subscribed to a
>duplicate bug report (704229).
>https://bugs.launchpad.net/bugs/659438
>
>Title:
> Installation/Removal fails because of package which could not be
> located (failure in apt.Cache.required_download)
>
>Status in Aptdaemon:
> Fix Committed
>Status in “apt” package in Ubuntu:
> Triaged
>Status in “aptdaemon” package in Ubuntu:
> Triaged
>Status in “python-apt” package in Ubuntu:
> Invalid
>Status in “apt” source package in Maverick:
> Confirmed
>Status in “aptdaemon” source package in Maverick:
> Fix Released
>Status in “python-apt” source package in Maverick:
> Invalid
>
>Bug description:
> Steps to reproduce:
>
> 1. Run apt-get nstall ms-ttcorefonts-installer in a terminal
> 2. Close the terminal window at the EULA question (apt-get/dpkg/debconf) will sting hang in the background and lock the system)
> 3. Reboot
>
>
> Traceback (most recent call last):
>   File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 768, in simulate
>     return self._simulate_helper(trans, status_path)
>   File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 936, in _simulate_helper
>     return depends, status, self._cache.required_download, \
>   File "/usr/lib/python2.6/dist-packages/apt/cache.py", line 218, in required_download
>     pm.get_archives(fetcher, self._list, self._records)
> SystemError: E:I wasn't able to locate file for the liblua50 package. This might mean you need to manually fix this package.
>
>To manage notifications about this bug go to:
>https://bugs.launchpad.net/aptdaemon/+bug/659438/+subscriptions
>

In Precise the issue doesn't appear since there is a race between the
simulate() and the run() method which eats the exception. This race
situation has been fixed in trunk recently that hasn't been uploaded
yet.

Furthermore aptdaemon trunk now catches the exception in the
apt.cache.Cache.required_download call and lets the transaction fail
with an ERROR_INCOMPLETE_INSTALL. So we won't get any bug reports of
this anymore - although the issue isn't fixed on the lower level
(debconf/apt).

Unfortunately software-center doesn't handle the
ERROR_INCOMPLETE_INSTALL correctly yet. It just displays the error
message but doesn't offer to run the FixIncompleteInstall() method of
aptdaemon which would basically run "dpkg --configure -a" and fix the
system.

Additionally the current error message doesn't contain any hind to run
sudo dpkg --configure -a manually.

But it seems to be a first step to resolve the issue. I will try to
create a working patch for s-c in the next days.

ok, noted!

thanks

On 4/8/12 8:34 AM, Sebastian Heinlein wrote:
> In Precise the issue doesn't appear since there is a race between the
> simulate() and the run() method which eats the exception. This race
> situation has been fixed in trunk recently that hasn't been uploaded
> yet.
>
> Furthermore aptdaemon trunk now catches the exception in the
> apt.cache.Cache.required_download call and lets the transaction fail
> with an ERROR_INCOMPLETE_INSTALL. So we won't get any bug reports of
> this anymore - although the issue isn't fixed on the lower level
> (debconf/apt).
>
> Unfortunately software-center doesn't handle the
> ERROR_INCOMPLETE_INSTALL correctly yet. It just displays the error
> message but doesn't offer to run the FixIncompleteInstall() method of
> aptdaemon which would basically run "dpkg --configure -a" and fix the
> system.
>
> Additionally the current error message doesn't contain any hind to run
> sudo dpkg --configure -a manually.
>
> But it seems to be a first step to resolve the issue. I will try to
> create a working patch for s-c in the next days.
>

Nithin C (nithin-aneesh) wrote :

But manual configuration of ddpkg is not solving the problem in Oneric. I tried it but the error persists. Is there anyway to fix this error so that we can use apt to install and uninstall softwares in Oneric?

Am Montag, den 09.04.2012, 15:11 +0000 schrieb nithin_aneesh:
> But manual configuration of ddpkg is not solving the problem in Oneric.
> I tried it but the error persists. Is there anyway to fix this error so
> that we can use apt to install and uninstall softwares in Oneric?

By manual configuration of dpkg you mean executing "sudo dpkg
--configure -a" in a terminal? Just to be sure.

Nithin C (nithin-aneesh) wrote :

Yes I ran "sudo dpkg --configure -a" in a terminal.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package aptdaemon - 0.43+bzr805-0ubuntu1

---------------
aptdaemon (0.43+bzr805-0ubuntu1) precise; urgency=low

  * New upstream snapshot:
    - Fix: Catch a possible exception in apt.cache.Cache.required_download
      which can occur if the user e.g. rebooted the system during a running
      debconf question (fixes LP: #659438)
      Furthermore raise ERROR_INCOMPLETE_INSTALL to signal the client
      that a call of FixIncompleteInstall() (basically a dpkg --configure -a
      call) fixes the issue
    - Fix: Sync all properties of the D-Bus transaction in the client before
      emitting the Finished signal (fixes LP: #747172) to ensure all changed
      properties are available (the order of received signals is not
      guranteed and the finished signal could be received before an error
      signal)
      Additionally raise the timeout before removing a transaction from
      D-Bus on the server side to give clients more time to sync
    - Fix wrong variable names in the download progress (fixes LP: #971839,
      LP: #976521)
    - Fix: Catch a possible pipe reading error (fixes LP: #733090)
    - Fix: Don't show the name of aptdaemon in crash reports
      (fixes LP: #973370)
      Aptdaemon is a system daemon and should work and fail silently
    - Fix: Fallback to a default terminal width of 80 chars (fixes LP: #948588)
      The width request could fail on standard input/output redirections
    - Fix: Don't use a reserved name for the simulate helper function
    - Fix: Convert exceptions to string before raising TransactionFailed()
    - Fix wrong variable name in the add license key failed error message
    - Fix: Don't overwrite the GObject.GObject.disconnect in
      aptdemon.client.Transaction by renaming the method to
      _disconnect_from_dbus()
    - Fix: Allow to cancel a transaction which hasn't been queued yet and
      is still in limbo
    - Fix: Raise NotImplementedError instead of ImplementedError
    - Add a test case for config file changes handling
  * debian/aptdaemon.install:
    - Don't ship the obsolete .desktop file anymore
 -- Sebastian Heinlein <email address hidden> Mon, 09 Apr 2012 20:48:44 +0200

Changed in aptdaemon (Ubuntu):
status: Triaged → Fix Released
Changed in apt (Ubuntu):
status: Triaged → Invalid
Changed in apt (Ubuntu Maverick):
status: Confirmed → Invalid
Sebastian Heinlein (glatzor) wrote :

Am Mittwoch, den 11.04.2012, 15:52 +0000 schrieb Brian Murray:
> ** Changed in: apt (Ubuntu)
> Status: Triaged => Invalid
>
> ** Changed in: apt (Ubuntu Maverick)
> Status: Confirmed => Invalid

Brian, the bug wasn't actually fixed on the apt/debconf level. We just
wrote a some recover functionality for the high level package managers
(s-c and aptd).

Changed in aptdaemon:
status: Fix Committed → Confirmed
status: Confirmed → Fix Committed
Naube (jagada247) wrote :

Thanks for you people.But now i'am not in need of Ubuntu updates because iv changed to windows7.Ubuntu is too much complicated.& it isn't user friendly.every thing
have to do with command.Also basic important applications are not available in Ubuntu or Linux....but windows have.....but keep it up Ubuntu is a beautiful OS.

> Date: Thu, 12 Apr 2012 02:29:16 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 659438] Re: Installation/Removal fails because of package which could not be located (failure in apt.Cache.required_download)
>
> ** Branch linked: lp:ubuntu/software-center
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (829692).
> https://bugs.launchpad.net/bugs/659438
>
> Title:
> Installation/Removal fails because of package which could not be
> located (failure in apt.Cache.required_download)
>
> Status in Aptdaemon:
> Fix Committed
> Status in “apt” package in Ubuntu:
> Invalid
> Status in “aptdaemon” package in Ubuntu:
> Fix Released
> Status in “python-apt” package in Ubuntu:
> Invalid
> Status in “apt” source package in Maverick:
> Invalid
> Status in “aptdaemon” source package in Maverick:
> Fix Released
> Status in “python-apt” source package in Maverick:
> Invalid
>
> Bug description:
> Steps to reproduce:
>
> 1. Run apt-get nstall ms-ttcorefonts-installer in a terminal
> 2. Close the terminal window at the EULA question (apt-get/dpkg/debconf) will sting hang in the background and lock the system)
> 3. Reboot
>
>
> Traceback (most recent call last):
> File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 768, in simulate
> return self._simulate_helper(trans, status_path)
> File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 936, in _simulate_helper
> return depends, status, self._cache.required_download, \
> File "/usr/lib/python2.6/dist-packages/apt/cache.py", line 218, in required_download
> pm.get_archives(fetcher, self._list, self._records)
> SystemError: E:I wasn't able to locate file for the liblua50 package. This might mean you need to manually fix this package.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/aptdaemon/+bug/659438/+subscriptions

pasotango (mpasotango) wrote :
Download full text (4.6 KiB)

It seems to be difficult for everybody, we are blocked, it's possible, it
depens perhaps on many thinks could hapen before the alert, can we remove
or replace a part of the this OS

__en francais : pourrait-on remplacer la partie infirme - malade qui nous
bloque tous, une fois soigné un morceau l'autre suite aux concéquence tombe
malade lui aussi. c'est qui ce passe en medecine, dans le batiment, ou
autre. Quand ça coute trop cher a réparer on remplace par du neuf. Peut on
remplacer une partie ou plus de l' OS
___
Le 16 avril 2012 04:05, Naube <email address hidden> a écrit :

> Thanks for you people.But now i'am not in need of Ubuntu updates because
> iv changed to windows7.Ubuntu is too much complicated.& it isn't user
> friendly.every thing
> have to do with command.Also basic important applications are not
> available in Ubuntu or Linux....but windows have.....but keep it up Ubuntu
> is a beautiful OS.
>
> > Date: Thu, 12 Apr 2012 02:29:16 +0000
> > From: <email address hidden>
> > To: <email address hidden>
> > Subject: [Bug 659438] Re: Installation/Removal fails because of package
> which could not be located (failure in apt.Cache.required_download)
> >
> > ** Branch linked: lp:ubuntu/software-center
> >
> > --
> > You received this bug notification because you are subscribed to a
> > duplicate bug report (829692).
> > https://bugs.launchpad.net/bugs/659438
> >
> > Title:
> > Installation/Removal fails because of package which could not be
> > located (failure in apt.Cache.required_download)
> >
> > Status in Aptdaemon:
> > Fix Committed
> > Status in “apt” package in Ubuntu:
> > Invalid
> > Status in “aptdaemon” package in Ubuntu:
> > Fix Released
> > Status in “python-apt” package in Ubuntu:
> > Invalid
> > Status in “apt” source package in Maverick:
> > Invalid
> > Status in “aptdaemon” source package in Maverick:
> > Fix Released
> > Status in “python-apt” source package in Maverick:
> > Invalid
> >
> > Bug description:
> > Steps to reproduce:
> >
> > 1. Run apt-get nstall ms-ttcorefonts-installer in a terminal
> > 2. Close the terminal window at the EULA question
> (apt-get/dpkg/debconf) will sting hang in the background and lock the
> system)
> > 3. Reboot
> >
> >
> > Traceback (most recent call last):
> > File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line
> 768, in simulate
> > return self._simulate_helper(trans, status_path)
> > File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line
> 936, in _simulate_helper
> > return depends, status, self._cache.required_download, \
> > File "/usr/lib/python2.6/dist-packages/apt/cache.py", line 218, in
> required_download
> > pm.get_archives(fetcher, self._list, self._records)
> > SystemError: E:I wasn't able to locate file for the liblua50 package.
> This might mean you need to manually fix this package.
> >
> > To manage notifications about this bug go to:
> > https://bugs.launchpad.net/aptdaemon/+bug/659438/+subscriptions
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/659438
>
> Title:
> Installation/Removal fails bec...

Read more...

Sebastian Heinlein (glatzor) wrote :

The reason for this bug is a missing call of pkgApplyStatus()
(apt-pkg/algorithms.cc). So we fail if there are packages in the
reqreinst state.

See also lp:~aptdaemon-developers/aptdaemon/fix-cannot-locate-file for a
regression test.

We should add something similar to CacheFile::CheckDeps
(cmdline/apt-get.cc) to apt.cache.Cache

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python-apt - 0.8.3ubuntu7

---------------
python-apt (0.8.3ubuntu7) precise; urgency=low

  [ Michael Vogt ]
  * python/cache.cc:
    - ensure that pkgApplyStatus is called when the cache is opened
      Thanks to Sebastian Heinlein for finding this bug, providing a fix
      and adding a regression test, LP: #659438
 -- Michael Vogt <email address hidden> Wed, 18 Apr 2012 10:26:06 +0200

Changed in python-apt (Ubuntu):
status: Invalid → Fix Released
pasotango (mpasotango) wrote :
Download full text (26.0 KiB)

bgraphite3 » étant manquant, il est considéré qu'aucun fichier du paquet
n'est actuellement installé.

dpkg : avertissement : le fichier contenant la liste des fichiers du paquet
« libgamin0 » étant manquant, il est considéré qu'aucun fichier du paquet
n'est actuellement installé.

dpkg : avertissement : le fichier contenant la liste des fichiers du paquet
« module-init-tools » étant manquant, il est considéré qu'aucun fichier du
paquet n'est actuellement installé.

dpkg : avertissement : le fichier contenant la liste des fichiers du paquet
« libflac8 » étant manquant, il est considéré qu'aucun fichier du paquet
n'est actuellement installé.

dpkg : avertissement : le fichier contenant la liste des fichiers du paquet
« gettext-base » étant manquant, il est considéré qu'aucun fichier du
paquet n'est actuellement installé.

dpkg : avertissement : le fichier contenant la liste des fichiers du paquet
« libvorbisfile3 » étant manquant, il est considéré qu'aucun fichier du
paquet n'est actuellement installé.

dpkg : avertissement : le fichier contenant la liste des fichiers du paquet
« libperl5.10 » étant manquant, il est considéré qu'aucun fichier du paquet
n'est actuellement installé.

dpkg : avertissement : le fichier contenant la liste des fichiers du paquet
« gnome-user-guide » étant manquant, il est considéré qu'aucun fichier du
paquet n'est actuellement installé.

dpkg : avertissement : le fichier contenant la liste des fichiers du paquet
« libdbus-1-3 » étant manquant, il est considéré qu'aucun fichier du paquet
n'est actuellement installé.

dpkg : avertissement : le fichier contenant la liste des fichiers du paquet
« libzvbi-common » étant manquant, il est considéré qu'aucun fichier du
paquet n'est actuellement installé.

dpkg : avertissement : le fichier contenant la liste des fichiers du paquet
« libgmp3c2 » étant manquant, il est considéré qu'aucun fichier du paquet
n'est actuellement installé.

dpkg : avertissement : le fichier contenant la liste des fichiers du paquet
« cups-ppdc » étant manquant, il est considéré qu'aucun fichier du paquet
n'est actuellement installé.

dpkg : avertissement : le fichier contenant la liste des fichiers du paquet
« ssh » étant manquant, il est considéré qu'aucun fichier du paquet n'est
actuellement installé.

dpkg : avertissement : le fichier contenant la liste des fichiers du paquet
« xscreensaver-data » étant manquant, il est considéré qu'aucun fichier du
paquet n'est actuellement installé.

dpkg : avertissement : le fichier contenant la liste des fichiers du paquet
« desktop-file-utils » étant manquant, il est considéré qu'aucun fichier du
paquet n'est actuellement installé.

dpkg : avertissement : le fichier contenant la liste des fichiers du paquet
« example-content » étant manquant, il est considéré qu'aucun fichier du
paquet n'est actuellement installé.

dpkg : avertissement : le fichier contenant la liste des fichiers du paquet
« gpgv » étant manquant, il est considéré qu'aucun fichier du paquet n'est
actuellement installé.

dpkg : avertissement : le fichier contenant la liste des fichiers du paquet
« linux-headers-2.6.35-31-generic » étant manquant, il est considéré
qu'aucun fichier du paquet n'...

1 comments hidden view all 166 comments
Victor Costan (costan) wrote :

#160 is spam, please remove and block the user.

because of this now i feel i regained control of my life http://www.cnbc32.com/ talk to you later

Robert McKay (mckay) wrote :

my wife is very proud of me and what I've accomplished in such a short time http://www.cnbc37.com/ ttyl

Hi!
j'ai toujours ces grefons qui sont en conflicts entre eux :
 gsfonts-x11 libc-bin libc-dev-bin libc6 libc6-dev
sun-java6-bin sun-java6-fonts sun-java6-jre sun-java-plugin
Il semblerait qu'il y ait un conflict avec aptdaemon
qui bloquent sur synaptic. mais on ne peut ni désintaller ni reparer
aucun grefon sans que les autres qui sont associés soient suprimés
qui d'ailleurs bloquent tout. imposible de réparer, désinstaller quoi
que ce soit.
Ne serait pas plus simple d'installer une nouvelle version d'ubuntu en
partionnant ?
Ce W.E. le GP F1 supporter le bruit ! j'habite à 50 mètres du circuit,
mais je n'entends que le bruit.
Merci pour tout
Marc Ponziani

In English please.

2012/5/24 pasotango <email address hidden>:
> Hi!
> j'ai toujours ces grefons qui sont en conflicts entre eux :
>  gsfonts-x11     libc-bin     libc-dev-bin     libc6    libc6-dev
> sun-java6-bin   sun-java6-fonts      sun-java6-jre     sun-java-plugin
> Il semblerait qu'il y ait un conflict avec aptdaemon
> qui  bloquent sur synaptic.  mais on ne peut ni désintaller ni reparer
> aucun grefon sans que les autres qui sont associés soient suprimés
> qui d'ailleurs bloquent tout.   imposible  de réparer, désinstaller quoi
> que ce soit.
> Ne serait pas plus simple d'installer une nouvelle version d'ubuntu  en
> partionnant ?
> Ce  W.E. le GP F1 supporter le bruit ! j'habite à 50 mètres du circuit,
> mais je n'entends que le bruit.
> Merci pour tout
> Marc Ponziani
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (945777).
> https://bugs.launchpad.net/bugs/659438
>
> Title:
>  Installation/Removal fails because of package which could not be
>  located (failure in apt.Cache.required_download)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/aptdaemon/+bug/659438/+subscriptions

surcouf (jc4) wrote :

Yes, if is not matter for you just reinstall with the last version,
Don't forget to save your personal stuff.
Bye

Envoyé de mon iPhone

Le 24 mai 2012 à 20:31, Nicholas Shatokhin <email address hidden> a écrit :

> In English please.
>
> 2012/5/24 pasotango <email address hidden>:
>> Hi!
>> j'ai toujours ces grefons qui sont en conflicts entre eux :
>> gsfonts-x11 libc-bin libc-dev-bin libc6 libc6-dev
>> sun-java6-bin sun-java6-fonts sun-java6-jre sun-java-plugin
>> Il semblerait qu'il y ait un conflict avec aptdaemon
>> qui bloquent sur synaptic. mais on ne peut ni désintaller ni reparer
>> aucun grefon sans que les autres qui sont associés soient suprimés
>> qui d'ailleurs bloquent tout. imposible de réparer, désinstaller quoi
>> que ce soit.
>> Ne serait pas plus simple d'installer une nouvelle version d'ubuntu en
>> partionnant ?
>> Ce W.E. le GP F1 supporter le bruit ! j'habite à 50 mètres du circuit,
>> mais je n'entends que le bruit.
>> Merci pour tout
>> Marc Ponziani
>>
>> --
>> You received this bug notification because you are subscribed to a
>> duplicate bug report (945777).
>> https://bugs.launchpad.net/bugs/659438
>>
>> Title:
>> Installation/Removal fails because of package which could not be
>> located (failure in apt.Cache.required_download)
>>
>> To manage notifications about this bug go to:
>> https://bugs.launchpad.net/aptdaemon/+bug/659438/+subscriptions
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (811081).
> https://bugs.launchpad.net/bugs/659438
>
> Title:
> Installation/Removal fails because of package which could not be
> located (failure in apt.Cache.required_download)
>
> Status in Aptdaemon:
> Fix Committed
> Status in “apt” package in Ubuntu:
> Invalid
> Status in “aptdaemon” package in Ubuntu:
> Fix Released
> Status in “python-apt” package in Ubuntu:
> Fix Released
> Status in “apt” source package in Maverick:
> Invalid
> Status in “aptdaemon” source package in Maverick:
> Fix Released
> Status in “python-apt” source package in Maverick:
> Invalid
>
> Bug description:
> Steps to reproduce:
>
> 1. Run apt-get nstall ms-ttcorefonts-installer in a terminal
> 2. Close the terminal window at the EULA question (apt-get/dpkg/debconf) will sting hang in the background and lock the system)
> 3. Reboot
>
>
> Traceback (most recent call last):
> File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 768, in simulate
> return self._simulate_helper(trans, status_path)
> File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 936, in _simulate_helper
> return depends, status, self._cache.required_download, \
> File "/usr/lib/python2.6/dist-packages/apt/cache.py", line 218, in required_download
> pm.get_archives(fetcher, self._list, self._records)
> SystemError: E:I wasn't able to locate file for the liblua50 package. This might mean you need to manually fix this package.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/aptdaemon/+bug/659438/+subscriptions

Displaying first 40 and last 40 comments. View all 166 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions