NoAccessToken: SD crashes when no access token found

Bug #488413 reported by Facundo Batista on 2009-11-25
This bug affects 350 people
Affects Status Importance Assigned to Milestone
Ubuntu One Client
High
Guillermo Gonzalez
ubuntuone-client (Ubuntu)
High
dobey
Karmic
Undecided
Unassigned

Bug Description

For Karmic users this bug is currently in proposed Karmic updates, which you can install by following this FAQ: https://answers.edge.launchpad.net/ubuntuone-client/+faq/930

For Jaunty users, his bug is released (rev 288) in the Ubuntu One beta PPA.

Sometimes the SD is started but the user hasn't the necessary auth information yet. Right now, it crashes:

2009-10-24 09:53:32,606 - ubuntuone.SyncDaemon.DBus - ERROR - Can't get the auth token
Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/ubuntuone/syncdaemon/dbus_interface.py", line 1053, in connect
    access_token = self.main.get_access_token()
  File "/usr/lib/python2.6/dist-packages/ubuntuone/syncdaemon/main.py", line 286, in get_access_token
    return self.oauth_client.get_access_token()
  File "/usr/lib/python2.6/dist-packages/ubuntuone/syncdaemon/main.py", line 326, in get_access_token
    raise NoAccessToken("No access token found.")
NoAccessToken: No access token found.

What we should do is to alert the applet somehow that we've been started without the user having the proper auth info, and quit.

To reproduce: delete the existing access token from the keyring with the client stopped, then start the client. It should go through the authorization process and not die.

Related branches

Changed in ubuntuone-client:
status: Triaged → In Progress
assignee: nobody → Guillermo Gonzalez (verterok)
tags: added: no-access-token
Changed in ubuntuone-client:
status: In Progress → Fix Committed
dobey (dobey) on 2009-12-09
Changed in ubuntuone-client (Ubuntu):
assignee: nobody → Rodney Dawes (dobey)
importance: Undecided → High
status: New → In Progress
dobey (dobey) on 2009-12-09
tags: added: ubuntuone-sru
summary: - SD crashes when no token found
+ NoAccessToken: SD crashes when no access token found
description: updated

Accepted ubuntuone-client into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in ubuntuone-client (Ubuntu Karmic):
status: New → Fix Committed
tags: added: verification-needed

This seems to work ok for me now.

Thanks

  Morg

Martin Pitt (pitti) on 2009-12-22
tags: added: verification-done
removed: verification-needed

Yes it's work good...

Thank you

Franck

Piotr Morgwai Kotarbiński a écrit :
> This seems to work ok for me now.
>
> Thanks
>
> Morg
>
>

Fessor (michaelbastholm) wrote :

It also seems to work for me. Thanks

description: updated
Szebenyi Bálint (szebenyib) wrote :

It was all working fine, but one of last week's update just turned it upside down. I updated it today as written at the top of the page, however the problem still exists. In the bug report there is no access token bug now, nothing in the bug report but it still won't connect and the red 'x' remains present over the icon. If I can help you with any other information let me know and I'll be glad to help.

Rick McBride (rmcbride) wrote :

This is working correctly with the current karmic-proposed version

description: updated
Szebenyi Bálint (szebenyib) wrote :

Ohh the last two rows were there last time as well? Now it's working with the proposed version!
This one helped as well:
http://notroswell.com/etcetera/etceterakarmic/
Thank you all!

description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client - 1.0.3-0ubuntu1

---------------
ubuntuone-client (1.0.3-0ubuntu1) karmic-proposed; urgency=high

  * New upstream release
    - Remove patch files now in upstream for #462828
    - Require python-ubuntuone-storageprotocol >= 1.0.1
    - BadTransition: SYS_CONNECTION_MADE (LP: #457147)
    - ValueError: invalid literal for int() with base 10: 'None' (LP: #476777)
    - Protocol version error with bw throttling enabled (LP: #455544)
    - Folder deletion from other machines results in conflicts (LP: #462003)
    - Syncdaemon doesn't disable throttling (LP: #483592)
    - Syncdaemon crashes with NoAccessToken (LP: #488413)
    - Error creating share from Nautilus: callback() (LP: #492100)
    - Work without NetworkManager installed (LP: #357395)
    - Create a POT during the build (LP: #455527)
    - Bring back timestamps in oauth-login.log (LP: #459175)
    - Applet starts syncdaemon without a token (LP: #491573)
    - Prefs changes don't take immediate affect (LP: #457564)
    - BW limit settings don't appear to be saved (LP: #465030)
    - Distinguish auth errors from other errors (LP: #450633)
    - Fix for running on python < 2.6.3 (LP: #451670)
 -- Rodney Dawes <email address hidden> Fri, 11 Dec 2009 15:45:52 -0500

Changed in ubuntuone-client (Ubuntu Karmic):
status: Fix Committed → Fix Released
dobey (dobey) on 2010-02-18
Changed in ubuntuone-client (Ubuntu):
status: In Progress → Fix Released
Changed in ubuntuone-client:
status: Fix Committed → Fix Released

now working good.
Thanks

On 18 de fevereiro de 2010 13:09, Rodney Dawes
<email address hidden>wrote:

> ** Changed in: ubuntuone-client (Ubuntu)
> Status: In Progress => Fix Released
>
> ** Changed in: ubuntuone-client
> Status: Fix Committed => Fix Released
>
> --
> NoAccessToken: SD crashes when no access token found
> https://bugs.launchpad.net/bugs/488413
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in Ubuntu One Client: Fix Released
> Status in “ubuntuone-client” package in Ubuntu: Fix Released
> Status in “ubuntuone-client” source package in Karmic: Fix Released
>
> Bug description:
> For Karmic users this bug is currently in proposed Karmic updates, which
> you can install by following this FAQ:
> https://answers.edge.launchpad.net/ubuntuone-client/+faq/930
>
> For Jaunty users, his bug is released (rev 288) in the Ubuntu One beta PPA.
>
> Sometimes the SD is started but the user hasn't the necessary auth
> information yet. Right now, it crashes:
>
> 2009-10-24 09:53:32,606 - ubuntuone.SyncDaemon.DBus - ERROR - Can't get the
> auth token
> Traceback (most recent call last):
> File
> "/usr/lib/python2.6/dist-packages/ubuntuone/syncdaemon/dbus_interface.py",
> line 1053, in connect
> access_token = self.main.get_access_token()
> File "/usr/lib/python2.6/dist-packages/ubuntuone/syncdaemon/main.py",
> line 286, in get_access_token
> return self.oauth_client.get_access_token()
> File "/usr/lib/python2.6/dist-packages/ubuntuone/syncdaemon/main.py",
> line 326, in get_access_token
> raise NoAccessToken("No access token found.")
> NoAccessToken: No access token found.
>
> What we should do is to alert the applet somehow that we've been started
> without the user having the proper auth info, and quit.
>
> To reproduce: delete the existing access token from the keyring with the
> client stopped, then start the client. It should go through the
> authorization process and not die.
>
>
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntuone-client/+bug/488413/+subscribe
>

--

Robson Franklin Vieira Silva

Download full text (4.2 KiB)

I am using the beta repositories for ubuntuone and I do not see an upgrade
for the last 15 days.

Is that correct?

Regards,

Mariano

2010/2/18 Robson <email address hidden>

> now working good.
> Thanks
>
> On 18 de fevereiro de 2010 13:09, Rodney Dawes
> <email address hidden>wrote:
>
> > ** Changed in: ubuntuone-client (Ubuntu)
> > Status: In Progress => Fix Released
> >
> > ** Changed in: ubuntuone-client
> > Status: Fix Committed => Fix Released
> >
> > --
> > NoAccessToken: SD crashes when no access token found
> > https://bugs.launchpad.net/bugs/488413
> > You received this bug notification because you are a direct subscriber
> > of a duplicate bug.
> >
> > Status in Ubuntu One Client: Fix Released
> > Status in “ubuntuone-client” package in Ubuntu: Fix Released
> > Status in “ubuntuone-client” source package in Karmic: Fix Released
> >
> > Bug description:
> > For Karmic users this bug is currently in proposed Karmic updates, which
> > you can install by following this FAQ:
> > https://answers.edge.launchpad.net/ubuntuone-client/+faq/930
> >
> > For Jaunty users, his bug is released (rev 288) in the Ubuntu One beta
> PPA.
> >
> > Sometimes the SD is started but the user hasn't the necessary auth
> > information yet. Right now, it crashes:
> >
> > 2009-10-24 09:53:32,606 - ubuntuone.SyncDaemon.DBus - ERROR - Can't get
> the
> > auth token
> > Traceback (most recent call last):
> > File
> >
> "/usr/lib/python2.6/dist-packages/ubuntuone/syncdaemon/dbus_interface.py",
> > line 1053, in connect
> > access_token = self.main.get_access_token()
> > File "/usr/lib/python2.6/dist-packages/ubuntuone/syncdaemon/main.py",
> > line 286, in get_access_token
> > return self.oauth_client.get_access_token()
> > File "/usr/lib/python2.6/dist-packages/ubuntuone/syncdaemon/main.py",
> > line 326, in get_access_token
> > raise NoAccessToken("No access token found.")
> > NoAccessToken: No access token found.
> >
> > What we should do is to alert the applet somehow that we've been started
> > without the user having the proper auth info, and quit.
> >
> > To reproduce: delete the existing access token from the keyring with the
> > client stopped, then start the client. It should go through the
> > authorization process and not die.
> >
> >
> >
> > To unsubscribe from this bug, go to:
> > https://bugs.launchpad.net/ubuntuone-client/+bug/488413/+subscribe
> >
>
>
> --
>
> Robson Franklin Vieira Silva
>
> --
> NoAccessToken: SD crashes when no access token found
> https://bugs.launchpad.net/bugs/488413
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in Ubuntu One Client: Fix Released
> Status in “ubuntuone-client” package in Ubuntu: Fix Released
> Status in “ubuntuone-client” source package in Karmic: Fix Released
>
> Bug description:
> For Karmic users this bug is currently in proposed Karmic updates, which
> you can install by following this FAQ:
> https://answers.edge.launchpad.net/ubuntuone-client/+faq/930
>
> For Jaunty users, his bug is released (rev 288) in the Ubuntu One beta PPA.
>
> Sometimes the SD is started but the user hasn't the necessary auth
> in...

Read more...

Ghennadi (mail2gena) wrote :
Download full text (6.6 KiB)

Hi Mariano ...

You can try console command

*sudo apt-get update* - to update your repository info
*sudo apt-get upgrade* - to upgrade your current applications ...
--

Best Regards
Ghennadi

"Think Green - Please do not print this email unless you really need to"

On Fri, Feb 19, 2010 at 1:31 AM, Mariano Cabrera
<email address hidden>wrote:

> I am using the beta repositories for ubuntuone and I do not see an upgrade
> for the last 15 days.
>
> Is that correct?
>
> Regards,
>
> Mariano
>
> 2010/2/18 Robson <email address hidden>
>
> > now working good.
> > Thanks
> >
> > On 18 de fevereiro de 2010 13:09, Rodney Dawes
> > <email address hidden>wrote:
> >
> > > ** Changed in: ubuntuone-client (Ubuntu)
> > > Status: In Progress => Fix Released
> > >
> > > ** Changed in: ubuntuone-client
> > > Status: Fix Committed => Fix Released
> > >
> > > --
> > > NoAccessToken: SD crashes when no access token found
> > > https://bugs.launchpad.net/bugs/488413
> > > You received this bug notification because you are a direct subscriber
> > > of a duplicate bug.
> > >
> > > Status in Ubuntu One Client: Fix Released
> > > Status in “ubuntuone-client” package in Ubuntu: Fix Released
> > > Status in “ubuntuone-client” source package in Karmic: Fix Released
> > >
> > > Bug description:
> > > For Karmic users this bug is currently in proposed Karmic updates,
> which
> > > you can install by following this FAQ:
> > > https://answers.edge.launchpad.net/ubuntuone-client/+faq/930
> > >
> > > For Jaunty users, his bug is released (rev 288) in the Ubuntu One beta
> > PPA.
> > >
> > > Sometimes the SD is started but the user hasn't the necessary auth
> > > information yet. Right now, it crashes:
> > >
> > > 2009-10-24 09:53:32,606 - ubuntuone.SyncDaemon.DBus - ERROR - Can't get
> > the
> > > auth token
> > > Traceback (most recent call last):
> > > File
> > >
> >
> "/usr/lib/python2.6/dist-packages/ubuntuone/syncdaemon/dbus_interface.py",
> > > line 1053, in connect
> > > access_token = self.main.get_access_token()
> > > File "/usr/lib/python2.6/dist-packages/ubuntuone/syncdaemon/main.py",
> > > line 286, in get_access_token
> > > return self.oauth_client.get_access_token()
> > > File "/usr/lib/python2.6/dist-packages/ubuntuone/syncdaemon/main.py",
> > > line 326, in get_access_token
> > > raise NoAccessToken("No access token found.")
> > > NoAccessToken: No access token found.
> > >
> > > What we should do is to alert the applet somehow that we've been
> started
> > > without the user having the proper auth info, and quit.
> > >
> > > To reproduce: delete the existing access token from the keyring with
> the
> > > client stopped, then start the client. It should go through the
> > > authorization process and not die.
> > >
> > >
> > >
> > > To unsubscribe from this bug, go to:
> > > https://bugs.launchpad.net/ubuntuone-client/+bug/488413/+subscribe
> > >
> >
> >
> > --
> >
> > Robson Franklin Vieira Silva
> >
> > --
> > NoAccessToken: SD crashes when no access token found
> > https://bugs.launchpad.net/bugs/488413
> > You received this bug notification because you are a direct subscriber
> > of a duplicate bug.
> >
> > St...

Read more...

Download full text (4.5 KiB)

vous allez arreter de me harceler avec votre fichu bug !

Please stop to send me such email....

Mariano Cabrera a écrit :
> I am using the beta repositories for ubuntuone and I do not see an upgrade
> for the last 15 days.
>
> Is that correct?
>
> Regards,
>
> Mariano
>
> 2010/2/18 Robson <email address hidden>
>
>
>> now working good.
>> Thanks
>>
>> On 18 de fevereiro de 2010 13:09, Rodney Dawes
>> <email address hidden>wrote:
>>
>>
>>> ** Changed in: ubuntuone-client (Ubuntu)
>>> Status: In Progress => Fix Released
>>>
>>> ** Changed in: ubuntuone-client
>>> Status: Fix Committed => Fix Released
>>>
>>> --
>>> NoAccessToken: SD crashes when no access token found
>>> https://bugs.launchpad.net/bugs/488413
>>> You received this bug notification because you are a direct subscriber
>>> of a duplicate bug.
>>>
>>> Status in Ubuntu One Client: Fix Released
>>> Status in “ubuntuone-client” package in Ubuntu: Fix Released
>>> Status in “ubuntuone-client” source package in Karmic: Fix Released
>>>
>>> Bug description:
>>> For Karmic users this bug is currently in proposed Karmic updates, which
>>> you can install by following this FAQ:
>>> https://answers.edge.launchpad.net/ubuntuone-client/+faq/930
>>>
>>> For Jaunty users, his bug is released (rev 288) in the Ubuntu One beta
>>>
>> PPA.
>>
>>> Sometimes the SD is started but the user hasn't the necessary auth
>>> information yet. Right now, it crashes:
>>>
>>> 2009-10-24 09:53:32,606 - ubuntuone.SyncDaemon.DBus - ERROR - Can't get
>>>
>> the
>>
>>> auth token
>>> Traceback (most recent call last):
>>> File
>>>
>>>
>> "/usr/lib/python2.6/dist-packages/ubuntuone/syncdaemon/dbus_interface.py",
>>
>>> line 1053, in connect
>>> access_token = self.main.get_access_token()
>>> File "/usr/lib/python2.6/dist-packages/ubuntuone/syncdaemon/main.py",
>>> line 286, in get_access_token
>>> return self.oauth_client.get_access_token()
>>> File "/usr/lib/python2.6/dist-packages/ubuntuone/syncdaemon/main.py",
>>> line 326, in get_access_token
>>> raise NoAccessToken("No access token found.")
>>> NoAccessToken: No access token found.
>>>
>>> What we should do is to alert the applet somehow that we've been started
>>> without the user having the proper auth info, and quit.
>>>
>>> To reproduce: delete the existing access token from the keyring with the
>>> client stopped, then start the client. It should go through the
>>> authorization process and not die.
>>>
>>>
>>>
>>> To unsubscribe from this bug, go to:
>>> https://bugs.launchpad.net/ubuntuone-client/+bug/488413/+subscribe
>>>
>>>
>> --
>>
>> Robson Franklin Vieira Silva
>>
>> --
>> NoAccessToken: SD crashes when no access token found
>> https://bugs.launchpad.net/bugs/488413
>> You received this bug notification because you are a direct subscriber
>> of a duplicate bug.
>>
>> Status in Ubuntu One Client: Fix Released
>> Status in “ubuntuone-client” package in Ubuntu: Fix Released
>> Status in “ubuntuone-client” source package in Karmic: Fix Released
>>
>> Bug description:
>> For Karmic users this bug is currently in proposed Karmic updates, which
>> you can install...

Read more...

zzamal (franck-lavarini) wrote :
Download full text (7.0 KiB)

vous allez arreter de me harceler avec votre fichu bug !

Please stop to send me such email....

Ghennadi a écrit :
> Hi Mariano ...
>
> You can try console command
>
> *sudo apt-get update* - to update your repository info
> *sudo apt-get upgrade* - to upgrade your current applications ...
> --
>
> Best Regards
> Ghennadi
>
>
> "Think Green - Please do not print this email unless you really need to"
>
>
> On Fri, Feb 19, 2010 at 1:31 AM, Mariano Cabrera
> <email address hidden>wrote:
>
>
>> I am using the beta repositories for ubuntuone and I do not see an upgrade
>> for the last 15 days.
>>
>> Is that correct?
>>
>> Regards,
>>
>> Mariano
>>
>> 2010/2/18 Robson <email address hidden>
>>
>>
>>> now working good.
>>> Thanks
>>>
>>> On 18 de fevereiro de 2010 13:09, Rodney Dawes
>>> <email address hidden>wrote:
>>>
>>>
>>>> ** Changed in: ubuntuone-client (Ubuntu)
>>>> Status: In Progress => Fix Released
>>>>
>>>> ** Changed in: ubuntuone-client
>>>> Status: Fix Committed => Fix Released
>>>>
>>>> --
>>>> NoAccessToken: SD crashes when no access token found
>>>> https://bugs.launchpad.net/bugs/488413
>>>> You received this bug notification because you are a direct subscriber
>>>> of a duplicate bug.
>>>>
>>>> Status in Ubuntu One Client: Fix Released
>>>> Status in “ubuntuone-client” package in Ubuntu: Fix Released
>>>> Status in “ubuntuone-client” source package in Karmic: Fix Released
>>>>
>>>> Bug description:
>>>> For Karmic users this bug is currently in proposed Karmic updates,
>>>>
>> which
>>
>>>> you can install by following this FAQ:
>>>> https://answers.edge.launchpad.net/ubuntuone-client/+faq/930
>>>>
>>>> For Jaunty users, his bug is released (rev 288) in the Ubuntu One beta
>>>>
>>> PPA.
>>>
>>>> Sometimes the SD is started but the user hasn't the necessary auth
>>>> information yet. Right now, it crashes:
>>>>
>>>> 2009-10-24 09:53:32,606 - ubuntuone.SyncDaemon.DBus - ERROR - Can't get
>>>>
>>> the
>>>
>>>> auth token
>>>> Traceback (most recent call last):
>>>> File
>>>>
>>>>
>> "/usr/lib/python2.6/dist-packages/ubuntuone/syncdaemon/dbus_interface.py",
>>
>>>> line 1053, in connect
>>>> access_token = self.main.get_access_token()
>>>> File "/usr/lib/python2.6/dist-packages/ubuntuone/syncdaemon/main.py",
>>>> line 286, in get_access_token
>>>> return self.oauth_client.get_access_token()
>>>> File "/usr/lib/python2.6/dist-packages/ubuntuone/syncdaemon/main.py",
>>>> line 326, in get_access_token
>>>> raise NoAccessToken("No access token found.")
>>>> NoAccessToken: No access token found.
>>>>
>>>> What we should do is to alert the applet somehow that we've been
>>>>
>> started
>>
>>>> without the user having the proper auth info, and quit.
>>>>
>>>> To reproduce: delete the existing access token from the keyring with
>>>>
>> the
>>
>>>> client stopped, then start the client. It should go through the
>>>> authorization process and not die.
>>>>
>>>>
>>>>
>>>> To unsubscribe from this bug, go to:
>>>> https://bugs.launchpad.net/ubuntuone-client/+bug/488413/+subscribe
>>>>
>>>> ...

Read more...

zzamal (franck-lavarini) wrote :

vous allez arreter de me harceler avec votre fichu bug !

Please stop to send me such email....

Launchpad Bug Tracker a écrit :
> This bug was fixed in the package ubuntuone-client - 1.0.3-0ubuntu1
>
> ---------------
> ubuntuone-client (1.0.3-0ubuntu1) karmic-proposed; urgency=high
>
> * New upstream release
> - Remove patch files now in upstream for #462828
> - Require python-ubuntuone-storageprotocol >= 1.0.1
> - BadTransition: SYS_CONNECTION_MADE (LP: #457147)
> - ValueError: invalid literal for int() with base 10: 'None' (LP: #476777)
> - Protocol version error with bw throttling enabled (LP: #455544)
> - Folder deletion from other machines results in conflicts (LP: #462003)
> - Syncdaemon doesn't disable throttling (LP: #483592)
> - Syncdaemon crashes with NoAccessToken (LP: #488413)
> - Error creating share from Nautilus: callback() (LP: #492100)
> - Work without NetworkManager installed (LP: #357395)
> - Create a POT during the build (LP: #455527)
> - Bring back timestamps in oauth-login.log (LP: #459175)
> - Applet starts syncdaemon without a token (LP: #491573)
> - Prefs changes don't take immediate affect (LP: #457564)
> - BW limit settings don't appear to be saved (LP: #465030)
> - Distinguish auth errors from other errors (LP: #450633)
> - Fix for running on python < 2.6.3 (LP: #451670)
> -- Rodney Dawes <email address hidden> Fri, 11 Dec 2009 15:45:52 -0500
>
> ** Changed in: ubuntuone-client (Ubuntu Karmic)
> Status: Fix Committed => Fix Released
>
>

zzamal (franck-lavarini) wrote :

vous allez arreter de me harceler avec votre fichu bug !

Please stop to send me such email....

Rodney Dawes a écrit :
> ** Changed in: ubuntuone-client (Ubuntu)
> Status: In Progress => Fix Released
>
> ** Changed in: ubuntuone-client
> Status: Fix Committed => Fix Released
>
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers