should warn at partitioning stage if /boot is on XFS

Bug #47848 reported by Xirtam
922
This bug affects 6 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Medium
Colin Watson

Bug Description

I downloaded Kubuntu 6.06 Dapper Drake final today and tried a clean install on my laptop.
The Live-system successfully loaded KDE so I tried to install it using the "Install" icon on the desktop.
I chose to set the partitions manually with the integrated qtparted (swap, root xfs, home xfs) and after that the installer copied the neccessary data. But before finishing the installation the installer crashed.
I could reproduce the crash by using the smae options again.

The crash did not occur when I changed two things: I activated the wireless LAN so the installer could download some packages and I changed the fs type from xfs to ext3

I checked if the CD was corrupt, but it is not.

Revision history for this message
Colin Watson (cjwatson) wrote :

Yes, you cannot use an XFS root filesystem reliably with grub unless you create a non-XFS /boot filesystem. We should warn about this at the partitioning stage rather than crashing later.

Revision history for this message
spiritraveller (spiritraveller) wrote :

My install also crashed when using XFS as the root filesystem and not having a separate /boot partition.

The crash occurs at the "Configuring boot loader..." stage.

Traceback (most recent call last):
  File "/usr/bin/ubiquity", line 130, in ?
    install(sys.argv[1])
  File "/usr/bin/ubiquity", line 55, in install
    ret = wizard.run()
  File "/usr/lib/python2.4/site-packages/ubiquity/frontend/gtkui.py", line 266, in run
    self.process_step()
  File "/usr/lib/python2.4/site-packages/ubiquity/frontend/gtkui.py", line 741, in process_step
    self.mountpoints_to_summary()
  File "/usr/lib/python2.4/site-packages/ubiquity/frontend/gtkui.py", line 1029, in mountpoints_to_summary
    self.progress_loop()
  File "/usr/lib/python2.4/site-packages/ubiquity/frontend/gtkui.py", line 538, in progress_loop
    raise RuntimeError, ("Install failed with exit code %s; see "
RuntimeError: Install failed with exit code 1; see /var/log/installer/syslog and /var/log/syslog

Revision history for this message
spiritraveller (spiritraveller) wrote : /var/log/installer/syslog

files that the crash notiifier requested I attach...

Revision history for this message
spiritraveller (spiritraveller) wrote : /var/log/syslog

/var/log/syslog

Revision history for this message
spiritraveller (spiritraveller) wrote :

/var/log/syslog

Revision history for this message
spiritraveller (spiritraveller) wrote : /var/log/partman

/var/log/partman

Revision history for this message
Manuel López-Ibáñez (manuellopezibanez) wrote :

This was showing up on my Unconfirmed results. I hope you don't mind I mark it as confirmed.

Changed in ubiquity:
status: Unconfirmed → Confirmed
Revision history for this message
Phil Miller (ubuntu-millenix) wrote :

It looks like bug #49178 has a lot of people experiencing this crash. It is also marked as Critical, while this is only Medium. Now that I know the exact cause, it will be much easier to avoid this.

Revision history for this message
NiceDay (ndo) wrote : Everything could have been so easy...

...if the installer would check if I like to use an XFS-FS as / or not. If I want to have XFS on / then, try to use lilo instead of grub.
I really do not know why they didn't integrate such kind of checking or even let the user choose a bootmanager...

Revision history for this message
Phil Miller (ubuntu-millenix) wrote :

NiceDay:
Switching bootloader under conditions that would be fairly opaque to the user would be a pain to support. Giving users the choice (at least in the non-expert modes) means asking a deeply technical question of users who shouldn't have to care. It also means supporting lilo as a bootloader for default installations. Checking wasn't implemented either because this wasn't caught before release or there was insufficient time to implement a proper check and response.

Colin:
My comment about the release notes in the other bug was a reference to <http://www.ubuntu.com/download/releasenotes/606>, which appears to have no link to the wiki page about known issues in Ubuquity.

Revision history for this message
kiwi (satelliittipupu) wrote :

So the workaround seems to be to make a separate /boot partition... But how big should the /boot partition be? 10 Mb? 100Mb? More?

Revision history for this message
Phil Miller (ubuntu-millenix) wrote :

50 megabytes should be more than sufficient, even with the possibility of kernel upgrades and such in mind.

Revision history for this message
Rudolf Vavruch (rvavruch) wrote :

I made mine 100MBs, which might be overkill.

All you have in there are your grub files (size negliable), and your linux-mage thingys (kernels I think), which seem to be around 20MBs each. If you don't clean it out you're going to run out of space, but you generally only need one of them.

Revision history for this message
Phil Miller (ubuntu-millenix) wrote : Re: [Bug 47848] Re: should warn at partitioning stage if /boot is on XFS

Generally, it's good practice to keep at least one previous kernel
around when installing a new one, in case you find problems after the
initial succesful boot with the new kernel. For example, an updated
driver in the new kernel could cause instability under circumstances
that only crop up after some time and lead you to reboot into the
older one until a fixed version is released.

Revision history for this message
Alan Tam (at) wrote :

Is there anyway for me to unsubscribe from this bug report? I am receiving the annoying bug-duplication e-mails since I also created one of the duplicates.

Revision history for this message
Colin Watson (cjwatson) wrote :
Download full text (3.2 KiB)

Fixed in Edgy, to be released in October 2006. I've also included this fix in the list of changes scheduled to go into the first point release of Dapper, which will probably be in August 2006. Since there are a lot of people subscribed to this bug due to duplicates, I'd appreciate it if any queries about this bug or complaints about the form of the fix were sent by private e-mail or filed as new bugs respectively.

ubiquity (1.1.0) edgy; urgency=low

  * Use try/finally in install.py to ensure that PROGRESS STOP is always
    called; ignore errors from PROGRESS STOP (e.g. because debconf has gone
    away due to a previous error).
  * Support /UNIONFS (Knoppix) as well as /rofs as the read-only filesystem
    source.
  * Don't require entering a full name (see
    http://www.hermann-uwe.de/blog/os-install-experiences-part-4-ubuntu).
  * GTK frontend:
    - Return None from location_from_point if point is None (thanks to Chris
      Moore for the idea; closes: Malone #48885).
  * KDE frontend:
    - Add slightly more paranoia in case getNearestCity returns None.
  * Don't show hw-detect/modprobe_error, and make it non-fatal (closes:
    Malone #48524).
  * Make it clear in the crash dialog that you should file a new bug, not
    attach your details to an existing bug.
  * Add passwd and adduser dependencies from user-setup.
  * Take a copy of the supplied choice map in set_keyboard_choices.
  * Save tracebacks from install.py and slurp them back into the traceback
    displayed if install.py exits non-zero.
  * Convert to new Python policy (python-central). Install Python
    modules/extensions to /usr/lib/ubiquity/ubiquity rather than into the
    public module path.
  * Warn in the partitioner if you try to use XFS for /boot (closes: Malone
    #47848).
  * Warn in the partitioner if system filesystems are not reformatted
    (closes: Malone #47046).
  * Remove /usr/bin/espresso compatibility symlink.
  * Use os._exit() rather than sys.exit() in the apt install progress child
    process after forking, fixing a lot of strange "PROGRESS STOP" messages
    in /var/log/installer/syslog and bizarre debconf exceptions. See also
    Malone #53298.
  * Use exceptions to communicate all failures in install.py, so that we get
    more useful tracebacks.

  * Automatic update of included source packages: apt-setup 1:0.11ubuntu1,
    base-installer 1.63ubuntu2, choose-mirror 2.04ubuntu1, clock-setup
    0.10ubuntu1, debian-installer-utils 1.32ubuntu1, grub-installer
    1.17ubuntu1, hw-detect 1.38ubuntu1, kbd-chooser 1.29ubuntu1,
    localechooser 1.20ubuntu3, partconf 1.16, partman-auto 54ubuntu1,
    partman-base 90ubuntu1, partman-basicfilesystems 47ubuntu1,
    partman-basicmethods 30, partman-ext3 41, partman-jfs 17,
    partman-newworld 13, partman-palo 4, partman-partitioning 40ubuntu1,
    partman-reiserfs 31, partman-target 42ubuntu1, partman-xfs 29,
    silo-installer 1.04ubuntu1, tzsetup 1:0.10ubuntu1, user-setup
    1.2ubuntu2, yaboot-installer 1.1.7ubuntu1.
  * Handle move of prebaseconfig scripts to (variously) post-base-installer
    or finish-install.
  * Install search-path from debia...

Read more...

Changed in ubiquity:
assignee: nobody → kamion
status: Confirmed → Fix Released
Revision history for this message
David Warde-Farley (david-warde-farley) wrote : unsubscribe david.warde.farley@utoronto.ca

On 19-Jul-06, at 3:15 PM, Carthik Sharma wrote:

> *** This bug is a duplicate of bug 47848 ***
>
> Thanks for your report. Due to some reliability problems with GRUB and
> XFS, you need to use a non-XFS root filesystem or create a non-XFS /
> boot
> filesystem. Bug 47848 is filed to note that the partitioner should
> warn
> you about this up-front.
>
> ** This bug has been marked a duplicate of bug 47848
> should warn at partitioning stage if /boot is on XFS
>
> --
> installer crashed
> https://launchpad.net/bugs/52798

Revision history for this message
David Warde-Farley (david-warde-farley) wrote :

unsubscribe <email address hidden>

Revision history for this message
David Warde-Farley (david-warde-farley) wrote :

(Sorry if I'm doing this wrong, there's just no bloody unsubscribe link - dwf)

Revision history for this message
andol123 (andol123) wrote :

I think it's a bug. I unsubscribed from this madness several weeks ago, still today I got 12 new emails about the subject. Who would've known there would be that many people using XFS. Once you unsubscribe the unsubscribe link disappears (naturually), but you're still in a subscribed state. Wierd.

Revision history for this message
David Warde-Farley (david-warde-farley) wrote :

It's infuriating is what it is. I sorted through every bug in the "duplicates" column, found the one I'd submitted and unsubscribed from it, and now I'm still receiving notifications. That's good enough reason for me to never submit a bug report again.

Revision history for this message
Peter Joseph (kneecaps-shockpulse) wrote :

yes..this is driving me mad also! Arrgh..please stop the email madness!

Revision history for this message
thattommyhall (thattommyhall) wrote : Re: [Bug 47848] Re: should warn at partitioning stage if /boot is on XFS

you are making it worse for me, you silly man
shut up

On 7/19/06, Peter Joseph <email address hidden> wrote:
> yes..this is driving me mad also! Arrgh..please stop the email madness!
>
> --
> should warn at partitioning stage if /boot is on XFS
> https://launchpad.net/bugs/47848
>

Revision history for this message
Colin Watson (cjwatson) wrote :
Download full text (3.4 KiB)

This will also be fixed in the first Dapper point release (which should hopefully dry up the flood of new reports of the same problem!).

ubiquity (1.0.13) dapper-updates; urgency=low

  * Don't require entering a full name (see
    http://www.hermann-uwe.de/blog/os-install-experiences-part-4-ubuntu).
  * GTK frontend:
    - Return None from location_from_point if point is None (thanks to Chris
      Moore for the idea; closes: Malone #48885).
  * KDE frontend:
    - Add slightly more paranoia in case getNearestCity returns None.
  * Don't show hw-detect/modprobe_error, and make it non-fatal (closes:
    Malone #48524).
  * Make it clear in the crash dialog that you should file a new bug, not
    attach your details to an existing bug.
  * Take a copy of the supplied choice map in set_keyboard_choices.
  * Save tracebacks from install.py and slurp them back into the traceback
    displayed if install.py exits non-zero.
  * Warn in the partitioner if you try to use XFS for /boot (closes: Malone
    #47848).
  * Warn in the partitioner if system filesystems are not reformatted
    (closes: Malone #47046).
  * Use os._exit() rather than sys.exit() in the apt install progress child
    process after forking, fixing a lot of strange "PROGRESS STOP" messages
    in /var/log/installer/syslog and bizarre debconf exceptions. See also
    Malone #53298.
  * Use 'replace' Unicode error handling when dealing with data coming from
    debconf (closes: Malone #44595, #48732).
  * Fix ubiquity/install/apt_error_install and
    ubiquity/install/apt_error_remove templates to be of type 'error'
    (closes: Malone #53258).
  * Install more defence against gparted/qtparted crashing (closes: Malone
    #47194, #48856).
  * If gparted or qtparted crashes, put up a dialog allowing the user to try
    again, return to autopartitioning, or quit the installer. This is a
    pretty awful hack, but hopefully we won't be using gparted/qtparted for
    all that much longer ...
  * Fix crash in KDE frontend while translating widgets (closes: Malone
    #53367).
  * When an error occurs with the install progress bar up, only return to
    autopartitioning if the partitioner is still running.
  * Turn DebconfInstallProgress upside-down so that the main process handles
    apt installation and the subprocess handles the translation of apt
    status messages into debconf protocol messages, rather than the other
    way round. The previous approach resulted in exceptions from apt ending
    up in the wrong process.
  * Silence apt errors while installing language packs, since we ignore them
    anyway.
  * Point apt at /target/var/lib/dpkg/status rather than
    /var/lib/dpkg/status (closes: Malone #47859).
  * Display grub-installer/install_to_xfs question if it's asked.
  * Fix get_filesystems() not to assume ext3 in quite so many situations.
  * Detect XFS for validation purposes even when it wasn't just formatted by
    gparted/qtparted (closes: Malone #53642).
  * Fix all mentions of gparted in the KDE frontend.
  * Leave existing newworld boot partitions alone when committing manual
    partitioning changes.
  * Always set mirror/country to the country selected on the t...

Read more...

Revision history for this message
ekerazha (ekerazha) wrote :

Shouldn't be GRUB >= 0.97 compatible with XFS? I've seen many systems (ex. Gentoo) running GRUB with /boot on XFS.

Revision history for this message
epintula (epintula) wrote :

ok, resolvido.
Muito Obrigado, o Ubuntu já está instalado.

2006/8/18, Mark Reitblatt <email address hidden>:
>
> ** Bug 56696 has been marked a duplicate of this bug
>
> ** Bug 56827 has been marked a duplicate of this bug
>
> --
> should warn at partitioning stage if /boot is on XFS
> https://launchpad.net/bugs/47848
>

Revision history for this message
kiwi (satelliittipupu) wrote : unsubscribe kiwi

unsubscribe kiwi

Revision history for this message
Adrian Fisher (lordalbion) wrote : unsubscribe

On 22/08/06, kiwi <email address hidden> wrote:
>
> unsubscribe kiwi
>
> --
> should warn at partitioning stage if /boot is on XFS
> https://launchpad.net/bugs/47848
>

Revision history for this message
Keltroth (keltroth) wrote : Re: [Bug 47848] unsubscribe kiwi

unsubscribe

2006/8/22, kiwi <email address hidden>:
>
> unsubscribe kiwi
>
> --
> should warn at partitioning stage if /boot is on XFS
> https://launchpad.net/bugs/47848
>

--
Django

Revision history for this message
John Vivirito (gnomefreak) wrote :

keltroth on the left hand side of this page you will see unsubscribe click it and than answer yes if you really want to unsubscribe.

Revision history for this message
kiwi (satelliittipupu) wrote : unsubscribe doesn't work! I'll mark launchpad as SPAM!

So, it seems the unsubscribe doesn't work. And there's no documentation anywhere about how to do it.
I'm marking each new mail from launchpad to be spam, and I'll never ever do the mistake of submitting a bug. And there you have it, my email address on the site, complete with @ and everything. This will propably get me alot more spam in the future.
This site makes my email unusable. Please fix it. Thank you.

Sorry for posting.

Revision history for this message
andol123 (andol123) wrote :

It's impossible to unsubscribe from this system. It was discussed in another bug report too. If you unsubscribe you're still subscribed. I unsubcribed from this bug about 3 days after reporting it. I still get 1-10 messages per day about new bug reports regarding XFS and grub. It's really tiresome. Perhaps someone will bother to fix it if when I start pushing out each message I receive from today to spam databases? ;)

Revision history for this message
Vassilis Pandis (pandisv) wrote :
Revision history for this message
Thomas Hotz (thotz-deactivatedaccount) wrote : Re: [Bug 47848] Re: should warn at partitioning stage if /boot is on XFS

And then why not fixing it ;-)? It was reported on 2006-06-07 (!).

Revision history for this message
Manuel López-Ibáñez (manuellopezibanez) wrote :

@yattaran
@kiwi

These are two issues. One is that you can't unsubscribe by email. You must use the web interface. I was not able to find any bug report about this in malone https://launchpad.net/products/malone/+bugs

You are very welcome to report it, if you really think it is a desirable feature. (I always use the web interface).

The other issue is that you can't unsubscribe from some bugs. This is bug 48860 and it haven't seen much movement since I reported it. I haven't insisted much because I filter my mail, so again, this is not really an issue for me. If it is important for you, please, show your interest in that bug report, so launchpad developers understand that it is an actual issue.

Revision history for this message
Keltroth (keltroth) wrote :

I already tried unsubscribe "funtionality" on the web site... in vain...

2006/8/22, Vassilis Pandis <email address hidden>:
>
> This is a launchpad issue.
> https://launchpad.net/products/malone/+bug/48860
>
> --
> should warn at partitioning stage if /boot is on XFS
> https://launchpad.net/bugs/47848
>

--
Django

Revision history for this message
epintula (epintula) wrote : Re: [Bug 47848] Re: [Bug 47848] Re: should warn at partitioning stage if /boot is on XFS

I don't speak english... I speak portuguese! But, I was repartition my
hard-drive and now is ok! The ubuntu is instaled and funtional! Do you
understand-me??

Portuguese:

Eu recebi a informação de que o problema era com o Grub/XFS e já
reparticionei o disco, criando uma partição /boot em reiserFS. Com isto, já
consegui instalar o Ubuntu e até o AIXGL... já está tudo funcionando,
perfeitamente.

Eu recebi vários e-mails da equipe do Ubuntu respondendo à minha questão e
devolvi os e-mails agradecendo... mas acho que o pessoal não sabe português,
daí não entenderam que eu só estava agradecendo o auxílio e então me
reenviaram dezenas de e-mails dando-me as mesmas instruções....

Repetindo: Agradeço, verdadeiramente, o auxílio e já estou trabalhando com o
Ubuntu, perfeitamente! Parabéns pelo trabalho e pelo suporte rápido e
solícito!

Um forte abraço!!!

Revision history for this message
Peter Joseph (kneecaps-shockpulse) wrote : Re: [Bug 47848] Re: [Bug 47848] unsubscribe kiwi

unsubscribe

Keltroth wrote:
> unsubscribe
>
> 2006/8/22, kiwi <email address hidden>:
>> unsubscribe kiwi
>>
>> --
>> should warn at partitioning stage if /boot is on XFS
>> https://launchpad.net/bugs/47848
>>
>
>

--
Peter Joseph Debian GNU/Linux Junkie
<email address hidden> <email address hidden>
http://www.shockpulse.co.uk/ http://www.debian.org/
   "If there were no god, we would have to invent him." - Voltaire

Revision history for this message
epintula (epintula) wrote : Re: [Bug 47848] Re: should warn at partitioning stage if /boot is on XFS

ok.

2006/9/20, Carthik Sharma <email address hidden>:
>
> ** Bug 61207 has been marked a duplicate of this bug
>
> --
> should warn at partitioning stage if /boot is on XFS
> https://launchpad.net/bugs/47848
>

Revision history for this message
andol123 (andol123) wrote :

@manu

>These are two issues. One is that you can't unsubscribe by email. You >must use the web interface. I was not able to find any bug report about >this in malone https://launchpad.net/products/malone/+bugs

>You are very welcome to report it, if you really think it is a desirable >feature. (I always use the web interface).

I don't think I've ever mentioned unsubsubscring by mail. It's the web interface which doesn't work. For all these /boot + XFS bug reports I keep getting, I can only choose "Subscribe" and "Subscribe Someone Else". There's no "Unsubscribe" link to click on using the web interface. Still I and probably many others keep getting bug reports mailed to us even though we're not even subscribed. We just happened to report a bug, and keep getting bug reports for anything concering this bug, even duplicates and duplicates of duplicates.

It's of course easy to filter out, but still totally unecessary. :-)

I noticed a bug report of this bug is "In Progress" at:
https://launchpad.net/products/malone/+bugs?field.searchtext=unsubscribe&orderby=-importance&search=Search&field.status%3Alist=Unconfirmed&field.status%3Alist=Confirmed&field.status%3Alist=In+Progress&field.status%3Alist=Needs+Info&field.status%3Alist=Fix+Committed&field.assignee=&field.owner=&field.omit_dupes=on&field.has_patch=&field.has_no_package=
Hopefully it's fixed soon.

Revision history for this message
Jonathan Harker (jonathanharker) wrote :

yattaran wrote:
> @manu
>
>> These are two issues. One is that you can't unsubscribe by email. You
>> must use the web interface. I was not able to find any bug report about
>> this in malone https://launchpad.net/products/malone/+bugs

I'm still getting these messages even though I have unsubscribed from
this bug. what gives?

J

Revision history for this message
duckdown (liquidhex) wrote : Re: [Bug 47848] Re: [Bug 47848] Re: should warn at partitioning stage if /boot is on XFS

Me too. This is highly annoying.

On 9/24/06, Jonathan Harker <email address hidden> wrote:
>
> yattaran wrote:
> > @manu
> >
> >> These are two issues. One is that you can't unsubscribe by email. You
> >> must use the web interface. I was not able to find any bug report about
> >> this in malone https://launchpad.net/products/malone/+bugs
>
> I'm still getting these messages even though I have unsubscribed from
> this bug. what gives?
>
> J
>
> --
> should warn at partitioning stage if /boot is on XFS
> https://launchpad.net/bugs/47848
>

Revision history for this message
strangelove (kungfaux) wrote : Re: [Bug 47848] Re: [Bug 47848] Re: [Bug 47848] Re: should warn at partitioning stage if /boot is on XFS

duckdown wrote:
> Me too. This is highly annoying.
>
>
> On 9/24/06, Jonathan Harker <email address hidden> wrote:
>
>> yattaran wrote:
>>
>>> @manu
>>>
>>>
>>>> These are two issues. One is that you can't unsubscribe by email. You
>>>> must use the web interface. I was not able to find any bug report about
>>>> this in malone https://launchpad.net/products/malone/+bugs
>>>>
>> I'm still getting these messages even though I have unsubscribed from
>> this bug. what gives?
>>
>> J
>>
>> --
>> should warn at partitioning stage if /boot is on XFS
>> https://launchpad.net/bugs/47848
>>
>>
>
>

Shut the fuck up. Your just making it worse for the rest of us.

As above:
https://launchpad.net/products/malone/+bugs?field.searchtext=unsubscribe&orderby=-importance&search=Search&field.status%3Alist=Unconfirmed&field.status%3Alist=Confirmed&field.status%3Alist=In+Progress&field.status%3Alist=Needs+Info&field.status%3Alist=Fix+Committed&field.assignee=&field.owner=&field.omit_dupes=on&field.has_patch=&field.has_no_package=

(Does profanity get me blocked?? :P)

-Jesse

Revision history for this message
Jonathan Harker (jonathanharker) wrote : Re: [Bug 47848] Re: [Bug 47848] Re: [Bug 47848] Re: [Bug 47848] Re: should warn at partitioning stage if /boot is on XFS
Revision history for this message
Vassilis Pandis (pandisv) wrote :

Could you please refrain from posting comments unrelated to the bug report? It causes unnecessary bug mail to everybody subscribed to the bug and to the developers. In the meantime,
please be sure to follow http://www.ubuntu.com/community/conduct/. Thanks.

Revision history for this message
John Doe (jodo-deactivatedaccount) wrote :

Is this still existing in Gutsy?

Revision history for this message
Kurt Huwig (k-huwig) wrote : Re: [Bug 47848] Re: should warn at partitioning stage if /boot is on XFS

Am Samstag, 27. Oktober 2007 schrieb nordlicht.ol:
> Is this still existing in Gutsy?

Hmm, not an my machine, although I do not have a /boot:

/dev/hda3 on / type xfs (rw)
--
Mit freundlichen Grüßen

Kurt Huwig (Vorstand)
Telefon 0681/96751-50, Telefax 0681/96751-66
http://www.iku-ag.de/

iKu Systemhaus AG, Am Römerkastell 4, 66121 Saarbrücken
Amtsgericht: Saarbrücken, HRB 13240
Vorstand: Kurt Huwig, Andreas Niederländer
Aufsichtsratsvorsitzender: Jan Bankstahl

GnuPG 1024D/99DD9468 64B1 0C5B 82BC E16E 8940  EB6D 4C32 F908 99DD 9468

Revision history for this message
Peter Cordes (peter-cordes) wrote :

I just installed i386 Gutsy from the desktop livecd on an old AMD K7 650MHz, 256MB RAM, that I use for messing around.

1 IDE hard drive:
hda1: win98
hda2: failed installed of winxp
hda5: swap
hda6: / (XFS)

Right after partitioning, the installer warns if you /boot will be on XFS. It pops up a dialog that warns you about grub-install not working properly on an XFS /boot, giving you options of [go back] an [continue]. The actions of the buttons are opposite to their text: [go back] continues, and vice versa.

 At the end of the install, a similar (or identical) dialog comes up before running grub-install. This time, the buttons are mapped correctly. I hit continue, and grub-install failed.

 To install grub manually, I made a grub floppy (cat /usr/lib/*-pc/stage[12] > /dev/fd0) This machine is so old that floppy booting works better than USB. :P Then
root (hd0,5)
setup (hd0)
did the trick. I think there's a way to get it to work from the grub shell running under Linux, maybe using install instead of setup.

 Anyway, Gutsy still has the warnings, and still needs them.

Revision history for this message
David Cuthbert (dacut) wrote :

Hm, it's possible that this is no longer needed (if Ubuntu is using grub > 0.97). According to http://oss.sgi.com/projects/xfs/faq.html#grubwork :

Q: Does GRUB work with XFS?

There is native XFS filesystem support for GRUB starting with version 0.91 and onward. Unfortunately, GRUB used to make incorrect assumptions about being able to read a block device image while a filesystem is mounted and actively being written to, which could cause intermittent problems when using XFS. This has reportedly since been fixed, and the 0.97 version (at least) of GRUB is apparently stable.

Revision history for this message
David Cuthbert (dacut) wrote :

Or, to clarify: s/no longer needed/could be made to work so the warning dialog is no longer needed/

Revision history for this message
epintula (epintula) wrote :

Sorry, I don't speak English ... I am Brazilian and I speak Portuguese.
The installer failed with the boot partition, XFS, but my son changes the ubiquiti script and the installation is successful.
Another strategy: I installed a ext3 /boot, reiniciei the system, and then copy the whole /boot to another directory, then I reinstall the boot partition with XFS, copy files for new /boot partition and reinstaller GRUB without error messages .
The error only occurs during installation by Ubiquity.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers