Tracker uses notifications with actions when the index is corrupt

Bug #361205 reported by Jordi on 2009-04-14
290
This bug affects 29 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
Tracker
Invalid
Undecided
Unassigned
tracker (Ubuntu)
Medium
Chris Coulson
Jaunty
Medium
Chris Coulson
Karmic
Medium
Chris Coulson

Bug Description

Binary package hint: tracker

Hi all,

I think the target entity is the trackerd or the tracker-applet.

Working on removable media, a popup from the tracker showed me that the index was corrupt, what provided me 3 options: Accept, Cancel, Start Reindexing (or something like that). The main issue is that whatever I click onto, the popup always re-appeared showing exactly the same message, with the same 3 options. I saw from:

https://bugs.launchpad.net/ubuntu/+source/tracker/+bug/305739

that this is a new feature, but the popup should disappear after the user commits one option. I used the top command and I saw that both trackerd and tracker-applet used either the 50% of the CPU (so the full CPU in usage from them), from the very beginning of the popup, and nothing about re-indexing was committed yet. When I accepted to re-index the content, the same popup reappeared, in addition to a new one advinsing that the re-indexing process could take a long time.

In order to have a useful computer, I had to kill (15) the tracker-applet, and now I have the trackerd using the 50% of the CPU, even that I have nothing enabled to be indexed (at least conciously).

Best,

Jordi

***TEST-CASE FOR SRU***

* With the current version of tracker (0.6.93-0ubuntu1), for those experiencing corruption you will see an error notification dialog with "Reindex", "Ok" and "Cancel" buttons.
1) Clicking Ok or Cancel will dismiss the dialog briefly and it will always re-appear straight away.
2) Clicking "Reindex" in the error dialog may cause the dialog to disappear, but it may reappear again a short-while later if the reindex wasn't successful in clearing the corruption.
3) Choose "Reindex" from the applet whilst monitoring the contents of ~/.cache/tracker. Note that file-index.db and email-index.db are not deleted on reindex.

* With the newer version of tracker (0.6.93-0ubuntu2), if corruption is detected you should see a brief notification warning you that an index error was detected. This should disappear and re-indexing should commence with no user interaction required. The notification should not reappear again afterwards. Also:
1) Make sure that you still see a confirmation dialog when manually requesting a reindex (right-click on applet, select Reindex. A "Reindex your system?" confirmation dialog should appear).
2) Select a manual reindex from the applet. When doing this, monitor the contents of ~/.cache/tracker. After initiating the reindex, all .db files should be deleted briefly and then recreated again.

It may be difficult to test due to you having to wait for Tracker to corrupt the index, which might never happen. For those brave enough, you can try manually corrupting your ~/.cache/tracker/file-index.db

Alex Hagen (ahagen) wrote :

I also have this problem, and had to kill tracker as well.

Chris Coulson (chrisccoulson) wrote :

Confirming, as multiple people seem to be having this issue. I'll take a look at this when I get home.

Changed in tracker (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Brunellus (luigi12081) wrote :

confirm on Jaunty.

hhlp (hhlp-deactivatedaccount) wrote :

after today updating in jaunty i have got this issue you can do reindex and accept the same error

regards.,

hhlp (hhlp-deactivatedaccount) wrote :

i delete ~/.cache/tracker with the same result ......

regards.,

hhlp (hhlp-deactivatedaccount) wrote :

this process work for me ....

first delete ~/.cache/tracker

go to system -> preference -> search and index and open

click on apply and accept

if and window open saying 'do you wnat to index' click yes

and the message desapeer

regards.,

Ralph Giles (giles-ghostscript) wrote :

I also got something like this today on jaunty. The 'Cancel' and 'Ok' buttons dismiss the dialog, when is then respawned. The 'Reindex All Contents' button does seem to do something. At least, when I click it I get a second, scarier dialog about how it's going to take forever and do I really want to do that. Not very useful since there appears to be only one choice here.

psychok7 (nunok7) wrote :

Hector.. it doesnt work for me...ill try killing the indexing process

I've got the same problem since my last update.

Changed in tracker (Ubuntu Jaunty):
assignee: nobody → Chris Coulson (chrisccoulson)
status: Confirmed → In Progress
tags: added: notifications
Chris Coulson (chrisccoulson) wrote :

I've written a patch which (should) just automatically reindex if index corruption is detected now, as opposed to displaying this confusing fallback notification. Reindexing is the only sane way to recover anyway, so the user shouldn't have to interact.

The patch is in my branch (linked to this bug report) and I've uploaded a build to my PPA (https://edge.launchpad.net/~chrisccoulson/+archive/ppa).

I haven't experienced any corruption recently, so my patch is completely untested. I would appreciate it if people experiencing index corruption could test the build from my PPA (0.6.93-0ubuntu2~chrisccoulson2) and provide feedback here.

What should happen now is that you should get a normal (pretty) notification telling you about the index error (with no actions), before it automatically begins re-indexing.

If you right-click on the tracker-applet tray icon and select "Reindex", you should still see a confirmation dialog (the same as the current behaviour). Please test that too to make sure I haven't broken it.

The patch only touches code in src/tracker-applet/tracker-applet.c. It adds a new parameter "no_confirm" to reindex (). If no_confirm is FALSE, then it will display a confirmation dialog before beginning reindex. If it is TRUE, it will reindex with no confirmation. I've added 2 new private calls (reindex_no_confirmation() and reindex_with_confirmation()) which are wrappers for reindex(). When you right-click on the applet and select "Reindex", this now calls reindex_with_confirmation(). When an index error is detected that requires a reindex, reindex_no_confirmation() is called instead.

summary: - corrupt index on tracker
+ Tracker uses notifications with actions when the index is corrupt

@Chris Coulson: The packages from your PPA "fixed" it for me, which means that they behaved as you described it, including the "manual" reindexing by right-click on the tracker-applet.

The initial problem of the permanently corrupted indexes could only be fixed by deleting ~/.cache/tracker (as Hector Louzao suggested above).

Thanks for the good work!

Mjateznik (goran-soderberg) wrote :

I have the same issue.

The indexing has halted on about 35% - whatever option I choose in the popup.

Ryan Steele (rgsteele) wrote :

tracker bug draft

Hi Chris,
I am also experiencing this issue. After installing the build from your PPA everything seemed to be fine, but after attempting to perform a search in Tracker I am receiving repeated popups saying "There was an error while performing indexing: index corrupted". I ran "ps aux | grep trackerd" to find the PID to kill the process but got an error that there was no such process. Turns out that trackerd appears to be continuously dying and restarting:

ryan@ryan-laptop:~$ ps aux | grep trackerd
ryan 10017 51.7 3.0 49392 31336 ? R 13:18 0:09 /usr/lib/tracker/trackerd
ryan 10022 0.0 0.0 4416 812 pts/0 S+ 13:18 0:00 grep trackerd
ryan@ryan-laptop:~$ kill 10017
bash: kill: (10017) - No such process
ryan@ryan-laptop:~$ ps aux | grep trackerd
ryan 10024 15.7 1.4 32568 14656 ? R 13:18 0:02 /usr/lib/tracker/trackerd
ryan 10027 0.0 0.0 4416 804 pts/0 R+ 13:18 0:00 grep trackerd
ryan@ryan-laptop:~$ ps aux | grep trackerd
ryan 10024 25.4 2.1 40816 22252 ? R 13:18 0:05 /usr/lib/tracker/trackerd
ryan 10038 0.0 0.0 4416 808 pts/0 S+ 13:19 0:00 grep trackerd
ryan@ryan-laptop:~$ ps aux | grep trackerd
ryan 10024 28.7 2.3 42000 23568 ? R 13:18 0:06 /usr/lib/tracker/trackerd
ryan 10040 0.0 0.0 4416 800 pts/0 R+ 13:19 0:00 grep trackerd
ryan@ryan-laptop:~$ ps aux | grep trackerd
ryan 10024 32.2 2.5 44480 26164 ? R 13:18 0:08 /usr/lib/tracker/trackerd
ryan 10042 0.0 0.0 4416 812 pts/0 S+ 13:19 0:00 grep trackerd
ryan@ryan-laptop:~$ ps aux | grep trackerd
ryan 10024 39.4 3.1 49436 31536 ? R 13:18 0:11 /usr/lib/tracker/trackerd
ryan 10044 0.0 0.0 4416 808 pts/0 S+ 13:19 0:00 grep trackerd
ryan@ryan-laptop:~$ ps aux | grep trackerd
ryan 10024 42.0 3.3 53320 34056 ? R 13:18 0:13 /usr/lib/tracker/trackerd
ryan 10046 0.0 0.0 4416 808 pts/0 S+ 13:19 0:00 grep trackerd
ryan@ryan-laptop:~$ ps aux | grep trackerd
ryan 10024 43.6 3.4 54496 35276 ? R 13:18 0:14 /usr/lib/tracker/trackerd
ryan 10048 0.0 0.0 4416 812 pts/0 S+ 13:19 0:00 grep trackerd
ryan@ryan-laptop:~$ ps aux | grep trackerd
ryan 10024 45.8 3.6 56072 36936 ? R 13:18 0:15 /usr/lib/tracker/trackerd
ryan 10050 0.0 0.0 4416 812 pts/0 S+ 13:19 0:00 grep trackerd
ryan@ryan-laptop:~$ ps aux | grep trackerd
ryan 10052 42.2 1.5 33520 15468 ? S 13:19 0:01 /usr/lib/tracker/trackerd
ryan 10055 0.0 0.0 4416 808 pts/0 S+ 13:19 0:00 grep trackerd
ryan@ryan-laptop:~$

The following line is repeated hundreds of times in /home/ryan/.local/share/tracker/tracker-indexer.log after the indexing error occurs:

18 Apr 2009, 13:38:23: Tracker-Warning **: Could not store word 'target_url': with fatal error

Chris Coulson (chrisccoulson) wrote :

Thanks for testing. Ryan, I'll need to take a look at that in more detail but I suspect your issue is more an upstream one, as my patch just automatically runs the action that would normally be taken when pressing the Reindex action on the notification that used to appear.

Those messages that you see in tracker-indexer indicate the index is corrupt, but they should stop once reindexing commences I think

Ryan Steele (rgsteele) wrote :

Yes, I realized after submitting my report that it probably needs to be filed as a separate bug.

FYI, in my research I came upon this other bug in which they are discussing the same issue that your patch resolves:

https://bugs.launchpad.net/ubuntu/+source/tracker/+bug/346912

I left a comment with a link to this bug.

pixolex (pixolex) wrote :

Upgraded yesterday to jaunty RC and I have the same problem. I followed the indications from https://bugs.launchpad.net/ubuntu/jaunty/+source/tracker/+bug/346912 (tracker-processes -r) and finally the indexing stoped, but now I don't have the icon any more. I'll try reboot.

baytuni (oytun-peksel) wrote :

same problem here..

same problem.

Ubuntu 9.04 RC
Package: tracker
Installed-Size: 3152
Architecture: i386
Version: 0.6.93-0ubuntu1

Martin Pitt (pitti) wrote :

Added to release notes.

Changed in ubuntu-release-notes:
status: New → Fix Released
brian russell (vagemulo) wrote :

I was able to solve this problem by installing tracker-utils. it is a suggested package.

perhaps this could be easily solved by relabeling it as a dependency.

brian russell (vagemulo) wrote :

oh, and I think i may have also rebooted. the best part was that i didn't have to reindex.

Chris Coulson (chrisccoulson) wrote :

Installing tracker-utils will not have any effect on this. The behaviour you experience is just coincedental - we already fully understand this bug.

I upgraded to 9.04 (alt-32bit) from 8.10.

I encountered this bug.

I ran the workaround in 9.04 release notes (http://www.ubuntu.com/getubuntu/releasenotes/904) "Tracker index corruption"

The workaround failed.

I installed tracker-utils and reinstalled tracker. (Thanks brian russell)

After this the tracker-processes -r ran.

Thomas W-P (thomaswp) wrote :

I too upgraded to 9.04 from 8.10 (32 bit).

I too encountered the bug and followed the release notes (http://www.ubuntu.com/getubuntu/releasenotes/904) but "tracker-processes -r" did not run.

Thanks to the above post I was able to succeed by installing tracker-utils.

Thanks to all who work so hard on this.

einfeldt (einfeldt) wrote :

I started a discussion about this bug here:

http://ubuntuforums.org/showthread.php?p=7149477#post7149477

I hope that is helpful. I am a fairly simple end user, and I am not very familiar with the proper way to resolve bugs. I had lots of stupid questions with which I did not want to junk up this bug list.

Thank you all for working to resolve this bug. I use Ubuntu both for my work as a lawyer and in creating a documentary movie called the Digital Tipping Point, so I get a lot of good use out of Ubuntu. I am very grateful to have such fine software at no cost.

rifd (rdohmeier) wrote :

I upgraded to 9.04 and have the same bug as reported in bug#361485 above. I would like to add:
I tried gparted and my /dev/sda1 reports a warning:
Unable to read contents of file system.

However, when I try to fix partition from a boot disk, the boot disk does not report any problem with the partition.

description: updated
John Costella (jpcostella) wrote :

Hi Chris,

Sorry for my ignorance, but I can't figure out how to install your patch. I see it listed when I go to https://edge.launchpad.net/~chrisccoulson/+archive/ppa, but clicking it does nothing more than twisting the triangle.

I've tried uninstalling, reinstalling, etc., instead, but the zombie keeps coming back.

Thanks in advance
John Costella

Martin Pitt (pitti) wrote :

Accepted into jaunty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in tracker (Ubuntu Jaunty):
status: In Progress → Fix Committed
tags: added: verification-needed
ragnaroknroll (ragnaroknroll) wrote :

Having the same problem after upgrading to Jaunty today...

Reagan [2009-04-28 2:26 -0000]:
> Having the same problem after upgrading to Jaunty today...

Can you please test the jaunty-proposed version?

Michael Jones (jonesmz) wrote :

Martin,

    I enabled jaunty-proposed. I have not seen the same issue happening, but I haven't actively been checking.

    I will say that now that its brought to my attention, I'm pleasantly surprised to not have this issue pestering me, so for my part something went right. I think it is best to wait for other people to confirm that the issue is resolved, however, as there may be some other action that I took that had an unintended consequence of making tracker leave my alone.

-Mike

I didn't have luck with the other workaround, nor with reinstalling
tracker on either of the machines I upgraded... however, the following
did indeed seem to do the trick on both:

sudo apt-get install tracker tracker-utils --reinstall
tracker-processes -r

if this works (even if it only coincidentally solves the issue) with
no need to reindex, is it not what we should be proposing to noobs in
the forums? any reason it'd be preferable to enable jaunty-proposed?
is tracker not going to run properly? seems to be running fine without
a reindex....

brian

Michael Jones (jonesmz) wrote :
Download full text (4.0 KiB)

brian,

    were you able to install the proposed package? or was that the version
you were still experiencing the problem with?

-Mike

On Wed, Apr 29, 2009 at 6:26 PM, brian russell <email address hidden>wrote:

> I didn't have luck with the other workaround, nor with reinstalling
> tracker on either of the machines I upgraded... however, the following
> did indeed seem to do the trick on both:
>
> sudo apt-get install tracker tracker-utils --reinstall
> tracker-processes -r
>
> if this works (even if it only coincidentally solves the issue) with
> no need to reindex, is it not what we should be proposing to noobs in
> the forums? any reason it'd be preferable to enable jaunty-proposed?
> is tracker not going to run properly? seems to be running fine without
> a reindex....
>
> brian
>
> --
> Tracker uses notifications with actions when the index is corrupt
> https://bugs.launchpad.net/bugs/361205
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in Ubuntu Release Notes: Fix Released
> Status in “tracker” source package in Ubuntu: In Progress
> Status in tracker in Ubuntu Jaunty: Fix Committed
> Status in tracker in Ubuntu Karmic: In Progress
>
> Bug description:
> Binary package hint: tracker
>
> Hi all,
>
> I think the target entity is the trackerd or the tracker-applet.
>
> Working on removable media, a popup from the tracker showed me that the
> index was corrupt, what provided me 3 options: Accept, Cancel, Start
> Reindexing (or something like that). The main issue is that whatever I click
> onto, the popup always re-appeared showing exactly the same message, with
> the same 3 options. I saw from:
>
> https://bugs.launchpad.net/ubuntu/+source/tracker/+bug/305739
>
> that this is a new feature, but the popup should disappear after the user
> commits one option. I used the top command and I saw that both trackerd and
> tracker-applet used either the 50% of the CPU (so the full CPU in usage from
> them), from the very beginning of the popup, and nothing about re-indexing
> was committed yet. When I accepted to re-index the content, the same popup
> reappeared, in addition to a new one advinsing that the re-indexing process
> could take a long time.
>
> In order to have a useful computer, I had to kill (15) the tracker-applet,
> and now I have the trackerd using the 50% of the CPU, even that I have
> nothing enabled to be indexed (at least conciously).
>
> Best,
>
> Jordi
>
> ***TEST-CASE FOR SRU***
>
> * With the current version of tracker (0.6.93-0ubuntu1), for those
> experiencing corruption you will see an error notification dialog with
> "Reindex", "Ok" and "Cancel" buttons.
> 1) Clicking Ok or Cancel will dismiss the dialog briefly and it will always
> re-appear straight away.
> 2) Clicking "Reindex" in the error dialog may cause the dialog to
> disappear, but it may reappear again a short-while later if the reindex
> wasn't successful in clearing the corruption.
> 3) Choose "Reindex" from the applet whilst monitoring the contents of
> ~/.cache/tracker. Note that file-index.db and email-index.db are not deleted
> on reindex.
>
> * With the newer version of tracker (0.6.93-0ubun...

Read more...

Chris Adams (acdha) wrote :

I'm not sure about Brian's case but I found that even with the PPA version
installed I had to delete the tracker store from ~/.cache & ~/.local/share
before Tracker started working. The update did solve the prompts but then I
had loadavg 3+ while the index/crash/reindex process ran endlessly.
I saved a copy of the defective ~/.cache/tracker if you want it - fairly
sure I forgot to save a copy of ~/.local/share before nuking it, however.

Chris

On Wed, Apr 29, 2009 at 9:47 PM, Michael Jones <email address hidden> wrote:

> brian,
>
> were you able to install the proposed package? or was that the version
> you were still experiencing the problem with?
>

d0m (dominic-innocent) wrote :

Hi
I have just upgraded from 8.10 to 9.04 & the same thing has happened. So tried the old fashioned way of doing things; I un-installed & re-installed Tracker. This seems to have worked; so far !
Thanks
d0m.

Chris Coulson (chrisccoulson) wrote :

Chris - what was the exact behaviour you experienced with the updated version? Did you see a notification telling you that there was an error with the index? If so, what happened after that? Did you see a further notification telling you that re-indexing was going to start? At which point did you have to delete the contents of ~/.cache and ~/.local/share?

The reason I ask is that once an index error is detected and a reindex is requested, the new version already deletes everything from these folders. But if the index is large, it may take some time for the files to be deleted.

Chris Adams (acdha) wrote :

With the updated version I got the on screen notification telling me
that there was a problem with the index and then the re-index message.
After a couple of seconds the process would repeat endlessly - this is
a test VM so I left it running while I was working on other things &
it repeated at least dozens of times over 20-30 minutes. The index
shouldn't have been very large as my home directory is fairly empty on
that system - just a couple of git & svn repositories.

I'll check when I get home but I'm certain that one file was not
deleted as its mtime predated installing the new version (all of the
others were very closely matched in time) - IIRC it was
file-update-index.db but I'm not certain about that.

Chris

tags: added: verification-failed
removed: verification-needed
Chris Coulson (chrisccoulson) wrote :

Yes, please let me know which file isn't deleted, so I can investigate some more. I see all files deleted here, and reindexing now does exactly the same thing as tracker-processes -r with the new version too

John Rose (johnaaronrose) wrote :

Tried suggestion of:
sudo apt-get install tracker tracker-utils --reinstall
tracker-processes -r
That worked. But no tracker on sys tray. Checked tracker startup (in Sessions menu entry) and thus ran /usr/lib/tracker/trackerd: gave
> (trackerd:16978): Tracker-WARNING **: Error loading
> query:'sqlite-fulltext.sql' #0, Cannot use virtual tables in
> shared-cache mode.
Still no tracker in sys tray. How do I get it back?

After believing I had found a workaround, this bug has recurred.

It may be related to https://bugs.launchpad.net/ubuntu/+source/packagekit/+bug/257639

I set up tracker to index several mounted drives and left it to run overnight. The next morning I found an index failed notice. When I restarted the system, the tracker notification error occurred.

I decided to download the proposed updates for this and when I used update manager, I got the https://bugs.launchpad.net/bugs/257639 error.

I have upgraded the following packages:
libtracker-gtk0 (0.6.93-0ubuntu1) to 0.6.93-0ubuntu2
libtrackerclient0 (0.6.93-0ubuntu1) to 0.6.93-0ubuntu2
tracker (0.6.93-0ubuntu1) to 0.6.93-0ubuntu2
tracker-search-tool (0.6.93-0ubuntu1) to 0.6.93-0ubuntu2
tracker-utils (0.6.93-0ubuntu1) to 0.6.93-0ubuntu2

:~$ uname -a
Linux KISE-003 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009 i686 GNU/Linux
:~$ lsb_release -rd
Description: Ubuntu 9.04
Release: 9.04

Chris Coulson (chrisccoulson) wrote :

John - tracker-processes -r stops all tracker processes, so you will lost the applet too. To get the applet back, you have to run tracker-applet. Those error messages are unrelated to this bug.

keepitsimpleengr - this bug is completely unrelated to bug 257639. I don't know where you saw any similarities there.

Chris Coulson (chrisccoulson) wrote :

Chris - file-index-update.db won't get deleted on reindex because tracker no longer uses that file (since 0.6.93). The presence of that file will cause no problems. Are there any other files that get left around? I can't recreate it here. Re-indexing deletes everything for me (just like tracker-processs -r does).

The only similarity is that the tracker notification error occurred
immediately after the tracker index fail notice, and that 257639 (corrupted
cache) occurred immediately after the tracker index fail notice when using
update-manager.

On Thu, Apr 30, 2009 at 8:27 AM, Chris Coulson <<email address hidden>
> wrote:

>
> keepitsimpleengr - this bug is completely unrelated to bug 257639. I
> don't know where you saw any similarities there.
>
>
>

Chris Coulson (chrisccoulson) wrote :

For anyone who can still recreate the cyclic index error notification followed by reindexing, over and over again, please can you do the following (without deleting the bad indexes):

1) "killall trackerd && killall tracker-indexer && killall tracker-extract"
2) Edit ~/.config/tracker/tracker.cfg and change "Verbosity=0" to "Verbosity=3"
3) Run /usr/lib/tracker/trackerd 2>&1 ~/trackerd.log (I know that tracker creates its own log, but the log is erased each time the daemon starts)
4) If the index is corrupt, you should see the notification, then trackerd should begin to shut down and remove the old indexes. When this instance of trackerd exits, please attach your created trackerd.log to this bug report.

***Remember that trackerd in debug mode will spew a lot of information out, including the filename of every file it looks at. If you have anything private in the filenames, please edit it out before attaching the log if you don't want others to see it. Alternatively, you can mail me the log and I promise I will keep any filenames confidential***

Thanks

Chris Coulson (chrisccoulson) wrote :

Hmmmm, I wonder if tracker-indexer is not exiting when the daemon exits for the reindex

Eman_No1 (eman-no1) wrote :

Hi Chris,

I have installed the latest round of upgrades for the current version and I am still getting the index corrupted error. This box does not have any critical or confidential files, if you would like I can set remote access so that you can poke around and see what is happing.

Eman

Patrik Jansson (patrikja) wrote :

I am running jaunty (since 24 hours;-) and I have problems with the repeated reindexing. I have done what was suggested above https://bugs.launchpad.net/ubuntu/jaunty/+source/tracker/+bug/361205/comments/44 (after minor modification to avoid indexing the rapidly changing logfile!)

killall trackerd && killall tracker-indexer && killall tracker-extract
# edited the verbosity
/usr/lib/tracker/trackerd 2>&1 | sudo tee /root/trackerd.log

I attach the result below.

Hope it can help!
/Patrik

I upgraded two laptops today from 8.10 to 9.04 (EeePC 900 and Lenovo X301). Both immediately had many tracker errors with corrupt indices.

Chris Coulson (chrisccoulson) wrote :

Eman - the updated package here won't fix the index corruption issues (that is a separate bug). What it should do is not present the index error dialog that requires you to press any button, and should ensure that if index corruption is detected a reindex should happen automatically to clear the corruption. You will still see a notification of an index error, but it should resolve itself with no interaction and without the error repeatedly reoccuring.

Patrik - thanks for the log. Are you sure this is with the updated version? The reason I ask is because I see this at the end of your log:

Tracker-Message: Shutdown started
Tracker-Message: State change from 'Indexing' --> 'Shutdown'
Tracker-Message: Cleaning up
Tracker-Message: Saving metadata backup in turtle file
Tracker-Message: Removing all database files
Tracker-Message: Removing database:'/home/patrikj/.local/share/tracker/data/common.db'
Tracker-Message: Removing database:'/tmp/tracker-patrikj/cache.db'
Tracker-Message: Removing database:'/home/patrikj/.cache/tracker/file-meta.db'
Tracker-Message: Removing database:'/home/patrikj/.cache/tracker/file-fulltext.db'
Tracker-Message: Removing database:'/home/patrikj/.cache/tracker/file-contents.db'
Tracker-Message: Removing database:'/home/patrikj/.cache/tracker/email-meta.db'
Tracker-Message: Removing database:'/home/patrikj/.cache/tracker/email-fulltext.db'
Tracker-Message: Removing database:'/home/patrikj/.cache/tracker/email-contents.db'
Tracker-Message: Closed sqlite3 database:'/home/patrikj/.local/share/tracker/data/common.db'
Tracker-Message: Closed sqlite3 database:'/tmp/tracker-patrikj/cache.db'
Tracker-Message: Closed sqlite3 database:'/home/patrikj/.cache/tracker/file-meta.db'
Tracker-Message: Closed sqlite3 database:'/home/patrikj/.cache/tracker/file-fulltext.db'
Tracker-Message: Closed sqlite3 database:'/home/patrikj/.cache/tracker/file-contents.db'
Tracker-Message: Closed sqlite3 database:'/home/patrikj/.cache/tracker/email-meta.db'
Tracker-Message: Closed sqlite3 database:'/home/patrikj/.cache/tracker/email-fulltext.db'
Tracker-Message: Closed sqlite3 database:'/home/patrikj/.cache/tracker/email-contents.db'
Tracker-Message: Closed sqlite3 database:'/home/patrikj/.local/share/tracker/data/common.db'
Tracker-Message: NFS lock finalized

OK

What this is showing is that there is no call to tracker_db_index_manager_remove_all() during the shutdown, which is definately there in the updated version (0.6.93-0ubuntu2) but isn't there in the 0.6.93-0ubuntu1 version. That call needs to happen to remove all the corrupt index files.

I expected to see the following line when a shutdown is requested:

"Removing all database index files"

tinker123 (tinker123) wrote :

Ubuntu 9.04: Tracker Applet Errors

I just upgraded to Ubuntu 9.04.

I keep getting a pop-up from the Tracker Applet that reads:

===================================================================
Tracker
There was an error while performing indexing
Index corrupted.
====================================================================

If I press the "okay" or "cancel" button the pop-up keeps coming back. If I press the "reindex" button the pop-up will go away, but will come back when I reboot.

Any idea how to fix this or make the pop-up stay gone away?

Thanks in advance

einfeldt (einfeldt) wrote :

hi

On Sat, May 2, 2009 at 12:28 PM, tinker123 <email address hidden> wrote:

> Ubuntu 9.04: Tracker Applet Errors
>
> I just upgraded to Ubuntu 9.04.
>
> I keep getting a pop-up from the Tracker Applet that reads:

Yes, please follow the instructions in this thread. Please feel free to
email me again if you have any other questions:

http://ubuntuforums.org/showthread.php?p=7149477#post7149477

Patrik Jansson (patrikja) wrote :

This log was with the standard jaunty version - I didn't read properly
further up in the tread. I attach a log after an additional step:

wget https://edge.launchpad.net/~chrisccoulson/+archive/ppa/+files/tracker_0.6.93-0ubuntu2~chrisccoulson6_i386.deb

sudo dpkg -i tracker_0.6.93-0ubuntu2~chrisccoulson6_i386.deb

The log now contains the line you wanted, but there is no change to
the repeated dialogs (I guess that is because I have not updated any
of the other packages in the tracker family - I didn't know how to do
that properly - see next comment).

/Patrik

On Sun, 2009-05-03 at 03:38 +0000, einfeldt wrote:
> hi
>
> On Sat, May 2, 2009 at 12:28 PM, tinker123 <email address hidden> wrote:
>
> > Ubuntu 9.04: Tracker Applet Errors
> >
> > I just upgraded to Ubuntu 9.04.
> >
> > I keep getting a pop-up from the Tracker Applet that reads:
>
>
> Yes, please follow the instructions in this thread. Please feel free to
> email me again if you have any other questions:
>
> http://ubuntuforums.org/showthread.php?p=7149477#post7149477
>
Can people please provide some more information rather than following
the workarounds? We're trying to get this fixed, and all the workaround
does is make it more difficult to fix the actual problem. What I need
people to do is to install the version of tracker in jaunty-proposed (as
described here:
https://bugs.edge.launchpad.net/ubuntu/+source/tracker/+bug/361205/comments/28 ). As I've already pointed out, this doesn't stop the corruption from happening, but should make tracker resolve the corruption by reindexing automatically. If people testing this package still see the notification about an index error repeatedly, then please follow the instructions here to provide extra information: https://bugs.edge.launchpad.net/ubuntu/+source/tracker/+bug/361205/comments/44 .

As I've already said, I can't recreate these issues, so I'm relying on
other people to provide the information for me. If people ignore these
requests and just follow workarounds, then it will not be possible to
fix this bug.

Patrik Jansson (patrikja) wrote :

After removing the 1-package update
sudo dpkg --force-downgrade -i /var/cache/apt/archives/tracker_0.6.93-0ubuntu1_i386.deb
I updated the whole tracker familj (I think)
# added deb http://ppa.launchpad.net/chrisccoulson/ppa/ubuntu jaunty main
# to /etc/apt/sources.list.d/ChrisCoulson.list
sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 0x2ae9c88de6cfef9fddfb209e2524246b1cc723db
sudo apt-get update
sudo apt-get upgrade

After running the same test as above https://bugs.launchpad.net/ubuntu-release-notes/+bug/361205/comments/44 I did not get any dialogs, so I assume all is well with the (re)indexing. I attach the log after I interrupted it (it didn't exit for two hours or so).

/Patrik

Chris Coulson (chrisccoulson) wrote :

Patrick - thanks. It would be better if you installed the version in jaunty-proposed though, as instructed here: https://bugs.edge.launchpad.net/ubuntu/+source/tracker/+bug/361205/comments/28 , as you need the new tracker-applet to turn the notification dialog with actions in to a notification that requires no user intervention.

However, you say that notification dialog repeatedly came back again, even when asking to reindex? Your log confirms that with the new version you're running that all index files are actually deleted correctly, as predicted.

Once you have upgraded all packages from jaunty-proposed, could you please try again, but this time could you run "dbus-monitor 2>&1 /tmp/dbus.log" as the index error notification repeatedly appears, then attach the resulting file here. Again, this log is likely to contain some sensitive information, such as filenames, so please be aware of this before attaching.

Could you also tell me if the tracker-indexer process exits at any point whilst these notifications are appearing? I might be able to tell if this is the case by looking at the log file you provide, but I'm not sure. A good tell-tale sign that tracker-indexer never exits is that it's PID will remain the same.

Thanks

On Sun, May 3, 2009 at 10:51 AM, Chris Coulson
<email address hidden> wrote:
> Patrick - thanks. It would be better if you installed the version in
> jaunty-proposed though, as instructed here:
> https://bugs.edge.launchpad.net/ubuntu/+source/tracker/+bug/361205/comments/28
> , as you need the new tracker-applet to turn the notification dialog
> with actions in to a notification that requires no user intervention.
Done. No reindexing message at all. All seems to work. (Except for
another detail - a small word-file which causes wvWare look.)

> However, you say that notification dialog repeatedly came back again,
> even when asking to reindex?

No, that was when only tracker was updated, not the other associated
ChrisCoulson-tracker-packages.

> Your log confirms that with the new version
> you're running that all index files are actually deleted correctly, as
> predicted.

> Once you have upgraded all packages from jaunty-proposed, could you
> please try again, but this time could you run "dbus-monitor 2>&1
> /tmp/dbus.log" as the index error notification repeatedly appears, then
> attach the resulting file here. Again, this log is likely to contain
> some sensitive information, such as filenames, so please be aware of
> this before attaching.

I have run this, but I don't get any reindexing dialogs and the log
file is around 100Mb - do you need it?

> Could you also tell me if the tracker-indexer process exits at any point
> whilst these notifications are appearing? I might be able to tell if
> this is the case by looking at the log file you provide, but I'm not
> sure. A good tell-tale sign that tracker-indexer never exits is that
> it's PID will remain the same.

This looks like you wanted the tracker log _and_ the dbus-log. I only
collected the dbus-log this time.

I would guess my index is OK by now, so I'm not sure it is any use to
rerun anything on this machine.

I may get a chance to do this on another machine at home, which seems
to have the same "reindexing dialog" problem.

/Patrik

> Thanks
>
> --
> Tracker uses notifications with actions when the index is corrupt
> https://bugs.launchpad.net/bugs/361205
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Chris Coulson (chrisccoulson) wrote :

Your second log file there Patrik suggests that the tracker-indexer is not running or is not responding - this probable explains why you see no more index error notifications. So, I'm ot yet convinced that it is fixed for you, and I think I understand the issue here.

Changed in tracker (Ubuntu Jaunty):
status: Fix Committed → In Progress
Chris Adams (acdha) wrote :

On Thu, Apr 30, 2009 at 12:58 PM, Chris Coulson
<email address hidden> wrote:
> Chris - file-index-update.db won't get deleted on reindex because
> tracker no longer uses that file (since 0.6.93). The presence of that

Sorry about the delay - I checked and the stale file is indeed
file-update-index.db, so it makes sense that it's not being removed
now. I can no longer reproduce the failure with my old copy of
~/.cache (I did verify that the indexer is running & scanning new
files) - I wish that I had thought to save a copy of
~/.local/share/tracker as it now seems likely that the problem was
triggered from there.

Chris

Chris Coulson (chrisccoulson) wrote :

Chris,

It's unlikely there was anything in ~/.local/share/tracker causing an issue - everything in there gets erased on reindex already. I still think your issue is more likely to be that tracker-indexer is not shutting down with the daemon when a reindex is initiated. But, as I can't recreate the problem, I need someone else to help me out with that ;)

Could someone still experiencing the repeated notifications with the new version in jaunty-proposed please provide me with a log of dbus activity (dbus-monitor 2>&1 ~/dbus.log) whilst it is happening and also tell me if the tracker-indexer process terminates after each index error notification (evident by the PID changing)

markling (markling) wrote :

I had an error report like this from Tracker Applet this morning:

"
Tracker
There was an error while performing indexing
Index corrupted
"

It asked me if I wanted to [reindex], [cancel] or [OK]

Neither [cancel] nor [OK] worked. The error window just popped right back at me like it was the terminator. I'd rather not ask it to reindex because i have no idea what it is and my machine's already running like an old dog since i installed Jaunty the other day.

This may have some bearing on the matter: I had an external drive connected the day before yesterday.

m.

I had the same issue after using a usb card. I think the problem is related
with that.

On Fri, May 8, 2009 at 9:06 AM, markling <email address hidden>wrote:

> I had an error report like this from Tracker Applet this morning:
>
> "
> Tracker
> There was an error while performing indexing
> Index corrupted
> "
>
> It asked me if I wanted to [reindex], [cancel] or [OK]
>
> Neither [cancel] nor [OK] worked. The error window just popped right
> back at me like it was the terminator. I'd rather not ask it to reindex
> because i have no idea what it is and my machine's already running like
> an old dog since i installed Jaunty the other day.
>
> This may have some bearing on the matter: I had an external drive
> connected the day before yesterday.
>
> m.
>
> --
> Tracker uses notifications with actions when the index is corrupt
> https://bugs.launchpad.net/bugs/361205
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Ed Iglehart (tipiglen) wrote :

Chris, I tried (dbus-monitor 2>&1 ~/dbus.log) as suggested, and got an error:
ed@ubuntu:~$ dbus-monitor 2>&1 ~/dbus.log
Failed to setup match "/home/ed/dbus.log": Match rule has a key with no subsequent '=' character

9.04 jaunty; 2.6.28-11-generic; gnome 2.26;
Hardware: Fujitsu-Siemens AmiloD 1845
497.4 GiB RAM CPU: 2x Mobile Pentium4 3.2GHz

Can you provide me with clear instructions? I will then load up a set of external data and see if the problem re-occurs.

I've had this problem since upgrading to Jaunty. I've installed tracker-utils and done the tracker-process -r thing, and I've de-selected indexing in system/preferences/search and indexing.

Now I have no problems until I use an external data source, e.g. photos via usb. Then I get the old immortal popup. I can just ignore it and leave it in the background, but the machine does slow down, and eventually I either re-boot or it shuts itself down.

I've yet to try also shutting it out via system/preferences/startup applications.

Here's hoping!
ed

Ryan Steele (rgsteele) wrote :

Anyone who is still seeing the popup with "OK/Cancel/Start Reindexing" has not installed the proposed fix from the "jaunty-proposed" repository. The instructions for doing so are here:

https://wiki.ubuntu.com/Testing/EnableProposed

Also, the correct command for logging dbus activity is:

dbus-monitor > ~/dbus.log 2>&1

But please don't comment on this bug unless you have enabled the "jaunty-proposed" repository, installed the updated version of tracker, and restarted your system. I suspect everyone who is still having issues hasn't actually installed the proposed fix.

For my part, I upgraded two PCs to Jaunty and had the repeated reindexing dialogs issue on both of them. Installing the update fixed the problem on both of them.

The jaunty proposed version is 0.6.93-obuntu2.
The earlier version is 0.6.93-obuntu1.

If you enable jaunty-proposed, be careful. If you allow all jaunty-proposed upgrades to take place, you may have other problems. It's best to enable jaunty proposed, update all tracker packages with the version 0.6.93-obuntu2, then disable jaunty proposed.

The contents of the jaunty-proposed repository are "beta" or "experimental" or "test", and some of these upgrades can have unintended consequences.

When is it expected that the fix will make the main repository and be
released as part of a normal update?

keepitsimpleengr wrote:
> The jaunty proposed version is 0.6.93-obuntu2.
> The earlier version is 0.6.93-obuntu1.
>
> If you enable jaunty-proposed, be careful. If you allow all jaunty-
> proposed upgrades to take place, you may have other problems. It's best
> to enable jaunty proposed, update all tracker packages with the version
> 0.6.93-obuntu2, then disable jaunty proposed.
>
> The contents of the jaunty-proposed repository are "beta" or
> "experimental" or "test", and some of these upgrades can have unintended
> consequences.
>

Chris Coulson (chrisccoulson) wrote :

On Fri, 2009-05-08 at 16:49 +0000, swulf wrote:
> When is it expected that the fix will make the main repository and be
> released as part of a normal update?
>
When it works reliably under all conditions. At the moment, some testers
still have issues even with the updated version.

Regards
Chris

Chris Coulson (chrisccoulson) wrote :

On Fri, 2009-05-08 at 16:49 +0000, swulf wrote:
> When is it expected that the fix will make the main repository and be
> released as part of a normal update?

When it works reliably under all conditions. At the moment, some testers
still experience problems even with the updated version.

Regards
Chris

Chris Coulson (chrisccoulson) wrote :

Sorry, silly mail client tricked me in to sending the same message twice;)

Chris Coulson (chrisccoulson) wrote :

I've uploaded an updated version of tracker in to my PPA (0.6.93-0ubuntu3~chrisccoulson1). This should make the indexer exit after detecting an error with the index. Could anyone still experiencing the issues here with the version in jaunty-proposed please try that version and report back.

Thanks

Chris Coulson (chrisccoulson) wrote :

Can anyone try this package out?

Ed Iglehart (tipiglen) wrote :

So far as I'm concerned, the problem has gone away.
My Synaptic manager tells me I have 0.6.93-0buntu1 installed.

I did enable jaunty-proposed and update, and then disabled jaunty-proposed, but I seem to have the "official" version in place. In any event, there have been no problems since.

markling (markling) wrote :

scuse me, chris. i don't mean to be rude. i've also not had the problem
arise again for a couple of days. i've hesitated to implement the
package because this being the only machine on which i can earn a
living, i'm reluctant to risk a spanner in its works. and having just
made the transition from user to bug reporter i think its too soon just
yet to beta testing anything but urgent fixes.

all the best

m.

Chris Coulson wrote:
> Can anyone try this package out?
>

Chris Coulson (chrisccoulson) wrote :

Right, but the problem is likely to arise again. My package isn't going to cause you any harm, and if people aren't prepared to test it then the bug simply just won't be fixed.

teledyn (garym-teledyn) wrote :

Markling, we feel your pain but please understand that this is opensource; there is no such thing as a "production release" it is ALL beta-testing; you and I and Chris are all of us the QA dept, the Dev Shop and the Consumer, rolled into one -- we're all in this together. that's the whole point ;)

fortunately, these days, with semi-intelligent package managers like apt, it is relatively easy to remove and re-install (and roll-back) individual packages, esp something like trackerd that has few dependencies, so the danger to your workstation is minimal, although yes, it will cost a bit of your time.

but that is the point of opensource; each of us contributes what we can and together we make the magic happen :)

swulf (swulf) wrote :

teledyn wrote:
> Markling, we feel your pain but please understand that this is
> opensource; there is no such thing as a "production release" it is ALL
> beta-testing; you and I and Chris are all of us the QA dept, the Dev
> Shop and the Consumer, rolled into one -- we're all in this together.
> that's the whole point ;)
>
> fortunately, these days, with semi-intelligent package managers like
> apt, it is relatively easy to remove and re-install (and roll-back)
> individual packages, esp something like trackerd that has few
> dependencies, so the danger to your workstation is minimal, although
> yes, it will cost a bit of your time.
>
> but that is the point of opensource; each of us contributes what we can
> and together we make the magic happen :)
>

I have been contributing Ubuntu bug reports for a while, but probably
less usefully than I could and certainly with some fear regarding
testing packages. I would like to help more but I don't know how to
(safely).

Is there a straightforward guide to the processes, issues and pitfalls
that may be encountered? For example, how and when should I switch to
the 'testing' release of Ubuntu; what is a PPA and how do I use it? What
'tips and tricks' should we be aware of?

Like many others out there I want to help fix these issues - things then
work better for us, after all - but I simply lack the necessary
background and experience, and want to minimize the risk of
catastrophically breaking something in my learning attempts.

teledyn (garym-teledyn) wrote :

as a general rule I'd say leave the testing releases of Ubuntu itself to the experts, unless you have a spare machine kicking about -- but for testing individual packages, esp where the existing package is a real show-stopper (like this one) you can judge how dangerous it might be when you try to remove the package that is causing the problems. In this case, removing the tracker package only involves a few other packages that all have 'tracker' in the name, so they are highly unlikely to cause any upset. On the other hand, if you tried to remove some package and discovered it wanted to take a dozen packages with it, and especially if many are general-use lib* packages, I'd say again, best leave it to the experts ;)

As for how to do this: the link Chris gave to the PPA contains full instructions, but what is maybe not clear is that you have to click on that odd hexadecimal key number and follow the links to get to his public key, then save that to a text file and install it in the package manager according to the instructions.

swulf (swulf) wrote :

teledyn wrote:
> as a general rule I'd say leave the testing releases of Ubuntu itself to
> the experts, unless you have a spare machine kicking about -- but for
> testing individual packages, esp where the existing package is a real
> show-stopper (like this one) you can judge how dangerous it might be
> when you try to remove the package that is causing the problems. In
> this case, removing the tracker package only involves a few other
> packages that all have 'tracker' in the name, so they are highly
> unlikely to cause any upset. On the other hand, if you tried to remove
> some package and discovered it wanted to take a dozen packages with it,
> and especially if many are general-use lib* packages, I'd say again,
> best leave it to the experts ;)
>
> As for how to do this: the link Chris gave to the PPA contains full
> instructions, but what is maybe not clear is that you have to click on
> that odd hexadecimal key number and follow the links to get to his
> public key, then save that to a text file and install it in the package
> manager according to the instructions.
>

OK, well, I will try and help by testing it and seeing how I get on.

mbana (m.bana) wrote :

can someone please just tell me how to stop this? can i just uninstall it?

i'm so tempted to just reformat and use interpid instead, as i'm also having troubles starting xmonad automatically.

btw, i'm shocked such an issue went unnoticed.

On Fri, 2009-05-15 at 17:12 +0000, mbana wrote:
> can someone please just tell me how to stop this? can i just uninstall
> it?
>
> i'm so tempted to just reformat and use interpid instead, as i'm also
> having troubles starting xmonad automatically.
>
> btw, i'm shocked such an issue went unnoticed.
>
If you read through this bug report, you will see that the issue has not
gone unnoticed. You could help by trying the package in my PPA [1]. The
package doesn't fix the corruption but should stop the annoying dialog
from repeatedly appearing, by correctly initiating a reindex and
clearing the problem. Once this has happened, the dialog notification
should not appear again, unless some other event corrupts the index.

Instructions for installing packages from my PPA can also be found on
the link to my PPA [1].

Thanks
Chris

[1] - https://launchpad.net/~chrisccoulson/+archive/ppa

Matt Harris (matthew-harris) wrote :

i have installed the package from your PPA, and the error has gone away, but now the issue is when i connect my Cowon S9 PMP player and use Exaile to play the music off of it, it causes the hard drive to grind, left it going for about 20 minutes and nothing happened, the hard drive just kept grinding, playlist did not load, Exaile didn't even seem to be trying to load anything. i have not had a chance to test this on other programs from other sources yet.

thanks for you hard work Chris.

Chris Coulson (chrisccoulson) wrote :

Matt- thank you for testing. The other issue you experience is likely because Tracker begins indexing removable media (if you have indexing enabled). If you have indexing disabled, it won't begin to index removable media (although the current Jaunty version will, due to another bug that this PPA version fixes).

If you want indexing enabled but don't want to index removable media, you can disable this in the preferences (System -> Preferences ->Search and Indexing -> FIle and the uncheck "Index mounted directories").

Thanks

Laura Cowen (lauracowen) wrote :

I've installed from the PPA and I think it's all fine now. The irritating message isn't popping up any more and the tracker seems to be indexing okay.

Thanks for your help. :)

swulf (swulf) wrote :

Hi,

OK, I have added your PPA to Synaptic and I am at the state shown in the attached screenshot. Which of the packages should I reinstall? All of them?

swulf: Yes, you should *upgrade* all of tracker packages - but no need for a screenshot to ask for that... :-D

Milan wrote:
> swulf: Yes, you should *upgrade* all of tracker packages - but no need
> for a screenshot to ask for that... :-D
>

Right - but I like to be sure =)

swulf (swulf) wrote :

Milan wrote:
> swulf: Yes, you should *upgrade* all of tracker packages - but no need
> for a screenshot to ask for that... :-D
>

OK, it's done. I rebooted (Windows habits die hard) and Tracker is
reindexing now. No errors as yet.

fred lonauer (sumperer) wrote :

I upgraded the tracker-packages from "jaunty proposed". Reindexed all (deleted ~/.cache/tracker before). No errors since 3 hours!

I think, you've got it!
Thanks!

swulf (swulf) wrote :

Tracker is idle, seems to work - can search. Looks like it may be fixed!

On Sat, 2009-05-16 at 20:24 +0000, swulf wrote:
> Tracker is idle, seems to work - can search. Looks like it may be fixed!
>

The updated package doesn't actually fix the corruption issues, and that
may reoccur. It should make sure that if index corruption is detected,
re-indexing happens automatically and the error is cleared.

Thanks for testing everybody.

It's an improvement not to have that error dialog popping up.

Thanks for the work you are doing on this issue. =)

Chris Coulson wrote:
> On Sat, 2009-05-16 at 20:24 +0000, swulf wrote:
>> Tracker is idle, seems to work - can search. Looks like it may be fixed!
>>
>
> The updated package doesn't actually fix the corruption issues, and that
> may reoccur. It should make sure that if index corruption is detected,
> re-indexing happens automatically and the error is cleared.
>
> Thanks for testing everybody.
>

frank (frank-berghaus) wrote :

The version in Jaunty proposed fixed the issue for me (tracker re-indexed everything and I can search now). I attached my dbus log from letting the tracker re-index over the weekend ... just in case you still need the log.

markling (markling) wrote :

teledyn, i'm with you all the way.

yes, we are all in it together. yes, each of us contributes what we can.
that is the beauty of open source, that both of these statements can be
true; that those who can only contribute a little are not denied an
equal share of the produce of our combined effort.

even those people who only have the time and knowledge to *use* linux
are making an invaluable contribution. its a big step for non-technical
users weaned on microsoft to make. many of these users also contribute
in other areas, in answer to other responsibilities, in different ways.
we cannot presume to know their priorities.

so three cheers for those who have contributed so much to make it work
and, like chris, continue to do so. three cheers also for those for whom
contributing what they can is not so much, but still as much as they can.

:)

teledyn wrote:
> Markling, we feel your pain but please understand that this is
> opensource; there is no such thing as a "production release" it is ALL
> beta-testing; you and I and Chris are all of us the QA dept, the Dev
> Shop and the Consumer, rolled into one -- we're all in this together.
> that's the whole point ;)
>
> fortunately, these days, with semi-intelligent package managers like
> apt, it is relatively easy to remove and re-install (and roll-back)
> individual packages, esp something like trackerd that has few
> dependencies, so the danger to your workstation is minimal, although
> yes, it will cost a bit of your time.
>
> but that is the point of opensource; each of us contributes what we can
> and together we make the magic happen :)
>

Babbino06 (teoden44) wrote :

I'm sorry, I click on "also added project" instead of "subscribe". Could someone correct my error? Thanks!

Sorry again.

Changed in tracker:
status: New → Invalid
Chris Coulson (chrisccoulson) wrote :

Here is an updated debdiff for jaunty-proposed

Martin Pitt (pitti) wrote :

Accepted tracker into jaunty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in tracker (Ubuntu Jaunty):
status: In Progress → Fix Committed
tags: added: verification-needed
tags: removed: verification-failed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tracker - 0.6.93-0ubuntu3

---------------
tracker (0.6.93-0ubuntu3) jaunty-proposed; urgency=low

  * 2 new patches from upstream to fix LP: #361205:
    - debian/patches/22_flush_stop_on_index_error.patch:
      + Make sync/async flush functions to stop on any error.
    - debian/patches/23_indexer_pause_on_index_error.patch:
      + Add new "index error" indexer status and pause the indexer
        on index error.

 -- Chris Coulson <email address hidden> Thu, 04 Jun 2009 21:49:31 +0100

Changed in tracker (Ubuntu Jaunty):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Copied jaunty-proposed to karmic.

Changed in tracker (Ubuntu Karmic):
status: In Progress → Fix Released
Petr_Kosv (karrrolina) wrote :

I downloaded plus ungzipped tracker_0.6.93.orig.tar.gz and read its readme. I didn't kill the elder buggy trackerd. To configure new installation of trackerd first I ran - by mistake - : sudo ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --enable-deskbar-applet=auto --with-deskbar-applet-dir=/usr/lib/deskbar-applet/{handlers,modules-2.20-compatible}. ("sudo" wasn't supposed to be there + the last two items were to intsall trackerd's deskbar applet.)

Secondly, trackrd's config.log did not allow me to run configuration anew correctly without the "sudo". I deleted the config.log and started anew correctly: ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --enable-deskbar-applet=auto --with-deskbar-applet-dir=/usr/lib/deskbar-applet/{handlers,modules-2.20-compatible}. In the configuration process I had to add these packages via synaptic package manager: zlib1g-dev, libgliv2.0-dev, libpango1.0-dev, libgmime-..., libdbus1-dev + libdbus-glib-1, intltool, libhal-storage-dev, libxml2-dev, libsqlite3-dev, starting the configuration abt ten times.

Then the configuration process finished successfully and printed on screen that I make sure sqlite is made or intsalled with a special attribute (for the deskbar applet to work, I suppose). (I failed to save the attribute details.) - Not knowing how to do that I ommited this.

Finally I ran "make" and "sudo make install" successfully.

However, the bug, the trackerd's obtrusive three-item choice (reindex / cancel / ok), eating 99-100% of cpu resources, is back as soon as I stick my usb in the laptop.

As you can see I'm a layman and will be grateful for any tip.

Petr: No need to go through such a painful process to test this package. ;-) As Martin posted above, just read the instructions at https://wiki.ubuntu.com/Testing/EnableProposed.

I think the way you installed Tracker did not replace the old one but installed it side-by-side with the old one. The best is to revert to the previous system state by running 'sudo make uninstall' form the directory where you uncompressed Tracker's sources. Then run 'sudo apt-get install tracker', and check that the version you have is the right one.

Petr_Kosv (karrrolina) wrote :

Milan: Thank you for your kind advice. It helped me a lot. Uninstalled as you kindly wrote and let your update service /etc/apt/sources.list: deb http://archive.ubuntu.com/ubuntu/ jaunty-proposed restricted - update the laptop. Though I don't know how to check the version, the bug is gone. Also the link is highly helpful (I overlooked it above, or read it days ago and forgot). It is thanks to people like you and those above that I can use this wonderful Ubuntu and learn, too. Thank you.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers