tracker just always reports "There was an error while perfoming indexing: index corrupted"

Bug #369832 reported by Albert Zeyer on 2009-04-30
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tracker (Ubuntu)
Undecided
Unassigned

Bug Description

After the update from Ubuntu 8 to Ubuntu 9, I always get the message "There was an error while perfoming indexing: index corrupted".

I clicked for about 20 times on "Reindex all contents" but I get the same message again immediatly. Clicking "OK" has the same behaviour. I cannot make the message disappear.

I have this problem on 2 different computers.

Albert Zeyer (albertzeyer) wrote :
Albert Zeyer (albertzeyer) wrote :

Under System / Settings / Indexing, I disabled the indexing completly but I still get the message.

d0m (dominic-innocent) wrote :

Hi
I've had the same problem & tried unloading & reloading "Tracker" search tool, but that didn't work for long. It reappeared after it had done its 'initializing'!
Thanks
d0m.

Matt Harris (matthew-harris) wrote :

i am having the same issue, but only when i connect a external storage device, like my Cowon MP3 player or a 2gb microSD card. the issue continues even after unplugging the devices, the only way i've found to stop it kill the process from the system monitor.

HP Laptop dv6000, upgraded from 8.10 64bit to 9.04 RC1.

Mark Brown (broonie) wrote :

I'm seeing this with Jaunty, tracker 0.6.93-0ubuntu1.

teledyn (garym-teledyn) wrote :

same as the above reports; I thought I had disabled it but it returned just now when I plugged in an external storage. I never use the tracker (I already KNOW what's in my home dir) so a workaround to just remove the program will suffice.

I tried to add my HOME dir under Ignored Paths and there is a long pause before I get the file dialog, then when I select my home dir it tells me that it cannot create that dir! Seems to be a very buggy program -- it is currently consuming 58% of my CPU and it is disabled!

teledyn (garym-teledyn) wrote :

was able to remove the package using synaptic, so I think I found my work-around, but thought the following from the tracker log might be important:

~/.local/share/tracker/trackerd.log

11 May 2009, 23:35:11: Tracker-Critical **: Couldn't set mount point state, Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

Ivan Frade (ivan-frade) wrote :

@teledyn The problem behind that Critical message has already been fixed in the upstream code, and it will be available in 0.6.95 release.

About the "Error while performing indexing", it could be caused because the tracker-indexer process crash, it is started again by trackerd, and it finds index file is corrupted. It means that:
1) tracker needs to handle the "corrupted index" situation correctly and
2) please report all crashes you can find in the tracker-indexer process to minimize the frequency of this problem.

Chris Coulson (chrisccoulson) wrote :

thank you for your bug report. The index corruption issue is bug 346912. The error notification not being able to be dismissed is bug 361205. The problem with indexing starting when you insert removeable media is also already reported as bug 359207.

If you still have the corrupt index around, please try the package in my PPA and leave a comment on bug 361205 (you should get the index error notification once, then it should automatically commence reindexing and the notification should not come back again)

Changed in tracker (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments