Ubuntu

E: The package cache file is corrupted E: _cache->open() failed, please report.

Reported by Larry Martin on 2008-08-13
244
This bug affects 23 people
Affects Status Importance Assigned to Milestone
PackageKit
Fix Released
Undecided
Unassigned
compiz-fusion-plugins-main (Ubuntu)
Undecided
Unassigned
Jaunty
Undecided
Unassigned
packagekit (Ubuntu)
High
Michael Vogt
Jaunty
High
Michael Vogt
update-manager (Ubuntu)
Medium
Unassigned
Jaunty
Undecided
Unassigned

Bug Description

TEST CASE:
1. I was not able to find a reliable way to reproduce the problem so please test for regressions
2. if you are a user affected by this problem, please install the update from jaunty-proposed (when it becomes available) and report if it fixes the problem

E: The package cache file is corrupted
E: _cache->open() failed, please report.

Got this error msg. when running the update mgr. I have Ibex alpha 3 w/all the available updates running on a Sempron 2400 PC that has 1.5GB of SDRAM w/a 8x AGP 256MB 9600XT Radeon Video Card

Benjamin Drung (bdrung) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Which program produces this output?

jms (jms) wrote :

For me, update-manager produces that error message when I run it manually.

Michael Vogt (mvo) wrote :

Thanks for additional information.

Does this always happen when you start update-manager? Or only when you try to install updates? Or only sometimes?

Changed in update-manager:
assignee: nobody → mvo
jms (jms) wrote :

Sorry for delay, I forgot to subscribe this bug.

No, it won't happen always. As far as I have noticed it happens when there is new updates available, but not every time even in that case.

claudio (private-claudio) wrote :

For me it happens in synaptic when I do a reload. But when I restart synaptic I see the packages which need to be updated and can install them without problems. This started to happen a 1-2 weeks ago.

$ dpkg-query -W synaptic
synaptic 0.62.1ubuntu9

I haven't seen any problems yet, when doing an apt-get update.

Erick Brunzell (lbsolost) wrote :

I experienced this identical problem this morning while the update manager ran. Still got updates OK and no errors in apt when I run update, upgrade or -f install.

All seems to be working properly otherwise (except for ongoing CD eject problem).

Erick Brunzell (lbsolost) wrote :

Well, I replied to this bug report before but don't see my response now.

Anyway I'm pretty sure it's a Medibuntu thing!

About 95% sure!

Bevan (bevan-bi-co) wrote :

I can't confirm this. I use ubuntu 8.10 beta (no fresh installation but an updated Hardy) and hat the same message a few times now. Update manager did his work anyway...

Juksu (jluostar) wrote :

I keep getting this in update manager whenever there are new updates.
It is resolved by running sudo dpkg --reconfigure -a in terminal. But the error msg keeps popping up from time to time. Everything seems to work, however, despite this message (the updates get installed).
Using ubuntu 8.10 final.

lunomad (damon-metapaso) wrote :

I get this same message almost every time I use "Software Sources" in the following scenario:

After adding a new source, or removing a source, I then reload. All the package information seems to download, but then then this error pops up.

I then switch to terminal and do
sudo apt-get update

and everything appears fine.

Michael Vogt (mvo) on 2008-11-07
Changed in update-manager:
importance: Undecided → High
milestone: none → intrepid-updates
status: Incomplete → Triaged
Michael Vogt (mvo) wrote :

Thanks for your bugreport.

Could you please run:
$ apt-config dump|grep Update

Could you also please check if you have "packagekit" installed ?

Michael Vogt (mvo) wrote :

I suspect that this is a race condition between synaptic read the package cache and packagekit. Packagekit gets a org.freedesktop.PackageKit.StateHasChanged "cache-update" signal when synaptic finishes its reload operation. This is a bug that seems to be caused by improper locking.

I would welcome if you could check if you have packagekit installed when the error happens.

claudio (private-claudio) wrote :

I have packagekit installed. This is the situation in my case:

$ apt-config dump|grep Update
APT::Periodic::Update-Package-Lists "1";
APT::Update "";
APT::Update::Post-Invoke-Success "";
APT::Update::Post-Invoke-Success:::: "touch /var/lib/apt/periodic/update-success-stamp 2>/dev/null || true";
APT::Update::Post-Invoke-Success:: "/usr/bin/dbus-send --system --dest=org.freedesktop.PackageKit --type=method_call /org/freedesktop/PackageKit org.freedesktop.PackageKit.StateHasChanged string:'cache-update'";

$ dpkg-query -W packagekit
packagekit 0.3.6-0ubuntu4

I have now removed packagekit and will see if the problem occurs again or not.

The difficulty is though the problem occurred with me only when there was some software to update, something which happened frequently while intrepid was in development, but now will happen less often.

lunomad (damon-metapaso) wrote :

I managed to re-create the error, although today it took me a few tries. I realized that perhaps I'm the cause of the problem. Specifically, the error occurs after the following steps:
1) In "Software Sources", enable a new source (e.g. ppa.launchpad development package), close, and reload.
2) Launch update manager (either manually or automatically) ---> new updates appear
3) Launch "Software Sources" again while update manager is open, but before installing the updates, disable the same source, close and reload
4) Error pops up.

Here is the CLI output:

:~$ apt-config dump | grep Update
APT::Periodic::Update-Package-Lists "1";
APT::Update "";
APT::Update::Post-Invoke-Success "";
APT::Update::Post-Invoke-Success:::: "touch /var/lib/apt/periodic/update-success-stamp 2>/dev/null || true";
APT::Update::Post-Invoke-Success:: "/usr/bin/dbus-send --system --dest=org.freedesktop.PackageKit --type=method_call /org/freedesktop/PackageKit org.freedesktop.PackageKit.StateHasChanged string:'cache-update'";

:~$ dpkg -l | grep packagekit
ii gstreamer0.10-packagekit 0.3.6-0ubuntu4 GStreamer plugin to install codecs using Pac
ii libpackagekit8 0.3.6-0ubuntu4 Library for accessing PackageKit
ii packagekit 0.3.6-0ubuntu4 provides a software installation daemon
ii packagekit-backend-apt 0.3.6-0ubuntu4 APT backend for packagekit

If the error occurs again in a different situation, I will be sure to note why.

Juksu (jluostar) wrote :

I have exactly the same outputs as claudio and lunomad.

Michael Vogt (mvo) wrote :

I move this to packagekit for now, but I suspect it is really a problem in python-apt with improper locking.

I have the same problem.

I think indeed it has to do with Edubuntu.

greetings
Frans

claudio (private-claudio) wrote :

On 2008-11-07 I had removed packagekit and from then on never saw the error message again even though I had several occasions where an update in synaptic resulted in update packages becoming available. A few days ago I installed packagekit again and today when performing a reload in synaptic I again received the error message. Thus I can confirm it happens only when packagekit is present.

Jean Gold (jean-gold) wrote :

Hello,

Sorry, but I don't think it has to do with Edubuntu because
I've got the same problem with Intrepid (simple release,
generic kernel, but upgraded to 2.6.27-11-generic). As for
me I wondered wether it had to do with that kernel ?
Is it also yours for now ? ("uname -r" to check).
Please let me now, it might mean we have to wait for
the next kernel release....
greetings
jehanx

Jean Gold (jean-gold) wrote :

I dont'understand,
looking for a solution I read [solved] at this forum
and nobody gives a solution........

I have the same bug.
Aspire 3683NWXCi
Intel Celeron M Processor 430
Mobile Intel 940 GML Express Chipset

> Date: Tue, 30 Dec 2008 17:22:10 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 257639] Re: E: The package cache file is corrupted E: _cache->open() failed, please report.
>
> I dont'understand,
> looking for a solution I read [solved] at this forum
> and nobody gives a solution........
>
> --
> E: The package cache file is corrupted E: _cache->open() failed, please report.
> https://bugs.launchpad.net/bugs/257639
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “packagekit” source package in Ubuntu: Triaged
>
> Bug description:
> E: The package cache file is corrupted
> E: _cache->open() failed, please report.
>
> Got this error msg. when running the update mgr. I have Ibex alpha 3 w/all the available updates running on a Sempron 2400 PC that has 1.5GB of SDRAM w/a 8x AGP 256MB 9600XT Radeon Video Card

_________________________________________________________________
Nieuw: nu ook chatten op je mobiel!
http://www.overaljevriendenbijje.nl/#superdeal

Jean Gold (jean-gold) wrote :

Hello Frans,

I was speaking about Linux kernel, that is what is loaded in high memory when booting up.
When one makes an update, if there is a new release of it and if you have checked the option
"pre-release update" in the sources manager, even for a not very important upgrade
you are proposed a partial upgrading. Since I met the bug only after my last kernel upgrade
I supposed it could be bound with that.
The fact is that the bug mainly happens for me when I manually uninstall an application
after testing it or using synaptic or when the sources manager updates before closing.
greetings

Jehanx

Hi Jehanx,

Thank you for the reply.

Will try this of course

greetings
frans

> Date: Wed, 31 Dec 2008 08:26:28 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 257639] Re: E: The package cache file is corrupted E: _cache->open() failed, please report.
>
> Hello Frans,
>
> I was speaking about Linux kernel, that is what is loaded in high memory when booting up.
> When one makes an update, if there is a new release of it and if you have checked the option
> "pre-release update" in the sources manager, even for a not very important upgrade
> you are proposed a partial upgrading. Since I met the bug only after my last kernel upgrade
> I supposed it could be bound with that.
> The fact is that the bug mainly happens for me when I manually uninstall an application
> after testing it or using synaptic or when the sources manager updates before closing.
> greetings
>
> Jehanx
>
> --
> E: The package cache file is corrupted E: _cache->open() failed, please report.
> https://bugs.launchpad.net/bugs/257639
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “packagekit” source package in Ubuntu: Triaged
>
> Bug description:
> E: The package cache file is corrupted
> E: _cache->open() failed, please report.
>
> Got this error msg. when running the update mgr. I have Ibex alpha 3 w/all the available updates running on a Sempron 2400 PC that has 1.5GB of SDRAM w/a 8x AGP 256MB 9600XT Radeon Video Card

_________________________________________________________________
Jouw nieuws en entertainment, vind je op MSN.nl!
http://nl.msn.com/

Jessica Doyle (jlhdoyle) wrote :

I have also received this error message on an Acer Aspire One running Ubuntu 8.10 (with some extra packages recommended for netbooks). I do NOT have packagekit installed.

When I enter "apt-config dump|grep Update" I get:
APT::Periodic::Update-Package-Lists "1";
APT::Update "";
APT::Update::Post-Invoke-Success "";
APT::Update::Post-Invoke-Success:::: "touch /var/lib/apt/periodic/update-success-stamp 2>/dev/null || true";

I only get this message when I run Update Manager manually. If I check packages a second time after receiving the error message I do not get the error message again.

One note -- I got the error message today (the update it was trying to get me was to acpi-support) and promptly lost my wireless connection, and when I restarted the computer failed to recognize my wireless card. (I had to download the madwifi driver to get it to see the wireless card in the first place.) That may be a complete coincidence.

Jean Gold (jean-gold) wrote :

Hello Jessica,

For me the problem seems to be solved since, by chance because of a
different error,
I happened to use "check" as a gParted function.
Try to do the same (if you don't have it : wget-install gparted)
1) run gParted
2) unmount your Linux partition
3) open the menu "Partition - Check"
4) when finished (normally you'll be advised of successful operation)
remount your partition
5) better reboot and everything should be ok, if not re-install your
default sources list.
Greetings
Jean

Jessica Doyle a écrit :
> I have also received this error message on an Acer Aspire One running
> Ubuntu 8.10 (with some extra packages recommended for netbooks). I do
> NOT have packagekit installed.
>
> When I enter "apt-config dump|grep Update" I get:
> APT::Periodic::Update-Package-Lists "1";
> APT::Update "";
> APT::Update::Post-Invoke-Success "";
> APT::Update::Post-Invoke-Success:::: "touch /var/lib/apt/periodic/update-success-stamp 2>/dev/null || true";
>
> I only get this message when I run Update Manager manually. If I check
> packages a second time after receiving the error message I do not get
> the error message again.
>
> One note -- I got the error message today (the update it was trying to
> get me was to acpi-support) and promptly lost my wireless connection,
> and when I restarted the computer failed to recognize my wireless card.
> (I had to download the madwifi driver to get it to see the wireless card
> in the first place.) That may be a complete coincidence.
>
>

Lödur (loedur) wrote :

Hallo,

this happens on Jaunty Jackalope Alpha 5, too.

Linux 2.6.28-8-generic #28-Ubuntu SMP Thu Mar 5 21:49:36 UTC 2009 i686 GNU/Linux

Aaron (apelly) wrote :

...and alpha 6

Martin Olsson (mnemo) wrote :

I just saw this on "pre-release jaunty as of march 25th". I have packagekit installed but at the time I was using "System::Administration::Update Manager"

Roosje (wilco-roos) wrote :

In jaunty, the removal of packagekit solves the problem, updates working smooth again. At least that is a temp workaround.

xalaros (skafidask) wrote :

i confirm that removing packagekit resolves the problem

Lulzim (lulzimbilali) wrote :

I have the same problem.
It happens when I run Update manager in the following scenario:
I run update manager
then I click check
after repositories are downloaded the error is shown
After the error the list of updates is refreshed and it looks to me like every thing works fine after.
If there are no updates the error doesn't show.

BTW I'm using ubuntu 9.04 Beta, it happens on Alpha 6 and most probably 5 as well.

All the Best
Lulzim

Santana (rigosantana3-gmx) wrote :

The report now has enough info to go to dev

Changed in update-manager (Ubuntu):
status: New → Confirmed
jdtiede (jdtiede) wrote :

This errer appeared when I tried to run sudo dpkg --configure -e. Just yesterday I downloaded over 100 updates and had not done much since.

Erick Brunzell (lbsolost) wrote :

I've experienced the same error in Jaunty Beta (both an upgrade from Intrepid and a fresh install). Removing packagekit gets rid of the error.

The error would present using Update Manager to "check" for updates, or when "reloading" Synaptic - (after reloading Synaptic and clicking Close on the error window Synaptic would also close).

In either instance the updates would be found and display properly for download/installation.

Apt is not effected.

Thura (trh) wrote :

Yep, it is still in Jaunty Beta.
I will try uninstalling packagekit.

Yannis Tsop (ogiannhs) wrote :

Removing kpackagekit solves the problem

Louis Simard (louis-simard) wrote :

Weirdly the problem occurs to me on my laptop as well. Using the Check button, and Install Updates again, rebuilds the cache and also works around this bug.

This is from a fresh install of Ubuntu 9.04 Beta, using the Update Manager GUI. apt-get update was *not* run before the GUI, nor had the update-notifier even appeared yet.

here is the fault I'm having here! The strange thing is out of 3 PC running Intrepid on mine seems to have this issue :(

kuser (nuca-nunca) wrote :

hello, just confirming, kubuntu jaunty alpha 6 32bit, having same trouble, purging kpackagekit helps.
thx

Arman (arman-jan) wrote :

In the past I updated via Package Manager so I don't know if the problem existed before that. However, in the past three days (including today) when I have ran Update Manager and have clicked "Checked" the first time, I received the same error as mentioned above.
Running Ubuntu 32Bit.

Steve Langasek (vorlon) wrote :

Michael,

The upload for this to jaunty appears to be a workaround for the locking problem, not a true fix? I'm reluctant to accept this change post-RC.

Martin Pitt (pitti) wrote :

Rejected, since it doesn't look like a proper fix, and there was no further explanation. Please reupload as SRU if this is really the correct solution; could you please give some further explanation about this? Thanks!

Michael Vogt (mvo) wrote :

@Martin, Steve: This is just a workaround. The problem is that there is a locking issue when both update-manager and packagekit try to rebuild the binary cache. The problem is that PK sends a signal right after any apt-get update run. The PK daemon rebuilds its binary cache at (roughly) the same time as e.g. synaptic (or update-manager). The upload works around this until the real lock issue if found. We have quite a few dups of this and the risk is low.

I'm preparing a different fix now.

Michael Vogt (mvo) wrote :

Here is a more advanced version. But I think for jaunty-updates we should just go with the workaround and understand the problem better for karmic. The race looks like its in libapt itself.

Zer0 (zero-nedlinux) wrote :

running jaunty over here.. what do i miss if i remove packagekit? this is solving the problem. Reading the packagekit description i still dont have the answer to my question.

I want to remove this to avoid errors, but what do im going to miss after removal?

Michael Vogt (mvo) wrote :

Workaround uploaded and waiting for approval

description: updated
Changed in packagekit (Ubuntu Jaunty):
status: Triaged → In Progress
Martin Pitt (pitti) wrote :

What listens to these signals? I. e. could anything break, or could any piece of UI hang because of the sleep 60?

If not, then this is probably okay as a workaround.

Martin Pitt (pitti) wrote :

This does not look at all related to compiz, closing task.

Changed in compiz-fusion-plugins-main (Ubuntu Jaunty):
status: New → Invalid
Martin Pitt (pitti) wrote :

Looks like we won't fix this at least in Jaunty's update-manager. Michael, please close the karmic task of update-manager if appropriate.

Changed in update-manager (Ubuntu Jaunty):
status: Confirmed → Won't Fix
Martin Pitt (pitti) wrote :

Accepted packagekit into jaunty-proposed-proposed; please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Zer0 (zero-nedlinux) wrote :

An update, yesterday i removed my NVIDIA drivers (1.80) compiz was disable after this. I did reinstall NVIDIA (180) enable compiz & now i dont get the corrupt cache anymore.

I reporting this since im reading about compiz over here. Im using jaunty (test)

Charlie Bounds (cbounds) wrote :

I installed proposed packagekit and have not seen the problem since. I reloaded the cache several times, both in the same and different sessions (and even different logons). Thank you.

Martin Pitt (pitti) on 2009-04-23
description: updated
tags: added: verification-done
removed: verification-needed
peter b (b1pete) wrote :

@Martin Pitt

it worked ok on the 2.6.28-8 kernel; however I did not try on the ....-11 kernel that was installed too because of #344406.

then I downloaded and installed the new released jaunty hoping that the problem reported on #344406 was somehow fixed/addressed. no joy so far. just for your info below is the output from the new jaunty install

cat /proc/partitions
major minor #blocks name

   8 0 488386584 sda
   8 1 35832951 sda1
   8 2 1 sda2
   8 3 24097 sda3
   8 5 16378236 sda5
   8 6 1020096 sda6
   8 7 33784663 sda7
   8 8 21486906 sda8
   8 16 244198584 sdb
   8 17 118784578 sdb1
   8 18 125411422 sdb2

re the newly installed jaunty (today's release) - it downloaded and installed the latest (some 5MB) OK, without the

E: The package cache file is corrupted
E: _cache->open() failed, please report.

message.

regards,
peter b

Martin Pitt wrote:
> Accepted packagekit into jaunty-proposed-proposed; please test and give
> feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed
> for documentation how to enable and use -proposed. Thank you in advance!
>
> ** Tags added: verification-needed
>
>
I have done what you have proposed and am still getting the error message:

E: The package cache file is corrupted
E: _cache->open() failed, please report.

M.

nakki (titibanjekistan) wrote :

I updated packagekit, python-packgekit, libpackagekit-glib11, libpackagekit-qt11, packagekit-backend-apt from the jaunty-proposed and I have not received the error message, for now. However the update-manager is SLOWER after updating the package informations.

Erick Brunzell (lbsolost) wrote :

Updated packagekit, packagekit-backend-apt, python-packagekit and libpackagekit-glib11 from 0.3.14-0ubuntu4 to 0.3.14-0ubuntu5 and all seems fine!

Using 0.3.14-0ubuntu5 on 9.04, I still see this error when using the graphical Add/Remove tool, but pkcon seems to work fine.

Alan Weeks (aweeks1) wrote :

I am getting about the same as Lulzim (1-4-09).

I run update-manager, get a couple of updates, then it says something is not up to date, & after it all finishes I see this error message.

I am not a Linux techie & have not attempted any remedy.

As requested:E: The package cache file is corrupted...

:~$ apt-cache policy update-manager
update-manager:
  Installed: 1:0.111.8
  Candidate: 1:0.111.8
  Version table:
 *** 1:0.111.8 0
        500 http://mirrors.us.kernel.org jaunty-updates/main Packages
        100 /var/lib/dpkg/status
     1:0.111.7 0
        500 cdrom://Ubuntu 9.04 _Jaunty Jackalope_ - Release i386 (20090420.1) jaunty/main Packages
        500 http://mirrors.us.kernel.org jaunty/main Packages

Martin Pitt (pitti) wrote :

Seems this isn't quite fixed yet then.

Changed in packagekit (Ubuntu):
milestone: intrepid-updates → none
Changed in packagekit (Ubuntu Jaunty):
milestone: intrepid-updates → jaunty-updates
Alan Weeks (aweeks1) wrote :

Since I loaded the "...jaunty proposed" file, the problem has not recurred.
Problem solved (so far!)

I set up tracker to index several mounted drives and left it to run overnight. The next morning I found an index failed notice. When I restarted the system, the tracker notification error occurred. (Bug https://bugs.launchpad.net/bugs/361205)

Then I ran update manager and the "The package cache file is corrupted E:" error occurred.

Upon rerunning, it did not occur.

I have installed the proposed fix for 361205, upgraded the following packages:
libtracker-gtk0 (0.6.93-0ubuntu1) to 0.6.93-0ubuntu2
libtrackerclient0 (0.6.93-0ubuntu1) to 0.6.93-0ubuntu2
tracker (0.6.93-0ubuntu1) to 0.6.93-0ubuntu2
tracker-search-tool (0.6.93-0ubuntu1) to 0.6.93-0ubuntu2
tracker-utils (0.6.93-0ubuntu1) to 0.6.93-0ubuntu2

Will watch to see if error reoccurs.

:~$ uname -a
Linux KISE-003 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009 i686 GNU/Linux
:~$ lsb_release -rd
Description: Ubuntu 9.04
Release: 9.04

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package packagekit - 0.3.14-0ubuntu5

---------------
packagekit (0.3.14-0ubuntu5) jaunty-proposed; urgency=low

  * debian/patches/15_cache_open.patch:
    - StateHasChange 'cache-update' gets a bigger timeout (LP: #257639)

 -- Michael Vogt <email address hidden> Wed, 22 Apr 2009 10:13:46 +0200

Changed in packagekit (Ubuntu Jaunty):
status: In Progress → Fix Released
Martin Pitt (pitti) wrote :

copied to karmic

Changed in packagekit (Ubuntu):
status: In Progress → Fix Released
Myroslav (mgalan) wrote :

Thanks,

I am no longer bothered by this bug.

Martin Pitt wrote:
> copied to karmic
>
> ** Changed in: packagekit (Ubuntu)
> Status: In Progress => Fix Released
>
>

Matt Burkhardt (matthewboh) wrote :

I'm running into this problem - but packagekit is NOT installed. I'm running a Dell Inspiron 6000 with Intrepid Ibex

 sudo aptitude show packagekit
Package: packagekit
State: not installed
Version: 0.3.6-0ubuntu4
Priority: extra
Section: universe/admin
Maintainer: Sebastian Heinlein <email address hidden>
Uncompressed Size: 1147k
Depends: libacl1 (>= 2.2.11-1), libarchive1 (>= 2.0.25), libattr1 (>= 2.4.41-1),
         libbz2-1.0, libc6 (>= 2.4), libdbus-1-3 (>= 1.0.2), libdbus-glib-1-2
         (>= 0.71), libglib2.0-0 (>= 2.16.0), libnm-glib0 (>= 0.7~~svn20080908),
         libpackagekit8 (= 0.3.6-0ubuntu4), libpolkit-dbus2 (>= 0.7),
         libpolkit-grant2 (>= 0.7), libpolkit2 (>= 0.7), libsqlite3-0 (>=
         3.5.9), zlib1g (>= 1:1.1.4), python, python-central (>= 0.6.7), dbus,
         packagekit-backend-apt | packagekit-backend-smart
Description: provides a software installation daemon
 PackageKit allows to perform simple software management tasks over a DBus
 interface e.g. refreshing the cache, updating, installing and removing software
 packages or searching for multimedia codecs and file handlers.

 The work is done by backends which make use of the package manager shipped by
 the corresponding distribution. PackageKit is not meant to replace advanced
 tools like Synaptic.

 The main benefits are:
 * unified interface on several distributions
 * fine grained privilleges by using PolicyKit
 * independecy from a running desktop session during the processing
Homepage: http://www.packagekit.org

Changed in update-manager (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
peter (peter-neuweiler) wrote :

Maybe I can give you a hint.

Most of the time I start the Update Manager and I get this error message, I can install one ore more packages.

Hope it helps.
Peter

Changed in packagekit (Ubuntu):
status: Fix Released → Confirmed
to be removed (liw) on 2009-08-05
Changed in packagekit (Ubuntu):
status: Confirmed → Fix Committed
status: Fix Committed → Fix Released
caplimajari (ii-kod) on 2009-08-19
Changed in update-manager (Ubuntu):
assignee: nobody → caplimajari (ii-kod)
Changed in update-manager (Ubuntu):
status: Triaged → Confirmed

@pietro, please don't change the status without an explanation.

Changed in update-manager (Ubuntu):
status: Confirmed → Triaged
savasten (savasten) on 2010-03-02
Changed in update-manager (Ubuntu):
status: Triaged → Fix Released
Changed in packagekit:
status: New → Fix Released
Martin Pitt (pitti) on 2010-03-02
Changed in update-manager (Ubuntu):
status: Fix Released → Triaged
Changed in packagekit (Ubuntu Jaunty):
status: Fix Released → New
Steve Langasek (vorlon) on 2010-03-21
Changed in packagekit (Ubuntu Jaunty):
status: New → Fix Released
alannew (alannew) wrote :

I have accidently erased the ## from vital package list, now all I get is E:_cache->open{}failed,please report.on 10.04 USB persistent and am pretty unable to fix this thanks

Changed in update-manager (Ubuntu):
assignee: caplimajari (ii-kod) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers