Ubuntu

2.6.24-15-generic: saa7134-alsa makes HAL to fail

Reported by Roberto Cássio Jr. on 2008-04-05
354
Affects Status Importance Assigned to Milestone
hal (Ubuntu)
Undecided
Unassigned
linux-ubuntu-modules-2.6.24 (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: linux-ubuntu-modules-2.6.24-15-generic

After upgrading do the latest kernel (Linux 2.6.24-15-generic), I was going to test if he bug #201431 ( https://bugs.launchpad.net/ubuntu/+source/linux-ubuntu-modules-2.6.24/+bug/201431 ) was fixed.

All I got was a message, few instants after gnome starts loading, saying "Failed to initialize hal". No network anymore, probably another things were not working also too but I didn't test.

Blacklisting the saa7134-alsa module is a workaround for the problem. But then, I can't get Audio from the TV card again... :/

In case it helps, I've attached an lspci -vv output, so you can get better identification of my TV card. Tv card worked fine on Gutsy, though.

Sense Egbert Hofstede (sense) wrote :

Thank you for reporting this bug. However, we still need some more information before we can pass it on to the developers. Could you please attach this:
/var/log/kern.log
uname -a
cat /proc/asound/cards
dmesg
cat /proc/version_signature

Please do this with the module loaded. And please don't paste all this in one file. It doesn't matter if you have to comment more than one time.

Changed in linux-ubuntu-modules-2.6.24:
assignee: nobody → qense
status: New → Incomplete

Ok. I removed saa7134-alsa from my /etc/modprobe.d/blackklist.d, so saa7134-alsa gets loaded (I confirmed it was loaded using lsmod). So, I'm attaching the needed outputs. Follows below.

(I'd guess my soundcard doesn't appear because hal detection fail)

Feel free to ask any additional info needed for fixing this bug.

Sense Egbert Hofstede (sense) wrote :

I couldn't fine a line indicating what went wrong. Could you please include /var/log/messages ? It contains a lot of different information.
Thanks in advance.

Could the following lines from dmesg be relevant?

[ 41.554732] saa7134 ALSA driver for DMA sound loaded
[ 41.554763] saa7130[0]/alsa: saa7130[0] at 0x92004800 irq 18 registered as card -2
[ 41.554830] Unable to handle kernel NULL pointer dereference at 0000000000000001 RIP:
[ 41.554834] [<ffffffff88b71bef>] :snd_pcm:snd_pcm_timer_init+0x2f/0x1a0

I'll be providing the requested file too.

Here it comes.

I'm having this bug too. I'll add those log files if it'd help, but I'm not on my home computer right now.

Also having these problems. Manually trying to modprobe the module saa7134_alsa results in a segfault. This is probably relevant as although I get the segfault message, lsmod shows that the module is loaded.

Sense Egbert Hofstede (sense) wrote :

This bug can be considered as confirmed since it contains a lot of log files and is confirmed by two other people.

Changed in linux-ubuntu-modules-2.6.24:
assignee: qense → nobody
importance: Undecided → Medium
status: Incomplete → Confirmed
Ignacio Larrain (ilarrain) wrote :

I can confirm this bug too.

I got a very similar dmesg output. My card is a removable pc-card. Anyway, after removing the card I was still unable to unload the conflicting module.

I'm subscribing, so if you need more debugging info, I'm willing to help.

Rui Castro (rui.castro) wrote :

Hi,

I can confirm this bug too.
I have a Pinnacle PCTV (driver saa7134) and at boot time an error occurs loading saa7134-alsa.

Rui Castro (rui.castro) wrote :

Here's my dmesg.

Shouldn't this bug priority set as high or critical? I'm not saying this because the saa7134-alsa driver not working, but because other basic system driver (like network and audio) don't work too (I guess it's due to HAL failure), making the system unusable for many potencial unexperienced users having a saa7134 based card (who wouldn't know that blacklisting this driver would workaround the problem).

I have also added hal as an affected package, because I believe that it wouldn't be expected from hal to stop working and loading the other system drivers just because saa7134-alsa driver failed. Please, correct me if I'm wrong.

Changed in linux-ubuntu-modules-2.6.24:
assignee: nobody → ubuntu-kernel-team
importance: Medium → High
status: Confirmed → Triaged
Max (maxter) wrote :

i confirm this bug too.
i think that also the following bug report could be related to this one:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/212093

Shirish Agarwal (shirishag75) wrote :

Here are mine.

Shirish Agarwal (shirishag75) wrote :
Shirish Agarwal (shirishag75) wrote :
Shirish Agarwal (shirishag75) wrote :
Shirish Agarwal (shirishag75) wrote :
Shirish Agarwal (shirishag75) wrote :
Juan C. Villa (juanqui) wrote :

I am having the same issue. It only happens on my PC with a TV capture card (PCHDTV 5500). I have attached my dmesg output as well. My workaround is to use the old kernel (I accidentally filed a duplicate bug thinking it was initially related to HAL, I some more comments in that page: https://bugs.launchpad.net/bugs/213746).

peter neologe (peter-neologe) wrote :

Confirmed, it's the TV Tuner card.

Hi everyone,

bug 212960 recently pulled in a fix which should hopefully resolve the issue you are seeing:

http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-hardy-lum.git;a=commit;h=607ab6f78fa5d51b4dab72d218455a858c499c6f

For those of you here who are comfortable building and booting your own kernel, it would be nice to get confirmation from you as well that this patch does resolve the issue. Otherwise please wait for the next linux-ubuntu-modules upload to test and verify. We apologize for any inconvenience this may have caused and appreciate your patience as we get the fix released to you. Thanks.

Juan C. Villa (juanqui) wrote :

I downloaded alsa-source, I patched the problematic file with the fix (http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-hardy-lum.git;a=commit;h=607ab6f78fa5d51b4dab72d218455a858c499c6f), and recompiled the alsa module. After installing the new alsa modules, I went ahead and rebooted the machine but I am still getting the same issue. I am not sure what's the correct way of doing this recompilation so there's a chance I might have done something wrong. Can I get some pointers as to how to correctly do this?

Thanks!

thom (tsk) wrote :

Hi Juan,

I am not that good in this stuff but it seems that some people have managed to patch.

You can find them here:

https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/212960

Search for: Frank Haverkamp

(oh, btw, another duplicate bug so it seems) ;-)

Juan C. Villa (juanqui) wrote :

Thanks thom, I have posted the question on that bug report. I appreciate the help :-D

Shirish Agarwal (shirishag75) wrote :

There was a new kernel couple of hours ago but it still didn't fix up the issue. These are the lines which were there while installing the new kernel. Can somebody confirm if this behaviour is correct/expected ?

Setting up linux-image-2.6.24-15-generic (2.6.24-15.27) ...
Not updating initrd symbolic links since we are being updated/reinstalled
(2.6.24-15.26 was configured last, according to dpkg)
Not updating image symbolic links since we are being updated/reinstalled
(2.6.24-15.26 was configured last, according to dpkg)
Running postinst hook script /usr/sbin/update-grub.
Updating /boot/grub/grub.cfg ...
Found Debian background: debian-blueish-wallpaper-640x480.png
Found linux image: /boot/vmlinuz-2.6.24-15-generic
Found initrd image: /boot/initrd.img-2.6.24-15-generic
Found linux image: /boot/vmlinuz-2.6.24-14-generic
Found initrd image: /boot/initrd.img-2.6.24-14-generic
Found linux image: /boot/vmlinuz-2.6.24-12-generic
Found initrd image: /boot/initrd.img-2.6.24-12-generic
Found linux image: /boot/vmlinuz-2.6.24-11-generic
Found initrd image: /boot/initrd.img-2.6.24-11-generic
Found memtest86+ image: /boot/memtest86+.bin
done

I am asking as initrd.gz didn't get updated this time around

Not updating initrd symbolic links since we are being updated/reinstalled
(2.6.24-15.26 was configured last, according to dpkg)
Not updating image symbolic links since we are being updated/reinstalled
(2.6.24-15.26 was configured last, according to dpkg)

Comments welcome :)

On Tue, Apr 8, 2008 at 11:32 PM, Shirish Agarwal <email address hidden>
wrote:

> I am asking as initrd.gz didn't get updated this time around
>
> Not updating initrd symbolic links since we are being updated/reinstalled
> (2.6.24-15.26 was configured last, according to dpkg)
> Not updating image symbolic links since we are being updated/reinstalled
> (2.6.24-15.26 was configured last, according to dpkg)

It was updated, the only thing that didn't get updated was the symbolic
links, because file locations didn't change.
http://en.wikipedia.org/wiki/Symbolic_link

Gina (ginalinux) wrote :

I get the HAL error on my desktop too but also a number of other errors on my laptop.

I have the saa7134 device in my desktop but nothing like that in the laptop. The saa7134 TV tuner is not being recognised currently with the older kernel (14) by TV tuner apps but does show in lspci correctly. I am currently investigating this - I'm not sure if this is a related problem.

cue (keino) wrote :

I can confirm that Bug as well.
Starting Hardy with 2.6.24.15 takes very long and after login a small dialog box in the upper left corner says 'Interner Fehler' = internal error failed to initialize HAL!
The Network is completely broken and the evolution-data-server-2.22 takes 90% of cpu time all the time.

Starting Hardy with 2.6.22.14 kernel is fast and solid as usual.

Hope that helps a bit,

cheers.

ludwigmace (mason-schoolfield) wrote :

I don't know if this will help to identify the problem or not, but I downloaded and compiled the stock 2.6.24.4 kernel from kernel.org and I have no problems with saa7134 or saa7134_alsa. When running the Ubuntu 2.6.24-15-generic I get the same problem as described in the bug name. Just figured I'd point that out. Sorry if that's useless info.

Andreas Gnau (rondom) wrote :

I can confirm this.
Could this be a similiar to bug 212960 ?

gudmk@hotmail.com (gudmk) wrote :

I have two Oops'es I had three, but I uninstalled lirc. I have two tv cards pvr-150 and hd5500.

Why do failures in driver modules affect hal?

All these failures seem to have something to do with alsa. In bug 202249 it is stated:

This kernel Oops occurs because btsco.c is built with the incorrect ALSA config settings due to the fact it is not built in the main ALSA tree.

Is this the reason for all these errors?

thom (tsk) wrote :

Hi Andreas,

Yes, AFAIK this bug is similar to bug 212960.

Hi All,

Just giving you an update that the patch in bug 212960 has been reverted as it was causing some boot issues: https://edge.launchpad.net/ubuntu/+source/linux-ubuntu-modules-2.6.24

Developers are still working on resolving this issue. Thanks for your patience.

Max (maxter) wrote :

well, the last update to kernel 2.6.24-16 seems to break alsa at all.
on two testing machine the audio driver are not loaded, after a long
pause before harware detection end.
the hardware is:
intel ich5 integrated chip on a netvista box
via integrated chip on an old machine

at least hal works :)

Max

Joachim Beckers (jbeckers) wrote :

same issue here as what Max reports

thom (tsk) wrote :

Both the ICH5 on my laptop as the ICH6 on my desktop are working perfectly.
Ofcourse i have to keep the saa7134 blacklisted to keep the Hal error away since the developers are still working on a solution for that.

@Joachim & Max:
Have you tried to purge the old packages/patches with apt-get purge ?

aidave (aidave) wrote :

Same, crashes on my Dell 1420n with latest kernel. Using older kernel working fine.

aidave (aidave) wrote :

Oops, please disregard my last post!

Rui Castro (rui.castro) wrote :

Hi,

The new kernel sill has the problem lading saa7134
"BUG: unable to handle kernel NULL pointer dereference at virtual address 00000001"

dmesg is attached.

I can confirm that the bug is still present on latest kernel from repositories (currently 2.6.24-16.30). Same "unable to handle kernel NULL pointer dereference at virtual address" while loading saa7134-alsa.

Feel free to ask any additional information needed.

retrow (vonrishi) wrote :

After being directed to this bug, I unplugged my TV tuner card just to make sure that its saa7134 and nothing else. I am glad to report that it was indeed the case. Or at least in my case it was this TV tuner card that was causing all the subsequent failures and crashes.

catinsnow (catinsnow) wrote :

I can confirm this issue too .I get system hang when boot,even with lastest kernel package and linux-ubuntu-modules-2.6.24 2.6.24-16.22.
here is some info,and error log file.

w@ubuntu:~$ lspci
00:00.0 Host bridge: Intel Corporation 82865G/PE/P DRAM Controller/Host-Hub Interface (rev 02)
00:01.0 PCI bridge: Intel Corporation 82865G/PE/P PCI to AGP Controller (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corporation 82801EB/ER (ICH5/ICH5R) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801EB/ER (ICH5/ICH5R) IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801EB/ER (ICH5/ICH5R) SMBus Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation NV36.2 [GeForce FX 5700] (rev a1)
02:05.0 Ethernet controller: 3Com Corporation 3c940 10/100/1000Base-T [Marvell] (rev 12)
02:0b.0 Multimedia controller: Philips Semiconductors SAA7134/SAA7135HL Video Broadcast Decoder (rev 01)

catinsnow (catinsnow) wrote :

and this bug has similar to: https://bugs.launchpad.net/ubuntu/+bug/212226
except that is for cx88 alsa support. it seems there are some relation.

William Grant (wgrant) wrote :

This looks rather like bug #212143.

catinsnow (catinsnow) wrote :

all these are similar. and bug #212100,too.

JC (jcsaintpo) wrote :

at start-up, hal fails to initialise!
no network connection to report it
in kernel 24-14 all worked fine

Jerzy Luszawski (dr-agon) wrote :

First, thanks for the workaround.
I blacklisted the saa7134 and now I can boot with 2.6.24-16-generic kernel and hald loads.

I tried to load saa7134 manually by 'sudo modprobe -v saa7134'
and I got this:

insmod /lib/modules/2.6.24-16-generic/kernel/drivers/media/video/v4l1-compat.ko
insmod /lib/modules/2.6.24-16-generic/kernel/drivers/media/video/v4l2-common.ko
insmod /lib/modules/2.6.24-16-generic/kernel/drivers/media/video/videodev.ko
insmod /lib/modules/2.6.24-16-generic/kernel/drivers/media/common/ir-common.ko
insmod /lib/modules/2.6.24-16-generic/kernel/drivers/media/video/ir-kbd-i2c.ko
insmod /lib/modules/2.6.24-16-generic/kernel/drivers/media/video/videobuf-core.ko
insmod /lib/modules/2.6.24-16-generic/kernel/drivers/media/video/videobuf-dma-sg.ko
insmod /lib/modules/2.6.24-16-generic/kernel/drivers/media/video/compat_ioctl32.ko
install /sbin/modprobe --ignore-install saa7134 && { /sbin/modprobe -Qb saa7134-alsa ; : ; }
insmod /lib/modules/2.6.24-16-generic/ubuntu/media/saa7134/saa7134.ko
insmod /lib/modules/2.6.24-16-generic/ubuntu/media/saa7134/saa7134-alsa.ko index=-2
Killed

and more in the syslog, which is attached below.
I just hope it will be fixed before final version of Hardy.

Thanks again.

ruminant1 (ruminant1) wrote :

I can confirm this bug with an Avermedia A180 tuner card. Interestingly, if I blacklist saa7134_alsa I still get sound and HAL works fine. saa7134 is blacklisted but loads anyway, likely due to my loading of saa7134_dvb.

I had submitted this as bug #212360, but I will now mark it as a duplicate.

Tim Gardner (timg-tpi) wrote :
Changed in linux-ubuntu-modules-2.6.24:
assignee: ubuntu-kernel-team → timg-tpi
milestone: none → ubuntu-8.04
status: Triaged → In Progress
Fran (frbastida) wrote :

I can confirm in 2.6.24-16-generic. In 2.6.24-16-rt works ok

Fran (frbastida) wrote :

I've proved to do wget commented in bug 212960 and i didn't found the .deb

Julian Alarcon (alarconj) wrote :

I confirm this. Right now I'm using kernel 2.6.24-16 but without my TV card (this use saa7143 module).

I just download the last cd image from hardy (daily build) and I think this is critic, don't boot.

Julian Alarcon (alarconj) wrote :

A provisional solution is:
Open like admin the file blacklist that is here /etc/modprobe.d/

sudo gedit /etc/modprobe.d/blacklist

Add a new line below with:

blacklist saa7134_alsa

Save the file.

Now you can boot this kernel (2.6.24-15 or 2.6.24-16) without problem. But your tv card will not function.

samuelmello (samuelmello) wrote :

I have tried to download the file indicated in bug 212960, but I got a 404 error.

I didn't understand why do we need to have the saa7134 both in the standard kernel (kernel/drivers/media/video/saa7134) and in ubuntu-specific drivers (ubuntu/media/saa7134).
The one from standard kernel seems to work fine (as it's working in 2.6.24-14 and there was no change in it), but the ubuntu-specific crashes.

haytjes (h4writer) wrote :

I can confirm that blacklisting saa7134_alsa works.

sudo modprobe saa7134_alsa gives a segmentation fault
sudo modprobe saa7134 don't give any output. So works I guess

After reading the bug #212960 I just tried to install updated linux-ubuntu-modules-2.6.24-16-generic v.23ubuntu2 supplied by Stefan Bader in his repository (https://launchpad.net/~stefan-bader-canonical/+archive) and the problem is gone! I mean that I removed saa7134 from blacklist and everything loads fine, have no HAL error.
Thanks!

Renzo Bagnati (renbag) wrote :

I confirm that after installing linux-ubuntu-modules-2.6.24-16-generic_2.6.24-16.23ubuntu2, from http://ppa.launchpad.net/stefan-bader-canonical/ubuntu/, the saa7134_alsa module loads without errors and the system boots and works without problems.

thom (tsk) wrote :

yes, I confirm this too.

I too installed linux-ubuntu-modules-2.6.24-16-generic_2.6.24-16.23ubuntu2, from http://ppa.launchpad.net/stefan-bader-canonical/ubuntu/ and it works. For the first time in hardy perfect recognition of the audio part and have xaw-tv running. You guys are GOOD!! :-)

Hello ubuntu devs,
this should be marked 'fix committed' just like bug 212960 (which is clearly a duplicate of this one).

Hi,
I confirm this too, but in linux-ubuntu-modules-2.6.24-16-generic_2.6.24-16.23ubuntu2 no nvidia driver modules, so I still use 2.6.24-16-rt.

Rui Castro (rui.castro) wrote :

Hi,

I can confirm that after installing linux-ubuntu-modules-2.6.24-16-generic_2.6.24-16.23ubuntu2 from http://ppa.launchpad.net/stefan-bader-canonical/ubuntu/ my systems boots without problems and my TV card Pinnacle PCTV (saa7134) works perfectly.
Nvidia driver is in linux-restricted-modules and it works too.

Fran (frbastida) wrote :

For Alexandr Rudenko : Try to reinstall linux-restricted-modules and look if NVIDIA drivers works. I had similar problems and i reinstalled the restricted modules and works

Dustin Kirkland  (kirkland) wrote :

Doing some bug cleanup. The cx88 null pointer exceptions and hal failing to load bugs are clearly duplicates of this one. Stefan committed a couple of changes to l-u-m that fixes this for me. The choir seems to agree. Thanks!

:-Dustin

Changed in linux-ubuntu-modules-2.6.24:
status: In Progress → Fix Released
Changed in hal:
status: New → Invalid
Changed in linux-ubuntu-modules-2.6.24:
status: Fix Released → Fix Committed

Thanks to all, the system boots fast, all the devices work, concerned only the abundance of communications xsession-errors

Julian Alarcon (alarconj) wrote :

I don't see any changes in the repository.. There is a solution but it's not committed to official repositories yet.

Changed in linux-ubuntu-modules-2.6.24:
status: Fix Committed → In Progress
Julian Alarcon (alarconj) wrote :

I still don't see any changes on official repositories.. So his bug is not fixed yet.

hmc8 (hmc8) wrote :

I can confirm this bug with the brandnew "Release Candidate" of Hardy!

Brian Murray (brian-murray) wrote :

I'm setting this bug's status to Fix Committed since the changes are pending and to be uploaded soon. Additionally, a working package has been provided by an Ubuntu kernel team member in a PPA. You can learn more about when bug statuses are to be used at https://wiki.ubuntu.com/Bugs/Status.

Changed in linux-ubuntu-modules-2.6.24:
assignee: timg-tpi → ubuntu-kernel-team
status: In Progress → Fix Committed
Julian Alarcon (alarconj) wrote :

---------
I'm setting this bug's status to Fix Committed since the changes are pending and to be uploaded soon. Additionally, a working package has been provided by an Ubuntu kernel team member in a PPA. You can learn more about when bug statuses are to be used at https://wiki.ubuntu.com/Bugs/Status.
---------

Sorry, my fault... I hope this fix get Fixed on Final Hardy Release.

Kai Cordes (cordes) wrote :

I have downloaded the Hardy-RC-Release and wanted to install 8.04. After starting the Live-CD the system says: "Failed to initialize hal".

I'm using the Pinnacle TV-Card and the Creative XFI-Xtreme AUDIO (with no driver Support in Linux, only other XFI-Xtreme Cards are supported :( ).

Now I cannot start the installation of Hardy. After opening the link nothing happens, no new window - nothing. I can start firefox from the live CD but not the installation! What should I do?

I installed 7.10 without any problems, updated the system and than did an upgrade with "update-manager --devel-release".

After install, the system does not start. I will post the output of the system in a few minutes.

I hope this can be fixed untill the final release, because I have no experiences with Linux and don't know what to do.

thom (tsk) wrote :

Hi Kai,

You might be able to use the boot alternative: When the system boots (grub bootloader) press ESC (?not sure, haven't used it for a long time) to make the bootmenu (grub) visible. choose option 2 (a kind of "start in safe mode")

when you are in safe mode (and you are root) just type (or cut 'n paste from here):

echo "#these lines can be removed in the official hardy release" >>/etc/modprobe.d/blacklist
echo blacklist saa7134 >>/etc/modprobe.d/blacklist
echo blacklist saa7134_dvb >>/etc/modprobe.d/blacklist

now (in theory) you should be able to boot up normally. :-)
And yes, this is a well known bug and it is already solved, it just didn't make it in time to get into the Hardy-RC-Release.

Kai Cordes (cordes) wrote :

While booting, the system messages are:

on tty1:
usplash: setting mode 1208*1024 failed
usplash: setting mode 1152*846 failed
usplash: using mode 1024/768
kinit: name_to_dev_t (/dev/disk/by_uiid/[UID]) = sda5 (8,5)
kinit: trying to resume from (/dev/disk/{UUID])
kinit: no resume image, doing normal boot...

on tty8:
* Reading files needes to boot [OK]
* Preparing restricted drivers [OK]
* Setting the system clock
* starting base networking [OK]
* Starting kernel event manager [OK]
* Loading hardware drivers [OK]
* Setting the system clock
* Loading kernel modules
* Loading manual drivers

Then after several minutes:
[ 716.954512] Pinnacle PCTV unknown key: key=0x39 raw=0x39 down=1
[ 717.0622279] Pinnacle PCTV unknown key: key=0x39 raw=0x39 down=0

After some more minutes:
[ 931.6325823] Pinnacle PCTV unknown key: key=0x5j raw=0x5j down=1
[ 931.740285] Pinnacle PCTV unknown key: key=0x5j raw=0x5j down=0

I waited some more minutes, but nothing happened.

thom (tsk) wrote :

Hi kai,

You have to hit the ESC key a lot sooner, just after your BIOS finished and just before the kernel is loaded into memory. You only have 3 seconds to interrupt the boot process.

If all else fails: boot with the live CD, you will see a drive labeled 'disk' on your Desktop.
So far so good.
If this worked, open a terminal (applications->accessories) and type: sudo su
Now you're root.

type:
echo "#these lines can be removed in the official hardy release" >>/media/disk/etc/modprobe.d/blacklist
echo blacklist saa7134 >>/media/disk/etc/modprobe.d/blacklist
echo blacklist saa7134_dvb >>/media/disk/etc/modprobe.d/blacklist

Now you can shutdown, remove the live CD and reboot and all should work.

Hello Thom,

many thanks for your sulution - it worked.

At the first boot after hitting ESC and using "safe-mode" the system
hanged with this message:
hda_codec: Unknown Model fpr ALC882 trying to auto-brobe from bios.

After wating for more than 5 Minutes, I pressed CTRL+ALT+DEL and got an
windows where I could choose "root".
But my whole filesystem war read-only, so I couldn't change the
blacklist - file.

After a reboot (also in safe mode) there was no hanging of the system, I
could choose "root" and apply the changes.

Once again - many thanks for your kind help.

Greetings from Osnabruck to the Netherlands
Kai

thom schrieb:
> Hi kai,
>
> You have to hit the ESC key a lot sooner, just after your BIOS finished
> and just before the kernel is loaded into memory. You only have 3
> seconds to interrupt the boot process.
>
> If all else fails: boot with the live CD, you will see a drive labeled 'disk' on your Desktop.
> So far so good.
> If this worked, open a terminal (applications->accessories) and type: sudo su
> Now you're root.
>
> type:
> echo "#these lines can be removed in the official hardy release" >>/media/disk/etc/modprobe.d/blacklist
> echo blacklist saa7134 >>/media/disk/etc/modprobe.d/blacklist
> echo blacklist saa7134_dvb >>/media/disk/etc/modprobe.d/blacklist
>
> Now you can shutdown, remove the live CD and reboot and all should work.
>
>

pvdeynse (vandeynse) wrote :

@Alexandr Rudenko
@Fran

   re-installing the "linux-restricted-modules-2.6.24-16-generic" did re-enable the NVIDIA driver, but configuring the NVIDIA X Server Settings from the Desktop menu System
   setting gives the following error message : select --> X Server Display Configuration
                                                                                          ( tried to changed the resolution back to my original 1440x900 )
                                                                                            while selecting "Save to X Configuration File" got error message :
                                                                                                        Unable to remove old X config backup
                                                                                                        file '/etc/X11/xorg.conf.backup'

  To solve, open a terminal window and type "sudo nvidia-settings" and repeat same steps as above, saving to X Configuration file will work now.
   Does anyone know if there is already a Bug report open for this? Couldn't find any.

Hello,

I can confirm that installation linux-ubuntu-modules-2.6.24-16-generic_2.6.24-16.23Dell1_amd64.deb from http://ppa.launchpad.net/stefan-bader-canonical/ubuntu/ solved issue.

I am using AverMedia AVerTV Super 007, amd64...

Huge thanks...
Milosz

Steve Langasek (vorlon) wrote :

This bug was fixed in the package linux-ubuntu-modules-2.6.24 - 2.6.24-16.23

---------------
linux-ubuntu-modules-2.6.24 (2.6.24-16.23) hardy; urgency=low

  [Amit Kucheria]

  * Poulsbo: Update to latest DRM drivers (Beta09)

  [Stefan Bader]

  * Use LUM version of ALSA headers when building media drivers.
  * Include correct ALSA config for media drivers.
    - LP: #212960

  [Daniel Mack]

  * caiaq: make high sample rates work with A8DJ
    This patch for snd_usb_caiaq makes sample rates higher than 49KHz work
    with devices which have more than 2 stereo input/output pairs.

  * caiaq: correct input channel order
    This patch corrects the input channel order of hardware supported by
    snd_usb_caiaq.

  [Matthew Ranostay]

  * hda: Correct SPDIF out default config
    Several laptops have have the SPDIF out defined as 'Digital other out'
    when it should be 'SPDIF out' in the default config.

  [Soren Hansen]

  * Remove openvm tools
    We're reliably informed that open-vm-tools is not something we
    want to support. Each VMWare product comes with its own version of
    these kernel modules (released under the GPL and everything),
    while open-vm-tools is not actually supported for any version of
    any VMWare product. This might very well change in either the
    intrepid or intrepid+1 time frame, but it's not there yet.

 -- Tim Gardner <email address hidden> Fri, 11 Apr 2008 10:57:39 -0600

Changed in linux-ubuntu-modules-2.6.24:
status: Fix Committed → Fix Released

I can confirm this bug with an Avermedia DVB-T 777 tuner card.

Ubuntu Tofu (rong-wang) wrote :

I don't think the problem is fixed.
I installed 2.6.24-16.30, there are similar problems.
I will upload the dmesg output later.
I had a HP workstation 6200.
The standard kernel failed to boot up, and failed on the audio card - Creative Labs SB Audigy
The nVidia module didn't work with Quadro FX 1400 either.
I had to compile modules for both.
After those fix, I had problem to load saa7134-alsa module with SAA7130 TV card.
Tons of this kind of errors:
[ 42.704962] saa7134_alsa: disagrees about version of symbol snd_pcm_new
[ 42.705336] saa7134_alsa: Unknown symbol snd_pcm_new

Ubuntu Tofu (rong-wang) wrote :

Upload lspci output

El Puño (el-puno-dk) wrote :

I agree with Ubuntu Tofu.

- Network is up.
- Terratec Cynergy 400 does not (using saa7134).
- No nVidia driver available (to select).
- Sound is ok.

I have reportet a similar problem : https://bugs.launchpad.net/ubuntu/+source/linux-ubuntu-modules-2.6.24/+bug/220380 regarding the network card.

Fabian (fsturm) wrote :

Hi!

I am also plagued by the bug and only 2.6.24-16.23ubuntu2 from Stefan Bader fixed the oops issue.
I still have the issue #209971 that my dvb card does not work, so I hope
both get fixed before the final release.

Thanks, Fabian
I can provide additional info if needed.

Hi,

I installed 2.6.24-16.23ubuntu3 today from https://launchpad.net/~stefan-bader-canonical/+archive and the Oops is gone, but pulseaudio does have problems:

desktop ~ # esd
ALSA lib confmisc.c:1286:(snd_func_refer) Unable to find definition 'cards.SAA7134.pcm.front.0:CARD=2'
ALSA lib conf.c:3513:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:3985:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2145:(snd_pcm_open_noupdate) Unknown PCM front:2
ALSA lib confmisc.c:1286:(snd_func_refer) Unable to find definition 'cards.SAA7134.pcm.surround40.0:CARD=2'
ALSA lib conf.c:3513:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:3985:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2145:(snd_pcm_open_noupdate) Unknown PCM surround40:2
ALSA lib confmisc.c:1286:(snd_func_refer) Unable to find definition 'cards.SAA7134.pcm.surround51.0:CARD=2'
ALSA lib conf.c:3513:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:3985:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2145:(snd_pcm_open_noupdate) Unknown PCM surround41:2
ALSA lib confmisc.c:1286:(snd_func_refer) Unable to find definition 'cards.SAA7134.pcm.surround51.0:CARD=2'
ALSA lib conf.c:3513:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:3985:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2145:(snd_pcm_open_noupdate) Unknown PCM surround50:2
ALSA lib confmisc.c:1286:(snd_func_refer) Unable to find definition 'cards.SAA7134.pcm.surround51.0:CARD=2'
ALSA lib conf.c:3513:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:3985:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2145:(snd_pcm_open_noupdate) Unknown PCM surround51:2
ALSA lib confmisc.c:1286:(snd_func_refer) Unable to find definition 'cards.SAA7134.pcm.surround71.0:CARD=2'
ALSA lib conf.c:3513:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:3985:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2145:(snd_pcm_open_noupdate) Unknown PCM surround71:2
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0

Only solution that works here is to blacklist saa7134_alsa (In my case that is okay, because I only use the composite input of my TV card and the sound is connected directly from an external cable receiver to my amplifier).

So I guess the package still contains a bug.

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers