KDE3 apps, OO.o and Wine loose screen text when run with nvidia 96 driver

Bug #294076 reported by alienexplorers
466
This bug affects 10 people
Affects Status Importance Assigned to Milestone
k3b (Ubuntu)
Undecided
Unassigned
Nominated for Intrepid by alienexplorers
nvidia-graphics-drivers-96 (Ubuntu)
Undecided
Unassigned
Nominated for Intrepid by alienexplorers

Bug Description

Binary package hint: k3b

When I startup K3B in 8.10 in the gnome enviroment with desktop effects enabled I loose text from the K3B page that is open. I have found that with desktop effects off K3B behaves correctly with no visible problems. I have included a screen shot of what is happening to K3B with desktop effects enabled.

Revision history for this message
alienexplorers (dfsjr47) wrote :
description: updated
Revision history for this message
Jonathan Thomas (echidnaman) wrote :

This is a known bug with the nvidia 96-series drivers documented here: http://www.nvnews.net/vbulletin/showthread.php?t=122350.
Also affects Wine.

Changed in k3b:
status: New → Triaged
Revision history for this message
alienexplorers (dfsjr47) wrote :

Jonathan Thomas,
Thanks for the information. I really thought something was wrong with my system since it is so old. Any idea when a fix will be out?

Revision history for this message
Solitaire (bill-s0l) wrote :

I'm having the same Text corruption in Wine as shown in the NvNews forum link.

I am NOT running Compiz. Desktop effects are disabled.

added screenshot of Wine to show issue.

Revision history for this message
Alexander Kallenbach (kallenbachalex) wrote :
Revision history for this message
alienexplorers (dfsjr47) wrote :

Found out that if I disable composite in xorg.conf that k3b works correctly. Verified this on another machine with the same results.

Revision history for this message
Jonathan Thomas (echidnaman) wrote :

Not a k3b issue, invalidating k3b task.

It is really up to nvidia as to when they release a fix. Since the drivers are closed-source we can't really know what the problem exactly is or when a fix will arrive.

Changed in k3b:
status: New → Invalid
Revision history for this message
Julien Aubin (gojulgarbmail) wrote :

Actually this affects all QT3 apps, not only the ones mentioned there.

Revision history for this message
Nobbit (lew-n-myschkin) wrote :

ouch. should have read carefully the warning when i installed nvidia (headbang).

Revision history for this message
TexasRanger (walker-lo) wrote :

My symptom:
With Ubuntu Visual Effects set to "Normal" or "Extra", OpenOffice menu text disappeared.

After several days of experimentation, I can report the following:
- I am running Ubuntu 8.04 LTS with Ubuntu release of OpenOffice 2.4.1 and Nvidia driver 96.43.09-0ubuntu1 graphics card driver.

- When I enabled Compiz Normal or Extra Visual Effects, the menu text in all OpenOffice apps disappeared, replaced thin horizontal lines. Problem does NOT occur with Visual Effects set to "None". No other apps displayed the symptom, only Oo.

- After experimenting, I found that Oo fonts could be restored by disabling "antialiasing" checkbox in the Oo Tools/Options/View submenu. Of course, this made the menu text fonts look very pixel-y.

- Problem solved (for me) by running "sudo dpkg-reconfigure fontconfig-config" and selecting "Autohinter", "Always" (for subpixel rendering on my LCD display), and "No" for Enable bitmapped fonts. Then, I changed Ubuntu System/Preferences/Appearance/Fonts to "Subpixel" smoothing. Viola! Problem solved.

Revision history for this message
alienexplorers (dfsjr47) wrote :

TexasRanger,
Took your findings and applied them and it took care of all the problems I was having in QT3 Apps. Works with compiz in Extra setting. I am deeply in your debt for getting this figured out. I was just about to give up and remove compiz, but now I don't have to.

Thank You very much for working this out.

Donald Saunders

Revision history for this message
Alexander Kallenbach (kallenbachalex) wrote :

The workaround from TexasRanger solved the problems with OO for me, but not for Wine.

Revision history for this message
Daniel Morante (tuaris) wrote :

Also happens with Compiz turned off
Additionally, I saw a similar problem occur when scrolling in the system monitor application (see screen shot)

Revision history for this message
daveh (david-huckfield) wrote :

I have been looking at several forums and doing a lot of Google-ing about this bug these last few days and it seems to me that:

1. Many people have been affected by this with their legacy cards.
2. It manifests itself with many different applications..OOv3, Opera, K3b, GoogleEarth....
3. There are several proposed "fixes" such as anti-aliasing, turn off compositing, the one above from TexasRanger.
4. Some work for some and not for others.
5. For me (Geforce4 MX440 card with 96beta driver on Intrepid) I changed my xorg.conf file to

Option "RenderAccel" "False"
or
Option "RenderAccel" "0"

in the Section "Device".

HTH
Dave

Revision history for this message
i (iiiiii-deactivatedaccount) wrote :

Excuse me, I'm brand new to Linux and have exactly the same problem as Texas Ranger. I'm using ubuntu 8.10 , OpenOffice 3.0 updated through http://ppa.launchpad.net/openoffice-pkgs/ubuntu intrepid main , Geforce MX460-VTP and 96.43.09-0ubuntu1 driver.
I typed 'sudo gedit /etc/X11/xorg.conf' and got this:
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Monitor"
 Identifier "Configured Monitor"
EndSection

Section "Screen"
 Identifier "Default Screen"
 Monitor "Configured Monitor"
 Device "Configured Video Device"
 DefaultDepth 24
 Option "AddARGBGLXVisuals" "True"
EndSection

Section "Module"
 Load "glx"
EndSection

Section "Device"
 Identifier "Configured Video Device"
 Driver "nvidia"
 Option "NoLogo" "True"
EndSection

Also I'm using CRT monitor and would appreciate any hints in what to do to fix my problem.

Revision history for this message
i (iiiiii-deactivatedaccount) wrote :

I added Option "RenderAccel" "False" in the "Device" section but it didn't change the problem, then I added that in the "Screen" section and it also changed nothing. Do I have to restart after changing the file?

Revision history for this message
Jonathan Thomas (echidnaman) wrote :

Yes, you must log out and press alt + e to restart the X server, though rebooting will also work.

Revision history for this message
i (iiiiii-deactivatedaccount) wrote :

Thank you very much. The procedure suggested by daveh worked for me.

Revision history for this message
sarahlizz3 (sarahlizz3) wrote :

TexasRanger,

Thank you so very much for sharing your solution. I have been looking for a solution for this for weeks (in between work and finals) and hadn't found a solution, I am so very grateful!

Revision history for this message
buizerd (havik) wrote :

I think I found a solution
as stated in xorg.conf I updated the file
  sudo dpkg-reconfigure -phigh xserver-xorg
all problems (openoffice.org, wine(picassa), and diplay of videos ) seems to be solved

buizerd

Revision history for this message
Jonathan Thomas (echidnaman) wrote :

If you reconfigure you aren't using the proprietary nvidia driver at all.

Revision history for this message
buizerd (havik) wrote :

no problem. because my system and the programs are functioning now

Revision history for this message
Bruno Salerno (brusblues-85) wrote :

I confirm the bug with OO3. The text from the menus is gone.
It's all right with qt3 though.
I have a Geforce4 MX440 card with the nvidia-glx96 package installed, on Intrepid (upgraded from hardy).

I will see what happens with the solution daveh proposed.

Revision history for this message
Bruno Salerno (brusblues-85) wrote :

daveh's solution worked!

Revision history for this message
RonParent (ronap) wrote :

ditto : :daveh's solution worked!"

No other changes to system

Revision history for this message
Richard Vanderlip (vanderlipr) wrote :

I was having the same issues as noted by others. First observed it in Amarok. I have Ubuntu 8.10 Intrepid Ibex on an older P4 machine. Graphics card is a Nvidia GEFORCE2 MX 200. I can confirm that daveh's solution worked for me on Amarok and OpenOffice but did not fix the Wine Configuration menus. I'll take what I can get -- thanks daveh!

Revision history for this message
Socrates (harry-x-williams) wrote :

I think the WINE text maybe a separate problem.

I had to tweak something or other to sort this out as well as the NVIDIA tweak.

perhaps wineHQ would be a good place to start looking.

Revision history for this message
Richard Vanderlip (vanderlipr) wrote :

Thanks Socrates for pointing me in the right direction. I found this at WineHQ (http://wiki.winehq.org/FAQ#head-dec980f6deabdb11b789c981bf49e10e70929eaf). I also followed the link to DJ_Peng's blog at think link http://ubuntuforums.org/showthread.php?t=966709. Basically, the solution involved editing the Wine Registry settings. This is what I did.

Created a text file called settings.txt with the registry value below and saved it in .wine/drive_c
[HKEY_CURRENT_USER\Software\Wine\X11 Driver]
"ClientSideWithRender"="N"

In terminal I ran the command wine regedit /home/username/.wine/drive_c/settings.txt

After that, the menus in the wine configuration app looked fine.

Thanks again Socrates!

Revision history for this message
Jonathan Thomas (echidnaman) wrote : Re: KDE3 apps, OO.o and Wine loose screen text when run with desktop effects

This bug has been fixed with the 96.43.10 drivers in Jaunty.

Changed in nvidia-graphics-drivers-96:
status: Triaged → Fix Released
Revision history for this message
David Wynn (wynn-david) wrote :

96.43.10 fixes this issue? Great! When will that be put into Intrepid?

Revision history for this message
i (iiiiii-deactivatedaccount) wrote :

And I thank you, mr. Richard Vanderlip, for making it so easy to fix the Wine menu issue. Now I can try this program for the first time.

Revision history for this message
pbennett45 (paul-pauljbennett) wrote :

FYI - 96.43.10 was released for beta testing... the stable version is still 96.43.07, presumably why it's not showing up as an ubuntu update yet.

Revision history for this message
David Wynn (wynn-david) wrote :

Wow! 34 duplicates. Who has authority to add a note on the 8.10 release notes for this? Need to have a blurb indicating that using nVidia + compiz causes invisible menus in OO.o, unless changes are made to xorg.conf to turn RenderAccel off. (May want to note if this is general to nVidia or specific to the 96 series)

Revision history for this message
Angel Angelov (dexterabc) wrote :

Daveh's solution works great for me! Many thanks!

P.S. I'm using an ancient NVidia MX-400

Revision history for this message
buizerd (havik) wrote :

in the new release of Ubuntu 9.04
with the new drivers of Nvidia 96.43.10
all the problems seems to be solved

Revision history for this message
Jürgen Sauer (juergen-sauer) wrote : Re: [Bug 294076] Re: KDE3 apps, OO.o and Wine loose screen text when run with desktop effects

Am Samstag, 2. Mai 2009 schrieb buizerd:
> in the new release of Ubuntu 9.04
> with the new drivers of Nvidia 96.43.10
> all the problems seems to be solved
>

Nothing is fixed in Ubuntu 8.04.02 LTS

This means Long Time Support. So please fix
J. Sauer

--
Jürgen Sauer - automatiX GmbH, +49-4209-4699, <email address hidden>
Das Linux Systemhaus - Service - Support - Server - Lösungen
Geschäftsführer (Managing Director): Jürgen Sauer,
Gerichtstand: Amtsgericht Walsrode • HRB 120986
Ust-Id: DE191468481 • St.Nr.: 36/201/14198

Revision history for this message
mouahed2010 (mouahed-elnahali) wrote : Re: [Bug 294076] Re: KDE3 apps, OO.o and Wine loose screen text when run with desktop effects

This is sound very nice thanx to Ubuntu 9.04 and the new version of
compiz fusion contributers and developpers.

2009/5/4, Jürgen Sauer <email address hidden>:
> Am Samstag, 2. Mai 2009 schrieb buizerd:
>> in the new release of Ubuntu 9.04
>> with the new drivers of Nvidia 96.43.10
>> all the problems seems to be solved
>>
>
> Nothing is fixed in Ubuntu 8.04.02 LTS
>
> This means Long Time Support. So please fix
> J. Sauer
>
> --
> Jürgen Sauer - automatiX GmbH, +49-4209-4699, <email address hidden>
> Das Linux Systemhaus - Service - Support - Server - Lösungen
> Geschäftsführer (Managing Director): Jürgen Sauer,
> Gerichtstand: Amtsgericht Walsrode • HRB 120986
> Ust-Id: DE191468481 • St.Nr.: 36/201/14198
>
> --
> KDE3 apps, OO.o and Wine loose screen text when run with desktop effects
> https://bugs.launchpad.net/bugs/294076
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in “k3b” source package in Ubuntu: Invalid
> Status in “nvidia-graphics-drivers-96” source package in Ubuntu: Fix
> Released
>
> Bug description:
> Binary package hint: k3b
>
> When I startup K3B in 8.10 in the gnome enviroment with desktop effects
> enabled I loose text from the K3B page that is open. I have found that with
> desktop effects off K3B behaves correctly with no visible problems. I have
> included a screen shot of what is happening to K3B with desktop effects
> enabled.
>

Revision history for this message
Tim Abell (tim-abell) wrote :

i changed the title of this bug because it doesn't just affect those with desktop effects on, and this caused me to file a duplicate bug

summary: - KDE3 apps, OO.o and Wine loose screen text when run with desktop effects
+ KDE3 apps, OO.o and Wine loose screen text when run with nvidia 96
+ driver
Revision history for this message
Tim Abell (tim-abell) wrote :

I deactivating the nvidia driver, logged out & in again, and the text reappears.

To post a comment you must log in.