Ubuntu

GNOME Panel icons (on right side) move apparently randomly on session start in some situations

Reported by Toby Smithe on 2006-05-10
This bug affects 349 people
Affects Status Importance Assigned to Milestone
GNOME Panel
Fix Released
High
Nominated for Main by The_Great_Bunghole
One Hundred Papercuts
Undecided
Unassigned
Declined for Karmic by Vish
gnome-panel (Ubuntu)
Low
Unassigned
Declined for Jaunty by Sebastien Bacher
Declined for Karmic by Sebastien Bacher
Declined for Lucid by Sebastien Bacher
Declined for Maverick by Sebastien Bacher

Bug Description

The items on the gnome panel is disordered in some cases, one of these being changing the screen reolution, possibly other, more random, cases as well.

-----

Temporary solution:
Backup the state of your panel:
gconftool-2 --dump /apps/panel > panel_backup.xml

and then restore it whenever it gets messed up:
gconftool-2 --load panel_backup.xml
killall gnome-panel (kills and auto-respawns, possibly need to run gnome-panel & as well)

-----

I have noticed for a while now that the above-mentioned phenomenon occurs when I, say, return from a shut-down. However, the strange thing is that it only happens on some occations. I don't really know what the problem is, so I can't, unfortunately, post more information.

Sebastien Bacher (seb128) wrote :

Thanks for your bug. Could you make a screenshot before and after to show the difference? No need to take the whole desktop, the same panel should be fine

Changed in gnome-panel:
assignee: nobody → desktop-bugs
status: Unconfirmed → Needs Info
Lionel Dricot (ploum) wrote :

I can confirm this if you have a non-extended with non-locked applets.

Sometimes, those applets move strangely. I solved this by locking all the applets.

I reproduce this by disabling the lock, making the panel "extend" itself, adding a new applet, disable the extend the reboot.

Changed in gnome-panel:
status: Needs Info → Confirmed
Sebastien Bacher (seb128) wrote :

Is that specific to non-extended panels as pointed by Lionel?

As you can see, all panels are fully extended.

Also, the icons are "locked" according to the context menu, but not in practise.

This is what I'd like my panels to stay like.

I'm using dapper 20060521 and gnome-panel 2.14.1-0ubuntu13.
I experience the same problem, sometimes after starting gnome the date and time appears misaligned to the left of the mixer icon in the top panel (see screenshot in attachment). Normally it should be located between the mixer icon and the logout icon. Ocassionaly the date and time doesn't appear at all, only the gray space between the mixer and logout icon is visible then.
This is probably caused by a recent update because I did not experience this problem on dapper a month ago.

Screenshot of "date and time" being misaligned on the panel.

Screenshot of "date and time" being aligned as it should be.

I forgot to mention that all the applets and launchers on my top panel are Locked.

Mike M (hairy-palms-19) wrote :

this happens to me too but only if the gdm resolution is different to the resolution of my desktop
it also happens to me sometimes when changing resolution normally. if gdm is the same res as ur desktop it might fix it.

My "gdm res is the same as [my] desktop".
On Mon, 2006-06-12 at 17:36 +0000, Hairy_Palms wrote:
> this happens to me too but only if the gdm resolution is different to the resolution of my desktop
> it also happens to me sometimes when changing resolution normally. if gdm is the same res as ur desktop it might fix it.
>

rai4shu2 (rai4shu2) wrote :

Locked or unlocked, applets move around randomly on the right side. On the left, applets move around randomly unless you manually move them. Manually moving applets on the right does *not* fix them.

Jussi Schultink (jussi01) wrote :

I have the same problem with Feisty. When logging in shutdown button and volume icon can appear in random places in the panel. So at shut down, it could be that you have volume, clock then shutdown button, but upon logging in you might have shutdown button, volume, clock. All the icons are locked aand must be unlocked to be put back in their proper places. Also, the network manager icon may disappear at random times during the session. However when this happens, the connection is not lost, only the icon disappears.

rai4shu2 (rai4shu2) wrote :

On my system, I have the Notification Area, the Volume Applet, the System Monitor, the Clock, and the Workspace Switcher on the right side of my panel going left to right. The Notification Area and the Clock change width from time to time, so perhaps that's what is causing this trouble.

As a workaround, I'm going to try keeping all these applets a small distance apart from each other rather than flush up against themselves and see if that fixes this issue.

rai4shu2 (rai4shu2) wrote :

Items on the right side of the panel move themselves back to flush up against each other if you change the Orientation. Is this another bug?

Jason (jasonxh) wrote :

I confirm this bug. It has been extremely annoying. Locked or not, the icons to the right sometimes randomly reorders themselves when I log in. I switch between internal and external display very often, so I always adjust the resolution. Don't know whether this has something to do with it. I'm using Ubuntu Edgy.

Lawrence H (it4wec) wrote :

As one can see from the attached screenshot of my panel, I've got a particularly nasty case of this bug. As others have noted, it looks to be tied into changing screen resolutions. I'm using Feisty.

I play an old video game that needs 640x480. My display is 1680x1050. To play the game I wrote a script that calls xrandr before and after the game to make the necessary adjustments. That's what started the icons moving.

Just calling xrandr and playing with different sizes doesn't make the icons move when I switch back to normal resolution. It's not at all clear what needs to happen in addition to changing resolution for the icons to move.

Geert Jan Alsem (gj-alsem) wrote :

I would like to confirm this bug.

My normal desktop resolution is 1280x1024. When I use my TV-Out I switch to 1024x768. Changing the resolution does not affect the order of the items on my panels immediately. But, if I changed the resolution at least once, then after a reboot the order of items on the right side of my panels have changed. This does not happen if I reboot after a session during which I did not change the resolution.

Also, it happens both when I use xrandr and when I use the gnome-display-properties GUI to change the resolution.

I'm using an up to date Ubuntu 7.04.

Sebastien Bacher (seb128) wrote :

The bug is already marked confirmed and known upstream; no need to add new comment to say it happen to you as well, the changes to fix it are just not trivial to do

Broomer68 (jbezemer) wrote :

I think I see the same bug, but on the left side, juggling the launcher icons. yesterday I had
amule, firefox, thunderbird, help and today it is
thunderbird, firefox, help, amule

Tom Badran (tom-badran) wrote :

I can confirm im getting the same problem. All my applets are locked, and anything on the right hand side of top or bottom panels appears in a random order on login, no matter how much i reset their positions etc.

This is on a dual screen setup with two 1680x1050 monitors, primary on right, secondary on left.

Changed in gnome-panel:
status: Confirmed → Triaged
unggnu (unggnu) wrote :

I can confirm this. Especially it happens after resolution changes like through external monitor or a wine game.

John Toliver (john-toliver) wrote :

I notice it happens when I reboot, and no resolution changes, nor have I added anything new to the panel. Two Icons on the far left simply appeared in interchanged positions. For example, the icons were in position 1-2-3-4-5-6-7 before reboot, and after reboot they are in position 1-2-3-4-5-7-6. Again all icons are locked. This happens on kernel 2.6.22-14 generic, gnome 2.20.1. Please advise if more information required.

Do you mean posision as the posision specified in gconf? Because that would be interesting. There is a configuration option for panel applets, called panel_right_stick. It seems that all of thiese problems are related to applets on the far right of the screen. Has anyone tried to move the panels a couple of pixels away from the edge and other applets and made sure panel_right_stick isn't enabled? It's just a wild guess, but could be worth a try.

Is it always the clock that's being pushed to the left? It's the applet that takes the longest time to load here.. Might that have anything to do with it?

Yes, if you move things a few pixels apart they keep their position, it gets
broken again if one of them (normally the clock) gets big enough to go over
the space, as this happens with day/month changes. It also seems to only
happen when on a screen which doesnt have a position of +0+0 i.e a monitor
on the right, doesnt matter whether primary or secondary.

Its not always the clock that changes position, its often the volume/systray
for me.

Tom

On Feb 6, 2008 3:26 PM, Jo-Erlend Schinstad <email address hidden>
wrote:

> Do you mean posision as the posision specified in gconf? Because that
> would be interesting. There is a configuration option for panel applets,
> called panel_right_stick. It seems that all of thiese problems are
> related to applets on the far right of the screen. Has anyone tried to
> move the panels a couple of pixels away from the edge and other applets
> and made sure panel_right_stick isn't enabled? It's just a wild guess,
> but could be worth a try.
>
> Is it always the clock that's being pushed to the left? It's the applet
> that takes the longest time to load here.. Might that have anything to
> do with it?
>
> --
> GNOME Panel icons (on right side) move apparently randomly on session
> start in some situations
> https://bugs.launchpad.net/bugs/44082
> You received this bug notification because you are a direct subscriber
> of the bug.
>

When I reported this problem, I was using rel 5.xx, and I had upgraded
from earlier releases. All the icons moved including the ones that had:
'Lock to Panel' option. Also I had made many changes to my system on my
own. So, to make this story short, in my case I resolved this problem by
installing Ubuntu in a clean and empty hard disk. All those problems
went away.

I am using Ubuntu 7.10 now, and I see the icons changing places only
sometimes when I change screen resolutions or when I enable or disable
Compiz.

I will pay attention to the suggestions below next time it happens.
-----Original Message-----
From: Jo-Erlend Schinstad <email address hidden>
Reply-To: Bug 44082 <email address hidden>
To: <email address hidden>
Subject: [Bug 44082] Re: GNOME Panel icons (on right side) move
apparently randomly on session start in some situations
Date: Wed, 06 Feb 2008 15:26:52 -0000

Do you mean posision as the posision specified in gconf? Because that
would be interesting. There is a configuration option for panel applets,
called panel_right_stick. It seems that all of thiese problems are
related to applets on the far right of the screen. Has anyone tried to
move the panels a couple of pixels away from the edge and other applets
and made sure panel_right_stick isn't enabled? It's just a wild guess,
but could be worth a try.

Is it always the clock that's being pushed to the left? It's the applet
that takes the longest time to load here.. Might that have anything to
do with it?

Actually it's stopped doing this. I don't believe I've done anything
differently. It's gone from a problem happening every reboot to
happening every month etc. The next time it does happen I will move
the icons a few pixels away and test this

On Feb 6, 2008 10:26 AM, Jo-Erlend Schinstad
<email address hidden> wrote:
> Do you mean posision as the posision specified in gconf? Because that
> would be interesting. There is a configuration option for panel applets,
> called panel_right_stick. It seems that all of thiese problems are
> related to applets on the far right of the screen. Has anyone tried to
> move the panels a couple of pixels away from the edge and other applets
> and made sure panel_right_stick isn't enabled? It's just a wild guess,
> but could be worth a try.
>
> Is it always the clock that's being pushed to the left? It's the applet
> that takes the longest time to load here.. Might that have anything to
> do with it?
>
>
> --
> GNOME Panel icons (on right side) move apparently randomly on session start in some situations
> https://bugs.launchpad.net/bugs/44082
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Patience yields far greater results than brute force or rage ever
could so relax......it's just life !!!

Tom Badran (tom-badran) wrote :

For me the problem did always seem to come and ago, i could often do many
reboots/relogs with no problems, then it would move stuff around every time
etc.

On Feb 6, 2008 5:41 PM, John Toliver <email address hidden> wrote:

> Actually it's stopped doing this. I don't believe I've done anything
> differently. It's gone from a problem happening every reboot to
> happening every month etc. The next time it does happen I will move
> the icons a few pixels away and test this
>
> On Feb 6, 2008 10:26 AM, Jo-Erlend Schinstad
> <email address hidden> wrote:
> > Do you mean posision as the posision specified in gconf? Because that
> > would be interesting. There is a configuration option for panel applets,
> > called panel_right_stick. It seems that all of thiese problems are
> > related to applets on the far right of the screen. Has anyone tried to
> > move the panels a couple of pixels away from the edge and other applets
> > and made sure panel_right_stick isn't enabled? It's just a wild guess,
> > but could be worth a try.
> >
> > Is it always the clock that's being pushed to the left? It's the applet
> > that takes the longest time to load here.. Might that have anything to
> > do with it?
> >
> >
> > --
> > GNOME Panel icons (on right side) move apparently randomly on session
> start in some situations
> > https://bugs.launchpad.net/bugs/44082
> > You received this bug notification because you are a direct subscriber
> > of the bug.
> >
>
>
> --
> Patience yields far greater results than brute force or rage ever
> could so relax......it's just life !!!
>
> --
> GNOME Panel icons (on right side) move apparently randomly on session
> start in some situations
> https://bugs.launchpad.net/bugs/44082
> You received this bug notification because you are a direct subscriber
> of the bug.
>

rhydse (rhydse) wrote :

Same problem me too

hsJc (hongshaojichi) wrote :

Totally agree with Tom Badran

Ferenc Magyar (garferi) wrote :

Confirm this!

Liken Otsoa (liken) wrote :

Same problem. Frecuently panel interchange order. Notification area puts himself at right.
I attach screenshot, normal and changed composite:

Dave Vree (hdave) wrote :

My right justified panel applets are always in the wrong place whenever I reboot with a different screen resolution. Was happening with Gutsy, still happening with Hardy. Will try leaving a little space in between them, but I doubt it will help.

Dave Vree (hdave) wrote :

Apparently, fixing this issue is on the Gnome 2.24 roadmap. Check it out:

http://live.gnome.org/RoadMap

rai4shu2 (rai4shu2) wrote :

I respectfully disagree. That roadmap only states "when Panel size changes," and that has nothing to do with this bug. This bug (probably) has more to do with the fact that applets have variable widths and are configured to specific locations that cause massive confusion in the panel rendering if you happen to do things like log out and log back in a little later (which changes the size of the clock applet). There doesn't appear to be anything that gives priority to the order of the applet as opposed to its exact position.

Ramy (ramy-daghstani) wrote :

i also get this problem.
it happens on boot and i think sometimes when i switch between metcity and compiz. and then sometimes not. I wish i could give them an order starting from the right instead of giving them a position...

Dan Ziemba (zman0900) wrote :

I can confirm this bug as well, but I don't think it is an Ubuntu issue. I have experienced the same things described by Tom on both Ubuntu 8.04 (upgraded from 7.10) and on Gentoo running GNOME 2.22.3. I have numerous applets and launchers on the top right of my screen that switch places, as well as a few on the bottom right. The thing on the top and bottom left never move. The things that switch places only do so about half the time, and once after I logged on and off about ten times, they went back to where they belonged.

My setup is a 17in laptop screen running at 1680x1050 at 96dpi using the 'nvidia' driver. On both Ubuntu and Gentoo all the items on the panel were locked, and panels were expanded.

Changed in gnome-panel:
status: New → Confirmed
Riccardo 'c10ud' (c10ud) wrote :

i confirm this annoying bug:

if resolution gets changed (i.e. fullscreen apps) the icons on the panel get scrambled after a reboot, even with "lock on panel activated"

this is VERY annoying

Geert Jan Alsem (gj-alsem) wrote :

C10uD, you should specifiy which version of Ubuntu/GNOME you are using. But unless it's Ubuntu 8.10/GNOME 2.24 you don't have to bother.

So, has anyone tried GNOME 2.24 yet? This bug was planned to be fixed in that release. I'll try GNOME 2.24 myself in a couple of days when the Ubuntu 8.10 beta comes out.

John Toliver (john-toliver) wrote :

Slightly off topic but I was trying to install nautilus 2.24 (or whichever
version comes with intrepid). I enabled the repos from intrepid and still
nothing. Any ideas?

On Tue, Sep 30, 2008 at 12:26, Geert Jan Alsem <email address hidden> wrote:

> C10uD, you should specifiy which version of Ubuntu/GNOME you are using.
> But unless it's Ubuntu 8.10/GNOME 2.24 you don't have to bother.
>
> So, has anyone tried GNOME 2.24 yet? This bug was planned to be fixed in
> that release. I'll try GNOME 2.24 myself in a couple of days when the
> Ubuntu 8.10 beta comes out.
>
> --
> GNOME Panel icons (on right side) move apparently randomly on session start
> in some situations
> https://bugs.launchpad.net/bugs/44082
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
I've discovered the key to success is to never give up. You either learn
the right way, or you run out of ways to do it wrong. A win/win situation!

Changed in hundredpapercuts:
status: New → Invalid
Ryan Maki (ryan.maki) on 2009-06-20
Changed in hundredpapercuts:
assignee: nobody → Ryan Maki (ryan.maki)
status: Invalid → In Progress
Ryan Maki (ryan.maki) on 2009-08-07
Changed in hundredpapercuts:
status: In Progress → Fix Committed
Changed in hundredpapercuts:
milestone: none → round-7
Changed in hundredpapercuts:
status: Fix Committed → In Progress
-JojoMan- (jojoman02) on 2009-11-01
description: updated
tags: added: qa-karmic-desktop
Changed in hundredpapercuts:
milestone: round-7 → r1
Changed in hundredpapercuts:
assignee: Ryan Maki (ryan.maki) → Canonical Desktop Team (canonical-desktop-team)
Martin Pitt (pitti) on 2009-12-01
Changed in hundredpapercuts:
assignee: Canonical Desktop Team (canonical-desktop-team) → Ryan Maki (ryan.maki)
description: updated
Vish (vish) on 2010-02-10
Changed in hundredpapercuts:
importance: Undecided → Low
Changed in gnome-panel (Ubuntu):
status: Triaged → Fix Committed
Changed in gnome-panel (Ubuntu):
status: Fix Committed → Fix Released
Changed in hundredpapercuts:
status: In Progress → Fix Committed
status: Fix Committed → Fix Released
Ivanka Majic (ivanka) on 2010-03-12
tags: added: gloam
Ronnie (ronnie.vd.c) on 2010-04-01
Changed in hundredpapercuts:
status: Fix Released → Confirmed
Changed in gnome-panel (Ubuntu):
status: Fix Released → Confirmed
Changed in gnome-panel:
status: Confirmed → Fix Released
Changed in gnome-panel (Ubuntu):
status: Confirmed → Triaged
Changed in hundredpapercuts:
status: Confirmed → Triaged
milestone: lucid-round-1 → maverick-round-7-notifications+gtk
154 comments hidden view all 234 comments
Zoubidoo (zoubidoo) wrote :

Please re-open this bug, it is not fixed in up-to-date Lucid.
Please increase importance, this is affecting at least 250 people.

The panel shuffle is alive and well in gnome-panel version 1:2.30.2-0ubuntu0.2 It has been around for over a year.

Michał Gołębiowski (mgol) wrote :

@Zoubidoo
You should write Your concerns on the GNOME bug instance, not here. Nowhere here is this bug marked as "Fix Released".

Kevin Hunter (hunteke) wrote :

Given the number of duplicates and people subscribed to this bug, I thought I'd offer a workaround that I recently discovered: Docky. As I currently see it, the gist of docky is to recreate, in open-source fashion, the OS X dock. On OS X I find the dock annoying, but since installing Docky, I rather enjoy it. I believe it only available if you're running Karmic or newer.

For Lucid, it's already part of the repositories:

$ sudo apt-get install docky

If you're running Karmic, I direct you to the docky site, but it's basically 3 command line operations, not one: http://www.go-docky.com/

For myself, I've even gained some vertical space on my screen because I'm now able to remove the bottom panel, after enabling fade away in Docky.

A suggestion.

Andrew (passa) wrote :

You now what, I'm finally sick of it. This bug, and the associated saga behind it, is absolutely ridiculous.

Me, personally, I lodged a ticket for this bug back sometime in 2006. I was quite enthusiastic about doing my bit to help improve Ubuntu. It's now been more than four years since I originally put this bug in. It was labelled a duplicate of all these others, so I was put into the mailing list for them as well.

For four years, I have received email notifications as people discussed the bug. Sometimes it was once every few weeks. Sometimes it was a few a day. Most of the time I just deleted them, but I never had the heart to label them as spam (nor could be bothered to remove myself from the mailing lists).

I have no doubt these emails/comments amount in the hundreds. Discussing the complexities of solving why a bunch of icons swap their order when you reboot. That's it. Four years later, I've gone through many desktop computers (though have kept the same laptop).. and through all 11 major releases of Ubuntu in this time, it has never been fixed, and still annoys the shit out of me in the latest version of Mint I installed a few days ago.

But the most incredulous rant inducing thing is not that the bug hasn't been fixed (Windows has plenty of irritating issues that have plagued it since 95 right to 7), but that people can discuss it for four years with hundreds of comments and neither fix the problem or even get any closer to fixing it. It is a damning indictment of the Ubuntu community - something that can, and does do great things, but also wastes a huge fuck-ton of time.

So in essence, you all waste a huge fuck-ton of time. Would love to see this fixed once and for all in Meerkat. But it won't be.

Passa: I understand your frustration. But here are your options:

1) Go upstream and try to help out GNOME with patches or ideas on patches.
2) Unsubscribe from this bug.
3) Try a different desktop environment.

I'm very sorry that you've been badly afflicted by this bug but there is nothing that can be done until there is someone that can do it. The best that we (as in Ubuntu/launchpad) can do is generate ideas and patches (which has been done) until something happens.

This bug is certainly an example of one of the problems that plagues GNOME: five+ year old annoyance bugs. But unless there is something we can do personally to help, I don't think we have a right to swear up a storm (on an indirect bug report, no less).

Also, side note to Kevin. I think you might find with some research that Mac is actually the one that, in closed-source fashion, recreated the Looking-Glass dock :).

Kevin Hunter (hunteke) wrote :

Thank you Chancellor, I stand corrected on that front. Apologies to any I might have insulted by my "OS X Dock recreation" description. Regardless, I suggest it's a good concept, or at least a usable workaround to this fairly annoying bug.

If you're looking for an easy workaround, then I'll present you with one: use two floating top panels, one for the menubar, and other stuff you have on the left, and one for clock, session menus, notifiers and other things you have on the right. As your resolution changes back and forth, the panels are moved back and forth, but the icons stay where they are relative to each other.

Problem solved. At least for now.

Dylan McCall (dylanmccall) wrote :

The source of this problem is really close to the heart of the panel's
design. It allows user-defined positions for applets, and these are
stored with absolute values (in pixels). No amount of fiddling will
change that that is a very poor, inflexible design. A better design
can be seen in XFCE's panel and in some kinds of customizable toolbars
like that in Firefox and some Gnome applications like Epiphany and
Evince.

Even if someone _does_ figure out how to maintain applet layout when
the resolution changes, there will be a hundred more bugs from the
same place. What this really calls for is a true gnome-panel
successor. (Which is a nice opportunity to deal with our last Bonobo
dependency, too).

I get the feeling such a project would actually be quite satisfying to
do. More-so than digging into this bug.

Changed in gnome-panel:
importance: Unknown → High
Keith Allcock (keith-allcock) wrote :

This bug is marked as fixed when using gnome-panel - 1:2.29.92-0ubuntu1, yet I am running maverick with gnome-panel 1:2.30.2 and still have the issue.
Has the fix not been included in the maverick packages or is it not fixed?

Rafael García (rgo) wrote :

Will be fixed in maverick in some update?

Because, as said Keith Allcock, gnome-panel version included is after to the fixed one. Perhaps is it fixed in debian packages and not in ubuntu packages already?

I thought the general understanding was that this bug wasn't going to be fixed as the underlying architecture was going to be redone as gnome 3.0 will be released within the next year or so and will replace 2.26. I could be wrong though.
-----Original Message-----
From: Rafael García <email address hidden>
Sender: <email address hidden>
Date: Sun, 17 Oct 2010 21:44:57
To: <email address hidden>
Reply-To: Bug 44082 <email address hidden>
Subject: [Bug 44082] Re: GNOME Panel icons (on right side) move apparently
 randomly on session start in some situations

Will be fixed in maverick in some update?

Because, as said Keith Allcock, gnome-panel version included is after to
the fixed one. Perhaps is it fixed in debian packages and not in ubuntu
packages already?

--
GNOME Panel icons (on right side) move apparently randomly on session start in some situations
https://bugs.launchpad.net/bugs/44082
You received this bug notification because you are a direct subscriber
of the bug.

Status in Desktop panel for GNOME: Fix Released
Status in One Hundred Paper Cuts: Triaged
Status in “gnome-panel” package in Ubuntu: Triaged
Status in “gnome-panel” source package in Hardy: Triaged

Bug description:
The items on the gnome panel is disordered in some cases, one of these being changing the screen reolution, possibly other, more random, cases as well.

-----

Temporary solution:
Backup the state of your panel:
gconftool-2 --dump /apps/panel panel_backup.xml

and then restore it whenever it gets messed up:
gconftool-2 --load panel_backup.xml
killall gnome-panel (kills and auto-respawns, possibly need to run gnome-panel & as well)

-----

I have noticed for a while now that the above-mentioned phenomenon occurs when I, say, return from a shut-down. However, the strange thing is that it only happens on some occations. I don't really know what the problem is, so I can't, unfortunately, post more information.

To unsubscribe from this bug, go to:
https://bugs.launchpad.net/gnome-panel/+bug/44082/+subscribe

ricardisimo (ricardisimo) wrote :

I don't have the fortitude necessary to read all 205 comments before mine, but the problem is not just with launcher icons on the top panel, in case that was not yet brought up by someone else. I constantly have to reorder the icons on the right-hand side of the lower panel. It is annoying, to say the least.

Joel Wright (joelwright1) wrote :

I can confirm this bug in Ubuntu 10.04 with GNOME 2.30.2

I have Ubuntu installed on my laptop which I like to connect to a large external monitor when I am working at home. I have tried locking/unlocking all applets and have made sure that the applets I want stuck to the right edge of the screen have the "panel-right-stick" option checked in gconf. No matter what, when I change resolution or reboot, these settings are lost.

sk8erbender (damnus) wrote :

I can confirm this bug in Ubuntu 10.10 with GNOME 2.30.2
When I reboot ,settings are lost.

Kevin Hunter (hunteke) wrote :

sk8erbender: Thank you for the bug confirmation. However, Dylan McCall put it succinctly in comment #202: "The source of this problem is really close to the heart of the panel's design. It allows user-defined positions for applets, and these are stored with absolute values (in pixels). No amount of fiddling will change that that is a very poor, inflexible design."

Unless a dev corrects me, this bug will not be fixed. It will only go away when a replacement is enacted, or there is a complete redesign of the fundamental panel code architecture and assumptions. In the meantime, there are a number of workarounds in the discussion above, but for now, this paper cut will continue to bleed.

Some workaround suggestions in the comments above:
Comment #110
Comment #197
Comment #201

sk8erbender (damnus) wrote :

heh then im gonna change to lxde maybe peppermint ice or something ;)

John Toliver (john-toliver) wrote :

This bug will not be fixed. In theory, the problem is going to be corrected whenever gnome 3.0 is released, and will have a completely different architecture for panels etc.
-----Original Message-----
From: Kevin Hunter <email address hidden>
Sender: <email address hidden>
Date: Mon, 25 Oct 2010 18:35:01
To: <email address hidden>
Reply-To: Bug 44082 <email address hidden>
Subject: [Bug 44082] Re: GNOME Panel icons (on right side) move apparently
 randomly on session start in some situations

sk8erbender: Thank you for the bug confirmation. However, Dylan McCall
put it succinctly in comment #202: "The source of this problem is really
close to the heart of the panel's design. It allows user-defined
positions for applets, and these are stored with absolute values (in
pixels). No amount of fiddling will change that that is a very poor,
inflexible design."

Unless a dev corrects me, this bug will not be fixed. It will only go
away when a replacement is enacted, or there is a complete redesign of
the fundamental panel code architecture and assumptions. In the
meantime, there are a number of workarounds in the discussion above, but
for now, this paper cut will continue to bleed.

Some workaround suggestions in the comments above:
Comment #110
Comment #197
Comment #201

--
GNOME Panel icons (on right side) move apparently randomly on session start in some situations
https://bugs.launchpad.net/bugs/44082
You received this bug notification because you are a direct subscriber
of the bug.

Status in Desktop panel for GNOME: Fix Released
Status in One Hundred Paper Cuts: Triaged
Status in “gnome-panel” package in Ubuntu: Triaged
Status in “gnome-panel” source package in Hardy: Triaged

Bug description:
The items on the gnome panel is disordered in some cases, one of these being changing the screen reolution, possibly other, more random, cases as well.

-----

Temporary solution:
Backup the state of your panel:
gconftool-2 --dump /apps/panel panel_backup.xml

and then restore it whenever it gets messed up:
gconftool-2 --load panel_backup.xml
killall gnome-panel (kills and auto-respawns, possibly need to run gnome-panel & as well)

-----

I have noticed for a while now that the above-mentioned phenomenon occurs when I, say, return from a shut-down. However, the strange thing is that it only happens on some occations. I don't really know what the problem is, so I can't, unfortunately, post more information.

To unsubscribe from this bug, go to:
https://bugs.launchpad.net/gnome-panel/+bug/44082/+subscribe

  or just play around with awn ;)

On 10/25/2010 09:02 PM, sk8erbender wrote:
> heh then im gonna change to lxde maybe peppermint ice or something ;)
>

Yeah but awn I noted doesn't always work with some applications. Like I have a windows app installed under wine and the shortcut I place on my desktop won't work in awn. It does that thing where the icon will move telling you the pc is doing something and then everything stops (the pc wants you to forget you clicked on the icon)

Only way it works is either on the desktop, from the menu, or from the panel.
-----Original Message-----
From: Sandro Mani <email address hidden>
Sender: <email address hidden>
Date: Mon, 25 Oct 2010 19:14:29
To: <email address hidden>
Reply-To: Bug 44082 <email address hidden>
Subject: Re: [Bug 44082] Re: GNOME Panel icons (on right side) move apparently
 randomly on session start in some situations

  or just play around with awn ;)

On 10/25/2010 09:02 PM, sk8erbender wrote:
> heh then im gonna change to lxde maybe peppermint ice or something ;)
>

--
GNOME Panel icons (on right side) move apparently randomly on session start in some situations
https://bugs.launchpad.net/bugs/44082
You received this bug notification because you are a direct subscriber
of the bug.

Status in Desktop panel for GNOME: Fix Released
Status in One Hundred Paper Cuts: Triaged
Status in “gnome-panel” package in Ubuntu: Triaged
Status in “gnome-panel” source package in Hardy: Triaged

Bug description:
The items on the gnome panel is disordered in some cases, one of these being changing the screen reolution, possibly other, more random, cases as well.

-----

Temporary solution:
Backup the state of your panel:
gconftool-2 --dump /apps/panel panel_backup.xml

and then restore it whenever it gets messed up:
gconftool-2 --load panel_backup.xml
killall gnome-panel (kills and auto-respawns, possibly need to run gnome-panel & as well)

-----

I have noticed for a while now that the above-mentioned phenomenon occurs when I, say, return from a shut-down. However, the strange thing is that it only happens on some occations. I don't really know what the problem is, so I can't, unfortunately, post more information.

To unsubscribe from this bug, go to:
https://bugs.launchpad.net/gnome-panel/+bug/44082/+subscribe

NicoLehmann (ekorn) wrote :

It's more a workaround than a solution for me but this seems to work:
gconftool-2 -s /apps/panel/global/locked_down --type=bool true
if you want to change something you have to set it back to false.

Vish (vish) wrote :

Thank you for bringing this bug to our attention.
 - We missed this for Maverick. Natty will use Unity for the desktop as well, and gnome-panel will not be used.
Also no one knows what is causing the bug.
For further information about papercuts criteria, please read https://wiki.ubuntu.com/PaperCut.
Don't worry though, this bug has been marked as "Invalid" only in the papercuts project.

Changed in hundredpapercuts:
assignee: Ryan Maki (ryan.maki) → nobody
milestone: maverick-round-7-notifications+gtk → none
status: Triaged → Invalid
importance: Low → Undecided
Changed in gnome-panel:
status: Fix Released → Confirmed
John Toliver (john-toliver) wrote :

So does the status being a confirmed fix release mean that eventually the fix will get pushed out in an update at some point in the future?
Sent from my Verizon Wireless BlackBerry

-----Original Message-----
From: Bug Watch Updater <email address hidden>
Sender: <email address hidden>
Date: Sun, 21 Nov 2010 15:27:22
To: <email address hidden>
Reply-To: Bug 44082 <email address hidden>
Subject: [Bug 44082] Re: GNOME Panel icons (on right side) move apparently
 randomly on session start in some situations

** Changed in: gnome-panel
       Status: Fix Released => Confirmed

--
GNOME Panel icons (on right side) move apparently randomly on session start in some situations
https://bugs.launchpad.net/bugs/44082
You received this bug notification because you are a direct subscriber
of the bug.

Status in Desktop panel for GNOME: Confirmed
Status in One Hundred Paper Cuts: Invalid
Status in “gnome-panel” package in Ubuntu: Triaged
Status in “gnome-panel” source package in Hardy: Triaged

Bug description:
The items on the gnome panel is disordered in some cases, one of these being changing the screen reolution, possibly other, more random, cases as well.

-----

Temporary solution:
Backup the state of your panel:
gconftool-2 --dump /apps/panel panel_backup.xml

and then restore it whenever it gets messed up:
gconftool-2 --load panel_backup.xml
killall gnome-panel (kills and auto-respawns, possibly need to run gnome-panel & as well)

-----

I have noticed for a while now that the above-mentioned phenomenon occurs when I, say, return from a shut-down. However, the strange thing is that it only happens on some occations. I don't really know what the problem is, so I can't, unfortunately, post more information.

To unsubscribe from this bug, go to:
https://bugs.launchpad.net/gnome-panel/+bug/44082/+subscribe

takeda64 (takeda64) wrote :

Let's see... a bug reported in in May 2006.. I wouldn't hold my breath if I were you.

BTW: Fix Released -> Confirmed is a step backwards. I think this bug will still be open in 2016.

I switched to another distro that uses KDE, it doesn't have this bug, though it has some other. Though it seems it's still less than GNOME. I personally think entire graphical user interface in linux should be redone from scratch. It's just a hack on top of another hack and it is full of race conditions which cause tons of heisenbugs.
It's almost like windows 9x.

Linux by itself isn't bad, it's very good when you use it from command line, but GUI is extremely frustrating because of small random bugs like this.

racecar56 (racecar56) wrote :

I can confirm this on my ASUS EeePC 1201T with Ubuntu 10.10. I think it happens when I switch back to the internal monitor coming back from an external VGA LCD with a larger resolution than the internal monitor.

rief (rief-the-dreamer) wrote :

I can confirm this on my Debian unstable with gnome-panel 2.30.2-4 for i386. I have this problem sometimes when the screen resolution is too small and the panel can't contain all the applets. For example starting a game with wine and the game changes the resolution, I obtain this bug. The funny thing is that it doesn't delete applets, it just change them position so the problem of containing applets still remains.

Kevin Hunter (hunteke) wrote :

@reif: The short answer is that this bug will not be fixed. For more context, please read these comments in this thread:

Comment #110
Comment #188
Comment #197
Comment #201
Comment #202

Changed in gnome-panel:
status: Confirmed → Fix Released
description: updated

It seems the problem is gone in Natty Gnome Classic mode:

In Natty the "Indicator Applet Complete" is used. It says "An applet to hold all of the system indicators".

This applet is a container which holds other applets. The good thing is, that the individual applets _cannot_ be moved but only the whole applet container! With this applet container it seems that this applet solves the problem with moving applets apparently around!

This nice "Indicator Applet Complete" is avalaible in Lucid LTS, too. But I haven't tested it there.

Geert Jan Alsem (gj-alsem) wrote :

felix.rommel, the problem is not "gone" in Natty. The problem is only a bit less bad, because all the indicators are grouped in one applet. But the order of different applets still gets messed up sometimes.

The problem should be gone in Oneiric Ocelot though, because of the upgrade to GNOME 3. I haven't tested it myself, but in the changelogs they say that in gnome-panel 3 all the old annoying bugs of gnome-panel 2 have been fixed.

On Sun, Jun 26, 2011 at 11:21, Geert Jan Alsem <email address hidden> wrote:
> felix.rommel, the problem is not "gone" in Natty. The problem is only a
> bit less bad, because all the indicators are grouped in one applet. But
> the order of different applets still gets messed up sometimes.

Yep, I have tested on Natty, and still there.

> The problem should be gone in Oneiric Ocelot though, because of the
> upgrade to GNOME 3. I haven't tested it myself, but in the changelogs
> they say that in gnome-panel 3 all the old annoying bugs of gnome-panel
> 2 have been fixed.

From what I have seen until now from Gnome 3 I don't like it - either
prefer Unity. I hope it will all come to a good end until next LTS on
12.04...

--
Martin Wildam

http://www.google.com/profiles/mwildam

avdd (avdd) wrote :

I am observing this behaviour in lucid, but didn't see it in karmic 9.10.

Martin Wildam (mwildam) wrote :

On Mon, Jul 11, 2011 at 11:38, avdd <email address hidden> wrote:
> I am observing this behaviour in lucid, but didn't see it in karmic
> 9.10.

I observed that issue in general only after you first moved something
on the right side manually. Or basically, as long as you re-align your
panels (content) on a large screen and then working only <= that size,
everything works.

--
Martin Wildam

http://www.google.com/profiles/mwildam

1 comments hidden view all 234 comments
Oussama Bounaim (obounaim) wrote :

screenshot of my panel

1 comments hidden view all 234 comments
Tyler Wagner (tyler) wrote :

I confirm that NicoLehmann's work-around in comment #214 works. Setting global/locked_down on the panel prevents the applets from wandering during screen resolution changes.

bojo42 (bojo42) wrote :

While it's great that locking down the panel solves this annoying bug, i like to change my panel configuration from time to time and as i am lazy i like to do that from the panel itself. As i didn't found any panel applet for this job i wrote this little shell script, which i trigger through a regular panel launcher.

If you like to do that as well:
- download the script somewhere (at best in your home directory, as it's by default a hidden file)
- make sure it got execute permissions
- create a launcher in the panel and enter the location of the script as command (like /home/USER/.gnome2_panel_lock_down)
- install the "libnotify-bin" package OR disable notifications in the script with your favorite editor (like "NOTIFY=off")

Have fun. To me this solution is rather nice, also because the amount of people still caring about the old panel is quite shrinking and i don't think this will ever get fixed.

bojo42 (bojo42) wrote :

Oops, seems like upload tool doesn't like hidden files or at least it failed. Rename to ".gnome2_panel_lock_down" after downloading if you like.

bojo42 (bojo42) wrote :

As the upload tool of launchpad doesn't work right now, here is my lazy lock down script:

#!/bin/sh

### Config
NOTIFY=on #(on/off)
LOCK_TITLE="Panel Lock Down"
LOCK_MSG="Locking the GNOME panel"
UNLOCK_TITLE="Panel Lock Down"
UNLOCK_MSG="Unlocking the GNOME panel"
LOCK_ICON="/usr/share/icons/hicolor/48x48/apps/gdu-encrypted-lock.png"
UNLOCK_ICON="/usr/share/icons/hicolor/48x48/apps/gdu-encrypted-unlock.png"

### Dependency checking
if [ -z "$(which gconftool-2)" ]; then
 if [ -n "$(which gconftool-2)" ]; then
  zenity --warning --text "Error. No binary found for gconftool-2!" --title "Panel Lock Down"
 else
  echo "Panel Lock Down: Error. No binary found for gconftool-2!"
 fi
 exit 1
fi
if [ "$NOTIFY" = "on" ] && [ -z "$(which notify-send)" ]; then
 SCRIPT_LOCATION="$(pwd)/$(basename $0)"
 if [ -n "$(which zenity)" ]; then
  zenity --warning --text "Notifcations failed! Please install the libnotify-bin package or disable notifications in $SCRIPT_LOCATION" --title "Panel Lock Down"
 else
  echo "Panel Lock Down: Notifcations failed! Please install the libnotify-bin package or disable notifications in $SCRIPT_LOCATION"
 fi
 NOTIFY="off"
fi

### Main
if [ "$(gconftool-2 -g /apps/panel/global/locked_down)" = "true" ]; then
 [ "$NOTIFY" = "on" ] && notify-send -i $UNLOCK_ICON "$UNLOCK_TITLE" "$UNLOCK_MSG"
 gconftool-2 -s /apps/panel/global/locked_down --type=bool false
elif [ "$(gconftool-2 -g /apps/panel/global/locked_down)" = "false" ]; then
 [ "$NOTIFY" = "on" ] && notify-send -i $LOCK_ICON "$LOCK_TITLE" "$LOCK_MSG"
 gconftool-2 -s /apps/panel/global/locked_down --type=bool true
else
 if [ -n "$(which zenity)" ]; then
  zenity --warning --text "Error. Undefined state of global panel lock down!" --title "Panel Lock Down"
 else
  echo 'Panel Lock Down: Error. Undefined state of global panel lock down!'
 fi
 exit 1
fi

Jeremy Bicha (jbicha) wrote :

This was fixed when gnome-panel was ported to GTK 3 last year. gnome-panel works pretty well in Ubuntu 12.04.

no longer affects: gnome-panel (Ubuntu Hardy)
Changed in gnome-panel (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
status: Triaged → Fix Released
Displaying first 40 and last 40 comments. View all 234 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.