Misleading error message - software source for package is not enabled

Bug #134918 reported by steve.horsley on 2007-08-26
84
Affects Status Importance Assigned to Milestone
restricted-manager (Ubuntu)
High
Martin Pitt
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

I just installed Gutsy tribe 5. Impressively, I get an alert straight away that a proprietary video driver is available. Of course I choose to install the driver, to which I receive a box with a no entry sign and the text:

The software source for package
   nvidia-glx-new
is not enabled.

Now, I know enough to know that I should launch Synaptic and enable the Multiverse and Universe repositories, but the Restricted Drivers icon in the system tray is for newcomers who will not know this. Worst, the messace could be interpreted as meaning that the software servers out there in the Internet are not enabled - perhaps I should try again in a few days when someone has enabled them?

I suggest that the message should go on to explain that the extra repositories can be enabled from the System->Software Sources configuration utility.

Perhaps it should also say which repositories should be enabled. I just went to Software Sources, and I see that Multiverse and Universe are indeed enabled. In fact, I kept getting that error message until I did a Reload in synaptic. Well done on prompting the user with driver info, but I think they need more help than the above error message.

I can confirm this using Gutsy Tribe 5 and an Nvidia GeForce FX 5600XT. When ticking the box to enable NVIDIA Accelerated graphics driver I received the message "The software source for the package nvidia-glx is not enabled". Looking at Software Sources, I saw that all repositories was ticked. I unticked and ticked them all and closed the window, which then reloaded the package lists and allowed me to install nvidia-glx.

Nanley Chery (nanoman) wrote :

Same problem here, and I was a little confused about what to do after receiving this message.

Changed in restricted-manager:
status: New → Confirmed
Matteo Z (matteozandi) wrote :

> Misleading error message

you are right, but if the package you want to install belongs to a software source which is not enabled, you have no chance to know anything about it with apt-cache.

Still we are aware of this issue, I wrote a few notes on
https://wiki.ubuntu.com/RestrictedManagerImprovements2
in order to come up with a good solution

About the software sources which are not updated and need to be 'reloaded', I believe this is a update-manager bug, I'll add it to the affected packages.

Nanley Chery (nanoman) on 2007-09-02
Changed in restricted-manager:
assignee: nobody → matteozandi
assignee: matteozandi → nobody
Michael Vogt (mvo) wrote :

Thanks for your bugreport.

Was this a fresh gutsy tribe5 install where it claimed that no nvidia-glx-new was available?

Thanks,
 Michael

Michael Vogt (mvo) wrote :

I can not think how this could be a update-manager bug, its more likely a bug in the default install that it does not come with the Packages.gz information for restricted or a bug in restricted-manager.

Changed in update-manager:
status: New → Invalid
steve.horsley (steve-horsley) wrote :

Yes, this was a fresh install of Gutsy tribe 5. The only deviation from a standard install, which I don't think is relevant, was that I tried to install Grub to the superblock of my jfs root partition instead of to the MBR, and this failed leaving me to manually install GRUB and create a menu.lst afterwards.

The little dialog coming from the notification area was there when I first logged in. My concern is really that this is probably the first interaction that newcomers will have with Ubuntu Linux, and it will simply confirm all their fears and the FUD that says Linux is hard and not suitable for normal users. It goes along the lines of;

There are special drivers available for your hardware. Would you like me to install them?
Ooh, yes please.
Well, I'm not going to. Figure out why for yourself.

It's going to send them running away screaming.

Matteo Z (matteozandi) wrote :

I tried to reproduce the "not updated" sources issue with no joy. Tribe 5 worked fine, r-m had no problems installing nvidia and nvidia_new.

Back to the topic of the misleading error message, this is due to the fact that apt has no evidence of packages if the repository they belong to is not enabled. So we don't know which repository is needed, e.g. universe for bcm43xx-fwcutter, thus the best we can do at the moment is printing a generic message.

Michael Vogt (mvo) wrote :

@steve.horlsey:
If you can still reproduce this issue, could you please run:
$ apt-cache madison nvidia-glx
on a terminal and attach the output here?

Matteo Z (matteozandi) on 2007-09-05
Changed in restricted-manager:
importance: Undecided → Low
status: Confirmed → Incomplete
Nanley Chery (nanoman) wrote :

A possible solution: give a shortcut to "Software Sources" inside the message. This way, the user could at least know where to go. Then it's just a simple matter of checking off the check boxes.

Matteo Z (matteozandi) wrote :

Michael: I reproduced the "not updated" sources issue. In my past try I only booted livecd in a virtualbox machine, now I installed the system.

matteo@gutsy:~$ apt-cache madison nvidia-glx
nvidia-glx | 1:1.0.9639+2.6.22.3-11.2 | http://us.archive.ubuntu.com gutsy/restricted Packages
linux-restricted-modules-2.6.22 | 2.6.22.3-11.2 | http://us.archive.ubuntu.com gutsy/restricted Sources

synthomps are the same as steve.horlsey described, main restricted universe and multiverse sources are enabled

Jamie Jackson (jamiejackson) wrote :

I had the same issues with Tribe 5 and the bcm43xx. I'm not exactly a new user, but I even had a head-scratching moment over the "The software source for package <whatever> is not enabled" message. I'd agree that a new user would be hopelessly lost.

Solution A sounds great from here (if only because I understand it, in comparison to solution B).
https://wiki.ubuntu.com/RestrictedManagerImprovements2

> A possible solution: give a shortcut to "Software Sources" inside the message. This way, the user could at least know where to go. Then it's just a simple matter of checking off the check boxes.

Well, there's also the "Update" step, which might not be intuitive.

In any case, I hope that *some* improvement is made by the Gutsy release, even if it is a more instructive message.

...and now I've gotta go off and file a bug for the bcm43xx simply not working (can't associate with listed APs in NM).

Nanley Chery (nanoman) on 2007-09-09
Changed in restricted-manager:
status: Incomplete → Confirmed
Martin Pitt (pitti) wrote :

Right. We need to wait until the daily cron job updated the apt lists, so that the package is actually available.

So a driver should check whether its driver package is available before it is offered for installation. This is easy to do and should be done by the final release to avoid this confusing user behaviour.

Changed in restricted-manager:
assignee: nobody → pitti
importance: Low → High
Michael Vogt (mvo) wrote :

The alternative approach is to offer a synaptic --update-at-startup --non-interactive run if it is not available and then re-check for the driver.

Martin Pitt (pitti) on 2007-09-26
Changed in restricted-manager:
status: Confirmed → Fix Committed
Martin Pitt (pitti) wrote :

restricted-manager (0.32) gutsy; urgency=low

  * RestrictedManager/{manager.glade,RestrictedManagerGtk.py}: Add a "Help"
    button and connect it to "yelp ghelp:hardware#restricted-manager", which
    provides a nice intro to restricted drivers. (LP: #134069)
  * bcm43xx.py, sl_modem.py: Uniformly name the variables for the driver
    package to "driver_package".
  * core.py: Add package_available() which uses apt-cache show to check
    whether a package is available for installation at all.
  * RestrictedManagerCommon.py, check mode: If the handler has a
    driver_package which is not available for installation, do not advertise
    it with a notification. (Gross Hacks R us, but it is good enough and
    unintrusive for Gutsy, and r-m is to be rewritten anyway in Hardy).
    (LP: #134918)

 -- Martin Pitt <email address hidden> Wed, 26 Sep 2007 13:09:26 +0200

Changed in restricted-manager:
status: Fix Committed → Fix Released
epicflux (jeremyisett) wrote :

I'm a noob to installing Ubuntu. I was ready to give up on the install till I found this forum. I went and checked off the repositories, the driver installed, and now the graphics card is fully operational. A link (or hint) to the Software Sources would have avoided a 6 hour stumper. I spent way to much in forums about editing the xorg.conf file. Thanks!

Thanks for the acknowlegement. It just struck me as soon as I saw it that
this message was going to be a real slap in the face for noobs. We really
don't want to send them away feeling insulted. Hell, even if you understand
what the message means, it's not true! How the hell is a noob supposed to
cope with that? Still, you've been there, haven't you.

Enjoy Linux. Its different to windows, but its not really harder, just
different. Similar in some ways, fundamentally different in other ways. But
I find it liberating - its more open that Win, and deeper too. There's no
point at which you hit a brick wall that says you can't look in here its
private. You can get to do computing as opposed to just running
applications, if you see the difference (which might take time). Use
ubuntuforums.org as a resource. They are friendly and helpful, and more
often than not can give you a good answer to your questions.

On 15/10/2007, epicflux <email address hidden> wrote:
>
> I'm a noob to installing Ubuntu. I was ready to give up on the install
> till I found this forum. I went and checked off the repositories, the
> driver installed, and now the graphics card is fully operational. A link
> (or hint) to the Software Sources would have avoided a 6 hour stumper. I
> spent way to much in forums about editing the xorg.conf file. Thanks!
>
> --
> Misleading error message - software source for package is not enabled
> https://bugs.launchpad.net/bugs/134918
> You received this bug notification because you are a direct subscriber
> of the bug.
>

rperfect (rperfect) wrote :

Hi, I'm a Noob/Newbie to Linux this is day one of trying out Gutsy and I ran into exactly this problem. All praise to Google I found this post and was able to fix this problem.

Nanley Chery (nanoman) wrote :

I still receive this error on installing the Final Image. It also happened to the reporter of Bug #153756. Could this have been just a transient network error due to the congestion of the servers?

Changed in restricted-manager:
status: Fix Released → Confirmed
Nico Zanferrari (nicozanf) wrote :

I also had exactly the same problem on the final Ubuntu 7.10 yesterday.

The software source for package
   nvidia-glx-new
is not enabled.

I took me an hour to realize that the problem was related to the repositories and not to the restricted manager itself.... I do know that the error is self explaining, but not for everyone (or not everytime ;-)

icek (icek39) wrote :

I am completely new to linux, so obviously Ubuntu as well. I have been having problems with this from the get go. Same error message as stated above:
"The software source for package
   nvidia-glx-new
is not enabled."
I have no clue how to fix this. I have done quite a few google searches and have tried for an entire day to get this working (please keep in mind I have never touched this stuff). I did find this article... http://ubuntuforums.org/showthread.php?p=3678338 and I tried to follow Dabl's directions however when I run envy I get the following message: Error: Dependency is not satisfiable: xserver-xorg-dev. I have also tried downloading the nvidia driver from nvidias website and launching the *.run file. Nothing seems to be working here. When I finally found the synaptic package manager, I had no idea what to do with it because repositories was greyed out. I logged out of that account and logged back in as root. Once I was logged in as root, the repositories option was no longer greyed out. When I click on respositories software sources comes up, but I have no idea what to do from here. It looks like this is where you choose where you want your updates coming from?I have tried checking everything on the ubuntu software tab(main, universe, restricted, multiverse, installable from cd-rom/dvd). There were some other things I have tried, but unfortunately with the amount of work I have to do, I have no more time to try to figure this one out until vacation. Any help would be greatly appreciated.

Martin Pitt (pitti) wrote :

This is solved differently in restricted-manager's successor (jockey). The drivers won't be shown at all if the packages are not available.

We also enable restricted by default, and if you install Gobuntu (which doesn't do this), then avoiding non-free drivers is the right thing to do anyway.

We will not change this in stable releases, though, it's too intrusive.

Changed in restricted-manager:
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers