Comment 3 for bug 134918

> Misleading error message

you are right, but if the package you want to install belongs to a software source which is not enabled, you have no chance to know anything about it with apt-cache.

Still we are aware of this issue, I wrote a few notes on
https://wiki.ubuntu.com/RestrictedManagerImprovements2
in order to come up with a good solution

About the software sources which are not updated and need to be 'reloaded', I believe this is a update-manager bug, I'll add it to the affected packages.