[regression] compiz crashes after Mesa upgrade

Bug #1735594 reported by Falk Bay on 2017-12-01
396
This bug affects 94 people
Affects Status Importance Assigned to Milestone
mesa (Ubuntu)
Undecided
Timo Aaltonen
Xenial
Undecided
Unassigned
Artful
Undecided
Unassigned

Bug Description

[Impact]
When I use the Unity session I automatically get logged out under these conditions:

    When I hover with my mouse over any icon of the sidebar.
    When I press the alt key.
    When I press the super key.

running dmesg after this unwanted logout happens I get following information:

compiz[10616]: segfault at 0 ip 00007fbca309feeb sp 00007fff5f59a4d0 error 4 in i965_dri.so[7fbca2af6000+7e4000]

This is caused by a mesa upgrade, which added a patch for bug #1727401. The crasher is reproduced on:
- gen4 / gen5 Intel
- if using modesetting X driver, like when xserver-xorg-video-intel is not installed, or the HWE stack is installed (xserver-xorg-core-hwe-16.04 defaults to modesetting)

[Test case]
Log in to Unity, open the dash or try to log out etc. Compiz shouldn't crash.

[Regression potential]
The backported patches need to be tested, here for regressions and on 1727401 that they fix the original bug (again).

Best to test on a wide array of Intel HW:
gen4 (965GM/GM45/G45)
gen5 (Ironlake)
gen6 (Sandy Bridge)
gen7 (Bay Trail, Ivy Bridge, Haswell)
gen8 (Braswell, Broadwell)
gen9 (Apollo Lake, Skylake, Gemini Lake, Kaby Lake, Coffee Lake)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nux (Ubuntu):
status: New → Confirmed
aleandro (aleandrodasilva) wrote :

Ubuntu 17.10

When I use the Unity session I automatically get logged out ot I get a crash of unity under this condition:

    When I hover with my mouse over the sidebar

I can use the top bar without problems instead. I upgraded to latest packages today.

Falk Bay (falkartis) wrote :

I edited the bug description to be more precise about what makes it happen.

description: updated
Falk Bay (falkartis) on 2017-12-07
affects: nux (Ubuntu) → compiz (Ubuntu)
Keri Alleyne (keri.alleyne) wrote :

Sorry about the cross posting but these may be potentially related bug reports:

https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/1741303
https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1741447

Falk Bay (falkartis) wrote :

Yes, the symptoms seem to be the same.

uwer@netic.de (uwer) wrote :

I have almost the same behavior with 16.04.3. It doesn't log me out but restarts Unity.
Freshly installed 16.04.3 runs normally. After installing updates Unity crashes exactly like in the OP. Same compiz segfault at 0 ip (...) error 4 in i965_dri.so (...) with slightly different addresses.

In low graphics mode it is a bit better but not completely gone.

As for hovering over the sidebar, it takes a half a second before Unity crashes, I suspect it happens when it tries to show the tooltip.

uwer@netic.de (uwer) wrote :

On 16.04.3 I used Synaptic to narrow down the packages that seem to cause the crash.
I installed packages, made not of them and rebooted to see if I could reproduce the problem.

The last four packages that were left over before the issue could be reproduced were:
libegl1-mesa 17.2.4-0ubuntu1~16.04.2
libgbm1 17.2.4-0ubuntu1~16.04.2
libgl1-mesa-dri 17.2.4-0ubuntu1~16.04.2
libwayland-egl1-mesa 17.2.4-0ubuntu1~16.04.2

These depend on each other, so I could not drill down further.
After installing these and rebooting, Unity crashed again.

uwer@netic.de (uwer) wrote :

*made _note_ of them*

Timo Aaltonen (tjaalton) wrote :

Bug misfiled, would've been useful to know about it a month ago :/

If you are able to build the package from ppa:ubuntu-x-swat/updates then that would be great. PPA builders are offline for days now because of SPECTRE.

affects: compiz (Ubuntu) → mesa (Ubuntu)
Changed in mesa (Ubuntu):
assignee: nobody → Timo Aaltonen (tjaalton)
Timo Aaltonen (tjaalton) wrote :

and could you run 'lspci -vnn | grep VGA' and tell what it says

uwer@netic.de (uwer) wrote :

thor@norb:~$ lspci -vnn |grep VGA
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07) (prog-if 00 [VGA controller])

thor@norb:~$ sudo lshw
[sudo] Passwort für thor:
norb
    Beschreibung: Notebook
    Produkt: 2847DGG
    Hersteller: LENOVO
    Version: ThinkPad SL510

On an almost identical laptop, that was setup with 16.04.1 or 16.04.2 (Don't remember) and has the 17.2.4-0ubuntu1~16.04.2 packages, the problem does not occur:
uwer@janeway:~$ lspci -vnn |grep VGA
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07) (prog-if 00 [VGA controller])

uwer@janeway:~$ sudo lshw
janeway
    Beschreibung: Notebook
    Produkt: 28477MG
    Hersteller: LENOVO
    Version: ThinkPad SL510

Timo Aaltonen (tjaalton) wrote :

huh, what kernel does those have?

Timo Aaltonen (tjaalton) wrote :

mesa 17.2.8 is now available for amd64 at
https://aaltoset.kapsi.fi/mesa-17.2.8/17.10 (/16.04)

you can try installing libgl1-mesa-dri and other pkgs it needs manually, this is not an apt repo.

uwer@netic.de (uwer) wrote :

Kernels:

thor@norb:~$ uname -r
4.10.0-42-generic

uwer@janeway:~$ uname -r
4.4.0-104-generic

Timo Aaltonen (tjaalton) wrote :

try 4.13, 4.10 is from the zesty stack and is EOL in a week

scuba (scubuntu) wrote :

I'm afraid this Bug has affected some of my installs too. My workaround for now is to activate "discreet graphics" in BIOS.

no longer affects: mesa
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mesa (Ubuntu Artful):
status: New → Confirmed
Changed in mesa (Ubuntu Xenial):
status: New → Confirmed
Timo Aaltonen (tjaalton) wrote :

I'm not able to reproduce this on a GM965 (2a02), tried on 4.4 & 4.10...

Tomas (sei-mai-neim-egen) wrote :

Timo Aaltonen (tjaalton) wrote 1 hour ago: #21
I'm not able to reproduce this on a GM965 (2a02), tried on 4.4 & 4.10...

-------

Are You on Ubuntu 16.04 ???

Timo Aaltonen (tjaalton) wrote :

of course

you can test ppa:paulo-miguel-dias/pkppa if mesa 17.3.1 fixes this for you too, as it did on 1741447

Robert Rojas (roberthrojasq) wrote :

This issue seems to affect Blender.
Blender fails to start, with the crash log being the following:

# backtrace
blender(BLI_system_backtrace+0x20) [0x1a6c8e0]
blender() [0x107a525]
/lib/x86_64-linux-gnu/libc.so.6(+0x354b0) [0x7f47797c04b0]
/usr/lib/x86_64-linux-gnu/dri/i965_dri.so(+0x5ddc16) [0x7f47650f0c16]
/usr/lib/x86_64-linux-gnu/dri/i965_dri.so(+0x5df30e) [0x7f47650f230e]
/usr/lib/x86_64-linux-gnu/dri/i965_dri.so(+0x5d1468) [0x7f47650e4468]
/usr/lib/x86_64-linux-gnu/dri/i965_dri.so(+0x5d2345) [0x7f47650e5345]
/usr/lib/x86_64-linux-gnu/dri/i965_dri.so(+0x3f34da) [0x7f4764f064da]
/usr/lib/x86_64-linux-gnu/dri/i965_dri.so(+0x3f3ddd) [0x7f4764f06ddd]
/usr/lib/x86_64-linux-gnu/dri/i965_dri.so(+0x42a333) [0x7f4764f3d333]
/usr/lib/x86_64-linux-gnu/dri/i965_dri.so(+0x17812e) [0x7f4764c8b12e]
/usr/lib/x86_64-linux-gnu/dri/i965_dri.so(+0x17dda3) [0x7f4764c90da3]
blender() [0x107e11d]
blender(wm_draw_update+0x3fe) [0x107f7ae]
blender(WM_main+0x28) [0x107b118]
blender(main+0x3f8) [0x1018bd8]
/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf0) [0x7f47797ab830]
blender() [0x107747e]

Timo Aaltonen (tjaalton) wrote :

uwer: which xserver versions do these machines have? apt-cache policy xserver-xorg-core

And do both have xserver-xorg-video-intel(-hwe-16.04) installed? One theory is that only machines installed with full HWE stack are affected, those do not have -intel installed but use the modesetting X driver (as intended).

Timo Aaltonen (tjaalton) wrote :

touché, after removing -intel I'm able to reproduce this \o/

Jaime Cruz (jaime-cruz) wrote :

xserver-xorg-core:
  Installed: (none)
  Candidate: 2:1.18.4-0ubuntu0.7
  Version table:
     2:1.18.4-0ubuntu0.7 500
        500 http://us.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu xenial-security/main amd64 Packages
     2:1.18.4-0ubuntu0.2 0
        100 /var/lib/dpkg/status
     2:1.18.3-1ubuntu2 500
        500 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 Packages

Timo Aaltonen (tjaalton) wrote :

The culprit is a patch added for bug 1727401, it needs to be replaced with a larger set of backports from 17.3...

Timo Aaltonen (tjaalton) on 2018-01-09
summary: - ubuntu automatically logs out when hovering sidebar
+ [regression] compiz crashes when hovering over sidebar
Timo Aaltonen (tjaalton) on 2018-01-09
description: updated
Timo Aaltonen (tjaalton) on 2018-01-09
summary: - [regression] compiz crashes when hovering over sidebar
+ [regression] compiz crashes after Mesa upgrade
Timo Aaltonen (tjaalton) wrote :

PPA builders are unfortunately still offline because of SPECTRE :(

One quick workaround for this issue is to downgrade to stock 16.04 xserver and install x-x-v-intel:

sudo apt install --install-recommends xserver-xorg xserver-xorg-video-all xserver-xorg-input-all xserver-xorg-video-intel

that should do it.. it'll remove a bunch of packages named -hwe-16.04 and replace them with the stock packages.

Timo Aaltonen (tjaalton) wrote :

this is a more complete command to install stock hwe stack on 16.04

sudo apt install --install-recommends xserver-xorg xserver-xorg-core xserver-xorg-video-all xserver-xorg-input-all xserver-xorg-video-intel xserver-xorg-video-qxl

ewa (ewa2u) wrote :

hi, I executed your command - the problem is always here...

The command from comment #30 has resolved this for me after a reboot. Thank you Timo.

ewa (ewa2u) wrote :

after reboot the problem is steel here. I'm on ubuntu 16.04 on Acer Aspire 7715Z.
I executed the command #30 twice and rebooted twice too.
uname -a gives acer 4.10.0-42-generic #46~16.04.1-Ubuntu SMP Mon Dec 4 15:57:59 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

I experienced the same problem on Acer Aspire 7715 and the Timo's solution solved it. Thank you.

ewa (ewa2u) wrote :

sudo apt-get update
then
sudo apt-get upgrade -y
then
Timo's solution resolved the problem, but introduced another one:
programs launcher doesn't respect the choice of workspace and it's impossible to go from one program to another through launcher - must select a workspace where the program is.

uwer@netic.de (uwer) wrote :

timo: Sorry for the delay.

uwer@janeway:~$ apt-cache policy xserver-xorg-core
xserver-xorg-core:
  Installiert: 2:1.18.4-0ubuntu0.7
  Installationskandidat: 2:1.18.4-0ubuntu0.7
  Versionstabelle:
 *** 2:1.18.4-0ubuntu0.7 500
        500 http://de.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu xenial-security/main amd64 Packages
        100 /var/lib/dpkg/status
     2:1.18.3-1ubuntu2 500
        500 http://de.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
Has xserver-xorg-video-intel 2:2.99.917+git20160325-1ubuntu1.2
No -hwe

thor@norb:~$ uname -a
Linux norb 4.13.0-26-generic #29~16.04.2-Ubuntu SMP Tue Jan 9 22:00:44 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

thor@norb:~$ apt-cache policy xserver-xorg-core
xserver-xorg-core:
  Installiert: (keine)
  Installationskandidat: 2:1.18.4-0ubuntu0.7
  Versionstabelle:
     2:1.18.4-0ubuntu0.7 500
        500 http://de.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu xenial-security/main amd64 Packages
     2:1.18.3-1ubuntu2 500
        500 http://de.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
Has xserver-xorg-video-intel-hwe-16.04 2:2.99.917+git20170309-0ubuntu1~16.04.1

Phil Norisez (norisezp) wrote :

How about withdrawing the update that causes this until fixed? Or, publishing some kind of advisory that doesn't require searching many threads to find???

Phil Norisez (norisezp) wrote :

This bug needs fixed for the following:

7.6 GiB Intel® Core™ i5 CPU M 480 @ 2.67GHz × 4 Intel® Ironlake Mobile 64-bit

Sorry I didn't add a comment elsewhere; not enough "Reputation Points" GAH!~

Timo Aaltonen (tjaalton) wrote :

There's no way to withdraw an update other than by dropping the offending patch, but since I already have a replacement available we should test that instead.

And now that the PPA builds are finally back, please test this one on xenial:

sudo apt-add-repository ppa:tjaalton/ppa && apt update && apt upgrade

but if you have the padoka ppa enabled, it needs to be removed first:

sudo ppa-purge ppa:paulo-miguel-dias/pkppa

and if you installed stock xenial xorg stack, reinstall -hwe-16.04 by:

sudo apt install --install-recommeds xserver-xorg-hwe-16.04

remember to reboot or at least log out after installing the new mesa from my ppa

Emmanuel Grumbach (egrumbach) wrote :

Testing....

Emmanuel Grumbach (egrumbach) wrote :

Timo,

I installed your ppa:

ii xserver-xorg-hwe-16.04 1:7.7+16ubuntu3~16.04.1 amd64 X.Org X server

Things are working.

Don't hesitate to ask me specific tests or other version if needed.

Thansk!!

Richard Harry (rharry) wrote :

comment #39 fixed it for me

Janghou (janghou) wrote :

ppa:tjaalton/ppa is working fine

FYI
glmark2 benchmark is down by ~25%, same as in padoka ppa
MESA:
17.2.4/8 152
17.0.7 206

ewa (ewa2u) wrote :

ppa doesn't work for me
sudo apt-add-repository ppa:tjaalton/ppa && apt update && apt upgrade

 Plus d’info : https://launchpad.net/~tjaalton/+archive/ubuntu/ppa
Appuyez sur [ENTRÉE] pour continuer ou Ctrl-C pour annuler l’ajout

gpg: le porte-clefs « /tmp/tmpvje1fdoi/secring.gpg » a été créé
gpg: le porte-clefs « /tmp/tmpvje1fdoi/pubring.gpg » a été créé
gpg: demande de la clef 621ADC80 sur le serveur hkp keyserver.ubuntu.com
gpg: /tmp/tmpvje1fdoi/trustdb.gpg : base de confiance créée
gpg: clef 621ADC80 : clef publique « Launchpad PPA for Timo Aaltonen » importée
gpg: Quantité totale traitée : 1
gpg: importées : 1 (RSA: 1)
OK
Lecture des listes de paquets... Fait
W: chmod 0700 of directory /var/lib/apt/lists/partial failed - SetupAPTPartialDirectory (1: Opération non permise)
E: Impossible d'ouvrir le fichier verrou /var/lib/apt/lists/lock - open (13: Permission non accordée)
E: Impossible de verrouiller le répertoire /var/lib/apt/lists/
W: Problème de suppression du lien /var/cache/apt/pkgcache.bin - RemoveCaches (13: Permission non accordée)
W: Problème de suppression du lien /var/cache/apt/srcpkgcache.bin - RemoveCaches (13: Permission non accordée)

sudo apt install --install-recommeds xserver-xorg-hwe-16.04
E: Command line option --install-recommeds is not understood in combination with the other options

ubuntu 16.04, 4.13.0-26-generic

Timo Aaltonen (tjaalton) wrote :

had a typo there -> "--install-recommends"

Chris Perry (clissold345) wrote :

sudo apt-add-repository ppa:tjaalton/ppa seems to have worked for me. Brief system details:

cpu:
                       Intel(R) Core(TM)2 Duo CPU T7100 @ 1.80GHz, 1800 MHz
                       Intel(R) Core(TM)2 Duo CPU T7100 @ 1.80GHz, 1800 MHz
keyboard:
  /dev/input/event3 AT Translated Set 2 keyboard
graphics card:
                       Lenovo ThinkPad T61/R61
                       Lenovo ThinkPad T61/R61

Hello Falk, or anyone else affected,

Accepted mesa into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mesa/17.2.4-0ubuntu1~17.10.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in mesa (Ubuntu):
status: Confirmed → Fix Committed
Changed in mesa (Ubuntu Artful):
status: Confirmed → Fix Committed
tags: added: verification-needed verification-needed-artful
Łukasz Zemczak (sil2100) wrote :

Hello Falk, or anyone else affected,

Accepted mesa into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mesa/17.2.4-0ubuntu1~16.04.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in mesa (Ubuntu Xenial):
status: Confirmed → Fix Committed
tags: added: verification-needed-xenial
Emmanuel Grumbach (egrumbach) wrote :

I am sorry, but I can't find how to install that package.

I did:

$ sudo apt-get update
Hit:1 http://il.archive.ubuntu.com/ubuntu xenial InRelease
Hit:2 http://il.archive.ubuntu.com/ubuntu xenial-updates InRelease
Hit:3 http://il.archive.ubuntu.com/ubuntu xenial-backports InRelease
Hit:4 http://il.archive.ubuntu.com/ubuntu xenial-proposed InRelease
Hit:5 http://security.ubuntu.com/ubuntu xenial-security InRelease
Ign:6 http://linux.dropbox.com/ubuntu xenial InRelease
Ign:7 http://linux.dropbox.com/ubuntu wily InRelease
Hit:8 http://linux.dropbox.com/ubuntu xenial Release
Hit:9 http://linux.dropbox.com/ubuntu wily Release
Reading package lists... Done

So clearly, -proposed is there.

And then:
$ sudo apt-get install mesa/xenial-proposed
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package mesa

What package exactly should I be looking for?

Timo Aaltonen (tjaalton) wrote :

"mesa" is the source package, try "sudo apt install libgl1-mesa-dri"... that should pull everything

Emmanuel Grumbach (egrumbach) wrote :

$ sudo apt-get install libgl1-mesa-dri/xenial-proposed
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Release 'xenial-proposed' for 'libgl1-mesa-dri' was not found

Timo Aaltonen (tjaalton) wrote :

your mirror hasn't been synced yet, use archive.ubuntu.com in the meantime

Emmanuel Grumbach (egrumbach) wrote :
Download full text (5.0 KiB)

$ sudo apt-get install libgl1-mesa-dri/xenial-proposed
Reading package lists... Done
Building dependency tree
Reading state information... Done
Selected version '17.2.4-0ubuntu1~16.04.3' (Ubuntu:16.04/xenial-proposed [amd64]) for 'libgl1-mesa-dri'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 indicator-bluetooth : Depends: unity-control-center but it is not going to be installed or
                                gnome-control-center but it is not going to be installed or
                                ubuntu-system-settings but it is not going to be installed
                       Depends: gnome-bluetooth but it is not going to be installed or
                                ubuntu-system-settings but it is not going to be installed
 liboxideqt-qmlplugin : Depends: libqt5quick5 (>= 5.0.2) but it is not going to be installed or
                                 libqt5quick5-gles (>= 5.0.2) but it is not going to be installed
 liboxideqtcore0 : Depends: libqt5gui5 (>= 5.4.0) but it is not going to be installed or
                            libqt5gui5-gles (>= 5.4.0) but it is not going to be installed
 liboxideqtquick0 : Depends: libqt5gui5 (>= 5.0.2) but it is not going to be installed or
                             libqt5gui5-gles (>= 5.0.2) but it is not going to be installed
                    Depends: libqt5quick5 (>= 5.2.0) but it is not going to be installed or
                             libqt5quick5-gles (>= 5.2.0) but it is not going to be installed
 libqmenumodel0 : Depends: libqt5gui5 (>= 5.0.2) but it is not going to be installed or
                           libqt5gui5-gles (>= 5.0.2) but it is not going to be installed
 libqt5multimedia5 : Depends: libqt5gui5 (>= 5.2.0) but it is not going to be installed or
                              libqt5gui5-gles (>= 5.2.0) but it is not going to be installed
 libqt5multimediaquick-p5 : Depends: libqt5gui5 (>= 5.0.2) but it is not going to be installed or
                                     libqt5gui5-gles (>= 5.0.2) but it is not going to be installed
                            Depends: libqt5quick5 (>= 5.4.0) but it is not going to be installed or
                                     libqt5quick5-gles (>= 5.4.0) but it is not going to be installed
 libqt5widgets5 : Depends: libqt5gui5 (>= 5.5.0) but it is not going to be installed or
                           libqt5gui5-gles (>= 5.5.0) but it is not going to be installed
 libubuntugestures5 : Depends: libqt5gui5 (>= 5.0.2) but it is not going to be installed or
                               libqt5gui5-gles (>= 5.0.2) but it is not going to be installed
                      Depends: libqt5quick5 (>= 5.0.2) but it is not going to be installed or
                               libqt5quick5-gles (>= 5.0.2) but it is not going to be installed
 libubuntutoolkit5 : Depends: libqt5gui5 (>= 5.0.2) but it is not going to be installed or
  ...

Read more...

MeanJim (meanjim) wrote :

I'm affected by this bug as well. I tried the -proposed package, but I'm getting the same error as Emmanuel Grumbach pasted above.

Timo Aaltonen (tjaalton) wrote :

you need to ppa-purge all extra ppa's, and then try again

or just run 'sudo apt update && apt upgrade' after enabling -proposed, that should work on top of my ppa (but not padoka's, since it has 17.3)

Leo Pilachowski (leopila) wrote :

It appears that the mirror I contact to still has not synced. How do I use "archive.ubuntu.com" ?

Phil Norisez (norisezp) wrote :

I got it to work, and it fixes my problem with the launcher resulting in an unknown file error on /usr/bin/compiz.

Go to Software & Updates via command line
ubuntu-software &
and selecting it from a list of apt applications.

Use Developer Options to enable xenial-proposed.

Then run command line:
sudo apt-get install libgl1-mesa-dri/xenial-proposed

This installed it for me.

Nelijuc (nelijuc) wrote :

I was affected by the regression introduced in mesa 17.2.4-0ubuntu1~16.04.2:amd64 in xenial-updates. After testing the packages 17.2.4-0ubuntu1~16.04.3:amd64 in xenial-proposed the regression is fixed.

I'm using ubuntu 16.04 hwe with kernel 4.13.0-26-generic.
My graphic card is "4 Series Chipset Integrated Graphics Controller" by Intel

tags: added: verification-done-xenial
removed: verification-needed-xenial
Janghou (janghou) wrote :

Proposed fixed it.

$ apt policy libgl1-mesa-dri
libgl1-mesa-dri:
  Installed: 17.2.4-0ubuntu1~16.04.3
  Candidate: 17.2.4-0ubuntu1~16.04.3
  Version table:
 *** 17.2.4-0ubuntu1~16.04.3 500
        500 http://archive.ubuntu.com/ubuntu xenial-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     17.2.4-0ubuntu1~16.04.2 -1
        500 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
     11.2.0-1ubuntu2 500
        500 http://archive.ubuntu.com/ubuntu xenial/main amd64 Packages

product: Mobile 4 Series Chipset Integrated Graphics Controller
vendor: Intel Corporation

Janghou (janghou) wrote :

@Emmanuel
If you get an error installing sudo apt-get install libgl1-mesa-dri/xenial-proposed, temporarily remove the file `/etc/apt/preferences.d/proposed-updates`

Add that file again afterwards to prevent upgrading all packages in proposed.
Package: *
Pin: release a=xenial-proposed
Pin-Priority: 400

See https://wiki.ubuntu.com/Testing/EnableProposed

Leo Pilachowski (leopila) wrote :

proposed did not fix

The compiz issue is resolved but the fix breaks other dependencies and software (ROS for example)

Just upgrading libgl1-mesa-dri from ...16.04.2 to ...16.04.3 gives dependency errors when installing other packages such as libegl1-mesa-dev:

The following packages have unmet dependencies:
 libegl1-mesa-dev : Depends: libegl1-mesa (= 17.2.4-0ubuntu1~16.04.2) but 17.2.4-0ubuntu1~16.04.3 is to be installed
                    Depends: libwayland-egl1-mesa (= 17.2.4-0ubuntu1~16.04.2) but 17.2.4-0ubuntu1~16.04.3 is to be installed
E: Unable to correct problems, you have held broken packages.

Timo Aaltonen (tjaalton) wrote :

run 'sudo apt -f install' to fix that

Leo Pilachowski (leopila) wrote :

Already tried that:

***
sudo apt -f install libegl1-mesa-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libegl1-mesa-dev : Depends: libegl1-mesa (= 17.2.4-0ubuntu1~16.04.2) but 17.2.4-0ubuntu1~16.04.3 is to be installed
                    Depends: libwayland-egl1-mesa (= 17.2.4-0ubuntu1~16.04.2) but 17.2.4-0ubuntu1~16.04.3 is to be installed
E: Unable to correct problems, you have held broken packages.
***

Trying with aptitude to get a solution gives:

***
The following actions will resolve these dependencies:

     Downgrade the following packages:
1) libegl1-mesa [17.2.4-0ubuntu1~16.04.3 (now) -> 17.2.4-0ubuntu1~16.04.2 (x
2) libgbm1 [17.2.4-0ubuntu1~16.04.3 (now) -> 17.2.4-0ubuntu1~16.04.2 (xenial
3) libgl1-mesa-dri [17.2.4-0ubuntu1~16.04.3 (now) -> 17.2.4-0ubuntu1~16.04.2
4) libwayland-egl1-mesa [17.2.4-0ubuntu1~16.04.3 (now) -> 17.2.4-0ubuntu1~16
***

The solution is to downgrade the 4 packages that fixed the graphics problem!

So, the proposed fix is somehow incomplete.

LeoP

Timo Aaltonen (tjaalton) wrote :

no it isn't, you just happen to have -dev packages installed too

sudo apt install libgl1-mesa-dri libegl1-mesa-dev/xenial-proposed

or something. Figure it out, this is not related to the update but something on your system.

Leo Pilachowski (leopila) wrote :

I did not realize that the -dev packages were also updated and in the proposed repository. I understood from a post above that everything would be pulled in when the libgl1-mesa-dri package was updated. I did look for -dev updates but I could not find a way to see any of the packages themselves on archive.ubuntu.com

Everything installs with no dependency issues now although working the mesa based graphics hard can still cause some problems, but no more than on other systems built before 1/4/2018.

Thanks, LP

Tom Juhasz (juhaszi) wrote :

Proposed update fixed issue on gen5 Ironlake hardware (Dell Inspiron N5040).

libgl1-mesa-dri:
  Installed: 17.2.4-0ubuntu1~16.04.3
  Candidate: 17.2.4-0ubuntu1~16.04.3
  Version table:
 *** 17.2.4-0ubuntu1~16.04.3 400
        400 http://us.archive.ubuntu.com/ubuntu xenial-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     17.2.4-0ubuntu1~16.04.2 500
        500 http://us.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
     11.2.0-1ubuntu2 500
        500 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 Packages

Thanks for the quick fix.

MeanJim (meanjim) wrote :

As per XXX, after temporarily removing /etc/apt/preferences.d/proposed-updates, the update installed and so far it seems to be working. It still takes a very long time to get to the desktop after logging in though.

Timo Aaltonen (tjaalton) wrote :

Hello Falk, or anyone else affected,

Accepted mesa into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mesa/17.2.4-0ubuntu1~16.04.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed-xenial
removed: verification-done-xenial
tags: added: verification-done verification-done-artful verification-done-xenial
removed: verification-needed verification-needed-artful verification-needed-xenial
Timo Aaltonen (tjaalton) wrote :

marked verified, this didn't affect artful

Mohammad Reza (mrhosseini1367) wrote :

Proposed update fixed the issue on an old Intel 1st gen Core i5-M450 with integrated Ironlake graphics

libgl1-mesa-dri:
  Installed: 17.2.4-0ubuntu1~16.04.3
  Candidate: 17.2.4-0ubuntu1~16.04.3
  Version table:
 *** 17.2.4-0ubuntu1~16.04.3 400
        400 http://ir.archive.ubuntu.com/ubuntu xenial-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     17.2.4-0ubuntu1~16.04.2 500
        500 http://ir.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
     11.2.0-1ubuntu2 500
        500 http://ir.archive.ubuntu.com/ubuntu xenial/main amd64 Packages

uwer@netic.de (uwer) wrote :

libgl1-mesa-dri 17.2.4-0ubuntu1~16.04.4 fixed the issue on my Thinkpad SL510

thor@norb:~$ sudo lshw
norb
    Beschreibung: Notebook
    Produkt: 2847DGG
    Hersteller: LENOVO
    Version: ThinkPad SL510
...
     *-cpu
          Beschreibung: CPU
          Produkt: Intel(R) Core(TM)2 Duo CPU T6670 @ 2.20GHz
          Hersteller: Intel Corp.
          Physische ID: 4
...
        *-display:0
             Beschreibung: VGA compatible controller
             Produkt: Mobile 4 Series Chipset Integrated Graphics Controller
             Hersteller: Intel Corporation
             Physische ID: 2
             Bus-Informationen: pci@0000:00:02.0
             Version: 07
             Breite: 64 bits
             Takt: 33MHz
             Fähigkeiten: msi pm vga_controller bus_master cap_list rom
             Konfiguration: driver=i915 latency=0
             Ressourcen: irq:16 memory:f2400000-f27fffff memory:d0000000-dfffffff ioport:1800(Größe=8) memory:c0000-dffff

Leo Gerard (lerardgeo) wrote :

Proposed update fixed the issue, thanks.

product: Mobile 4 Series Chipset Integrated Graphics Controller
vendor: Intel Corporation

$ apt policy libgl1-mesa-dri
libgl1-mesa-dri:
  Installed: 17.2.4-0ubuntu1~16.04.4
  Candidate: 17.2.4-0ubuntu1~16.04.4
  Version table:
 *** 17.2.4-0ubuntu1~16.04.4 400
        400 http://fr.archive.ubuntu.com/ubuntu xenial-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     17.2.4-0ubuntu1~16.04.2 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
     11.2.0-1ubuntu2 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/main amd64 Packages

a_b_j_q (a-q) wrote :

Running an Acer Aspire 5332 with 16.04 pretty much a fresh install from last week.

The patch did fix the problem, eventually, but on the first boot none of the X clients connected to the display, so all I had was a mouse pointer.

logged in via Alt-F1 console and ran an Xterm with :0 DISPLAY env var, but that didn't connect (although it showed no errors on stderr).

Then rebooted once more, and it all started working OK.

So - if it doesn't work first time, you might want to try another reboot.

P.S. love all the "dependency" problems above - NOT - oh for the good old days where libraries had fixed API's and you could mix and match different version.

Johanna (johannad) wrote :

16.04.03 64 bits
Intel® Pentium(R) Dual CPU T2390 @ 1.86GHz × 2
ASUS Notebook X51L

I followed these instructions to install libgl1-mesa-dri/xenial-proposed step by step: https://askubuntu.com/questions/992571/gui-unity-crashing-in-16-04-lts-after-updates-2018-01-04-compiz-segfaults
and it failed...

Installing stock hwe stack on 16.04 worked for me (#30). Thanks a lot!

I couldn't use my sidebar. When I hovered with my mouse over the sidebar or clicked on one of the icons everything disappeared except for the background picture and then the windows and sidebar came back immediately but no program was opened. I also could not reboot/shutdown/logout using the graphic menu.

Olivier Philippe (ophilippe) wrote :

It's good for me with the package "libgl1-mesa-dri", thank you.

msi PR601/VR603
Intel(R) Pentium(R) Dual CPU T3200 @ 2.00GHz
VGA compatible controller; Mobile 4 Series Chipset Integrated Graphics Controller

https://askubuntu.com/questions/992571/gui-unity-crashing-in-16-04-lts-after-updates-2018-01-04-compiz-segfaults

$ apt policy libgl1-mesa-dri
libgl1-mesa-dri:
  Installé : 17.2.4-0ubuntu1~16.04.4
  Candidat : 17.2.4-0ubuntu1~16.04.4
 Table de version :
 *** 17.2.4-0ubuntu1~16.04.4 400
        400 http://archive.ubuntu.com/ubuntu xenial-proposed/main i386 Packages
        100 /var/lib/dpkg/status
     17.2.4-0ubuntu1~16.04.2 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main i386 Packages
     11.2.0-1ubuntu2 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/main i386 Packages

Ram (ram-dahal) wrote :

I was having the same flickering desktop problem. I followed the first part of the instructions from

https://askubuntu.com/questions/992571/gui-unity-crashing-in-16-04-lts-after-updates-2018-01-04-compiz-segfaults

and the problem is solved. Thank you.

Carl McLaughlin (c1150) wrote :

I had the same issue.

I found https://askubuntu.com/questions/992571/gui-unity-crashing-in-16-04-lts-after-updates-2018-01-04-compiz-segfaults
first and followed the directions there. It resolved my problem.

Jaime Cruz (jaime-cruz) wrote :

Installed the updated package from "Proposed" and that has resolved the issue. Thanks.

Luca Marocco (marluc) wrote :

The proposed fix works on my machine. Thanks.

Ubuntu 16.04; Processor: Intel® Core™ i5 CPU M 540 @ 2.53GHz × 4; Graphics: Intel® Ironlake Mobile

description: Laptop
    product: Latitude E4310
    vendor: Dell Inc.
    version: 0001
    serial: G4N8XN1
    width: 64 bits
    capabilities: smbios-2.6 dmi-2.6 vsyscall32
    configuration: boot=normal chassis=laptop uuid=44454C4C-3400-104E-8038-C7C04F584E31
  *-core
       description: Motherboard
       product: 012JJ4
       vendor: Dell Inc.
       physical id: 0
       version: A01
     *-firmware
          description: BIOS
          vendor: Dell Inc.
          physical id: 0
          version: A15
          date: 05/12/2017
          size: 64KiB
          capacity: 960KiB
*-display
             description: VGA compatible controller
             product: Core Processor Integrated Graphics Controller
             vendor: Intel Corporation
             physical id: 2
             bus info: pci@0000:00:02.0
             version: 02
             width: 64 bits
             clock: 33MHz
             capabilities: msi pm vga_controller bus_master cap_list rom
             configuration: driver=i915 latency=0

maport (akfypzn-zjp2-nw2wga2) wrote :

Proposed fix fixed it for me (Lenovo 3000 N200). Many thanks.

Original error was:

compiz[1519]: segfault at 0 ip 00007f54d91a2986 sp 00007ffd58273a20 error 4 in i965_dri.so[7f54d8bca000+82d000]

Machine details:

$ sudo lshws

    description: Notebook
    product: 0769EUG (Lenovo)
    vendor: LENOVO
    version: 3000 N200
    width: 64 bits
    capabilities: smbios-2.4 dmi-2.4 vsyscall32
    configuration: boot=oem-specific chassis=notebook family=Lenovo sku=Lenovo
     *-cpu
          description: CPU
          product: Intel(R) Core(TM)2 Duo CPU T5750 @ 2.00GHz
          vendor: Intel Corp.
          physical id: 4
          bus info: cpu@0
          version: CPU Version
          slot: U2E1
          size: 1634MHz
          capacity: 4096MHz
          width: 64 bits
          capabilities: fpu fpu_exception wp vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx x86-64 constant_tsc arch_perfmon pebs bts rep_good nopl cpuid aperfmperf pni dtes64 monitor ds_cpl est tm2 ssse3 cx16 xtpr pdcm lahf_lm pti dtherm cpufreq
     *-pci
          description: Host bridge
          product: Mobile PM965/GM965/GL960 Memory Controller Hub
          vendor: Intel Corporation
          physical id: 100
          bus info: pci@0000:00:00.0
          version: 0c
          width: 32 bits
          clock: 33MHz
        *-display:0
             description: VGA compatible controller
             product: Mobile GM965/GL960 Integrated Graphics Controller (primary)
             vendor: Intel Corporation
             physical id: 2
             bus info: pci@0000:00:02.0
             version: 0c
             width: 64 bits
             clock: 33MHz
             capabilities: msi pm vga_controller bus_master cap_list rom
             configuration: driver=i915 latency=0
             resources: irq:16 memory:fc000000-fc0fffff memory:d0000000-dfffffff ioport:1800(size=8) memory:c0000-dffff

$ apt policy install libgl1-mesa-dri

libgl1-mesa-dri:
  Installed: 17.2.4-0ubuntu1~16.04.4
  Candidate: 17.2.4-0ubuntu1~16.04.4
  Version table:
 *** 17.2.4-0ubuntu1~16.04.4 400
        400 http://gb.archive.ubuntu.com/ubuntu xenial-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     17.2.4-0ubuntu1~16.04.2 500
        500 http://gb.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
     11.2.0-1ubuntu2 500
        500 http://gb.archive.ubuntu.com/ubuntu xenial/main amd64 Packages

Proposed fixed this bug on my Dell Vostro 1015

description: Portable Computer
    product: Vostro 1015
    vendor: Dell Inc.
    serial: 9KKDQQ1
    width: 64 bits
    capabilities: smbios-2.4 dmi-2.4 vsyscall32
    configuration: boot=normal chassis=portable uuid=44454C4C-4B00-104B-8044-B9C04F515131

*-cpu
          description: CPU
          product: Intel(R) Core(TM)2 Duo CPU T6670 @ 2.20GHz
          vendor: Intel Corp.
          physical id: 400
          bus info: cpu@0
          slot: Microprocessor
          size: 918MHz
          capacity: 2201MHz
          width: 64 bits

*-display:0
             description: VGA compatible controller
             product: Mobile 4 Series Chipset Integrated Graphics Controller
             vendor: Intel Corporation
             physical id: 2
             bus info: pci@0000:00:02.0
             version: 07
             width: 64 bits
             clock: 33MHz
             capabilities: msi pm vga_controller bus_master cap_list rom
             configuration: driver=i915 latency=0
             resources: irq:16 memory:f6c00000-f6ffffff memory:e0000000-efffffff ioport:efe8(size=8) memory:c0000-dffff
        *-display:1 UNCLAIMED
             description: Display controller
             product: Mobile 4 Series Chipset Integrated Graphics Controller
             vendor: Intel Corporation
             physical id: 2.1
             bus info: pci@0000:00:02.1
             version: 07
             width: 64 bits
             clock: 33MHz
             capabilities: pm bus_master cap_list
             configuration: latency=0
             resources: memory:f6b00000-f6bfffff

libgl1-mesa-dri:
  Installed: 17.2.4-0ubuntu1~16.04.4
  Candidate: 17.2.4-0ubuntu1~16.04.4
  Version table:
 *** 17.2.4-0ubuntu1~16.04.4 100
        100 /var/lib/dpkg/status
     17.2.4-0ubuntu1~16.04.2 500
        500 http://do.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
     11.2.0-1ubuntu2 500
        500 http://do.archive.ubuntu.com/ubuntu xenial/main amd64 Packages

          clock: 200MHz
          capabilities: x86-64 fpu fpu_exception wp vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx constant_tsc arch_perfmon pebs bts rep_good nopl cpuid aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 xsave lahf_lm pti tpr_shadow vnmi flexpriority dtherm ida cpufreq
          configuration: cores=2 enabledcores=2 threads=2

*-pci
          description: Host bridge
          product: Mobile 4 Series Chipset Memory Controller Hub
          vendor: Intel Corporation
          physical id: 100
          bus info: pci@0000:00:00.0
          version: 07
          width: 32 bits
          clock: 33MHz

Arjan (arjanv01) wrote :

Proposed fix worked on my old vaio too.

Error: compiz[3077]: segfault at 0 ip 00007f97f3aeb986 sp 00007ffc3be748f0 error 4 in i965_dri.so[7f97f3513000+82d000]

Machine (redacted lshw):

vaio
    description: Notebook
    product: VGN-NR498E (N/A)
    vendor: Sony Corporation
    version: C3LRAYYV
    serial: 28274739-3013909
    width: 64 bits
    capabilities: smbios-2.4 dmi-2.4 vsyscall32
    configuration: boot=normal chassis=notebook family=N/A sku=N/A uuid=546EF640-2B7E-11DD-80F1-001A80F59ED6
  *-core
       description: Motherboard
       product: VAIO
       vendor: Sony Corporation
       physical id: 0
       version: N/A
       serial: N/A
       slot: ��@
     *-firmware
          description: BIOS
          vendor: Phoenix Technologies LTD
          physical id: 0
          version: R2060J9
          date: 02/28/2008
          size: 101KiB
          capacity: 960KiB
          capabilities: pci pnp upgrade shadowing escd cdboot bootselect edd int9keyboard int10video acpi usb agp smartbattery biosbootspecification netboot
     *-cpu
          description: CPU
          product: Intel(R) Core(TM)2 Duo CPU T5750 @ 2.00GHz
          vendor: Intel Corp.
          physical id: 4
          bus info: cpu@0
          version: Intel(R) Core(TM)2 Duo CPU T5750 @ 2.00GHz
          serial: N/A
          slot: N/A
          size: 1995MHz
          capacity: 2GHz
          width: 64 bits
          clock: 167MHz
     *-pci
          description: Host bridge
          product: Mobile PM965/GM965/GL960 Memory Controller Hub
          vendor: Intel Corporation
          physical id: 100
          bus info: pci@0000:00:00.0
          version: 0c
          width: 32 bits
          clock: 33MHz
        *-display:0
             description: VGA compatible controller
             product: Mobile GM965/GL960 Integrated Graphics Controller (primary)
             vendor: Intel Corporation
             physical id: 2
             bus info: pci@0000:00:02.0
             version: 0c
             width: 64 bits
             clock: 33MHz
             capabilities: msi pm vga_controller bus_master cap_list rom
             configuration: driver=i915 latency=0
             resources: irq:16 memory:fc000000-fc0fffff memory:d0000000-dfffffff ioport:1800(size=8) memory:c0000-dffff

$ apt policy libgl1-mesa-dri
libgl1-mesa-dri:
  Installed: 17.2.4-0ubuntu1~16.04.4
  Candidate: 17.2.4-0ubuntu1~16.04.4
  Version table:
 *** 17.2.4-0ubuntu1~16.04.4 400
        400 http://us.archive.ubuntu.com/ubuntu xenial-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     17.2.4-0ubuntu1~16.04.2 500
        500 http://us.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
     11.2.0-1ubuntu2 500
        500 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 Packages

thanks!

François (ronfr) wrote :

Proposed fix worked on my Dell Vostro 220.

    description: Ordinateur de Bureau
    produit: Vostro 220 Series
    fabriquant: Dell Inc.
    numéro de série: DVJPQH1
    bits: 64 bits
    fonctionnalités: smbios-2.5 dmi-2.5 vsyscall32
    configuration: boot=normal chassis=desktop uuid=44454C4C-5600-104A-8050-C4C04F514831
  *-core
       description: Carte mère
       produit: 0P301D
       fabriquant: Dell Inc.
       identifiant matériel: 0
       version: A00
       numéro de série: ..CN7360489701MO.
     *-firmware
          description: BIOS
          fabriquant: Dell Inc.
          identifiant matériel: 0
          version: 1.3.0
          date: 06/22/2010
          taille: 64KiB
          capacité: 960KiB
          fonctionnalités: isa pci pnp apm upgrade shadowing escd cdboot bootselect socketedrom edd int13floppy1200 int13floppy720 int13floppy2880 int5printscreen int9keyboard int14serial int17printer int10video acpi usb ls120boot zipboot biosbootspecification
     *-cpu
          description: CPU
          produit: Intel(R) Pentium(R) Dual CPU E2200 @ 2.20GHz
          fabriquant: Intel Corp.
          identifiant matériel: 4
          information bus: cpu@0
          version: Intel(R) Pentium(R) Dual CPU E2200 @ 2.20GHz
          numéro de série: To Be Filled By O.E.M.
          emplacement: Socket 775
          taille: 1226MHz
          capacité: 2200MHz
          bits: 64 bits
          horloge: 200MHz
          fonctionnalités: x86-64 fpu fpu_exception wp vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx constant_tsc arch_perfmon pebs bts rep_good nopl cpuid aperfmperf pni dtes64 monitor ds_cpl est tm2 ssse3 cx16 xtpr pdcm lahf_lm pti dtherm cpufreq
          configuration: cores=2 enabledcores=2 threads=2
     *-pci
          description: Host bridge
          produit: 4 Series Chipset DRAM Controller
          fabriquant: Intel Corporation
          identifiant matériel: 100
          information bus: pci@0000:00:00.0
          version: 03
          bits: 32 bits
          horloge: 33MHz
        *-display:0
             description: VGA compatible controller
             produit: 4 Series Chipset Integrated Graphics Controller
             fabriquant: Intel Corporation
             identifiant matériel: 2
             information bus: pci@0000:00:02.0
             version: 03
             bits: 64 bits
             horloge: 33MHz
             fonctionnalités: msi pm vga_controller bus_master cap_list rom
             configuration: driver=i915 latency=0
             ressources: irq:16 mémoire:fe400000-fe7fffff mémoire:d0000000-dfffffff portE/S:dc00(taille=8) mémoire:c0000-dffff

Thanks!

Lewie McDogs (dogsmclewie) wrote :
Download full text (3.7 KiB)

Proposed fixed the issue of compiz crashing on my machine (Dell Latitude e5410). Thanks for that. But there is now an issue with video playback on VLC media player (ver 2.2.2-5ubuntu0.16.04.4). The video hangs every few seconds. It is only an issue with VLC though as video playback works fine on other media apps. Tried reinstalling VLC and it still doesn't work.

I was wondering if others are experiencing the same thing?

    description: Laptop
    product: Latitude E5410
    vendor: Dell Inc.
    version: 0001
    serial: G6YN7N1
    width: 64 bits
    capabilities: smbios-2.6 dmi-2.6 vsyscall32
    configuration: boot=normal chassis=laptop uuid=44454C4C-3600-1059-804E-C7C04F374E31
  *-core
       description: Motherboard
       product: 00K2MH
       vendor: Dell Inc.
       physical id: 0
       version: A00
       serial: /G6YN7N1/CN7016609G00N3/
     *-firmware
          description: BIOS
          vendor: Dell Inc.
          physical id: 0
          version: A15
          date: 07/11/2013
          size: 64KiB
          capacity: 960KiB
          capabilities: pci upgrade shadowing escd cdboot bootselect socketedrom edd int13floppy1200 int13floppy720 int13floppy2880 int5printscreen int9keyboard int14serial int17printer int10video acpi usb ls120boot zipboot biosbootspecification
     *-cpu
          description: CPU
          product: Intel(R) Core(TM) i5 CPU M 520 @ 2.40GHz
          vendor: Intel Corp.
          physical id: 4
          bus info: cpu@0
          version: Intel(R) Core(TM) i5 CPU M 520 @ 2.40GH
          serial: To Be Filled By O.E.M.
          slot: CPU 1
          size: 1631MHz
          capacity: 4GHz
          width: 64 bits
          clock: 533MHz
          capabilities: x86-64 fpu fpu_exception wp vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc cpuid aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 popcnt aes lahf_lm pti tpr_shadow vnmi flexpriority ept vpid dtherm ida arat cpufreq
          configuration: cores=2 enabledcores=1 threads=2
        *-cache:0
             description: L1 cache
             physical id: 5
             slot: L1-Cache
             size: 32KiB
             capacity: 32KiB
             capabilities: internal write-back unified
             configuration: level=1
        *-cache:1
             description: L2 cache
             physical id: 6
             slot: L2-Cache
             size: 512KiB
             capacity: 512KiB
             capabilities: internal varies unified
             configuration: level=2
        *-cache:2
             description: L3 cache
             physical id: 7
             slot: L3-Cache
             size: 3MiB
             capacity: 3MiB
             capabilities: internal varies unified
             configuration: level=3
     *-memory
          description: System Memory
          physical id: 19
          slot: System board or motherboard
          size: 4GiB
        *-bank:0
             description: SODIMM DDR3 Synchronous 1067 MHz...

Read more...

Andrei (andreic) wrote :

When will this be available in the main repositories?

Robert Rojas (roberthrojasq) wrote :

Proposed fixed the crash in compiz and blender, but introduces graphical glitches (at least) in blender 2.79 (from the official website), and in the packages
tumiki-fighters and torus-trooper.

It looks like a wireframe being drawn on top of some elements on the screen.

Comments #30 and #35 resolved this for me after a reboot. Thanks.

Renato Bispo (rensilbis) wrote :

I'm running Ubuntu 16.04.3, my Unity was crashing in a similar way as it was originally described in this bug. Installing libgl1-mesa-dri/xenial-proposed fixed the issue. However, today, I tried to install Steam and it failed, at least partially, because the system is not being able to install libgl1-mesa-dri:i386 and libgl1-mesa-glx:i386. This seems to be related to the installation of libgl1-mesa-dri/xenial-proposed.

These are the messages I see in the terminal when trying to open Steam for the first time:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libegl1-mesa : Depends: libgl1-mesa-dri (= 17.2.4-0ubuntu1~16.04.4) but it is not going to be installed
 libgnome-desktop-3-12 : Depends: libgtk-3-0 (>= 3.9.10) but it is not going to be installed
 libqt5svg5 : Depends: libqt5widgets5 (>= 5.3.0) but it is not going to be installed
 qtdeclarative5-ubuntu-ui-toolkit-plugin : Depends: qml-module-ubuntu-components
                                           Depends: qml-module-ubuntu-performancemetrics
                                           Depends: qml-module-ubuntu-test but it is not going to be installed
 ubuntu-system-settings : Depends: libubuntuoneauth-2.0-0 (>= 13.08) but it is not going to be installed
                          Depends: powerd (>= 0.15) but it is not going to be installed or
                                   gnome-settings-daemon but it is not going to be installed
                          Depends: qml-module-qtmultimedia or
                                   qml-module-qtmultimedia-gles but it is not going to be installed
                          Depends: qtdeclarative5-ubuntu-content1 but it is not going to be installed
                          Recommends: ubuntu-system-settings-online-accounts but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Colin Sindle (csindle) wrote :

Please revert my above status change (which was done in error).

Changed in mesa (Ubuntu Xenial):
status: Fix Committed → Fix Released
Daniel Daza (dfdazac) wrote :

Proposed fixed on my Dell laptop as well.

product: Intel(R) Core(TM) i3 CPU M 330 @ 2.13GHz
vendor: Intel Corp.

libgl1-mesa-dri:
  Installed: 17.2.4-0ubuntu1~16.04.4
  Candidate: 17.2.4-0ubuntu1~16.04.4
  Version table:
 *** 17.2.4-0ubuntu1~16.04.4 100
        100 /var/lib/dpkg/status
     17.2.4-0ubuntu1~16.04.2 500
        500 http://nl.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
     11.2.0-1ubuntu2 500
        500 http://nl.archive.ubuntu.com/ubuntu xenial/main amd64 Packages

Falk Bay (falkartis) wrote :

I installed the libgl1-mesa-dri package from the paulo-miguel-dias repository, now everything seems to work fine, unity desktop. I haven't tried blender.

apt policy libgl1-mesa-dri
libgl1-mesa-dri:
  Instal·lat: 1:17.3.1-1~a~padoka0
  Candidat: 1:17.3.1-1~a~padoka0
  Taula de versió:
 *** 1:17.3.1-1~a~padoka0 500
        500 http://ppa.launchpad.net/paulo-miguel-dias/pkppa/ubuntu artful/main amd64 Packages
        100 /var/lib/dpkg/status
     17.2.4-0ubuntu1~17.10.2 500
        500 http://es.archive.ubuntu.com/ubuntu artful-proposed/main amd64 Packages
     17.2.2-0ubuntu1 500
        500 http://es.archive.ubuntu.com/ubuntu artful/main amd64 Packages

Timo Aaltonen (tjaalton) wrote :

the fix has _not_ landed in xenial-updates, never close a SRU bug manually..

Changed in mesa (Ubuntu Xenial):
status: Fix Released → Fix Committed
Changed in mesa (Ubuntu Xenial):
status: Fix Committed → Fix Released
Laurent Gibergues (loranger12) wrote :

Proposed (comments #39) fixed the crash in blender 2.7x on my Dell Vostro 3700.
Thanks a lot !

Robie Basak (racb) on 2018-01-16
tags: added: regression-update
Timo Aaltonen (tjaalton) wrote :

What did I say about changing the bug status? Don't touch it!

Changed in mesa (Ubuntu Xenial):
status: Fix Released → Fix Committed
Emmanuel Grumbach (egrumbach) wrote :

Somehow I can't repro the bug although I removed all the ppa / proposed repositories. Maybe I need to add them again and purge them to make sure I removed the packages and not only the pointer to the repository?

So - I was under the impression that the fix did make it to xenial-updates (although I haven't touched the the tags / bug status :))

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mesa - 17.2.4-0ubuntu1~17.10.2

---------------
mesa (17.2.4-0ubuntu1~17.10.2) artful; urgency=medium

  * i965-disable-l3-cache-alloc-for-ext-buffers.diff:
    - Replaced with five backported commits from upstream
      (LP: #1727401, #1735594)

mesa (17.2.4-0ubuntu1~17.10.1) artful; urgency=medium

  * Backport to artful.
  * vulkan-mir.patch: Dropped, breaks radeon vulkan driver. (LP:
    #1720890)

mesa (17.2.4-0ubuntu1) bionic; urgency=medium

  * New upstream bugfix release. (LP: #1727390)
  * i965-disable-l3-cache-alloc-for-ext-buffers.diff: Fix corruption
    running windowed 3D apps on dGPU. (LP: #1727401)

 -- Timo Aaltonen <email address hidden> Tue, 09 Jan 2018 15:28:48 +0200

Changed in mesa (Ubuntu Artful):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for mesa has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mesa - 17.2.4-0ubuntu1~16.04.4

---------------
mesa (17.2.4-0ubuntu1~16.04.4) xenial; urgency=medium

  * control: Relax mesa-opencl-icd dependency on libclc. (LP: #1743018)

mesa (17.2.4-0ubuntu1~16.04.3) xenial; urgency=medium

  * i965-disable-l3-cache-alloc-for-ext-buffers.diff:
    - Replaced with five backported commits from upstream
      (LP: #1727401, #1735594)

 -- Timo Aaltonen <email address hidden> Sat, 13 Jan 2018 09:06:08 +0200

Changed in mesa (Ubuntu Xenial):
status: Fix Committed → Fix Released
laurel (mtnlaurel) wrote :

My Unity Launcher now works after installing the January 17, 2018 update from the Software Updater(gnome-software).

I'm a newbie so I wasn't able to use the fixes noted in the other comments but after the install, I clicked on the side panel and the Dash, File Manager, Chromium browser and the suite of Libre Office tools all worked. The Launcher seems stable and doesn't flicker off and then on. Also I can go to the wheel at the top right and shutdown the computer now.

I have a Toshiba Satellite M645 (2011)
Intel Core i5 CPU, 64 bit OS
Ubuntu 16.04.3 LTS

THANK YOU, Timo and all who tested this fix. I appreciate all the work. The good outcome of this, for me, was that I learned to use terminal commands rather quickly! I now really appreciate the GUI interface.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers