Activity log for bug #1735594

Date Who What changed Old value New value Message
2017-12-01 01:51:03 Falk Bay bug added bug
2017-12-02 20:14:47 Launchpad Janitor nux (Ubuntu): status New Confirmed
2017-12-03 11:20:47 Falk Bay description When I use the Unity session I automatically get logged out under these conditions: When I hover with my mouse over the sidebar or the top-bar. When I press the alt+tab combination. When I press the super key. running dmesg after this unwanted logout happens I get following information: compiz[10616]: segfault at 0 ip 00007fbca309feeb sp 00007fff5f59a4d0 error 4 in i965_dri.so[7fbca2af6000+7e4000] When I log in the first thing I see is an error message showing something like this: Could not apply the configuration stored for the monitors required virtual size does not fit available size: requested=(1,1),minimum=(320,200),maximum=(8192,8192) Sometimes this appears twice. The info about my installed compiz: compiz: Instal·lat: 1:0.9.13.1+17.10.20170901-0ubuntu1 Candidat: 1:0.9.13.1+17.10.20170901-0ubuntu1 Taula de versió: *** 1:0.9.13.1+17.10.20170901-0ubuntu1 500 500 http://es.archive.ubuntu.com/ubuntu artful/universe amd64 Packages 500 http://es.archive.ubuntu.com/ubuntu artful/universe i386 Packages 100 /var/lib/dpkg/status When I use the Unity session I automatically get logged out under these conditions:     When I hover with my mouse over any icon of the sidebar.     When I press the alt key.     When I press the super key. running dmesg after this unwanted logout happens I get following information: compiz[10616]: segfault at 0 ip 00007fbca309feeb sp 00007fff5f59a4d0 error 4 in i965_dri.so[7fbca2af6000+7e4000] The info about my installed compiz: compiz:   Instal·lat: 1:0.9.13.1+17.10.20170901-0ubuntu1   Candidat: 1:0.9.13.1+17.10.20170901-0ubuntu1   Taula de versió:  *** 1:0.9.13.1+17.10.20170901-0ubuntu1 500         500 http://es.archive.ubuntu.com/ubuntu artful/universe amd64 Packages         500 http://es.archive.ubuntu.com/ubuntu artful/universe i386 Packages         100 /var/lib/dpkg/status
2017-12-03 11:45:04 Falk Bay attachment added I add a crash file found in /var/crash/ I hope this is useful. https://bugs.launchpad.net/ubuntu/+source/nux/+bug/1735594/+attachment/5017735/+files/_usr_bin_compiz.1001.crash
2017-12-07 11:11:07 Falk Bay affects nux (Ubuntu) compiz (Ubuntu)
2018-01-06 12:24:46 Tomas bug added subscriber Tomas
2018-01-07 07:16:25 Timo Aaltonen affects compiz (Ubuntu) mesa (Ubuntu)
2018-01-07 07:16:25 Timo Aaltonen mesa (Ubuntu): assignee Timo Aaltonen (tjaalton)
2018-01-07 07:16:43 Timo Aaltonen nominated for series Ubuntu Artful
2018-01-07 07:16:43 Timo Aaltonen bug task added mesa (Ubuntu Artful)
2018-01-07 07:16:43 Timo Aaltonen nominated for series Ubuntu Xenial
2018-01-07 07:16:43 Timo Aaltonen bug task added mesa (Ubuntu Xenial)
2018-01-07 14:55:39 scuba bug task added mesa
2018-01-07 15:01:03 scuba bug task deleted mesa
2018-01-07 20:03:31 Tomas removed subscriber Tomas
2018-01-08 06:13:54 Launchpad Janitor mesa (Ubuntu Xenial): status New Confirmed
2018-01-08 06:13:54 Launchpad Janitor mesa (Ubuntu Artful): status New Confirmed
2018-01-08 19:19:43 Benoist bug added subscriber Benoist
2018-01-09 09:03:02 Yves Wittouck bug added subscriber Yves Wittouck
2018-01-09 09:03:22 Yves Wittouck removed subscriber Yves Wittouck
2018-01-09 13:59:26 Timo Aaltonen summary ubuntu automatically logs out when hovering sidebar [regression] compiz crashes when hovering over sidebar
2018-01-09 14:19:49 Timo Aaltonen description When I use the Unity session I automatically get logged out under these conditions:     When I hover with my mouse over any icon of the sidebar.     When I press the alt key.     When I press the super key. running dmesg after this unwanted logout happens I get following information: compiz[10616]: segfault at 0 ip 00007fbca309feeb sp 00007fff5f59a4d0 error 4 in i965_dri.so[7fbca2af6000+7e4000] The info about my installed compiz: compiz:   Instal·lat: 1:0.9.13.1+17.10.20170901-0ubuntu1   Candidat: 1:0.9.13.1+17.10.20170901-0ubuntu1   Taula de versió:  *** 1:0.9.13.1+17.10.20170901-0ubuntu1 500         500 http://es.archive.ubuntu.com/ubuntu artful/universe amd64 Packages         500 http://es.archive.ubuntu.com/ubuntu artful/universe i386 Packages         100 /var/lib/dpkg/status [Impact] When I use the Unity session I automatically get logged out under these conditions:     When I hover with my mouse over any icon of the sidebar.     When I press the alt key.     When I press the super key. running dmesg after this unwanted logout happens I get following information: compiz[10616]: segfault at 0 ip 00007fbca309feeb sp 00007fff5f59a4d0 error 4 in i965_dri.so[7fbca2af6000+7e4000] This is caused by a mesa upgrade, which added a patch for bug #1727401. The crasher is reproduced on: - gen4 / gen5 Intel - if using modesetting X driver, like when xserver-xorg-video-intel is not installed, or the HWE stack is installed (xserver-xorg-core-hwe-16.04 defaults to modesetting) [Test case] Log in to Unity, open the dash or try to log out etc. Compiz shouldn't crash. [Regression potential] The backported patches need to be tested, here for regressions and on 1727401 that they fix the original bug (again). Best to test on a wide array of Intel HW: gen4 (965GM/GM45/G45) gen5 (Ironlake) gen6 (Sandy Bridge) gen7 (Bay Trail, Ivy Bridge, Haswell) gen8 (Braswell, Broadwell) gen9 (Apollo Lake, Skylake, Gemini Lake, Kaby Lake, Coffee Lake)
2018-01-09 14:45:12 Timo Aaltonen summary [regression] compiz crashes when hovering over sidebar [regression] compiz crashes after Mesa upgrade
2018-01-09 14:51:43 Martin Zurowietz bug added subscriber Martin Zurowietz
2018-01-10 09:54:15 Eloy Molina bug added subscriber Eloy Molina Álvarez
2018-01-10 15:51:57 daberner bug added subscriber daberner
2018-01-11 07:25:07 Emmanuel Grumbach bug added subscriber Emmanuel Grumbach
2018-01-11 15:55:58 Tor Cardell bug added subscriber Tor Cardell
2018-01-11 16:41:39 Igor Tarasov bug added subscriber Igor Tarasov
2018-01-11 18:03:56 Łukasz Zemczak mesa (Ubuntu): status Confirmed Fix Committed
2018-01-11 18:06:54 Łukasz Zemczak mesa (Ubuntu Artful): status Confirmed Fix Committed
2018-01-11 18:06:56 Łukasz Zemczak bug added subscriber Ubuntu Stable Release Updates Team
2018-01-11 18:06:57 Łukasz Zemczak bug added subscriber SRU Verification
2018-01-11 18:07:03 Łukasz Zemczak tags crash logout crash logout verification-needed verification-needed-artful
2018-01-11 18:46:35 Łukasz Zemczak mesa (Ubuntu Xenial): status Confirmed Fix Committed
2018-01-11 18:46:42 Łukasz Zemczak tags crash logout verification-needed verification-needed-artful crash logout verification-needed verification-needed-artful verification-needed-xenial
2018-01-11 21:36:28 dragoon bug added subscriber dragoon
2018-01-11 22:03:33 yoyoma2 bug added subscriber yoyoma2
2018-01-11 22:37:07 Borislav bug added subscriber Borislav
2018-01-12 08:55:50 Nelijuc tags crash logout verification-needed verification-needed-artful verification-needed-xenial crash logout verification-done-xenial verification-needed verification-needed-artful
2018-01-13 08:32:26 Timo Aaltonen tags crash logout verification-done-xenial verification-needed verification-needed-artful crash logout verification-needed verification-needed-artful verification-needed-xenial
2018-01-13 08:34:25 Timo Aaltonen tags crash logout verification-needed verification-needed-artful verification-needed-xenial crash logout verification-done verification-done-artful verification-done-xenial
2018-01-13 16:22:25 Jim Engle bug added subscriber Jim Engle
2018-01-13 18:30:09 Johanna bug added subscriber Johanna
2018-01-15 14:25:01 Arjan bug added subscriber Arjan
2018-01-16 06:21:52 Colin Sindle bug added subscriber Colin Sindle
2018-01-16 08:29:35 Colin Sindle mesa (Ubuntu Xenial): status Fix Committed Fix Released
2018-01-16 15:41:42 Timo Aaltonen mesa (Ubuntu Xenial): status Fix Released Fix Committed
2018-01-16 17:47:18 giorgio solinas mesa (Ubuntu Xenial): status Fix Committed Fix Released
2018-01-16 23:33:24 Robie Basak tags crash logout verification-done verification-done-artful verification-done-xenial crash logout regression-update verification-done verification-done-artful verification-done-xenial
2018-01-17 06:39:58 Timo Aaltonen mesa (Ubuntu Xenial): status Fix Released Fix Committed
2018-01-17 15:33:56 Launchpad Janitor mesa (Ubuntu Artful): status Fix Committed Fix Released
2018-01-17 15:34:16 Łukasz Zemczak removed subscriber Ubuntu Stable Release Updates Team
2018-01-17 15:34:31 Launchpad Janitor mesa (Ubuntu Xenial): status Fix Committed Fix Released
2018-01-18 10:25:37 Alan Patterson removed subscriber Alan Patterson
2018-01-18 10:25:49 Alan Patterson bug added subscriber Alan Patterson
2018-01-21 16:13:37 Emmanuel Grumbach removed subscriber Emmanuel Grumbach
2018-03-01 08:42:28 Timo Aaltonen mesa (Ubuntu): status Fix Committed Fix Released
2018-03-02 05:20:41 Carwin Zimmermann bug added subscriber Carwin Zimmermann
2018-04-17 04:23:35 Calvin Leung bug added subscriber Calvin Leung
2018-05-17 20:36:10 Keri Alleyne bug added subscriber Keri Alleyne
2018-07-10 11:17:24 Michel-Ekimia bug added subscriber Michel-Ekimia
2018-08-04 08:51:09 Liam McDonagh-Greaves bug added subscriber Liam McDonagh-Greaves
2018-09-08 15:15:58 Eugene Savelov bug added subscriber Eugene Savelov