Unity / Compiz in a crash loop after login, after mesa updates of 2018-01-04

Bug #1741447 reported by Janghou on 2018-01-05
352
This bug affects 73 people
Affects Status Importance Assigned to Milestone
Mesa
New
Undecided
Unassigned
mesa (Ubuntu)
Critical
Timo Aaltonen
Xenial
Undecided
Unassigned
Artful
Undecided
Unassigned

Bug Description

GUI is constantly crashing, can't start desktop

Jan 5 11:21:29 1810 kernel: [ 806.368754] compiz[10824]: segfault at 0 ip 00007f83c4f31c16 sp 00007ffd48dfc2f0 error 4 in i965_dri.so[7f83c4954000+82d000]
Jan 5 11:21:40 1810 kernel: [ 817.279740] compiz[11111]: segfault at 0 ip 00007fda21519c16 sp 00007ffd7b40a150 error 4 in i965_dri.so[7fda20f3c000+82d000]
Jan 5 11:22:30 1810 kernel: [ 867.445137] compiz[11271]: segfault at 0 ip 00007f8462855c16 sp 00007fff07c857f0 error 4 in i965_dri.so[7f8462278000+82d000]
Jan 5 11:22:46 1810 kernel: [ 883.319195] compiz[11458]: segfault at 0 ip 00007f72b7af0c16 sp 00007ffc3b92d830 error 4 in i965_dri.so[7f72b7513000+82d000]
Jan 5 11:23:01 1810 kernel: [ 898.587610] compiz[11516]: segfault at 0 ip 00007fe25113dc16 sp 00007ffcf79754c0 error 4 in i965_dri.so[7fe250b60000+82d000]

In /var/crash:
_usr_bin_compiz.999.crash

Did manage to start a GUI in Low graphics mode (lowgfx.conf) but this is not really usable.
- dash not working
- no window switching
- sometimes all windows disappear for a few seconds

So effectively my laptop is not usable after latest updates.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: unity 7.4.0+16.04.20160906-0ubuntu1
ProcVersionSignature: Ubuntu 4.10.0-42.46~16.04.1-generic 4.10.17
Uname: Linux 4.10.0-42-generic x86_64
.tmp.unity_support_test.0:

.tmp.unity_support_test.1:

ApportVersion: 2.20.1-0ubuntu2.15
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Fri Jan 5 11:16:53 2018
DistUpgraded: 2016-04-22 18:36:32,349 DEBUG icon theme changed, re-reading
DistroCodename: xenial
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07) (prog-if 00 [VGA controller])
   Subsystem: Acer Incorporated [ALI] Mobile 4 Series Chipset Integrated Graphics Controller [1025:029b]
   Subsystem: Acer Incorporated [ALI] Mobile 4 Series Chipset Integrated Graphics Controller [1025:029b]
InstallationDate: Installed on 2014-04-18 (1357 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
MachineType: Acer Aspire 1810TZ
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.10.0-42-generic root=UUID=86d7d9a6-ffc3-47cb-adc4-68cfcbcadcef ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: Upgraded to xenial on 2016-04-22 (622 days ago)
dmi.bios.date: 08/31/2010
dmi.bios.vendor: INSYDE
dmi.bios.version: v1.3314
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: JM11-MS
dmi.board.vendor: Acer
dmi.board.version: Base Board Version
dmi.chassis.type: 1
dmi.chassis.vendor: Chassis Manufacturer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnINSYDE:bvrv1.3314:bd08/31/2010:svnAcer:pnAspire1810TZ:pvrv1.3314:rvnAcer:rnJM11-MS:rvrBaseBoardVersion:cvnChassisManufacturer:ct1:cvrChassisVersion:
dmi.product.name: Aspire 1810TZ
dmi.product.version: v1.3314
dmi.sys.vendor: Acer
version.compiz: compiz 1:0.9.12.2+16.04.20160823-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.83-1~16.04.1
version.libgl1-mesa-dri: libgl1-mesa-dri 17.2.4-0ubuntu1~16.04.2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 17.2.4-0ubuntu1~16.04.2
version.xserver-xorg-core: xserver-xorg-core N/A
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati N/A
version.xserver-xorg-video-intel: xserver-xorg-video-intel N/A
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A
xserver.bootTime: Fri Jan 5 11:14:24 2018
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.19.5-0ubuntu2~16.04.1
xserver.video_driver: modeset

Janghou (janghou) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Tomas (sei-mai-neim-egen) wrote :

Exactly same things started happening to me - my Desktop is now almost unusable.

Janghou (janghou) wrote :

As a workaround I enabled low graphics mode in a terminal, and rebooted

    nano ~/.config/upstart/lowgfx.conf
    Paste this into it:

start on starting unity7
pre-start script
    initctl set-env -g UNITY_LOW_GFX_MODE=1
end script

    Log out and back in

https://insights.ubuntu.com/2016/09/19/low-graphics-mode-in-unity-7/

At least you can do something, but it's buggy as hell.

So I consider moving back from HWE kernels to default 16.04, because I feel it was caused by the latest libgl1-mesa / xorg updates

Keri Alleyne (keri.alleyne) wrote :

Sorry about the cross posting but here is another potentially related bug report:

https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/1741303

Janghou (janghou) wrote :

To be a bit more precise, I can login, but then Unity starts a crash loop, so nothing showing, just a wallpaper.

Khurshid Alam (khurshid-alam) wrote :

You can always go back to older kernel version (4.4.x) from grub menu while rebooting.

grar05 (grar-knal) wrote :

Same here after doing an apt-get upgrade this afternoon.
Seems that it updated some gl/mesa related packages, so I guess they may be the cause. From the apt logs:

Unpacking libegl1-mesa-dev:amd64 (17.2.4-0ubuntu1~16.04.2) over (17.0.7-0ubuntu0.16.04.2) ...
Unpacking libwayland-egl1-mesa:amd64 (17.2.4-0ubuntu1~16.04.2) over (17.0.7-0ubuntu0.16.04.2) ...
Unpacking libegl1-mesa:amd64 (17.2.4-0ubuntu1~16.04.2) over (17.0.7-0ubuntu0.16.04.2) ...
Unpacking libgbm1:amd64 (17.2.4-0ubuntu1~16.04.2) over (17.0.7-0ubuntu0.16.04.2) ...
Unpacking libgl1-mesa-dev:amd64 (17.2.4-0ubuntu1~16.04.2) over (17.0.7-0ubuntu0.16.04.2) ...
Unpacking mesa-common-dev:amd64 (17.2.4-0ubuntu1~16.04.2) over (17.0.7-0ubuntu0.16.04.2) ...
Unpacking libgl1-mesa-glx:amd64 (17.2.4-0ubuntu1~16.04.2) over (17.0.7-0ubuntu0.16.04.2) ...
Unpacking libgles2-mesa-dev:amd64 (17.2.4-0ubuntu1~16.04.2) over (17.0.7-0ubuntu0.16.04.2) ...
Unpacking libgles2-mesa:amd64 (17.2.4-0ubuntu1~16.04.2) over (17.0.7-0ubuntu0.16.04.2) ...
Unpacking libglapi-mesa:amd64 (17.2.4-0ubuntu1~16.04.2) over (17.0.7-0ubuntu0.16.04.2) ...
Selecting previously unselected package libllvm5.0:amd64.
Unpacking libllvm5.0:amd64 (1:5.0-3~16.04.1) ...
Unpacking libgl1-mesa-dri:amd64 (17.2.4-0ubuntu1~16.04.2) over (17.0.7-0ubuntu0.16.04.2) ...
Unpacking libjavascriptcoregtk-4.0-18:amd64 (2.18.4-0ubuntu0.16.04.1) over (2.18.3-0ubuntu0.16.04.1) ...
Unpacking libxatracker2:amd64 (17.2.4-0ubuntu1~16.04.2) over (17.0.7-0ubuntu0.16.04.2) ...
Unpacking mesa-vdpau-drivers:amd64 (17.2.4-0ubuntu1~16.04.2) over (17.0.7-0ubuntu0.16.04.2) ...

Is there any way to downgrade this packages meanwhile there is no fix?

I doubt this is a duplicate of bug #1735594

- I'm not logged out every time
- problems started after updates of 4/1/2018, not in December 2017

summary: - Can't login after latest updates (4/1), Unity / Compiz crashes
+ Unity / Compiz in a crash loop after login, after updates 4/1
Janghou (janghou) wrote :

After updates and several I get just a wallpaper;
- no dash
- no panel
- could not start any program, just a VT terminal

After I enabled low graphics mode see #4, I'm able to, at least, start Firefox, still
- dash not working, but keyboard shortcuts are
- not window switching, alt tab
- windows key not working
- can't shutdown through menu

But no sudden log-outs.

Booting with an older kernel (4.4) did not help, so my guess the latest mesa/xorgs updates are the culprit.

axoin (axoin) wrote :

I downgraded
libgl1-mesa-dev libgl1-mesa-glx libgl1-mesa-glx:i386 libglapi-mesa libglapi-mesa:i386 libosmesa6 libosmesa6:i386 mesa-common-dev
to version 17.0.7-0ubuntu0.16.04.2 and this solved the problem.

I went the hard route and downloaded the deb-files manually from "built files"
https://launchpad.net/ubuntu/+source/mesa/17.0.7-0ubuntu0.16.04.2/+build/13231714

and installed with
# sudo dpkg -i *.deb

manually watching out for dependencies. Looks like a mesa regression rather than unity bug, though.

Same issue here, after install 16.04.3
My desktop is unusable, constantly disappear, i can't use it

uwer@netic.de (uwer) wrote :

On 16.04.3 I used Synaptic to narrow down the packages that seem to cause the crash.
I installed packages, made note of them and rebooted to see if I could reproduce the problem.

The last four packages that were left over before the issue could be reproduced were:
libegl1-mesa 17.2.4-0ubuntu1~16.04.2
libgbm1 17.2.4-0ubuntu1~16.04.2
libgl1-mesa-dri 17.2.4-0ubuntu1~16.04.2
libwayland-egl1-mesa 17.2.4-0ubuntu1~16.04.2

These depend on each other, so I could not drill down further.
After installing these and rebooting, Unity crashed again.

Apicultor (apicultor) wrote :

After reverting the packages as mentioned in comment 16, drop this file in /etc/apt/preferences.d/ to prevent the system from upgrading them to this specific problematic version (17.2.4-0ubuntu1~16.04.2) again.

summary: - Unity / Compiz in a crash loop after login, after updates 4/1
+ Unity / Compiz in a crash loop after login, after updates of 2018-01-04
summary: - Unity / Compiz in a crash loop after login, after updates of 2018-01-04
+ Unity / Compiz in a crash loop after login, after mesa updates of
+ 2018-01-04
Apicultor (apicultor) wrote :

Package: libxatracker2
Pin: version 17.2.4-0ubuntu1~16.04.2
Pin-Priority: -1

Package: mesa-va-drivers
Pin: version 17.2.4-0ubuntu1~16.04.2
Pin-Priority: -1

Package: libegl1-mesa
Pin: version 17.2.4-0ubuntu1~16.04.2
Pin-Priority: -1

Package: libgbm1
Pin: version 17.2.4-0ubuntu1~16.04.2
Pin-Priority: -1

Package: libgl1-mesa-dri
Pin: version 17.2.4-0ubuntu1~16.04.2
Pin-Priority: -1

Package: libgl1-mesa-glx
Pin: version 17.2.4-0ubuntu1~16.04.2
Pin-Priority: -1

Package: libglapi-mesa
Pin: version 17.2.4-0ubuntu1~16.04.2
Pin-Priority: -1

Package: libwayland-egl1-mesa
Pin: version 17.2.4-0ubuntu1~16.04.2
Pin-Priority: -1

Timo Aaltonen (tjaalton) on 2018-01-07
no longer affects: mesa
no longer affects: unity
Timo Aaltonen (tjaalton) wrote :

Could you test 17.10 live image? It comes with 17.2.2 and should work, then upgrading to artful-proposed should break it again since it has 17.2.4.

Looks like Intel gen4 & 5 regressed, everything newer seems to work fine which is why testing didn't catch this. There is a newer upstream version available (17.2.8) but PPA builders are down so I don't have that available for testing.

affects: unity (Ubuntu) → mesa (Ubuntu)
Changed in mesa (Ubuntu):
assignee: nobody → Timo Aaltonen (tjaalton)
Janghou (janghou) wrote :

Is 17.10 available for download again?

`The download of Ubuntu 17.10 is currently discouraged due to a BIOS issue on certain laptops. Once fixed this download will be enabled again.`

Also tried yesterday the x-swat ppa, but nothing there, like you say.

But I have tried a Lubuntu 17.10 Live USB that was lying around, that works fine.

Janghou (janghou) wrote :

But to try artful-proposed a persistent live image is needed, or is it possible to test mesa updates without reboot?

uwer@netic.de (uwer) wrote :

What file name should the file from comment #17 have?

Timo Aaltonen (tjaalton) wrote :

you can update packages on a live session just like on a normal install, just logout/login and you should have a fresh session running on new packages

lubuntu doesn't use unity, so it doesn't trigger this bug either, but you should be able to install unity there

Janghou (janghou) wrote :

My USB 4.0GB Live image runs out of space installing unity on lubuntu

BTW:
- 17.10 doesn't use Unity either
- After logout you need to login:
 username = lubuntu, blank password, (ubuntu for ubuntu)
- Lubuntu 17.10 runs fine with artful-proposes, seems a reasonable workaround for now
  apt install lubuntu-desktop (270mb)

Apicultor (apicultor) wrote :

For me, I made a file called /etc/apt/preferences.d/00mesa-17-2-4-blacklist with the contents of comment 18, and the changes took effect instantly (apt stopped offering the update for those packages).

Timo Aaltonen (tjaalton) wrote :

this is probably a dupe of 1735594, but let's keep it separate for now

mesa 17.2.8 is available for amd64 at
https://aaltoset.kapsi.fi/mesa-17.2.8/17.10 (/16.04)

you can try installing libgl1-mesa-dri and other pkgs it needs manually

Timo Aaltonen (tjaalton) wrote :

does it crash if you boot with kernel 4.4?

Janghou (janghou) wrote :

Sorry, not that experienced in this stuff, trying to manually install the packages, but stumble on missing i386 dependencies

dpkg: error processing package libglapi-mesa:amd64 (--install):
 package libglapi-mesa:amd64 17.2.8-0ubuntu0~17.10.1 cannot be configured because libglapi-mesa:i386 is at a different version (17.2.4-0ubuntu1~16.04.2)
Processing triggers for libc-bin (2.23-0ubuntu9) ...
Errors were encountered while processing

Janghou (janghou) wrote :

Yes, it does crash booting with 4.4, see #13

scuba (scubuntu) wrote :

Try to activate "discrete graphics" in BIOS... (ie. deactivate switchable graphics)
worked for me.

Lucian C. (lucian1) wrote :

The exact same things happens for me. Let's hope they fix it soon, this is really frustrating :(

Janghou (janghou) wrote :

axoin, uwer, Timo
Thx, downgrading the 4 mentioned packages solved all problems here.

Doug McMahon (mc3man) wrote :

Not affected at all here with Haswell, i.e.

CPU: Quad core Intel Core i7-4700MQ (-HT-MCP-) cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 19155
           clock speeds: max: 3400 MHz 1: 2394 MHz 2: 2394 MHz 3: 2394 MHz 4: 2394 MHz 5: 2394 MHz 6: 2394 MHz
           7: 2394 MHz 8: 2394 MHz
Graphics: Card-1: Intel 4th Gen Core Processor Integrated Graphics Controller bus-ID: 00:02.0
           Card-2: NVIDIA GK107M [GeForce GT 755M] bus-ID: 01:00.0
           Display Server: X.Org 1.19.5 drivers: (unloaded: fbdev,vesa) FAILED: nouveau
           Resolution: 1920x1080@59.91hz
           GLX Renderer: Mesa DRI Intel Haswell Mobile GLX Version: 3.0 Mesa 17.2.4 Direct Rendering: Yes
libgl1-mesa-dri:
  Installed: 17.2.4-0ubuntu1~16.04.2
ect.

Adolfo Jayme (fitojb) on 2018-01-08
Changed in mesa (Ubuntu):
importance: Undecided → Critical
Marcos Gonçalves (marcos4758) wrote :

Men, help us. I spent a lot of time yesterday dealing with this issue. I even formatted and put a fresh 16.04 Ubuntu, but after the system updates the problem reappears again. The system is almost unusable, I can't pass the pointer over the side bar and everthing disappears and appears again. My laptop is old, it dates back to 2009, with an Intel Core 2 Duo T5800.

Timo Aaltonen (tjaalton) wrote :

xenial users please test mesa 17.2.8 from a ppa:

sudo apt-add-repository ppa:canonical-x/x-staging && apt update && apt upgrade -y

Janghou (janghou) wrote :

Tested you're ppa.

Negative. Doesn't work, problems still there.

an 8 14:48:41 1810 kernel: [10886.847038] compiz[22501]: segfault at 0 ip 00007fd6cdf7a296 sp 00007fffc1e6bf30 error 4 in i965_dri.so[7fd6cd9a3000+827000]

Timo Aaltonen (tjaalton) wrote :

Did you log out or reboot after the install? Verify that you have the update by running:

apt-cache policy libgl1-mesa-dri:amd64

Janghou (janghou) wrote :

libgl1-mesa-dri:
  Installed: 17.2.8-0ubuntu0~16.04.1~1
  Candidate: 17.2.8-0ubuntu0~16.04.1~1
  Version table:
 *** 17.2.8-0ubuntu0~16.04.1~1 500
        500 http://ppa.launchpad.net/canonical-x/x-staging/ubuntu xenial/main amd64 Packages
        100 /var/lib/dpkg/status
     17.2.4-0ubuntu1~16.04.2 -1
        500 http://nl.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
     17.2.4-0ubuntu1~16.04.0 500
        500 http://ppa.launchpad.net/ubuntu-x-swat/updates/ubuntu xenial/main amd64 Packages
     11.2.0-1ubuntu2 500
        500 http://nl.archive.ubuntu.com/ubuntu xenial/main amd64 Packages

Tried both: logout, reboot
still negative

Timo Aaltonen (tjaalton) wrote :

ok, need to test later versions then, maybe best to try these ppa's (in this order)

https://launchpad.net/~paulo-miguel-dias/+archive/ubuntu/pkppa/

and if 17.3.1 in this ppa doesn't work, try

https://launchpad.net/~paulo-miguel-dias/+archive/ubuntu/mesa

which has a git snapshot

I tried the first ppa above and this worked for me. Screen handling is now stable, so thanks.

Janghou (janghou) wrote :

Yep, ppa:paulo-miguel-dias/pkppa

seems fine. ;)

Timo Aaltonen (tjaalton) wrote :

cool, now it would need to be bisected :/

Chamili (chamilie) on 2018-01-08
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mesa (Ubuntu Artful):
status: New → Confirmed
Changed in mesa (Ubuntu Xenial):
status: New → Confirmed
tedy58 (tedy58) wrote :

I am affectef from the same issue and it is very nasty.
I install lubunty as is suggested in the bug report bellow, but it is not mine desktop environment and it must be reconfigured a lot.
I'm using Ubuntu 16.04-3 64-bit with Unity DE on Asus N53Jn. After last update I run over the same issue. I reported this, but still not have solution for that issue as mention Jacob Edward Opstad

$uname -a

Linux User-N53Jn 4.10.0-42-generic #46~16.04.1-Ubuntu SMP Mon Dec 4 15:57:59 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
User-N53Jn:~$ lsb_release -a

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 16.04.3 LTS
Release: 16.04
Codename: xenial

I reinstall unity DE, compiz and some other things that I think will resolve the problem, but still not have good solution for that issue. Really it is very annoying.

Now I read GUI/Unity crashing in 16.04 LTS after latest updates, compiz segfaults My configuration is Intel-i3, 8Gb RAM, 240Gb SSD, Nvidia Optimus 1G

All tips for resolving are welcome.

Keri Alleyne (keri.alleyne) wrote :

Agreed, ppa:paulo-miguel-dias/pkppa

This also works here. No more crash events so far.

Chamili (chamilie) wrote :

I think the lasted update solved my problem. After removing the ppa:paulo-miguel-dias/pkppa because it didn't worked for me, the unity stopped crashing.

Janghou (janghou) wrote :

Timo, don't hurt yourself with the scalpel.

FYI:
Glmark2 benchmark plummeted from 201 to 151 with PPA mesa 17.3

Jacob Opstad (jeopstad) wrote :

Similar problem but not the same. My system is usable. I log in to whatever account I want and everything looks normal. It's only a problem if I put the cursor over any icon in the launcher or press the super key or when the logout/shutdown dialog or the alt+tab image is supposed to come up. In any of those cases, the launcher and top bar flicker and seem to reset. I can't log out or open or switch programs using the normal methods. I can get by just fine using the terminal but it's interrupting my work flow.

Romeo (constantaromeo) wrote :

I have the same problem.I reinstall 16.04 and work fine before updates, After updates everything is crashing.Some time I can open Mozilla but not home or something else.Some friend help me and I move some how all icons on the top bar. Is nothing on the right bar and looks like working this way. I have Application and Places on the left top corner on the bar and I can open from there everything.I'd like to return to normal but No ideea when will be fix this bug. I know this won't help you to much but at least you are not alone on this mater. Sorry about this

tedy58 (tedy58) wrote :

@Janghou thank m8 for the recomendations, I use Paulo Miguel PPA, but it doesn't works for me too.

Now I update system with the official update, remove PPA and all is ok now.
Thank for all hard work here and the official Ubuntu team!

Yevhen (onegin-ua) wrote :

The same problem (Ubuntu 16.04). Unusable desktop after recent update.

ppa:paulo-miguel-dias/pkppa works for me. No more crashes.

Chamili (chamilie) wrote :

I was wrong before. The ppa:paulo-miguel-dias/pkppa did corrected my problem, which is exactly as Jacob Opstad described in comment #50. To work it out, after installing the PPA I needed to restart the daemon, or reboot the system.

Thank you all! It have been really frustrating working on my laptop these last few days.

laurel (mtnlaurel) wrote :

I'm a newbie and after updating Ubuntu 16.04 on Jan 5, 2018, I experienced launcher disappearing when running over with mouse, windows disappearing and appearing, Dash not working and cannot shutdown. I get Internal Error Message: compiz crashed with SIGSERV. The error report incorrectly prints that I have amd64 architecture and that I have Ubuntu 16.04.2 LTS Release amd64 (20170215.2) when I have Ubuntu 16.04.3 This result seems not to have been commented on in the previous bug #1735594.

I'm working on a Toshiba Satellite M645 laptop (2011) with an Intel Core i5 CPU, 64 bit OS and graphics is Intel Ironlake Mobile.

I'm afraid to try the ppa:paulo-miguel-dias/pkppa suggestion because I am so new to this. I installed August 2017 and had no problems until Jan 5, 2018 when using the Software Updater.

The good news is: I learned to use terminal commands and can access all the browsers, word processors, files, etc. that I have on my machine so I'm not down just inconvenienced. Thanks

ppa:paulo-miguel-dias/pkppa works for me too

No more issues

Janghou (janghou) wrote :

@laurel, to find your version, try in a terminal
 lsb_release -a

If you have further questions for support or how to deal with his matter, please read:
https://askubuntu.com/questions/992571/gui-unity-crashing-in-16-04-lts-after-latest-updates-compiz-segfaults

Gord Kunz (kgord99) wrote :

ppa:paulo-miguel-dias/pkppa worked for me. No problems since.

The ppa: paulo-miguel-dias / pkppa worked but you have freezing from the desktop from time to time and recover by doing alt-tab or pkill compiz.

It does not work fine. nevertheless in gnme-shell if it works well. for the moment I stay in this environment until your solution.

Timo Aaltonen (tjaalton) wrote :

this bug is already marked as a dupe of 1735594, and you should have received further info on how to test fixed packages, no need to test anything else now

Leo Pilachowski (leopila) wrote :

There appear to be two ppa locations to get the fix for 16.04 i386:

ppa: paulo-miguel-dias / pkppa

ppa:tjaalton/ppa

Please tell us again how to get and try out the possible fix. I am experienced but new to Ubuntu but need to get a older system up and running asap on 16.04.

Leo

Timo Aaltonen (tjaalton) wrote :

forget about those ppa's and follow the main bug, a fix has been uploaded to xenial-proposed already

Leo Pilachowski (leopila) wrote :

Thanks. I saw that and that the comment on the "fix" was entered 8 minutes after my post above. But, I see there may be dependency problems installing that fix.

LP

Setget (setget) wrote :

sudo apt-add-repository ppa:paulo-miguel-dias/pkppa
sudo apt update && sudo apt upgrade -y
sudo reboot

works for me!!!

Don Essig (bluegecko) wrote :

This bug, or what I believe to be this bug and not 1735594, cropped up for me in an update on July 24, 2018 to kernel 4.4.0-131. Have spent the last week + searching the web and residing trying to figure things out and have landed here.

I am running Ubuntu 16.04 LTS on an old Acer Extensa 4420 with AMDS TK-57 processor and on board Nvidia 1250 video.

System boots into login screen just fine, but any attempt to Login, either Gnome or Ubuntu gets me to a wallpaper only with a mouse cursor. Messages flash up on the screen but do not stay long enough for me to interact with them. Initially one of the said Compiz crashed, but after the first reboot (holding the power switch down), that message no longer appears.

I can boot into Grub and duplicate issue with any of the 7 older kernels I have.

Can drop to system prompt from GRUB but am too inexperience to know what to do then.

This is being posted form another computer running Windows as laptop is currently unusable, and after many years of reliable Ubuntu service.

Please help.

I can confirm I have what I believe to be this bug in 16.04. All packages updated to current. Have also downloaded latest 16.04 LTS release .iso and run it off a USB drive. Same symptoms.

Originally, the issue was confined to Firefox, which crashed on many websites. The error related to "r300_dri.so". I disabled WebGL and this fixed the problem. However, as of mid-July, I have the same problems as other users (flashing icons at login, etc.). My logs tell me I installed a mesa update on 15/07/18.

Acer 5100
Ubuntu 16.04 (64-bit)
Graphics card: VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RS482M [Mobility Radeon Xpress 200]

I have tried to force a version downgrade of libgl1-mesa-dri in Synaptic, but the only option it gives me is a really old version - I just want to roll back to, say, February. Newbie, so don't want to play around too much and break stuff.

Many thanks to the developers - hopefully you can help.

Download full text (4.9 KiB)

Apologies for double-posting. Some additional info that may be helpful.

Paste from /var/crash/_usr_bin_compiz.1000.crash:
//BEGIN CODE PASTE//
ProblemType: Crash
Architecture: amd64
CrashCounter: 1
CurrentDesktop: Unity
Date: Thu Jul 26 22:13:47 2018
DistroRelease: Ubuntu 16.04
ExecutablePath: /usr/bin/compiz

<snip>

SegvAnalysis:
 Segfault happened at: 0x7f19500522c9: movdqu (%r8,%rbx,1),%xmm9
 PC (0x7f19500522c9) ok
 source "(%r8,%rbx,1)" (0x00000320) not located in a known VMA region (needed readable region)!
 destination "%xmm9" ok
SegvReason: reading NULL VMA
SourcePackage: compiz
Stacktrace:
 #0 0x00007f19500522c9 in ?? ()
 No symbol table info available.
 #1 0x0000000000000000 in ?? ()
 No symbol table info available.
StacktraceTop:
 ?? ()
 ?? ()
Tags: xenial xenial ubuntu compiz-0.9
ThreadStacktrace:
 .
 Thread 6 (Thread 0x7f19297bc700 (LWP 2252)):
 #0 syscall () at ../sysdeps/unix/sysv/linux/x86_64/syscall.S:38
 No locals.
 #1 0x00007f1956c7dcfa in g_cond_wait_until () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 No symbol table info available.
 #2 0x00007f1956c0d999 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 No symbol table info available.
 #3 0x00007f1956c0dfbb in g_async_queue_timeout_pop () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 No symbol table info available.
 #4 0x00007f1956c6060a in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 No symbol table info available.
 #5 0x00007f1956c5fbb5 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 No symbol table info available.
 #6 0x00007f19565ca6ba in start_thread (arg=0x7f19297bc700) at pthread_create.c:333
         __res = <optimised out>
         pd = 0x7f19297bc700
         now = <optimised out>
         unwind_buf = {cancel_jmp_buf = {{jmp_buf = {139746046887680, 2698625152003350009, 0, 140732259479199, 139746046888384, 139746491836624, -2647795865437594119, -2647591021518381575}, mask_was_saved = 0}}, priv = {pad = {0x0, 0x0, 0x0, 0x0}, data = {prev = 0x0, cleanup = 0x0, canceltype = 0}}}
         not_first_call = <optimised out>
         pagesize_m1 = <optimised out>
         sp = <optimised out>
         freesize = <optimised out>
         __PRETTY_FUNCTION__ = "start_thread"
 #7 0x00007f195841641d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109
 No locals.
 .
 Thread 5 (Thread 0x7f1942859700 (LWP 2244)):
 #0 pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
 No locals.
 #1 0x00007f194343670b in ?? () from /usr/lib/x86_64-linux-gnu/dri/r300_dri.so
 No symbol table info available.
 #2 0x00007f1943436427 in ?? () from /usr/lib/x86_64-linux-gnu/dri/r300_dri.so
 No symbol table info available.
 #3 0x00007f19565ca6ba in start_thread (arg=0x7f1942859700) at pthread_create.c:333
         __res = <optimised out>
         pd = 0x7f1942859700
         now = <optimised out>
         unwind_buf = {cancel_jmp_buf = {{jmp_buf = {139746466961152, 2698625152003350009, 0, 140732259485039, 139746466961856, 0, -2647566498614731271, -2647591021518381575}, mask_was_saved = 0}}, priv = {pad = {0x0, 0x0, 0x0, 0x0}, data = {prev = 0x0, cleanup = 0x0, canceltype = 0}}}
         not_first_call = <optimised...

Read more...

Dash (devel-tootai) wrote :

I too have this bug. I use radeon module for

01:05.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RS482/RS485 [Radeon Xpress 1100/1150]

Error is

compiz[12038]: segfault at 38c ip 00007f2dbc01a2c9 sp 00007fff9bbce640 error 4

I installed ubuntu-gnome-desktop but this failed too with a segfault

What I find out is that after a long time, flashing is stopping but desktop is not complete (eg not all icons nor launcher are displayed). From this time mouse or keyboard are responding but after a while everything is frozen.

Another think: if I remove linux-modules-extra from lets say 4.4.0-124-generic kernel, the problem disappear! No luck for me, I need this package for my network card ;)

I installed the xenial-proposed repo which gave 4.4.0-132 kernel, problem is still there. Attached is the file from /var/crash

Thanks to find a solution, computer is unusable :(

Daniel

Timo Aaltonen (tjaalton) wrote :

This bug and the bug it was marked as a dupe of was about Intel graphics. If you have a Radeon then file a new bug.

To post a comment you must log in.