Comment 89 for bug 1735594

Renato Bispo (rensilbis) wrote :

I'm running Ubuntu 16.04.3, my Unity was crashing in a similar way as it was originally described in this bug. Installing libgl1-mesa-dri/xenial-proposed fixed the issue. However, today, I tried to install Steam and it failed, at least partially, because the system is not being able to install libgl1-mesa-dri:i386 and libgl1-mesa-glx:i386. This seems to be related to the installation of libgl1-mesa-dri/xenial-proposed.

These are the messages I see in the terminal when trying to open Steam for the first time:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libegl1-mesa : Depends: libgl1-mesa-dri (= 17.2.4-0ubuntu1~16.04.4) but it is not going to be installed
 libgnome-desktop-3-12 : Depends: libgtk-3-0 (>= 3.9.10) but it is not going to be installed
 libqt5svg5 : Depends: libqt5widgets5 (>= 5.3.0) but it is not going to be installed
 qtdeclarative5-ubuntu-ui-toolkit-plugin : Depends: qml-module-ubuntu-components
                                           Depends: qml-module-ubuntu-performancemetrics
                                           Depends: qml-module-ubuntu-test but it is not going to be installed
 ubuntu-system-settings : Depends: libubuntuoneauth-2.0-0 (>= 13.08) but it is not going to be installed
                          Depends: powerd (>= 0.15) but it is not going to be installed or
                                   gnome-settings-daemon but it is not going to be installed
                          Depends: qml-module-qtmultimedia or
                                   qml-module-qtmultimedia-gles but it is not going to be installed
                          Depends: qtdeclarative5-ubuntu-content1 but it is not going to be installed
                          Recommends: ubuntu-system-settings-online-accounts but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.