Comment 25 for bug 1735594

uwer: which xserver versions do these machines have? apt-cache policy xserver-xorg-core

And do both have xserver-xorg-video-intel(-hwe-16.04) installed? One theory is that only machines installed with full HWE stack are affected, those do not have -intel installed but use the modesetting X driver (as intended).