Ubuntu

Ralink rt2400 / rt2500 / rt2570 / rt61 / rt73 do not work out of the box in Gutsy/Hardy

Reported by Piotr Makowski (Aviary.pl) on 2007-08-25
952
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux-backports-modules-2.6.22 (Ubuntu)
Undecided
Unassigned
Nominated for Dapper by escipio
Declined for Feisty by Brian Murray
Declined for Gutsy by Brian Murray
Nominated for Intrepid by escipio
Hardy
Undecided
Unassigned
linux-backports-modules-2.6.24 (Ubuntu)
High
Stefan Bader
Nominated for Dapper by escipio
Declined for Feisty by Brian Murray
Declined for Gutsy by Brian Murray
Nominated for Intrepid by escipio
Hardy
High
Stefan Bader
linux-ubuntu-modules-2.6.22 (Ubuntu)
Medium
Ubuntu Kernel Network Team
Nominated for Dapper by escipio
Declined for Feisty by Brian Murray
Declined for Gutsy by Brian Murray
Nominated for Intrepid by escipio
Hardy
Medium
Ubuntu Kernel Network Team
linux-ubuntu-modules-2.6.24 (Ubuntu)
High
Stefan Bader
Nominated for Dapper by escipio
Declined for Feisty by Brian Murray
Declined for Gutsy by Brian Murray
Nominated for Intrepid by escipio
Hardy
High
Stefan Bader

Bug Description

===
The poll shows that most of the problems with wireless networking are problems with ralink cards in Ubuntu.
POLL: What wireless chipset are you having a problem with in Gutsy?
http://ubuntuforums.org/showthread.php?p=4178322

The bug occurs commonly and it's very important - and will be easy - to fix it.
======================================

Cards don't work because of the invalid drivers (extremely slow connection, no connection, connection lost, lack of the wpa support) included in Ubuntu.

Work-around: To install the proper driver from serialmonkey.

SOLUTION:
1. Find out which version of a serialmonkey driver works properly with each ralink card.
2. Implement ralink serialmonkey drivers in Ubuntu.

http://rt2x00.serialmonkey.com/

Most likely the newest CVS version of each ralink driver works correctly.

===
Please write which drivers are known to work and which are invalid.
==

Exemplary posts on ubuntuforums.org:

Linksys WUSB54G V4 (rt2570-based card)
http://ubuntuforums.org/showthread.php?t=588045

HOWTO: RT73 (RT71) serialmonkey drivers
http://ubuntuforums.org/showthread.php?t=400236

====================
OLD BUG DESCRIPTION:
====================
I configured my rt2400 card connection in network-admin succesfully but the connection is extremely slow.
Ping works, but I can't get into any website, download packages through Synaptic even if waiting a few minutes.
The card was recognized by Feisty as ra0, but now it's wlan0 in Gutsy.

PING onet.pl (213.180.130.200) 56(84) bytes of data.
64 bytes from 213.180.130.200: icmp_seq=4 ttl=52 time=93.6 ms
64 bytes from 213.180.130.200: icmp_seq=5 ttl=52 time=82.8 ms
64 bytes from 213.180.130.200: icmp_seq=6 ttl=52 time=96.9 ms

The problem does not occur when running Feisty and when running Gutsy with Feisty kernel (2.6.20.x). The newest Gutsy and Hardy kernel still generates problems with ralink card. The transfer rate is extremly low - 678 b/s - 1391 b/s.

Thank you for taking the time to report this bug and helping to make Ubuntu better. I noticed an updated kernel, 2.6.22-11.32, was recently released. Can you try updating to this newer kernel and verify this bug is still an issue for you? Also, I just want to clarify that you do not see this problem when running Feisty correct? Thanks in advance!

Changed in linux-source-2.6.22:
assignee: nobody → leannogasawara
Changed in linux-source-2.6.22:
importance: Undecided → Medium
status: New → Incomplete

The problem does not occur when running Feisty and when running Gutsy with Feisty kernel (2.6.20.x). The newest Gutsy kernel still generates problems with ralink card. The transfer rate is extremly low - 678 b/s - 1391 b/s.

Changed in linux-source-2.6.22:
assignee: leannogasawara → ubuntu-kernel-network
status: Incomplete → Confirmed
Jonathan Austin (mailforwho) wrote :

I have the same problem when using gutsy. Under Feisty it's fine for me.

I have a ralink rt2500 based PCI card.

I've attached the output of lspci from feisty.

Using a WEP network set up by network manager (the first release this has 'worked' for me in - yay :)

jepessen (danwolf80) wrote :

I've a problem too.

I've tried today to install gutsy tribe 5 on my Fujitsu Siemens Amilo A 1630, with alternate iso.

But when textual installation program searches fot network interfaces, it find only the ethernet card and the IR. Feisty, instead, find and use ralink chipset during installation without any problem.

I've stopped installation of gutsy 'cause of this.

lspci command gives me this row about ralink card

00:0b.0 Network controller: RaLink RT2500 802.11g Cardbus/mini-PCI (rev 01)

If necessary, I'll install gutsy.

Will be the bug resolved in the final Gutsy release? It makes all rt2x00 cards useless with Ubuntu!

Kai Stempfle (kai-stempfle) wrote :

Well, it's not currently listed at https://launchpad.net/ubuntu/+milestone/ubuntu-7.10-rc
which means it will most likely not be fixed for the first release candidate.

jepessen (danwolf80) wrote :

I've finally tried gutsy.

ralink card is not recognized during installation, only cable, but when all was installed, after reboot my wireless card was correctly identified and configured.

Oh, this is just great, it's still not even worked on _and_ not on the RC list :(

Adam McMaster (adammc) wrote :

Is it too late to add it to the list?

Ubuntu 7.10 released today with a serious regression - RALINK cards work no more. Great! :( And.. nothing can be done?

Jos Dehaes (jos-dehaes) wrote :

you can install the rt2400-source package and build the legacy driver with module-assistant. Don't forget to blacklist rt2400pci. This works for me (rt2500).

D-Evil (dj-soft) wrote :

Ralink driver is under heavy development. If may be already solved, but I'm quite sure this can't be done (or is very hard to do) in this kernel version. You can try to compile newer version yourself.

Jos Dehaes (jos-dehaes) wrote :

The rt2x00 is not API compatible with the gutsy kernel.
I've tried recent (last week) rt2x00 kernels, the driver is still a lot slower than the legacy driver (100kB/s), although it does work with network-manager. I find myself always going back to the legacy driver.

You can also try to use ndiswrapper and Ralink's Windows drivers.
Just switched to ndiswrapper and it works (RT2500 based PCI card).

Is there legacy driver shipped with Gutsy (and blacklisted)? If so there is no problem, if not I don't get why it is not done this way. In Feisty new rt2x00 driver was present but blacklisted (brave one could try unstable driver) and every one were happy.

terdon (selenop) wrote :

Hi guys,
        I finally got my onboard RT2500 card working under Gutsy on my Fujitsu-Siemens Amilo A1630. The drivers that come with gutsy didn't work and nor did ndiswrapper. However, the lastest CVS snapshot of seriualmonkey's driver (http://rt2x00.serialmonkey.com/rt2500-cvs-daily.tar.gz) worked great!

So, just download the file, untar, follow instructions in the README of the Module diretcory.

After you are done blackist the old drivers by adding these lines to /etc/modprobe.d/blacklist:

blacklist rt2500pci
blacklist rt2x00pci
blacklist rt2x00lib

Hope this helps!

I tried to install the driver for my rt2400 and was successful with the legacy. The next-generation one does not work.
http://rt2x00.serialmonkey.com/rt2400-cvs-daily.tar.gz

D-Evil (dj-soft) wrote :

I would like to say that this new driver works (with rt2400 pcmcia card). Yes, it has problems like slow performance, falling connection, no signal strength reporting, errors and lockups on suspend, so it is unusable right now. But it works, it supports wireless extensions, it can scan air, it works with NetworkManager, it can handle WPA (both personal and enterprise). So please be patient, things are moving and they are on the right way. Even this is better than nothing you have when you need WPA.

Legacy driver can also be used with WPA, it's just a different manner of setting things up. You say it yourself, it's unusable right now. In the near future it will be usable, but not with Gutsy. The legacy drivers should also be included.

Cesare Tirabassi (norsetto) wrote :

Anyone had any success with version 2.0.9-2 (available from the rt2x00-source package, from debian unstable)?

D-Evil (dj-soft) wrote :

I've tried kernel 2.6.24-rc1 (driver is included here for first time, version 2.0.10) and there is no clearly visible progress in speed for me (I'm using WPA). But you can try to use Windows driver through ndiswrapper. It is fast, NetworkManager compatible (with WPA too) and even signal strength reporting works on rt2400 cards.

I vote for inclusion of legacy drivers in Gutsy. The user will have the choice between legacy and new driver by means of blacklisting (as in Feisty). Current status of the driver for rt2x00 cards is what makes me NOT upgrade to Gutsy.

Cesare Tirabassi (norsetto) wrote :

I don't see your point. Legacy drivers ARE in Gutsy (thats what I'm using a this very moment):

rt2400-source - source for rt2400 wireless network driver: Version: 1.2.2+cvs20070219-3
rt2500-source - source for rt2500 wireless network driver: Version: 1:1.1.0-b4-4ubuntu1
rt2570-source - RT2570 wireless network drivers source: Version: 1.1.0+cvs20070219-2

wodz (wodz) wrote :

I was not precise - my point is to ship both legacy and new rt2x00 modules with gutsy kernel (the way it was in feisty). By means of blacklisting user will have the choice to use NetworkManager compilant rt2x00 with poor performance (this can be default) or legacy one with weird configuration but with good performance. Compiling driver form rt2500-source with every kernel upgrade is rather unhandy.

Animacide (animacide) wrote :

I agree with Wodz, but I'd go one step further and say the legacy driver should be the default. There seems to be a consensus that the rt2x00 module is unusable, and I can't see any reason why users would want an unusable module as the default. It also seems to me that most users would not want to go out of their way to compile a module just so they can get wireless working properly, and many of them may not even know that option exists. I imagine that there are quite a few less experienced users out there who are not even aware that a solution is available, they just know that after the Gutsy upgrade the wireless connection on their PC is buggy and slow.

Linuxluver (sbwithers) wrote :

I followed the development of the rt2400/802.11b wireless drivers for a couple of years. Last I heard the drivers for the RaLink RT2400 did not work with the SMP version of any kernel and only worked with the UNI version of the kernel. Gutsy installs the SMP version of the kernel with no facility I can find to replace it with the uni kernel without connecting to the Net.....so I was screwed and had to get rid of Gutsy.

Xandros 4.0 includes/d both SMP and UNI versions of the kernel and one could switch between the two without having to download anything.

I'd rather get a good 802.11g wireless card that works well with Linux......but I have had to resort increasingly to Windows both for wireless networking and for video capture and processing. Having been on Linux exclusively for the past 6 years, moving back to Windows has been a disappointment. I just don't have time to frig around with Linux any more. ...and this issue is just one more example.

Henrik Nilsen Omma (henrik) wrote :

This will be retargeted towards the Hardy kernel once it is released. It's tagged this as "hardy-kernel-candidate" so that we make sure to retarget this report once the new release is out. However against the linux-source-2.6.22 package this is being marked as "Won't Fix" as it does not meet the criteria for a stable release update. To learn more about the stable release update process please refer to https://wiki.ubuntu.com/StableReleaseUpdates . Thanks!

Changed in linux-ubuntu-modules-2.6.22:
status: Confirmed → Won't Fix

My rt2400 card still does not work under Hardy Alpha 2. I hope the proper, WORKING driver will be set by default in the next release.

oponek (oponek-merged) on 2008-01-02
description: updated
description: updated
Changed in linux-ubuntu-modules-2.6.24:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: New → Triaged

The bug affects also Ralink RT61 card. It does not work out of the box. It is needed to install another driver: http://ubuntuforums.org/showthread.php?p=3859034 to get it working.

The same problem with a slow connection with rt73 card has been reported by another user: https://bugs.launchpad.net/ubuntu/+source/linux-ubuntu-modules-2.6.22/+bug/134344 . Ralink cards should work out of the box in Hardy - it is needed to check which version of those drivers works correctly. The rt73 is known to work only with rt73-cvs-2007072709 version.

oponek (oponek-merged) on 2008-01-10
description: updated

yes, I can confirm the rt73usb.ko driver does not work for "ANY RELEASE" never did, although the rt73 driver from here:
http://rt2x00.serialmonkey.com/rt73-cvs-daily.tar.gz
works fine. Wpa works great as well, unfortunately any wpa password longer than 20 characters crashes Ubuntu and locks up the box, oops, nevermind, just checked this forum thread:
http://rt2x00.serialmonkey.com/phpBB2/viewtopic.php?p=28063#28063
it seems the password length issue has been resolved for wpa with the rt73 driver from serialmonkey, basically here is how to install:
wget http://rt2x00.serialmonkey.com/rt73-cvs-daily.tar.gz
tar zxvf rt73-cvs-daily.tar.gz
cd rt73*
cd M*
make
sudo make install
sudo gedit /etc/modprobe.d/blacklist
append this to the end of the file:
# rt73 blacklisted drivers
blacklist rt2500usb
blacklist rt73usb
blacklist rt2x00usb
blacklist rt2x00lib
blacklist ipv6
now sudo /etc/init.d/networking restart and we shall be connected if /etc/network/interfaces file is configured correctly, here is an example of mine:
# WORKING STATIC AES/WPA CONFIG
#auto wlan0
#iface wlan0 inet static
#address 192.168.1.66
#netmask 255.255.255.0
#gateway 192.168.1.254
#pre-up ifconfig wlan0 up
#pre-up iwconfig wlan0 essid 2WIRE
#pre-up iwconfig wlan0 mode managed
#pre-up iwpriv wlan0 set Channel=9
#pre-up iwpriv wlan0 set AuthMode=WPAPSK
#pre-up iwpriv wlan0 set EncrypType=AES
#pre-up iwpriv wlan0 set WPAPSK=yourwpapasswd
#pre-up iwpriv wlan0 set TxRate=0

# WORKING DYNAMIC AES/WPA CONFIG
auto wlan0
iface wlan0 inet dhcp
pre-up ifconfig wlan0 up
pre-up iwconfig wlan0 essid 2WIRE
pre-up iwconfig wlan0 mode managed
pre-up iwpriv wlan0 set Channel=10
pre-up iwpriv wlan0 set AuthMode=WPAPSK
pre-up iwpriv wlan0 set EncrypType=TKIP
pre-up iwpriv wlan0 set WPAPSK=yourwpapasswd
pre-up iwpriv wlan0 set TxRate=0
mtu 1500
There we go rt73 working perfectly, now, lets watch and see if the Ubuntu developers can add this wonderful driver to Gutsy and Heron...
Kyle Weller

Kyle M Weller (kylew) wrote :

btw its working with this exact card:
Bus 001 Device 002: ID 050d:705a Belkin Components

Kyle M Weller (kylew) wrote :

oh and please stop by http://rt2x00.serialmonkey.com/phpBB2/viewtopic.php?p=28063#28063 and thank those developers for this :)

oponek (oponek-merged) on 2008-01-22
description: updated
description: updated
description: updated
oponek (oponek-merged) on 2008-01-22
description: updated
description: updated
oponek (oponek-merged) on 2008-01-24
description: updated
Changed in linux-ubuntu-modules-2.6.24:
importance: Medium → High
Tim Gardner (timg-tpi) on 2008-02-13
Changed in linux-ubuntu-modules-2.6.24:
milestone: none → hardy-alpha-4
status: Triaged → Fix Released
Id2ndR (id2ndr) on 2008-03-11
Changed in linux-ubuntu-modules-2.6.24:
status: Fix Released → Confirmed
Steve Langasek (vorlon) on 2008-03-20
Changed in linux-ubuntu-modules-2.6.24:
milestone: hardy-alpha-4 → ubuntu-8.04
Stefan Bader (smb) on 2008-03-26
Changed in linux-ubuntu-modules-2.6.24:
assignee: ubuntu-kernel-team → stefan-bader-canonical
191 comments hidden view all 271 comments

On Wed, Apr 16, 2008 at 4:59 PM, _oOMOo_ <email address hidden> wrote:

> Just to satisfy my curiosity, seeing that the version in backports is a)
> newer and b) appears to work better than the packaged version, why is it
> not already in Hardy?

because it's backported from linux 2.6.25 (which is an "unstable"
kernel - so the odd minor version number) and because hardy officially
ships with 2.6.24

I posted some time ago my information:
rt2500 in a pcmcia card (and other one in PCI) that works flawless in
gutsy (with minor issues like not reporting rate) results in a card
that works in hardy, but terribly slow. After connecting, if you do:

$sudo iwconfig wlan0 rate 54M

...then problems seems to go away. I'm connecting to a wpa-psk g
access point, and getting between 1000 and 2000 KiB/s with the pcmcia,
and 1500-2400 KiB/s with the PCI one.

The news: I tried the linux-backports-modules-hardy package and my
problems persisted.

By the way, i'm trying to workaround with a simple script in
/etc/network/if-up.d/ with no success at all. That simple script is
like this:

galvesband@sysop:~$ cat /etc/network/if-up.d/99rt2500_hack
#! /bin/sh

# Only for wlan0...
[ "$IFACE" = "wlan0" ] || exit 0

wait 5
iwconfig wlan0 rate 54M

This seems to works at first sight, but it isn't working at all:
iwconfig report a 54Mb rate, but practical speed seem to be limited to
80 KiB/s, very far from the 1000/1500 KiB/s I usually achieve.

I'm not sure if this helps anyone. I just saw people go on reporting
and wondered if this improves the information a gave previously.

Regards.

Olivia (oli-maia) wrote :

Andreas, the linux-backports-modules thing seems to be working great with rt73usb :) Thanks for that!

Kai Stempfle (kai-stempfle) wrote :

Unfortunately, I cannot report any success at all...

I'm using a rt2500-based card by Foxconn:

$ lspci | grep RT2500
05:06.0 Network controller: RaLink RT2500 802.11g Cardbus/mini-PCI (rev 01)
$ lspci -n | grep 05:06.0
05:06.0 0280: 1814:0201 (rev 01)

WEP HEX 128-bit based encryption. I'm not able to associate to my AP at all.
I'm attaching dmesg and iwconfig output from rt2500pci as well as ndiswrapper (which I'm currently using)

4 comments hidden view all 271 comments
luca.mg (luca-mg) wrote :

After a few days of testing I want to tell to all of us struggling with a hardy kernel on top of gutsy that the best way to go is to install hardy: everything works much better in hardy than in gutsy with updated kernel, wicd a must AFAICT. I also have to say that things are working better than before but we're not there yet: the hardware dies after a few hours online, while it used to die after a bunch of minutes before; this is an improvement but things are not working as they should and some more work has to be done. This is in regard of the rt73 dongle, still no luck with the rt2570 as of today.

Regarding the linux-backports-modules-hardy package: I installed this too but did not notice any benefit, how do I make sure the kernel is loading the backport modules instead of the default ones? Going to the /lib/modules directory shows that both modules are installed in different locations and I really do not know how to verify which generation of module is being loaded. A nice weekend to everybody, luca

Kaminix (kaminix) wrote :

I'm on a RT2500 card. This is how it looks in lshw under Gutsy:
           *-network
                description: Wireless interface
                product: RT2500 802.11g Cardbus/mini-PCI
                vendor: RaLink
                physical id: 2
                bus info: pci@0000:06:02.0
                logical name: wmaster0
                version: 01
                serial: 00:0d:f0:1d:31:b1
                width: 32 bits
                clock: 33MHz
                capabilities: pm bus_master cap_list logical ethernet physical w
ireless
                configuration: broadcast=yes driver=rt2500pci ip=192.168.0.5 lat
ency=32 module=rt2500pci multicast=yes wireless=IEEE 802.11g

In Gutsy my network worked well, it had some troubles but overall I was quite happy with it. Then I upgraded to Gutsy, and now I'm experiencing the troubles described in this report. The speeds are unbelievably slow, three times slower than I was on Gutsy and almost 10 times slower than my sister's (we can't loose to VISTA!) according to speedtest.nl (conducted with in Gutsy via the Live CD...). If I use download something under Hardy and ping my router at the same time I get ping times like 25 000ms and packetlosses of up to 25% it seems.

I upgraded from Hardy via the upgrade tool by the way, but it all worked under Gutsy.

Download full text (3.4 KiB)

Kudos. You guys made a tremendous 8.04 deadline job.
You even added suspense ;-)
This report may be incomplete, but I wanted to thank for the impressive improvement regarding general ease of use.
The only problem I see is RT2500 download data rate.

Shall we tell them?
http://www.bluenext.co.uk/wifi-adapter/bn-wd54g-wireless-usb-adapter.html
Now VISTA Supported, you can plug and play in Windows VISTAtm without install driver! New Mac and Linux driver is avaliable*
* Mac and Linux driver is not offically supported by us.

I installed 8.04 CR, near to what 8.04 LTS will be, on two computers.
For the first time, my two ex-infamous Ralink-based wifi interfaces ran out of the box (well, I didn't put them back in it and they escaped, you know what I mean).
Up to 8.04 beta included, I had to install serialmonkey for both.
Specifically :
USB 148F:2573 mod=rt73usb case=BlueNEXT BN-WD54G
PCMCIA "RT2500 802.11g Cardbus/mini-PCI" mod=rt2500pci case=Comtrend GN-WMKG
Both bought cheap on Ebay and are now nicely hot pluggable.
Switch is USR5462 configured with WPA & TKIP.
Channel 1 as I had had recongition problems of 12 before.

I've run 1500 bytes pings for hours (ping 192.168.0.1 -s 1500).
Not a single packet loss when running a sigle interface alone in an idle machine.
Up to 5 hours for the RT73, probably 9 but I lost the stats, I explain why...

Remarks are:
- Internet download data rate is OK on RT73 (350 KiB/s) but slow on RT2500 (20-40 KiB/s) but I made decent Web browsing. CPU rate difference (800/400 MHz) cannot be the reason. To be checked.
- The pings didn't run simultaneously on both machines. Once one got replies, the other stopped and they alternated. The computers were very near one another though. Fixed by moving one interface away.
- The computer running RT73 freezes (behind a power&screensaved display) after a long time of inactivity (but PING). This is why I can't be sure of 9 lossfree hours. I suspect the hanging is not RT73 related, though, more probably to the screen. I would come back here if it was.
- The 2500's second LED is off whereas serialmonkey switches it on and blinking when packets flow (seeing it off meant it wasn't working, as when just plugged in). Annoying but I would trade just this for the rest.
- I wonder why it is/was hard to port excellent serialmonkey's sources to here, but they probably know much better than I.

RT73:
-----
--- 192.168.0.1 ping statistics ---
17303 packets transmitted, 17295 received, 0% packet loss, time 17302100ms = 5 hours
rtt min/avg/max/mdev = 1.419/4.741/874.366/41.046 ms
(64-bytes only pings, up to 9 hours 1500-bytes sessions ran smoothly but were interrupted by crash)

rest is 1500-bytes
8801 packets transmitted, 8799 received, 0% packet loss, time 8800036ms
rtt min/avg/max/mdev = 8.067/26.500/2091.843/151.196 ms, pipe 3

RT2500, all 1500-bytes
----------------------
--- 192.168.0.1 ping statistics ---
1315 packets transmitted, 1312 received, 0% packet loss, time 1314069ms
rtt min/avg/max/mdev = 152.395/201.203/289.634/23.264 ms

2582 packets transmitted, 2308 received, 10% packet loss, time 2585980ms
rtt min/avg/max/mdev = 143.066/271.846/6339.902/386.283 ms, pipe 4
(during Firefox activ...

Read more...

1 comments hidden view all 271 comments
Kaminix (kaminix) wrote :

I compiled and installed the serialmonkey drivers for rt2500 and blacklisted the old ones, and moved the .ko-file to the right place.
It's dirty, but it worked, now I get full speeds with my rt2500 card, possibly even faster than I ever did in Gutsy! :)

Though I don't think the upload is quite up to what I should be able to get, just a feeling, it mostly works well.

Update to my message.

RT2500:
With 7.10 and serialmonkey, Rate=54 Mb/s and download reaches 350 KiB/sec.
With 8.04CR, Rate=1 Mb/s and download reaches 20 KiB/sec.
after setting sudo iwconfig wlan0 rate 54M
Rate=54 Mb/s and download reaches 150 KiB/sec.

RT73:
With 8.04CR, Rate=1 Mb/s and download exceeds 350 KiB/sec (up to 450)
Changing the rate produces no download throughput change.

Is it possible to set the rate automatically when the interface starts?

Hoping this will help,

André.

wlan0 RT2500 Wireless ESSID:"xxx"
          Mode:Managed Frequency=2.412 GHz Access Point: 00:C0:49:xx:xx:xx
          Bit Tx-Power:0 dBm
          RTS thr:off Fragment thr:off
          Link Quality=62/100 (*) Signal level:-63 dBm Noise level:-82 dBm
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0
350 KiB/sec

wlan0 IEEE 802.11g ESSID:"xxx"
          Mode:Managed Frequency:2.412 GHz Access Point: 00:C0:49:xx:xx:xx
          Bit Rate=1 Mb/s Tx-Power=27 dBm
          Retry min limit:7 RTS thr:off Fragment thr=2346 B
          Link Quality=48/100 (*) Signal level=-69 dBm
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0
  20 KiB/sec

wlan0 IEEE 802.11g ESSID:"xxx"
          Mode:Managed Frequency:2.412 GHz Access Point: 00:C0:49:xx:xx:xx
          Bit Rate=54 Mb/s Tx-Power=27 dBm
          Retry min limit:7 RTS thr:off Fragment thr=2346 B
          Link Quality=69/100 (*) Signal level=-65 dBm
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0
150 KiB/sec

(*) 20 if the microwave oven is running :-)

Jos Dehaes (jos-dehaes) wrote :

I can confirm that in hardy RC suddenly the rate is by default 1MB/s. This was not the case in earlier hardy kernels. Manually setting the rate to 54M, I get downloads of > 1MB/s (20 Mbit line). Setting the rate manually should not be necessary.

Jos Dehaes (jos-dehaes) wrote :

Sorry, this was for the rt2500 chip (rt2x00pci driver).

Tony Arnold (tony-arnold) wrote :

I had the same problem as Jos with Hardy RC after upgrading from Gutsy. But even setting the speed manually did not seem to give me full speed. I resorted to downloading the latest CVS driver from serial monkey and that works fine.

Hamish Downer (mishd) wrote :

Found some relevant comments about why the speed of the connection may be lower than expected.
http://lwn.net/Articles/278191/

To quote it here:

"At the moment the semi-free madwifi is more reliable than ath5k with 2.6.25-rc kernels[*], due
(I suspect) to problems with the mac80211 layer being rather too aggressive in reducing the
link speed in face of less than ideal signal conditions. Signal quality/level monitoring
(using wavemon) suggests that unsmoothed values are causing the rate algorithms to believe
that conditions are worse than they actually are. I see similar problems with the in-kernel
rt2500 driver."

And in another comment from there

"It appears to be tweakable via debugfs." - http://linuxwireless.org/en/developers/Documentation/mac80211/RateControl/PID

Hope this is helpful to some ...

André Pirard (a.pirard) wrote :

Funny, this is what I had ready to post just while finding the above.

According to my tests, it seems to me that the problem is not that the interface is set to "rate 1M", but to "rate auto", and that this automatic bitrate adjustment mode is broken, setting rate down to 1M.
Hence, I have put this script in /etc/network/if-up.d under any name.

#!/bin/bash
# Only for wlanX...
[[ $IFACE == wlan* ]] || exit 0
iwconfig $IFACE rate 36M

to use a fixed bitrate. 54M is not necessarily the best value and you'll have to experiment, these were my rough results.

54M 140 KiBps
48M 170
36M 190
24M 180

It continues to be a mystery why the transmission rate is so low and still varies more than surrounding noise can explain (packet size adjustment? but that's sending side matter).
Anyway, doing away with having to compile the divers to continue each Ubuntu installation is excellent work.

Ian (superian) wrote :

With the 2.6.24-16 kernel, I no longer need to change the setup of the wireless network (DHCP to static IP or vice versa) before my card will work. (See comment 140, 142 and 143 above.)

Unfortunately, it looks like there's a wireless network related bug in 2.6.24.* that frequently causes a kernel panic (= system lockup) here.

Does anyone else get this?

Annoyingly using ndiswrapper isn't an option for me, because the card maker only supplies a Windows .exe file which isn't an archive format 7zip knows about, not .inf files.

Running 8.04 CR, I've has 4 cases in 2 days of lockup when the rt73 was plugged in.
Unplugged the rt73 and 8.04 CR ran about 48 hours without stop.

Ian, if you stop answering the Windows' WiFi installer's questions at some point before it starts installing, you will find the decompressed files in the TEMP folder.
If a system where the installation was made, the .inf file is in the INF folder and its contents indicates what files have been installed and have to be used by ndiswrapper.

On Mon, Apr 21, 2008 at 11:05 PM, Ian <email address hidden> wrote:

> Annoyingly using ndiswrapper isn't an option for me, because the card
> maker only supplies a Windows .exe file which isn't an archive format
> 7zip knows about, not .inf files.

Ian, just run the installer .exe under WINE - I've done this many
times before to extract Windows wireless drivers.

e.g. wine setup.exe

On one occasion the installer would not even install properly, and
would delete all temporary files when it failed and exited. So I had
to let it unpack all files, and then leave it waiting at an OK prompt,
then browse the temporary folder where it had unpacked them to find
the .inf file. I think that's pretty rare, though.

Changed in linux-ubuntu-modules-2.6.24:
milestone: ubuntu-8.04 → ubuntu-8.04.1
milestone: ubuntu-8.04.1 → ubuntu-8.04
Stefan Bader (smb) wrote :

I am closing this as won't fix for now and for the lum target. This is by no way meant as if we do want to drop the subject. However there seem to be some which have the kernel driver working for them. For others the external version (now in lbm works better), The lbm version also will be the one to change/fix more likely, since it is outside the kernel. Also this report now has several hardware and several issues grouped together which does not make matters simpler. So, if there are problems with the kernel driver, try lbm. If there are still problems a new report should be made for the various issues (and should mention the driver used).

Changed in linux-ubuntu-modules-2.6.24:
status: Confirmed → Won't Fix
Steve Langasek (vorlon) on 2008-04-25
Changed in linux-backports-modules-2.6.22:
status: New → Invalid
Changed in linux-backports-modules-2.6.24:
assignee: nobody → stefan-bader-canonical
importance: Undecided → High
milestone: none → ubuntu-8.04.1
Changed in linux-ubuntu-modules-2.6.24:
milestone: ubuntu-8.04 → none
Stefan Bader (smb) wrote :

commit 13c78d70f397c31ca9cf3043114a218751514551
Date: Fri Apr 25 12:19:09 2008 -0400

    UBUNTU: rt2x00: Update driver to serialmonkey version 2.1.5

Changed in linux-ubuntu-modules-2.6.24:
status: Confirmed → Won't Fix
Changed in linux-backports-modules-2.6.24:
status: New → Fix Committed
sefs (sefsinc) wrote :

I am experiencing a problem with serial monkey rt73 drivers.
On boot the hardware device is not starting and cannot be detected.

I have to wait until the system is fully booted. unplug the usb
adapter, plug it back in and restart the network by cli to get the
network adapter started.

What is up with that?

This is with rt73-cvs-daily-apr-25-2008

the one before that does not even work any more, although it worked in
gutsy.

What is going on here fellas.

This problem is new to me in hardy. Will there be a fix for this.

Janek Thomaschewski (thefoxx) wrote :

As I said already I installed Hardy with Virtualbox on my Gutsy System some time ago. With the Hardy alpha kernel inside the Virtualbox System I was able to use my RT2570 (USB) interface without any problems (I was able to connect and to download with full 6k DSL speed, didn't tested more).
After really installing Hardy beta on my linux partition the connection failed again... Today I installed the serialmonkey CVS hourly tarball "rt2570-cvs-2008042709" and now it seems to be a stable connection with 54 Mbit when using static IP settings. DHCP does not work.
Will there be any updates in the backports?

Ian (superian) wrote :

Thanks to André and Ashley (comments 252 and 253) - when I have it up long enough to download wine, Ill try that.

There's more on the problems I've had at https://bugs.launchpad.net/ubuntu/+source/linux/+bug/206068

Neil Wallace (rowinggolfer) wrote :

Ian,
Wine is unlikely to help you have it up for longer.

Alexander Jones (alex-weej) wrote :

Top marks for innuendo.

On 2008-05-02 00:02, Neil Wallace wrote :
> On 2008-05-01 22:56, Ian wrote :
>
>> Thanks to André and Ashley (comments 252 and 253) - when I have it up
>> long enough to download wine, Ill try that.
>>
> Ian,
> Wine is unlikely to help you have it up for longer.
>
Both of you probably love puns, Ian and Neil ;-)
My added fun was to find your messages right next to another one titled :
Votre Phaaaaarmacie en ligne, Viiiaaa -ra - 0.88 EURO (your pharmacy
online ...)

Now, just as serious as we must be...
He wants to download wine to be able to extract drivers liable to keep
his interface up all the time.
But again, don't tell this to anyone on the street without some
preliminary word of warning :-)

André.

Ian (superian) wrote :

Ho ho. Running the installer with wine did leave the files in several silly places (whoever wrote the installer should be taken out and shot) but - fingers crossed - the backports modules version seems to avoid the lockup problem.

It doesn't like being woken up after hibernating (I have to restart to get the wireless network back) and for some reason, the two LEDs on the card are permanently on rather than flickering away when there's some network action, but...

Finally I got my D-link dwl-g122 rev b (rt2570 chipset) working with hardy using ndiswrapper. Try it, just remember to use the i386 version of ubuntu, because ndiswrapper won't explicitly warn you about incompatibility between 64bit kernel and 32bit driver. Good luck!

Marking this "Fix Released" as Stefan's patch is available in linux-backports-modules:

linux-backports-modules-2.6.24 (2.6.24-16.14) hardy; urgency=low

  [Stefan Bader]

  * Added rt2x00 driver from serialmonkey.org
    - LP: #134660

For the full changelog refer to: https://edge.launchpad.net/ubuntu/+source/linux-backports-modules-2.6.24

If you are still experiencing issues, refer to comment 254 - https://bugs.edge.launchpad.net/ubuntu/+bug/134660/comments/254

Thanks.

Changed in linux-backports-modules-2.6.24:
status: Fix Committed → Fix Released
status: Fix Committed → Fix Released
OMUT (valeri1963) wrote :

I established rt2500-CVS driver from serialmonkey, and now I do not have problems :)

[quote]
ra0 RT2500 Wireless ESSID:"Valeri"
          Mode:Managed Frequency=2.437 GHz Access Point: 00:15:0C:74:88:CD
          Bit Rate=54 Mb/s Tx-Power:0 dBm
          RTS thr:off Fragment thr:off
          Link Quality=73/100 Signal level:-75 dBm Noise level:-85 dBm
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0
[/quote]

sorry for my English:)

Magnes (magnesus2) wrote :

RT61 PCI (module rt61pci) on Hardy Heron sometimes (during downloading files from Internet) crashes Ubuntu. The screen freezes, the keyboard leds - capslock and numlock - are blinking and there is no response to any button (alt+f1 for example) or mouse movements.
Also it doesn't always connect, sometimes I need to use "sudo /etc/init.d/networking restart".

From syslog:

May 17 08:45:44 d700 kernel: [ 311.132490] ADDRCONF(NETDEV_UP): wlan0: link is not ready
May 17 08:45:45 d700 kernel: [ 311.879292] wlan0: Initial auth_alg=0
May 17 08:45:45 d700 kernel: [ 311.879305] wlan0: authenticate with AP 00:1a:70:95:f7:5c
May 17 08:45:45 d700 kernel: [ 311.880763] wlan0: RX authentication from 00:1a:70:95:f7:5c (alg=0 transaction=2 status=0)
May 17 08:45:45 d700 kernel: [ 311.880772] wlan0: authenticated
May 17 08:45:45 d700 kernel: [ 311.880776] wlan0: associate with AP 00:1a:70:95:f7:5c
May 17 08:45:45 d700 kernel: [ 311.896597] wlan0: RX AssocResp from 00:1a:70:95:f7:5c (capab=0x461 status=0 aid=1)
May 17 08:45:45 d700 kernel: [ 311.896606] wlan0: associated
May 17 08:45:45 d700 kernel: [ 311.898244] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
May 17 08:45:45 d700 dhclient: There is already a pid file /var/run/dhclient.ra0.pid with pid 134519072
May 17 08:45:45 d700 dhclient: Internet Systems Consortium DHCP Client V3.0.6
May 17 08:45:45 d700 dhclient: Copyright 2004-2007 Internet Systems Consortium.
May 17 08:45:45 d700 dhclient: All rights reserved.
May 17 08:45:45 d700 dhclient: For info, please visit http://www.isc.org/sw/dhcp/
May 17 08:45:45 d700 dhclient:
May 17 08:45:45 d700 dhclient: wmaster0: unknown hardware address type 801
May 17 08:45:46 d700 ntpdate[6637]: step time server 91.189.94.4 offset -1.316687 sec
May 17 08:45:45 d700 avahi-daemon[5565]: Registering new address record for fe80::21b:11ff:fec5:1f2b on wlan0.*.
May 17 08:45:45 d700 dhclient: wmaster0: unknown hardware address type 801
May 17 08:45:45 d700 dhclient: Bind socket to interface: No such device
May 17 08:45:54 d700 kernel: [ 321.999047] wlan0: no IPv6 routers present
---- my note: here the system crashed ----
May 17 08:55:39 d700 syslogd 1.5.0#1ubuntu1: restart.

from messages:

May 17 08:57:29 d700 kernel: [ 179.814629] ADDRCONF(NETDEV_UP): wlan0: link is not ready
May 17 08:57:30 d700 kernel: [ 180.569922] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
---- my note: here the system crashed ----
May 17 09:09:58 d700 syslogd 1.5.0#1ubuntu1: restart.

Nothing interesting in XOrg log.

Sorry if this is a wrong but to attach this to. ;)

lol1972 (lol1972) wrote :

UBUNTU VERSION: HARDY 2.6.24-17-generic (gutsy upgrade)
lsusb : 07d1:3c03 D-Link System
USB WIRELESS DLINK: DWL-G122 H/W VER. C1.
NETWORK WIRELESS 801G, WEP, HEXADECIMAL.

Got it to work eventually with the rt73usb driver.
added a line to the following file, /etc/modules:

      rt73usb

Saved, closed & rebooted.

Opened up network manager (via menu: System, Administration, Network)
and manually configured Wireless connection. Entered wep settings via (via properties button).

Magnes (magnesus2) wrote :

lbm version with rt61 - even worse, more crashes, harder to connect. I had to revert to normal version. :(

Sorry for asking a stupid question, but I'm experiencing problems with the rt2500pci driver on an old PCI wifi card (which, incidentally, worked flawlessly, fast and smooth on Feisty Fawn!) and installing linux-backports-modules-2.6.24-generic didn't solve my problem. I tried blacklisting rt2500pci in /etc/modprobe.d/blacklist to no avail - network manager didn't see my wireless capability at all.

I might have overlooked something obvious here, but as far as I can see, this is not fixed? Is there some more manual tweaking required to get this flying?

Thanks!

termitor (termitor) wrote :

hello.
Depending on the version I use kubuntu kernel, I do not have the same detection capability.
The sensitivity would be concerned mainly via the register BBP which would not be managed the same way, I'm hardy kernel with a gusty, I also tested regularly intrepid, depending on the version of the kernel, I do not have the same sensitivity, all that would link to register BBP, so most of the time it did not detect my wireless connections

If you like, you could resolve the problem of sensitivity?

http://rt2x00.serialmonkey.com/phpBB/viewtopic.php?t=3434 example of a subject in the report, most of the problems of detection should come from this register.

Sincerely yours

Hardware : Network controller: RaLink RT2500 802.11g Cardbus/mini-PCI (rev 01)

 Link Signal level=-77 dBm (with gutsy kernel, and iwconfig )

 Signal level=-81 dBm (with gutsy kernel and iwlist wlan0 scan)

[use google for translate this, sorry :-) ]

Stuart Bishop (stub) wrote :

This bug has been closed for a while, so people still having troubles probably need to open new bugs to get them looked at as they are probably different issues.

Displaying first 40 and last 40 comments. View all 271 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.