10.04 -> 10.10 upgrade fails: pkgProblemResolver::Resolve generated breaks: xserver-xorg-video-v4l demoted to universe

Bug #614993 reported by Rebug on 2010-08-08
442
This bug affects 79 people
Affects Status Importance Assigned to Milestone
Software Updater
New
Undecided
Unassigned
apt (Ubuntu)
Medium
Unassigned
libdrm (Ubuntu)
High
Unassigned
xorg-server (Ubuntu)
High
Michael Vogt

Bug Description

This machine; Dell inspiron 560 MT Intel Pentium Dual Core E5400
Memory;4GB DDR3
Graphics:512MB Nvidia GeForce G310 Driver update to nvidia-current-256.44
Dell screen: ST2010 1600x900

Attachment included: /var/log/dist-upgrade/

Key (error): Could not calculate the upgrade
An unresolvable problem occurred while calculating the upgrade:
E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
 This can be caused by:
 * Upgrading to a pre-release version of Ubuntu
 * Running the current pre-release version of Ubuntu
 * Unofficial software packages not provided by Ubuntu
If none of this applies, then please report this bug against the 'update-manager' package and include the files in /var/log/dist-upgrade/ in the bug report.

Thanks.

Rebug (j-de-cuba) wrote :
Rebug (j-de-cuba) wrote :
Rebug (j-de-cuba) wrote :
Philip Muškovac (yofel) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in update-manager.

When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

affects: ubuntu → update-manager (Ubuntu)
Jean-Baptiste Lallement (jibel) wrote :

Can you confirm that it is an upgrade from lucid to maverick ?
Did you install one of the graphic driver manually (and specifically xserver-xorg-video-nouveau) ?

Changed in update-manager (Ubuntu):
status: New → Incomplete
Rebug (j-de-cuba) wrote :

This is Lucid x86_64
It was indeed an attempt to upgrade from Lucid to Maverick.
No graphic driver manually installed (see attachment dpkg.log)

Rebug (j-de-cuba) wrote :
Jean-Baptiste Lallement (jibel) wrote :

There is currently a transition in maverick of the X.org packages breaking the ABI and preventing to upgrade the packages. You should try again in a few days when all the X.org stack have been published.

Changed in update-manager (Ubuntu):
status: Incomplete → Confirmed

The only thing I can add on this is that my upgrade was done in a virtualbox 3.2.6 environment using the release version of lucid 32bit to maverick 32bit, alpha 3 release. Everything else was stock, no added drivers, and no customizations.

David R. Hedges (p14nd4) wrote :

I received the same error attempting an i386 lucid->maverick upgrade via update-manager -d. The base files in /var/log/dist-upgrade/ are attached. I don't believe I've manually installed any video drivers on this system, but it has been through several release updates.

summary: - fails to "upgrade-manager -d" upgrade
+ 10.04 -> 10.10 upgrade fails: pkgProblemResolver::Resolve generated
+ breaks: Holding Back xserver-xorg-video-nouveau rather than change xorg-
+ video-abi-8.0
Changed in update-manager (Ubuntu):
importance: Undecided → Medium

Grabbing the maverick libdrm source, dropping the Breaks: xserver-xorg-video-nouveau (<< 1:0.0.16) from libdrm-nouveau1, versioning it higher than maverick's and rebuilding/installing it under lucid indeed fixes the problem here and allows the dist upgrade to go through. Can anyone think of another way to work around it? libdrm 2.4.21 indeed does break xserver-xorg-video-nouveau so I don't believe its incorrect to be there.

Robert Hooker (sarvatt) on 2010-08-26
Changed in libdrm (Ubuntu):
status: New → Confirmed
importance: Undecided → High

I'm raising importance of the update-manager task because something can very likely be done at the DistUpgradeQuirks level if everything is correct on the libdrm side.

Changed in update-manager (Ubuntu):
importance: Medium → High
Bryce Harrington (bryce) on 2010-08-27
tags: added: maverick
miked (miked11) wrote :

Bug #626147 - two computers with this bug.

I can reproduce it while upgrading from a fresh lucid to maverick.
1. Install a fresh 10.04.1 and all updates
2. edit /etc/apt/sources.list to disable the universe repository
3. run "update-manager -d" or "do-release-upgrade -m desktop -d"
4. Installation fails with "pkgProblemResolver::Resolve generated breaks" and the "libdrm-nouveau1 has broken Breaks on xserver-xorg-video-nouveau" error in apt.log

If I enable 'universe' I can proceed with the upgrade.

What is odd, is that I only have packages in 'main' or 'restricted' installed so enabling/disabling universe shouldn't break things.
The major difference with the reports here, is that they have universe enabled.

I'm setting to 'critical' because that may hit a large number the user and affecting to mvo.

Changed in update-manager (Ubuntu):
assignee: nobody → Michael Vogt (mvo)
importance: High → Critical
status: Confirmed → Triaged
Robert Hooker (sarvatt) wrote :

The procedure I mentioned earlier in comment #11 to get around it doesn't seem to be optimal. Removing the Breaks: completely from libdrm-nouveau1 left me with xserver-xorg-video-nouveau 1:0.0.15 installed after the lucid->maverick upgrade which held back all of the X upgrades and it required a manual sudo apt-get install xserver-xorg-video-nouveau/maverick to fix. I couldn't work out a method to test but changing the Breaks: to Conflicts: might fix it?

Jean-Baptiste: That's odd that you only hit it with universe disabled, because I hit the problem on a clean 10.04.1 install with universe enabled. These are essential packages though and I agree its a major problem.

Michael Vogt (mvo) wrote :

The problem is that the package "xserver-xorg-video-v4l" is demoted from main to universe. Apt will try to find a solution for the xserver problem by upgrading to the latest xserver abi (because of the breaks). But it can't find one because there is no newer version of xserver-xorg-video-v4l available.

The best fix I can think of currently is a explict:

Package: xserver-xorg-core
Conflicts: xserver-xorg-video-v4l (<< 1:0.2.0-4ubuntu1)

to ensure the upgrade works. I'm testing this now.

Michael Vogt (mvo) wrote :

Another way is to use

Package: xserver-xorg-core
Conflicts: xserver-xorg-video-6

(but that is a rather strong statement, though it will help the resolver to deal with the situation).

Michael Vogt (mvo) wrote :
affects: update-manager (Ubuntu) → xorg-server (Ubuntu)
Changed in xorg-server (Ubuntu):
status: Triaged → In Progress
Michael Vogt (mvo) on 2010-08-30
Changed in libdrm (Ubuntu):
status: Confirmed → Invalid
summary: 10.04 -> 10.10 upgrade fails: pkgProblemResolver::Resolve generated
- breaks: Holding Back xserver-xorg-video-nouveau rather than change xorg-
- video-abi-8.0
+ breaks: xserver-xorg-video-v4l demoted to universe
Michael Vogt (mvo) wrote :

Note that I changed the Conflicts to a Breaks as its cleaner tihs way and archives the same effect. I uploaded the diff to maverick now (its waiting in the upload queue).

Changed in xorg-server (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server - 2:1.9.0-0ubuntu2

---------------
xorg-server (2:1.9.0-0ubuntu2) maverick; urgency=low

  * debian/control:
    - add explict breaks from xserver-xorg-core against
      xserver-xorg-video-v4l (<< 1:0.2.0-4ubuntu1) to ensure that
      upgrades with universe disabled work (LP: #614993)
 -- Michael Vogt <email address hidden> Mon, 30 Aug 2010 15:40:07 +0200

Changed in xorg-server (Ubuntu):
status: Fix Committed → Fix Released
Rebug (j-de-cuba) wrote :

I have tried a moment ago (Ned. local time 20:35) same Dell machine to upgrade from 10.04 to 10.10 getting same error >> "Could not calculate the upgrade".
I will try dist-upgrade again on august 31 2010, thanks.

Rebug, could you please attach the file /var/lib/dpkg/status to this report ? Thanks.

David R. Hedges (p14nd4) wrote :

I also just tried the update to maverick again (after verifying that packages based on the xorg-server version above were listed in http://us.archive.ubuntu.com/ubuntu/dists/maverick/main/binary-i386/Packages.bz2 ), and got the same error. A diff of the dist-upgrade/apt.log and one from last week shows no change in any xorg-video or xorg-server lines. I've attached my /var/lib/dpkg/status file. As mentioned above, this system has run through multiple [pre-]release updates over the past couple years.

Steve Beattie (sbeattie) wrote :

I can also confirm that after ensuring the xorg-server 2:1.9.0-0ubuntu2 packages made it into my local mirror that upgrades from lucid to maverick still fail here. Attached is my /var/lib/dpkg/status with the /var/log/dist-upgrade/apt.log to follow.

Steve Beattie (sbeattie) wrote :

Oh, and yes, universe is most definitely enabled here.

Changed in xorg-server (Ubuntu):
status: Fix Released → In Progress

I've been able to reproduce the problem on a fresh lucid with xserver-xorg-video-radeonhd which has been removed from maverick and is blocking the upgrade.

Those who are hit by this bug, could you please try to remove that driver and try performing the upgrade again.

But, following recent discussion with bdmurray on IRC, removing that driver from his system doesn't fix the problem for him, so there is another one.

On Mon, Aug 30, 2010 at 10:09:24PM -0000, Jean-Baptiste Lallement wrote:
> I've been able to reproduce the problem on a fresh lucid with xserver-
> xorg-video-radeonhd which has been removed from maverick and is blocking
> the upgrade.
>
> Those who are hit by this bug, could you please try to remove that
> driver and try performing the upgrade again.
>
> But, following recent discussion with bdmurray on IRC, removing that
> driver from his system doesn't fix the problem for him, so there is
> another one.

As I reported to you on IRC, removing xserver-xorg-video-radeonhd did
allow the upgrade to be calculated for me. Thanks.

--
Steve Beattie
<email address hidden>
http://NxNW.org/~steve/

tags: added: patch
David R. Hedges (p14nd4) wrote :

I just ran sudo aptitude purge xserver-xorg-video-radeonhd , then tried running the maverick update again. The end result was the same, but the apt.log is a little different this time around (mostly seems to be differences in scores for proposed resolutions, but I didn't scrutinize it carefully). I've attached the files from /var/log/dist-upgrade/ and a diff of apt.log from the previous attempt.

Michael Vogt (mvo) wrote :

Hello David, thanks for your feedback. Can you please remove xserver-xorg-video-dummy and see if the upgrade wroks then?

The following drivers are breaking the ABI during upgrade:
Provides: xserver-xorg-video-7
xserver-xorg-video-dummy - X.Org X server -- dummy display driver
xserver-xorg-video-glide - X.Org X server -- Glide display driver
Provides: xserver-xorg-video-6
xserver-xorg-video-glamo - X.Org X server -- SMedia Glamo display driver

Michael Vogt (mvo) wrote :

Thanks Jean-Baptiste! I uploaded a new xserver-xorg-core package that adds those additional breaks (plus some I merged from debian).

Rebug (j-de-cuba) wrote :

Attached: file /var/lib/dpkg/status (08-30-2010)

Michael Vogt (mvo) wrote :

Lowering the priority as it no longer breaks all upgrades.

Changed in apt (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Changed in xorg-server (Ubuntu):
milestone: none → ubuntu-10.10-beta
importance: Critical → High
Michael Vogt (mvo) wrote :

A proposed apt fix is in lp:~mvo/apt/conflicts-on-virtuals

Michael Vogt (mvo) wrote :

New xserver-xorg-core uploaded (waiting in the moderation queue).

Changed in apt (Ubuntu):
status: Confirmed → In Progress
Changed in xorg-server (Ubuntu):
status: In Progress → Fix Committed
David R. Hedges (p14nd4) wrote :

I was hoping the new xserver-xorg-core package would show up in the maverick repository more quickly, so I could test if that alone resolved my problem, but I got impatient. I ran aptitude purge xserver-xorg-video-dummy , then update-manager -d, and the upgrade was able to proceed. (No word yet on if the remainder of the upgrade works, but it appears that removing xserver-xorg-video-dummy (and earlier xserver-xorg-video-radeonhd ) resolved this particular bug for me.) I hope that information helps.

Thanks for troubleshooting this and finding a resolution, Michael and Jean-Baptiste.

I just updated my lucid and re-ran sudo update-manager -d to no avail - bug still happens, apt.log complaining about the nouveau drivers... Still time to get this in for the beta deadline?

miked (miked11) wrote :

root@LeftGuest:~# sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
root@LeftGuest:~# do-release-upgrade -m desktop -d
Checking for a new ubuntu release
Done Upgrade tool signature
Done Upgrade tools
Done downloading
extracting 'maverick.tar.gz'
authenticate 'maverick.tar.gz' against 'maverick.tar.gz.gpg'
tar: Removing leading `/' from member names

Reading cache

Checking package manager
Reading package lists... Done
Building dependency tree
Reading state information... Done
Building data structures... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
Building data structures... Done

Updating repository information
WARNING: Failed to read mirror file
100% [Working] 0s 39s
Checking package manager
Reading package lists... Done
Building dependency tree
Reading state information... Done
Building data structures... Done

Calculating the changes

Calculating the changes

Could not calculate the upgrade

An unresolvable problem occurred while calculating the upgrade:
E:Error, pkgProblemResolver::Resolve generated breaks, this may be
caused by held packages.

This can be caused by:
* Upgrading to a pre-release version of Ubuntu
* Running the current pre-release version of Ubuntu
* Unofficial software packages not provided by Ubuntu

If none of this applies, then please report this bug against the
'update-manager' package and include the files in
/var/log/dist-upgrade/ in the bug report.

Restoring original system state

Aborting
Reading package lists... Done
Building dependency tree
Reading state information... Done
Building data structures... Done
root@LeftGuest:~#

miked (miked11) wrote :
miked (miked11) wrote :
Changed in xorg-server (Ubuntu):
status: Fix Committed → Fix Released
tags: added: iso-testing
Colin Watson (cjwatson) on 2010-09-16
Changed in apt (Ubuntu):
status: In Progress → Fix Released
Changed in xorg-server (Ubuntu):
status: Fix Released → In Progress
status: In Progress → New
Changed in xorg-server (Ubuntu):
milestone: ubuntu-10.10-beta → none
status: New → Fix Released
jonny (astro64m) on 2010-10-31
description: updated
39 comments hidden view all 119 comments
John Johnson (the-art-of-spam) wrote :

As of Feb 2011, this problem still persists.

Upgrading from 10.4 to 10.10 breaks with this error: "An unresolvable problem occurred while calculating the upgrade: E:Error, pkgProblemResolver::Resolve generated breaks..."

As suggested above, it was fixed by removing: the xserver-xorg-video-nouveau package.

Logfiles contain these entries, see attachment:
Package libdrm-nouveau1 has broken Breaks on xserver-xorg-video-nouveau
Package xserver-xorg-video-nouveau has broken Depends on xorg-video-abi-8.0

lspci output for video card:
01:00.0 VGA compatible controller: nVidia Corporation G86 [GeForce 8400 GS] (rev a1)

broe (erich-rupp) wrote :

i can also confirm this is not fixed. i get the same messages about xserver-xorg-video-nouveau.

Maddmaxx (maddmaxx666) wrote :

Confirmed: "sudo apt-get purge xserver-xorg-video-nouveau", then "sudo update-manager -c -d" will fix you up!
Completing upgrade as we speak, now to recompile my wireless driver and (fingers crossed) all is well!

I will add another confirmation about "xserver-xorg-video-nouveau" preventing an upgrade to 10.10. Removing it lets the upgrade proceed as expected.

Dean Hoover (kb7qdi) wrote :

I used the commands from Maddmaxx, and the upgrade worked as expected.

Dr.Death (dr.death) wrote :

# sudo apt-get remove xserver-xorg-video-nouveau
# update-manager -d

did the trick for me :)

ID (blood-of-amdusias) wrote :

Except that I cannot boot Ubuntu, and OS that tries to read its
partition hangs immediately.

On 2/15/11, Dr.Death <email address hidden> wrote:
> # sudo apt-get remove xserver-xorg-video-nouveau
> # update-manager -d
>
> did the trick for me :)
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (716219).
> https://bugs.launchpad.net/bugs/614993
>
> Title:
> 10.04 -> 10.10 upgrade fails: pkgProblemResolver::Resolve generated
> breaks: xserver-xorg-video-v4l demoted to universe
>
> Status in “apt” package in Ubuntu:
> Fix Released
> Status in “libdrm” package in Ubuntu:
> Invalid
> Status in “xorg-server” package in Ubuntu:
> Fix Released
>
> Bug description:
> This machine; Dell inspiron 560 MT Intel Pentium Dual Core E5400
> Memory;4GB DDR3
> Graphics:512MB Nvidia GeForce G310 Driver update to nvidia-current-256.44
> Dell screen: ST2010 1600x900
>
> Attachment included: /var/log/dist-upgrade/
>
> Key (error): Could not calculate the upgrade
> An unresolvable problem occurred while calculating the upgrade:
> E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused
> by held packages.
>  This can be caused by:
>  * Upgrading to a pre-release version of Ubuntu
>  * Running the current pre-release version of Ubuntu
>  * Unofficial software packages not provided by Ubuntu
> If none of this applies, then please report this bug against the
> 'update-manager' package and include the files in /var/log/dist-upgrade/ in
> the bug report.
>
> Thanks.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/apt/+bug/614993/+subscribe
>

John Haynes (jbhaynesjr) wrote :

Had this problem (reported as #718321). As suggested here, removed xserver-xorg-video-nouveau. Upgrade ran without problems. Added ...-nouveau back after upgrade and system works fine.
Thanks for help.

Mark Dwyer (mdwy62) wrote :

Thank you for tying this to another bug --- with a solution! Will give
it a go.

-Mark

On Tue, 2011-02-15 at 18:13 +0000, John Haynes wrote:

> Had this problem (reported as #718321). As suggested here, removed xserver-xorg-video-nouveau. Upgrade ran without problems. Added ...-nouveau back after upgrade and system works fine.
> Thanks for help.
>

Dennis (dennis-gurnick) wrote :

Purging xserver-xorg-video-nouveau worked here as well. FWIW: The box hasn't been touched for some months. Probably should have tried this sooner.

Thanks guys,

D

John Landon (elicit35140) wrote :

Same here ...

Thx for the info ...

BTW, I used the Synaptic Package Manager to remove xserver-xorg-video-nouveau and it also removed xserver-xorg-video-all.

Running just fine so far w/o them ... will only reinstall if something claims to need them.

Thanks for your help.

John

ifone (hellocyf) wrote :

thinkpad r40e could not upgrade 10.04->10.10

ifone (hellocyf) wrote :

this error log.

 This can be caused by:
 * Upgrading to a pre-release version of Ubuntu
 * Running the current pre-release version of Ubuntu
 * Unofficial software packages not provided by Ubuntu

Luís de Sousa (luis-de-sousa) wrote :

Hello everyone,

Just to report that I bumped into this same bug upgrading from 10.04 to 10.10 with a VAIO VGN-FW31ZJ.

After purging the xserver-xorg-video-nouveau package I was able to start the upgrade (downloading new packages right now). Will see how the machine behaves when its finished.

Best,

Luís

Luís de Sousa (luis-de-sousa) wrote :

Hello again,

Just to report that the system seems perfectly functional after the upgrade to version 10.10. The purge of the xserver-xorg-video-nouveau package has proved innocuous so far.

Best,

Luís

Mark Dwyer (mdwy62) wrote :

I purged the nouveau package as suggested above and the upgrade went fine. Subsequently (the next day or so), the update manager complained that a bunch of video related packages would be held back and not upgraded. This was fixed by reinstalling nouveau after the 10.10 upgrade.

Manfred Hampl (m-hampl) wrote :

I propose to re-add 'affects update-manager'. There are still several people trying to upgrade from 10.04 to 10.10 and failing because of this bug. The error message they see instructs them to file a bug against update-manager. "...please report this bug against the 'update-manager' package..."

Currently this bug cannot be found when searching for 'update-manager' related bugs!

bug 721306 is the master report to track the issue with the upgrade of xorg-xserver-video-nouveau.

Gabriel_P (gabp) wrote :

I'm having this same issue, except uninstalling xserver-xorg-video-nouveau didn't help...
I attach the /var/log/dist-upgrade/ logs

Any ideas?

On 01/03/2011 15:12, Gaba_p wrote:
> I'm having this same issue, except uninstalling xserver-xorg-video-nouveau didn't help...
> I attach the /var/log/dist-upgrade/ logs
>
> Any ideas?
>
> ** Attachment added: "log files"
> https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/614993/+attachment/1878614/+files/20110301-0839.tar.gz
>
Gaba, I managed to upgrade after uninstalling the same
(xserver-xorg-video-nouveau). Upgrade was thru download. The problem now
is that 10.10 is very slow. Have been trying to uninstall it but have
failed so far.

Farewell

Bruno Medeiros (brunojcm) wrote :

Gaba_p, try removing 'plasma-netbook'.

Gabriel_P (gabp) wrote :

Hi Bruno,

'plasma-netbook' is not installed in my system Only 'libplasmagenericshell4' is installed (whatever that is)

I have several external repositories instilled (ie: burg, docky, qbittorrent, google, dropbox, medibuntu, jdownloader, etc..), maybe those have something to do with this issue?

Gabriel_P (gabp) wrote :

Well, yesterday the system installed a bunch of updates and now the upgrade is working (downloading packages right now :) Don't really know what was wrong but it's fixed now.

Cheers!

Walter Motaung (wmotaung) wrote :

On 03/03/2011 16:01, Gaba_p wrote:
> Well, yesterday the system installed a bunch of updates and now the
> upgrade is working (downloading packages right now :) Don't really know
> what was wrong but it's fixed now.
>
> Cheers!
>
Good for you, Gaba. Glad that things are working for you. I am still
struggling to improve my laptop performance since upgrade from 10.04 to
10.10. The thing is dead slow. Farewell

Peshko R. (peshko-us) wrote :

I completely agree with hackel comment #68.

This is pathetic! We are less than 1 month away from the offcial release of Natty Narwhal (11.04) and we still have a critical bug, reported several months ago, NOT fixed, preventing MANY people to upgrade from 10.04 --> 10.10. I too had to go trough many comments to find to how to work around it.

This is ridicoulous! A paragraph in the release notes would made my life (and I am sure many others) much easier.

JanCeuleers (jan-ceuleers) wrote :

I added also-affects update-manager because this problem has clearly not yet been fully resolved, despite the fix-released state on a number of affected packages.

Neil McLeish (nmcleish) wrote :

Still no luck with this.

I have removed the nouveau and so on and ran update-manager -d - as various people have suggested.

I am beginning to think that the only way to upgrade is to do a vanilla reinstallation.

This will be particularly inconvenient, being as I have VBox with Win7 installed, and that means I will probably have to call Microsoft to get the licence working again as each Windows doesn't like having its virtual container updated.

All in all, it is going to be a real big time-consuming hassle, if I have to do a vanilla installation, so some clear instruction would be very gratefully received.

Many thanks,

Neil

Manfred Hampl (m-hampl) wrote :

@Neil, main.log and apt.log from /var/log/dist-upgrade/ should contain hints pointing to the package(s) that make(s) trouble. Please attach them.

v3g4 (3d1gg4) wrote :

I have the same issue
here's my apt.log

v3g4 (3d1gg4) wrote :

difference is I4m trying to upgrade from 10.10 to 11.04 beta
latest try logs attached?field.comment=difference is I4m trying to upgrade from 10.10 to 11.04 beta
latest try logs attached

v3g4 (3d1gg4) wrote :
Manfred Hampl (m-hampl) wrote :

@v3g4:
You better create a new bug for the failure with the 10.10 to 11.04 upgrade.
This bug is (as the tilte clearly says) about 10.04 -> 10.10 upgrades failing.

radsaq (radsaq) wrote :

I seem to be having the same upgrading from 10.04 to 11.04. Yes, I'm aware the title says 10.04 to 10.10; I don't think this bug is fixed.

radsaq (radsaq) wrote :

My bad, I didn't notice that it was actually trying to upgrade me to maverick and not natty. However, my point that this particular issue still isn't fixed is still true. :)

Manfred Hampl (m-hampl) wrote :

@radsaq:
Have you already tried the documented workaround to remove the package xserver-xorg-video-nouveau (will also remove xserver-xorg-video-all)?

radsaq (radsaq) wrote :

That log was from after I had removed the package. However, after messing around with my sources.list a bit (I was trying to do an update from a local mirror), the problem somehow sorted itself out.

Walter Motaung (wmotaung) wrote :

On 03/05/2011 18:07, radsaq wrote:
> That log was from after I had removed the package. However, after
> messing around with my sources.list a bit (I was trying to do an update
> from a local mirror), the problem somehow sorted itself out.
>
Hi

No more there. Upgraded to 11.04. It is great!

Hb (hbb) wrote :

As posted in comment 82 after "sudo apt-get purge xserver-xorg-video-nouveau" the upgrade was possible.

ysingh (ys-rajput) wrote :

I am able to update orupgrade, but get error-

An unresolvable problem occurred while calculating the upgrade.

Please report this bug against the 'update-manager' package and include the following error message:
'E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.'

Jim (jim-jimcortez) wrote :

I had lots of package held errors in /var/log/dist-upgrade/apt.log surrounding kdevelop. Am upgrading from 10.04->10.10->11.04->11.10. After I did "sudo apt-get purge kdevelop", I am able to continue.

Displaying first 40 and last 40 comments. View all 119 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions