Ubuntu

Alps touchpad is recognized but synaptics clients and scrolling do not work

Reported by Mary on 2010-03-29
This bug affects 451 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
Touchpad-indicator
Undecided
Unassigned
Baltix
Undecided
Unassigned
linux (Fedora)
New
Undecided
Unassigned
linux (Ubuntu)
Medium
Andy Whitcroft
Lucid
Medium
Unassigned
Maverick
Medium
Unassigned
xserver-xorg-input-synaptics (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned
Maverick
Undecided
Unassigned

Bug Description

SRU Justification:

Impact: The end result of the commit is loss of scroll support, with no
extra functionality gained.

How addressed: By reverting the commit, the previously enabled scroll
support is reestablished through the ImPS/2 extension.

Reproduction: Run current Ubuntu kernel on affected hardware. Scroll
functionality present in previous Ubuntu releases is now missing.

Regression Potential: Since this is a revert of a one-line device id,
the regression potential is minimal. The device should fall back to
ImPS/2 protocol without issue.

=====

Binary package hint: xserver-xorg-input-synaptics

I have Ubuntu 9.10 and an Alps touchpad (E7: 73 02 64). Chase fixed the kernel so that it was recognized and, indeed, the touchpad shows up in both gsynaptics and system>preferences>mouse, but when I actually try to adjust the settings nothing changes. My goal is to disable the tap-to-click feature or disable the touchpad when typing. Chase suggests it may be something related to the driver and to open another bug.

ProblemType: Bug
Architecture: i386
Date: Sun Mar 28 22:02:25 2010
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
MachineType: Hewlett-Packard HP Pavilion dm3 Notebook PC
Package: xserver-xorg-input-synaptics 1.1.2-1ubuntu7
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-21-generic root=UUID=f1e2e19e-a0f8-407d-9533-c5ba95a8be50 ro quiet splash
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-21.58~alps4-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu10
 libgl1-mesa-glx 7.6.0-1ubuntu4
 libdrm2 2.4.14-1ubuntu1
 xserver-xorg-video-intel 2:2.9.0-1ubuntu2.1
 xserver-xorg-video-ati 1:6.12.99+git20090929.7968e1fb-0ubuntu1
SourcePackage: xserver-xorg-input-synaptics
Uname: Linux 2.6.31-21-generic i686
XorgConf:
 Section "InputDevice"
  Identifier "Macintosh mouse button emulation"
  Driver "synaptics"
  Option "SHMConfig" "true"
 EndSection
dmi.bios.date: 12/04/2009
dmi.bios.vendor: Insyde Corp.
dmi.bios.version: F.22
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 3656
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 44.1D
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnInsydeCorp.:bvrF.22:bd12/04/2009:svnHewlett-Packard:pnHPPaviliondm3NotebookPC:pvr0486110000241F00110320000:rvnHewlett-Packard:rn3656:rvr44.1D:cvnHewlett-Packard:ct10:cvrN/A:
dmi.product.name: HP Pavilion dm3 Notebook PC
dmi.product.version: 0486110000241F00110320000
dmi.sys.vendor: Hewlett-Packard
fglrx: Not loaded
system:
 distro: Ubuntu
 architecture: i686kernel: 2.6.31-21-generic

Mary (mtaussig44) wrote :
Mary (mtaussig44) wrote :

Also, I lost my ability to scroll with the edge of the touchpad when the kernel was fixed.

Bryce Harrington (bryce) on 2010-03-30
tags: added: karmic
Topher (hunt-topher) wrote :

Mostly same here on my HP Mini 311. However my device isn't even recognized as a touchpad; it's recognized as a generic mouse, thus there's no "Touchpad" tab in mouse preferences. When I try to activate syndaemon it says that there's no synaptics device found, so there's no way to disable tapping while typing... highly annoying.

Will attach my relevant files since my circumstance seems slightly different from above.

Topher (hunt-topher) wrote :

Confirming that this problem also exists in Ubuntu 10.04 Karmic beta 1 (ie, touchpad is recognized as a generic mouse device) on HP Mini 311.

Download full text (3.4 KiB)

Topher, take a look at Bug 545307. There you will see that Chase recently
developed a patch for the Kernel for recognizing Alps touchpad type listed.
It worked for me. For me, now the tabs show up for me, but the settings
don't adjust. I am not sure if my problem with that is unique to me
(because we were messing around trying to fix it earlier) or whether every
one will have it. But if you have the same type of touchpad and can find the
patch and install it, it is worth a try

On Tue, Mar 30, 2010 at 8:01 PM, Topher <email address hidden> wrote:

> Confirming that this problem also exists in Ubuntu 10.04 Karmic beta 1
> (ie, touchpad is recognized as a generic mouse device) on HP Mini 311.
>
> --
> Alps touchpad is recognized but neither gsynaptics nor mouse preferences
> work
> https://bugs.launchpad.net/bugs/550625
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “xserver-xorg-input-synaptics” package in Ubuntu: New
>
> Bug description:
> Binary package hint: xserver-xorg-input-synaptics
>
> I have Ubuntu 9.10 and an Alps touchpad (E7: 73 02 64). Chase fixed the
> kernel so that it was recognized and, indeed, the touchpad shows up in both
> gsynaptics and system>preferences>mouse, but when I actually try to adjust
> the settings nothing changes. My goal is to disable the tap-to-click feature
> or disable the touchpad when typing. Chase suggests it may be something
> related to the driver and to open another bug.
>
> ProblemType: Bug
> Architecture: i386
> Date: Sun Mar 28 22:02:25 2010
> DistroRelease: Ubuntu 9.10
> InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
> MachineType: Hewlett-Packard HP Pavilion dm3 Notebook PC
> Package: xserver-xorg-input-synaptics 1.1.2-1ubuntu7
> ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-21-generic
> root=UUID=f1e2e19e-a0f8-407d-9533-c5ba95a8be50 ro quiet splash
> ProcEnviron:
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.31-21.58~alps4-generic
> RelatedPackageVersions:
> xserver-xorg 1:7.4+3ubuntu10
> libgl1-mesa-glx 7.6.0-1ubuntu4
> libdrm2 2.4.14-1ubuntu1
> xserver-xorg-video-intel 2:2.9.0-1ubuntu2.1
> xserver-xorg-video-ati 1:6.12.99+git20090929.7968e1fb-0ubuntu1
> SourcePackage: xserver-xorg-input-synaptics
> Uname: Linux 2.6.31-21-generic i686
> XorgConf:
> Section "InputDevice"
> Identifier "Macintosh mouse button emulation"
> Driver "synaptics"
> Option "SHMConfig" "true"
> EndSection
> dmi.bios.date: 12/04/2009
> dmi.bios.vendor: Insyde Corp.
> dmi.bios.version: F.22
> dmi.board.asset.tag: Base Board Asset Tag
> dmi.board.name: 3656
> dmi.board.vendor: Hewlett-Packard
> dmi.board.version: 44.1D
> dmi.chassis.type: 10
> dmi.chassis.vendor: Hewlett-Packard
> dmi.chassis.version: N/A
> dmi.modalias:
> dmi:bvnInsydeCorp.:bvrF.22:bd12/04/2009:svnHewlett-Packard:pnHPPaviliondm3NotebookPC:pvr0486110000241F00110320000:rvnHewlett-Packard:rn3656:rvr44.1D:cvnHewlett-Packard:ct10:cvrN/A:
> dmi.product.name: HP Pavilion dm3 Notebook PC
> dmi.product.version: 0486110000241F00110320000
> dmi.sys.vendor: Hewlett-Packard
> fglrx: Not loaded
> system:
> distro: Ubunt...

Read more...

Thanks for the tip Mary. I installed the patch. No luck! No touchpad tab in mouse prefs, no synaptics driver installed. Perhaps our hardware is a little different. Either way, I hope this bug isn't going to be as thorny as it looks... I'm resorting to a piece of cardboard taped over the touchpad just to type now.

J. McDonald (mcdonald-joseph) wrote :

I also have this problem with the ALPS GlidePoint trackpad on my HP Mini 311 on Lucid Beta 2. The buttons and tap to click work but edge scrolling quite working, changes to "Mouse Preferences" have no impact and 2-finger scroll is grayed-out of mouse preferences. This was working until a daily build approximately 2-3 days ago.

Alberto Milone (albertomilone) wrote :

@J. McDonald
2-finger scroll is grayed-out because (somehow) the kernel detected that you trackpad doesn't support multitouch (i.e. the last two values of the Synaptics capabilities property should be 0). If it used to work, then it's definitely a kernel issue.

@Topher
I think you're still experiencing a kernel issue and your touchpad is being detected as a mouse. The output of dmesg and your /var/log/Xorg.0.log should help me confirm my theory.

Alberto Milone (albertomilone) wrote :

I'm subscribing Chase as he might have an idea about what's happening to J. McDonald's touchpad in the kernel.

Alberto Milone (albertomilone) wrote :

@Mary
What's the output of the following command?
xinput list-props "AlpsPS/2 ALPS GlidePoint"

J. McDonald (mcdonald-joseph) wrote :

I did try booting into the older kernel (2.6.32-20). Edge scrolling suddenly reappeared but the trackpad tab disappeared from mouse preferences. My Xorg.0 log is attached. I will also attach dmesg in a few minutes

J. McDonald (mcdonald-joseph) wrote :

Here is the dmesg

J. McDonald (mcdonald-joseph) wrote :

Just to reiterate, with current kernel versions in Lucid beta 2 over the last couple of days, edge scrolling is disabled, it is selectable from "Mouse Preferences" but selecting or deselecting any option in "Mouse Preferences" has no impact on the trackpads function. I don't use 2-finger scrolling, but I did notice it was grayed-out and I though I should include that description for completeness. Edge scrolling returns when reverting to an older kernel version at time of boot using grub, but if I do this the tab for the trackpad disappears and while it seems to function fine, it no longer appears to be recognized by either "Mouse Preferences" or by "GPointing Device Settings". Using the latest kernel versions (2.6.33-20, -21) the trackpad is definitely showing up as an ALPS GlidePoint within GPointing Device, but as with Mouse Settings none of the selectable options appear to change anything with respect to trackpad function. Thanks again for your assistance with this issue.

tob (tobynbertram) wrote :

I have a Sony Vaio VPCF11 which also uses the AlpsPS/2 ALPS GlidePoint (E7: 73 02 64) running Kubuntu 10.04 beta 2. My problems with the touchpad are identical to Mary's. xinput list-props shows a large list of touchpad properties. Furthermore, changes that are made in the KDE touchpad GUI are reflected in the output of xinput list-props. xinput test "AlpsPS/2 ALPS GlidePoint" shows no response from the touchpad while xinput test "PS/2 Mouse" outputs the relative movements and button press events of the touchpad.

There is a duplicate bug here:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/527890

More info here:
http://ubuntuforums.org/showthread.php?t=1316361&page=2

J. McDonald (mcdonald-joseph) wrote :

I can confirm that xinput test "PS/2 Mouse" outputs relative movements in kernel 2.6.32-21 and -20 while xinput test "AlpsPS/2 ALPS GlidePoint" shows no response. In kernel 2.6.31-21, xinput test "ImPS/2 Generic Wheel Mouse" outputs relative movements for the ALPS GlidePoint in the HP Mini 311.

J. McDonald (mcdonald-joseph) wrote :

I checked output from lsmod. It does not show synaptics as loaded.

Mary (mtaussig44) wrote :

Alberto - sorry I didn't see your request earlier! Here it is.

J. McDonald (mcdonald-joseph) wrote :

Mary - your xinput list props looks similar to mine, but in my case xinput test confirms that it's actually "PS/2 Mouse" that is being used instead of "AlpsPS/2 ALPS GlidePoint". Are you able to get any output from xinput test "AlpsPS/2 ALPS GlidePoint" when you use the trackpad?

alabamas (a-huqi) wrote :

I think that is something related to driver,

Maybe Absolute mode is not working the way it should.
The Scrolling on Alps is managed by the absolute mode.
So if someone is able to debug the absolute mode please help!!!!

Thanks.

J. McDonald (mcdonald-joseph) wrote :

Could this be a bug in evdev?

Chase Douglas (chasedouglas) wrote :

I'd prefer to leave this bug unduplicated, since I've been following this bug and will be working on it shortly.

Thanks

J. McDonald (mcdonald-joseph) wrote :

That sounds good. I probably should not have marked the duplication without fully understanding the implications. Thanks for working on this bug.

Chase Douglas (chasedouglas) wrote :

J, McDonald:

Just so you know, marking bugs as duplicates is generally a good thing and helps keep bugs manageable. Definitely keep doing what you're doing. It's just that in this case, I have a history with this bug, so I want to work through things here. If this is marked as a duplicate, it gets removed from all the bug lists. It's just a matter of preference and ease for me as I try to work it.

Thanks

Download full text (3.4 KiB)

No, I don't get any output. (I think I did what you suggested - put xinput
test "AlpsPS/2 ALPS GlidePoint" as a command in the terminal and nothing
came up, although when I tried to close the terminal a message came up
saying a process was running and I would kill it when I closed the
terminal. I waited a long time, but nothing happened, so I closed it.)

On Sat, Apr 17, 2010 at 10:47 AM, J. McDonald <
<email address hidden>> wrote:

> Mary - your xinput list props looks similar to mine, but in my case
> xinput test confirms that it's actually "PS/2 Mouse" that is being used
> instead of "AlpsPS/2 ALPS GlidePoint". Are you able to get any output
> from xinput test "AlpsPS/2 ALPS GlidePoint" when you use the trackpad?
>
> --
> Alps touchpad is recognized but neither gsynaptics nor mouse preferences
> work
> https://bugs.launchpad.net/bugs/550625
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “xserver-xorg-input-synaptics” package in Ubuntu: New
>
> Bug description:
> Binary package hint: xserver-xorg-input-synaptics
>
> I have Ubuntu 9.10 and an Alps touchpad (E7: 73 02 64). Chase fixed the
> kernel so that it was recognized and, indeed, the touchpad shows up in both
> gsynaptics and system>preferences>mouse, but when I actually try to adjust
> the settings nothing changes. My goal is to disable the tap-to-click feature
> or disable the touchpad when typing. Chase suggests it may be something
> related to the driver and to open another bug.
>
> ProblemType: Bug
> Architecture: i386
> Date: Sun Mar 28 22:02:25 2010
> DistroRelease: Ubuntu 9.10
> InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
> MachineType: Hewlett-Packard HP Pavilion dm3 Notebook PC
> Package: xserver-xorg-input-synaptics 1.1.2-1ubuntu7
> ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-21-generic
> root=UUID=f1e2e19e-a0f8-407d-9533-c5ba95a8be50 ro quiet splash
> ProcEnviron:
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.31-21.58~alps4-generic
> RelatedPackageVersions:
> xserver-xorg 1:7.4+3ubuntu10
> libgl1-mesa-glx 7.6.0-1ubuntu4
> libdrm2 2.4.14-1ubuntu1
> xserver-xorg-video-intel 2:2.9.0-1ubuntu2.1
> xserver-xorg-video-ati 1:6.12.99+git20090929.7968e1fb-0ubuntu1
> SourcePackage: xserver-xorg-input-synaptics
> Uname: Linux 2.6.31-21-generic i686
> XorgConf:
> Section "InputDevice"
> Identifier "Macintosh mouse button emulation"
> Driver "synaptics"
> Option "SHMConfig" "true"
> EndSection
> dmi.bios.date: 12/04/2009
> dmi.bios.vendor: Insyde Corp.
> dmi.bios.version: F.22
> dmi.board.asset.tag: Base Board Asset Tag
> dmi.board.name: 3656
> dmi.board.vendor: Hewlett-Packard
> dmi.board.version: 44.1D
> dmi.chassis.type: 10
> dmi.chassis.vendor: Hewlett-Packard
> dmi.chassis.version: N/A
> dmi.modalias:
> dmi:bvnInsydeCorp.:bvrF.22:bd12/04/2009:svnHewlett-Packard:pnHPPaviliondm3NotebookPC:pvr0486110000241F00110320000:rvnHewlett-Packard:rn3656:rvr44.1D:cvnHewlett-Packard:ct10:cvrN/A:
> dmi.product.name: HP Pavilion dm3 Notebook PC
> dmi.product.version: 0486110000241F00110320000
> dmi.sys.vendor: Hewlett-Packard
> fglrx: Not loaded
> s...

Read more...

All the properties look correct to me. The right edge is defined as anything to the right of value 870. I suggest we try to find out what X values are being reported when we attempt to scroll on the right edge of the touchpad. Someone please test the following:

You will want to print out or write down these instructions as we will be changing to a VT for part of it. You can switch back and forth using chvt if you want, but if you are unfamiliar it will be easiest to run through these steps verbatim. If you get stuck in a text terminal and don't know how to get out, run "sudo chvt 7".

$ sudo apt-get install input-utils evtest
$ sudo chvt 1

log in as your normal user

$ sudo lsinput

Find your mouse, should be something like "AlpsPS/2 ALPS GlidePoint". Now copy the "/dev/input/event#" line for the mouse.

$ sudo evtest [/dev/input/event# from previous step] | tee evtest.dump

Now run your finger across the trackpad in three motions:

1. Left to right across the middle of the touchpad
2. Top to bottom across the middle of the touchpad
3. Top to bottom across the right edge as though you are trying to scroll

You will see a ton of output flow across the screen. You may ignore the output, it's just there so you're sure it's working. The output is being saved to evtest.dump. When done:

$ sudo chvt 7

Finally, upload the evtest.dump file here. With this data we should be able to figure out if the edges reported to the synaptics X driver is correct.

Thanks

tuxinvader (tuxinvader) wrote :

done this.... My alps has no output (event8), but I also have a ps2 mouse on event7, all data appears on this input.

See attached: events.tgz

Chase Douglas (chasedouglas) wrote :

@tuxinvader:

Were you in the VT when you ran evtest? If you run evtest while in the desktop X session, you won't receive anything. That's why I have the chvt in the instructions.

I worry that the ps2 mouse events won't be comparable to the synaptics events.

Thanks

tuxinvader (tuxinvader) wrote :

I wasn't, I was logged on via ssh.

I have just tested it again on the console (/dev/tty1), and I get exactly the same output. Nothing on the ALPS device, everything on the PS2 mouse device.

J. McDonald (mcdonald-joseph) wrote :

I changed to VT and ran lsinput but the event number lines scrolled by so fast that I couldn't see which one corresponded to the ALPS Glidepoint. Is it OK to do lsinput from a terminal window in Gnome to get the event number and then switch to VT to run the test?

J. McDonald (mcdonald-joseph) wrote :

I just figured it out:

sudo lsinput | less

enter for each and then q when it reaches the end

I'm slowly learning...

J. McDonald (mcdonald-joseph) wrote :

In VT, I did:

$ sudo lsinput | less

and found "AlpsPS/2 ALPS GlidePoint" at

/dev/input/event7

so then I did:

$ sudo evtest /dev/input/event7 | tee evtest.dump

and wound up with a blinking cursor and no output at all corresponding to input from the trackpad. I had to do a forced shutdown to get out of it. I will check to see if evtest.dump was created and post output here if I find it.

Chase Douglas (chasedouglas) wrote :

@J. McDonald:

I'm sorry, sometimes I forget not everyone is a kernel hacker :). If you run a command at the command line and you need to stop it, hitting ctrl+c usually does the trick. That's what I would have used in this instance. I should have been more clear.

So this is confirmation that there is still an issue with the kernel driver. Even though the driver recognizes the device, it's not processing any packets. I will make a test kernel to determine what is going wrong.

Thanks

J. McDonald (mcdonald-joseph) wrote :

I only aspire to be a kernel hacker - but I'll get there someday! I can load up a test kernel and give it a try if that would help with the debugging. Thanks again.

J. McDonald (mcdonald-joseph) wrote :

I while in VT I confirmed what Tuxinvader found. This time around "AlpsPS/2 ALPS GlidePoint" was at /dev/input/event9 and "PS/2 Mouse" was at /dev/input/event8.

Like Tuxinvager, I was able to get the trackpad to output but only with

$ sudo evtest /dev/input/event8 | tee evtest2.dump

evtest2.dump is attached. As with the last go round, doing

$ sudo evtest /dev/input/event9 | tee evtest1.dump

gave no output from the trackpad. I quite with CRTL-C (thanks) and the resulting evtest1.dump file was empty. So the ALPS trackpad is using the PS/2 Mouse driver. Surprising that it works at all. Very strange. Are there any hints in the dmesg or Xorg.0.log?

J. McDonald (mcdonald-joseph) wrote :

There seems to have been an earlier problem where psmouse loading prior to synaptics would prevent synaptics from loading:

http://ubuntuforums.org/showthread.php?t=1035407

A temporary workaround was to blacklist psmouse and load the module after boot from rc.local

I checked the loaded modules and it does look like synaptics is not loading, so maybe this issue has been around for awhile.

Chase Douglas (chasedouglas) wrote :

@J. McDonald:

Good find! I would appreciate it if someone could test if blacklisting psmouse solves the issue. Be aware though, that if you blacklist psmouse and the alps driver still isn't working, then you may have difficulties in the desktop session :). If you find yourself in this situation, switch to a VT using 'ctrl+alt+1', log in, and use "sudo rm /etc/modprobe.d/touchpad" to delete the blacklist. Then run 'sudo restart gdm' to start the X desktop again.

The maintainer of the input subsystem of the kernel noted that this could also be due to a new ALPS protocol. If that's the case, we may have difficulties determining how to talk to these new mice.

Topher (hunt-topher) wrote :

Heh, I tried blacklisting psmouse in /etc/modprobe.d/touchpad, but it just disabled my touchpad altogether. :-) I checked Mouse preferences just in case Synaptics might have loaded improperly, but there was still no "Touchpad" tab. So I un-blacklisted again.

tuxinvader (tuxinvader) wrote :

Fixed it. There's a ubuntu specific patch which adds the following line to the alps kernel driver alps.c:

   { { 0x73, 0x02, 0x64 }, 0xf8, 0xf8, 0 }, /* HP Pavilion dm3 */

Commenting out this new device fixes the ALPs on the HP mini 311c ;-)

Topher (hunt-topher) wrote :

Awesome. Is there a standard way to test this fix on my machine? I'm not a kernel hacker either...

tuxinvader (tuxinvader) wrote :

You can try my module if you wish.... The only other way would be for you to compile your own kernel....

Download the psmouse.ko file attached, and then in a console (from the directory containing my module) run:

$ sudo rmmode psmouse
$ sudo insmod psmouse.ko

I should warn you about the dangers of installing kernel modules produced by people you don't know on the internet ;-)

You can trust me though :-p

description: updated
Changed in xserver-xorg-input-synaptics (Ubuntu):
status: New → Invalid
affects: xserver-xorg-input-synaptics (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
assignee: nobody → Chase Douglas (chasedouglas)
status: Invalid → In Progress
milestone: none → lucid-updates
tags: added: patch
Changed in linux (Ubuntu):
status: In Progress → Fix Committed
summary: - Alps touchpad is recognized but neither gsynaptics nor mouse preferences
+ Alps touchpad is recognized but synaptics clients and scrolling do not
work
Stefan Bader (smb) on 2010-06-10
Changed in linux (Ubuntu Lucid):
importance: Undecided → Medium
status: New → Fix Committed
Changed in linux (Ubuntu):
milestone: lucid-updates → none
Martin Pitt (pitti) on 2010-06-11
tags: added: verification-needed
Changed in linux (Ubuntu Lucid):
status: Fix Committed → Fix Released
tob (tobynbertram) on 2010-07-01
Changed in linux (Ubuntu):
status: Fix Committed → Confirmed
Jo-We (jonas-kleemann) on 2010-07-04
Changed in linux (Ubuntu Lucid):
status: Fix Released → Incomplete
Martin Pitt (pitti) on 2010-08-17
tags: added: verification-done
removed: verification-needed
Changed in linux (Ubuntu):
assignee: Chase Douglas (chasedouglas) → nobody
tags: removed: i386
Teva Riou (teva-riou) on 2010-10-30
Changed in linux:
importance: Undecided → Unknown
status: New → Unknown
importance: Unknown → Undecided
status: Unknown → New
Changed in linux (Fedora):
importance: Unknown → Undecided
status: Unknown → New
Teva Riou (teva-riou) on 2010-10-30
Changed in linux (Fedora):
importance: Undecided → Unknown
status: New → Unknown
importance: Unknown → Undecided
status: Unknown → New
Cymaphore (cymaphore) on 2010-11-23
Changed in linux (Ubuntu Lucid):
status: Incomplete → Opinion
Gursimran singh (simar) on 2010-11-24
Changed in linux (Ubuntu):
importance: Undecided → Medium
Andy Whitcroft (apw) on 2011-01-19
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Andy Whitcroft (apw) on 2011-02-16
Changed in linux (Ubuntu Lucid):
status: Opinion → New
Changed in linux (Ubuntu):
status: Incomplete → Fix Released
assignee: nobody → Andy Whitcroft (apw)
tags: added: kernel-key
Changed in linux (Ubuntu Lucid):
status: New → Triaged
Changed in linux (Ubuntu Maverick):
status: New → Triaged
Changed in linux (Ubuntu Maverick):
importance: Undecided → Medium
Dan Faulks (aitaix9) on 2011-03-31
description: updated
C de-Avillez (hggdh2) on 2011-04-22
Changed in linux:
importance: Undecided → Unknown
status: New → Unknown
Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed
tags: added: natty
Bryce Harrington (bryce) on 2011-06-28
Changed in xserver-xorg-input-synaptics (Ubuntu Maverick):
status: New → Invalid
Changed in xserver-xorg-input-synaptics (Ubuntu Lucid):
status: New → Invalid
Changed in xserver-xorg-input-synaptics (Ubuntu):
status: New → Invalid
Changed in xserver-xorg-input-synaptics (Ubuntu Lucid):
status: Invalid → Confirmed
Changed in xserver-xorg-input-synaptics (Ubuntu Maverick):
status: Invalid → Confirmed
Serg Alexv (agel) on 2011-10-18
tags: added: oneiric
513 comments hidden view all 593 comments

BlogCrawler,
Thanks for your suggestion. I've followed this procedure but it didn't help.

Thanks for your time.

However, just out of curiosity I have tried the Fn+F3 that disables the touchpad. Strangely enough it appeared the popup to notify the touchpad is disabled. The touchpad is not recognized yet, but could that be a hint that something actually happened?

Federico (f-ghigo) wrote :

Package DKMS at #492 works fine for me, Sony VAIO VPVEC3Z1E
Thank you !

BlogCrawler (blogcrawler) wrote :

quarara,
Does you laptop's touchpad works like a basic mouse? Please post your dmesg and also 'xinput list'.
Mine was detected as a mouse before installing this patch and pressing Fn+F3 was showing an empty notification while the touchpad was still functional (enabled).

This is it.

luigi@luigi-Inspiron-N5110:~$ xinput list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ PS/2 Generic Mouse id=12 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Power Button id=6 [slave keyboard (3)]
    ↳ Video Bus id=7 [slave keyboard (3)]
    ↳ Power Button id=8 [slave keyboard (3)]
    ↳ Sleep Button id=9 [slave keyboard (3)]
    ↳ Laptop_Integrated_Webcam_HD id=10 [slave keyboard (3)]
    ↳ AT Translated Set 2 keyboard id=11 [slave keyboard (3)]
    ↳ Dell WMI hotkeys id=13 [slave keyboard (3)]

Thank you so much.

> The dumps I posted yesterday are when I see the slow down, and I'm not
> near any other electronic devices.
>
> I'm going to have to keep a journal of the "mouse flying off to the
> left" problem and see if it correlates to things I'm next to.

Note that it could be interference from internal devices as well. The
driver simply reports the values from the hardware unmodified, so unless
there's some problem with interpreting the data (which seems unlikely at
this stage, but not impossible) the jump indicates a sudden change in
the position being reported by the touchpad. If you can enable the
packet dump and collect the dmesg data (*immediately* after you see the
jump, switch to a VT and collect the data without touching the touchpad
or trackstick) I'll take a look and see if I can identify what's
happening.

Seth Forshee (sforshee) wrote :

On Fri, Nov 11, 2011 at 01:09:47PM -0000, quarara wrote:
> However, just out of curiosity I have tried the Fn+F3 that disables the
> touchpad. Strangely enough it appeared the popup to notify the touchpad
> is disabled. The touchpad is not recognized yet, but could that be a
> hint that something actually happened?

The mechanism for enabling/disabling the touchpad is completely separate
from the touchpad driver itself. I don't think the notification
indicates anything about the touchpad driver.

Thank you, Seth.
In the meanwhile I've installed your drivers several times following the aforementioned procedure but I wasn't able to make my touchpad work. The patch worked on a friend's laptop, though.

I have installed the package from #492 within "Ubuntu 11.10/x86_64" on "Dell/E5420" with "ImPS/2 ALPS GlidePoint" and now the disable tap on click works good AFAIS.

Thank you very much Seth for your commitment. Is some data collection required for this type/model?

I hate to crosspost, but it looks like the patch posted by Seth in comment #492 could be modified to make more touchpad recongnized by the system. See comment #62 of bug #606238 for further reference.

Seth Forshee (sforshee) wrote :

On Mon, Nov 14, 2011 at 10:54:38AM -0000, quarara wrote:
> I hate to crosspost, but it looks like the patch posted by Seth in
> comment #492 could be modified to make more touchpad recongnized by the
> system. See comment #62 of bug #606238 for further reference.

Not necessarily; see my response on that bug. It's not clear whether the
modifications really support the touchpad, or just cause it to be
identified as ALPS while the touchpad continues to report PS/2 relative
event data.

Vladimir Hidalgo (vlad88sv) wrote :

Can't compile 0.10 into kernel 3.2 (from kernel mainline ppa)

$ cat /var/lib/dkms/psmouse-alps/0.10/build/make.log

DKMS make.log for psmouse-alps-0.10 for kernel 3.2.0-999-generic (i686)
vie nov 18 20:00:36 CST 2011
make: se ingresa al directorio «/usr/src/linux-headers-3.2.0-999-generic»
  LD /var/lib/dkms/psmouse-alps/0.10/build/src/built-in.o
  CC [M] /var/lib/dkms/psmouse-alps/0.10/build/src/psmouse-base.o
  CC [M] /var/lib/dkms/psmouse-alps/0.10/build/src/synaptics.o
  CC [M] /var/lib/dkms/psmouse-alps/0.10/build/src/alps.o
/var/lib/dkms/psmouse-alps/0.10/build/src/alps.c:135:33: error: expected ‘)’ before ‘int’
make[2]: *** [/var/lib/dkms/psmouse-alps/0.10/build/src/alps.o] Error 1
make[1]: *** [/var/lib/dkms/psmouse-alps/0.10/build/src] Error 2
make: *** [_module_/var/lib/dkms/psmouse-alps/0.10/build] Error 2
make: se sale del directorio «/usr/src/linux-headers-3.2.0-999-generic»

harry (rimez) wrote :

@Seth

Thanks for the driver on post #466. for over a year now I've been using the imps hack in /etc/modprobe.d

With this, I am even now able to use touchpad indicator as it correctly sees the touchpad as a touchpad and not a ps2 mouse. Thank you!!!

I'm running Ubuntu 11.04 on an Acer TimelineX 3820TG.

Francisco Cribari (cribari) wrote :

@Seth, has your patch been included in the Ubuntu kernel 3.0.0-13? If not, will it be available in a Ubuntu kernel prior to 3.2? Thank you.

Steven (svanpoeck) wrote :
Download full text (4.1 KiB)

Hi @seth,

First off, thanks for the patch, it works like a charm on my DELL Latitude E6510.

I just acquired a Dell Precision M6400. The default Mouse and Touchpad settings don't give me the possibility to deactivate the touchapd alltogether, so I installed your patch from comment #492. But it does not seem to install correctly: no gpointing-device-settings binary is available...

Here are the hardware details:
* uname -a:
Linux mt-lap-04 3.0.0-13-generic #22-Ubuntu SMP Wed Nov 2 13:27:26 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

* xinput list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ DualPoint Stick id=13 [slave pointer (2)]
⎜ ↳ AlpsPS/2 ALPS DualPoint TouchPad id=14 [slave pointer (2)]
⎜ ↳ MLK Trust Mouse 16536 id=11 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Power Button id=6 [slave keyboard (3)]
    ↳ Video Bus id=7 [slave keyboard (3)]
    ↳ Power Button id=8 [slave keyboard (3)]
    ↳ Sleep Button id=9 [slave keyboard (3)]
    ↳ Laptop_Integrated_Webcam_FHD id=10 [slave keyboard (3)]
    ↳ AT Translated Set 2 keyboard id=12 [slave keyboard (3)]
    ↳ Dell WMI hotkeys id=15 [slave keyboard (3)]

* lspci
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:16.3 Serial controller: Intel Corporation 6 Series/C200 Series Chipset Family KT Controller (rev 04)
00:19.0 Ethernet controller: Intel Corporation 82579LM Gigabit Network Connection (rev 04)
00:1a.0 USB Controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b4)
00:1c.1 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 2 (rev b4)
00:1c.2 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 3 (rev b4)
00:1c.3 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 4 (rev b4)
00:1c.7 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 8 (rev b4)
00:1d.0 USB Controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation QM67 Express Chipset Family LPC Controller (rev 04)
00:1f.2 RAID bus controller: Intel Corporation Mobile 82801 SATA RAID Controller (rev 04)
00:1f...

Read more...

Seth Forshee (sforshee) wrote :

On Sat, Dec 03, 2011 at 09:59:00PM -0000, Francisco Cribari wrote:
> @Seth, has your patch been included in the Ubuntu kernel 3.0.0-13? If
> not, will it be available in a Ubuntu kernel prior to 3.2? Thank you.

No, there are no plans to include the driver updates in the kernels for
11.10 due to the risk associated with so large a change. The new driver
support has already been applied to the kernel for 12.04.

Seth Forshee (sforshee) wrote :

On Sun, Dec 04, 2011 at 12:50:02PM -0000, Steven wrote:
> Hi @seth,
>
> First off, thanks for the patch, it works like a charm on my DELL
> Latitude E6510.
>
> I just acquired a Dell Precision M6400. The default Mouse and Touchpad
> settings don't give me the possibility to deactivate the touchapd
> alltogether, so I installed your patch from comment #492. But it does
> not seem to install correctly: no gpointing-device-settings binary is
> available...

Steven: The changes I worked on only add support for a subset of Dell
hardware, albeit a fairly large subset. If you have a model that isn't
supported, I'd suggest you check and see if anyone has opened a bug
specific to your model already, and if not file a new bug.

Is it possible to make this driver available for other distributions as well?

If I'm right it is just about the packaging because this is fix is in fact for kernel?
Though I'm not capable of repackaging this driver or patching my kernel someone else might be?

I'm using Fedora and I have HP DM3z and I'm quite sure that this pug is the one affecting me.

And somehow I get the feeling of this launchpad page that it somehow is related to fedora (my url is https://bugs.launchpad.net/fedora/+source/linux/+bug/550625?comments=all) yet there is only talk about different Ubuntu variants and .deb packages going around.

pauljohn32 (pauljohn32) wrote :

Sampo Saarela: The RedHat/Fedora folks have been a little late to the party on this problem. In fact, they tried to close work on it, arguing that it was an impossible problem because ALPS would not cooperate. It was really quite disappointing to me.

That's why I'm so impressed and delighted that Seth Forshee found a way to make it work.

Now there are packages for their distros, however. I think the best place to track that is here:

https://bugzilla.redhat.com/show_bug.cgi?id=590880

V. 010 work great with Toshiba Satellite R840-139.

ndkhoi168 (ndkhoi168) wrote :

I tried your suggestion on #492, every steps are ok. Unfortunately, multitouch and scroll don't work on my touchpad, Fn+F3 to disable touchpad doesn't work as well. I'm using Laptop DELL N5110 15R and Ubuntu 11.10 32 bit.

I also removed all power sources after install your alps-mouse package.

I attach lsinput, xinput list, input-events and dmesg output.

Please help me soon. Thank so much

ndkhoi168 (ndkhoi168) wrote :

I attach the output. Please look for that

pauljohn32 (pauljohn32) wrote :
Download full text (3.6 KiB)

ndkhoi168: There's no way for us to know that you have the particular kind of touchpad that this driver supports. Supposing it is, you need to use the synclient program to review and set the options. Simply installing the d river does not necessarily do any good. You need to be sure the kernel module is loading and then configure everything.

I don't see any attachments with your post, but I'm not sure they would help me anyway. I want to see the output of

$ synclient -l

I see this output.
~$ synclient -l
Parameter settings:
    LeftEdge = 300
    RightEdge = 1750
    TopEdge = 210
    BottomEdge = 1190
    FingerLow = 93
    FingerHigh = 98
    FingerPress = 250
    MaxTapTime = 180
    MaxTapMove = 107
    MaxDoubleTapTime = 180
    SingleTapTimeout = 180
    ClickTime = 100
    FastTaps = 0
    EmulateMidButtonTime = 75
    EmulateTwoFingerMinZ = 141
    EmulateTwoFingerMinW = 7
    VertScrollDelta = 48
    HorizScrollDelta = 0
    VertEdgeScroll = 1
    HorizEdgeScroll = 0
    CornerCoasting = 0
    VertTwoFingerScroll = 1
    HorizTwoFingerScroll = 0
    MinSpeed = 1
    MaxSpeed = 1.75
    AccelFactor = 0.0819336
    TrackstickSpeed = 40
    EdgeMotionMinZ = 15
    EdgeMotionMaxZ = 80
    EdgeMotionMinSpeed = 1
    EdgeMotionMaxSpeed = 195
    EdgeMotionUseAlways = 0
    TouchpadOff = 0
    LockedDrags = 0
    LockedDragTimeout = 5000
    RTCornerButton = 0
    RBCornerButton = 0
    LTCornerButton = 0
    LBCornerButton = 0
    TapButton1 = 1
    TapButton2 = 3
    TapButton3 = 3
    ClickFinger1 = 1
    ClickFinger2 = 1
    ClickFinger3 = 1
    CircularScrolling = 0
    CircScrollDelta = 0.1
    CircScrollTrigger = 0
    CircularPad = 0
    PalmDetect = 1
    PalmMinWidth = 20
    PalmMinZ = 99
    CoastingSpeed = 100
    CoastingFriction = 50
    PressureMotionMinZ = 15
    PressureMotionMaxZ = 80
    PressureMotionMinFactor = 1
    PressureMotionMaxFactor = 1
    GrabEventDevice = 1
    TapAndDragGesture = 1
    AreaLeftEdge = 0
    AreaRightEdge = 0
    AreaTopEdge = 0
    AreaBottomEdge = 0

 If, after a system restart, you can do this to see if the psmouse module is running.

$ /sbin/lsmod

will list all modules loaded. make sure psmouse is in there.

If not, run

$ /sbin/modprobe psmouse

When I force the mouse driver to be removed and restarted, I see this in dmesg output:

[284927.600654] alps.c: E6 report: 00 00 64
[284927.619964] alps.c: E7 report: 73 02 64
[284928.066718] alps.c: E6 report: 00 00 64
[284928.085731] alps.c: E7 report: 73 02 64
[284928.201449] alps.c: trackstick E7 report: 42 02 3c
[284928.626809] input: DualPoi...

Read more...

Francisco Cribari (cribari) wrote :

When upgrading to kernel 3.2.0-15 via PPA (Linux Mint 12, 64 bit) I got:

Examining /etc/kernel/header_postinst.d.
run-parts: executing /etc/kernel/header_postinst.d/dkms 3.2.0-15-generic /boot/vmlinuz-3.2.0-15-generic
Error! Bad return status for module build on kernel: 3.2.0-15-generic (x86_64)
Consult /var/lib/dkms/psmouse-alps/0.10/build/make.log for more information.
Error! Bad return status for module build on kernel: 3.2.0-15-generic (x86_64)
Consult /var/lib/dkms/virtualbox-guest/4.1.2/build/make.log for more information.

The contents of /var/lib/dkms/psmouse-alps/0.10/build/make.log:

cribari@darwin ~ $ cat /var/lib/dkms/psmouse-alps/0.10/build/make.log
DKMS make.log for psmouse-alps-0.10 for kernel 3.2.0-15-generic (x86_64)
Wed Feb 8 13:17:51 BRT 2012
make: Entering directory `/usr/src/linux-headers-3.2.0-15-generic'
  LD /var/lib/dkms/psmouse-alps/0.10/build/src/built-in.o
  CC [M] /var/lib/dkms/psmouse-alps/0.10/build/src/psmouse-base.o
  CC [M] /var/lib/dkms/psmouse-alps/0.10/build/src/synaptics.o
  CC [M] /var/lib/dkms/psmouse-alps/0.10/build/src/alps.o
/var/lib/dkms/psmouse-alps/0.10/build/src/alps.c:135:33: error: expected ‘)’ before ‘int’
make[2]: *** [/var/lib/dkms/psmouse-alps/0.10/build/src/alps.o] Error 1
make[1]: *** [/var/lib/dkms/psmouse-alps/0.10/build/src] Error 2
make: *** [_module_/var/lib/dkms/psmouse-alps/0.10/build] Error 2
make: Leaving directory `/usr/src/linux-headers-3.2.0-15-generic'

I've got this same error when updating to Ubuntu 12.04 Beta 1 from 11.10. But I think the current kernel in this version (3.2.0-17-generic #27-Ubuntu) already incorporates the new module since the touchpad is perfectly recognized and working correctly. Can this bug be marked as fixed released and may be ask to SRU it to previous Ubuntu releases if there is interest?

Seth Forshee (sforshee) wrote :

It _is_ marked fix released where appropriate. The other bug statues ought to be updated though. I'll go ahead and do that.

This isn't the type of change we'd normally backport though, and I don't have plans to do so.

Changed in xserver-xorg-input-synaptics (Ubuntu Lucid):
status: Confirmed → Invalid
Seth Forshee (sforshee) wrote :

Ugh, I got one updated and now launchpad times out every time I try. I give up.

Changed in touchpad-indicator:
status: New → Invalid
Changed in baltix:
status: New → Invalid
Changed in linux (Ubuntu Lucid):
status: Triaged → Invalid
Changed in linux (Ubuntu Maverick):
status: Triaged → Invalid
Changed in xserver-xorg-input-synaptics (Ubuntu Maverick):
status: Confirmed → Invalid
Luke (lukeckelly) wrote :

This command did not work "gconftool-2 --set --type boolean
/desktop/gnome/peripherals/touchpad/touchpad_enabled true"

I was also getting a lot of "module psmouse does not exist in proc/modules".

The only thing which worked was "sudo modprobe -r psmouse; sudo modprobe psmouse".

I am running an Asus Eee PC with Ubuntu 11.10 32-bit. Asus Eee PC has 1GB or RAM and an Intel Atom 1.66Ghz single-core.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu laptop testing tracker.

A list of all reports related to this bug can be found here:
http://laptop.qa.ubuntu.com/qatracker/reports/bugs/550625

tags: added: laptop-testing
george panta (adgeruy) wrote :

Hello everyone,

I have made a patch that adds semi-mt support to v4 Alps touchpads.
Unfortunately it is quite buggy.

On my Vaio the Left Half of the Touchpad is quite erratic (synclient -m 10
shows f alternating constantly between 1 and 2 fingers with one finger touching
it).

The right Half of the Touchpad (i.e. if x>1000 in synclient -m x) works as
intended (two finger scrolling/taps and three fingers are recognized).

I have used the Documentation from Seth Forshee and essentially copied his
work.

I would really appreciate it if someone could finalize the patch.
I hope Seth could revisit this :)

P.S. I am not a programmer (I guess programmers will understand this) :)

Seth Forshee (sforshee) wrote :

george: I suggest you use bug #954109 for the v4 semi-MT support.

Changed in linux:
status: Confirmed → Fix Released

The fix doesn't work on Dell Inspiron N5110 15R.

earthmeLon (earthmelon) wrote :

* Linux x64 3.0.0-17-generic
* Sony Vaio VPCF126FM

I have installed the latest package (10) and removed/added the module from the kernel.
dmesg shows "ImPS/2 Generic Wheel Mouse as /devices/platform/i8042/serio1/input/input18"

I would be very grateful if anybody could provide me with any additional information that may get my touchpad working.
I am more than willing to provide any information that may help.

My ultimate goal is to disable the touchpad while typing, but I really do want to experiment with multi-touch features.

Thanks for everybody who has contributed thus far.

earthmeLon (earthmelon) wrote :

* Linux 3.3.0-030300-generic #201203182135 SMP Mon Mar 19
* Sony Vaio VPCF126FM

Now I am unable to install your packages (I've tried 10 and 11).

sudo dpkg -i psmouse-alps-dkms_0.10_all.deb
Selecting previously deselected package psmouse-alps-dkms.
(Reading database ... 419345 files and directories currently installed.)
Unpacking psmouse-alps-dkms (from psmouse-alps-dkms_0.10_all.deb) ...
Setting up psmouse-alps-dkms (0.10) ...

Loading tarball for psmouse-alps-0.10
Loading /var/lib/dkms/psmouse-alps/0.10/2.6.38-11-generic/x86_64...

DKMS: ldtarball Completed.

Creating symlink /var/lib/dkms/psmouse-alps/0.10/source ->
                 /usr/src/psmouse-alps-0.10

DKMS: add Completed.
First Installation: checking all kernels...
Building only for 3.3.0-030300-generic
Building for architecture x86_64
Building initial module for 3.3.0-030300-generic
ERROR (dkms apport): unable to determine source package for psmouse-alps-dkms
Error! Bad return status for module build on kernel: 3.3.0-030300-generic (x86_64)
Consult /var/lib/dkms/psmouse-alps/0.10/build/make.log for more information.

@Seth, thanks for the driver. Great job.

I have an HP Pavilion dm4-2075 running Ubuntu 11.10.

After installing version 0.10 of your driver (post #492), I got the following results:

  + Two-finger vertical scrolling works

  + Two-finger horizontal scrolling works

  + Disabled while typing works

None of these worked before.

Once again, thanks. I was so impressed by the way this community works
that I finally decided to join. I have been using Ubuntu for over
5 years now, and I feel I should contribute to this great project
somehow. Don't know how yet, but I'll find a way.

Cliff Wells (cliff-develix) wrote :

Martin, that's a 404.

Steffen Neumann (sneumann) wrote :

Hi,
I am coming from bug #1041916, where the ALPS device on Fujitsu Lifebook AH530 is not recognized
by psmouse.ko, neither on precise, quantal, nor mainline linux-image-3.6.0-999-generic 3.6.0-999.20120830405,
Since psmouse-alps-dkms has helped some people to have their ALPS detected,
does it make sense to check that ? Where did it go ?

Steffen

Hemanti (henrikmarcel) wrote :

Hi,

I was very glad, when I could finally use my touchpad on my HP Pavillion dm4-2000sg. Thank you again very much for that great work and your great support here, Seth.

Unfortunately, I have upgraded my system to Ubuntu 12.04 the other day and the touchpad stopped working. I tried uninstalling, reinstalling the driver, rebooted after each change loaded the module manually, but nothing helped. :( What can I do?

Btw, I still have the debug outputs about those random clicks that just happen from time to time on my hard drive. Are you still interested, Seth?

Regards,
Henrik

Hemanti (henrikmarcel) wrote :

After an upgrade to Quantal, it still does not work. :( Any ideas, anyone?

Henrik

Displaying first 40 and last 40 comments. View all 593 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.