Ubuntu

Alps touchpad detected as ImPS/2 Generic Wheel Mouse(in VAIO E series) after the kernel upgrade

Reported by Vladimir Hidalgo on 2010-04-17
492
This bug affects 85 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
Ubuntu Netbook Remix
Undecided
Unassigned
linux (Ubuntu)
Medium
Unassigned

Bug Description

Initially the ALPS touchpad was detected by the kernel but does not support horizontal and vertical support but after the kernel upgrade to 10.04 vertical scroll is working but horizontal scroll is not working. And the kernel is not detecting the ALPS touchpad and the cat /proc/bus/input/devices says it is a PS2 mouse ..

This is seen in sony vaio E series.

---
Architecture: i386
DistroRelease: Ubuntu 11.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100224.1)
Package: linux (not installed)
ProcEnviron:
 LANGUAGE=es_SV:es_SV.UTF-8:es:en_GB:en
 LANG=es_SV.UTF-8
 SHELL=/bin/bash
Tags: unity-2d natty
Uname: Linux 3.0.0-0300rc7-generic i686
UnreportableReason: The running kernel is not an Ubuntu kernel
UpgradeStatus: Upgraded to natty on 2011-07-05 (26 days ago)
UserGroups: adm admin audio cdrom fuse lpadmin netdev plugdev sambashare vboxusers video
---
Architecture: i386
DistroRelease: Ubuntu 11.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100224.1)
Package: linux (not installed)
ProcEnviron:
 LANGUAGE=es_SV:es_SV.UTF-8:es:en_GB:en
 LANG=es_SV.UTF-8
 SHELL=/bin/bash
Tags: unity-2d natty
Uname: Linux 3.0.0-0300rc7-generic i686
UnreportableReason: The running kernel is not an Ubuntu kernel
UpgradeStatus: Upgraded to natty on 2011-07-05 (26 days ago)
UserGroups: adm admin audio cdrom fuse lpadmin netdev plugdev sambashare vboxusers video

Vladimir Hidalgo (vlad88sv) wrote :

cat /var/log/Xorg.0.log

(II) config/udev: Adding input device AlpsPS/2 ALPS GlidePoint (/dev/input/event11)
(**) AlpsPS/2 ALPS GlidePoint: Applying InputClass "evdev pointer catchall"
(**) AlpsPS/2 ALPS GlidePoint: Applying InputClass "evdev touchpad catchall"
(**) AlpsPS/2 ALPS GlidePoint: Applying InputClass "touchpad catchall"
(II) LoadModule: "synaptics"
(II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
(II) Module synaptics: vendor="X.Org Foundation"
 compiled for 1.7.6, module version = 1.2.2
 Module class: X.Org XInput Driver
 ABI class: X.Org XInput driver, version 7.0
(II) Synaptics touchpad driver version 1.2.2
(**) Option "Device" "/dev/input/event11"
(II) AlpsPS/2 ALPS GlidePoint: x-axis range 0 - 1023
(II) AlpsPS/2 ALPS GlidePoint: y-axis range 0 - 767
(II) AlpsPS/2 ALPS GlidePoint: pressure range 0 - 127
(II) AlpsPS/2 ALPS GlidePoint: finger width range 0 - 0
(II) AlpsPS/2 ALPS GlidePoint: buttons: left right middle
(--) AlpsPS/2 ALPS GlidePoint: touchpad found
(**) AlpsPS/2 ALPS GlidePoint: always reports core events
(II) XINPUT: Adding extended input device "AlpsPS/2 ALPS GlidePoint" (type: TOUCHPAD)
(**) AlpsPS/2 ALPS GlidePoint: (accel) keeping acceleration scheme 1
(**) AlpsPS/2 ALPS GlidePoint: (accel) acceleration profile 0
(**) AlpsPS/2 ALPS GlidePoint: (accel) acceleration factor: 2.000
(**) AlpsPS/2 ALPS GlidePoint: (accel) acceleration threshold: 4
(--) AlpsPS/2 ALPS GlidePoint: touchpad found
(II) config/udev: Adding input device AlpsPS/2 ALPS GlidePoint (/dev/input/mouse5)
(II) No input driver/identifier specified (ignoring)

Vladimir Hidalgo (vlad88sv) wrote :

I activated scrollbar in Preferences -> Mouse -> Touchpad but it's not working.

I've seen the options HorizEdgeScroll and VertEdgeScroll in Xorg.conf's man page, but Lucid does not come with a default xorg.conf and I'm not willing to create one for this.

Brian O'Connor (gatzby3jr) wrote :

I'm experiencing the same problem on my hp pavilion dm3z

From my Xorg.0.log:

(II) config/udev: Adding input device AlpsPS/2 ALPS GlidePoint (/dev/input/event
10)
(**) AlpsPS/2 ALPS GlidePoint: Applying InputClass "evdev pointer catchall"
(**) AlpsPS/2 ALPS GlidePoint: Applying InputClass "evdev touchpad catchall"
(**) AlpsPS/2 ALPS GlidePoint: Applying InputClass "touchpad catchall"
(II) LoadModule: "synaptics"
(II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
(II) Module synaptics: vendor="X.Org Foundation"
        compiled for 1.7.6, module version = 1.2.2
        Module class: X.Org XInput Driver
        ABI class: X.Org XInput driver, version 7.0
(II) Synaptics touchpad driver version 1.2.2
(**) Option "Device" "/dev/input/event10"
(II) AlpsPS/2 ALPS GlidePoint: x-axis range 0 - 1023
(II) AlpsPS/2 ALPS GlidePoint: y-axis range 0 - 767
(II) AlpsPS/2 ALPS GlidePoint: pressure range 0 - 127
(II) AlpsPS/2 ALPS GlidePoint: finger width range 0 - 0
(II) AlpsPS/2 ALPS GlidePoint: buttons: left right middle
(--) AlpsPS/2 ALPS GlidePoint: touchpad found
(**) AlpsPS/2 ALPS GlidePoint: always reports core events
(II) XINPUT: Adding extended input device "AlpsPS/2 ALPS GlidePoint" (type: TOUCHPAD)
(**) AlpsPS/2 ALPS GlidePoint: (accel) keeping acceleration scheme 1
(**) AlpsPS/2 ALPS GlidePoint: (accel) acceleration profile 0
(**) AlpsPS/2 ALPS GlidePoint: (accel) acceleration factor: 2.000
(**) AlpsPS/2 ALPS GlidePoint: (accel) acceleration threshold: 4
(--) AlpsPS/2 ALPS GlidePoint: touchpad found
(II) config/udev: Adding input device AlpsPS/2 ALPS GlidePoint (/dev/input/mouse2)
(II) No input driver/identifier specified (ignoring)

I've enabled it in gnome-mouse-settings, and I've disabled tap-to-click, which does nothing (it still clicks).

Just wanted to confirm the problem exists with the Sony Vaio E series. I have a VPCEB11FM and it lacking the vertical or horizontal scroll. I did not try to create the xorg.conf in Lucid because I am unsure if I have to include configuration for all devices, or if its ok to only put the synaptics configution.

I can confirm Windows 7 vertical scrolling works. I did not test horizontal scrolling.

Vladimir Hidalgo (vlad88sv) wrote :

VAIO E series' ALPS touchpads seems to be true multitouch also.

In Windows 7 you can zoom (tested in chrome) putting two fingers in the middle of the touchpad, then expanding them until you reach the edges.

Vladimir Hidalgo (vlad88sv) wrote :

 sudo tpconfig --info
Found Synaptics Touchpad.
Firmware: 8.96 (multiple-byte mode).
Sensor type: unknown (0).
Geometry: rectangular/landscape/up.
Packets: absolute, 80 packets per second.
Corner taps disabled; no tap gestures.
Edge motion: none.
Z threshold: 6 of 7.
2 button mode; corner tap is right button click.

mrphd (andrubuntu) wrote :

I have same problem on Vaio VPCEB1Z0E

Hi ! Same here with a HP mini 311c.

IndyCore (jan-kjerbye) wrote :

Same problem on Dell 6410 ATG

Alps Toucpad, no edge or two finger scrolling, although it works fine in Win 7

Vladimir Hidalgo (vlad88sv) wrote :

This is solved with Kernel 2.6.34 by default.

More info:
http://ubuntuforums.org/showpost.php?p=9329402&postcount=3

Segitz (flacht82) wrote :

That is not a fix, though...

The recent kernel/module update for 10.4 (I think from the proposed packages) just makes it so that it is detected as either a PS2 mouse or a Macintosh mouse. Not as an Alps anymore, which kills off all of the better features it offers (the Vaio EB series supports multitouch in windows, for example).

Vladimir Hidalgo (vlad88sv) wrote :

With xorg-edger's lastest packages of Xorg things get worse, as even 3rd button emulation is lost.

$ cat /var/log/Xorg.0.log | grep -i mouse
[ 26.144] (==) intel(0): Silken mouse enabled
[ 27.028] (II) config/udev: Adding input device ImPS/2 Generic Wheel Mouse (/dev/input/event6)
[ 27.028] (**) ImPS/2 Generic Wheel Mouse: Applying InputClass "evdev pointer catchall"
[ 27.029] (**) ImPS/2 Generic Wheel Mouse: always reports core events
[ 27.029] (**) ImPS/2 Generic Wheel Mouse: Device: "/dev/input/event6"
[ 27.044] (--) ImPS/2 Generic Wheel Mouse: Found 3 mouse buttons
[ 27.044] (--) ImPS/2 Generic Wheel Mouse: Found scroll wheel(s)
[ 27.044] (--) ImPS/2 Generic Wheel Mouse: Found relative axes
[ 27.044] (--) ImPS/2 Generic Wheel Mouse: Found x and y relative axes
[ 27.044] (II) ImPS/2 Generic Wheel Mouse: Configuring as mouse
[ 27.044] (**) ImPS/2 Generic Wheel Mouse: YAxisMapping: buttons 4 and 5
[ 27.044] (**) ImPS/2 Generic Wheel Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[ 27.044] (II) XINPUT: Adding extended input device "ImPS/2 Generic Wheel Mouse" (type: MOUSE)
[ 27.044] (**) ImPS/2 Generic Wheel Mouse: (accel) keeping acceleration scheme 1
[ 27.044] (**) ImPS/2 Generic Wheel Mouse: (accel) acceleration profile 0
[ 27.044] (**) ImPS/2 Generic Wheel Mouse: (accel) acceleration factor: 2.000
[ 27.044] (**) ImPS/2 Generic Wheel Mouse: (accel) acceleration threshold: 4
[ 27.044] (II) ImPS/2 Generic Wheel Mouse: initialized for relative axes.
[ 27.044] (II) config/udev: Adding input device ImPS/2 Generic Wheel Mouse (/dev/input/mouse1)
[ 27.048] (II) config/udev: Adding input device Sony Vaio Jogdial (/dev/input/mouse0)

It detected a Jogdial even my laptop does have one!, ALPS seems to be gone :'(

Gursimran singh (simar) wrote :

Hi bug reporters
First of all Ubuntu BugSquad thankyou to report the bug and help ubuntu to get more close to a bug free OS. I think the situation can be better understood by the developers if you could include the output of xev program by typing in bash

xev >~/xev.txt
while trying to perform horizontal, vertical scroll in the window area that appears in the bottom left area of your screen after the command. After this avoid unnecessary moving your touchpad in the window area as this will create unnecessary noise in the xev.txt file. After you are done with this close the window with Alt+F4 as this will not be captured as a event there.Then you can upload the file xev.txt here so we can see if the information that it encloses if necessary for forwarding this bug upstream or not.

Vladimir Hidalgo (vlad88sv) wrote :

First tried vertical scrolling and then horizontal scrolling.

Horizontal is the problem because the pointer gets out xev's windows.

BTW; xev window was created at right-bottom corner.

Gursimran singh (simar) wrote :

It means that you are able to scroll vertically but not horizontly??

Yes, it looks like I'm unable to horizontal scroll.

This is the output of
$ cat /var/log/Xorg.0.log | grep -i mouse

PS: it's the same with lastest xorg* updates from Lucid and with
packages from xorg-edgers PPA

--
27.761] (II) config/udev: Adding input device ImPS/2 Generic Wheel Mouse
(/dev/input/event6)
[ 27.761] (**) ImPS/2 Generic Wheel Mouse: Applying InputClass "evdev
pointer catchall"
[ 27.761] (**) ImPS/2 Generic Wheel Mouse: always reports core events
[ 27.761] (**) ImPS/2 Generic Wheel Mouse: Device: "/dev/input/event6"
[ 27.780] (--) ImPS/2 Generic Wheel Mouse: Found 3 mouse buttons
[ 27.780] (--) ImPS/2 Generic Wheel Mouse: Found scroll wheel(s)
[ 27.780] (--) ImPS/2 Generic Wheel Mouse: Found relative axes
[ 27.780] (--) ImPS/2 Generic Wheel Mouse: Found x and y relative axes
[ 27.780] (II) ImPS/2 Generic Wheel Mouse: Configuring as mouse
[ 27.780] (**) ImPS/2 Generic Wheel Mouse: YAxisMapping: buttons 4 and 5
[ 27.780] (**) ImPS/2 Generic Wheel Mouse: EmulateWheelButton: 4,
EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[ 27.780] (II) XINPUT: Adding extended input device "ImPS/2 Generic
Wheel Mouse" (type: MOUSE)
[ 27.780] (**) ImPS/2 Generic Wheel Mouse: (accel) keeping
acceleration scheme 1
[ 27.781] (**) ImPS/2 Generic Wheel Mouse: (accel) acceleration profile 0
[ 27.781] (**) ImPS/2 Generic Wheel Mouse: (accel) acceleration
factor: 2.000
[ 27.781] (**) ImPS/2 Generic Wheel Mouse: (accel) acceleration
threshold: 4
[ 27.781] (II) ImPS/2 Generic Wheel Mouse: initialized for relative axes.
[ 27.781] (II) config/udev: Adding input device ImPS/2 Generic Wheel
Mouse (/dev/input/mouse1)
[ 27.784] (II) config/udev: Adding input device Sony Vaio Jogdial
(/dev/input/mouse0)

Gursimran singh (simar) on 2010-06-30
summary: - vertical/horizontal scrollbar in VAIO's touchpad does not work
+ horizontal scrollbar does not work in VAIO VPCEB15EL touchpad.

Vladimir It appears that you don't have the package xserver-xorg-input-synaptics installed in your linux.

To serve you better I have a few questions. Have you got a synaptics touchpad or a ALPS touchpad.
Does synaptics drivers work with alps touchpad? I mean have you got your touchpad worked ever with synaptics drivers?

Vladimir also try this and upload the results..
cat /var/log/Xorg.0.log | grep TouchPad (mind the caps)
cat /var/log/Xorg.0.log | grep Synaptics

Gursimran singh (simar) wrote :

For finding out you touchpad, you may use windows 7 device manager where it works fine.

Segitz (flacht82) wrote :

I have the same problem too... ever since some recent update, the touchpad is detected as a PS2 mouse. But that made the scrolling work.

The Sony Vaio E series has an ALPS touchpad, as it was detected as such with the original 10.4 installation.

Gursimran singh (simar) wrote :

It appears that the bug is now not linked to xserver-xorg-inout-syanptics as the driver no longer provides support to ALPS touchpad so the affects package should be changed ......

Vladimir Hidalgo (vlad88sv) wrote :

simar, thank you for your attention into this problem.

As Segitz stated, VAIO E series area ALPS (multitouch) touchpad.

I think original summary was ok because default 10.04 installation detect it as AlpS and neither vertical/horizontal scrollbar works.

In a effort to make both work, I blindy updated my kernel to 2.6.34, which made vertical scrollbar work, later to 2.6.35-rc3 but nothing else changed.

Then I upgraded Xorg with xorg-edgers's ppa, wich I might say, worsen the situation as I lost the ability to simulate 3rd button click (mouse wheel click / middle button click).

I already had installed xserver-xorg-input-synaptics when doing the xev's test.

$ cat /var/log/Xorg.0.log | grep -i TouchPad
<nothing>

$ cat /var/log/Xorg.0.log | grep -i Synaptics
<nothing>

I had a optical mouse connected last time, so a new grep -i mouse:

$ cat /var/log/Xorg.0.log | grep mouse
$ cat /var/log/Xorg.0.log | grep -i -n1 mouse
335-[ 26.360] (==) intel(0): Backing store disabled
336:[ 26.360] (==) intel(0): Silken mouse enabled
337-[ 26.377] (II) intel(0): Initializing HW Cursor
--
433-[ 28.784] (**) Option "xkb_options" "grp:alts_toggle"
434:[ 28.784] (II) config/udev: Adding input device ImPS/2 Generic Wheel Mouse (/dev/input/event6)
435:[ 28.784] (**) ImPS/2 Generic Wheel Mouse: Applying InputClass "evdev pointer catchall"
436:[ 28.784] (**) ImPS/2 Generic Wheel Mouse: always reports core events
437:[ 28.784] (**) ImPS/2 Generic Wheel Mouse: Device: "/dev/input/event6"
438:[ 28.800] (--) ImPS/2 Generic Wheel Mouse: Found 3 mouse buttons
439:[ 28.800] (--) ImPS/2 Generic Wheel Mouse: Found scroll wheel(s)
440:[ 28.800] (--) ImPS/2 Generic Wheel Mouse: Found relative axes
441:[ 28.800] (--) ImPS/2 Generic Wheel Mouse: Found x and y relative axes
442:[ 28.800] (II) ImPS/2 Generic Wheel Mouse: Configuring as mouse
443:[ 28.800] (**) ImPS/2 Generic Wheel Mouse: YAxisMapping: buttons 4 and 5
444:[ 28.800] (**) ImPS/2 Generic Wheel Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
445:[ 28.800] (II) XINPUT: Adding extended input device "ImPS/2 Generic Wheel Mouse" (type: MOUSE)
446:[ 28.800] (**) ImPS/2 Generic Wheel Mouse: (accel) keeping acceleration scheme 1
447:[ 28.800] (**) ImPS/2 Generic Wheel Mouse: (accel) acceleration profile 0
448:[ 28.800] (**) ImPS/2 Generic Wheel Mouse: (accel) acceleration factor: 2.000
449:[ 28.800] (**) ImPS/2 Generic Wheel Mouse: (accel) acceleration threshold: 4
450:[ 28.800] (II) ImPS/2 Generic Wheel Mouse: initialized for relative axes.
451:[ 28.800] (II) config/udev: Adding input device ImPS/2 Generic Wheel Mouse (/dev/input/mouse1)
452-[ 28.800] (II) No input driver/identifier specified (ignoring)
--
454-[ 28.804] (II) No input driver/identifier specified (ignoring)
455:[ 28.804] (II) config/udev: Adding input device Sony Vaio Jogdial (/dev/input/mouse0)
456-[ 28.804] (II) No input driver/identifier specified (ignoring)

That's how my xorg is actually detecting (2) mouse in my system.

It calls my attention the "Vaio Jogdial". I think my laptop does not physically have one.

Gursimran singh (simar) wrote :

Please excuse me for delayed response vladimir. This is a mail to justify that I'm still considering the status of this bug.
It appears that while you have xserver-xorg-input-synaptics installed this is not really loaded and is not controlling your touchpad .

Gursimran singh (simar) wrote :

Thanks Vladimir for keeping patience and giving us time for sorting out issues. Delayed response is deeply regretted. However your bug is very near to be triaged, ony one last thing that you please include output of following commands in separate comments..

1. cat /proc/bus/input/devices >devices.txt
2. lspci -vv >lspci,txt

Thanks in advance for helping us to make ubutnu better...

Gursimran singh (simar) wrote :

Another thing is that the bug is in the kernel instead and not located in xserver-xorg-input-synaptics. So i'm changing the affects package..

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: New → Confirmed
affects: xserver-xorg-input-synaptics (Ubuntu) → linux (Ubuntu)
summary: - horizontal scrollbar does not work in VAIO VPCEB15EL touchpad.
+ Alps touchpad detected as ImPS/2 Generic Wheel Mouse(in VAIO E series)
+ after the kernel upgrade
Gursimran singh (simar) on 2010-07-06
description: updated
Vladimir Hidalgo (vlad88sv) wrote :

Requested file.

Vladimir Hidalgo (vlad88sv) wrote :

Requested file.

Vladimir Hidalgo (vlad88sv) wrote :

Thank you for your time and effort on this bug, Gursimran singh Mohar.

Gursimran singh (simar) wrote :

Well you are always welcome Vladimir Hidalgo reather you are encouraged to file more bugs so that our aim to make ubuntu reach as many people as possible and support a varity of hardware is possible.. I have maked your bug as triaged soon someone (developers) will look to your bug and hopefully this will be ok in the next kernel release ..

Chris Halse Rogers (raof) wrote :

I'm not sure why this bug has been assigned to the kernel. What has made people think that this is a kernel problem, rather than a problem in the synaptics driver?

Also, although snippets of /var/log/Xorg.0.log have been posted, it's really much more useful to have the entire log attached - from the logs, it looks like the synaptics driver is correctly binding to the alps touchpad, and is setting up various input properties. Could you please attach the full /var/log/Xorg.0.log Vladimir?

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Gursimran singh (simar) wrote :

From the devices file that vladimir uploaded

I: Bus=0011 Vendor=0002 Product=0005 Version=0000
N: Name="ImPS/2 Generic Wheel Mouse"
P: Phys=isa0060/serio2/input0
S: Sysfs=/devices/platform/i8042/serio2/input/input6
U: Uniq=
H: Handlers=mouse1 event6
B: EV=7
B: KEY=70000 0 0 0 0 0 0 0 0
B: REL=103

Sorry for any error committted by me as I'm a new triager. Please excuse me for such things . This is what kernel reports about the pointing input device that are connected to the computer Now as the kernel is not detecting right, I think the bug is in the kernel instead.

Chris Halse Rogers (raof) wrote :

It looks like this bug has changed over time; the touchpad does indeed seem to be being misdetected by the kernel now - it wasn't in the initial report, which was being correctly picked up by the synaptics X input driver.

That means that this will actually be two separate bugs. Let's first deal with the kernel one, which will be masking what appears to be a second one in the synaptics driver.

The device started to be identified as a Generic Wheel Mouse after an update - could anyone identify which update it was? That will make it much easier to work out what's happened. If you go to the Ubuntu Software Centre you should be able to select “History” and get a list of when all the upgrades were.

Changed in linux (Ubuntu):
status: Incomplete → New
status: New → Incomplete
Vladimir Hidalgo (vlad88sv) wrote :

On my first report I was using latest Lucid Lynx Alpha available at 2010-04-17.

That was the default kernel (2.6.32) and was detected as "AlpsPS/2 ALPS GlidePoint", at this point neither horizontal or vertical scroll worked.

Then in 2010-05-19 I updated to Kernel 2.6.34 from PPA Kernel Mainline, vertical scrollbar started to work but mouse were detected as Generic Wheel Mouse.

Later I upgrade Xserver/Xorg using ~xorg-edgers PPA but things actually got worse, as now I can't longer do simulated middle click by pressing simultaneously left and right click buttons.

I tried 2.6.35 RC3 but nothing changed, yesterday I tried 2.6.35 RC4 and surprise! keyboard/touchpad stop from working at all.

It's like support for ALPS is actually getting worse :P

skar (skar-karthikeyan) wrote :

I too have a VAIO E series laptop.

 xinput list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ Macintosh mouse button emulation id=12 [slave pointer (2)]
⎜ ↳ ImPS/2 Generic Wheel Mouse id=11 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Video Bus id=6 [slave keyboard (3)]
    ↳ Sony Vaio Keys id=7 [slave keyboard (3)]
    ↳ Power Button id=8 [slave keyboard (3)]
    ↳ USB 2.0 Camera id=9 [slave keyboard (3)]
    ↳ AT Translated Set 2 keyboard id=10 [slave keyboard (3)]

/proc/bus/input/devices has:

I: Bus=0011 Vendor=0002 Product=0005 Version=0000
N: Name="ImPS/2 Generic Wheel Mouse"
P: Phys=isa0060/serio2/input0
S: Sysfs=/devices/platform/i8042/serio2/input/input7
U: Uniq=
H: Handlers=mouse2 event7
B: EV=7
B: KEY=70000 0 0 0 0
B: REL=103

I'm on Lucid amd64 2.6.32-23-generic #37-Ubuntu SMP Fri Jun 11 08:03:28 UTC 2010 x86_64 GNU/Linux.

Hope this gets fixed soon. This laptop is 3-4 months old and this problem is still bugging me :)

Sound used to be a problem too, but manually compiling latest alsa 1.0.23 fixed it.

Vladimir Hidalgo (vlad88sv) wrote :

Data supplied

Changed in linux (Ubuntu):
status: Incomplete → New
Sense Egbert Hofstede (sense) wrote :

Please don't change the status to New when the data is provided. In that case the bug either remains Incomplete, or goes to Confirmed or Triaged, depending on the decision the bug triager makes.

Changed in linux (Ubuntu):
status: New → Incomplete
Gursimran singh (simar) wrote :

Hi Chris
          I think the bug reporters have submitted what you intended. As you were not subscribed to the bug report (probably you forget to subscribe), I have subscribed you. You may wish to continue your work on this bug report.

Gursimran singh (simar) wrote :

This is another person waiting for fix of this bug eagerly. He has mailed me.

Jefferson Carvalho to me

Hi Simar, my name is Jefferson and I read at https://bugs.launchpad.net/ubuntu/+source/linux/+bug/553370 that you are having problems with the alps touchpad and ubuntu. Well, I own a vaio vpceb13eb too and my touchpad is recognized as ps2 mouse. I tried updating my kernel with no results. I Would like to know if you found any solution that you can share.

Thanks for any help. bye.

Gursimran singh (simar) on 2010-08-07
Changed in linux (Ubuntu):
importance: Undecided → Medium
Changed in linux (Ubuntu):
status: Incomplete → New
status: New → Incomplete
Vladimir Hidalgo (vlad88sv) wrote :

By the way, could it be a bug in udev?.

Kernel 2.6.32
(II) config/udev: Adding input device AlpsPS/2 ALPS GlidePoint (/dev/input/event11)

Kernel 2.6.34 - 2.6.35RC6
(II) config/udev: Adding input device ImPS/2 Generic Wheel Mouse (/dev/input/event6)

Seems like it's picking another "input/event"?

Doing:
cat /var/log/Xorg.0.log | grep -i event11

Outputs nothing, like if original input/event11 were gone.

I have the same issue; hp mini311-1000. The OS (Ubuntu 10.04.1, latest kernel patches as of 2010.08.01) thinks my touchpad is a PS/2 mouse. It's devilishly hard to type on it as a result.

xinput --list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ ImPS/2 Generic Wheel Mouse id=12 [slave pointer (2)]
⎜ ↳ Macintosh mouse button emulation id=13 [slave pointer (2)]

cat /proc/bus/input/devices
...
I: Bus=0011 Vendor=0002 Product=0005 Version=0000
N: Name="ImPS/2 Generic Wheel Mouse"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input6
U: Uniq=
H: Handlers=mouse1 event6
B: EV=7
B: KEY=70000 0 0 0 0 0 0 0 0
...

Attachment for xorg.log attached. Hope this helps, so I do.

B: REL=103

--ckr

By the bye, it seems as though the OS never loaded the Synaptics drivers at all. No indication that they're present.

root@tiger:/home/ckr# cat /var/log/Xorg.0.log | grep -i synaptics
root@tiger:/home/ckr#

As can be seen.

On the GUI, there is no "touchpad tab" available. No touchpad utilities will start or load because the drivers are not present. HAL, or its replacement, simply does not "see" a touchpad.

--ckr

Gursimran singh (simar) on 2010-08-17
Changed in linux (Ubuntu):
status: Incomplete → Triaged
Gursimran singh (simar) on 2010-08-23
description: updated
Jeremy (jafoutz) on 2010-10-23
Changed in linux (Ubuntu):
status: Triaged → Fix Released
status: Fix Released → Incomplete
status: Incomplete → New
tags: added: kj-triage
Brad Figg (brad-figg) on 2011-07-18
Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: apport-collected natty running-unity
116 comments hidden view all 196 comments

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Joe Burgess (joemburgess) wrote :

I just marked bug #816110 a duplicate of this bug. the original reporter has tried this on the latest dev release and it is still being recognized as a ps/2 mouse.

Hopefully the upstream will fix this soon. It looks like they are getting close

Joe Burgess (joemburgess) wrote :

If someone could also please test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

The situation is the same or even worse for my laptop (a Dell Latitude E6420) in the latest upstream kernel. I tested with the plain 3.0 kernel from kernel.org (from source) and the ubuntu mainline kernel at http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.0-oneiric/ (both 64bit).

In the 2.6.38 kernel, the touchpad is recognized as "ImPS/2 ALPS GlidePoint", vertical scrolling works but settings like tapping cannot be configured.
In both new kernels my touchpad is recognized as a "PS/2 Generic Mouse" which is worse than in the default 2.6.38 kernel, because now even the vertical scrolling does not work anymore.

lennart@latitude ~ $ uname -a
Linux latitude 3.0.0-0300-generic #201107220917 SMP Fri Jul 22 09:20:45 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

lennart@latitude ~ $ cat /proc/bus/input/devices

[..]

I: Bus=0011 Vendor=0002 Product=0001 Version=0000
N: Name="PS/2 Generic Mouse"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input8
U: Uniq=
H: Handlers=mouse0 event8
B: PROP=0
B: EV=7
B: KEY=70000 0 0 0 0
B: REL=3

I did some more research. I noticed some remarkable differences between the alps.c drivers in the 2.6 and 3.0 kernels. There are all kinds of functions missing in the 3.0 version, and I am not a kernel developer but it looks to me those missing functions are connected to the fact the ALPS is recognized as a PS/2 mouse in the newer kernel.

See attached file for the output to "diff linux-source-2.6.38/drivers/input/mouse/alps.c linux-3.0/drivers/input/mouse/alps.c"

Please let me know if you need more data.

Changed in linux:
importance: Undecided → Unknown
status: New → Unknown
Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed
tags: added: unity-2d
description: updated
description: updated
Vladimir Hidalgo (vlad88sv) wrote :

I'm sorry, I tried to run apport, but as I'm trying with 3.0 kernel it's unable to send the report. It just added an unity-2d tag (I don't know why?).

Anyway, with 3.0.0-0300rc7-generic #201107120911 SMP Tue Jul 12 10:15:32 UTC 2011 i686 i686 i386 GNU/Linux I'm able to do vertical scroll again.

$ cat /proc/bus/input/devices
I: Bus=0011 Vendor=0002 Product=0005 Version=0000
N: Name="ImPS/2 Generic Wheel Mouse"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input7
U: Uniq=
H: Handlers=mouse2 event7
B: PROP=0
B: EV=7
B: KEY=70000 0 0 0 0 0 0 0 0
B: REL=103

Vladimir Hidalgo (vlad88sv) wrote :

$ sudo tpconfig --info
Found Synaptics Touchpad.
Firmware: 8.96 (multiple-byte mode).
Sensor type: unknown (0).
Geometry: rectangular/landscape/up.
Packets: absolute, 80 packets per second.
Corner taps disabled; no tap gestures.
Edge motion: none.
Z threshold: 6 of 7.
2 button mode; corner tap is right button click.

Sony VAIO VPCEB15EL

Changed in linux (Ubuntu):
status: Confirmed → Triaged
Konstantine Rybnikov (k-bx) wrote :

Fresh Ubuntu 11.04 with latest updates on SONY VAIO VPC-EB46FX, it sees the touchpad tab in gnome settings, but no scroll work.

If some information is still needed -- I'd be happy to give that. If someone of developers can't reproduce the bug -- I don't know, maybe just ssh to my machine and experiment, we'll work on that somehow etc.

Thanks.

Konstantine Rybnikov (k-bx) wrote :

@rvaliant yes, but all I want is vertical scroll (at least) to work on my vaio. It seems that current ubuntu kernel already has this patch https://patchwork.kernel.org/patch/350841/ (that your post mentions), but it still doesn't work on vaio.

Hello, I have a Sony VAIO E series and my touchpad is incorrectly detected. Symptoms include non-existant PS/2 Mouse listed in Pointing Devices, Alps PS/2 Alps Glidepoint listed in Pointing Devices but changes made here do not effect touchpad, no scrolling, unable to disable tap-to-click. I would like to contribute in whatever way possible to reverse engineering the glidepoint, creating or editing a driver, editing the kernel, or whatever is necessary to get this issue sorted. Please let me know what I can do! I await your instructions...

Dmitri (lamukra) wrote :

Sony VAIO VPC-EB1S1E

ALPS touchpad is detected properly and working, except scrolling, gestures and two finger scroll(not sure if it is possible in ubuntu)

It was annoying to be without scrolling, so created a file with name psmouse.conf in:

/etc/modprobe.d

with text inside:

options psmouse proto=imps

Saved and run through commands:

sudo modprobe -r psmouse
sudo modprobe psmouse

After this my ALPS is detected as ImPS/2 Generic Wheel Mouse, but scrolling is working

Also I cannot set/change any setting through configuration utilities
Tried to play with xorg.conf, but nothing helped me in order to make scrolling work, except psmouse.conf file

Thx for helping!

Konstantine Rybnikov (k-bx) wrote :

@Dmitri wow, that helped for me too, thanks! Sony VAIO VPCEB46FX

Dmitri solution worked also for me (Sony Vaio VPCEB3M1E), but with Ubuntu 11.10 i can't configure my touchpad, due to the fact that in the "Mouse and Touchpad" section there is only the mouse option not the other one, but after "patching" with Dmitri solution, i had this option but my touchpad doesn't work!.

Seth Forshee (sforshee) wrote :

I've been working on driver updates to fully support ALPS touchpads. Please take a look at bug 550625 if you would like to test this driver. Thanks!

Vladimir Hidalgo (vlad88sv) wrote :

Thank you very much Seth Forshee, just tested your driver 0.9 in 3.0.0-12-generic #19-Ubuntu SMP Fri Sep 23 21:18:13 UTC 2011 i686 i686 i386 and works perfectly!.

Laptop is Sony VPCEB15E.

Tested reported as good: vertical scroll & horizontal scroll.
Tested and does not work: two finger scroll. (This ALPS in this notebook is multitouch) and left click button stopped from working.

Click on tap is working, also right click button.

Thanks a lot

Thank you very much Seth Forshee, just tested your driver 0.9 in ubuntu
11.04

Laptop is Sony VPCEH15E.

Tested reported as good: vertical scroll, horizontal scroll, two finger
scrolling, left click button & right click button.

But there remains some jitter which is quiet annoying...

Thanks a lot

Gav O'Connor (scalamoosh) wrote :

Hi, Seth. I have also installed your 0.9 driver on my VPCEB3J1E. I have scrolling and tapping working, but 2-finger scrolling doesn't seem to work. Is there any information I could send you to help troubleshoot this problem?

Thanks

Seth Forshee (sforshee) wrote :

On Fri, Oct 07, 2011 at 12:32:21PM -0000, Gav O'Connor wrote:
> Hi, Seth. I have also installed your 0.9 driver on my VPCEB3J1E. I have
> scrolling and tapping working, but 2-finger scrolling doesn't seem to
> work. Is there any information I could send you to help troubleshoot
> this problem?

Two-finger scrolling doesn't work yet for some models, and it's a
feature that will need to be added later on for those models. Thanks for
offering to help, but there's no data needed at this time.

Barry Drake (b-drake) wrote :

I have reported a bug at : https://bugs.launchpad.net/bugs/876386 which is remarkably similar but on a different touchpad and machine. Also, the problem 'came and went'.

Dixon Xavier (dixoncx) wrote :

On Fri, Oct 7, 2011 at 6:44 PM, Seth Forshee <email address hidden>wrote:

> On Fri, Oct 07, 2011 at 12:32:21PM -0000, Gav O'Connor wrote:
> > Hi, Seth. I have also installed your 0.9 driver on my VPCEB3J1E. I have
> > scrolling and tapping working, but 2-finger scrolling doesn't seem to
> > work. Is there any information I could send you to help troubleshoot
> > this problem?
>
> Two-finger scrolling doesn't work yet for some models, and it's a
> feature that will need to be added later on for those models. Thanks for
> offering to help, but there's no data needed at this time.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/565543
>
> Title:
> Alps touchpad detected as ImPS/2 Generic Wheel Mouse(in VAIO E series)
> after the kernel upgrade
>
> Status in The Linux Kernel:
> Confirmed
> Status in Ubuntu Netbook Remix:
> New
> Status in “linux” package in Ubuntu:
> Triaged
>
> Bug description:
> Initially the ALPS touchpad was detected by the kernel but does not
> support horizontal and vertical support but after the kernel upgrade
> to 10.04 vertical scroll is working but horizontal scroll is not
> working. And the kernel is not detecting the ALPS touchpad and the cat
> /proc/bus/input/devices says it is a PS2 mouse ..
>
> This is seen in sony vaio E series in particular ...
>
> Also Bill in Comment #52 says
> Acer Aspire One 532h (Alps touchpad).
> I booted the distribution from a thumb drive, but once I installed from
> the thumb drive and updated Ubuntu (10.04), I lost the touchpad (works as a
> mouse) ..
> ---
> Architecture: i386
> DistroRelease: Ubuntu 11.04
> InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100224.1)
> Package: linux (not installed)
> ProcEnviron:
> LANGUAGE=es_SV:es_SV.UTF-8:es:en_GB:en
> LANG=es_SV.UTF-8
> SHELL=/bin/bash
> Tags: unity-2d natty
> Uname: Linux 3.0.0-0300rc7-generic i686
> UnreportableReason: The running kernel is not an Ubuntu kernel
> UpgradeStatus: Upgraded to natty on 2011-07-05 (26 days ago)
> UserGroups: adm admin audio cdrom fuse lpadmin netdev plugdev sambashare
> vboxusers video
> ---
> Architecture: i386
> DistroRelease: Ubuntu 11.04
> InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100224.1)
> Package: linux (not installed)
> ProcEnviron:
> LANGUAGE=es_SV:es_SV.UTF-8:es:en_GB:en
> LANG=es_SV.UTF-8
> SHELL=/bin/bash
> Tags: unity-2d natty
> Uname: Linux 3.0.0-0300rc7-generic i686
> UnreportableReason: The running kernel is not an Ubuntu kernel
> UpgradeStatus: Upgraded to natty on 2011-07-05 (26 days ago)
> UserGroups: adm admin audio cdrom fuse lpadmin netdev plugdev sambashare
> vboxusers video
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/linux/+bug/565543/+subscriptions
>

Seth Forshee ,

Your driver fixed my touchpad problem in ubuntu 11.04.
But after installing installing fresh ubuntu 11.10, the same comes
again...:(
My question is, can i use the same driver here in ubuntu 11.10 also..?

Thanks in advance..

--
Regards,
   . : D i X O N : .

Kent Baxley (kentb) wrote :

@Dixon,

You will have to re-apply the drive if you installed a fresh 11.10. The driver will work on that release.

Dixon Xavier (dixoncx) wrote :

@Kent Baxley,

Thanks for the response,
i will try it in ubuntu 11.10 ...
--
. : D i X O N : .

Dixon Xavier (dixoncx) wrote :

I installed driver 0.10 in Ubuntu 11.10 after upgrading dkms package.
my system: Sony Vaio VPCEH15

Working fine:
  horizontal scrolling
  vertical scrolling
  2 finger scrolling
  left button and
  right button

Thanks....!!!

And my " xinput list " command gives:
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer
(2)]
⎜ ↳ DualPoint Stick id=13 [slave pointer
(2)]
⎜ ↳ AlpsPS/2 ALPS DualPoint TouchPad id=14 [slave pointer
(2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard
(3)]
    ↳ Power Button id=6 [slave keyboard
(3)]
    ↳ Video Bus id=7 [slave keyboard
(3)]
    ↳ Sony Vaio Keys id=8 [slave keyboard
(3)]
    ↳ Power Button id=9 [slave keyboard
(3)]
    ↳ Sony Visual Communication Camer id=10 [slave keyboard
(3)]
    ↳ AT Translated Set 2 keyboard id=12 [slave keyboard
(3)]

DualPoint Stick & AlpsPS/2 ALPS DualPoint TouchPad ??
Is that anything to worry about ??

--
. : D i X O N : .

Seth Forshee (sforshee) wrote :

On Sat, Oct 22, 2011 at 03:23:50PM -0000, Dixon wrote:
> DualPoint Stick & AlpsPS/2 ALPS DualPoint TouchPad ??
> Is that anything to worry about ??

No, the ALPS driver always registers two devices, even when the
trackstick is not present. It won't cause any problems.

Richard B (rich-fatbunny) wrote :

Ubuntu 12.04 Precise Beta 2 (Linux sangheili 3.2.0-21-generic #34-Ubuntu SMP Fri Mar 30 04:25:35 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux), on a Sony VPCSA laptop. xinput reports the touchpad as a "ImPS/2 Generic Wheel Mouse".

Changed in linux:
status: Confirmed → Fix Released
Marcin (iim1) wrote :

I have the same bug on my Acer Aspire V3 771G:
I: Bus=0011 Vendor=0002 Product=0001 Version=0000
N: Name="PS/2 Generic Mouse"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input15
U: Uniq=
H: Handlers=mouse1 event15
B: PROP=0
B: EV=7
B: KEY=70000 0 0 0 0
B: REL=3
I use Ubuntu 13.04 with 3.8.0-23 kernel.

description: updated
Displaying first 40 and last 40 comments. View all 196 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.