Inkscape fails to start on Vista / Windows 7

Bug #453931 reported by Keiji on 2009-10-17
280
This bug affects 44 people
Affects Status Importance Assigned to Milestone
Inkscape
High
Unassigned

Bug Description

Whenever I try to start Inkscape 0.46 on my Windows 7 release candidate computer, it gives me this message after doing nothing for several seconds:

"The application was unable to start correctly (0xc0000005). Click OK to close the application."

During the several seconds it waits for, WerFault.exe can be found in Task Manager, but disappears before the error appears.

Killing WerFault.exe simply makes the error appear sooner.

Running the program as an administrator does not change anything.

This first happened a while ago, after which I restarted and it worked fine until today. However, this time, I restarted and it still happened, then I uninstalled Inkscape, removing personal preferences, redownloaded the installer and reinstalled and it still occurs.

Keiji (kei-teamikaria) on 2009-10-17
tags: added: crash startup win32
Keiji (kei-teamikaria) wrote :

I've worked around this today by running it on my XP computer instead of W7, which isn't a hassle at all, so I'd rather stick to that rather than using a non-stable version. However, I just opened it by accident on W7, and it opened normally this time. I really have no idea what causes this to happen or not happen.

~suv (suv-lp) on 2009-10-17
tags: removed: startup
MarkM (mmonica) wrote :

Experienced the same issue on the first release of Win 7. Worked, stopped working throwing the error mentioned and restart clears it.

irongamer (schoty) wrote :

OS: Windows 7 Home Premium (64bit)
CPU: Intel Core 2 Duo E8400
RAM: 4gb

Strange. I downloaded 0.47 from the inkscape front page two days ago and got the error:

"The application was unable to start correctly (0xc0000005). Click OK to close the application."

I tired running the application in various compatibility modes and as administrator. Also got the same error.
I do install all my applications to another drive so it is not in the program files area.

I looked around and found 0.46 on version tracker. 0.46 works but it does
randomly crash. It doesn't matter what tool I am using. I just make sure I save often.

irongamer (schoty) wrote :

I did a reinstall of 0.47: Inkscape 0.47 r22583, built Nov 21 2009
I installed it in a different folder but kept 0.46 on my system.

0.47 starts up fine now. The first install may have been bad or something.

Keiji (kei-teamikaria) wrote :

You probably know this already, but I found out the other day that 0xc0000005 is the Windows exit status for segmentation fault.

In other words, there's a segfault that sometimes happens on startup.

Alvin Penner (apenner) wrote :

    It may be worthwhile to try to trap the exit messages that are generated. This can be done in Windows using the utility program inkscapec.exe from :
http://kaioa.com/node/63
    You will need to run this from a DOS prompt in the same directory that Inkscape is in.

John R. Williams (jrw) wrote :

I had the same problem with Inkscape 0.46 and Inkscape 0.47 (r22583, built Nov 21 2009) while running Windows 7 x64. I had no trouble with 0.45. After I restarted Windows, 0.47 starts without any problems.

Tibi (tchampenier) wrote :

I’m currently having the same problem with Inkscape 0.47 and Windows 7 x64, it used to work just a few days ago.

Trying to open an svg file with inkview gives the same error.

inkscapec.exe gives no output to the console, the 0xc0000005 window pops up.
Any idea what else I could try to identify the problem while I have it? I’ll try not to reboot in the next days just in case.

I have tried and downloaded this daily build

   inkscapeR9303-1004092119.7z 09-Apr-2010 18:21

from http://inkscape.modevia.com/win32/?M=D

I have unpacked it in a user folder and looks like it's working

Win7x64 Pro

Jose Roberto Navas (coche) wrote :

Hi, I'm experiencing the same problem with Inkscape 0.47-3, so I tried to install the new 0.48pre1-1, but I get the same result:

"The application was unable to start correctly (0xc0000005). Click OK to close the application"

I'm using Windows 7 Home Premium 64-bit

Thanks for any help.

~suv (suv-lp) wrote :

Changing status to 'Confirmed' as per multiple confirmations in the comments and duplicates.

Changed in inkscape:
importance: Undecided → High
status: New → Confirmed
Jose Roberto Navas (coche) wrote :

Update: I started my computer today and I tried to start Inkscape, and now it works!! It seems pretty rare, but maybe the program needed a system restart.

I'm using Inkscape 0.48pre1-1 on Windows 7 Home Premium 64-bit

Thanks for your help guys!

Ove (ove-inkscape) wrote :

I had got the same error message on startup as well. I am running Inkscape-0.47-3 on win 7 pro 64. Additionally I saved a dump file after the crash using visual studio 2005 (however since this is a segfault error, the dump may be junk).

--
Ove

Ove (ove-inkscape) wrote :

Oh and one more detail. After inkscape crashes, process explorer shows this as the current stack:

zlib1.dll!zError+0x6e61
wow64cpu.dll!TurboDispatchJumpAddressEnd+0x690
wow64cpu.dll!TurboDispatchJumpAddressEnd+0x484
wow64.dll!Wow64SystemServiceEx+0x1ce
wow64.dll!Wow64LdrpInitialize+0x429
ntdll.dll!RtlResetRtlTranslations+0x1b08
ntdll.dll!RtlResetRtlTranslations+0xc63
ntdll.dll!LdrInitializeThunk+0xe
ntdll.dll!NtWaitForSingleObject+0x15
ntdll.dll!RtlReportException+0x86
ntdll.dll!LdrVerifyImageMatchesChecksum+0x663
ntdll.dll!RtlUlonglongByteSwap+0x4021
ntdll.dll!LdrInitializeThunk+0x10
ntdll.dll!RtlRestoreLastWin32Error+0x96c

Hopefully this is vaguely helpful.

iglooo101 (iglooo101) wrote :

O/S VISTA 32
INKSCAPE ver. 48.0

Uninstalled / Reinstalled a fresh copy, rebooted..it is back to normal again..
Picutres of the crash are in the duplicate Bug #624161

For me the fix was de-install Adobe Dreamweaver.

iglooo101 (iglooo101) wrote :

The only Adobe product installed is Adobe Reader9.
So, no software conflict here

~suv (suv-lp) on 2010-11-11
summary: - Inkscape fails to start on Windows 7
+ Inkscape fails to start on Vista / Windows 7
Martin Smith (martins-gmail) wrote :

Re the duplicate https://bugs.launchpad.net/inkscape/+bug/674139 ; a restart initially cleared the error message, but it is now happening again in Vista.

tx9515 (tx9515) wrote :

The same problem raised up for me, after installing Scribus 1.3.9 and, potentially more important, Ghostscript 9.0. Inkscape now crash on my Win 7 UIltimate with (0xc0000005) as in topicstarter situation. Reinstalling Inkscape (0.48-1), after removing Ghostscript and Scribus didn't helps. I've found someone with the same problem on mac (http://www.inkscapeforum.com/viewtopic.php?f=29&t=3485), he have Inkscape crash after installing Ghostscript too...

~suv (suv-lp) wrote :

@tx9515 - the old issue with Ghostscript installed via MacPorts and Inkscape 0.46-2 and 0.47-pre1 on OS X Leopard that you refer to is completely unrelated to your problem and this report (bug #453931). Try rebooting your system once or two times - most users report that Inkscape starts without error after that.

tx9515 (tx9515) wrote :

@~suv — this looks weird, but reboot helped. Thank you! =)

On my win7 pro 64-bit, this reliably happens on every launch. The error occurs while inkscape starts, I never see the application window. I tried both the stable 0.48 and the very latest bleeding edge build inkscape_R9983-1012261236.

In the bleeding edge build, I tried gdb and see the following:

C:\Users\Ross\Documents\Random\inkscape\inkscape_R9983-1012261236\inkscape>gdb inkscape
GNU gdb 6.8
Copyright (C) 2008 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-pc-mingw32"...
(no debugging symbols found)
(gdb) symbol-file inkscape.dbg
Reading symbols from C:\Users\Ross\Documents\Random\inkscape\inkscape_R9983-1012261236\inkscape/inkscape.dbg...done.
(gdb) run
Starting program: C:\Users\Ross\Documents\Random\inkscape\inkscape_R9983-1012261236\inkscape/inkscape.exe
[New thread 5392.0xd90]
Error: dll starting at 0x77300000 not found.
Error: dll starting at 0x76b40000 not found.
Error: dll starting at 0x77300000 not found.
Error: dll starting at 0x77420000 not found.

Program received signal SIGSEGV, Segmentation fault.
0x8fdf0000 in ?? ()
(gdb)

I also ran DEPENDS.EXE over it, and used its profile mechanism to log all DLL loads. Most of that log is the routine of loading the large number of referenced DLLS, but at the end it shows:

Entrypoint reached. All implicit modules have been loaded.
LoadLibraryA("gdi32.dll") called from "c:\windows\syswow64\USP10.DLL" at address 0x75A96890.
LoadLibraryA("gdi32.dll") returned 0x77080000.
LoadLibraryA("KERNEL32.DLL") called from "c:\users\ross\documents\random\inkscape\inkscape_r9983-1012261236\inkscape\PTHREADGC2.DLL" at address 0x611837E6.
LoadLibraryA("KERNEL32.DLL") returned 0x76B40000.
LoadLibraryA("QUSEREX.DLL") called from "c:\users\ross\documents\random\inkscape\inkscape_r9983-1012261236\inkscape\PTHREADGC2.DLL" at address 0x61183823.
LoadLibraryA("QUSEREX.DLL") returned NULL. Error: The specified module could not be found (126).
Second chance exception 0xC0000005 (Access Violation) occurred at address 0x8FD70000.
Exited "c:\users\ross\documents\random\inkscape\inkscape_r9983-1012261236\inkscape\INKSCAPE.EXE" (process 0x1674) with code -1073741819 (0xC0000005).

From this, it seems like PThreads is implicated, but I haven't had a chance to pursue it further.

John Horner (jmhorner) wrote :

I agree with the comments above, downloading it twice and I have that message coming up say click ok to close

Changed in inkscape:
status: Confirmed → New
~suv (suv-lp) on 2011-01-21
Changed in inkscape:
status: New → Confirmed

I no longer have this issue. Between the last time I checked for it and today, a fair amount of other software has been updated (including all the usual windows updates), so it is difficult to pinpoint a specific cause. That said, the one thing I have not updated in the mean time is Inkscape itself. I just verified that both the stable 0.48 and developer 0.48 I tried in January now launch without issue.

I'm happy now, but that still leaves the mystery of what changed since January, and why it mattered this severely.

xtempore (jbriden) wrote :

I've been getting this problem on Windows Vista.

After reading a few comments, I decided just to try uninstalling/reinstalling.

I downloaded the latest build and tried to install that. It seemed to successfully remove the previous installation, but then when it tried to install it could not replace inkscape.exe.

I looked in Task Manager and although the InkScape application was not shown as running (just the installer was), I found 4 processes running inkscape.exe. After killing the processes I was able to retry the install.

The bug has gone (at least for now).

The fact that there were processes in memory running inkscape.exe, would possibly explain why some people find that rebooting makes the problem go away. (because that clears out all the extra processes)

It may mean that inkscape is sometimes staying in memory after certain events, and this is what causes this behaviour.

Hope that helps.

Geoff McDonald (glmcdona) wrote :
Download full text (11.6 KiB)

I have the exact same problem as Ross Berteig on Vista 32 bit. My Inkscape was working fine for months until today. I uninstalled my avast antivirus yesterday and this is likely the cause. It seems the code is being built for fixed dll load offsets.

I tried reinstalling with the latest stable version and installed the bleeding edge version. I believe this could be something like a compilation mode error, because it appears that the liblcms-1.dll is not using dynamic linking properly. Typically when compiled in release mode I thought dlls were allowed to be loaded at any address, but the code in liblcms-1.dll is specifically expecting a dll to be loaded at a specified address (but the dll is not loaded at that address!).

Here is some debugging information for the inkscape_r10115-201103191533

Exception occurs at:
0x25118E (liblcms-s.dll + 0x118E): CALL 0x8FC90000 <- Address 0x8FC90000 is unallocated and causes and access violation.

Here is the assembly in the area around this instruction:
00251170 55 PUSH EBP
00251171 B8 0000C98F MOV EAX,8FC90000
00251176 89E5 MOV EBP,ESP
00251178 83EC 08 SUB ESP,8
0025117B 85C0 TEST EAX,EAX
0025117D 74 14 JE SHORT liblcms-.00251193
0025117F C74424 04 20F027>MOV DWORD PTR SS:[ESP+4],liblcms-.0027F0>
00251187 C70424 00E52700 MOV DWORD PTR SS:[ESP],liblcms-.0027E500
0025118E E8 6DEEA38F CALL 8FC90000
00251193 A1 90AB2700 MOV EAX,DWORD PTR DS:[27AB90]
00251198 85C0 TEST EAX,EAX
0025119A 74 3A JE SHORT liblcms-.002511D6
0025119C C70424 00B02700 MOV DWORD PTR SS:[ESP],liblcms-.0027B000 ; ASCII "libgcj_s.dll"
002511A3 E8 F88A0200 CALL <JMP.&KERNEL32.GetModuleHandleA>
002511A8 BA 0000C98F MOV EDX,8FC90000
002511AD 83EC 04 SUB ESP,4
002511B0 85C0 TEST EAX,EAX
002511B2 74 15 JE SHORT liblcms-.002511C9
002511B4 C74424 04 0DB027>MOV DWORD PTR SS:[ESP+4],liblcms-.0027B0>; ASCII "_Jv_RegisterClasses"
002511BC 890424 MOV DWORD PTR SS:[ESP],EAX
002511BF E8 EC8A0200 CALL <JMP.&KERNEL32.GetProcAddress>
002511C4 83EC 08 SUB ESP,8
002511C7 89C2 MOV EDX,EAX
002511C9 85D2 TEST EDX,EDX
002511CB 74 09 JE SHORT liblcms-.002511D6
002511CD C70424 90AB2700 MOV DWORD PTR SS:[ESP],liblcms-.0027AB90
002511D4 FFD2 CALL EDX
002511D6 C9 LEAVE
002511D7 C3 RETN

Here is a stack trace at the exception time:
0022F9D8 00251193 RETURN to liblcms-.00251193 from 8FC90000
0022F9DC 0027E500 liblcms-.0027E500
0022F9E0 0027F020 liblcms-.0027F020
0022F9E4 /0022FA04
0022F9E8 |0025125E RETURN to liblcms-.0025125E from liblcms-.00251170
0022F9EC |01220000
0022F9F0 |40000060
0022F9F4 |00000080
0022F9F8 |0022FAF4
0022F9FC |00000001
0022FA00 |00000001
0022FA04 ]0022FA24
0022FA08 |002510E1 RETURN to liblcms-.002510E1 from liblcms-.00251230
0022FA0C |00000080
0022FA10 |0022FA38
0022FA14 |012443D8
0022FA18 |0022FA3C
0022FA1C |00000001
0022FA20 |0022FA38
0022FA24 ]0022FA44
0022FA28 |76F413B4 RETURN to ntdll.76F413B4
0022FA2C |00250000 ...

I've just developed this problem. Inkscape has been running fine on Windows 7 for me until today, but it's picked up this bug. The only factor I can think of is a whole new swag of updates the thing picked up. Maybe something in the update clashed with Inkscape?

ScislaC (scislac) wrote :

Would someone who reliably experiences this be willing to try the following build?
http://inkscape.modevia.com/win32/inkscape_r10256-201106051123.7z

You will need 7zip to extract it. http://www.7-zip.org

Just extract it to some directory other than your installed version and run inkscape.exe.

Martin Smith (martins-gmail) wrote :

For what it's worth, the build is working well for me on Vista. However, it's been a while since I've encountered the problem with the latest version.

Chua Wen Ching (chuawenching) wrote :

I tried to install the latest inkscape on windows 7 32 bits and got the error

---------------------------
inkscape.exe - Application Error
---------------------------
The application was unable to start correctly (0xc0000005). Click OK to close the application.
---------------------------
OK
---------------------------

Any help to resolve this? Thanks.

ScislaC (scislac) wrote :

Chua: Latest stable or latest nightly?

Chua Wen Ching (chuawenching) wrote :

is alright, after a restart it works fine already :) thanks anyway :)

Kirk Cooper (enoted) wrote :

If people are having problems with the release version 7600 of Windows 7, then this is quite common with tons of other software titles. But as soon as newer versions arrived, fewer problems arose. Although I have release version 7600 I only experienced strange memories issues, But I have a newer version and no hassles,

andrew k (andruu-k) wrote :

im having the same problem, ive tried administator, compatibility mode and reinstall.. i cant seem to access the latest builds, the links above dont work for me. does anyone have a link to the latest build ?

many thanks

~suv (suv-lp) wrote :

andrew k wrote:
> ive tried administator, compatibility mode and reinstall..

Try the steps described in this comment:
 <https://bugs.launchpad.net/inkscape/+bug/769894/comments/1>
from duplicate bug #769894 and report back whether Inkscape launched correctly after a complete shutdown/reboot of your computer.

Will Stanley (c-wkll-e) wrote :

Used inkscape for the first time yesterday - found it great of editing SVG files.
Now (next day) I get this same issue. Have you worked out root cause yet?

I've taken a full minidump at first chance access_denied if it helps; although I'm guessing this is easily reproducible looking at this thread? Can send over if helpful...
Stack at fault (no sym/source):

0:000:x86> kvn
*** ERROR: Symbol file could not be found. Defaulted to export symbols for C:\Program Files (x86)\Inkscape\liblcms-1.dll -
 # ChildEBP RetAddr Args to Child
WARNING: Frame IP not in any known module. Following frames may be wrong.
00 0028f9cc 003c1193 003ee500 003ef020 0028f9fc 0x8fe00000
01 0028f9dc 003c125e 01de0000 40000060 00000080 liblcms_1+0x1193
02 0028f9fc 003c10e1 00000080 0028fa30 01127aa0 liblcms_1+0x125e
03 0028fa1c 76f79930 003c0000 00000001 0028fd24 liblcms_1+0x10e1
04 0028fa3c 76f7d8a9 003c1060 003c0000 00000001 ntdll32!LdrpCallInitRoutine+0x14
05 0028fb30 76f92120 0028fd24 7efdd000 7efde000 ntdll32!LdrpRunInitializeRoutines+0x26f (FPO: [Non-Fpo])
06 0028fcb0 76f90bda 0028fd24 76f40000 7708fe5d ntdll32!LdrpInitializeProcess+0x1400 (FPO: [Non-Fpo])
07 0028fd00 76f79e59 0028fd24 76f40000 00000000 ntdll32!_LdrpInitialize+0x78 (FPO: [Non-Fpo])
08 0028fd10 00000000 0028fd24 76f40000 00000000 ntdll32!LdrInitializeThunk+0x10 (FPO: [Non-Fpo])

Jon Kloske (4fg-jon-50e) wrote :

definitely toast.

(gdb) file inkscape.exe inkscape.dbg
Reading symbols from c:\Program Files (x86)\Inkscape/inkscape.exe...(no debugging symbols found)...done.
Reading symbols from c:\Program Files (x86)\Inkscape/inkscape.dbg...done.
(gdb) run
Starting program: c:\Program Files (x86)\Inkscape/inkscape.exe
[New thread 5744.0x11d8]
Error: dll starting at 0x76db0000 not found.
Error: dll starting at 0x768d0000 not found.
Error: dll starting at 0x76db0000 not found.
Error: dll starting at 0x76ed0000 not found.

Program received signal SIGSEGV, Segmentation fault.
0x90b50000 in ?? ()
(gdb) bt
#0 0x90b50000 in ?? ()
#1 0x01111193 in virtual thunk to Inkscape::XML::SimpleNode::next() const () from c:\Program Files (x86)\Inkscape\liblcms-1.dll
#2 0x0113e500 in virtual thunk to Inkscape::XML::SimpleNode::next() const () from c:\Program Files (x86)\Inkscape\liblcms-1.dll
#3 0x0113f020 in virtual thunk to Inkscape::XML::SimpleNode::next() const () from c:\Program Files (x86)\Inkscape\liblcms-1.dll
#4 0x0028f9fc in ?? ()
#5 0x0111125e in virtual thunk to Inkscape::XML::SimpleNode::next() const () from c:\Program Files (x86)\Inkscape\liblcms-1.dll
#6 0x01180000 in virtual thunk to Inkscape::XML::SimpleNode::next() const ()
#7 0x40000060 in ?? ()
#8 0x00000080 in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)
(gdb)

Hi everyone,

I experienced this bug today, as well (running Windows 7 64bit).
But neither did I need to restart nor did I have to reinstall to be able to launch Inkscape again.

When the error occurred (and it was reproducible each time) the other applications running where Microsoft Outlook 2007, Mozilla Firefox 9.0.1 and Microsoft Visual Studio 2008.

I then closed all applications because I wanted to do a reboot to solve the problem (as mentioned above).
Just before I clicked 'reboot', I decided to give it another try - and voilà Inkscape started right away.

Unfortunately, by closing Inkscape and restarting the applications and then starting Inkscape again I could not yet trigger the segfault again. Inkscape starts up fine.

Even if these pieces of information might not be very helpful I wanted to share them with you. Maybe anyone can make sense of this. Perhaps it is some sort of "library conflict" (i.e. another application uses one of the libraries inkscape needs and something goes wrong) ? But that is just a long shot...

Cheers

Tobias

Ktron (kevin-hamer) wrote :

This issue started happening to me recently and I couldn't figure out why, but I think I have: Firefox.

I can cause this error 100% of the time if Firefox is running on my system, and Inkscape starts normally if Firefox is not open. I can have lots of other programs open-- Chrome, mumble, Pidgin, GIMP, etc.-- and Inkscape starts normally, but if Firefox is running first it will not open. I can start Firefox second and both seem to work correctly.

Jose Roberto Navas (coche) wrote :

I'm agree with Ktron,
I also have noticed that if I have already open Firefox, then Inkscape often fails to start.

Not to downplay kevin-hamer or coche, I feel I should mention something so we do not bark up the wrong tree. I do not have Firefox installed on this installation of Windows 7 and I still encounter the problem sporadically.
I'm encountering it right now, I have the following programs running (in the foreground atleast).
* Explorer (shell extensions: TortoiseSVN, 7Zip, gVim)
* gTalk
* Outlook
* Microsoft Office Communicator
* VirtuaWin (for ALT window movement)
* Chrome
* Visual Studio 2010
* Process Explorer
* Sidebar (desktop widgets)
* Java Update Scheduler
* A couple of headless VirtualBox instances.

As far as I recall, I don't think any of that (except maybe virtual box, TortoiseSVN, and gVim) uses GTK+...

Phil Wise (philip-wise) wrote :

I hit the same problem today.

I was using Inkscape 0.47+devel r9596. When I hit the issue I upgraded to the latest version, Inkscape 0.48.2 r9819.

Both versions hit the 0xC0000005 error every time, but shutting down and restarting windows fixed the issue.

Before the reboot I captured a couple of minidumps using WinDBG. They were taken at the Second Chance exception handler breakpoint.

A dump taken with the windbg command ".dump /mhit" is attached. The dump with everything ".dump /ma" is 75Mb so I haven't included it here. I'm happy to upload it if it would be useful.

Hugh (gamehaxe) wrote :

This crash just started happening to me every time (without changing the inkscape install).
Then I replaced liblcms-1.dll with the one found at http://cue.yellowmagic.info/softwares/separate-plus/index.html and it now works.
I noticed when I attached the MS debugger that there was a little warning that it did not load this dll at the default location, so some other install/security fix may have changed this and indirectly caused the problem.

Jaspervdg (jaspervdg) wrote :

I just read a trick somewhere for how to force relocation of a dll: load a second copy (with a different name). I'm not sure this would work when linking statically (because of finding the same symbols twice), but it might work when loading it at run-time. If this works then it would allow testing whether dll relocation is what is causing the problem. (I won't get around to trying this until friday at the earliest, so if someone else wants to try this, be my guest.)

Jaspervdg (jaspervdg) wrote :

Interestingly, trying to load a second (renamed) copy of liblcms indeed fails (without a crash, but that's probably due to the use of LoadLibrary vs. "normal" dll loading), while several other dll's show no problems when being loaded twice. Also, the version of liblcms that Hugh pointed to above does not show this problem. So perhaps there is something wrong with the way our liblcms was compiled or something. I'll see if anyone on the mailing list objects to exchanging our liblcms for the one Hugh pointed to (or simply compiling a new version ourselves).

Chris König (chriskoenig) wrote :

Hi, guys,
I can herewith confrom the above said: on Win7 64bit a restart will do (latest build 048.2). Funny though: yesterday evening I installed the latest build on my notebook and it would start IS without any trouble after installation, no need to reboot - same OS, different computer. Funny, hm? Greetings from Germany, Chris

Chris König (chriskoenig) wrote :

Oops, I meant to say CONFIRM, not CONFROM... CK

FriendFX (friendfx) wrote :

This bug just came up again, while Inkscape used to start fine before. Here some version info:
Inkscape 0.48.2 r9819
Windows 7 Professional SP1, 64-bit

One commenter above stated that other currently running apps might cause the problem, which I hereby confirm:
1. closed Firefox, after which Inkscape still didn't start
2. Closed Outlook 2007 (12.0.6562.5003) SP2 MSO (12.0.6562.5003)

Step 2 did it for me, I could start Inkscape. Also, closed Inkscape, I re-started Outlook and was able to start Inkscape again.

AK (akidess) wrote :

This bug made me unable to run Inkscape 0.48.2 (Win7 HP 64bit, fully patched) even after closing Outlook 2010, and Firefox is not installed on my system. I just downloaded an Inkscape nightly 0.48-develr11656 and Inkscape seems to run normally. I suggest everyone affected by the bug to try the nightly.

Derrick Coetzee (o-dc) wrote :

I encountered this failure with the following info on Inkscape 0.48.2-1 on Windows 7 Pro x64. I installed the 0.48.3.1-2 build instead without rebooting but this did not resolve the problem. Changing the path also didn't help. I haven't tried rebooting yet.

----

Problem signature:
  Problem Event Name: APPCRASH
  Application Name: inkscape.exe
  Application Version: 0.48.1.0
  Application Timestamp: 4e4844be
  Fault Module Name: StackHash_4c0d
  Fault Module Version: 0.0.0.0
  Fault Module Timestamp: 00000000
  Exception Code: c0000005
  Exception Offset: 90b50000
  OS Version: 6.1.7601.2.1.0.256.48
  Locale ID: 1033
  Additional Information 1: 4c0d
  Additional Information 2: 4c0d4d78887f76d971d5d00f1f20a433
  Additional Information 3: 4c0d
  Additional Information 4: 4c0d4d78887f76d971d5d00f1f20a433

Read our privacy statement online:
  http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
  C:\Windows\system32\en-US\erofflps.txt

Jaspervdg (jaspervdg) wrote :

Could you please try the fix suggested in post 44 (by Hugh (gamehaxe))?

Vegar Guldal (vegarg) wrote :

I also had the same problem. After I tried the solution suggested in post 44, Inkscape now starts normally. Thanks Hugh.

Jaspervdg (jaspervdg) wrote :

I have replaced liblcms in devlibs with a freshly compiled version that does not seem to suffer from the same problem. Hopefully this means this bug will be fixed in the next release. In the mean time, the dll can be downloaded from (or see post 44):
http://bazaar.launchpad.net/~inkscape.dev/inkscape-devlibs/trunk/download/head:/liblcms1.dll-20100115235938-919t8q32w8ep3n7w-74/liblcms-1.dll

My computer just upgraded yesterday from XP to 7, and after inkscape installation, I was unable to launch it, with same error message as described here.
I replaced liblcms in inkscape directory, as explained in comment #44 and I confirm it works fine.
Thanks for this workaround.

#44
@Hugh (gamehaxe)

Thank you for your comment. It helped me a lot. This one sugestion heplped me fixing InkScape

I get the same problem as descrbed

Thumb Up

Kai (kaik) wrote :

I suddenly (from one day to another) had the same problem.

For me it works to close "FreeCommander" (www.freecommander.com), no restart necessary, no dll replacement necessary

Win 7, 64bit, Inkscape 0.48.2 r9819 Portable

absolin (absolin) wrote :

#44
@Hugh (gamehaxe)

Your solution worked, thanks!!

W7-64
Inkscape.exe throws "The application was unable to start correctly (0xc0000005). Click OK to close the application."

Fixed by Hugh's: "Then I replaced liblcms-1.dll with the one found at http://cue.yellowmagic.info/softwares/separate-plus/index.html and it now works."

jazzynico (jazzynico) wrote :

Could someone confirm the latest stable version (0.48.4, see http://inkscape.org/download/) fixes the issue?
It uses an updated version of the liblcms dll and thus should work as expected.

rickmastfan67 (rickmastfan67) wrote :

Well, I'm running 0.48.4 on W7 x64, and haven't had it crash yet. Sometimes I've gone 4+ months without it showing up. My guess is that you might have to wait at least 6 months of no crashes reported to say this bug has been fixed to be honest.

#59 JazzyNico: Unfortunatelly I have to confirm it (Inkscape 0.48.4, Windows 7 Pro, 64bit) again. I have tried switching liblcms libraries from various sources incl. the trunk one (and also a latest devel binaries of Inkscape) with no luck. Older stable binaries have the same problem too.

One thing that might help narrowing the problem - 0.48.4 works for me at one PC with Win7 Home Premium 64bit.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers