BAMF Application Matching Framework

Libreoffice and unity integration broken.

Reported by Lukasz Olszewski on 2011-09-06
This bug affects 284 people
Affects Status Importance Assigned to Milestone
BAMF
High
Marco Trevisan (Treviño)
Unity
Undecided
Unassigned
Unity Distro Priority
Undecided
Unassigned
bamf (Ubuntu)
High
Marco Trevisan (Treviño)
Oneiric
High
Unassigned
Quantal
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

SRU TESTCASE
1 Enable the splash screen in libreoffice
2 Launch libreoffice double-cliking on a lo file
3 Repeat this action multiple times and the bug should manifest.
4 Now install bamf from oneiric proposed and the repeat the above steps
5 The issue wont appear

When I open an existing file with lets say oowriter or oocalc it's icon isn't listed in unity panel as a running app. Window controls and window title isn't shown on a top panel either (see attached screenshot). Empty-staring these app's doesn't rise this issue. Sometimes after fresh boot this problem doesn't occur but it's usually pretty soon back after opening few existing files.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity 4.12.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,imgjpeg,decor,compiztoolbox,regex,move,winrules,place,imgpng,mousepoll,resize,grid,vpswitch,gnomecompat,session,animation,wall,unitymtgrabhandles,workarounds,wobbly,fade,thumbnail,expo,scale,scaleaddon,unityshell]
Date: Tue Sep 6 13:02:31 2011
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
SourcePackage: unity
UpgradeStatus: Upgraded to oneiric on 2011-08-28 (8 days ago)

Oh and one more thing - Alt+Tab window switcher doesn't see those broken windows either... As this doesn't happen every time I open files with libreoffice , I'll try to investigate further but hopefully someone else already had.

Not sure if this is related but i get the following message when starting from command line:
Warning: failed to launch javaldx - java may not fuction correctly

Omer Akram (om26er) wrote :

a similar bug was fixed last cycle it seems now its back again, it does not happen all the times but it happens. bug 662280

Thanks for confirmation Omer.

Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
status: New → Confirmed
tags: added: regression-release
Omer Akram (om26er) on 2011-09-22
Changed in bamf:
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in bamf:
status: New → Confirmed
Changed in unity:
importance: Undecided → Medium

I'll add little note: the windows controls also don't appear in the unity panel. You need to use the menu File to exit the application

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bamf (Ubuntu):
status: New → Confirmed

I have provided some more information in bug 842566, duplicated to this one. Now I attach a video on something I believe related but where the user looses all control over the Libreoffice window, and the only way of closing it is by killing the soffice process. I can reproduce this (and the other issues mentioned in this report) consistently with the file attached to bug 842566.

Aritchie (aritchie) wrote :

I have noticed that with LibreOffice 3.4.3 and the latest build of Oneiric Ocelot this occurring when I first start writer or calc. The controls, menu and title are not drawn until I clcik and give the focus to another window and than click back on writer - then everything works fine. Strange - Empathy behaved this way when I was running 11.04. Empathy now does not do this with 11.10 beta 2 with unity-2d but now LibreOffice now does it.

Didier Roche (didrocks) on 2011-10-03
Changed in unity-2d:
status: New → Confirmed
Changed in unity-2d:
importance: Undecided → Medium

it happens also in Ubuntu 11.10

Aritchie (aritchie) wrote :

Yes, when I open a document associated with one of the libreoffice apps it does export the titlebar, controls just fine to the panel. It does not; however, do it when I open up - say writer directly with a blank document. It seems like it only exports when you open an existing document from within nautilus.

One other thing worth mentioning is that only a window opened as the first is broken. So if I open lets say odt or ods document and then another one then only the first one isn't integrated with unity and the second one is.

Xavier Guillot (valeryan-24) wrote :

Hello,

I have similar problems, I think this is related to the same bug :

Sometimes, even if a LibreOffice document is opened, there is no icon in Unity dock - or, if I configured some LO icons to stay on dock, none is marked as opened with the left white triangle.

Other times, there is the white icon of Libre Office which "replaces" the Calc / Writer icon.

Other strange behavior, sometimes there is no "close", "minimize", "maximize" buttons on the menu bar, when I close all other program windows there can be a LibreOffice document still opened, I can modify it, work on it, save it thanks the buttons bars in LO, but not close it...

Happens both on Natty with LibreOffice 3.3.4 and Oneiric with LO 3.4.3

Please see the following screenshots to understand. First one with blank LinreOffice icon in dock instead of Impress one.

Xavier Guillot (valeryan-24) wrote :

A Calc document is opened, no white triangle on Unity dock on Calc icon, if I click on it, instead of going back to my document, it opens an empty ods new file. No other icon (not the blank one this time...).

Xavier Guillot (valeryan-24) wrote :

All windows, except of LibreOffice, closed, I can work on the document but no global menu - this is the Desktop one, no icon in dock, no way to close or minimize the document, it stays in foreground (this screenshot is in Natty with LO 3.3.4), previous one in Oneiric with 3.4.3)...

Krzysztof Nowak (novacellus) wrote :

As for now installing 'lo-menubar' package (sudo apt-get install lo-menubar) did the trick for me.

Lucazade (lucazade) wrote :

'lo-menubar' unfortunately doesn't help here, I always missing menubar and window control buttons.
I need to focus out and focus back libreoffice window get these appearing in the panel.

thomas (thomas-heuer) on 2011-10-20
tags: removed: amd64
neuromancer (neuromancer) wrote :

A workaround to have windows control and title in Unity top panel is to install the package lo-menubar (https://launchpad.net/lo-menubar), available in the Ubuntu Software Center for natty, oneiric and precise.

Aibara Iduas (aibaraiduas) wrote :

Installing lo-menubar isn't a workaround on Oneiric - Libreoffice can still break. In fact, it makes things a bit worse, since when it does the menu is totally hidden and you can't close it without knowing the keyboard shortcut to do so.

Peter Harvey (pdqharvey) wrote :

MS v. OpenDocument filetypes (with workaround):

I find that behaviour is different for .ods and .xls / .xlt files

I can confirm Xavier Guillot's experience (post 1). Here are some detailed observations of my own - all involving LO 3.4.3, CALC, on Oneiric 64bit, Unity 3D. These relate to applications listed as running in both the Application Switcher (and the instances of their open files) and the Unity Launcher

In GENERAL (there could be exceptions):
1) MS .xls and .xlt file types are usually shown correctly, with GREEN CALC icon

2) Open Document .ods files are almost always identified by a general WHITE (general) LibreOffice icon (v occasionally by the green icon, which is correct). They rarely show up at all *when opened first* (before any other LO document). IF one does, it is when the file is opened very shortly (less than 10s or so) after closing the last LO document - i.e. before the application has completely closed.

3) if an .xls or .xlt file is already open, an .ods file has a hugely increased chance of being shown, but always(?) under a WHITE LibreOffice icon

4) When an .ods document is not listed at all, both the window buttons and title are missing from the menu bar.

Further tests show that LO WRITER documents follow a similar pattern (.doc = good, .odt = bad), although the application (IF listed) is always shown as the BLUE icon, rather than the general white one.

Apologies for tedious detail, but I hope this helps point someone towards a solution.

WORKAROUNDS:
1) You can get to an unlisted file using super+W, and close it with alt+F4, Ctrl+Q or through the file menu.

and finally...
2) If I am right about .xls and .doc files get listed correctly, the (temporary) solution is to use MS rather than native Open Document filetypes.

Peter Harvey (pdqharvey) wrote :

Disappointed footnote to my post above:

CORRECTION!
Despite that all being the case earlier this morning, ALL LO documents (MS or OpenDoc.) now fail to appear in the App Switcher and the Unity Launcher. Sorry about that. All very frustrating...

Michael Villet (mvillet) wrote :

Running Ubuntu 11.10 64-bit, I find the following consistent behaviors for LibreOffice Writer 3.4.3. I do not by default have a LibreOffice icon on the Unity launcher. The second use case I describe creates a particularly severe usability problem, because an open document becomes completely inaccessible to the Unity launcher and Alt-Tab interface.

Open new instance of LibreOffice writer via Dash:
Writer icon appears on Launcher as it should. However, when I open a .odt document (or write into the blank document and then save it), the system continues to show "Untitled 1" on top of the window menubar. Menus (File, Edit etc.) appear in the document window; the global menu displays "LibreOffice Writer" but mouseover does not reveal any menus. If I maximize and then de-maximize, the correct document title appears in the window menubar, but menus are still in the window. While maximized, the menus appear beneath the global menubar; mousing over the global menus reveals only the close/minimize/de-maximize buttons.

Open a .odt document via Dash search:
Writer icon does not appear on Launcher, and the Writer window does not appear on Alt-Tab! Document window menubar displays "LibreOffice 3.4" instead of document name. Global menubar shows Desktop menu options upon mouseover, but does not say "Desktop." After first maximization, global menubar continues this behavior - no minimize, etc. buttons are available for Writer, only Desktop menus are accessible. After de-maximization (by dragging), correct document title appears in window menubar. After the first de-maximization, the global menubar becomes completely dead, showing no text, buttons or menus with or without mouseover. This is true even if the window is maximized again. If a fresh instance of Writer is opened via the Dash, the directly-opened document window remains inaccessible/invisible via Alt-Tab or the Launcher.

This latter case is very troublesome because the invisibility of these open documents to the Unity interface makes multitasking almost impossible. Furthermore, if the documents are minimized, they are essentially inaccessible from then on!

@Michael: I think the first issue you describe is simply the lack of global menu integration for LibreOffice. There is a package "lo-menubar" in the archives, which will install a preliminary LO-addon which will integrate the menu into the global menu. But it seems not to be ready for default inclusion.

The second issue is what this bug report is really about. It makes some LO windows unaccessible, except for Super+W scale mode. This also affects the usability of the global menu integration: I once tried out lo-menubar, and it worked quite well. But if Unity "looses" a LO window, its menu will also not appear in the global menu, and thus there is no way even to close the document. If the menu is displayed in the window (no global menu integration), it will at least stay accessible, even when Unity does not handle it.

All the same here. Opening a file from Thunderbird causes the same issue, while you if you open from the app launcher the app directly and then the file, is all well.

Hey guys:
http://ubuntuforums.org/showthread.php?p=11417570#post11417570

Could be related to regex matching of the window name ! When you open certain files in read-only mode, LibreOffice append a "(read only)" string somewhere in the title, it could mess up the matching of the task manager of Unity. Hope is useful to fix the bug ! Is really very annoying, and affecting a lot of people that are not posting on Launchpad.

Simone,
This can't be the only cause. I can open the same file exactly the same
way and in the same circumstances I might get this error and I might
not. So it seems to be more random and unrelated to any obvious
circumstances.

Steffen Sindzinski (stesind) wrote :

I have this behavior always with the writer.

capricorn (ubuntuuser82) wrote :

I like to and also have to use unity-2d and one of the most annoying bugs is the persistently missing titlebar in any of the libreoffice apps unless you switch between windows. I found the following workaround: When starting libreoffice with the --nologo option, the titlebar always seems to appear. So I modified the launchers... Can the logo be part of the problem?

Colin Law (colin-law) wrote :

I think the missing controls when libreoffice is started up in full screen mode on Unity-2D may be a different bug, as it is only seen (for me at least) on 2d. I have added it to bug #886606 (Some apps show no menu in panel until click away and back). Others seeing this might like to attach themselves to that bug in order to confirm it.

Reece H. Dunn (msclrhd-gmail) wrote :

0. Pin libreoffice calc to the unity launcher side bar.
1. Open a nautilus instance.
2. Navigate to a location containing an ods spreadsheet.
3. Double click on the ods spreadsheet to launch libreoffice calc.
4. Press Alt+Tab to switch between applications.

NOTE: libreoffice calc does not appear in the task switcher.

5. Move the mouse to the far left to open the lask launcher.

NOTE: libreoffice calc in the launcher does not indicate that it has an
instance running.

6. Select libreoffice calc in the launcher.
7. Press Alt+Tab to switch between applications.

NOTE: The libreoffice calc instance from (6) appears in the task
switcher, but the one from (3) does not.

8. Move the mouse to the far left to open the lask launcher.

NOTE: Only one calc instance is highlighted (a white arrow instead of
two dots).

9. Alt+Tab to the calc instance.

NOTE: Both windows become visible -- only the selected instance should
become visible.

10. Minimize the instance opened in (3).
11. Select the full-screen nautilus window.
12. Alt+Tab to the calc window.

NOTE: Only the calc instance in (6) is displayed.

13. Select the document opened from (3) in the "Recent Documents" menu
of the calc instance opened in (6).

NOTE: The calc instance from (3) is focused, but is not present in the
unity launcher or task switcher (4-5).

Changed in unity-2d:
importance: Medium → High
David Barth (dbarth) on 2011-11-10
Changed in unity:
milestone: none → 4.26.0
Glennz nl (glenn-de-groot) wrote :

My friend (Unity) and me (Unity-2D) both have this with a fully updated Ubuntu 11.10.

Omer Akram (om26er) wrote :

Libreoffice is a core application in the Ubuntu desktop, its integration with Ubuntu have been in this form since 11.04 so I raised the priority to High. As I believe its something we would not want to miss for the LTS and hopefully backport to the stable releases as well.

Changed in bamf:
importance: Medium → High
Changed in bamf (Ubuntu):
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Medium → High
Changed in unity:
importance: Medium → High

This bug is very, very high if not critical.

In my experiencie, Is very dificul to replicate because it happen in all use cases but one, when i open a document from within LO,(Crtl-A or File-> Open) this doesn't happen and file (Open document format or MS format) open correctly

i hope this help

Achim Behrens (k1l) wrote :

I opened a .odt file and everything works as it should. Closed it and reopened it again (again by doubleclick on the text.odt) the document opens in libreoffice writer but doesnt apear in the launcher sidebar or in the (alt+tab).

Fully updated 11.10

Gerry Boland (gerboland) on 2011-11-19
Changed in unity-2d:
milestone: none → 5.2
Didier Roche (didrocks) on 2011-11-23
Changed in unity-distro-priority:
status: New → Fix Committed
Robert (baumgaro) wrote :

installing 'lo-menubar' package (sudo apt-get install lo-menubar) and a restart did the trick for me (until now).

Chascon (chascone) wrote :

As someone mentioned lo-menubar doesn't work. I can confirm that it isn't reliable, because it work about half the time I try to use it.

Mario S. (sm666) wrote :

very strange: libreoffice (in my case calc) is lost in the task switcher as soon as it is opened from the desktop or from nautilus. the funny thing is, that it also results in unity loosing focus, i.e. the unity bar (on the left) is sometimes not more visible and also the "unity shell" is only opening in the background (not visible if any other app is in fg.

so it seems unity looses its focus or order of apps due to the "lost" calc app?

best
sm

Mario S. (sm666) wrote :

by the way, I think we should tell whether we are using "Quickstart" of libreoffice - I do not use it, i.e. no instance of libreoffice is running when I double click on a ODS or XLS file in Nautilus.

sorry for the two messages ...

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-2d (Ubuntu):
status: New → Confirmed
Changed in bamf:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in bamf:
status: Confirmed → In Progress
Changed in unity:
status: Confirmed → Invalid
Changed in unity-2d:
status: Confirmed → Invalid
Changed in bamf (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity-2d (Ubuntu):
status: Confirmed → Invalid
Changed in unity (Ubuntu):
status: Confirmed → Invalid
Changed in bamf (Ubuntu):
status: Confirmed → In Progress
Omer Akram (om26er) on 2011-12-11
no longer affects: unity-2d (Ubuntu)
no longer affects: unity (Ubuntu)
Changed in bamf:
status: In Progress → Fix Committed
Changed in bamf (Ubuntu):
status: In Progress → Fix Released
Omer Akram (om26er) on 2012-01-06
no longer affects: unity-2d
no longer affects: unity
Omer Akram (om26er) on 2012-01-06
Changed in bamf (Ubuntu Oneiric):
importance: Undecided → High
status: New → Confirmed
milestone: none → oneiric-updates
status: Confirmed → Won't Fix
status: Won't Fix → Confirmed
Gord Allott (gordallott) on 2012-01-12
no longer affects: unity
Changed in unity:
status: New → Fix Committed
milestone: none → 5.0.0
Changed in unity (Ubuntu):
status: New → Fix Committed
Didier Roche (didrocks) on 2012-01-12
Changed in bamf:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity (Ubuntu Oneiric):
status: New → Confirmed
Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Omer Akram (om26er) on 2012-01-15
description: updated
Changed in unity (Ubuntu Oneiric):
importance: Undecided → High
no longer affects: unity (Ubuntu Oneiric)
Didier Roche (didrocks) on 2012-01-19
Changed in unity-distro-priority:
status: Fix Committed → Fix Released
Martin Pitt (pitti) on 2012-02-03
Changed in bamf (Ubuntu Oneiric):
status: Confirmed → Fix Committed
tags: added: verification-needed
Martin Pitt (pitti) on 2012-02-16
tags: added: verification-done
removed: verification-needed
Changed in bamf (Ubuntu Oneiric):
status: Fix Committed → Fix Released
76 comments hidden view all 156 comments

omvsj: that's due to the upgrade to libreoffice 3.4.5 it needs other fixes (already in precise).

So or you backport bamf (just grab the bamf precise packages) or you can "fix" it by manually editing the /usr/share/applications/libreoffice-*.desktop files changing the Exec value to something like "libreoffice -writer %U" (instead of "libreoffice --writer %U", i.e. remove one dash char). You can just save these files in ~/.local/share/applications not to worry about upgrades or if you don't want to edit them system-wide.

Steve Kroon (kroon) wrote :

I still have this problem with bamfdaemon 0.2.104-0ubuntu1.1 and libreoffice 3.4.4 on an up-to-date oneiric.

lenooh (lenooh) wrote :

Slightly offtopic, but in comment #80 I pointed out that the window title does not contain the filename of the opened document.
Since this problem occurs for all windows, not just libreoffice, I created a new bug report
https://bugs.launchpad.net/bamf/+bug/926055
but it does not seem to be getting any attention.
If you are affected by this bug (most probably), please mark that the bug affects you. Thanks ;-)

peterzay (peterzay) wrote :

Duplicate Bug #946077 affects Ubuntu 12.04 beta 28-feb-2012 Precise Pangolin.

Just wanted to make that clear since Precise is not mentioned in the "affects" column at the top of this page.

Lisa Nelson (lisa50469) wrote :

This bug is still an issue. I can get the buttons back by choosing file/fullscreen, then leaving fullscreen mode...
It's a big irritant for our customers.

bowser (bwbernard-wong1) wrote :

This also occurs for Natty. Can't install bamfdaemon 0.2.104 in Natty and I am not about to "upgrade" to 11.10 as it seems to be a lot more buggy than 11.04 even 6 months after release.

bowser (bwbernard-wong1) wrote :

For Natty enabling quick starter seems to have solved the problem completely. The catch is that in order to shut down the machine you would need to manually quit quickstarter, also have to configure with the dconf-editor to show the quick starter icon on the panel. Don't know if it works for later versions of Ubuntu.

LibreOffice 1:3.5.1-1ubuntu1~natty2 installed from the LO ppa https://launchpad.net/~libreoffice/+archive/ppa?field.series_filter=natty

glaroc (glaroc) wrote :

On my installation of 12.04, LibreOffice base and Unity do not work well at all. When I launch Base from Dash, the Base icon does not show up at all in Unity, so if I navigate away from Base, I can only regain focus by minimizing other windows or accessing Base through Dash again. Writer and Calc do not have this behavior (maybe since they are permanently in the Unity dock?). Also, I cannot seem to be able to add Base to the Unity dock at all.

Simon Rijk (s-p-rijk) wrote :

Bump. Can't find LibreOffice on Ubuntu 12.04 in the launcher either...

rpr nospam (rpr-nospam) wrote :

I see this bug on Ubuntu 12.04 64-bit with LibO 3.5.4.2 and bamfdaemon 0.2.118-0ubuntu0.2.

Which versions of Ubuntu distribution have this fixed?

I use the following repositories and components in /etc/apt/sources.list:
precise main multiverse universe
precise-updates main multiverse universe
precise-security main multiverse universe
precise-backports main multiverse universe
precise-proposed main multiverse universe

-- rpr.

I have writer in the laucher, and after the actualization of bamfdeamon to 0.2.118-0ubuntu0.2 when i open writer the launcher doesn't appear to have an open window nor in the atl-tab switcher.

What i did was to remove (un-dock) writer from the launcher but when i did the writer icon didn't so i do a logOut-LogIn.

Then all seems to be working fine.

I hope it helps

now i have other problem but i think it's related to this bug
I have attached a foto

Alex Tasin (alextasin) wrote :

after the bamf update There is still no Libreoffice Base icon on the launcher.

Matthieu FAURE (mfaure) wrote :

I experienced the behaviour described in #844119 (which led me here, because it is a duplicate) and it seems I found a workaround.

1) The behaviour I had:

To reproduce:
 * Open Libre Office Writer
 * Open a few other applications such a Firefox and Thunderbird
 * Hit Alt-Tab and switch to Firefox
 * Hit Alt-Tab again while keeping Alt depressed

Expected behavior:
 * Libre Office should be in the list of available switchable applications

Actual behavior:
 * Libre Office is not in the list of available switchable applications when hitting Alt-Tab and keeping Alt depressed
 * Libre Office is not switched back to when tapping Alt-Tab quickly (the last-used application before Libre Office is jumped to)

2) my configuration:

- Precise Pangolin (12.04)
- libreoffice3.4* packages installed
- the LibreOffice PPA (https://launchpad.net/~libreoffice/+archive/ppa) added in my source.list
- libreoffice* packages installed (note the lack of version number at the end of the package name), which is actually LibreOffice 3.5.5.2
- bamfdaemon 0.2.118-0ubuntu0.2

3) the workaround (to be confirmed by others)

- uninstall libreoffice3.4* packages (sudo aptitude remove libreoffice3.4*)

This way, I can now switch (alt-tab) between Firefox and libreoffice

Matthieu FAURE (mfaure) wrote :

ouch, this has worked for 3 hours but I'm getting back to the problem now...

pwaring (launchpad-pwaring) wrote :

I don't have any libreoffice3.4* packages installed and I'm experiencing the same problem, seems to have surfaced in the past couple of days for me (on an up to date 12.04, no PPAs). At present my only workaround is to fire up an XP VM and read the spreadsheets in Excel.

I am seeing is this for the last two weeks.

I have been using Ubuntu 12.04 Since a week after its release and been regularly updating.

I am using the distro provided Libre office and not using external PPAs for Libre Office as far as I checked with the repositories list in /etc/apt/sources.list

1. I am facing the issue of not being to switch to Libre Office file that is open using Alt+Tab.
This issue is not seen sometimes when only one file is opened. But, when multiple Libre Office Writer files are opened, this issue shows up always.

In this case, Launcher icon is not lit and I can switch to Libre Office only by minimizing the windows that get shown over the Libre Office window.

2. I also have the issue of Libre Office icon shown again in the Libre Office for the file that has been opened. Alt+Tab also does not work occassionally during this scenario.

On not all, but most occassions, if I restart the machine, everything works normally for sometime and goes back to showing the above mentioned issues.

If it helps, the applications that I normally have open are Terminal, Google Chrome, Thunderbird, Skype and Netbeans 7.1.2

I have had this issue on a 12.04 freshly installed.

The problems seems to be fixed after running:
sudo apt-get --reinstall install bamfdaemon

Although there appears to be still a few glitches with the icon on the Unity bar:

- sometimes the icon appears to be invisible, although it's working as when clicking on it the document is indeed brought forward;

- sometimes an empty document LibreOffice icon is showed instead of the correct LibreOffice application icon;

- sometimes an empty slot is left on top of the opened document icon;

Colin Law (colin-law) wrote :

In view of all those still seeing problems with this, should the bug be re-opened or does it need a new one?

Matthieu FAURE (mfaure) wrote :

The workaround given by Marco Lackovic (comment #134) worked also for me.
I ran a:

sudo aptitude reinstall bamfdaemon

then opened 2 files in LibreOffice writer, and could swith from one to another or to another application (eg Nautilus).

I have the same problem on 12.04 up to date on a Samsung N310.

This started a few days ago. It is very annoying, as often I click on the launcher icon and instead of bringing the document that is already opened, it opens a new blank document.

So the document is often not visible on the launcher or in alt+tab, but it is visible when using the spread function (either with super+Z or with a hotcorner set by Ubuntu Tweak).

I sometimes also get an extra icon at the bottom of launcher (the icons don't merge for some reason).

So what is the package that needs to be fixed? It would be good to change the status to reopen the bug so it gets some attention (it was tricky to find this bug as the fixed bugs don't appear in the search results by default).

Matthieu FAURE (mfaure) wrote :

Ouch ! The problem appeared again for me, but in a different way.

I had only one writer document opened, moved it from one workspace to another, did many different things for one hour, and then I could not switch from Firefox to LibreOffice. I had to minimize Firefox to see Libreoffice. In the mean time, I tried to clic on the LibreOffice icon, but nothing happened.

Unfortunately, I couldn't reproduce the behaviour.

pwaring (launchpad-pwaring) wrote :

Is there anything we can do to help identify what the outstanding problem is and get this bug fixed? Perhaps it's just that some of us are running the 'wrong' package or haven't got the update yet (although I'm running a standard 12.04 installation with no PPAs, all updates installed etc.).

Matthieu FAURE (mfaure) wrote :

I found a (very) little workaround:

the LibreOffice window is still accessible by pressing SUPER + W (which presents a panorama of all the windows of the current workspace)

Omer Akram (om26er) wrote :

Please open new bug report for any problem you face now.

Zdenek Dlauhy (e-tast-k) wrote :

Matthieu FAURE (mfaure) wrote on 2012-07-18: #139

Well as Matthieu pointed out, this bug really suddenly appeared again. I saw it today several times with libreoffice...

bad is that i don't know, how to triger it. It usually happened when i opened multiple windows of calc sheets and jumped to another window like firefox and then I tried to open calc, and i couldn't get window back. So i guess that this is back in some another form and should be fixed asap as... some co-workers also saw this...but they don't know what should they do to get back windows....their solution is to get back to 8.04 or 10.04..... So I hope, that we can really find how to fix this. I did 5 clean installs of 12.04 because, it worked quite well and now ...:/

goniomdq (jose-goni) wrote :

Same issue here.

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04 LTS
Release: 12.04
Codename: precise

$dpkg -l
unity 5.12-0ubuntu1.1
libreoffice-base-core 1:3.5.4-0ubuntu1

goniomdq (jose-goni) wrote :

And I also get the same issu with other applications, such as VirtualBox-ose, where now only the main window appears in the panel and in the switcher. The VM I have open is only accesible vie SUPER+W

Dear all

Here is the new bug: Bug #1026426

Please go to that one, mark it as affecting you, and follow the discussion there.

Cheers

1 comments hidden view all 156 comments
Bob (bbrazie) wrote :

I also noticed that the "save as" is broken. in Ubuntu 12.10.

Kris Warner (kdwarn) wrote :

I was having the same problems (particularly the inability to switch using Alt+Tab, and blank logos appearing in the launcher), but installing lo-menubar and re-installing bamf (sudo apt-get --reinstall install bamfdaemon) seems to have done the trick for me.

Dani Mardones (dmardones) wrote :
Download full text (3.8 KiB)

Edu, en referencia a les icones de libreoffice que desapareixn. A veure si funciona...

----- Kris Warner <email address hidden> escribió:
> I was having the same problems (particularly the inability to switch
> using Alt+Tab, and blank logos appearing in the launcher), but
> installing lo-menubar and re-installing bamf (sudo apt-get --reinstall
> install bamfdaemon) seems to have done the trick for me.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (862171).
> https://bugs.launchpad.net/bugs/842566
>
> Title:
> Libreoffice and unity integration broken.
>
> Status in BAMF Application Matching Framework:
> Fix Released
> Status in Unity:
> Fix Released
> Status in Unity Distro Priority:
> Fix Released
> Status in “bamf” package in Ubuntu:
> Fix Released
> Status in “unity” package in Ubuntu:
> Fix Released
> Status in “bamf” source package in Oneiric:
> Fix Released
>
> Bug description:
> SRU TESTCASE
> 1 Enable the splash screen in libreoffice
> 2 Launch libreoffice double-cliking on a lo file
> 3 Repeat this action multiple times and the bug should manifest.
> 4 Now install bamf from oneiric proposed and the repeat the above steps
> 5 The issue wont appear
>
> When I open an existing file with lets say oowriter or oocalc it's
> icon isn't listed in unity panel as a running app. Window controls and
> window title isn't shown on a top panel either (see attached
> screenshot). Empty-staring these app's doesn't rise this issue.
> Sometimes after fresh boot this problem doesn't occur but it's usually
> pretty soon back after opening few existing files.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.10
> Package: unity 4.12.0-0ubuntu2
> ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
> Uname: Linux 3.0.0-10-generic x86_64
> NonfreeKernelModules: nvidia
> Architecture: amd64
> CompizPlugins: [core,bailer,detection,composite,opengl,imgjpeg,decor,compiztoolbox,regex,move,winrules,place,imgpng,mousepoll,resize,grid,vpswitch,gnomecompat,session,animation,wall,unitymtgrabhandles,workarounds,wobbly,fade,thumbnail,expo,scale,scaleaddon,unityshell]
> Date: Tue Sep 6 13:02:31 2011
> InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
> SourcePackage: unity
> UpgradeStatus: Upgraded to oneiric on 2011-08-28 (8 days ago)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/bamf/+bug/842566/+subscriptions

--

Dani Mardones Musoll
Tècnic Informàtic
Consell Comarcal de la Noguera
Passeig Àngel Guimerà, 28-30. 25600 Balaguer
Tel 973 448 933 Fax 973 445 324
-------------------------------------------
Tota la informació que pot tenir aquest correu electrònic
 i els seus arxius annexos és confidencial i es dirigeix exclusivament
al seu destinatari, i es troba emparada per la Llei Orgànica 15/1999, de
 13 de desembre, de Protecció de Dades de Caràcter Personal (LOPD)
quedant prohibida la seva revelació, còpia, distribució o l'exercici de
qualsevol acció relativa al seu contingut per qualsevol persona sense
autorització expressa del Consell Comarcal de la Noguera. Si ha rebut
aquest missatge per error, es prega que ho comuniqui de forma immediata...

Read more...

intuiter (vmetsis) wrote :

I am still experiencing the same promlems with LibreOffice on Ubuntu 12.04 x64. Installing bamfdaemon kind of helped in the sense that the icon does not completely disappear from the launcher panel and I can use Alt+Tab, but I still get strange behavior. E.g. when I open a .doc file, two icons appear on my launcher panel. One of them in invisible (just an empty space on the launcher panel) and does not do anything.

rpr nospam (rpr-nospam) wrote :

As this bug has been marked as fixed, it is suggested to add new comments to bug #1026426 if you still have the issue.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bamf (Ubuntu Quantal):
status: New → Confirmed
Walter Ribeiro (wribeirojr) wrote :

The attached image shows the same issue reported in this bug or is it another problem?
This happens after opening 2 or 3 documents it with double click, just like in the bug description above.

rpr nospam (rpr-nospam) wrote :

I'd say you have another issue reported in bug #1082496.

Walter Ribeiro (wribeirojr) wrote :

Rpr nospam, I reported the bug you mentioned, but it seems strange that only 3 people have the same problem. This always happens to me, so I expected it to affect more people. I'm looking for similar problems, they may have the same cause.

Changed in bamf (Ubuntu Quantal):
status: Confirmed → Fix Released
Displaying first 40 and last 40 comments. View all 156 comments or add a comment.