[master] Remaining corner cases where windows receive invalid stack positions

Bug #859405 reported by Jason Warner
544
This bug affects 104 people
Affects Status Importance Assigned to Milestone
Compiz
High
Unassigned
Compiz Core
High
Unassigned
Unity
Fix Released
High
Sam Spilsbury
Unity Distro Priority
Medium
Unassigned
compiz (Ubuntu)
High
Sam Spilsbury
unity (Ubuntu)
High
Unassigned

Bug Description

I'm using the latest compiz and unity and still have some sporadic stacking issues with Unity and alt+tab.

Not sure if related, but I also have compiz crash report (attached).

EDIT (smspillaz): I'm hijacking this bug as a means to track the remaining edge cases
1) Mumble can go on top of dock windows when opening itself: Bug 865863
2) "Happens with maximized windows" (still tracking down): Bug 831466

-- NB: Before reporting bugs, please use oneiric-proposed! software-center -> edit -> software sources -> updates -> "oneiric-proposed"

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: compiz 1:0.9.5.94+bzr20110919-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 1.23-0ubuntu1
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,gnomecompat,place,imgpng,session,grid,vpswitch,resize,move,snap,mousepoll,unitymtgrabhandles,regex,wall,animation,workarounds,fade,scale,expo,ezoom,unityshell]
CompositorRunning: compiz
Date: Mon Sep 26 15:38:29 2011
DistUpgraded: Fresh install
DistroCodename: oneiric
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0126] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:21da]
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110919)
MachineType: LENOVO 4286CTO
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_AU:en
 LC_CTYPE=en_US.UTF-8
 PATH=(custom, user)
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-11-generic root=UUID=705894e9-4493-41b0-8b0a-26944457902d ro quiet splash vt.handoff=7
SourcePackage: compiz
UpgradeStatus: No upgrade log present (probably fresh install)
XorgConf:
 Section "Monitor"
         Identifier "HDMI1"
         Option "Ignore" "True"
 EndSection
dmi.bios.date: 07/07/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 8DET50WW (1.20 )
dmi.board.asset.tag: Not Available
dmi.board.name: 4286CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr8DET50WW(1.20):bd07/07/2011:svnLENOVO:pn4286CTO:pvrThinkPadX220:rvnLENOVO:rn4286CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 4286CTO
dmi.product.version: ThinkPad X220
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.5.94+bzr20110919-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Revision history for this message
Jason Warner (jasoncwarner) wrote :
Didier Roche (didrocks)
Changed in unity:
milestone: none → 4.18.0
tags: added: didrocks-oneiric-list
Didier Roche (didrocks)
Changed in unity:
milestone: 4.18.0 → 4.20.0
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Revision history for this message
Omer Akram (om26er) wrote :

should be fixed with the latest update of compiz.

compiz (1:0.9.6-0ubuntu1) oneiric; urgency=low

   - Applications which create multiple windows that are transients of each other can be given invalid stack positions (LP: #858625)

Revision history for this message
Omer Akram (om26er) wrote :

Can you test and confirm if the latest compiz indeed fixes the issue for you. I am marking the issue as incomplete as you test.

Changed in unity:
status: New → Incomplete
Changed in compiz (Ubuntu):
status: Confirmed → Incomplete
Didier Roche (didrocks)
Changed in unity:
milestone: 4.20.0 → 4.22.0
Changed in unity:
importance: Undecided → Critical
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in compiz (Ubuntu):
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in unity:
status: Incomplete → In Progress
Changed in compiz (Ubuntu):
status: Incomplete → In Progress
description: updated
Changed in unity:
milestone: 4.22.0 → 4.24.0
Omer Akram (om26er)
Changed in compiz (Ubuntu):
importance: Undecided → Critical
milestone: none → oneiric-updates
Changed in unity:
milestone: 4.24.0 → 4.26.0
summary: - More Unity (Launcher, Dash) and alt+tab stacking issues
+ remaining corner cases where windows receive invalid stack positions
David Barth (dbarth)
summary: - remaining corner cases where windows receive invalid stack positions
+ [master] Remaining corner cases where windows receive invalid stack
+ positions
description: updated
Revision history for this message
Serhiy Zahoriya (xintx-ua) wrote :

Just upgraded to compiz from oneiric-proposed and it didn't fix it.
Also I've found a simple workaround that works for me: just making Firefox or Chromium fullscreen one time after login fixes it.

description: updated
description: updated
Revision history for this message
Vadim Peretokin (vperetokin) wrote :

I got hit by this today - seems similar? Unfortunately you can't see the clicking, but it is obvious to see that when focus was on a background window, the chrome window was not going away as it should.

Revision history for this message
Frederik Elwert (frederik-elwert) wrote :

Is there any further information needed to get these remaining issues fixed? There is still a lively discussion in Bug #805087, so there are still many users affected by this.

Revision history for this message
Silvano (silvavlis) wrote :

The workaround proposed by Загорія Сергій (xintx-ua) in comment #5 works. But don't mistake maximize for fullscreen as I did! Simply select Firefox or Chromium and press F11 once to start fullscreen and once again to get out of fullscreen.

Revision history for this message
Tom Kaminski (ttkaminski) wrote :

I am running unity 4.24.0, and I can confirm that pressing F11 twice in Chromium fixed the window stacking problem. When this stacking problem occurs, I need to minimize each open window in order to get back to the desktop before I can use the unity launcher to switcher.

Revision history for this message
Serhiy Zahoriya (xintx-ua) wrote :

Do you all use Intel's Integrated Graphics?

Revision history for this message
Nick Moffitt (nick-moffitt) wrote :

I certainly am, and I see these problems:

  00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
  00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)

Revision history for this message
Dean Henrichsmeyer (dean) wrote :

No, this happened to me with an ATI 5450.

Revision history for this message
Andrew Somerville (andy16666) wrote :

Yes, and to me with a NVidia 8800GT

Revision history for this message
Shock (mmiron) wrote :

nVidia 7600GT here, using proprietary drivers.

Revision history for this message
Joaquin (jknvv13) wrote : Re: [Bug 859405] Re: [master] Remaining corner cases where windows receive invalid stack positions
Download full text (4.0 KiB)

G210 here, propietary too.
El 08/11/2011 19:02, "Shock" <email address hidden> escribió:

> nVidia 7600GT here, using proprietary drivers.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (871285).
> https://bugs.launchpad.net/bugs/859405
>
> Title:
> [master] Remaining corner cases where windows receive invalid stack
> positions
>
> Status in Unity:
> In Progress
> Status in Unity Distro Priority:
> New
> Status in “compiz” package in Ubuntu:
> In Progress
>
> Bug description:
> I'm using the latest compiz and unity and still have some sporadic
> stacking issues with Unity and alt+tab.
>
> Not sure if related, but I also have compiz crash report (attached).
>
> EDIT (smspillaz): I'm hijacking this bug as a means to track the
> remaining edge cases
> 1) Mumble can go on top of dock windows when opening itself: Bug 865863
> 2) "Happens with maximized windows" (still tracking down): Bug 831466
>
> -- NB: Before reporting bugs, please use oneiric-proposed! software-
> center -> edit -> software sources -> updates -> "oneiric-proposed"
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.10
> Package: compiz 1:0.9.5.94+bzr20110919-0ubuntu1
> ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
> Uname: Linux 3.0.0-11-generic x86_64
> .tmp.unity.support.test.0:
>
> ApportVersion: 1.23-0ubuntu1
> Architecture: amd64
> CompizPlugins:
> [core,bailer,detection,composite,opengl,compiztoolbox,decor,gnomecompat,place,imgpng,session,grid,vpswitch,resize,move,snap,mousepoll,unitymtgrabhandles,regex,wall,animation,workarounds,fade,scale,expo,ezoom,unityshell]
> CompositorRunning: compiz
> Date: Mon Sep 26 15:38:29 2011
> DistUpgraded: Fresh install
> DistroCodename: oneiric
> DistroVariant: ubuntu
> GraphicsCard:
> Intel Corporation 2nd Generation Core Processor Family Integrated
> Graphics Controller [8086:0126] (rev 09) (prog-if 00 [VGA controller])
> Subsystem: Lenovo Device [17aa:21da]
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110919)
> MachineType: LENOVO 4286CTO
> PackageArchitecture: all
> ProcEnviron:
> LANGUAGE=en_AU:en
> LC_CTYPE=en_US.UTF-8
> PATH=(custom, user)
> LANG=en_AU.UTF-8
> SHELL=/bin/bash
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-11-generic
> root=UUID=705894e9-4493-41b0-8b0a-26944457902d ro quiet splash vt.handoff=7
> SourcePackage: compiz
> UpgradeStatus: No upgrade log present (probably fresh install)
> XorgConf:
> Section "Monitor"
> Identifier "HDMI1"
> Option "Ignore" "True"
> EndSection
> dmi.bios.date: 07/07/2011
> dmi.bios.vendor: LENOVO
> dmi.bios.version: 8DET50WW (1.20 )
> dmi.board.asset.tag: Not Available
> dmi.board.name: 4286CTO
> dmi.board.vendor: LENOVO
> dmi.board.version: Not Available
> dmi.chassis.asset.tag: No Asset Information
> dmi.chassis.type: 10
> dmi.chassis.vendor: LENOVO
> dmi.chassis.version: Not Available
> dmi.modalias:
> dmi:bvnLENOVO:bvr8DET50WW(1.20):bd07/07/2011:svnLENOVO:pn4286CTO:pvrThinkPadX220:rvnLENOVO:rn4286CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
> dmi.product.name: 4286CTO
> dmi.product.version: ThinkPad X2...

Read more...

Revision history for this message
Amvince (amvince) wrote :

nVidia 8600M GT - same issue. The F11 on the browser works around though.

Revision history for this message
Sam Spilsbury (smspillaz) wrote :
Download full text (4.0 KiB)

This is not a hardware related issue.

On Wed, Nov 9, 2011 at 6:51 AM, Amvince <email address hidden> wrote:
> nVidia 8600M GT - same issue.  The F11 on the browser works around
> though.
>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/859405
>
> Title:
>  [master] Remaining corner cases where windows receive invalid stack
>  positions
>
> Status in Unity:
>  In Progress
> Status in Unity Distro Priority:
>  New
> Status in “compiz” package in Ubuntu:
>  In Progress
>
> Bug description:
>  I'm using the latest compiz and unity and still have some sporadic
>  stacking issues with Unity and alt+tab.
>
>  Not sure if related, but I also have compiz crash report (attached).
>
>  EDIT (smspillaz): I'm hijacking this bug as a means to track the remaining edge cases
>  1) Mumble can go on top of dock windows when opening itself: Bug 865863
>  2) "Happens with maximized windows" (still tracking down): Bug 831466
>
>  -- NB: Before reporting bugs, please use oneiric-proposed! software-
>  center -> edit -> software sources -> updates -> "oneiric-proposed"
>
>  ProblemType: Bug
>  DistroRelease: Ubuntu 11.10
>  Package: compiz 1:0.9.5.94+bzr20110919-0ubuntu1
>  ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
>  Uname: Linux 3.0.0-11-generic x86_64
>  .tmp.unity.support.test.0:
>
>  ApportVersion: 1.23-0ubuntu1
>  Architecture: amd64
>  CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,gnomecompat,place,imgpng,session,grid,vpswitch,resize,move,snap,mousepoll,unitymtgrabhandles,regex,wall,animation,workarounds,fade,scale,expo,ezoom,unityshell]
>  CompositorRunning: compiz
>  Date: Mon Sep 26 15:38:29 2011
>  DistUpgraded: Fresh install
>  DistroCodename: oneiric
>  DistroVariant: ubuntu
>  GraphicsCard:
>   Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0126] (rev 09) (prog-if 00 [VGA controller])
>     Subsystem: Lenovo Device [17aa:21da]
>  InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110919)
>  MachineType: LENOVO 4286CTO
>  PackageArchitecture: all
>  ProcEnviron:
>   LANGUAGE=en_AU:en
>   LC_CTYPE=en_US.UTF-8
>   PATH=(custom, user)
>   LANG=en_AU.UTF-8
>   SHELL=/bin/bash
>  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-11-generic root=UUID=705894e9-4493-41b0-8b0a-26944457902d ro quiet splash vt.handoff=7
>  SourcePackage: compiz
>  UpgradeStatus: No upgrade log present (probably fresh install)
>  XorgConf:
>   Section "Monitor"
>           Identifier "HDMI1"
>           Option "Ignore" "True"
>   EndSection
>  dmi.bios.date: 07/07/2011
>  dmi.bios.vendor: LENOVO
>  dmi.bios.version: 8DET50WW (1.20 )
>  dmi.board.asset.tag: Not Available
>  dmi.board.name: 4286CTO
>  dmi.board.vendor: LENOVO
>  dmi.board.version: Not Available
>  dmi.chassis.asset.tag: No Asset Information
>  dmi.chassis.type: 10
>  dmi.chassis.vendor: LENOVO
>  dmi.chassis.version: Not Available
>  dmi.modalias: dmi:bvnLENOVO:bvr8DET50WW(1.20):bd07/07/2011:svnLENOVO:pn4286CTO:pvrThinkPadX220:rvnLENOVO:rn4286CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
>  dmi.product.name: 4286CTO
>  dmi.product.version: Think...

Read more...

Tim Penhey (thumper)
tags: added: udp
Revision history for this message
Mario (meconio) wrote :

I'm on a Dell Inspiron with intel graphics card and the bug does go off after using the F11 on the browser trick.

Didier Roche (didrocks)
Changed in unity-distro-priority:
status: New → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks)
Changed in unity (Ubuntu):
status: Confirmed → In Progress
David Barth (dbarth)
Changed in unity:
milestone: 4.26.0 → 4.28.0
Omer Akram (om26er)
Changed in unity (Ubuntu):
importance: Undecided → Critical
Changed in unity:
milestone: 4.28.0 → 4.30.0
Revision history for this message
Omer Akram (om26er) wrote :

I personally think this bug is now fixed or atleast its now occuring to a much less extent. When this issue was *actually* happening it was like 5 report/day

Changed in compiz (Ubuntu):
importance: Critical → High
Changed in unity (Ubuntu):
importance: Critical → High
Changed in unity:
importance: Critical → High
status: In Progress → Triaged
Changed in compiz (Ubuntu):
status: In Progress → Triaged
Changed in unity (Ubuntu):
status: In Progress → Triaged
Tim Penhey (thumper)
tags: added: distro-priority
Didier Roche (didrocks)
Changed in unity-distro-priority:
importance: Undecided → Medium
Revision history for this message
David Gillies (daveg) wrote :

Precise has now been released and I'm still seeing this bug on multiple computers. The fullscreening of chrome using F11 does work as a temporary work around though.

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Could someone please clarify exactly what the remaining bug(s) is/are and describe it in the Bug Description?

Changed in compiz-core:
importance: Undecided → High
status: New → Confirmed
status: Confirmed → Incomplete
Changed in unity:
status: Triaged → Incomplete
Changed in compiz (Ubuntu):
status: Triaged → Incomplete
Changed in unity (Ubuntu):
status: Triaged → Incomplete
Changed in compiz:
importance: Undecided → High
status: New → Incomplete
Stephen M. Webb (bregma)
Changed in unity:
milestone: 4.30.0 → none
Revision history for this message
Andrea Azzarone (azzar1) wrote :

Both bugs in the bug description are fixed now. Closing the bug.

Changed in compiz:
status: Incomplete → Fix Released
Changed in compiz-core:
status: Incomplete → Fix Released
Changed in compiz (Ubuntu):
status: Incomplete → Fix Released
Changed in unity (Ubuntu):
status: Incomplete → Fix Released
Changed in unity:
status: Incomplete → Fix Released
To post a comment you must log in.