opening a directory using an application change associations incorrectly

Bug #260492 reported by Carlos Perelló Marín on 2008-08-22
576
This bug affects 33 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Medium
gnome-panel (Ubuntu)
Medium
Michael Vogt
Intrepid
Undecided
Unassigned
nautilus (Ubuntu)
Medium
Ubuntu Desktop Bugs
Intrepid
Undecided
Unassigned
update-manager (Ubuntu)
Wishlist
Unassigned
Intrepid
Undecided
Unassigned

Bug Description

TESTCASE:
* using hardy and upgrading to intrepid
- right click on a directory in nautilus
- select the open with menu entry
- select an application in the list, eog for example

try opening a directory in the places menu, nautilus is used, upgrade to intrepid, eog is being used now

* using intrepid and upgrading to the fixed version
- right click on a directory in nautilus
- select the properties menu entry
- go to the open with tab and set an application to be the default there, eog for example

try opening a directory in the places menu eog is being used now

* upgrading to the candidate version should make nautilus be used again in both scenarios (you need to restart your session to get the new version running)

---------------------------------------------------

After using 'upgrade-manager -d" to Intrepid, something during the upgrade prosses unintentionally hijacked our configurations to launch various programs in-place of nautilus for opening folders from the places menu.

I do not believe that the package 'gnome-panel' is necessarily at fault, but don't have a clue where the root cause is as I don't understand how the places menu works, however Tuomas Aavikko's workaround gave me success in fixing the issue:

Right click on a folder in nautilus ->Open with app-> File Manager

Now I can open my home folder from the places menu again. So it seems that there is a file extension for folders that is being hijacked by the installation / upgrade of other packages such as VLC, gthumb, totem, amarok, kaffeine, Konqueror, Archiver Manager. (compiled from comments and duplicate of this bug.)

Sebastien Bacher (seb128) wrote :

thank you for your bug report. are you sure you did assign this software to directories in nautilus?

Changed in gnome-panel:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
Carlos Perelló Marín (carlos) wrote :

I don't remember doing such thing but taking a look to any folder properties shows me that gthum is selected as the default application to open it. Changing it back to nautilus fixes the problem.

If I'm the only one seeing this behaviour, I guess I did such change by mistake...

Changed in gnome-panel:
status: Incomplete → Invalid
Sebastien Bacher (seb128) wrote :

you are not the only one and it's possible some application did this change, you should open a bug against the concerned application if you figure which one

dlgandalf (gandalf-die-laterne) wrote :

I don't think it's gthumbs fault, as my upgrade to intrepid resulted in the above behaviour with kaffeine.
Little change gthumb and kaffeine both have the same bug.

Tim (darkxst) wrote :

Similar problem here, after upgrading to intrepid, Amarok took over the folder associations.

changed it back to nautilus in the folder properties box and all is ok.

Dereck Wonnacott (dereck) wrote :

Simlarly, VLC hijacked my places menu after upgrade to intrepid.

Jojo (kuzniarpawel) wrote :

In my case Totem opens Desktop, Home folder or any folder from bookmarks

Tuomas Aavikko (taavikko) wrote :

Right click on folder->Open with app->
Now clicking places->homefolder that previously selected app starts, instead of nautilus.

Jojo (kuzniarpawel) wrote :

Simple workaround

Right click -> Open with -> custom command -> nautilus

repeat for all folders

now should open folders from Places in Nautilus

Dereck Wonnacott (dereck) wrote :

Setting the status of this bug back to confirmed. The problem is that "upgrade-manager -d" unintentionally switched our configurations to launch various programs in-place of nautilus.

 I also do not believe that the package 'gnome-panel' is necessarily at fault, but don't have a clue where the root is.

Changed in gnome-panel:
importance: Low → Medium
status: Invalid → Confirmed
description: updated
description: updated
Sebastien Bacher (seb128) wrote :

the issue is a nautilus one and has been sent on http://bugzilla.gnome.org/show_bug.cgi?id=553237 now

Changed in nautilus:
status: Confirmed → Triaged
Sebastien Bacher (seb128) wrote :

don't specify the ubuntu version you are using in the title, that creates confusion and extra work for triagers

Changed in nautilus:
status: Unknown → New
rekado (rekado) wrote :

same here after upgrading. workaround as mentioned above works.

rekado (rekado) on 2008-09-26
Changed in nautilus:
status: Triaged → Confirmed
Sebastien Bacher (seb128) wrote :

the bug has been sent upstream and is triaged

Changed in nautilus:
status: Confirmed → Triaged

EasyTag took its place here. I wonder if there's a better way of changing all these file association instead of clicking on every folder changing it.

Olaf Leidinger (leidola) wrote :

similar problem: (as reported in bug #280729).

But in my case no application is linked with a folder, which is correct according to [1], but clicking the "Places/Home Folder" or another directory in gnome-panel doesn't open it.

I don't know what gnome-panel does to execute the launcher, but the default should be to open a folder in nautilus, if nothing else is set -- I guess.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=553237

Tuomas Aavikko (taavikko) wrote :

Additional info;

Before setting folders to open with F-Spot
cat .local/share/applications/mimeapps.list

[Added Associations]
audio/mpeg=rhythmbox.desktop;
video/x-msvideo=smplayer.desktop;
inode/directory=nautilus-folder-handler.desktop;

[Removed Associations]
inode/directory=mplayer.desktop;smplayer.desktop;

After
cat .local/share/applications/mimeapps.list

[Added Associations]
audio/mpeg=rhythmbox.desktop;
video/x-msvideo=smplayer.desktop;
inode/directory=f-spot-import.desktop;nautilus-folder-handler.desktop;

[Removed Associations]
inode/directory=mplayer.desktop;smplayer.desktop;

Removing F-spot from folders properties
cat .local/share/applications/mimeapps.list

[Added Associations]
audio/mpeg=rhythmbox.desktop;
video/x-msvideo=smplayer.desktop;
inode/directory=nautilus-folder-handler.desktop;

[Removed Associations]
inode/directory=f-spot-import.desktop;mplayer.desktop;smplayer.desktop;

Olaf Leidinger (leidola) wrote :

The default application for folders in gnome should be nautilus-folder-handler, as it contains:

MimeType=x-directory/gnome-default-handler;x-directory/normal;inode/directory;application/x-gnome-saved-search;

Experimenting with ~/.local/share/applications/mimeapps.list I get the following result:

[Added Associations]
inode/directory=nautilus-folder-handler.desktop;

==> I can't open the home folder from gnome-panel

[Added Associations]
inode/directory=nautilus.desktop;

Everything works as expected. So I suspect something is wrong with nautilus-folder-handler.desktop on my intrepid system.

Using strace I found out that there was a local nautilus-folder-handler.conf in ~/.local/share/applications/

(Name and Comment grep-ed away)
--- local 2008-10-09 22:54:31.000000000 +0200
+++ system-wide 2008-10-09 22:49:19.000000000 +0200
@@ -1,9 +1,10 @@
 [Desktop Entry]
 Encoding=UTF-8
 Exec=nautilus --no-desktop %U
-Hidden=true
+Icon=folder-open
 MimeType=x-directory/gnome-default-handler;x-directory/normal;inode/directory;application/x-gnome-saved-search;
 NoDisplay=true
+OnlyShowIn=GNOME;
 StartupNotify=true
 Terminal=false
 TryExec=nautilus
@@ -11,4 +12,5 @@
 X-GNOME-Bugzilla-Bugzilla=GNOME
 X-GNOME-Bugzilla-Component=general
 X-GNOME-Bugzilla-Product=nautilus
-X-GNOME-Bugzilla-Version=2.20.0
+X-GNOME-Bugzilla-Version=2.24.0
+X-Ubuntu-Gettext-Domain=nautilus

Deleting it solved the problem, as the system wide file seems to work. But this arises two questions:

1. How did this file come to my $HOME?
2. Why didn't it work?

It seems as if this file is from gnome-2.20. Restoring the local version and setting Hidden=false everything works, too - but not using Hidden=true.
Was this attribute ignored before?

Sebastien Bacher (seb128) wrote :

the bug has been fixed upstream now

Changed in nautilus:
status: Triaged → Fix Committed
1 comments hidden view all 129 comments
adder1972 (adder1972) wrote :

I have the same bug. VLC has "hijacked" my system.

I have a newly upgraded/updated system.

If I remove VLC, then everything is normal. Reinstalling it reproduces the bug.

Changed in nautilus:
status: New → Fix Released
Ramptu (tblue69) wrote :

Same problem here. Upgraded to 8.10 (which so far is great) and Places menu doesn't work. Get error cannot open wxvlc.

Tuomas Aavikko (taavikko) wrote :

addr1972 & Ramptu, Bug is known and already fix committed, there's no need for further
confirmations. But feel free to comment or open a new one on any open bugs you might experience.

Ramptu (tblue69) wrote :

I just noticed I didnt have the Private encrypted folder in my Home folder. I fixed the Places menu item by doing the above suggestion by going to properties and choosing open using Open folder instead of VLC.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:2.24.1-0ubuntu1

---------------
nautilus (1:2.24.1-0ubuntu1) intrepid; urgency=low

  * New upstream version:
    - Fix saving of spatial window geometry on close
    - Remove trailing spaces on filenames when copying to FAT file systems
    - Allow emblems that don't start with "emblem-" (lp: #55574)
    - On unmount close tabs that show the unmounted location
    - Fixed redraw issues with labels on zoom
    - Don't toggle sidebar splitter when dragging it
    - Fix bookmark issue that sometimes led to locations not loading
    - Don't show the "cancel" dialog after a timeout when displaying a dialog
      (lp: #238425)
    - Fix crashes and leaks
    - Don't change the default association when using a software which is not
      listed by default (lp: #260492)
  * debian/patches/90_correct_spatial_geometry.patch:
    - the change is in the new version

 -- Sebastien Bacher <email address hidden> Mon, 20 Oct 2008 15:11:57 +0200

Changed in nautilus:
status: Fix Committed → Fix Released
tonfa (bboissin) wrote :

This is not fixed for me, I just had this bug, upgrading to intrepid today.

tonfa@pirzuine:~$ aptitude show nautilus
Package: nautilus
State: installed
Automatically installed: no
Version: 1:2.24.1-0ubuntu1

$ cat .local/share/applications/mimeapps.list

[Added Associations]
inode/directory=vlc-usercustom.desktop;nautilus-folder-handler.desktop;
application/x-extension-img=userapp-vlc-WEXVHU.desktop;

And I have some entries about vlc in .local/share/applications.
I remember having already read a folder (containing some .TS from a dvd) by right-clicking and choosing vlc.
If that's the reason the fix isn't working for me, fine (then it shouldn't affect many people). But it still shouldn't behave like that during the upgrade.

Tuomas Aavikko (taavikko) wrote :

Just tested,
changed in folder properties, open with rhythmbox, Places->Homefolder opens rhythmbox

So this should be changed back to "confirmed" Anyone else affected still?

Sebastien Bacher (seb128) wrote :

the properties dialog is supposed to change associations if you use it, what should not be changing those is using a software to open something once, not that hardy could have written buggy configurations too

Juanvi (jvjativa) wrote :

Upgraded from 8.04 to 08.10 yesterday and found this problems. It has been fixed by editing the file local/share/applications/mimeapps.list as described above.

Andreas Jonsson (sonofjon) wrote :

I can confirm that the problem still exists. I upgraded from hardy to intrepid RC1 on Oct 25th, and ever since baobab was started whenever I clicked a location under the Places menu. I resolved this simply by removing the following problematic line in .local/share/applications/mimeapps.list:

[Added Associations]
inode/directory=baobab-usercreated.desktop;

Sebastien Bacher (seb128) wrote :

you confirm that the current intrepid creates buggy configuration? are you sure you didn't have that configuration in hardy?

Bug 290028 has a detailed description of the problem, which might be helpful.

tonfa (bboissin) wrote :

I don't know if intrepid *creates* the buggy configuration (because I didn't look in .local/share/applications before upgrading), but I am sure that I didn't have any problem opening a directory in hardy, while trying to open a directory with intrepid (from the "places" menu) didn't work and tried to open it with wxvlc.

So please reopen the bug.

I upgraded to Intrepid during the rc phase to catch this kind of bug, it would be nice if other people do not encounter this bug.

Andreas Jonsson (sonofjon) wrote :

Sebastian:

I went back and looked at a backed up version of

.local/share/applications/mimeapps.list

from my hardy installation (i.e. what I had before I upgraded to intrepid RC1). I was surprised to see that my hardy and intrepid mimeapps.list files are identical. So, just to be clear, I had the buggy line

[Added Associations]
inode/directory=baobab-usercreated.desktop;

also in my hardy installation. However, I didn't experience any problems in hardy. Strange... Let me know what I can do to help further.

Changed in nautilus:
status: Fix Released → Confirmed
Sebastien Bacher (seb128) wrote :

the nautilus issue is fixed in the current version

Changed in nautilus:
status: Confirmed → Fix Released
Sebastien Bacher (seb128) wrote :

could be that gnome-panel was not using gio correctly in hardy (there was some issues which has been fixed this cycle) so it was not respecting the application selected, the current intrepid behaviour is correct and nautilus doesn't write buggy configuration either, not sure what could be changed for users who changed the association by error in hardy though

tonfa (bboissin) wrote :

Please not that while gnome-panel wasn't able to open any directory, the "places" in the sidebar in nautilus was working for me.

In hardy I did a "open with ..." once with a directory, but I never explicitely said to open *every* directory with vlc.

Yes, I am sure. However changing the association has fixed this problem.

To date I have had no further problems

Thanks for your help.

Quoting "Sebastien Bacher" <email address hidden>:

> you confirm that the current intrepid creates buggy configuration? are
> you sure you didn't have that configuration in hardy?
>
> --
> opening a directory using an application change associations incorrectly
> https://bugs.launchpad.net/bugs/260492
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in Nautilus: Fix Released
> Status in ?nautilus? source package in Ubuntu: Fix Released
>
> Bug description:
> After using 'upgrade-manager -d" to Intrepid, something during the
> upgrade prosses unintentionally hijacked our configurations to
> launch various programs in-place of nautilus for opening folders
> from the places menu.
>
> I do not believe that the package 'gnome-panel' is necessarily at
> fault, but don't have a clue where the root cause is as I don't
> understand how the places menu works, however Tuomas Aavikko's
> workaround gave me success in fixing the issue:
>
> Right click on a folder in nautilus ->Open with app-> File Manager
>
> Now I can open my home folder from the places menu again. So it
> seems that there is a file extension for folders that is being
> hijacked by the installation / upgrade of other packages such as
> VLC, gthumb, totem, amarok, kaffeine, Konqueror, Archiver Manager.
> (compiled from comments and duplicate of this bug.)
>

Perhaps the update-manager should prevent users from running into this problem?

Changed in update-manager:
importance: Undecided → Wishlist
Michael Vogt (mvo) on 2008-10-29
Changed in update-manager:
status: New → Incomplete
Michael Vogt (mvo) on 2008-10-31
Changed in update-manager:
status: Incomplete → Invalid
Changed in gnome-panel:
importance: Undecided → Medium
milestone: none → intrepid-updates
status: New → In Progress
Michael Vogt (mvo) on 2008-11-03
Changed in gnome-panel:
assignee: nobody → mvo
Martin Pitt (pitti) on 2008-11-03
Changed in update-manager:
status: New → Invalid
Changed in nautilus:
status: New → Fix Released
Changed in gnome-panel:
status: New → Fix Committed
description: updated
description: updated
description: updated
Martin Pitt (pitti) on 2008-11-07
Changed in gnome-panel:
milestone: intrepid-updates → none
status: In Progress → Fix Released
Martin Pitt (pitti) on 2008-11-10
Changed in gnome-panel:
status: Fix Committed → Fix Released
Changed in gratissip:
status: New → Invalid
mario (trsma) on 2009-09-12
Changed in nautilus (Ubuntu):
status: Fix Released → Confirmed
Changed in nautilus:
status: Fix Released → Confirmed
Changed in gnome-panel (Ubuntu):
status: Fix Released → Confirmed
Changed in gnome-panel (Ubuntu Intrepid):
status: Fix Released → Confirmed
Steve Langasek (vorlon) on 2009-09-12
Changed in nautilus:
status: Confirmed → Fix Released
Changed in gnome-panel (Ubuntu Intrepid):
status: Confirmed → Fix Released
Changed in gnome-panel (Ubuntu):
status: Confirmed → Fix Released
Changed in nautilus (Ubuntu):
status: Confirmed → Fix Released
49 comments hidden view all 129 comments
Lex Ross (lross) wrote :

I hit the exact same problem when performing clean 9.10 Karmic install preserving my home directory. I had 7.04, 8.04, 8.10 and 9.04 clean installations before with no problems. Double-clicking folders on the desktop would open them implying there was an application registered for folder mime type. The places menu entries however did not work as per this bug report. Had to right-click on a folder, select "open with another program..." and then to pick nautilus as default application to open "this and other files of type "folder" to fix this issue.

I am not sure if the problem occurred right after install or after tracker installation and removal (and then I have manually removed ~/.config/tracker file as well). It may worth to look at tracker app as a potential source of a problem, as it was installed on earlier versions of Ubuntu by default, and is supposed to index files and folders so it could possibly affect mimetype list somehow.

Having said that, I never had a problem like this until upgrading to Karmic.

jarlaxl lamat (jarlaxl) wrote :

My two cents here if it d help someone:
This bug was triggered to my system (Jaunty) when i edited the program menu by remmoving some entries. Eg. removing the metacity entries (About 10 of them) which i have i no idea how they appeared in the program menu -unchecked- caused metacity not to run. Similarly removing Dolphin file manager entry (several entries) caused nautilus (the default one) not to open the shortcuts from the places menu.

2 comments hidden view all 129 comments
cement_head (andor-udel) wrote :

PLEASE STOP MARKING THIS EFFING BUG AS "FIX RELEASED"! IT IS NOT.

Totally fresh Karmic install -> completely borked after less than a month with this bug.

Rather than mark this as "fix released" maybe a developer could explain the problem in detail to us so that we can fix this as it gets screwed up?

I have to now waste a day reinstalling my O/S.

1 comments hidden view all 129 comments
cement_head (andor-udel) wrote :

Totally fresh Karmic install -> completely borked after less than a month with this bug.

Rather than mark this as "fix released" maybe a developer could explain the problem in detail to us so that we can fix this as it gets screwed up?

I have to now waste a day reinstalling my O/S.

Mackenzie Morgan (maco.m) wrote :

It's marked as fixed in Hardy and Intrepid. You're saying it exists in Karmic now too? When you say totally fresh, do you mean you do or don't have updates installed? If it was this bug coming back, it shouldn't take a month either. It should immediately break as soon as you opened a folder in any application other than Nautilus. Do you fit that completely reproducible test case? If not, open a new bug.

It's marked as fixed in Hardy and Intrepid. You're saying it exists
in Karmic now too? When you say totally fresh, do you mean you do or
don't have updates installed? If it was this bug coming back, it
shouldn't take a month either. It should immediately break as soon as
you opened a folder in any application other than Nautilus. Do you
fit that completely reproducible test case? If not, open a new bug.

Danté (dante-ashton) wrote :

I can confirm this bug still exists in Lucid (10.04)

The system defaulted to trying to open my Home directory in Movie Player.

1 comments hidden view all 129 comments
Mark Kaehny (kaehny) wrote :

Version 10.10 fresh updates as of 2010-7-10 with zero other changes also has this exact bug.
Going into .local/share/applications/mimeapps.list and altering mime-type for inode/directory to nautilus.desktop fixed the problem.
Something is changing or adding that line to that file.

2 comments hidden view all 129 comments

That's .local in your home dir right? Is this also with a fresh home dir?

Lars Ola Liavåg (l-liavag) wrote :

I thin I've got this too. Opening 'Computer' launches Nautilus but double-clicking any other folder opens Brasero. This appeared after my first (intentional) Brasero project since upgrading to Lucid. Simply no idea what has happened or why. Any help would be appreciated.

1 comments hidden view all 129 comments
Lars Ola Liavåg (l-liavag) wrote :

I think I've got this too. Opening 'Computer' launches Nautilus but double-clicking any other folder opens Brasero. This appeared after my first (intentional) Brasero project since upgrading to Lucid. Simply no idea what has happened or why. Any help would be appreciated.

Lars Ola Liavåg (l-liavag) wrote :

I opened Nautilus and right-clicked on an arbitrary folder. Under "Open with Other Application", I chose Nautilus and made sure the "remember this..." check was toggled on. Now, folders open with Nautilus as they should. Let's see how long it lasts...

ross morrish (rossnmare1) wrote :

Hi, I have 10.04 installed for a couple of months now. Recently when I open folders in places menu it open a file in VLC.
in usr/local/share/applications/mimeinfo.cache is the only file, no file called mimeapps.list. also if I open places then right click on folder like Home Folder it open up VLC right away. (is there a folder called Nautilus somewhere??? where do you go to make a file open with Nautilus and toggle remember this) My computer abilities are copy and paste. Help much appreciated.

3 comments hidden view all 129 comments
Mackenzie Morgan (maco.m) wrote :

If you hit alt+f2 and type in "nautilus" you can get a Nautilus (file browser)
window open.

Lars Ola Liavåg (l-liavag) wrote :

Actually, under right-click and "Open with Other Application", it doesn't say "Nautilus" but rather "File browser" (or whatever it's called in your system language). After doing this once and clicking "remember this", my problem is still gone.

ross morrish (rossnmare1) wrote :

the menu under places does not give me a option to open with other application. Only open, open in new tab, open in new window. If I go to places/computer it open in nautilus, and all items in the menu open up correctly. All my folders under these menu's open up correctly. If I right click any of these folders they are to open with file browser. The items menu does not give me this option to change what to open with. Tanks in advance for your help.

Lars Ola Liavåg (l-liavag) wrote :

Once you have Nautilus open, e.g. by typing nautilus in a terminal, you can navigate to and right-click on any of the objects in your Places menu and choose "other application" etc. This made my folders open with Nautilus again, whether I do it from the Places menu, using GNOME Do, or from within Nautilus itself. If this doesn't work for you, I'm afraid I have no further advice. Anyway, this is just the same workaround mentioned in the original bug posting and I guess this bug is really about the hijacking of the opening application in the first place.

ross morrish (rossnmare1) wrote :

no computer expert, just cut & paste
copy below into terminal
gksudo gedit cat ~/.local/share/applications/mimeapps.list

below list came...

Added Associations]

message/rfc822=gedit.desktop;openoffice.org-writer.desktop;thunderbird.desktop;

application/octet-stream=eog.desktop;

application/vnd.ms-powerpoint=openoffice.org-impress.desktop;openoffice.org-writer.desktop;nautilus-browser.desktop;

application/x-ole-storage=openoffice.org-draw.desktop;

inode/socket=f-spot-view.desktop;

application/x-extension-part=vlc.desktop;

inode/directory=vlc.desktop;nautilus-folder-handler.desktop;transmission.desktop;nautilus-browser.desktop;

application/x-executable=gedit.desktop;

application/x-extension-drive=nautilus-browser.desktop;

application/x-extension-link=nautilus-browser.desktop;

image/png=eog.desktop;f-spot-view.desktop;gimp.desktop;firefox.desktop;nautilus-browser.desktop;

text/x-ldif=gedit.desktop;openoffice.org-writer.desktop;thunderbird.desktop;

after ..
inode/directory=
delete ( vlc.desktop;)
should read..
inode/directory=nautilus-folder-handler.desktop;transmission.desktop;nautilus-browser.desktop;

worked for me!!!!

Changed in nautilus:
importance: Unknown → Medium
2 comments hidden view all 129 comments
Eugene Crosser (crosser) wrote :

The probem exists for me in Maverick.

If I have gnome-mplayer installed, *and* I have at least once opened System->Preferences->Preferred Applications (without changing anything there!) "Places" start being opened by mplayer instead of nautilus.

Presumably (?) "Preferred applications" creates ".local/share/applications/mimeapps.list" file, and it has "inode/directory" with "bad" order of entries.

Obvioulsy editing this file and making "nautilus-folder-handler.desktop" the first (or only) entry in this line reverts things to norm, but this should not happen in the first place.

3 comments hidden view all 129 comments
landennick (nick-lan-den) wrote :

Banshee did this to me in Maverick 10.10 to me. I installed Banshee using software centre and it took over from nautilus. The work around of running nautilus with run Application worked for me.

landennick (nick-lan-den) wrote :

Installing Banshee using software centre caused banshee to launch as the file manager in Maverick 10.10. The work around of running nautilus with run Application worked for me.

I have just experienced these exact symptoms on my upto date version of Ubuntu 10.10.

Any folder I opened from the "places" would immediately cause the entire contents of that folder to be opened by media player.

I fixed the problem afterwards by editing .local/share/applications/mimeapps.list as someone above recommended.

However it caused further dodgy problems on my system: The "update manager" popped up and thought it was doing a "partial upgrade". Update manager also prompted me to do "sudo apt-get install -f" and "sudo dpkg --configure -a" to clear things up, which worked eventually.

I would recommended that this bug be rated more seriously. It's still present in ubuntu 10.10.

Leading up to my experience of this bug, I had been trying to open a corrupted file in both VLC and Media Player, so maybe that was the cause?

Good luck with fixing it.

1 comments hidden view all 129 comments

An update for the record:

People were still reporting this into 2011, though this was marked fixed. (Except for a wish for upgrades to clean up cruft under ~/)

It was happening to me too, and has now been fixed again: see bug 797000. Permanently, I hope -- it seems we've replayed this problem. 'nautilus-folder-handler.desktop' is installed under /usr, and, with a clean config under .local, you can open folders with other apps, like media players. But the Trash, and places that should be opened with Nautilus, get Nautilus, and not those other apps, anymore. So I think the later comments were valid, and have finally been addressed.

Like I said, hope it stays that way! :)

Oh yeah -- if you do have older .desktop files, created by nautilus, in ~/.local/share/applications, you can still have the Trash opened with the movie player, etc. I had to delete those, specifically an old version of nautilus-folder-handler.desktop.

So the problem with this affecting upgrading users, rather than new installs, remains. That might be a wishlist bug for nautilus itself, for newer versions to clean up those old files. That might be more likely than trying to do it through update-manager.

Displaying first 40 and last 40 comments. View all 129 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.