Ubuntu

Black screen, and bad usplash.conf after installation

Reported by Patrice Vetsel on 2007-10-09
292
Affects Status Importance Assigned to Milestone
ubiquity (Baltix)
Undecided
Unassigned
ubiquity (Ubuntu)
Medium
Colin Watson
Gutsy
Medium
Colin Watson
usplash (Ubuntu)
High
Unassigned
Gutsy
Undecided
Unassigned

Bug Description

In Ubuntu 7.10, the desktop CD installer did not correctly configure the splash screen's resolution for the current hardware.

This problem is believed to be fixed in Hardy Alpha 2, and so should be fixed in Ubuntu 8.04.

If you are experiencing this bug and wish to verify whether it's due to the problem originally reported here, then please compare the resolution shown in System -> Administration -> Screens and Graphics (assuming you haven't changed it) with that in the file /etc/usplash.conf. They should be the same. For example, on the computer I'm using at the moment, Screens and Graphics says "Resolution: 1280x800" and /etc/usplash.conf has "xres=1280" and "yres=800".

If they are different, then this bug has recurred for some reason and I would like to know about it in this bug report.

If you find that the *live CD* does not display a splash screen while booting, or if you have an installed system that does not display a splash screen while booting but has the *same* values in Screens and Graphics and in /etc/usplash.conf as above, then this is not the same problem as this bug; instead, it is likely to be a deeper problem with the splash screen software, possibly specific to your hardware. Please report that on the 'usplash' package in Ubuntu.

Related branches

Jonathan Riddell (jr) wrote :

I confirm this in Kubuntu RC candidates. Affected two computers with different video cards. usplash.conf set to 1280x1024 when monitors are 1024x768

Changed in usplash:
status: New → Confirmed
Henrik Nilsen Omma (henrik) wrote :

As a data point, my Ubuntu desktop with 1280x1024 has the following usplash.conf

xres=1024
yres=768

Which looks fine, so I don't know why higher values would be needed here really.

Changed in usplash:
importance: Undecided → Medium
Colin Watson (cjwatson) wrote :

Fixed in my local tree, but needs testing and may be post-RC at this point.

Changed in ubiquity:
assignee: nobody → kamion
status: Confirmed → In Progress
Henrik Nilsen Omma (henrik) wrote :

stgraber confirmed on IRC that this also affects Ubuntu ninstalls.

Confirmed.

Stevi (stevi) wrote :

On my machine there's also a black screen during boot and shutdown-process.
(Toshiba Satellite Amilo Pro 100, Gutsy RC, ATI Mobility Radeon X1400 "1280x800", Intel Core Duo)

Stevi (stevi) wrote :

Sorry, I mixed up my machines. This bug appears on my Toshiba Satellite Pro A100.

DeployPenguins (deploypenguins) wrote :

I'm experiencing an issue with my Lenovo T60 X1400 where when I try to boot the LiveCD using either the normal boot selection or the Safe Graphics Selection, after the kernel configures itself, X tries to start "about 6 times" but fails each time. Looking at the Xorg file that was automatically configured for me indicates that the Safe Graphics mode correctly picked out the VESA driver.

I'm just worried because the issue I'm experiencing seems like the one I had with 7.04 Final and don't want it to repeat this time around. I did NOT have this problem with 7.10 Beta in Safe Graphics Mode.

This applies to 7.10 RC.

Again, this is the first time I've ever posted in a bug report, so please accept my dearest apologies for my inexperience. Thanks for everything you all do!

DeployPenguins (deploypenguins) wrote :

I forgot to post the "question" I had that lead to me writing the above comment. :) Sorry!

I wanted to know if this ticket applies to what I'm experiencing if maybe someone would kindly take the time to help me find out?

Thanks!

infodroid (infodroid) wrote :

I reported bug #152265 with similar problems. The screen is blank while booting up, however it did appear with the livecd but at the wrong resolution (it was not widescreen).

Just to point out my laptop is widescreen with resolution 1440x900. Hardware is Mobile Intel PM965 chipset with ATI Mobility Radeon X1350 graphics.

Roel Huybrechts suggested modifying the usplash.conf to 1024x768.

So I looked in /etc/usplash.conf and found the resolution to be 1280x1024. I changed it to 1024x768 but the screen was still blank during booting up. Also the same if I changed it to 1440x900.

bluwShark (bluwshark) wrote :

I was having the same issue with the black screen Dell that has a ati x1400 video card and widescreen lcd (1440x900) and was able to fix the problem using the steps below.

1) Change the resolution in /etc/usplash.conf to 1024x768
2) Add vga=791 to the kernel line in /etc/boot/menu.lst
3) sudo update-initramfs -u -k `uname -r`

I found the fix at https://bugs.launchpad.net/ubuntu/+source/usplash/+bug/63558

Harvey Muller (hlmuller) wrote :

Same experience reported by infodroid. Hardware similar, 1440x900 resolution laptop screen, PM965 chipset, NVIDIA GeForce 8400M GS.

Attempted fix reported by bluwShark, but no success.

Stéphane Graber (stgraber) wrote :

Markus Korn had a similar issue with Ubuntu Desktop amd64 (20071016).
In his case the uplash.conf xres and yres are empty then his screen goes off at boot time and he's unable to see anything till X started (unable to do the check CD for example).

Hardware is a Geforce 8600GT and a VGA screen (trough a DVI->VGA adapter).

Vadim Peretokin (vperetokin) wrote :

Same problem here, usplash.conf was reporting 1280x1024. I changed it down to 1024x768, but no deal. I'm on a ThinkPad T40, Radeon 7500.

But, oddly enough, the shutdown splash works. Just not the bootup one...

Drascus (enchantedvisionsband) wrote :

I have the same problem with my Compaq presario V2000 Laptop with AMD/ATI chipset. On boot up the Grub would display and then the screen would go blank. It did nothing after this. By holding ctrl/alt/F3 a command line displayed and the computer booted after this. I then received no login splash screen nor did I get a splash screen on shutdown.

Brett Alton (brett-alton) wrote :

Intel Celeron 1.7GHz, Intel 845GL northbridge, Intel 82801DB southbridge, Intel integrated 82845G GPU, generic 22" widescreen monitor.

No USplash.

I used "Start-up manager" to fix the problem. It was set at 1400x1050 so I changed the splash to 640x480. It also added the line "vga=791" and that may have helped.

yossarian (kapica-p) wrote :

HP ze2113us, ATI 200M - same problem as posted by Vadim Peretokin

(Usplash.conf was reporting 1280x1024. I changed it down to 1024x768, but no deal.
The shutdown splash works. Just not the bootup one)

Brett Alton (brett-alton) wrote :

=========
RUN THIS
=========
$ cp -p /boot/grub/menu.lst ~/menu.lst-bak && cp -p /etc/usplash.conf ~/usplash.conf-bak && sudo aptitude install startupmanager && gksudo startupmanager && echo '-- Please reboot your computer!'

--------------
REBOOT YOUR COMPUTER
--------------

==============
THEN RUN THIS
==============
$ cp -p /boot/grub/menu.lst ~/menu.lst && cp -p /etc/usplash.conf ~/usplash.conf && diff -ruN ~/usplash.conf-bak ~/usplash.conf > usplash.diff && diff -ruN ~/menu.lst-bak ~/menu.lst

--------------
THEN POST
--------------
 'usplash.diff' and/or 'menu.diff' if they're not empty (0 kb) and tell us if you can now see USplash.

Thanks :-)

JoshuaKersey (goodtimetribe) wrote :

experiencing problem on a N6600 with a VA1921wb via VGA and a panasonic 35" crt via s-vid.
 haven't had a chance to try above steps.

yossarian (kapica-p) wrote :

brettalton,

I have done exactly what you wrote above, then set in StartupManager 1024x768@16bits and it helped :)
usplash.diff is empty, menu.diff says:

--- /home/jump/menu.lst-bak 2007-10-19 12:09:55.000000000 +0200
+++ /home/jump/menu.lst 2007-10-19 10:24:00.000000000 +0200
@@ -30,7 +30,7 @@
 # control (menu entry editor and command-line) and entries protected by the
 # command 'lock'
 # e.g. password topsecret
-# password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
+## password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
 # password topsecret

 #

BTW, on my second HP ze2113us with ATI 200M I have tried another solution which also works:
1) Install ubuntu
2) Change the resolution in /etc/usplash.conf to 1024x768
3) sudo update-initramfs -u -k `uname -r`

Thank you for help! :-)

Giuseppe Pantanetti (sep) wrote :

I had the same problem on a IBM Thinkpad T43 (Model 2668Y3U) with an ATI Radeon Mobility X300 with a fresh install of Gutsy (desktop version).

I've solved this issue using bluwShark's procedure:
1) Changed the resolution in /etc/usplash.conf to 1024x768
2) sudo update-initramfs -u -k `uname -r`

I've to mention that, when usplash had problems, boot process took 180sec. since usplash monopolized all CPU resources (check attached image).

Harvey Muller (hlmuller) wrote :

Additional information - None of the above work to resolve the usplash issue on an Inspiron 1420 / NVIDIA GeForce 8400 on a Gutsy amd64 install. If I remember correctly when I was testing, the i386 version did not have this problem.

sirwitti (sirwitti) wrote :

same problem on Acer Travelmate 4001 LMi (1024 x 768): no bootsplash at startup, but at shutdown everything was fine. and it took some minutes (more than normal) to boot.

for me worked the workaround posted by bluwShark, but even without adding a line to grub's menu.lst:

1) changed the resolution in /etc/usplash.conf to 1024x768:
   xres=1024
   yres=786
2) executed the following:
sudo update-initramfs -u -k `uname -r`

now the bootsplash woks as it should, and the boot time is normal too.
so, thank you guys for helping :)
witti

BJizzle (redflag-420) wrote :

I have this same problem, though I'm trying to use frame buffer. I changed my resolution than ran update-initramfs and that didn't seem to help any. I'm going to try and not use frame buffer and see what it does.

BJizzle (redflag-420) wrote :

Yes, turning frame buffer off appears to allow the console to be displayed again at boot time.

Bug confirmed for Radeon Mobility U1 @ 1280x800
Workaround (as described): /etc/usplash.conf to 1024x768 && update-initramfs

Giuseppe Pantanetti (sep) wrote :

Some interesting news: I made a fresh install of Gutsy (on ATI Mobility Radeon X300 1024x768) with an alternate version disk and this problem didn't appear.
I suffered from this bug on my previous installation with a live/desktop disk...

Wingman (mikywing) wrote :

I confirm this bug. This happens also to me using a fresh install of ubuntu 7.10 final from the i386 desktop cd
I use a CRT screen (15 inchs) on an old nvdia RIVA TNT2 video card (open drivers). I haven't checked usplash.conf yet, i'll do it as soon as possible.

I also noticed that the sceen seems like non receiving a true video signal during the boot splashscreen since it's lights bink strangely. (sorry but i havent got the manual XD)

Hope this will be fixed soon :)

Tony Manco (trmanco) wrote :

I can get the splash screen but during the system boot the screen turns off and then turns on again, this also happens when I restart or shutdown.

Bruno Luna (brunoluna) wrote :

I confirm also this bug in my laptop (asus f5r, video card ati Xpress 200M, 1280x800, 60Hz). Same problem as the other guys, that means, without boot splash screen during start and shutdown of the system, and also the really slow boot(as mentioned by sirwitti). But I used the same workaround (usplash.conf set to 1024x768) and executed sudo update-initramfs -u -k `uname -r`) and everything is working fine now, boot splash is there and the whole process is much faster! So, I just would like to thank you guys very much for the help!!! See ya!

Raúl Santos (borfast) wrote :

I can also confirm this on my laptop (Acer TravelMate 4001 WLMi, graphics card ATI Mobility Radeon 9700/64 Mb).

After the fix in /etc/usplash.conf and executing «sudo update-initramfs -u -k `uname -r`» it came back to normal.

I have this error on my Laptop (Asus V1S) as well, graphics card NVidia Geforce 8600M GT. I tried changing resolutions in /etc/usplash.conf to 1024x768 and executed update-initramfs, but it didn't do any good or bad.

Vadim Peretokin (vperetokin) wrote :

Doing this as someone above posted:

"1) Changed the resolution in /etc/usplash.conf to 1024x768
2) sudo update-initramfs -u -k `uname -r`"

Fixed the issue for my ThinkPad T40 (Radeon 7500 as the video card).

Brett Alton (brett-alton) wrote :

If "sudo update-initramfs -u -k `uname -r`" doesn't work, can you please try my fix here: https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/150930/comments/18

Thank you.

Harvey Muller (hlmuller) wrote :

brettalton: For clarity, that along with the other suggestions have not worked in my case. There was no difference in the config files in my case. And running startupmanager did not have any effect on the system, unless I actually changed a value.

Brett Alton (brett-alton) wrote :

Well that's what I was trying to get you to do: use startmanager and make USplash 640x480 and see if it works. If it does, then give us the diff file to see what has changed.

I've fixed previous bad USplash's with this method. The only thing that I can see that fixed them was startupmanager concatenated 'vga=791' to the end of the kernel options in /boot/grub/menu.lst.

zajjar (zajjar) wrote :

I also confirm this bug on Toshiba Satelite A75-S206 (ATI Radeon Mobility 9000).

Workaround is similar to solutions described above:
1. Modify file: "/etc/usplash.conf" to 1280x800
2. Run: sudo update-initramfs -u -k `uname -r`

malaeum (malaeum) wrote :

I also am having this bug. On the 7.10 live cd I am getting it as well as on my installed OS. I am using an Nvidia 8600 GT with nvidia 100.14.X drivers installed via Envy.

I have two displays hooked up, each is 1280x1024. I tried updating /etc/usplash.conf to 1024x768, 800x600, and 640x480 and then using update-initramfs and each time the startup produced the same behavior. Grub loads and then a few lines of text and when it comes time to load the initrd it fails and I end up with a blank screen until kdm starts up. I have noticed that most people affected by this are on laptops, I however am not.

brettalton:
I tried your method and got basically nothing the diff output was basically that I used startupmanager to manually select 1280x1024 (vga=795). I'm going to try a few more things and play around with your suggestion at various resolutions to see if I can get any meaningful output to help troubleshoot this. Is there any sort of logfile specifically for initrd stuffs?

Sam Pearson (sagepe) wrote :

I have seen this bug with an old (~6 year) 1024x768 TFT driven by an nVidia GForce MX2 card following an install from the final Gutsy release CD. The monitor compains about the resolution before turning itself off until X comes up, which is configured fine and works perfectly.

First thing I tried was adding vga=791 to my boot params but this just triggered bug #129910 <https://bugs.launchpad.net/ubuntu/+source/initramfs-tools/+bug/129910>. Fixed this as in my post to that bug.

Editing /etc/usplash.conf to contain the correct res and then updating my initramfs with 'update-initramfs -u' fixed the splash screen issue.

Jonas Bygdén (jbygden) wrote :

Isn't this related to (or even a duplicate of) <a href="https://bugs.launchpad.net/bugs/129910">bug #129910</a>?

Colin Watson (cjwatson) on 2007-12-03
Changed in ubiquity:
milestone: ubuntu-7.10-rc → hardy-alpha-2
status: In Progress → Fix Committed
Colin Watson (cjwatson) on 2007-12-18
Changed in ubiquity:
status: Fix Committed → Fix Released
72 comments hidden view all 152 comments
fsstar (fsliuxiaoxing) wrote :

This problem occurred yesterday after a system update of 10 packages,so I tried to set the 640*480 resolution in the usplash.conf file and ran the 'sudo update-initramfs -u -k `uname -r` command ,it worked then.It seems ok today.

fsstar (fsliuxiaoxing) wrote :

I think the method mentioned in the comment by timbl is better than mine.

wangi (lee-leekindness) wrote :

As mentioned, none of the workarounds solved the issue for me on Fiesty or Gutsy and I was left with powersave during boot. Tonight I have downloaded the fresh Hardy Alpha 3 image (alternative 64bit) and done a clean install. I still have the same symptoms - the fix in Hardy does *not* make usplash work on my system.

Hardware details are above (a Dell Inspiron 530 with nVidia GeForce 8600 GT), let me know what I can post that will help nail this one

Thanks/L

wangi (lee-leekindness) wrote :

Oh, do I need to / should I report this elsewhere specifically against the Hardy alpha 3?

Saivann Carignan (oxmosys) wrote :

wangi : Thanks for your comment. Can you confirm that ubuntu still boot? If you don't even get to your Desktop, that is another bug like bug #179336. If your computer boot but that you just don't see usplash, it looks like we're talking about the same bug.

In case it's really the usplash bug, can you copy here :
1. The content of your /etc/usplash.conf file here?
2. The result of this command in a terminal : cat /etc/X11/xorg.conf | grep -A 4 'Section "Device"'

Thanks for these informations

wangi (lee-leekindness) wrote :

Hi Saïvann, yes the system still boots fine - monitor goes into powersave, boots up, out of powersave and shows gdm. I will reply with requested information later this evening. Thanks/L

wangi (lee-leekindness) wrote :

As requested:

wangi@figgate:~$ cat /etc/usplash.conf
# Usplash configuration file
xres=640
yres=480
wangi@figgate:~$ cat /etc/X11/xorg.conf | grep -A 4 'Section "Device"'
Section "Device"
 Identifier "Configured Video Device"
EndSection

Section "Monitor"
wangi@figgate:~$

Saivann Carignan (oxmosys) wrote :

Thanks for these informations. Can you also provide the result of that command in a terminal : lspci | grep VGA

wangi (lee-leekindness) wrote :

Sure:

wangi@figgate:~$ lspci | grep VGA
01:00.0 VGA compatible controller: nVidia Corporation GeForce 8600 GT (rev a1)

Thanks/L

Saivann Carignan (oxmosys) wrote :

wangi : Can you install ubuntu for i386 architecture and see if the problem still happens? I found the existence of bug #147623 which looks a lot like your problem and only happens with AMD64 ubuntu.

wangi (lee-leekindness) wrote :

Will do, downloading the ISO now. I can see the relationship and perhaps for many these are the same bugs. One difference is I boot into X fine, it's just that i'm in powersave until then. One of the dupes of this bug is a x64 only one, and when i386 is used it works.

wangi (lee-leekindness) wrote :

As expected the i386 build works, although with a usplash resolution of 640x480.

(However it's got its own problems and is less usable than the x86 version without usplash - after logon at gdm your stuck on the beige screen)

Saivann Carignan (oxmosys) wrote :

wangi : Thanks for your comment and for your hard testing.

From what you say, it seems clear that your bug is the bug #147623 and not this one, this was important to confirm this. bug #147623 does already have a lot of debugging informations so I think that we should wait. Concerning the new problem that you got with Hardy i386, if you're still in shape and that you're ready to contribute more, you can search for similar bug reports and look if you can contribute to one of them by giving debugging informations. However, you can also take a break and enjoy Gutsy ;) . Thanks for your contribution so far!

orange2k (orange2k) wrote :

Yesterday I downloaded Hardy 64-bit, and today I tried it. It still boots with no splash and no progress bar, so it looks like this problem hasn`t been fixed, yet.
Hardy (LiveCD) has (on my system) also another bug with display: when I set it to 1280x1024 resolution - 85 Hz, it switches to 84Hz (!) but thats another story and it probably doesnt belong here...

Pat_Primate (patprimate) wrote :

I posted this in Bug # 147623 as well (as I'm not sure which one is the most appropriate) - but I just tried Kubuntu 64 Hardy Alpha 3 and got this bug again. Booting off of the live cd with any of the default boot options results in a black screen (with monitor entering sleep mode eventually) and the system refuses to boot. I can't get into the system at all off of the live cd unless I remove 'splash' from the kernel options.

This is very unsettling, if we can't get this fixed before the 8.04, then I fear we will lose a lot of potential users (most newbies will not spend the time to learn how to fix it - they will simply give up on (K/X)Ubuntu).

I have a NVidia 8800GTS 320mb with a 22inch widescreen monitor

Let me know if/how I can help (as someone without programing skillz :S)

Pat

Saivann Carignan (oxmosys) wrote :

The black usplash screen problem with any {k}{x}ubuntu for AMD64 is bug #147623. This bug has enough information, unless you know something that has not been said in this bug report. However, you can contribute by testing new releases when this bug will be fixed. From now on, the bug is on the hand of the developers. Perhaps that it would be a good idea to speak directly to ubuntu developers about this. Thanks for your contribution.

Colin Watson (cjwatson) wrote :

If you are experiencing this bug and wish to verify whether it's due to the problem originally reported here, then please compare the resolution shown in System -> Administration -> Screens and Graphics (assuming you haven't changed it) with that in the file /etc/usplash.conf. They should be the same. For example, on the computer I'm using at the moment, Screens and Graphics says "Resolution: 1280x800" and /etc/usplash.conf has "xres=1280" and "yres=800".

If they are different, then this bug has recurred for some reason and I would like to know about it in this bug report.

If you find that the *live CD* does not display a splash screen while booting, or if you have an installed system that does not display a splash screen while booting but has the *same* values in Screens and Graphics and in /etc/usplash.conf as above, then this is not the same problem as this bug; instead, it is likely to be a deeper problem with the splash screen software, possibly specific to your hardware. Please report that on the 'usplash' package in Ubuntu. I'm sorry if this seems like being fobbed off (to quote an earlier commenter), but it is important to us to keep separate problems in separate bug reports, otherwise we can't keep track of what has been fixed where and things will be worse for everyone.

Thanks for your attention!

description: updated
Markus Korn (thekorn) wrote :

Hi Colin,
comparing these two values is impossible for me because displayconfig-gtk is not running properly (Bug 178061):
markus@markus-desktop:~$ cat /etc/usplash.conf
# Usplash configuration file
xres=640
yres=480
markus@markus-desktop:~$ displayconfig-gtk
*** Error: couldn't find any ServerLayout sections
markus@markus-desktop:~$

So I'm not sure if this is really related to the problem originally reported here.

Markus

Harvey Muller (hlmuller) wrote :

Colin,

In a fresh installation of Hardy Desktop amd64 Alpha 4, the problem is still present on the Dell Inspiron 1420 (nVidia GeForce 8400M GS). The screen blanks during normal boot period until gdm starts. Normal behaviour returns after manual fix.

Screens and Graphics reports the expected laptop screen resolution @ 1400x900. During installation, this had to be manually configured using displayconfig-gtk (pops up automatically)

/etc/usplash.conf differs with:
xres=640
yres=480

The manual fix is the same as previously stated:

- Modify /etc/usplash.conf (xres=1400 yres=900)
- Modify /boot/grub/menu.lst (add vga=0x0365 at end of kernel line)
- Modify /etc/initramfs-tools/modules (add fbcon and vesafb on separate lines)
- Modify /etc/modprobe.d/blacklist-framebuffer (comment out 'blacklist vesafb')\
- run 'sudo update-initramfs -u'

If there's additional information you need, please let me know.

Regards,

Harvey

Saivann Carignan (oxmosys) wrote :

Harvey Muller : Thanks for your comment. You are using a amd64 bit ubuntu edition with nvidia geforce 8400M GS, this is a known but with nvidia cards which you can find here : bug 147623. In order to make sure that you reproduced the good bug, can you try the same with ubuntu 32 bit? Thanks for your contribution.

i install ubuntu 7.10, then i update they want some (Third-party software, Authenticate) GPG key same time i want (Java Runtime Environment-6) JRE 6. how to install JRE 6. now i try shutdown my system it will be log and come to user name & Pass word ask (both shutdown and logoff all the time) then i directly switch off my system now i restart the ubuntu 7.10 it will not enter to normal and recovery, what can i do, i want JRE install and reset my ubuntu

Harvey Muller (hlmuller) wrote :

Saïvann Carignan:

Thank you for clarifying. I was unaware this bug report was for the Hardy Desktop i386 edition.

I've installed Hardy Desktop i386 Alpha 4 as you recommended and can confirm this bug is NOT an issue for this edition on my hardware. I will continue to watch bug 147623 instead.

The only related issue with the i386 edition is the blank ttys, but that's a different bug.

Appreciate your assistance!

Harvey

Saivann Carignan (oxmosys) wrote :

Colin Watson : Numerous comments in different bug reports says that usplash often get 640x480 resolution in Hardy. My own laptop which is always in 1440x900 resolution with Xorg did have a /etc/usplash.conf of 640x480 in Hardy Alpha 4. I suggest that we take a look at this before the final release.

bug 188764 in usplash describe the same problem, I confirmed it in usplash but if we find that this is still the ubiquity bug, we should mark it as a duplicate.

mbana (m.bana) wrote :

I've got the same problem, infact i can't even boot of the livecd i had to install of the alternate cd. In all honesty this is a huge bug, i could imagine alot of people being put of ubuntu because the live cd not working. If it makes a difference i using dvi.

here are my specs.

Samsung SpinPoint T 500GB SATA-II 16MB Cache - OEM (HD501LJ
Samsung SpinPoint T 320GB SATA-II 16MB Cache - OEM (HD321KJ)
Corsair HX 520W ATX2.2 Modular SLI Compliant PSU (CMPSU-520HXUK)
Corsair 4GB DDR2 XMS2 PC2-6400C5 TwinX (2x2GB)
Intel Core 2 Quad Pro Q6600 "Energy Efficient SLACR 95W Edition" 2.40GHz (1066FSB) - Retail
EVGA GeForce 8800 GTS "Crysis Edition" 512MB GDDR3 HDTV/Dual DVI (PCI-Express) - Retail (512-P3-E841-AE-CrysisUK)
Samsung SH-S203NRSMN 20x DVD±RW SATA Dual Layer Lightscribe ReWriter (Beige/Black/Silver) - Retail
Abit IP35 (Socket 775) PCI-Express DDR2 Motherboard
Logitech Wave Keyboard USB
Logitech MX518 Gaming mouse
Dell 22 inch Widescreen Flat Panel Display with built-in Webcam (SP2208WFP)

Just to let people know who might not. If none of the work arounds here seem to help you particular computer. You can always type "sudo gedit /boot/grub/menu.lst" Go to the this line in the document:
 "kernel /boot/vmlinuz-2.6.22-14-generic root=UUID=048896bf-abae-4771-82cf-53eff300fe28 ro quiet splash"

Erase the word splash then save the document.
This will allow Ubuntu to boot without a splash screen at all. It will show boot text instead. Not as aesthetically pleasing perhaps but it works.

fsstar (fsliuxiaoxing) wrote :

I re-installed Gutsy one week ago in my Intel845 machine with only one hard disk and let Gutsy to be my only OS,in these days ,this bug has not re -occurred.I have not changed the usplash.conf file ,because the 1280*1024 setting is correct.

Bram Stolk (b-stolk) wrote :

I have two graphic cards.
One is nVidia 6600
Other is nVidia 8600GT

The 6600 works with usplash
THe 8600 does not work with usplash. It does work with X though.

THis is on a 7.10 xubuntu install.

Also, I noticed I don't have my text consoles when using the 8600.
When removing the 8600, and using the 6600, my text consoles and usplash work.

  Bram

Saivann Carignan (oxmosys) wrote :

Bram Stolk : That means that your bug is bug 147623. Thanks :)

I just wanted to say thanks. Ubuntu 8.04 fixed this problem for me. The half-screen I was getting on login that I had to hit CTRL+ALT+DEL to resolve is also fixed.

Colin Watson (cjwatson) wrote :

xserver-xorg.postinst no longer sets up xserver-xorg/config/display/modes; instead, the X server deals with mode configuration at run-time. This means that usplash.postinst no longer has anywhere to get the correct modes.

In the desktop CD case, we can cope with this since we have a running X display, and can use xdpyinfo to fish the current screen dimensions out of that (although we may also have to restrict them to valid VESA modes). Unfortunately we can't do anything about the alternate install CD case, since an X server hasn't been started at the point when usplash is configured (well, we could perhaps do X -probeonly along the same lines as xresprobe, but that feels risky at this point).

I think the best option is to have usplash.postinst use xdpyinfo to fetch screen dimensions if DISPLAY is set. That way you at least have the option of reconfiguring usplash within a running X display if it picks the wrong values, and it keeps package-specific logic out of ubiquity. It won't be pretty, but is probably about the best we can do. I'll work on this.

Changed in usplash:
assignee: nobody → kamion
importance: Undecided → High
milestone: none → ubuntu-8.04
status: New → In Progress
Colin Watson (cjwatson) wrote :

7.10 had xserver-xorg/config/display/modes, so the usplash task is not relevant for gutsy.

Changed in usplash:
status: New → Invalid
Saivann Carignan (oxmosys) wrote :

Colin Watson : The current issue with Hardy is different from the initial issue described in this bug report. I believe that we should work on this in bug 188764 or, if you prefer, set bug 188764 as a duplicate of this one.

Colin Watson (cjwatson) wrote :

Bouncing around between bugs is boring, but sure, whatever you like ...

Changed in usplash:
status: In Progress → Invalid
assignee: kamion → nobody
milestone: ubuntu-8.04 → none
Åskar (olskar) wrote :

I can confirm this problem is still in latest hardy, upgraded yesterday

Saivann Carignan (oxmosys) wrote :

Åskar : Thanks for your comment, can your provide the following informations?

1. Did you fix the problem while you used Gutsy with the workaround? If not, no need to go further, installing a brand new Hardy system should not have this bug, but if you already have wrong values in /etc/usplash.conf and that you upgrade, nothing will change, Hardy will keep the existing values in /etc/usplash.conf.
2. If the problem suddenly appeared with Hardy, can you attach your /etc/usplash.conf ?
3. Can you also say what is the resolution of your screen as you can see in System / Preferences / Screen Resolution ?

If the values in /etc/usplash.conf were already the same as your actual screen resolution and that you still get this bug, you might have bug 205990.

Åskar (olskar) wrote :

Hi Saïvann

I did not fix the problem in gutsy, I used nosplash at grub instead. So perhaps that means that this was an old usplash.conf as you say.

I changed the resolution in /etc/usplash.conf in hardy and the problem went away. My resolution is 1440x900.

Saivann Carignan (oxmosys) wrote :

Thank you for your confirmation, that means that the bug is still fixed.

Bruce (hobsonb) wrote :

# Usplash configuration file
xres=1280
yres=1024

Reflects my Ctrl-F1 thru Ctrl-F6 screen settings. While my X-Windows screen is set for 1680x1050.

My Display Adapter is a Nvidia 8600 GT

Thanks,

Bruce

gamgee911 (samuel-grund) wrote :

Confirming for Ubuntu Hardy PPC

Fresh install on PowerBook G4 (nvidia graphics 867mhz). I changed the conf file to match my resolution but the colors are still messed up. I think they have to be increased to 16 bit color? I'm not sure how to do that however :/

Sergio Zanchetta (primes2h) wrote :

The 18 month support period for Gutsy Gibbon 7.10 has reached its end of life -
http://www.ubuntu.com/news/ubuntu-7.10-eol . As a result, we are closing the
Gutsy task.

Changed in ubiquity (Ubuntu Gutsy):
status: In Progress → Won't Fix
milestone: ubuntu-7.10-rc → none
Displaying first 40 and last 40 comments. View all 152 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers