Ubuntu

Embedded Terminal Emulator isn't giving a TERM variable

Reported by WalterCool on 2010-08-21
560
This bug affects 122 people
Affects Status Importance Assigned to Milestone
Awn Extras
Undecided
Unassigned
Gnome Virtual Terminal Emulator
Invalid
Medium
Guake
Invalid
Unknown
Release Notes for Ubuntu
Undecided
Unassigned
Terminator
Undecided
Unassigned
tilda
Undecided
Unassigned
awn-extras-applets (Ubuntu)
Low
Unassigned
Maverick
Low
Unassigned
guake (Ubuntu)
Low
Unassigned
Maverick
Low
Unassigned
lxterminal (Ubuntu)
Low
Unassigned
Maverick
Low
Unassigned
terminator (Ubuntu)
Undecided
Unassigned
Maverick
Undecided
Unassigned
vte (Ubuntu)
Low
Mathieu Trudel-Lapierre
Maverick
Low
Mathieu Trudel-Lapierre
xfce4-terminal (Ubuntu)
Undecided
Unassigned
Maverick
Undecided
Unassigned

Bug Description

Binary package hint: guake

This is the problem:

Root env fragment:

TERM=unknown
SHELL=/bin/bash

Users arent using a specified TERM variable, working very slow and problems..., i must set TERM=xterm and works fine

Thats happen on the last version of Guake (0.4.2-1)

Edited: Is strange... running guake from gnome-terminal works fine. Downgrading guake doesnt fix that too... someone can "trace" this error? Thanks

WalterCool (waltercool) on 2010-08-21
description: updated
MrMacman2u (mrmacman2u-gmail) wrote :

Having the same trouble here. Guake is a great time saver/convenience and having to manually set the TERM after every reboot is rather troublesome. Hope it's fixed soon, just shout if any additional information is needed!

Jason J. Herne (hernejj) wrote :

I can confirm this one as well. Changing status to confirmed.

Changed in guake (Ubuntu):
status: New → Confirmed
Sense Egbert Hofstede (sense) wrote :

I can confirm this bug and have forwarded it upstream. Therefore I'm marking this bug as Triaged. The importance is set to low since this bug has a moderate impact on a non-core application.

Changed in guake (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Changed in guake:
status: Unknown → New
MrMacman2u (mrmacman2u-gmail) wrote :

Yeah, this popped up on the Alpha and has carried over to the beta. Adding a screenshot depicting the bug.

The "normal" gnome terminal works just fine however.

fishexe (dyson-sphere-explorer) wrote :

Upgrading from Ubuntu 10.04 to Ubuntu 10.10beta causes this bug to arise.

Daniel Fett (fett-ubuntu) wrote :

The same happens to tilda as well. Seems as if an underlying shared component causes this bug.

Daniel Fett (fett-ubuntu) wrote :

Got it resolved by purging guake and reinstalling it. However, the problem persists in AWN's terminal plugin!

summary: - Guake isnt giving a TERM variable
+ Embedded Terminal Emulator isn't giving a TERM variable

My understanding is that this is due to a change in behaviour in new versions of libvte/python-vte. It used to provide the TERM variable, but now it doesn't and so it's up to the application (guake, tilda etc.) to provide it instead. I presume that this is an intentional change to libvte.

As a horrible, quick and dirty fix.

From /usr/bin/guake (press Alt+F2, type "gksudo gedit /usr/bin/guake",press Enter to edit), change:

exec -a guake $PYTHON -OO $GUAKEPATH/guake.py "$@"

To:

exec -a guake $PYTHON -OO $GUAKEPATH/guake.py "$@" -e "export TERM=xterm"

Is guake still being maintained? because I'll fork the code base and patch it properly myself if it is no longer being maintained.

JayCee (x-launchpad-jaycee) wrote :

Purge and reinstall guake doesn't help but Michael's tip fixed the problem for me.

Rhys Thomas (e-rhys-thomas) wrote :

Yes, thank you Michael for that quick fix.

The fix will only work for the 1st tab though, a terminal variable needs to be set manually for a new tab.

David Lavoie (david-nectyr) wrote :

Have the same problem, I added the:
export TERM=xterm
to my ~/.bashrc file to correct on all guake tabs (must restart guake or open a new guake tab to see the results)

Daniel Fett (fett-ubuntu) wrote :

I don't believe this was an intentional change, because vte.Terminal.get_emulation() still returns xterm. But I can't find any documentation either.

sasagundul (mindscrewer06) wrote :

maybe you can try this quick fix:

edit /etc/environment

add "export TERM=xterm" without quotes

then reboot

Urs Fleisch (ufleisch) wrote :

I have the same problem with lxterminal from Lubuntu 10.10, so this problem may also affect lxterminal.

Leo Arias (elopio) wrote :

Happens to me too on AWN terminal applet. Marking as confirmed.

elopio@elopio-laptop:~$ top
TERM environment variable not set.

I'm using Maverick beta.

Changed in awn-extras:
status: New → Confirmed
tags: added: maverick
Jens Maucher (jensmaucher) wrote :

Same probleme here.

Nicolas Vandamme (n.vandamme) wrote :

Has anyone try to set emulation in this case ?

In GuakeTerminal.configure_terminal:

if not self.get_emulation() or self.get_emulation() == '':
    self.set_emulation("xterm")

Victor (v-simankin) wrote :

if not self.get_emulation() or self.get_emulation() == '':
      self.set_emulation('xterm')
work!

Victor (v-simankin) wrote :

iam add "export TERM=xterm" to /usr/bin/guake

# cat /usr/bin/guake
#!/bin/bash
#
# Copyright (C) 2007 Gabriel Falcão <email address hidden>
..............................................

GUAKEPATH="/usr/lib/guake"
PYTHONPATH="$PYTHONPATH:$GUAKEPATH"
PYTHON="/usr/bin/python"
export TERM=xterm

exec -a guake $PYTHON -OO $GUAKEPATH/guake.py "$@"

On 21 September 2010 13:46, Victor <email address hidden> wrote:
> if not self.get_emulation() or self.get_emulation() == '':
>      self.set_emulation('xterm')
> work!
>

I confirm: the patch seems to work...

actually there's something strange: launching guake from terminal it
works, but by closing guake & reopening it from the launcher it
doesn't use the new TERM variable...
don't know... maybe the launcher has some strange flag that causes
configure_terminal() to never be called, or maybe a simple
logout/login would fix it... i'll try it later since now i don't have
time

Sylvestre Ledru (sylvestre) wrote :

Funny, this bug does not exist under the Debian version of this package ...

Same bug here.

I think the importance should be raised : most of the CLI program will not work properly using guake...

Alejandro Díaz-Caro (janus) wrote :

On Fri, Sep 24, 2010 at 12:00 PM, Sylvestre Ledru
<email address hidden> wrote:
> This upload fixes this issue:
> https://launchpad.net/ubuntu/maverick/+source/guake/0.4.2-2ubuntu1

I confirm that I still have the issue with this package version.

Sylvestre Ledru (sylvestre) wrote :

Alejandro Díaz-Caro: could you send me the content of /usr/bin/guake ?
thanks

Alejandro Díaz-Caro (janus) wrote :

On Fri, Sep 24, 2010 at 4:01 PM, Sylvestre Ledru
<email address hidden> wrote:
> Alejandro Díaz-Caro: could you send me the content of /usr/bin/guake ?
> thanks

Here you are:

#!/bin/bash
#
# Copyright (C) 2007 Gabriel Falcão <email address hidden>
# Copyright (C) 2007 Lincoln de Sousa <email address hidden>
#
# This program is free software; you can redistribute it and/or
# modify it under the terms of the GNU General Public License as
# published by the Free Software Foundation; either version 2 of the
# License, or (at your option) any later version.
#
# This program is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
# General Public License for more details.
#
# You should have received a copy of the GNU General Public
# License along with this program; if not, write to the
# Free Software Foundation, Inc., 59 Temple Place - Suite 330,
# Boston, MA 02111-1307, USA.

GUAKEPATH="/usr/lib/guake"
PYTHONPATH="$PYTHONPATH:$GUAKEPATH"
PYTHON="/usr/bin/python"

exec -a guake $PYTHON -OO $GUAKEPATH/guake.py "$@"

Gabor Karsay (gabor-karsay) wrote :

Awn Terminal, Ubuntu 10.10 beta:
"echo $TERM" gives me on i386 "xterm", user Federico Vera reported it (in a duplicate) to be "dumb" on x64.

Julien Lavergne (gilir) on 2010-09-25
Changed in awn-extras-applets (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Julien Lavergne (gilir) wrote :

There is a possible fix upstream in the 0.26 version : http://git.gnome.org/browse/vte/commit/?h=vte-0-26&id=0574bcfbd5c5925458ecdea0e6bbac6d65e30efc
I'm preparing a package with the patch to be able to test the fix.

Changed in lxterminal (Ubuntu):
status: New → Triaged
Changed in vte (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Changed in lxterminal (Ubuntu):
importance: Undecided → Low
Julien Lavergne (gilir) wrote :

The 0.26 of vte is available in Maverick, could you test and report back if the problem is fixed ?

Alejandro Díaz-Caro (janus) wrote :

On Mon, Sep 27, 2010 at 11:36 PM, Julien Lavergne
<email address hidden> wrote:
> The 0.26 of vte is available in Maverick, could you test and report back
> if the problem is fixed ?

I just updated and upgraded my Maverick and the problem is still there.

Is a new gnome session login necessary for this, or not? Because I did install the new 0.26 packages and restarted guake but still have this issue. (and cannot logout/login at this very moment because I am syncing lots of stuff to my phone)

Julien Lavergne (gilir) wrote :

Thank you for the tests. Forwarded upstream.

Changed in vte:
importance: Unknown → Medium
status: Unknown → New
Snowmean (snowmean-gmail) wrote :

Confirm this bug after upgrade to 10.10 beta.

Fido (fedevera) wrote :

I just did a fresh install with Maverick's daily build (64-bits) and the bug is still present, 'export TERM=xterm' works like a charm though.

Man doesn't work with this bug. But the weird is that gnome-terminal is not affected, at least not in maverick RC. Guake still is.

Changed in guake (Ubuntu):
status: Triaged → Confirmed
DLCBurggraaff (burdi) wrote :

xfce4-terminal is affected as well.

I think it is better to state
   [ "$TERM" = dumb ] && export TERM=xterm
in /etc/bash.bashrc - applies to all users and does not affect the consoles.

Changed in vte (Ubuntu):
assignee: nobody → Mathieu Trudel (mathieu-tl)
status: Triaged → In Progress

I have confirmed this bug in xfce4-terminal.

Changed in xfce4-terminal (Ubuntu):
status: New → Confirmed
Dave (davem99) wrote :

Another confirmation for xfce4-terminal in xubuntu 10.10.

Adding [ "$TERM" = dumb ] && export TERM=xterm to /etc/bash.bashrc seems to make it go away.

tags: added: iso-testing

This is an issue in vte that we should be able to fix for all these terminal emulators as SRU right after release.

screen is affected as well

Bremm (bremm) wrote :

Tested DLCBurggraaff's solution and it works for me (no need of rebooting). Xubuntu 10.10 xfce4-terminal.

Changed in vte:
status: New → Unknown
Vadim Peretokin (vperetokin) wrote :

Same problem upon upgrade, DLCBurggraaff's fix worked.

Martin Pitt (pitti) wrote :

Mathieu, are the other tasks still actually relevant? Can you please invalidate them if not?

Changed in vte (Ubuntu Maverick):
status: In Progress → Fix Committed
tags: added: verification-needed

Accepted vte into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Martin Pitt (pitti) wrote :

The current patch seems to be an appropriate workaround. What about the official one at

  http://git.gnome.org/browse/vte/commit/?id=e5fd6c3cda63cad2e3d7af8728a168b90eb009dc

?

Sense Egbert Hofstede (sense) wrote :

I can confirm the solution in maverick-proposed fixes this bug. I'm therefore marking the Guake task Invalid since this issue is not a Guake issue.

Other reporters, please let know if the other applications are also fixed by the new version of vte. Do make sure that the version of vte at your system is at least '1:0.26.0-0ubuntu2' since the fix isn't available to the bulk of the users, you have to have enabled the proposed updates.

Changed in guake (Ubuntu Maverick):
status: Confirmed → Invalid
elrond (elrond.) wrote :

I also can confirm that the vte update in maverick-proposed fixes the bug (at least for lxterminal).

Changed in lxterminal (Ubuntu Maverick):
status: Triaged → Invalid
Norko (norko-solko) wrote :

I also discovered this bug after updating to 10.10 Maverick Meerkat.
Guake said:
     When starting top: TERM environment variable not set.
     htop: Error opening terminal: unknown.
     mc: TERM environment variable needs set.
     screen: Please set a terminal type.

I read this thread and tested lxterminal, tilda, xfce4-terminal - they said the same.

Solved with maverick-proposed's vte packages '1:0.26.0-0ubuntu2' on amd64. All four (guake, lxterminal, tilda, xfce4-terminal) now works. Thank you!

tags: added: verification-done
removed: verification-needed
Sense Egbert Hofstede (sense) wrote :

Thanks to everyone for reporting this bug and testing the solution, and especially thanks to Mathieu Trudel for writing the patch. I assume the patch has been forwarded upstream?

Changed in awn-extras-applets (Ubuntu Maverick):
status: Triaged → Invalid
Changed in xfce4-terminal (Ubuntu Maverick):
status: Confirmed → Invalid
Sense Egbert Hofstede (sense) wrote :

Closing all tasks for projects other than VTE as Invalid since it is not a bug in anything else but VTE.

Changed in awn-extras:
status: Confirmed → Invalid
Changed in tilda:
status: New → Invalid
Fido (fedevera) wrote :

I can confirm that the update fixes the problem in avant-window-navigator terminal plugin.

Changed in guake:
status: New → Invalid
Daniel Holm (danielholm) wrote :

Confirm that the VTE packe fixes this error in Guake.

Dietmar Winkler (dietmarw) wrote :

I can confirm this on 10.10. final release when using Tilda.

Changed in tilda:
status: Invalid → Confirmed
Sense Egbert Hofstede (sense) wrote :

I'm closing this task for Tilda again since this issue is not a bug in Tilda but rather a bug in VTE. There is a fix for this bug waiting in the test section, I suspect it will be available to all users soon.

Changed in tilda:
status: Confirmed → Invalid
Dario Bertini (berdario) wrote :

my 2 cents:

i don't think it's wise to set the bug for all those projects as invalid

even if the bug is not in the sources of these projects, it is still affecting the application, and thus i think that we risk to see many more users like Dietmar who are still affected by the bug (that is, until the fix will be released in the normal updates), and thus think of changing the status of the bug back to confirmed... especially for a bug with an high notability like this one (many duplicates and many projects affected)

Dietmar Winkler (dietmarw) wrote :

Thanks Dario, exactly what I thought. Just because it's reported to upstream doesn't mean that it's already fixed for the application that this also impacts. For me it as just logical to report this as not fixed yet for this application.

Sense Egbert Hofstede (sense) wrote :

I agree that this may be confusing for users because they don't have (and can't be asked to have) notion of the relation between the way an application acts and the libraries it uses. Launchpad may need some improvement there. However, this is not an issue in Tilda and doesn't need to be fixed by people working on Tilda. Therefore, it's correct to mark this bug as Invalid for Tilda.

This bug hasn't been fixed upstream as far as I'm aware—even though it has been reported upstream—but there is a task for the upstream bug open as you can see above. There is a fix in the proposed updates section of Maverick, and I hope that it will be made available for all Maverick users shortly.

I understand that there might have been some confusion, we cannot expect everyone to know everything about the way we work, but please don't make changes to bug statuses without reading the bug's discussion and without being sure what you're doing.
If you're not, just leave a comment and we'll be glad to process that information. Thank you!

Dario Bertini (berdario) wrote :

if the problem is to avoid presenting this bug as a thing to be worked upon by the various developers team, i think there could be 3 different compromises:

1- (would require an enhancement in launchpad or to workaround this with a tag) set the bug-project combination of #621927 & vte as blocking for all the other projects
2- (since, to be certain that the bug depended only on vte, a fix had to be developed, this shouldn't be a problem) set the bug as fix commited also for all the other projects
3- set the bugs as confirmed, but ignore confirmed bugs in the workflow: only work on triaged bugs... since the bug can't be really fixed in tilda, guake, etc. in this case we could have reverted the state from "triaged" to "confirmed" (using as definition of triaged: "ready to be worked upon by the developer")

i realize that to enhance launchpad another bug (or blueprint) should be opened, but i'm writing this down also because it could be "simply" the way that you work to be improved

obviously, by definition, it's the way _you_ work, so at the end of the day it's only your decision that matters on how you decide to do these things

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vte - 1:0.26.0-0ubuntu2

---------------
vte (1:0.26.0-0ubuntu2) maverick-proposed; urgency=low

  * debian/patches/lp621927_set_default_term.patch: properly set TERM
    environment variable if unset on vte_terminal_init so applications started
    from the wm menus properly get a sane value to begin with (LP: #621927)
 -- Mathieu Trudel-Lapierre <email address hidden> Tue, 05 Oct 2010 15:02:50 -0400

Changed in vte (Ubuntu Maverick):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

This was tested by several people, and causes a lot of confusion, so I'll skip the usual 7 day maturing period and release this now.

Martin Pitt (pitti) wrote :

Closing release notes task, the bug is fixed in -updates now.

Changed in ubuntu-release-notes:
status: New → Won't Fix
Martin Pitt (pitti) wrote :

Copied to natty as well.

Changed in vte (Ubuntu):
status: Fix Committed → Fix Released
Franko Burolo (fburolo) wrote :

I am still experiencing this bug...

Bremm (bremm) wrote :

I was, but after downloading libvte9_1%3a0.26.0-0ubuntu2 and libvte-common_1%3a0.26.0-0ubuntu2 the problem was solved.

It's already available through normal updates. Try it with update-manager.

Johnny (jonikang) wrote :

i can confirm that the update works well as the resolution.

Chris Jones (cmsj) on 2010-10-14
Changed in terminator (Ubuntu):
status: New → Fix Released
Changed in terminator (Ubuntu Maverick):
status: New → Fix Released
Changed in terminator:
status: New → Fix Released
Chris Jones (cmsj) wrote :

For the various upstream terminal projects following along - it seems like a wise idea to specifically set TERM to xterm in your terminal code. GNOME Terminal does this (see terminal-screen.c around like 1386), and as a result of our early Maverick testing, Terminator 0.95 also follows this behaviour now. I'm not going to go as far as changing the Invalid statuses though :)

Sasquatch (sasquatch) wrote :

I have the symptoms of this bug, yet am fully updated. I upgraded from 10.04 Xubuntu to 10.10 Xubuntu. When I type 'env' in my terminal, it says that TERM=linux. This messes things up with vim, less and man when using the home and end keys (and arrow keys). It seems that the fix in libvte is not working for me, the variable is set again on a later stage, overwriting the fix.
It's a problem on xfce4-terminal as well as on a TTY. I can't find anything in my user profile that links to this variable, so it has to be set globally somewhere. Where is this variable set and how can I change it to xterm?

sargas (sargas) wrote :

In my tty's, having a TERM=linux is the default and doesn't cause problems with vim. Perhaps you have another bug?

xfce4-terminal is what sets the TERM, but it shouldn't be linux, since then programs wouldn't know they can set the title.

DLCBurggraaff (burdi) wrote :

In a freshly installed Xubuntu 10.10 (from the desktop CD) and all updates applied, but no personal settings yet:

burdi01@riposo:~$ env | grep TERM
TERM=xterm
COLORTERM=Terminal
burdi01@riposo:~$

DLCBurggraaff (burdi) wrote :

The above is in Terminal 0.4.5, on a console it is:

burdi01@riposo:~$ env | grep TERM
TERM=linux
burdi01@riposo:~$

In both instances I can run top and friends.

Sasquatch (sasquatch) wrote :

Correct, I just checked with my freshly installed Xubuntu 10.10 at work and Xfce4-terminal shows xterm, TTY says linux. But on my PC at home, both show Linux and Xfce4-terminal has problems. It does have xterm set as TERM variable. This variable is not accepted. I changed it to linuz, env still shows linux.
My laptop has the same problem and it too was upgraded from 10.04 to 10.10 and fully updated. I can of course add a work-around as described above that exports TERM in my .bashrc, but that doesn't fix the actual bug. I really wonder why the variable isn't set by xfce4-terminal.

Sasquatch (sasquatch) wrote :

I just removed GDM in favour of LXDM on my laptop and suddenly it's showing this issue. This bug is not solved if you are using a different login manager like LXDM. AFAIK, GDM and KDM work around this 'bug'. No idea about WDM or other login managers.

gnome-terminal sets TERM for you. And Guake never set it, libvte did,
which is what changed. I made some instructions on how to work around
this before it was fixed in GDM. Assuming you use Ubuntu (or other
flavor which has profile.d) follow them:
http://joelslinux.blogspot.com/2010/10/ubuntu-maverick-term-variable.html
Othewise change it so that you add the line directly to /etc/profile.

That should fix it.

On Sat, Nov 13, 2010 at 6:28 PM, Sasquatch <email address hidden> wrote:
> I just removed GDM in favour of LXDM on my laptop and suddenly it's
> showing this issue. This bug is not solved if you are using a different
> login manager like LXDM. AFAIK, GDM and KDM work around this 'bug'. No
> idea about WDM or other login managers.
>
> --
> Embedded Terminal Emulator isn't giving a TERM variable
> https://bugs.launchpad.net/bugs/621927
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (635804).
>
> Status in Awn Extras: Invalid
> Status in Guake: Invalid
> Status in Terminator: Fix Released
> Status in Tilda: Invalid
> Status in Release Notes for Ubuntu: Won't Fix
> Status in Gnome Virtual Terminal Emulator: Unknown
> Status in “awn-extras-applets” package in Ubuntu: Invalid
> Status in “guake” package in Ubuntu: Invalid
> Status in “lxterminal” package in Ubuntu: Invalid
> Status in “terminator” package in Ubuntu: Fix Released
> Status in “vte” package in Ubuntu: Fix Released
> Status in “xfce4-terminal” package in Ubuntu: Invalid
> Status in “awn-extras-applets” source package in Maverick: Invalid
> Status in “guake” source package in Maverick: Invalid
> Status in “lxterminal” source package in Maverick: Invalid
> Status in “terminator” source package in Maverick: Fix Released
> Status in “vte” source package in Maverick: Fix Released
> Status in “xfce4-terminal” source package in Maverick: Invalid
>
> Bug description:
> Binary package hint: guake
>
> This is the problem:
>
> Root env fragment:
>
> TERM=unknown
> SHELL=/bin/bash
>
> Users arent using a specified TERM variable, working very slow and problems..., i must set TERM=xterm and works fine
>
> Thats happen on the last version of Guake (0.4.2-1)
>
> Edited: Is strange... running guake from gnome-terminal works fine. Downgrading guake doesnt fix that too... someone can "trace" this error? Thanks
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/awn-extras/+bug/621927/+subscribe
>

Sasquatch (sasquatch) wrote :

I am aware of the work around, it's just that this 'bug' is only fixed when you use GDM or KDM. Xfce4-terminal should set the variable too, but it never happens. It's xterm by default, but even if you enter some garbage text, the $TERM variable will always be linux. I find it odd that this bug is marked as invalid for xfce4-terminal, while it's very apparent.
I think I'll just add 'export TERM=xterm' to my .bashrc or something.

Sasquatch (sasquatch) wrote :

I tried the xterm.sh in /etc/profile.d/ but that didn't work at all. The only thing that does work, is put it in .bashrc. That's hardly a solution.

Changed in vte:
status: Unknown → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.