Ubuntu

[apport] gnome-panel crashed with SIGSEGV on package installation, valgrind log required

Reported by WINTLE, John on 2007-02-17
This bug affects 13 people
Affects Status Importance Assigned to Milestone
GNOME Panel
Fix Released
Critical
gnome-panel (Ubuntu)
High
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-panel

happened with package upgrade.

ProblemType: Crash
CrashCounter: 1
Date: Sat Feb 17 22:29:23 2007
Disassembly: 0xb749f984:
DistroRelease: Ubuntu 7.04
ExecutablePath: /usr/bin/gnome-panel
Package: gnome-panel 2.17.91-0ubuntu1
ProcCmdline: gnome-panel --sm-client-id 117f000101000117161269800000051250000 --screen 0
ProcCwd: /home/john
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: gnome-panel
Stacktrace:
 Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
 #0 0xb749f984 in ?? ()
StacktraceTop: ?? ()
ThreadStacktrace:

Uname: Linux john-laptop 2.6.20-6-generic #2 SMP Wed Jan 31 20:53:39 UTC 2007 i686 GNU/Linux
UserGroups: adm admin audio cdrom dialout dip floppy lpadmin netdev plugdev powerdev scanner video

WINTLE, John (johnwintle) wrote :
Sebastien Bacher (seb128) wrote :

Thanks for your bug report. The crash looks like a memory corruption. Could you try to get a valgrind log for it? (you can follow the instructions from https://wiki.ubuntu.com/Valgrind for that)

Changed in gnome-panel:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: Unconfirmed → Needs Info
Sebastien Bacher (seb128) wrote :

Subscribing Vincent who is upstream, launchpad is getting a lot of duplicates for that bug and it's likely that bug-buddy will do that on bugzilla, he might be interested to informations on the topic

From a valgrind log that might be a GTK problem, the log has several mentions from that:

"

==8991== Invalid read of size 1
==8991== at 0x40222BE: strcmp (mc_replace_strmem.c:341)
==8991== by 0x48675F3: g_str_equal (gstring.c:77)
==8991== by 0x483E81E: g_hash_table_insert (ghash.c:240)
==8991== by 0x437F35C: insert_theme (gtkicontheme.c:2213)
==8991== by 0x4380BBD: ensure_valid_themes (gtkicontheme.c:1044)
==8991== by 0x4381277: gtk_icon_theme_get_icon_sizes (gtkicontheme.c:1493)
==8991== by 0x44D99E7: icon_list_from_theme (gtkwindow.c:2767)
==8991== by 0x44DA011: gtk_window_realize_icon (gtkwindow.c:2851)
==8991== by 0x47FA9C8: g_cclosure_marshal_VOID__VOID (gmarshal.c:77)
==8991== by 0x47ED62A: g_closure_invoke (gclosure.c:490)
==8991== by 0x47FE0F2: signal_emit_unlocked_R (gsignal.c:2440)
==8991== by 0x47FF616: g_signal_emit_valist (gsignal.c:2199)
==8991== Address 0x5924B80 is 0 bytes inside a block of size 7 free'd
==8991== at 0x4020F9A: free (vg_replace_malloc.c:233)
==8991== by 0x4851F90: g_free (gmem.c:187)
==8991== by 0x483E730: g_hash_table_replace (ghash.c:390)
==8991== by 0x437F33F: insert_theme (gtkicontheme.c:2212)
==8991== by 0x4380BBD: ensure_valid_themes (gtkicontheme.c:1044)
==8991== by 0x4381277: gtk_icon_theme_get_icon_sizes (gtkicontheme.c:1493)
==8991== by 0x44D99E7: icon_list_from_theme (gtkwindow.c:2767)
==8991== by 0x44DA011: gtk_window_realize_icon (gtkwindow.c:2851)
==8991== by 0x47FA9C8: g_cclosure_marshal_VOID__VOID (gmarshal.c:77)
==8991== by 0x47ED62A: g_closure_invoke (gclosure.c:490)
==8991== by 0x47FE0F2: signal_emit_unlocked_R (gsignal.c:2440)
==8991== by 0x47FF616: g_signal_emit_valist (gsignal.c:2199)"

Changed in gnome-panel:
importance: Medium → High
status: Needs Info → Confirmed
Sebastien Bacher (seb128) wrote :

I've opened http://bugzilla.gnome.org/show_bug.cgi?id=409101 upstream on GTK about that invalid read pointed with valgrind

Changed in gnome-panel:
status: Unknown → Unconfirmed
wiz (wiz) wrote :

Just caught this one. Installed gparted and gnome-panel suddenly crashed.

Michael Nagel (nailor) wrote :

gnome-panel crashed during installation of today's dist-updates and asked me to report a bug... i agreed, chose to upload the complete log and was taken to:

file:///home/nailor/%22https://launchpad.net/ubuntu/+source/gnome-panel/+filebug/8hXXDuuk1kH3ZlC0FfbYNTcPY1s?field.title=%5Bapport%5D+gnome-panel+crashed+with+SIGSEGV%22

this file does not exist, of course and even removing the invalid prefix does not help really.

additionally, gnome-panel crashed two more times after i tried to submit the bug, but it seems to be running fine right now...

Vincent Untz (vuntz) wrote :

Got the crash this morning :-)
It's weird that it only happens in the panel...

Changed in gnome-panel:
status: Unconfirmed → Fix Released
Sebastien Bacher (seb128) wrote :

That upload fixes the GTK problem:

 gtk+2.0 (2.10.9-0ubuntu2) feisty; urgency=low
 .
   * debian/control.in:
     - Desktop Team is the Maintainer for Ubuntu
   * debian/patches/090_from_svn_fix_incorrect_gtkicontheme_read.patch:
     - patch from the SVN, fix incorrect read to gtkicontheme
       which might be causing gnome-panel crashes on packages upgrade
       (Ubuntu: #85776)

Marking the bug "Needs Info", would be interesting if that still happens after the update and restart the panel to run the new GTK code. I'll mark the bug fixed if the launchpad stops getting duplicates about that crash

Changed in gnome-panel:
status: Confirmed → Needs Info
William Grant (wgrant) wrote :

I still get crashes on some upgrades.

Sebastien Bacher (seb128) wrote :
Download full text (5.3 KiB)

New valgrind crash:

==1171== Invalid read of size 1
==1171== at 0x402255E: strcmp (mc_replace_strmem.c:341)
==1171== by 0x48717B3: g_str_equal (gstring.c:77)
==1171== by 0x48489FE: g_hash_table_insert (ghash.c:240)
==1171== by 0x4386F97: ensure_valid_themes (gtkicontheme.c:1133)
==1171== by 0x438766F: gtk_icon_theme_lookup_icon (gtkicontheme.c:1268)
==1171== by 0x807D3C9: panel_find_icon (panel-util.c:640)
==1171== by 0x807D468: panel_load_icon (panel-util.c:668)
==1171== by 0x806F46C: button_widget_reload_pixbuf (button-widget.c:187)
==1171== by 0x806F515: button_widget_icon_theme_changed (button-widget.c:210)
==1171== by 0x48049D8: g_cclosure_marshal_VOID__VOID (gmarshal.c:77)
==1171== by 0x47F762A: g_closure_invoke (gclosure.c:490)
==1171== by 0x4808102: signal_emit_unlocked_R (gsignal.c:2440)
==1171== by 0x4809626: g_signal_emit_valist (gsignal.c:2199)
==1171== by 0x48097E8: g_signal_emit (gsignal.c:2243)
==1171== by 0x438629F: do_theme_change (gtkicontheme.c:624)
==1171== by 0x4386AE4: gtk_icon_theme_rescan_if_needed (gtkicontheme.c:1725)
==1171== by 0x4386EDD: ensure_valid_themes (gtkicontheme.c:1192)
==1171== by 0x438766F: gtk_icon_theme_lookup_icon (gtkicontheme.c:1268)
==1171== by 0x807D3C9: panel_find_icon (panel-util.c:640)
==1171== by 0x807D468: panel_load_icon (panel-util.c:668)
==1171== by 0x806F46C: button_widget_reload_pixbuf (button-widget.c:187)
==1171== by 0x806F515: button_widget_icon_theme_changed (button-widget.c:210)
==1171== by 0x48049D8: g_cclosure_marshal_VOID__VOID (gmarshal.c:77)
==1171== by 0x47F770C: g_closure_invoke (gclosure.c:490)
==1171== by 0x4808102: signal_emit_unlocked_R (gsignal.c:2440)
==1171== by 0x4809626: g_signal_emit_valist (gsignal.c:2199)
==1171== by 0x48097E8: g_signal_emit (gsignal.c:2243)
==1171== by 0x438629F: do_theme_change (gtkicontheme.c:624)
==1171== by 0x4386AE4: gtk_icon_theme_rescan_if_needed (gtkicontheme.c:1725)
==1171== by 0x4386EDD: ensure_valid_themes (gtkicontheme.c:1192)
==1171== by 0x438766F: gtk_icon_theme_lookup_icon (gtkicontheme.c:1268)
==1171== by 0x807D3C9: panel_find_icon (panel-util.c:640)
==1171== by 0x807D468: panel_load_icon (panel-util.c:668)
==1171== by 0x806F46C: button_widget_reload_pixbuf (button-widget.c:187)
==1171== by 0x806F515: button_widget_icon_theme_changed (button-widget.c:210)
==1171== by 0x48049D8: g_cclosure_marshal_VOID__VOID (gmarshal.c:77)
==1171== by 0x47F762A: g_closure_invoke (gclosure.c:490)
==1171== by 0x4808102: signal_emit_unlocked_R (gsignal.c:2440)
==1171== by 0x4809626: g_signal_emit_valist (gsignal.c:2199)
==1171== by 0x48097E8: g_signal_emit (gsignal.c:2243)
==1171== Address 0x7415230 is 0 bytes inside a block of size 7 free'd
==1171== at 0x402123A: free (vg_replace_malloc.c:233)
==1171== by 0x485C130: g_free (gmem.c:187)
==1171== by 0x4848910: g_hash_table_replace (ghash.c:390)
==1171== by 0x4385373: insert_theme (gtkicontheme.c:2219)
==1171== by 0x438515A: insert_theme (gtkicontheme.c:995)
==1171== by 0x438515A: insert_theme (gtkicontheme.c:995)
==1171== by 0x438515A: insert_theme (gtkiconthe...

Read more...

Changed in gnome-panel:
status: Needs Info → Confirmed
rasz (citizenr) wrote :

How do I get out of this chickenshit outfit?
launchpad is having a seizure and subscribed me to this and other 'gnome-panel crash' bugs :/ I get 2-3 mails a day, and there is no info in launchpad under my accounts subscriptions.

For goodness sake, count me out of this as well! I'm getting really
tired of this. Next time I'll reconsider allowing apport to report
anything...!

On 3/18/07, rasz <email address hidden> wrote:
> How do I get out of this chickenshit outfit?
> launchpad is having a seizure and subscribed me to this and other 'gnome-panel crash' bugs :/ I get 2-3 mails a day, and there is no info in launchpad under my accounts subscriptions.
>
> --
> [apport] gnome-panel crashed with SIGSEGV on package installation, valgrind log required
> https://launchpad.net/bugs/85776
>

--
Tomasz Dominikowski
http://www.skyos.org
"Brian, let us pray. Dear Lord... stay out of our way!"

Sebastien Bacher (seb128) wrote :

could you open a bug or contact the launchpad team about that, commenting on this bug doesn't reach the right guys and is of no use

Sitsofe Wheeler (sitsofe) wrote :

(This is offtopic but since it's come up a few times)
Drowning in duplicate bug mail is covered by Bug #46237 (at the moment malone doesn't distinguish between different types of change notification)...

Neil (nnkx00) wrote :

Happened here too, just now (installing Seahorse, and it's dependency, libgpgme11).

Didn't happen when I was installing everything else though (I installed probably upwards of a hundred or more packages yesterday, not counting their dependencies).

As of right now:
neil@ion:~$ dpkg -l | grep "gnome-panel"
ii gnome-panel 2.18.0-0ubuntu2 launcher and docking facility for GNOME 2
ii gnome-panel-data 2.18.0-0ubuntu2 common files for GNOME 2 panel

Hope it helps.

LGB [Gábor Lénárt] (lgb) wrote :

I've got this problem as weil, with version 2.18.0-0ubuntu3 on AMD64, I've just reported as bug #99351 but I was told that that's a duplication of this bug. Sometimes (but not always!) gnome-panel crashes on package installing. As far as I can remember it has been occuring since about a month or so.

Neil (nnkx00) wrote :

For those trying to unsubscribe:
1. Click on the link to the desired bug (probably
https://bugs.launchpad.net/bugs/85776 if you're reading this).
2. On the left of the page, you will see a red (on mine) section
labeled "Actions". Click unsubscribe. Confirm on next page.
3. Live a happy, spam-free life.

Cheers.

Daniel Holbach (dholbach) wrote :
Tom Womack (tom-womack) wrote :

Got the same issue when installing with the update manager at 2345 on 5 April.

yharrow (yharrow) wrote :

As of 1 am EST on April 8, this bug has still not been fixed. It is very annoying and it kicks gnome-power-manager out of the panel every time it crashes the panel.

Andrew Conkling (andrewski) wrote :

On 4/20/07, Sebastien Bacher <email address hidden> wrote:
> ** Changed in: gnome-panel (Ubuntu)
> Target: ubuntu-7.04 => later

As many duplicates as this has gotten, should it really be deferred? Looks like the upstream bug (in GTK+) has been fixed; could this be released as in feisty-updates?

Sebastien Bacher (seb128) wrote :

The upstream patches have been used, there is no indication if that was the only bugs though since we didn't get lot of valgrind logs there

This bug is still present in up-to-date gutsy. Did http://bugzilla.gnome.org/show_bug.cgi?id=409101#c1 get applied to Ubuntu's packages?

The apport report is in 92988.

Cheers.

Reinhard Tartler (siretart) wrote :

Happend here today (on Jul 07) on i386 as well.

Sebastien Bacher (seb128) wrote :

yes, we applied the upstream patches

Bubba Siggler (bud3) wrote :

On 7/27/07, Sebastien Bacher <email address hidden> wrote:
>
> yes, we applied the upstream patches

Hi Sebastien,
This is what I get when trying to run the trace trace. I know it's something
I'm doing.

l:~$ gdg <Apport> 2>&1 | tee gdb-<Apport>.txt bash: syntax error near
unexpected token `2'

best regards

flint_dude

see attch

> --
> [apport] gnome-panel crashed with SIGSEGV on package installation,
> valgrind log required
> https://bugs.launchpad.net/bugs/85776
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

--
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.3 (GNU/Linux)

iD8DBQFFkcN7yXWcajQQndYRAgbqAKCMyXN9Jx4g0X7jocg+aUSFz0x4LwCgrURW
eGtqLjpzQVYa9+gzpCRtB84=
=zrpM
-----END PGP SIGNATURE-----

Emilio Pozuelo Monfort (pochu) wrote :

I haven't seen this bug in Gutsy for a long time.

I was in fight with this bug too but for now ...seems like it was killed.

Emilio Pozuelo Monfort wrote:
> I haven't seen this bug in Gutsy for a long time.
>

gnudoc (gnudoc) wrote :

This bug is fixed is fixed in current gutsy (1/10/07). gnome-panel does not crash following installation of packages, whether using the add/remove tool, apt-get, aptitude or synaptic. gnome bugzilla indicates the patch was applied at gtk 2.10 - gutsy uses 2.12 by default.

Changed in gnome-panel:
status: Confirmed → Fix Released
Scott Wegner (swegner) wrote :

I was just upgrading my Hardy alpha 5 and got crash on reboot.

On Tue, Apr 8, 2008 at 6:26 PM, Scott Wegner <email address hidden> wrote:

> I was just upgrading my Hardy alpha 5 and got crash on reboot.
>

Very likely a different bug; could you possibly report a new bug via Apport?
(Apport will mark it as a duplicate if it turns out to be the same issue.)

Scott Wegner (swegner) wrote :

Hmmm, I would love to, if there is there some way to get to old crash reports in Apport? Although, I also haven't experienced this bug since I rebooted + some more updates this morning.

Yeah, it's pretty sporadic, hard to reproduce. You can find old crash reports in /var/crash (you can navigate to there in a file browser window.) Simply double-click on one and it will be processed. (Also, I've found that old crash reports do not get re-processed if the crash report sits in there, so delete any that you are trying to reproduce, e.g. when trying to retrace after installing debug packages.

Let me know if you need any more help.

------Original Message------
From: Scott Wegner
Sender: <email address hidden>
To: <email address hidden>
ReplyTo: Bug 85776
Sent: Apr 9, 2008 09:52
Subject: [Bug 85776] Re: [apport] gnome-panel crashed with SIGSEGV on packageinstallation, valgrind log required

Hmmm, I would love to, if there is there some way to get to old crash
reports in Apport? Although, I also haven't experienced this bug since
I rebooted + some more updates this morning.

--
[apport] gnome-panel crashed with SIGSEGV on package installation, valgrind log required
https://bugs.launchpad.net/bugs/85776
You received this bug notification because you are a direct subscriber
of the bug.

Scott Wegner (swegner) wrote :

Hi Andrew,

Thanks for the tip, I didn't realize the crash reports were saved and so easy to look at. After looking into the stack-trace and such, it looks to be a duplicate of bug #214079, which already has a reported fix. Let me know if you would like to report a new bug anyway, and I can.

On Wed, Apr 9, 2008 at 3:42 PM, Scott Wegner <email address hidden> wrote:

> After looking into the stack-trace and such, it looks
> to be a duplicate of bug #214079, which already has a reported fix. Let
> me know if you would like to report a new bug anyway, and I can.
>

When in doubt, do, and Apport will automatically mark it as a duplicate once
it retraces it. I'd say do it, err on the side of redundancy. :)

Andrew Conkling (andrewski) wrote :

On Thu, Apr 10, 2008 at 8:21 PM, Andrew Conkling <email address hidden>
wrote:

> When in doubt, do, and Apport will automatically mark it as a duplicate
> once it retraces it. I'd say do it, err on the side of redundancy. :)
>

Especially since bug 214079 seems to be missing a valid backtrace.

Unsubscribe sent back

--------------------------------------------------
From: "Andrew Conkling" <email address hidden>
Sent: Thursday, April 10, 2008 8:21 PM
To: <email address hidden>
Subject: Re: [Bug 85776] Re: [apport] gnome-panel crashed with SIGSEGV
onpackage installation, valgrind log required

> On Wed, Apr 9, 2008 at 3:42 PM, Scott Wegner <email address hidden> wrote:
>
>> After looking into the stack-trace and such, it looks
>> to be a duplicate of bug #214079, which already has a reported fix. Let
>> me know if you would like to report a new bug anyway, and I can.
>>
>
> When in doubt, do, and Apport will automatically mark it as a duplicate
> once
> it retraces it. I'd say do it, err on the side of redundancy. :)
>
>
> ** Attachment added: "unnamed"
> http://launchpadlibrarian.net/13345325/unnamed
>
> --
> [apport] gnome-panel crashed with SIGSEGV on package installation,
> valgrind log required
> https://bugs.launchpad.net/bugs/85776
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
>
> --
> No virus found in this incoming message.
> Checked by AVG.
> Version: 7.5.519 / Virus Database: 269.22.11/1368 - Release Date: 4/9/2008
> 4:20 PM
>
>

jhmac (jhmac) wrote :

unsubscribe sent back return to sender

--------------------------------------------------
From: "Andrew Conkling" <email address hidden>
Sent: Thursday, April 10, 2008 8:22 PM
To: <email address hidden>
Subject: Re: [Bug 85776] Re: [apport] gnome-panel crashed with SIGSEGV
onpackage installation, valgrind log required

> On Thu, Apr 10, 2008 at 8:21 PM, Andrew Conkling
> <email address hidden>
> wrote:
>
>> When in doubt, do, and Apport will automatically mark it as a duplicate
>> once it retraces it. I'd say do it, err on the side of redundancy. :)
>>
>
> Especially since bug 214079 seems to be missing a valid backtrace.
>
>
> ** Attachment added: "unnamed"
> http://launchpadlibrarian.net/13345327/unnamed
>
> --
> [apport] gnome-panel crashed with SIGSEGV on package installation,
> valgrind log required
> https://bugs.launchpad.net/bugs/85776
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
>
> --
> No virus found in this incoming message.
> Checked by AVG.
> Version: 7.5.519 / Virus Database: 269.22.11/1368 - Release Date: 4/9/2008
> 4:20 PM
>
>

Andrew Conkling (andrewski) wrote :

On Fri, Apr 11, 2008 at 5:24 AM, jhmac77 <email address hidden> wrote:

> unsubscribe sent back return to sender

I believe you're looking for this?
https://bugs.launchpad.net/ubuntu/+source/gnome-panel/+bug/85776/+subscribe

Scott Wegner (swegner) wrote :

Submitted: bug #215718

dotancohen (dotancohen) wrote :

I think that this bug can be closed now. The issue is fixed and it has been almost two years since the last dupe.

On 08/22/2009 04:18 PM, dotancohen wrote:
> I think that this bug can be closed now. The issue is fixed and it has
> been almost two years since the last dupe.
>
Closing due to above comment.

 status fixreleased

--
Sincerely Yours,
    John Vivirito

https://launchpad.net/~gnomefreak
https://wiki.ubuntu.com/JohnVivirito
Linux User# 414246

"How can i get lost, if i have no where to go"
    -- Metallica from Unforgiven III

Changed in gnome-panel:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.