package PACKAGE failed to install/upgrade: error writing to '<standard output>': Success

Bug #545790 reported by James Salinas on 2010-03-24
This bug affects 1163 people
Affects Status Importance Assigned to Milestone
dpkg
New
Undecided
Unassigned
dpkg (Ubuntu)
High
Canonical Foundations Team

Bug Description

:: DESCRIPTION ::
The scenario seems to be:
- run update-manager
- system crashes / hangs
- hard reset
- apport triggers this kind of report

The problem appeared in Karmic

User experiencing this error are often facing bug 541595 too.

:: Original description ::
upgrade a new install of 9.10 to 10.04 via update-manager -d
--
previous attempts at 'clean install' from downloaded ISO images for Ubuntu 10.04 x64 and i386 failed to boot to media.
reinstall of 9.10 followed by update-manager -d caused installer crash ( and 100% cpu utilization ). reboot resulted in this error.
apt-get install -f processed remainder of install.
reboot resulted in crashed recycle bin and this error

ProblemType: Package
Architecture: i386
Date: Wed Mar 24 01:52:23 2010
DistroRelease: Ubuntu 10.04
ErrorMessage: error writing to '<standard output>': Success
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
NonfreeKernelModules: nvidia
Package: libselinux1 2.0.89-4
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: libselinux
Title: package libselinux1 2.0.89-4 failed to install/upgrade: error writing to '<standard output>': Success
Uname: Linux 2.6.31-14-generic i686

James Salinas (jsalinas) wrote :
Jean-Baptiste Lallement (jibel) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage. I have classified this bug as a bug in dpkg.

When reporting bugs in the future please use apport, either via the appropriate application's "Help -> Report a Problem" menu or using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

affects: ubuntu → dpkg (Ubuntu)
summary: - package libselinux1 2.0.89-4 failed to install/upgrade: error writing to
- '<standard output>': Success
+ package PACKAGE failed to install/upgrade: error writing to '<standard
+ output>': Success
Changed in dpkg (Ubuntu):
status: New → Confirmed
Changed in dpkg (Ubuntu):
importance: Undecided → Medium
description: updated
Changed in dpkg (Ubuntu):
importance: Medium → High
description: updated
Matt Zimmerman (mdz) wrote :

I think it is a dpkg bug that this error message does not explain what is going on. The sequence of events is:

1. write() something to stdout
2. fflush(stdout)
3. check ferror(stdout) and display an error message based on the value of errno

If write() returns an error, but fflush() does not (because there is nothing left in the buffer?), then we end up with this "Success" result (and the actual error code is lost)

Hi
 Thanks for the email
 I have been trying to run an upgrade of Ubuntu9.10 to 10.04 and
originally it loaded bot now with updates it downloads the
packages but during the installation it fails and the screen goes
into low res mode with a list of options none of which work
 I have to then restart the laptop and the package is not loaded
 The Kernel was downloaded but did not install
 this has happened with - 17 and then - 18 neither has installed
 the original -16 is the only one that is on there now
 Apart from that I keep getting a red splash on Menu bar that tells me
there has been a crash but

 Thanks for a brilliant platform You guys are fantastic
 Regards
 gary

On Wed, Mar 31, 2010 at 12:08 AM, Matt Zimmerman <email address hidden> wrote:

> I think it is a dpkg bug that this error message does not explain what
> is going on. The sequence of events is:
>
> 1. write() something to stdout
> 2. fflush(stdout)
> 3. check ferror(stdout) and display an error message based on the value of
> errno
>
> If write() returns an error, but fflush() does not (because there is
> nothing left in the buffer?), then we end up with this "Success" result
> (and the actual error code is lost)
>
> --
> package PACKAGE failed to install/upgrade: error writing to '<standard
> output>': Success
> https://bugs.launchpad.net/bugs/545790
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

--
gfr

Rolf Leggewie (r0lf) on 2010-09-07
description: updated

Ran my daily update and got the crash

if you need anything please ask

tags: added: rls-mgr-p-tracking
Steve Langasek (vorlon) on 2011-10-26
tags: added: rls-p-tracking
Steve Langasek (vorlon) on 2011-11-16
Changed in dpkg (Ubuntu):
milestone: none → ubuntu-12.04
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Steve Langasek (vorlon) on 2011-12-14
Changed in dpkg (Ubuntu):
status: Confirmed → Triaged
tags: added: bugpattern-written
Steve Langasek (vorlon) on 2012-03-24
tags: removed: rls-p-tracking
Erwan Georget (dremor) on 2012-04-27
Changed in dpkg (Ubuntu):
status: Triaged → Fix Released
Steve Langasek (vorlon) on 2012-04-27
Changed in dpkg (Ubuntu):
status: Fix Released → Triaged
Changed in dpkg (Ubuntu):
status: Triaged → New
status: New → Incomplete
Micah Gersten (micahg) on 2012-04-29
Changed in dpkg (Ubuntu):
status: Incomplete → Triaged
Changed in dpkg (Ubuntu):
milestone: ubuntu-12.04 → ubuntu-12.10

DELETE UNSUBSCRIBE REMOVE

On 06/05/2012 05:50 PM, Brian Murray wrote:
> ** Changed in: dpkg (Ubuntu)
> Milestone: ubuntu-12.04 => ubuntu-12.10
>

IKT (ikt) wrote :

@phreakincool

To unsubscribe from this bug:

Click on the right > edit bug mail > mute all emails from this bug

Reported again today. 11.10

Changed in dpkg (Ubuntu):
status: Triaged → Fix Released
Steve Langasek (vorlon) on 2012-11-24
Changed in dpkg (Ubuntu):
status: Fix Released → Triaged
piotr zimoch (ebytyes) on 2013-06-14
Changed in dpkg (Ubuntu):
status: Triaged → Incomplete
status: Incomplete → Invalid
status: Invalid → Confirmed
status: Confirmed → In Progress
status: In Progress → Fix Committed
status: Fix Committed → Fix Released
Colin Watson (cjwatson) wrote :

Please refrain from pressing all the buttons in succession :-)

Changed in dpkg (Ubuntu):
status: Fix Released → Triaged

 You guys are fantastic thanks Love your work
 Gary

On Fri, Jun 14, 2013 at 10:15 PM, Colin Watson <email address hidden>wrote:

> Please refrain from pressing all the buttons in succession :-)
>
> ** Changed in: dpkg (Ubuntu)
> Status: Fix Released => Triaged
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (548780).
> https://bugs.launchpad.net/bugs/545790
>
> Title:
> package PACKAGE failed to install/upgrade: error writing to '<standard
> output>': Success
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/dpkg/+bug/545790/+subscriptions
>

--
gfr

richard (druide34666) on 2013-11-25
Changed in dpkg:
assignee: nobody → richard (druide34666)

The attachment "AptOrdering.txt" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
GFR (robertsgfr) wrote :

 Hi Richard My whole system crashed and I have not had any
kind of luck getting it up and running again I didnt have a backup and
have lost a hell of a lot of stuff if I cant get my computer up and
running again
 It will boot up until i put in my password and then just runs
text and at the end it says Fatal
  I dont know if you have advice mate
 Cheers Gary

On Mon, Nov 25, 2013 at 10:21 AM, Ubuntu Foundations Team Bug Bot <
<email address hidden>> wrote:

> The attachment "AptOrdering.txt" seems to be a patch. If it isn't,
> please remove the "patch" flag from the attachment, remove the "patch"
> tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the
> team.
>
> [This is an automated message performed by a Launchpad user owned by
> ~brian-murray, for any issues please contact him.]
>
> ** Tags added: patch
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (548780).
> https://bugs.launchpad.net/bugs/545790
>
> Title:
> package PACKAGE failed to install/upgrade: error writing to '<standard
> output>': Success
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/dpkg/+bug/545790/+subscriptions
>

--
gfr

tags: removed: patch
markus (mmenschner) on 2015-05-24
Changed in dpkg (Ubuntu):
status: Triaged → Opinion
Changed in dpkg (Ubuntu):
status: Opinion → Triaged
milestone: ubuntu-12.10 → none
dino99 (9d9) on 2015-07-25
Changed in dpkg:
assignee: richard (druide34666) → nobody
ali nagi (alin43958) on 2016-05-06
Changed in dpkg (Ubuntu):
status: Triaged → Fix Released
Steve Langasek (vorlon) on 2016-05-06
Changed in dpkg (Ubuntu):
status: Fix Released → Triaged
Randyman99 (rgb99) wrote :

This just happened to me trying to install xsane in Ubuntu 16.04. Previous fix seems to be inadequate.

Thanks for all your great work guys

On Mon, Aug 14, 2017 at 4:35 PM, William Grant <email address hidden>
wrote:

> ** Attachment removed: "C851D2A42CCFEF2D.jpg"
> https://bugs.launchpad.net/ubuntu/+source/dpkg/+bug/
> 545790/+attachment/4922489/+files/C851D2A42CCFEF2D.jpg
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (548780).
> https://bugs.launchpad.net/bugs/545790
>
> Title:
> package PACKAGE failed to install/upgrade: error writing to '<standard
> output>': Success
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/dpkg/+bug/545790/+subscriptions
>

--
gfr

james (ssemujju) wrote :

Hullo I can't run my updates I don't know why

On 13 Oct 2017 11:46 PM, "GFR" <email address hidden> wrote:

Thanks for all your great work guys

On Mon, Aug 14, 2017 at 4:35 PM, William Grant <email address hidden>
wrote:

> ** Attachment removed: "C851D2A42CCFEF2D.jpg"
> https://bugs.launchpad.net/ubuntu/+source/dpkg/+bug/
> 545790/+attachment/4922489/+files/C851D2A42CCFEF2D.jpg
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (548780).
> https://bugs.launchpad.net/bugs/545790
>
> Title:
> package PACKAGE failed to install/upgrade: error writing to '<standard
> output>': Success
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/dpkg/+bug/545790/+subscriptions
>

--
gfr

--
You received this bug notification because you are subscribed to a
duplicate bug report (1687120).
https://bugs.launchpad.net/bugs/545790

Title:
  package PACKAGE failed to install/upgrade: error writing to '<standard
  output>': Success

Status in dpkg:
  New
Status in dpkg package in Ubuntu:
  Triaged

Bug description:
  :: DESCRIPTION ::
  The scenario seems to be:
  - run update-manager
  - system crashes / hangs
  - hard reset
  - apport triggers this kind of report

  The problem appeared in Karmic

  User experiencing this error are often facing bug 541595 too.

  :: Original description ::
  upgrade a new install of 9.10 to 10.04 via update-manager -d
  --
  previous attempts at 'clean install' from downloaded ISO images for
Ubuntu 10.04 x64 and i386 failed to boot to media.
  reinstall of 9.10 followed by update-manager -d caused installer crash (
and 100% cpu utilization ). reboot resulted in this error.
  apt-get install -f processed remainder of install.
  reboot resulted in crashed recycle bin and this error

  ProblemType: Package
  Architecture: i386
  Date: Wed Mar 24 01:52:23 2010
  DistroRelease: Ubuntu 10.04
  ErrorMessage: error writing to '<standard output>': Success
  InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
  NonfreeKernelModules: nvidia
  Package: libselinux1 2.0.89-4
  ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
  SourcePackage: libselinux
  Title: package libselinux1 2.0.89-4 failed to install/upgrade: error
writing to '<standard output>': Success
  Uname: Linux 2.6.31-14-generic i686

To manage notifications about this bug go to:
https://bugs.launchpad.net/dpkg/+bug/545790/+subscriptions

Download full text (4.9 KiB)

I am a beginner with linux, sometimes I don't know why some packages can't
update

Kim Mạnh Cường
Vietnam national university, Hanoi (VNU)
University of Engineering and Technology (VNU - UET)
Faculty of Electronics and Tele-communications (FET)

VNU Key Laboratory for Smart Integrated Systems (SISLAB)

-----------------------------------------------------------------------------------
Facebook: https://www.facebook.com/kimmanhcuong96
Phone: 0166 618 1001
Address: 144 Xuan Thuy str, Cau giay ditr , Ha Noi, Viet Nam

2017-10-15 6:11 GMT+07:00 james <email address hidden>:

> Hullo I can't run my updates I don't know why
>
>
> On 13 Oct 2017 11:46 PM, "GFR" <email address hidden> wrote:
>
> Thanks for all your great work guys
>
> On Mon, Aug 14, 2017 at 4:35 PM, William Grant <email address hidden>
> wrote:
>
> > ** Attachment removed: "C851D2A42CCFEF2D.jpg"
> > https://bugs.launchpad.net/ubuntu/+source/dpkg/+bug/
> > 545790/+attachment/4922489/+files/C851D2A42CCFEF2D.jpg
> >
> > --
> > You received this bug notification because you are subscribed to a
> > duplicate bug report (548780).
> > https://bugs.launchpad.net/bugs/545790
> >
> > Title:
> > package PACKAGE failed to install/upgrade: error writing to '<standard
> > output>': Success
> >
> > To manage notifications about this bug go to:
> > https://bugs.launchpad.net/dpkg/+bug/545790/+subscriptions
> >
>
>
> --
> gfr
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1687120).
> https://bugs.launchpad.net/bugs/545790
>
> Title:
> package PACKAGE failed to install/upgrade: error writing to '<standard
> output>': Success
>
> Status in dpkg:
> New
> Status in dpkg package in Ubuntu:
> Triaged
>
> Bug description:
> :: DESCRIPTION ::
> The scenario seems to be:
> - run update-manager
> - system crashes / hangs
> - hard reset
> - apport triggers this kind of report
>
> The problem appeared in Karmic
>
> User experiencing this error are often facing bug 541595 too.
>
> :: Original description ::
> upgrade a new install of 9.10 to 10.04 via update-manager -d
> --
> previous attempts at 'clean install' from downloaded ISO images for
> Ubuntu 10.04 x64 and i386 failed to boot to media.
> reinstall of 9.10 followed by update-manager -d caused installer crash (
> and 100% cpu utilization ). reboot resulted in this error.
> apt-get install -f processed remainder of install.
> reboot resulted in crashed recycle bin and this error
>
> ProblemType: Package
> Architecture: i386
> Date: Wed Mar 24 01:52:23 2010
> DistroRelease: Ubuntu 10.04
> ErrorMessage: error writing to '<standard output>': Success
> InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
> NonfreeKernelModules: nvidia
> Package: libselinux1 2.0.89-4
> ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
> SourcePackage: libselinux
> Title: package libselinux1 2.0.89-4 failed to install/upgrade: error
> writing to '<standard output>': Success
> Uname: Linux 2.6.31-14-generic i686
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/dpkg/+bug/545790/+subscriptions
>
> --
> Y...

Read more...

brachayehudit (brachayehudit) wrote :

I had a computer guy do my Ubuntu upgrade to 16 but as you wrote here, he
did not do it well (and I already paid him a generous price for his time).
He warned me he is not so familiar with Ubuntu as with Windows. So should
I call him back or pay again to have someone who really knows Ubuntu
correct the whole problem. Would you know someone in Jerusalem Israel who
could be called in or I could bring in my hard disk to him but he should be
recommended by you. Have a wonderful week and thanks for warning me.
Alice Bracha (my mail is: <email address hidden>

On Fri, Oct 13, 2017 at 6:52 PM, Randyman99 <email address hidden> wrote:

> This just happened to me trying to install xsane in Ubuntu 16.04.
> Previous fix seems to be inadequate.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1713332).
> https://bugs.launchpad.net/bugs/545790
>
> Title:
> package PACKAGE failed to install/upgrade: error writing to '<standard
> output>': Success
>
> Status in dpkg:
> New
> Status in dpkg package in Ubuntu:
> Triaged
>
> Bug description:
> :: DESCRIPTION ::
> The scenario seems to be:
> - run update-manager
> - system crashes / hangs
> - hard reset
> - apport triggers this kind of report
>
> The problem appeared in Karmic
>
> User experiencing this error are often facing bug 541595 too.
>
> :: Original description ::
> upgrade a new install of 9.10 to 10.04 via update-manager -d
> --
> previous attempts at 'clean install' from downloaded ISO images for
> Ubuntu 10.04 x64 and i386 failed to boot to media.
> reinstall of 9.10 followed by update-manager -d caused installer crash (
> and 100% cpu utilization ). reboot resulted in this error.
> apt-get install -f processed remainder of install.
> reboot resulted in crashed recycle bin and this error
>
> ProblemType: Package
> Architecture: i386
> Date: Wed Mar 24 01:52:23 2010
> DistroRelease: Ubuntu 10.04
> ErrorMessage: error writing to '<standard output>': Success
> InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
> NonfreeKernelModules: nvidia
> Package: libselinux1 2.0.89-4
> ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
> SourcePackage: libselinux
> Title: package libselinux1 2.0.89-4 failed to install/upgrade: error
> writing to '<standard output>': Success
> Uname: Linux 2.6.31-14-generic i686
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/dpkg/+bug/545790/+subscriptions
>

Randyman99 (rgb99) wrote :

Brachayehhudit, the problem solved itself for me just by running the software installation again. While Ubuntu does work better with a bit of technical saviness, it's not too difficult to pick it up in bits and pieces over time, and I would encourage you to stick with it and learn to do the upgrades yourself over time. No need to pay someone else when they don't know what they're doing. BTW, it would not work to take your hard drive out and take it to someone else. The installation is hardware specific, so the person you take it too would need to have the exact same hardware configuration, which is not likely.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers