Server software is closed source

Reported by Corey Burger on 2009-05-12
714
This bug affects 141 people
Affects Status Importance Assigned to Milestone
EasyPeasy Overview
High
Jon Ramvi
Ubuntu One Servers
High
Martin Albisetti

Bug Description

The Ubuntu One server software is closed source. This is 2009. I thought we learnt this lesson with Launchpad.

visibility: private → public
Elliot Murphy (statik) on 2009-05-13
Changed in ubunet:
status: New → Invalid
Mike Basinger (mike.basinger) wrote :

While this software should be open sourced eventually, I don't think it is a problem if the Ubuntu One developers code in house at first to get the software to the point that they envisioned before opening to the community.

Corey Burger (corey.burger) wrote :

Rather than just close this, can we at least get a statement one way or the other about the long term roadmap of the server side? All the rumours I am getting say it will never be open-sourced as it is apparently a "service", whatever the hell that means.

Lucio Torre (lucio.torre) wrote :

Please, lets keep bugs as bugs. I need to work with them, and all this movement makes my life more complicated. Please use answers if you need answers to this type of questions.

Elliot Murphy (statik) wrote :

Hi Corey, there are currently no plans or roadmap to open-source the server software part of Ubuntu One.

Corey Burger (corey.burger) wrote :

That is what I thought. All the more reason it needs to be named something other than UbuntuOne.

Lucio, I consider software to be non-free to be a bug, but I guess you don't.

Matt Lee (mattl) wrote :

Why is a free software project like Ubuntu is creating further proprietary web applications. We have already seen that much of Launchpad, including the code-hosting part, will now not be released as free software, and now free software users are being encouraged to sign up for a data silo.

Why is Ubuntu One (and Launchpad for that matter) not being released in a way that would adhere to the Franklin Street Statement? http://autonomo.us/2008/07/franklin-street-statement/

Services like http://identi.ca and http://libre.fm have shown that free software users will embrace free network services with abundance.

Matt Lee
Founder, Libre.fm
http://libre.fm/

William Grant (wgrant) wrote :

mattl, Ubuntu is not creating any of these proprietary applications. Canonical Ltd. - one of Ubuntu's sponsors - is doing it. As you've seen in bug #375345, many of us in the community are not happy with the name Canonical has chosen for its product, as it causes confusion with Ubuntu itself.

Matt Lee (mattl) wrote :

Gotcha. Still, s/Ubuntu/Canonical and the point still stands.

Bradley M. Kuhn (bkuhn-ebb) wrote :

I agree with mattl's point. Having been around the Free Software world since 1992, I've slowly watched every for-profit company that originally had Free Software principles slowly but surely lose them. Indeed, I started to write off Canonical on this point when I saw that Launchpad was proprietary. I was reinvigorated when I saw the work of many folks that made a change there and they are on course to Free it under the AGPLv3.

However, as someone else in this bug mentioned, apparently no lessons were learned there. The goal of UbuntuOne as a service is a great one, because there are many proprietary services that do this already and having a FaiF replacement would help make our community better.

I was just saying to Amanda Brock a few months ago that much of the party line of Canonical sounds like Bob Young did about Red Hat in the 1990s. I told her that I had a hard time believing it because I've heard many for-profit companies in the past espouse a commitment to Free Software before only to let our community down.

She assured me that Canonical was different because of Mark Shuttleworth's leadership and commitment to Free Software. I tried to believe her, but was still skeptical. Seeing the launch of UbuntuOne shows that my skepticism was well founded. Please, Mark, I'd be quite happy to made to look like a fool for being so pessimistic. Please make a commitment and a plan today to release the server side of UbuntuOne under the AGPLv3.

Changed in ubunet:
status: Invalid → Confirmed
pault4 (paul-coffswifi) wrote :

Not happy chapys. bkuhn and mattl both hit the nail on it head. There seems to be a trend with a lot of for-profit company's changing tracks as soon as they have critical mass. Canoncal do the right thing and lets keep the world free.

Starting a proprietary network service like this, and trying to sell it to the free software community like this, is sending the worst possible message at the worst possible time. Right now the autonomo.us group and others are trying to define the importance of free network services as an issue. At this very time, Canonical is sending the message that it is simply a non-issue.

Allow me to quote directly from this article:
http://arstechnica.com/open-source/news/2009/05/hands-on-canonical-aims-for-the-cloud-with-new-ubuntu-one.ars

  "Unlike the client components, the server software will not be released under an open source license. Canonical will keep the server software closed for now so that it can build a healthy business on top of the service."

The irony is that I would have been happy to pay money for such a service if I felt that it was helping to develop free network services. I am well aware that storage, bandwidth, and datacenter space take precious resources and money to deploy, so I am happy to pay for the convenience. However, I am not happy to pay for either lock-down or lock-in. The message that Canonical is sending here is that a locked in system is the only business model that they have faith in.

The naming issue is technically a separate issue, and it is true that naming really does not matter too much in a certain sense. However, there is a component in which the issue of the network services being nonfree and being branded as Ubuntu that *is* relevant. Canonical may have the legal right to do this, but what message does it send? There are plenty of Ubuntu Local teams that rally around that word. Clearly, Canonical is trying to brand this project as part of the Ubuntu desktop (to say otherwise would be to advocate doublespeak). I don't think anyone reasonable objects to Canonical trying to make a business out of Ubuntu as a free desktop system. But selling Ubuntu as a free desktop tied and branded to a series of nonfree and controlled services.. I don't think that's the kind of project these many local teams of volunteers mean to dedicate themselves and their time to. So in that sense, it *is* kind of a slap in the face.

Please reconsider making Ubuntu One a flagship proprietary project. You have the opportunity of making Ubuntu One a flagship free network service. Now that would be actually interesting innovation... and a project I'd actually be interested in investing my money in.

Elliott, would you consider this bug to be valid if it were described in terms like 'Most popular web services are proprietary and not Free Software' along the lines of Bug #1?: https://bugs.edge.launchpad.net/ubuntu/+bug/1

Elliot Murphy (statik) wrote :

Hi Michael,

It's frustrating that as one of the project leaders I don't seem to be given the respect or right to close a bug on my own project. For example, I respect Bradley very much and am not remarking at all on the content of his comment (he certainly speaks from an informed perspective and it would be foolish to ignore his input), I don't think he should override my decision to close the bug. With bzr branches, I only give commit rights to certain people, and I have the opinion that only the core developers of a project (and the bug reporter) should have the final word on the disposition of a bug report, just like they do on whether or not to accept a patch. Now, thats just my personal opinion about how to use bug trackers, and it's probably not shared by most of the people at Canonical, and obviously not shared by the good people that designed the bug tracker :)

I understand that it's healthy and good for people to offer comments and criticism on the stated roadmap of the project, or disagree about whether we should take action on any bug, design decision, etc.

But, I want to use the bug tracker to track ongoing/pending work in the Ubuntu One project, not as the place where debates happen over whether Canonical is doing the right thing. If people want to write commentary on big picture strategy, it would be much more appropriate in a blog, not in bug reports. And when I read articles that are critical of Canonical or Ubuntu One via my google blogsearch in the morning, I actually enjoy them and contemplate the points in them, because they are not filling up my inbox as bug mails that are obscuring the real bug reports from people trying to use and contribute to the project in a more concrete and tangible way.

It wouldn't be so bad except that every single developer on the project gets emailed every time someone makes another clever comment on one of these bugs, and all we want to do is get on with writing more code to make this thing work even better for the people who do want to use it, because we genuinely believe we have a feature set which will make a lot of Ubuntu computers more useful for end users. Maybe it would be less frustrating if we could turn off the mail for this bug. Even if we could, when one of the developers working for me goes to look at the list of pending bugs for Ubuntu One, I don't want this one to show up because it's not something that any of the developers working on this project are going to be able to take action on, and thats why I want it to be set to 'invalid' or 'wontfix'. I kind of wish there was a status of 'please dont take it personally but you should totally blog this instead of putting it in a bug report kthxbye'.

I love all you folks in the Ubuntu and wider software development communities, and it would be crazy to think that I or Canonical should censor or ignore input from anyone in the community, it's just my opinion that the bug tracker is not the best place for this particular type of discussion.

Brian Burger (bburger) wrote :

Elliot,

Rather than crying in your beer about this bug disrupting your precious workflow and the sanctity of your project's bug tracking, why not make actually solving it PART of your workflow and project goals?

If every Ubuntu One dev asked Mark & other senior Canonical people for a concrete open-sourcing roadmap, would that add impetus to actually closing this bug?

If you want to talk about 'lack of respect', how about the appearance of not respecting their own public Trademark Policy and commitment to open-source solutions that this whole project is tarnishing Canonical with?

Besides which, the original reporter of this bug is quite unlikely to allow you to simply close it with the situation unresolved, so a more constructive attitude toward it's continued existance might do more good than harm.

Elliot Murphy (statik) on 2009-05-15
Changed in ubunet:
status: Confirmed → Invalid
Bradley M. Kuhn (bkuhn-ebb) wrote :

Elliot, I apologize if my changing the bug status was offensive to you. I can understand your decision not to work on the bug (which would entail trying to convince your bosses at Canonical to allow you to Free the code). I would request that you would leave it open until such time as Canonical decides to give freedom to users of UbuntuOne.

My primary annoyance is with the choices available by default on launchpad. "Invalid" makes it sound like the user has reported a bug that isn't real. It seems there is no state similar to bugzilla's "WON'T FIX", which I think is better fitting. Users have seen something that clearly is an issue for them, but the developer (Canonical) has decided to make it proprietary.

Anyway, I won't change the state again, and I am sorry that it upset you. I hope you will strongly consider making the case to your bosses that they should respect the freedom of users.

Elliot Murphy (statik) wrote :

sure, changing to won't fix.

Changed in ubunet:
status: Invalid → Won't Fix

Elliot, you didn't actually answer my question as to whether you would consider this valid if the bug used the suggested alternate wording, but I suppose changing from "Invalid" to "Won't Fix" is an oblique answer of sorts.

Rick McBride (rmcbride) wrote :

Michael,

However it is worded, this bug does not meet the requirements for an open bug in THIS project. It is not related to software issues that can be corrected by the developers that are responsible for responding to bugs filed here.

This is an important discussion that I am eager to follow in the appropriate venues.

This is not one of those venues. This is a bug list utilized by developers working to make this project better through code.

Continuing the discussion here will not have any effect on the outcome of the overall debate. It's counterproductive to the developers on this project, and it's counterproductive to reaching any resolution on the matter.

Please, to add my voice to those who have already requested it, Take this discussion out of my bug queue. I have a job to do.

Rick McBride wrote at 18:16 (EDT) on Friday:

> This is not one of those venues. This is a bug list utilized by
> developers working to make this project better through code.

There have been many studies and reports that show Free Software
releases help make better, more secure, and more high quality software.
So, I think the bug is relevant to this project, regardless.

However, "Won't Fix" is clearly a reasonable state to set for it. The
developers have decided it's not a bug they think is worth fixing at
this time.

> Please, to add my voice to those who have already requested it, Take
> this discussion out of my bug queue. I have a job to do.

I hope you will chose adding to your job description convincing your
employer to release its software as Free Software, just as many
individuals inside other proprietary software companies have done. Such
a task would certainly be in the spirit of the principles the Ubuntu
project was founded on.
--

   -- bkuhn

Brian Burger (bburger) wrote :

Rick McBride wrote:
> This is a bug list utilized by developers working to make this project better through code

The founding bug of Launchpad & the Ubuntu project is bug #1, which has nothing to do with code, particularly.

Sometimes issues aside from just code need to be tracked in a public, documented way. Bug #1 is the ultimate precedent for that, and complaining about this bug in the face of bug #1's continued existance seems very blinkered.

People in the Ubuntu community have issues with the licensing (or lack thereof) of the UbuntuOne server code. That's as much a code-related bug report as #1 is.

Kamikaze321 (d-gun) wrote :

We all know why its closed source . They want to steal all your data and/or monitor you. Using UbuntuOne is like upload your Home directory to Microsoft. Who the hell knows whats going on on their servers? Some intelligence agency will secretly force them to run monitoring software etc. or a gouverment will force them to prevent "child pornography" and force them to send everything to a 3rd party server. They dont want private HD's, they want all your data stored on their comps, thats why every gouverment want a super fast isp. Because they hope one day its ok with everyone uploading everything to a 3rd party server. In 30 years the usual hd size will be 5 mb and everything will be on a 3rd party quantum computer server, wich will crack your 256bit sh.. within milliseconds.

Changed in ubunet:
status: Won't Fix → New
Martin Albisetti (beuno) on 2009-08-10
Changed in ubunet:
status: New → Won't Fix
Kyle Jones (mutiny32) wrote :

Well, you just caught the attention of Reddit. I'm sure they will have some interesting input on this bug. I have one theoretical question though. What happens if the source is released and is deemed that code contained within is encompassed by some other license that mandates that source be freely accessible? I'm willing to wager that this is more than just a possibility; more of an almost certainty.

I just have to say that if it turns out that you are using open-source and licensed code on a project that you have closed off, you had damn well better be prepared to take some major heat. If it's one thing you don't do to the OSS community it would be to test the waters of legitimacy or legality of those licenses.

Then again, everything could be totally cool, you developed it all yourself, utilized licenses properly, and are just severely damaging the image of Canonical.

Niels Egberts (nielsegberts) wrote :

"I just have to say that if it turns out that you are using open-source and licensed code on a project that you have closed off, you had damn well better be prepared to take some major heat. If it's one thing you don't do to the OSS community it would be to test the waters of legitimacy or legality of those licenses."

As long as Canonical does not redistribute their program, they can mix closed and opensource as much as they want. Thats what the GPL sais. Many servers of Google are running on a modified Apache, but as long as Google keeps the source in-house, there are no licence violations.

Bradley M. Kuhn (bkuhn-ebb) wrote :

Niels Egberts wrote at 03:19 (EDT):

> As long as Canonical does not redistribute their program, they can mix
> closed and opensource as much as they want. Thats what the GPL says.

This is quite correct, and this is why the Affero GPL (AGPL) exists.
However, I strongly doubt that UbuntuOne server side code is based on
any AGPL'd project. If it is based on GPL or Apache-licensed software,
the morally correct thing would be for them to release their generally
useful improvements, but they have no legal obligation in that case to
do what's right.

Meanwhile, while I am very sad and a bit outraged at Canonical for
keeping this server software proprietary, I think further complaint on
this ticket is unwarranted. Canonical has heard our message, they
understand that the community is unhappy, but they've decided to keep
the software proprietary. It's always sad when a previously Free
Software company starts going a little proprietary. I've been around
the community long enough to remember when the same thing happened with
Red Hat and with Ximian, and both were sad days.

I suggest that we take any energy we'd spend complaining about this and
instead put the time and effort into a AGPLv3'd replacement for this
proprietary software that Canonical is creating. Since the client is
Free Software, it should be relatively straightforward to implement a
replacement server that is Free Software.

When a proprietary software company writes proprietary software, the
best response is to briefly tell them you think they are treating users
poorly and should start respecting the freedom of the users. Once the
message is delivered, then we should turn our full attention to writing
a free software replacement. This method is what we began in 1984 and
should continue until companies stop subjugating users with proprietary
software. Don't tolerate companies hiding behind "well it's a service"
to pretend that it's not just proprietary software as a service.
--

   -- bkuhn

UbuntuOne isn't that interesting of an offer anyway. I don't suspect it to ever be a succes unless the storage / price ratio and the platform support can compete with dropbox. The technology is also not that very hard. The sort of people that would want to run it on their own servers, are already using rsync right now. And since the client side is open sourced, it would not require a lot of effort to compete with them using the same client-side integration.

I'm sorry if this is way out of the scope of the bug report, but I tend to see these type of bug reports as 'canonical needs to make money and we don't like their current choices'.

What I would love to see, is, at the VPS hosting from Canonical.

Preferably with small-scale cloud options. I think there is a large market of websites and intranet-style server, that want to be able to scale when needed, that would like to run Ubuntu servers, and would love the tight integration of hosting support and upstream support. The support could be a censored or private section of launchpad. If it is a software problem, selective developpers could get direct access to the machiene and debug it straight from there.

It would be a very healthy setup, because every improvement to the server-side, would reduce support costs and you get first class information on how your product is actually used and where the issues lie. It would make money on the short term, but it would make the ubuntu server-side the fastest growing and best established server platform.

These advantages would, for my company, but also for me, mean that the price wouldn't have to be that competitive in regard to the budget hosters.

In general, I feel it is a pity Canonical seems to focus their strategy on a few large clients rather than having thousands of smaller ones and for that I was happy to see UbuntuOne. It's just that as a product, it isn't very compelling.

Elliot Murphy (statik) wrote :

Ralf Nieuwenhuijsen wrote:
> In general, I feel it is a pity Canonical seems to focus their strategy
> on a few large clients rather than having thousands of smaller ones and
> for that I was happy to see UbuntuOne. It's just that as a product, it
> isn't very compelling.

Hi Ralf! I obsess over this particular detail every single day at work
on Ubuntu One, all day long. I won't be able to rest until it's
compelling for at least some number of millions of users :)

Niels Egberts (nielsegberts) wrote :

> I don't suspect it to ever be a succes unless the storage / price
> ratio and the platform support can compete with dropbox.

Probably file storage is just the beginning. There is a bigger picture. Synchronizing your tomboy notes, bookmarks on you browser, email and messenger settings etc.

Of course it will. But I am little bit concerned that all this "clouding" will smash down a lot of IT activities and, worst of all, will bind users data to a limited set of services providers (MS, Google, Canonical).

I would like decision maker starts talking about sort of "universal API" for things like this. An user should be free to insert a domain name, a username/password and change "cloud provider" in minutes.

Niels Egberts (nielsegberts) wrote :

I find that the cloud is only a thread when lock-ins are being created. Microsoft did this for example by not being able to export your mail out of hotmail/live, or not being able to open your documents in something else than MS Office.

I'm happy as long as I can decide what I want to do with my data, the api is open and I can go to another company for the same service if I want to.

I think an universal api is bad because I think it holds back innovation but you should indeed be able to step to another provider without very much hassle.

Ok, agree. But start consider to provide to users something like this in System -> Preferences

==============
| Cloud provider:
| Username:
| Password:
==============

I have seen something like this upstream in recentrly patch that integrates GoogleDocs in GVFS[0][1]

jdhore (jdhore1) wrote :

UbuntuOne seems to have another depressing problem that will cause it to fail compared to DropBox or SpiderOak or similar solutions.

UbuntuOne will only run on Ubuntu (and possibly Debian with a bit of .deb hackery). If you're forced to use Windows at work or CentOS or something, you're SOL.

With DropBox, it works fine on every recent version of Windows, every recent version of Mac OS X and at least currently, any linux distro with Nautilus installed (though i hear there's a command-line DropBox client on its way that has very few dependencies. Likely only simple stuff like rsync or curl or wget or similar).

Niels Egberts (nielsegberts) wrote :

On Fri, Aug 21, 2009 at 5:32 AM, jdhore <email address hidden> wrote:
>
> UbuntuOne will only run on Ubuntu (and possibly Debian with a bit of
> .deb hackery). If you're forced to use Windows at work or CentOS or
> something, you're SOL.

The fact that windows is not supported in the beta stage of Ubuntu-one
does not mean that it will never be supported. Plus that if Ubuntuone
gets popular in the Ubuntu-community I bet we'll have windows, BSD and
OSx ports in no-time. I agree that not having a windows/osx client
will hurt the project.

mE (mstudye) wrote :

launchpad wasn't open source until recently

so i don't think it is a surprise that the server is not open source

but: i am running karmic and i really don't like this ubuntuone so i uninstalled it
the idea that it is installed by default is pushy and feels a bit unnatural for a open source software user(to start such a proprietary service)

Sheol (sheol-s) wrote :

I wish everyone would relax about this.
1. Canonical is a for-profit company. I want them to be successful, and I definitely do not want them to be Debian (not that I have anything against Debian, but as an end user I have other needs). Having a service that integrates wholly with Ubuntu is a great idea to move the company and product forward.
2. Open Source projects are generally more successful after significant upfront development has gone into them. I am sure that Canonical will OS this as soon as they have another project to move forward on.
3. I find no inconsistencies in keeping code closed in a service. It is completely within the spirit of open source.

Using Debian and wearing that brand is showing your support for hard-core free software. Debian is about a community working together to make something great.
Ubuntu is about community trust with a company. These sorts of relationships are always tense. I use KDE4 and often feel ignored by Canonical. It happens. But with this sort of structured relationship we community members get resources put into developing the sort of things we want to see, as opposed to the sort of things the developers want to see. The trade off is that the company is going to work towards having the resources to keep doing that.

So far I prefer the structure I have by being with Ubuntu, I don't miss my Debian days. It's really your choice, Canonical's not (IMHO) doing anything immoral. But their model is not Debian's model and it doesn't make much sense to conflate them.

I hope the developers produce something that allows Canonical to really move forward as a company and thus allows Ubuntu to move forward as a OS, and as a community.

Mark, Elliot; Good luck.

I wish all successful for Canonical (well, not too much...) but "pre-installing" and "pre-configuring" semi-commercial services by default without teaching the user that there are many of providers for same service reminds me another company.

Blaise Alleyne (balleyne) wrote :

Ubuntu One makes me want to leave Ubuntu. I switched to Ubuntu because I wanted to run a free software operating system, but I'm not sure how much longer I can take a distribution that shoves a proprietary web service in my face. I expect better from Canonical.

Luka Renko (lure) wrote :

balleyne, you can also switch to Kubuntu or some other derivative that does not link with Ubuntu One.

On Sun, Jan 17, 2010 at 09:58:33AM -0000, balleyne wrote:
> Ubuntu One makes me want to leave Ubuntu. I switched to Ubuntu because I
> wanted to run a free software operating system, but I'm not sure how
> much longer I can take a distribution that shoves a proprietary web
> service in my face. I expect better from Canonical.

Thanks for your feedback, it's interesting to realize how users feel
about this issues.

Cheers.

PS Note that my blog does allow comments, in case you want to have them
   public.

--
Stefano Zacchiroli -o- PhD in Computer Science \ PostDoc @ Univ. Paris 7
zack@{upsilon.cc,pps.jussieu.fr,debian.org} -<>- http://upsilon.cc/zack/
Dietro un grande uomo c'è ..| . |. Et ne m'en veux pas si je te tutoie
sempre uno zaino ...........| ..: |.... Je dis tu à tous ceux que j'aime

Elliot Murphy (statik) wrote :

Just an update - the ubuntu one server software is less closed than before - the file sharing server is still closed source but the couchdb and desktopcouch stuff that backs tomboy notes, contacts, and bookmark syncing is open source, and the Funambol code that provides the syncml functionality we are working on is open source too. Don't give up on us yet :)

Corey Burger (corey.burger) wrote :

Elliot, that is great information and a great start. Sadly, we still have neither 1) a statement that it will become free at some point (ala early LP) or 2) a statement that it will become free on X date (ala late LP). Given Canonical now has a track record of following through with its promises on open-sourcing things, I think it is very telling the silence around UbuntuOne.

Why has the server side of UbuntuOne still not been open sourced? Canonical can still make their money selling subscriptions. I have never used UbuntuOne and never will, until I can look at the source code and run it on my own servers.

Corey: I agree with you that their silence is telling. I hope it becomes open source, but them not saying that it will become free makes me wonder if it ever will.

zomp (jan-molnar) wrote :

Colin, this could be the problem, if you run Ubuntu One on your own servers, you wouldn't pay anything to Canonical. They are just for-profit company. Maybe, they just want to gain the most paying users possible and then they open source Ubuntu One for the rest who would never pay them.

ikus060 (ikus060) wrote :

Apart of complaining it's not open source. Any one planing to implement a GPL version of UbuntuOne ?? The client and the protocol is open source. It's shouldn't be a hard job to re-implement the server side.

Osama Khalid (osamak) wrote :

ikus060, it's funny that we have to reimplement something a for-profit company claiming to be pro-software-freedom has made. Canonical doesn't do it right by denying UbuntuOne users their right to move their data to their own servers, but Ubuntu project also should refuse to include UbubtuOne client in the default release, not before it is, in both sides, completely free.

Changed in ubuntuone-servers:
assignee: nobody → Mark Shuttleworth (sabdfl)
assignee: Mark Shuttleworth (sabdfl) → nobody
Jon Ramvi (ramvi) wrote :

We are looking into fixing this by using SparkleShare instead of UbuntuOne. Still very fresh software though.

Changed in easypeasy-project:
status: New → In Progress
importance: Undecided → High
assignee: nobody → Jon Ramvi (ramvi)
milestone: none → 1.7alpha2
threethirty (threethirty) wrote :

Ubuntu One is fairly useless to me without the source code. It's just a distro locked Dropbox clone as far as I'm concerned. So I'm me too-ing this bug in hopes of free-ing this project.

MvW (2nv2u) wrote :

They should include the Ubuntu one server as option in the ubuntu server version, detect LAN or WAN connections (much faster file transfers/syncing when at the office), include installed software and PPA repositories, add global user management (for Ubuntu one as well for attached Ubuntu systems in general), remote management for attached machines and this all should be reachable through one secure port over ssh and manageable with a nice GUI and for file sharing a web interface as well (preferable with some file sharing hash keys for use on the Internet).

Next the should add the ability to the desktop installer to define a Ubuntu one server instead of user details and you've created a perfect solution for small/medium sized businesses.
Even for home users they could make a hosted version like it is right now.

Next they should make a nice Android, iPhone, Mac and Windows client.

As of now it's merely a derivative of Dropbox with no potential or any added value at all.

Lord Panta (panta2mi) on 2010-10-15
Changed in easypeasy-project:
status: In Progress → Confirmed
Voidcode (terkelsorensen) wrote :

The problem with it is not open source is that now I can not even get the chance to try my idea!!
http://brainstorm.ubuntu.com/idea/26817/

But will just have to hope that Canonical has the courage and desire and money to realize this idea :(

jtl999 (jtl999) wrote :

Not having it open source means people can't make there own cloud out of a 1TB drive which is a neat idea

MvW (2nv2u) wrote :

Open source is the second step from my point of view.
They should make it available for ubuntu server as service. Closed source or not.

Changed in easypeasy-project:
status: Confirmed → Incomplete
status: Incomplete → Invalid
Fred (eldmannen+launchpad) wrote :

When using the Ubuntu One cloud client you are put into a disadvantageous vendor lock-in situation where you are locked into a single proprietary cloud provider, the cloud provided by Canonical.

The user should be allowed to freely choose which cloud provider to use and be able to switch provider at any time.

tags: added: cloud proprietary
John Lenton (chipaca) wrote :

Fred,

When somebody talks about vendor lock-in, in general they're talking about the user's data becoming unavailable to them other than through the vendor. We have at all times made sure that all your data is available to you, either because it is on your computers directly, or, in the cases where you've explicitly chosen not to have it on a subset of your computers, your data is accessible via published Free and open standards and protocols; in most cases (in all cases except one) these standards are not even our making.

There is another issue with some cloud providers that you might think of as vendor lock-in where the protocol might be Free and open and published and all, but the client is closed and the standards and protocols governed in such a way that in effect makes it so impractical it's impossible to retrieve your data. Again, with us you always have your data unless you've elected to not synchronize to a particular device; complicating your case even further, the clients are all DFSG-free software. If you go to the Ubuntu One project on Launchpad, you can find all our clients; our service also relies on Free, open clients from other people, which I can point you at if you want.

Some of our server-side bits are closed (most of them are Free, open, published, etc). You are free to not use the service and, if you are currently using the service and want to leave, you have access to all your data at any time through a variety of means. We'll be sorry to see you go, but it's your decision.

Thank you for reading.

MvW (2nv2u) wrote :

For Ubuntu One to succeed it has to have some kind of advantage over the rest of the dropbox clones.
But in fact it doesn't and lacks behind those other services which are cheaper, have better client side applications, are fully cross platform. They all use the same base principle, storing data in the "cloud", but none of them let users / administrators use there own hardware.

Even for me, as a 99.9% ubuntu user, it doesn't offer me enough to even consider it as a alternative to dropbox or simple webdav / ssh sharing.
The only thing that would make it worthwhile besides it competitors / alternatives is to offer a "host it yourself" option which would open a whole new market. Not everyone wants there data to be stored "somewhere".

To make it a no brainer service which would also help ubuntu gaining market in the office space it should include the following features ordered by importance:

1. It should offer different cloud services, even ones hosted by yourself (As default package within ubuntu server).
(I agree with Fred although the vendor lock-in doesn't seem to be as apparent as he makes it look like)
2. It should support sync over LAN if machines multiple machines are detected using the same share.
3. It should support multiple shares (folders).
4. It should share software repositories cross ubuntu clients and make profiles which would install/remove software from attached machines automatically (ubuntu only).
5. It should offer a centralized user management for ubuntu clients (ubuntu only).
(install ubuntu, define server in the installation procedure and select machine profile)
6. It should allow sharing without data syncing / replication (Media files for example).
7. It should offer a website with login and generated one time hashkeys to be able to reach and share data over the web.
8. It should use existing data sharing options and configurations on a plugin bases (Firefox sync for example).
(could be as simple as syncing a single folder from you home folder)
9. It should have a nicely integrated version control system in the explorer (nautilus) as well as through the website.
10. Possibly a server version for those NAS devices out there (Synology for example).

Just my 2 cents.

Fred (eldmannen+launchpad) wrote :

The client doesn't even let you change which server to connect to.

Lucio Torre (lucio.torre) wrote :

$ /usr/lib/ubuntuone-client/ubuntuone-syncdaemon --help
Usage: ubuntuone-syncdaemon [config file] [extra config files] [options]

Options:
[SNIP]
  --host=HOST The server address
  --dns_srv=DNS_SRV The DNS SRV record
  --port=PORT The port on which to connect to the server
[SNIP]

try:
$ /usr/lib/ubuntuone-client/ubuntuone-syncdaemon --dns_srv=None --host=yourhost --port=yourport

Bradley M. Kuhn (bkuhn-ebb) wrote :

I believe that this bug ticket being marked as "WON'T FIX" puts it in direct contradiction with the Ubuntu philosophy, as stated at http://www.ubuntu.com/project/about-ubuntu/our-philosophy , which says your philosophy is:

> We believe that every computer user should have the freedom to download, run, copy, distribute, study, share,
> change and improve their software for any purpose, without paying licensing fees.

Can someone point us to the exception document that explains why Ubuntu One users *shouldn't* have that freedom?

Niobe (pt20100938) wrote :

I appreciate what you guys are doing to improve the Ubuntu distribution and the hard work and effort put into this project.But I believe I speak for the greater part of the community when I voice my concerns, that this is not the way to do things in good spirit. Whether the ubuntu philosophy rings true with the individuals that have the power to exercise the will of the community or not. We are all here because we believe in the power of FOSS and what it brings to our own lives and that of our fellow aficionados.

I am not preaching nor dictating what should be done. If you could weigh the arguments of the community against that of yours(the powers that be), that is all I ask.
Cheers

Randall Ross (randall) wrote :

Suggest that this issue gets tabled at a future UDS and all interested parties attend the session.

Bradley M. Kuhn (bkuhn-ebb) wrote :

In http://blog.canonical.com/2014/04/02/shutting-down-ubuntu-one-file-services/ , Silber says:

> the Ubuntu One file services, the quality of the code, and the user experience, so will release the code as open source software to give others an opportunity to build on this code to create an open source file syncing platform.

My thought is that this ticket should be assigned to Silber and status should be set to "In Progress".

I would ike to add that it's rather telling about Canonical, Ltd. policy that Silber fails to mention in her blog post that there was substantial pressure and feeback from the community -- in this bug ticket and elsewhere -- indicating that it was a mistake to proprietarize the software in the first place and that many informed people didn't think keeping the software proprietary and/or trade-secret was going to advance the business model anyway.

It turns out we who pushed for this bug ticket were right about that.

I now wonder if this source release will be too little, too late, now that Free-Software-from-the-start projects like ownCloud are well on their way. I don't think ownCloud as a project is structured perfectly, but it's probably a better option for developers and users than the throw-it-over-the-wall abandon-ware that Canonical, Ltd. has just decided to release.

MvW (2nv2u) wrote :

I would suggest Canonical (or Us?) should rebrand this software as personaOne (or something catchy), keeping the software in the repository and app stores (Android and IOS) and add server configuration option into the clients.
Include the server packages in to the repositories and make the server packages optional in the server installer.

As I mentioned in this bug (thread) before, I would still consider jumping ship from other storage providers and host the stuff myself if it was kept integrated in Ubuntu and exposed my listed features. (See #55)

It could potentially fill the gap Linux has in local / small business user and desktop management like the Active Directory from Microsoft provides. Would love to be able to install a new desktop, selecting a server to manage it's user access and keep the data stored / synced.

Perhaps we should just start this project, I would love to be a part of it and help thinking about what this product / project should entail, anyone interested? Can't wait... :)

Fred (eldmannen+launchpad) wrote :

This is the problem with vendor-specific clients. The service can disappear.

This is why we need a vendor-neutal cloud-agnostic cross-platform cloud client that work Google Drive, Microsoft OneDrive, Apple iCloud, Dropbox, Box, and ownCloud.

Then I can freely migrate between underlying service providers while still using the same client software.

Martin Albisetti (beuno) on 2014-04-02
Changed in ubuntuone-servers:
status: Won't Fix → In Progress
assignee: nobody → Martin Albisetti (beuno)
importance: Undecided → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers