no HTTPSConnection._tunnel_host in python <= 2.6.2

Bug #451670 reported by Alexei M. on 2009-10-14
390
This bug affects 81 people
Affects Status Importance Assigned to Milestone
Ubuntu One Client
Critical
dobey
ubuntuone-client (Ubuntu)
Low
dobey
Karmic
Undecided
Unassigned

Bug Description

FIXES:
For those not using NetworkManager and are on Karmic, the fix for this bug is in proposed updates. To install proposed updates, please read this FAQ: https://answers.edge.launchpad.net/ubuntuone-client/+faq/930

For those on Jaunty, please update to the latest version of the client and this should work.

--------------------------------------

STEPS TO REPRODUCE/TEST:

1. $ ubuntuone-client-applet

Result: Traceback (most recent call last):
  File "/var/lib/python-support/python2.6/dbus/connection.py", line 578, in msg_reply_handler
    reply_handler(*message.get_args_list(**get_args_opts))
  File "/usr/lib/python2.6/dist-packages/ubuntuone/oauthdesktop/auth.py", line 276, in got_state
    self.acquire_access_token(description, store)
  File "/usr/lib/python2.6/dist-packages/ubuntuone/oauthdesktop/auth.py", line 336, in acquire_access_token
    self.request_token = self.make_token_request(oauth_request)
  File "/usr/lib/python2.6/dist-packages/ubuntuone/oauthdesktop/auth.py", line 229, in make_token_request
    fp = opener.open(oauth_request.http_url, oauth_request.to_postdata())
  File "/usr/lib/python2.6/urllib.py", line 205, in open
    return getattr(self, name)(url, data)
  File "/usr/lib/python2.6/urllib.py", line 437, in open_https
    h.endheaders()
  File "/usr/lib/python2.6/httplib.py", line 868, in endheaders
    self._send_output()
  File "/usr/lib/python2.6/httplib.py", line 740, in _send_output
    self.send(msg)
  File "/usr/lib/python2.6/httplib.py", line 699, in send
    self.connect()
  File "/usr/lib/python2.6/dist-packages/ubuntuone/oauthdesktop/auth.py", line 58, in _connect_wrapper
    if self._tunnel_host:
AttributeError: HTTPSConnection instance has no attribute '_tunnel_host'

Expected result: Ubuntu One client applet starts up properly

--------------------------------------

ORIGINAL DESCRIPTION:

The file "ubuntuone/oauthdesktop/auth.py" references HTTPSConnection._tunnel_host unconditionally that is only available in python/httplib >= 2.6.3 and therefore fails on Jaunty that has 2.6.2 installed.

xxxxxxxxx~$ ubuntuone-client-applet
Traceback (most recent call last):
  File "/var/lib/python-support/python2.6/dbus/connection.py", line 578, in msg_reply_handler
    reply_handler(*message.get_args_list(**get_args_opts))
  File "/usr/lib/python2.6/dist-packages/ubuntuone/oauthdesktop/auth.py", line 276, in got_state
    self.acquire_access_token(description, store)
  File "/usr/lib/python2.6/dist-packages/ubuntuone/oauthdesktop/auth.py", line 336, in acquire_access_token
    self.request_token = self.make_token_request(oauth_request)
  File "/usr/lib/python2.6/dist-packages/ubuntuone/oauthdesktop/auth.py", line 229, in make_token_request
    fp = opener.open(oauth_request.http_url, oauth_request.to_postdata())
  File "/usr/lib/python2.6/urllib.py", line 205, in open
    return getattr(self, name)(url, data)
  File "/usr/lib/python2.6/urllib.py", line 437, in open_https
    h.endheaders()
  File "/usr/lib/python2.6/httplib.py", line 868, in endheaders
    self._send_output()
  File "/usr/lib/python2.6/httplib.py", line 740, in _send_output
    self.send(msg)
  File "/usr/lib/python2.6/httplib.py", line 699, in send
    self.connect()
  File "/usr/lib/python2.6/dist-packages/ubuntuone/oauthdesktop/auth.py", line 58, in _connect_wrapper
    if self._tunnel_host:
AttributeError: HTTPSConnection instance has no attribute '_tunnel_host'

ProblemType: Bug
.home.alexei..cache.ubuntuone.log.syncdaemon.exceptions.log:

.home.alexei..config.ubuntuone.ubuntuone.client.conf:
 [ubuntuone]
 bookmarked = True
 connected = True
 connect = 0
 show_applet = 1
Architecture: i386
CrashDB: ubuntuone
DistroRelease: Ubuntu 9.04
Package: ubuntuone-client 1.0.0+r255-0ubuntu1~ppa1~jaunty
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubuntuone-client
ThirdParty: True
Uname: Linux 2.6.28-15-generic i686
UnreportableReason: This is not a genuine Ubuntu package

Related branches

Alexei M. (alexeim) wrote :
Mitch Towner (kermiac) wrote :

A simple "me too". Everything installed fine on both Jaunty & Karmic a couple of days ago. When trying to add another (jaunty) PC to my account it fails to display the "add computer" webpage.

.home.mitch..config.ubuntuone.ubuntuone.client.conf:
 [ubuntuone]
 connected = True
 connect = 0
 show_applet = 0
 bookmarked = True
Architecture: i386
CrashDB: ubuntuone
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: fglrx
Package: ubuntuone-client 1.0.0+r255-0ubuntu1~ppa1~jaunty
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_AU.UTF-8
ThirdParty: True
Uname: Linux 2.6.28-15-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Mitch Towner (kermiac) wrote :
Mitch Towner (kermiac) wrote :
dliberal (dliberal) wrote :

I'm suffering also the same bug:

$ ubuntuone-client-applet
Traceback (most recent call last):
  File "/var/lib/python-support/python2.6/dbus/connection.py", line 578, in msg_reply_handler
    reply_handler(*message.get_args_list(**get_args_opts))
  File "/usr/lib/python2.6/dist-packages/ubuntuone/oauthdesktop/auth.py", line 276, in got_state
    self.acquire_access_token(description, store)
  File "/usr/lib/python2.6/dist-packages/ubuntuone/oauthdesktop/auth.py", line 336, in acquire_access_token
    self.request_token = self.make_token_request(oauth_request)
  File "/usr/lib/python2.6/dist-packages/ubuntuone/oauthdesktop/auth.py", line 229, in make_token_request
    fp = opener.open(oauth_request.http_url, oauth_request.to_postdata())
  File "/usr/lib/python2.6/urllib.py", line 205, in open
    return getattr(self, name)(url, data)
  File "/usr/lib/python2.6/urllib.py", line 437, in open_https
    h.endheaders()
  File "/usr/lib/python2.6/httplib.py", line 868, in endheaders
    self._send_output()
  File "/usr/lib/python2.6/httplib.py", line 740, in _send_output
    self.send(msg)
  File "/usr/lib/python2.6/httplib.py", line 699, in send
    self.connect()
  File "/usr/lib/python2.6/dist-packages/ubuntuone/oauthdesktop/auth.py", line 58, in _connect_wrapper
    if self._tunnel_host:
AttributeError: HTTPSConnection instance has no attribute '_tunnel_host'

It started yesterday, I've just installed one update but it didn't fix it

Carsten Heidmann (stranljip) wrote :

I've got exactly the same behaviour (Jaunty i686):

$ ubuntuone-client-applet
Traceback (most recent call last):
  File "/var/lib/python-support/python2.6/dbus/connection.py", line 578, in msg_reply_handler
    reply_handler(*message.get_args_list(**get_args_opts))
  File "/usr/lib/python2.6/dist-packages/ubuntuone/oauthdesktop/auth.py", line 276, in got_state
    self.acquire_access_token(description, store)
  File "/usr/lib/python2.6/dist-packages/ubuntuone/oauthdesktop/auth.py", line 336, in acquire_access_token
    self.request_token = self.make_token_request(oauth_request)
  File "/usr/lib/python2.6/dist-packages/ubuntuone/oauthdesktop/auth.py", line 229, in make_token_request
    fp = opener.open(oauth_request.http_url, oauth_request.to_postdata())
  File "/usr/lib/python2.6/urllib.py", line 205, in open
    return getattr(self, name)(url, data)
  File "/usr/lib/python2.6/urllib.py", line 437, in open_https
    h.endheaders()
  File "/usr/lib/python2.6/httplib.py", line 868, in endheaders
    self._send_output()
  File "/usr/lib/python2.6/httplib.py", line 740, in _send_output
    self.send(msg)
  File "/usr/lib/python2.6/httplib.py", line 699, in send
    self.connect()
  File "/usr/lib/python2.6/dist-packages/ubuntuone/oauthdesktop/auth.py", line 58, in _connect_wrapper
    if self._tunnel_host:
AttributeError: HTTPSConnection instance has no attribute '_tunnel_host'

Joshua Hoover (joshuahoover) wrote :

Hi Alexei,

I have a Jaunty 9.04 clean install with all the latest updates and I'm not seeing this error. I have Python 2.6.2 installed. I'm going to assign this to one of our developers so he can take a closer look at it. Note that we've been having some server problems recently that have been causing authorization issues as well.

Thank you,

Joshua

Changed in ubuntuone-client:
assignee: nobody → Rodney Dawes (dobey)
status: New → Triaged
importance: Undecided → High
tags: added: desktop+
Joan Maria Talarn (jmtalarn) wrote :

Hi boys,
meanwhile the bug is treated, is there any workaround to add a computer to my account?

Joan Maria Talarn (jmtalarn) wrote :

I think a best way to add a computer should be an option into the tray icon like the option to open folder or go to Web, etc.

Why is needed to open a Webpage for add a computer on the account?

Leonel Nunez (leonelnunez) wrote :

Same error here or .. "me too"

On Fri, 2009-10-16 at 09:24 +0000, Joan Maria Talarn wrote:
> I think a best way to add a computer should be an option into the tray
> icon like the option to open folder or go to Web, etc.
>
> Why is needed to open a Webpage for add a computer on the account?
>

This is how OAuth works, and we use OAuth as the mediated authentication
mechanism for accessing your data.

There is option in the tray icon's left-click menu which initializes the
process, if you haven't already authorized the machine, titled
"Connect."

Changed in ubuntuone-client:
importance: High → Critical
tags: added: ubuntuone-karmic
Joan Maria Talarn (jmtalarn) wrote :

About the workaround, if I try the Connect action from the icon tray ... nothing happens, and nothing is prompted into the console after the last trace "AttributeError: HTTPSConnection instance has no attribute '_tunnel_host'". I also tried the Nautilus integrated option in Ubuntu One folder to connect but it get stalled in connecting status...

This is happening for me for two new installations in different machines of the Ubuntu One Client. I don't taste the Ubuntu One service yet!

dobey (dobey) on 2009-10-16
Changed in ubuntuone-client:
status: Triaged → In Progress
Joan Maria Talarn (jmtalarn) wrote :

Hi Rodney,

in the nightly version of Ubuntu One client ( ubuntuone-client 1.1+r261-0ubuntu1~ppa1~jaunty ) it seems to be solved, it work properly.

Leonel Nunez (leonelnunez) wrote :

just upgraded to 1.0.1+r257-0ubuntu1~ppa1~jaunty same error

AttributeError: HTTPSConnection instance has no attribute '_tunnel_host'

mybluevan (mybluevan) wrote :

Confirmed, r261 seems to fix it.

Edward Harding (psyphre) wrote :

Another "me too".

I iinstalled it today (18th Oct) using the PPA, so I guess the fix doesnt work for me.

Using Jaunty 64bit.

me too

Andrew Betts (andrew-betts) wrote :

Installed 261... still can't add a computer.

Changed in ubuntuone-client:
status: In Progress → Fix Committed
Joan Maria Talarn (jmtalarn) wrote :

If you have updated to the new version, you must remove the computer as added.

Quit the applet.
Then got to Account menu from the Ubuntu One web page and remove the computer from associated's.
The next step is remove the key from the gnome key ring.
And finally relaunch the Ubuntu One applet.

Viacheslav Kurenyshev (slavic) wrote :

I use 9.04 and it's up to date, but the version of ubuntu one client is r257.
Is it possible to install 261 in 9.04?

dobey (dobey) wrote :

If you've already authorized your computer, it should be fine. If you're running r261 and still are failing to authorize the computer, you're most likely having another issue, and not this one. Please file a separate bug using the "Report a Problem" option on the applet's menu, or by running "ubuntu-bug ubuntuone-client" so that the applet log will be attached, and we can determine if it is a duplicate of this, or another issue, or a new problem entirely.

Thanks.

Edward Harding (psyphre) wrote :

As Vyacheslav Kurenyshev said, I too have got my ubuntuone up to date on the PPA, yet it still says r257. How do I get r261?

mybluevan (mybluevan) wrote :

r261 was still in Bazaar source control. I just reloaded my repositories and found r261 a few minutes ago. Try reloading and updating again.

Changed in ubuntuone-client:
status: Fix Committed → Fix Released
dobey (dobey) wrote :

On Mon, 2009-10-19 at 16:48 +0000, Edward Harding wrote:
> As Vyacheslav Kurenyshev said, I too have got my ubuntuone up to date on
> the PPA, yet it still says r257. How do I get r261?
>

It was in the nightlies PPA, and should now be in the beta PPA.

Edward Harding (psyphre) wrote :

Ok, I checked the updates again and your right, the new revision is now there. Have installed, restarted and tried again.

Thanks, I no longer get the error.

I have just updated from repositories, Kubuntu 9.04, KDE 4.3.2, and now it
is working without error. Good job.

Thank you.

On Mon, Oct 19, 2009 at 8:44 PM, Edward Harding <email address hidden>wrote:

> Ok, I checked the updates again and your right, the new revision is now
> there. Have installed, restarted and tried again.
>
> Thanks, I no longer get the error.
>
> --
> no HTTPSConnection._tunnel_host in python <= 2.6.2
> https://bugs.launchpad.net/bugs/451670
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Mitch Towner (kermiac) wrote :

I can also confirm that the update to r261 in the beta PPA works properly & allows authorising new PC's. Thanks for this update, great work.

Dan Rawlings (dan-rawlings) wrote :

Good-to-go here as well - Thanks for the quick update.

Verified fixed, great work. thanks.

JTFlint (walter-acheson) wrote :

Yes, Finally, its working after this patch today. Thanks, guys! :) Good job.

kurtis (kurtis318) wrote :

Yes, looks like the fix works for me too. Thanks...

On Mon, Oct 19, 2009 at 6:05 PM, JTFlint <email address hidden> wrote:

> Yes, Finally, its working after this patch today. Thanks, guys! :) Good
> job.
>
> --
> no HTTPSConnection._tunnel_host in python <= 2.6.2
> https://bugs.launchpad.net/bugs/451670
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in Ubuntu One Client: Fix Released
>
> Bug description:
> The file "ubuntuone/oauthdesktop/auth.py" references
> HTTPSConnection._tunnel_host unconditionally that is only available in
> python/httplib >= 2.6.3 and therefore fails on Jaunty that has 2.6.2
> installed.
>
> xxxxxxxxx~$ ubuntuone-client-applet
> Traceback (most recent call last):
> File "/var/lib/python-support/python2.6/dbus/connection.py", line 578, in
> msg_reply_handler
> reply_handler(*message.get_args_list(**get_args_opts))
> File "/usr/lib/python2.6/dist-packages/ubuntuone/oauthdesktop/auth.py",
> line 276, in got_state
> self.acquire_access_token(description, store)
> File "/usr/lib/python2.6/dist-packages/ubuntuone/oauthdesktop/auth.py",
> line 336, in acquire_access_token
> self.request_token = self.make_token_request(oauth_request)
> File "/usr/lib/python2.6/dist-packages/ubuntuone/oauthdesktop/auth.py",
> line 229, in make_token_request
> fp = opener.open(oauth_request.http_url, oauth_request.to_postdata())
> File "/usr/lib/python2.6/urllib.py", line 205, in open
> return getattr(self, name)(url, data)
> File "/usr/lib/python2.6/urllib.py", line 437, in open_https
> h.endheaders()
> File "/usr/lib/python2.6/httplib.py", line 868, in endheaders
> self._send_output()
> File "/usr/lib/python2.6/httplib.py", line 740, in _send_output
> self.send(msg)
> File "/usr/lib/python2.6/httplib.py", line 699, in send
> self.connect()
> File "/usr/lib/python2.6/dist-packages/ubuntuone/oauthdesktop/auth.py",
> line 58, in _connect_wrapper
> if self._tunnel_host:
> AttributeError: HTTPSConnection instance has no attribute '_tunnel_host'
>
> ProblemType: Bug
> .home.alexei..cache.ubuntuone.log.syncdaemon.exceptions.log:
>
> .home.alexei..config.ubuntuone.ubuntuone.client.conf:
> [ubuntuone]
> bookmarked = True
> connected = True
> connect = 0
> show_applet = 1
> Architecture: i386
> CrashDB: ubuntuone
> DistroRelease: Ubuntu 9.04
> Package: ubuntuone-client 1.0.0+r255-0ubuntu1~ppa1~jaunty
> PackageArchitecture: all
> ProcEnviron:
> LANGUAGE=
> PATH=(custom, user)
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SourcePackage: ubuntuone-client
> ThirdParty: True
> Uname: Linux 2.6.28-15-generic i686
> UnreportableReason: This is not a genuine Ubuntu package
>

--
Kurtis (Kurt) W. Ruby
<email address hidden>

Viacheslav Kurenyshev (slavic) wrote :

Unfortunately, it has't fixed my issue. I posted a new bug (https://bugs.launchpad.net/ubuntuone-client/+bug/455967)

homtoo (homtoo) wrote :

hi , everyone .if you installed shiretoko and unstalled firefox 3.0 ,then it will not add computer to one . ubuntuone need firefox ,but shiretoko under /usr/bin is firefox-3.5 ,you should chang it ,then it will OK . sorry for my poor english .

dliberal (dliberal) wrote :

It seems that update r261 fixed the problem, but it force me to re-include my comuputer again. I'm working with two computer (home / work) keep some docs synch, although in the list of added computer I have now three. I will update later at home and let you the results.
Another thing that worries me is that now on the "Ubuntu One" (local) folder I have no files, only the folder "shared with me" but the files are on the server, so how can I force to synch them back to my PC ? or do I have to wait ?

Hitesh Naran (hnaran) wrote :

I was having trouble connecting to Ubuntuone ever after updating to the
latest version. I retired complete removal and reinstallation via Synaptic
Package Manger -- still didn't work. So, uninstalled all traces Ubuntuone
and went through the reinstallation process again from the beginning from
the Ubuntuone site -- that did the trick. It's working now.

On Tue, Ot 20, 2009 at 12:17 AM, dliberal <email address hidden> wrote:

> It seems that update r261 fixed the problem, but it force me to re-include
> my comuputer again. I'm working with two computer (home / work) keep some
> docs synch, although in the list of added computer I have now three. I will
> update later at home and let you the results.
> Another thing that worries me is that now on the "Ubuntu One" (local)
> folder I have no files, only the folder "shared with me" but the files are
> on the server, so how can I force to synch them back to my PC ? or do I have
> to wait ?
>
> --
> no HTTPSConnection._tunnel_host in python <= 2.6.2
> https://bugs.launchpad.net/bugs/451670
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

--
Hitesh Naran
<email address hidden>

Viacheslav Kurenyshev (slavic) wrote :

Hitesh,

Please, could you explain (step by step) what did you do saying 'uninstalled all traces Ubuntuone'?

Hitesh Naran (hnaran) wrote :

1. Opened System/Administration/Synaptic Package Manager
2. Entered Ubuntuone in quicksearch
3. Right clicked on Ubuntone-Client, Ubuntuone-Client-Gnome,
Ubuntuone-ppa-beta, Python-Ubuntuone-Client,
Python-Ubuntuone-Storageprotocol and selected "Mark for Complete Removal"
4. Hit Apply button

il.com> wrote:

> Hitesh,
>
> Please, could you explain (step by step) what did you do saying
> 'uninstalled all traces Ubuntuone'?
>
> --
> no HTTPSConnection._tunnel_host in python <= 2.6.2
> https://bugs.launchpad.net/bugs/451670
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

--
Hitesh Naran
<email address hidden>

diablotin (diablotin) wrote :

great work!
It can work now!!

dliberal (dliberal) wrote :

No news... good news, but is not the case.

Yesterday I didn't try on my other computer (home PC). But today I've tried again on my work computer, it didn't connect and send me to the ubuntu-one page, once I click on sign in I've got:

::::::::::::::::::::::::::
Proxy Error

The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request GET /auth/complete/.

Reason: Error reading from remote server

Apache/2.2.8 (Ubuntu) mod_python/3.3.1 Python/2.5.2 mod_ssl/2.2.8 OpenSSL/0.9.8g Server at one.ubuntu.com Port 443
::::::::::::::::::::::::::

I've closed the client and relaunch it again, but this time request to add my computer again... Don't know what is going on.

I will uninstall everything, and try it again :-(

James (jamesasgrim) wrote :

I did an update and I still had the same problem - I then uninstalled everything and re-installed and this works for me now.

Joshua Hoover (joshuahoover) wrote :

For those experiencing problems in the past 12 hours or so, please note that it is likely related to some server issues. We're in the process of fixing this right now. If you see anything like a "proxy error" or excessive timeouts while connecting, then this is almost certainly due to the server issue that we hope to have fixed very soon. My apologies for the inconvenience this has caused.

dliberal (dliberal) wrote :

Greetings,

I've tried once again today to remove (uninstall and delete folders) and reinstall everything again but no way.

The client launches, I delete the old reference to my computer and and add it again. After that it seems to be working but the files does not sync. I have some on the server and NOTHING on my Local Machine. Another thing is that my Ubuntu One folder seems to be Disconnected and when I click on Connect nothing happens.

So, what can I do ?

Stapel (wstapelberg) wrote :

It seems like the often these problems are down to the server being down,
but the client does not let you know when it can't connect to the server.

On Fri, Oct 23, 2009 at 12:25 PM, dliberal <email address hidden> wrote:

> Greetings,
>
> I've tried once again today to remove (uninstall and delete folders) and
> reinstall everything again but no way.
>
> The client launches, I delete the old reference to my computer and and
> add it again. After that it seems to be working but the files does not
> sync. I have some on the server and NOTHING on my Local Machine. Another
> thing is that my Ubuntu One folder seems to be Disconnected and when I
> click on Connect nothing happens.
>
> So, what can I do ?
>
> --
> no HTTPSConnection._tunnel_host in python <= 2.6.2
> https://bugs.launchpad.net/bugs/451670
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

dobey (dobey) on 2009-12-11
Changed in ubuntuone-client (Ubuntu):
assignee: nobody → Rodney Dawes (dobey)
importance: Undecided → Low
status: New → In Progress

Accepted ubuntuone-client into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in ubuntuone-client (Ubuntu Karmic):
status: New → Fix Committed
tags: added: verification-needed
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client - 1.0.3-0ubuntu1

---------------
ubuntuone-client (1.0.3-0ubuntu1) karmic-proposed; urgency=high

  * New upstream release
    - Remove patch files now in upstream for #462828
    - Require python-ubuntuone-storageprotocol >= 1.0.1
    - BadTransition: SYS_CONNECTION_MADE (LP: #457147)
    - ValueError: invalid literal for int() with base 10: 'None' (LP: #476777)
    - Protocol version error with bw throttling enabled (LP: #455544)
    - Folder deletion from other machines results in conflicts (LP: #462003)
    - Syncdaemon doesn't disable throttling (LP: #483592)
    - Syncdaemon crashes with NoAccessToken (LP: #488413)
    - Error creating share from Nautilus: callback() (LP: #492100)
    - Work without NetworkManager installed (LP: #357395)
    - Create a POT during the build (LP: #455527)
    - Bring back timestamps in oauth-login.log (LP: #459175)
    - Applet starts syncdaemon without a token (LP: #491573)
    - Prefs changes don't take immediate affect (LP: #457564)
    - BW limit settings don't appear to be saved (LP: #465030)
    - Distinguish auth errors from other errors (LP: #450633)
    - Fix for running on python < 2.6.3 (LP: #451670)
 -- Rodney Dawes <email address hidden> Fri, 11 Dec 2009 15:45:52 -0500

Changed in ubuntuone-client (Ubuntu Karmic):
status: Fix Committed → Fix Released
Rick McBride (rmcbride) wrote :

This was fixed and verified some time ago, with the unfortunate side effect of disabling proxy support.

Definitely fixed in SRU candidate, although the bug itself is a non-issue on 9.10

dobey (dobey) on 2010-02-18
Changed in ubuntuone-client (Ubuntu):
status: In Progress → Fix Released
viscmad (420mostwanted) on 2010-09-04
Changed in ubuntuone-client:
status: Fix Released → New
Steve Langasek (vorlon) on 2010-09-04
Changed in ubuntuone-client:
status: New → Fix Released
To post a comment you must log in.