Ralink RT3090 Wireless Not Supported in Lucid

Bug #541620 reported by darren on 2010-03-19
412
This bug affects 70 people
Affects Status Importance Assigned to Milestone
Baltix
Undecided
Unassigned
linux (Ubuntu)
High
Unassigned
Declined for Lucid by Leann Ogasawara
Declined for Maverick by Leann Ogasawara
Natty
High
Unassigned
linux-2.6 (Debian)
Fix Released
Unknown

Bug Description

Installed Lucid Alpha 2 and the daily build but the RT3090 Wireless chip isn't supported.

This works in Karmic using this PPA: https://launchpad.net/~markus-tisoft/+archive/rt3090

In Lucid it seems to want to try to use the chip, and it creates a device and loads the rt3090sta module but iwlist scanning doesn't return any results.

lspci -vvv (from karmic):

02:00.0 Network controller: RaLink RT3090 Wireless 802.11n 1T/1R PCIe
 Subsystem: Device 1a3b:1087
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0, Cache Line Size: 32 bytes
 Interrupt: pin A routed to IRQ 17
 Region 0: Memory at fbff0000 (32-bit, non-prefetchable) [size=64K]
 Capabilities: [40] Power Management version 3
  Flags: PMEClk- DSI- D1- D2- AuxCurrent=375mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
 Capabilities: [50] Message Signalled Interrupts: Mask- 64bit+ Queue=0/5 Enable-
  Address: 0000000000000000 Data: 0000
 Capabilities: [70] Express (v2) Endpoint, MSI 00
  DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <512ns, L1 unlimited
   ExtTag- AttnBtn- AttnInd- PwrInd- RBE+ FLReset-
  DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
   RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop-
   MaxPayload 128 bytes, MaxReadReq 512 bytes
  DevSta: CorrErr+ UncorrErr- FatalErr- UnsuppReq+ AuxPwr- TransPend-
  LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Latency L0 <512ns, L1 <64us
   ClockPM+ Suprise- LLActRep- BwNot-
  LnkCtl: ASPM L0s L1 Enabled; RCB 64 bytes Disabled- Retrain- CommClk+
   ExtSynch- ClockPM+ AutWidDis- BWInt- AutBWInt-
  LnkSta: Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
 Capabilities: [100] Advanced Error Reporting <?>
 Capabilities: [140] Device Serial Number 1c-4b-d6-2d-3a-4d-00-00
 Kernel driver in use: rt2860
 Kernel modules: rt3090sta

Sorry not sure what package this driver is from (Linux-firmware?) but let me know if you need any more info.

This chip is in an Asus EEE 1001HA.

Philip Muškovac (yofel) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage. I have classified this bug as a bug in the linux kernel.

When reporting bugs in the future please use apport, either via the appropriate application's "Help -> Report a Problem" menu or using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

affects: ubuntu → linux (Ubuntu)
tags: added: kernel-series-unknown
Gary M (garym) on 2010-03-22
tags: added: iso-testing lucid
Gary M (garym) on 2010-03-22
tags: added: ubuntu-une
Gary M (garym) on 2010-03-22
tags: added: hw-specific
tags: removed: kernel-series-unknown
Neo (reminraphael) wrote :

lspci -vvv Report in #Lucid Beta, installed rt3090-dkms successfully but am not able to enable the wifi key...

02:00.0 Network controller: RaLink RT3090 Wireless 802.11n 1T/1R PCIe
 Subsystem: Device 1a3b:1087
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0, Cache Line Size: 32 bytes
 Interrupt: pin A routed to IRQ 17
 Region 0: Memory at fbff0000 (32-bit, non-prefetchable) [size=64K]
 Capabilities: [40] Power Management version 3
  Flags: PMEClk- DSI- D1- D2- AuxCurrent=375mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
 Capabilities: [50] Message Signalled Interrupts: Mask- 64bit+ Queue=0/5 Enable-
  Address: 0000000000000000 Data: 0000
 Capabilities: [70] Express (v2) Endpoint, MSI 00
  DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <512ns, L1 unlimited
   ExtTag- AttnBtn- AttnInd- PwrInd- RBE+ FLReset-
  DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
   RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop-
   MaxPayload 128 bytes, MaxReadReq 512 bytes
  DevSta: CorrErr+ UncorrErr- FatalErr- UnsuppReq+ AuxPwr- TransPend-
  LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Latency L0 <512ns, L1 <64us
   ClockPM+ Suprise- LLActRep- BwNot-
  LnkCtl: ASPM L0s L1 Enabled; RCB 64 bytes Disabled- Retrain- CommClk+
   ExtSynch- ClockPM+ AutWidDis- BWInt- AutBWInt-
  LnkSta: Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
 Capabilities: [100] Advanced Error Reporting <?>
 Capabilities: [140] Device Serial Number 1c-4b-d6-2e-7d-8a-00-00
 Kernel driver in use: rt2860
 Kernel modules: rt3090sta

Gary M (garym) wrote :

I was also using an Asus Eee PC 1001HA, and lucid beta 1's inbuilt staging driver module was failing. The logs showed an error due to a missing configuration file: /etc/Wireless/RT2860/RT2860.dat .

This file is available from the dkms package at https://launchpad.net/~markus-tisoft/+archive/rt3090 (which I've used in karmic), or from the vendor's original source at http://www.ralinktech.com/support.php?s=2 .

Creating the missing folders as root and placing the file there allowed the module to load and function.

I found that replacing the configuration with an empty file also worked (in karmic at least).

Below is the relevant extract from syslog during the startup of NetworkManager :

Mar 22 02:50:00 ubuntu kernel: [ 39.811101] RtmpOSFileOpen(): Error 2 opening /etc/Wireless/RT2860STA/RT2860STA.dat
Mar 22 02:50:00 ubuntu kernel: [ 39.811112] Open file "/etc/Wireless/RT2860STA/RT2860STA.dat" failed!
Mar 22 02:50:00 ubuntu kernel: [ 39.811120] 1. Phy Mode = 0
Mar 22 02:50:00 ubuntu kernel: [ 39.811125] ERROR!!! NICReadRegParameters failed, Status[=0x00000001]
Mar 22 02:50:00 ubuntu NetworkManager: <info> (wlan0): deactivating device (reason: 2).
Mar 22 02:50:00 ubuntu kernel: [ 39.816384] !!! rt28xx Initialized fail !!!
Mar 22 02:50:00 ubuntu NetworkManager: supplicant_interface_acquire: assertion `mgr_state == NM_SUPPLICANT_MANAGER_STATE_IDLE' failed

I'll try patching this next.

blusa (corsiandr-libero) wrote :

I tried creating /etc/Wireless/RT2860 and coping the .dat file but it didn't work. Changing the name of the directory in /etc/Wireless/RT2860STA and coping the RT2869STA.dat file do the job.

I didn't try using an empty .dat file.

Miguel (miguel-glug) wrote :

I have seen this bug too in the latest Lucid. Even after installing the rt3090-dkms of karmic from https://launchpad.net/~markus-tisoft/+archive/rt3090 no change has shown. The module rt3090sta is loaded but the mac80211 module can't use it, so the wireless isn't running at all. It has to be said in Karmic all went fine with this package, but in Lucid I can't find the way to make it works.

Xan (dxpublica) wrote :
Xan (dxpublica) wrote :

Confirmed. For example in xubuntu live cd of today, I can't see any wifi nets.

Xan.

Changed in linux (Ubuntu):
status: New → Confirmed
Xan (dxpublica) wrote :

What output you need for fixing that?

Rodrigo Donado (frezeeer) wrote :

Hi:
The link by Markus Heberling used to work in Karmic, after the last kernel update (2.6.31-21-generic) doesn't any more.
Same happen to me trying the Betas from Lucid.
Wifi is something everybody needs, please come up with a solution!!!
If someone needs outputs of both, the driver working and not working, please let me know.
By the way the Markus patch used to work flawlessly!

Alan (mrintegrity) wrote :

This affects me on latest lucid beta updates and eeepc 1001ha.

/A

linuxnoob18 (hotwheels-12-12) wrote :

The driver also works on the MSI U130 in Karmic however since lucid beta's this no longer works I would be extremeley happy if this is fixed in the RC version

Gary M (garym) wrote :

The kernel's staging driver module rt3090sta disappeared between lucid kernel versions 2.6.32-19 (beta 2) and 2.6.32-20. Please bring it back!

FWIW, an empty /etc/Wireless/RT2860STA/RT2860STA.dat file worked in lucid kernel 2.6.32-19 also.

I'm currently upgrading my system to lucid and will try to find a fix for the rt3090 driver.

Can't promise anything, since I have basically only packaged the ralink driver and have no experience in driver development myself.

darren (darrenm) wrote :

Cheers Markus! Your driver works perfectly in Karmic so I hope it should be simple to fix.

Hmm. The karmic driver works for me in lucid. I had to completely remove the package and install it again though. Otherwise I got an obscure error message.

markus@ubuntu-media-server:~$ uname -a
Linux ubuntu-media-server 2.6.32-21-generic #31-Ubuntu SMP Tue Apr 13 20:34:00 UTC 2010 i686 GNU/Linux

markus@ubuntu-media-server:~$ ifconfig ra0
ra0 Link encap:Ethernet Hardware Adresse 00:0d:f0:6d:47:0c
          inet Adresse:192.168.178.29 Bcast:192.168.178.255 Maske:255.255.255.0
          inet6-Adresse: XXXXXX/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metrik:1
          RX packets:2211 errors:97 dropped:0 overruns:0 frame:0
          TX packets:243 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:1000
          RX bytes:293955 (293.9 KB) TX bytes:45263 (45.2 KB)
          Interrupt:17

markus@ubuntu-media-server:~$ iwlist ra0 scanning
ra0 Scan completed :
          Cell 01 - Address: XXXXXXX
                    Protocol:802.11b/g
                    ESSID:"XXXXX"
                    Mode:Managed
                    Frequency:2.432 GHz (Channel 5)
                    Quality:100/100 Signal level:-25 dBm Noise level:-92 dBm
                    Encryption key:on
                    Bit Rates:54 Mb/s
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (1) : TKIP
                        Authentication Suites (1) : PSK
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK

markus@ubuntu-media-server:~$ modinfo rt3090sta
filename: /lib/modules/2.6.32-21-generic/updates/dkms/rt3090sta.ko
version: 2.3.1.3
srcversion: FFE8374362ED5B734E14328
alias: pci:v00001814d00003092sv*sd*bc*sc*i*
alias: pci:v00001814d00003091sv*sd*bc*sc*i*
alias: pci:v00001814d00003090sv*sd*bc*sc*i*
depends:
vermagic: 2.6.32-21-generic SMP mod_unload modversions 586
parm: mac:rt28xx: wireless mac addr (charp)

On Fri, 16 Apr 2010 20:33:28 -0000
Markus Heberling <email address hidden> wrote:

> Hmm. The karmic driver works for me in lucid. I had to completely
> remove the package and install it again though. Otherwise I got an
> obscure error message.
>
> markus@ubuntu-media-server:~$ uname -a
> Linux ubuntu-media-server 2.6.32-21-generic #31-Ubuntu SMP Tue Apr 13
> 20:34:00 UTC 2010 i686 GNU/Linux
>
> markus@ubuntu-media-server:~$ ifconfig ra0
> ra0 Link encap:Ethernet Hardware Adresse 00:0d:f0:6d:47:0c
> inet Adresse:192.168.178.29 Bcast:192.168.178.255
> Maske:255.255.255.0 inet6-Adresse: XXXXXX/64
> Gültigkeitsbereich:Verbindung UP BROADCAST RUNNING MULTICAST
> MTU:1500 Metrik:1 RX packets:2211 errors:97 dropped:0 overruns:0
> frame:0 TX packets:243 errors:0 dropped:0 overruns:0 carrier:0
> Kollisionen:0 Sendewarteschlangenlänge:1000
> RX bytes:293955 (293.9 KB) TX bytes:45263 (45.2 KB)
> Interrupt:17
>
> markus@ubuntu-media-server:~$ iwlist ra0 scanning
> ra0 Scan completed :
> Cell 01 - Address: XXXXXXX
> Protocol:802.11b/g
> ESSID:"XXXXX"
> Mode:Managed
> Frequency:2.432 GHz (Channel 5)
> Quality:100/100 Signal level:-25 dBm Noise
> level:-92 dBm Encryption key:on
> Bit Rates:54 Mb/s
> IE: WPA Version 1
> Group Cipher : TKIP
> Pairwise Ciphers (1) : TKIP
> Authentication Suites (1) : PSK
> IE: IEEE 802.11i/WPA2 Version 1
> Group Cipher : TKIP
> Pairwise Ciphers (1) : CCMP
> Authentication Suites (1) : PSK
>
> markus@ubuntu-media-server:~$ modinfo rt3090sta
> filename: /lib/modules/2.6.32-21-generic/updates/dkms/rt3090sta.ko
> version: 2.3.1.3
> srcversion: FFE8374362ED5B734E14328
> alias: pci:v00001814d00003092sv*sd*bc*sc*i*
> alias: pci:v00001814d00003091sv*sd*bc*sc*i*
> alias: pci:v00001814d00003090sv*sd*bc*sc*i*
> depends:
> vermagic: 2.6.32-21-generic SMP mod_unload modversions 586
> parm: mac:rt28xx: wireless mac addr (charp)
>
I installed your driver from the ppa and still haven't been able to get
things going. I tried all of your commands and the only one that works
is the last with the same output.

The iwlist ra0 scanning tells me that the interface does not support
scanning.

ifconfig ra0 gives me "device not found"

I'm going to reinstall and see if that makes any difference

Shelagh

--

----------------------------------------------------------------
Jabber: <email address hidden>
Wave: <email address hidden>

There's a thin line between fishing and standing on the shore
looking foolish.
----------------------------------------------------------------

Robert Nasiadek (robzon) wrote :

I had the same issue on Lucid. Creating an empty file, which was reported missing in dmesg (/etc/Wireless/RT2860STA/RT2860STA.dat) resolved the issue and my wifi works now.

Lucid Lynx Beta 2, MSI CX500 notebook with Ralink RT3090.

darren (darrenm) wrote :

Just done a dist-upgrade to Lucid on my EEE 1001HA. The /etc/Wireless/RT2860STA/RT2860STA file was already there. I touched it anyway and still didn't work so I did a dpkg-reconfigure rt3090-dkms and it rebuilt the kernel module. Didn't even need to reboot, just modprobed rt3090sta and network-manager connected right away. Thanks again Markus, just wish this could be sorted out without requiring 3rd party packages.

Carsten Agger (agger) wrote :

Just installed Lucid Lynx Beta 2 on an MSI Wind U135 - wireless with this chipset does not work. Will try tips given above, hope it will be fixed in the repos before release so it can work out of the box.

Carsten Agger (agger) wrote :

Situation report on my MSI Wind U135 with Lucid Beta 2:

Touch /etc/Wireless/RT2860STA/RT2860STA.dat

This file is empty!

update & upgrade

reboot

Wireless works

There should not be any "Wireless" directory in /etc, i believe - and the file is not needed. This mus be a bug in the driver - it should not look for this file since it isn't need it. How do I locate the driver and do we have the source code for it? I'm not familiar with Ubuntu development but with plenty experience with C I think I could easliy fix it. Maybe better leave it to upstream, tho

Alan (mrintegrity) wrote :

I would just like to confirm that the workaround suggested by Carsten seems to work perfectly (so far).

As root:

mkdir -p /etc/Wireless/RT2860STA/
touch /etc/Wireless/RT2860STA/RT2860STA.dat
service network-manager restart

It is then possible to connect via network manager.

/Alan

Neo (reminraphael) wrote :

WIFI hotkeys does not run (for example Fn + F2). Lucid 10.04 final on my eeepc 1001HA

Downloaded rt3090 driver from

http://www.ralinktech.com/download.php?t=U0wyRnpjMlYwY3k4eU1ERXdMekF5THpJekwyUnZkMjVzYjJGa09Ea3pOalE1TlRBd09DNWllakk5UFQxU1ZETXdPVEJmVEdsdWRYaFRWRUZmVmpJdU15NHhMalJmTWpBeE1EQXlNakl1ZEdGeUM=

installed successfully but hotkey is not working. wifi cant enable.

cheers,
Neo

Jeremy Visser (jeremy-visser) wrote :

Neo, if your Eee 1001 is anything like my Eee 901, you can enable WiFi
in the BIOS setup screen (F2 on boot).

djbmister (db260179) wrote :

Comment 22 is the solution, but there is also more that is causing the problem.

In the new kernel there is an early version of rt3090sta.ko in /lib/modules/2.6.32.21-generic/drivers/staging/rt3090
2.1.0 i believe. You need to remove this first before updating.

Using Ralink driver, the Wifi kill switch no longer works, which is a bummer.

Hope this helps

Xan (dxpublica) wrote :

Neo,

There is a problem with hotkeys in eeepc 1001ha. See the bug https://bugs.launchpad.net/ubuntu/+source/udev/+bug/558628
Perhaps it's a related bug, I don't know. I report the bug #558628 because some hotkeys does not run in my eeepc (1001ha). Please, follow the guide https://wiki.ubuntu.com/Hotkeys/Troubleshooting and add wifi hotkeys if there is a real problem....

Regards,
Xan.

Hi,

Having the same hardware (Asus Eeepc 1001HA) with UNR 9.10 karmic installed, I upgraded to lucid lynx and did exactly what darren proposed in comment #18. It worked perfectly.

Laurent

Xan (dxpublica) wrote :

I think the problem is that there is no feature "out-of-the-box" in 10.04

Neo (reminraphael) wrote :

many thanks 2 Jeremy Visser comment #23 work fine on lucid asus eeepc 1001HA wifi

cheers,
Neo

Sam St. James (samsaintjames) wrote :

I simply installed the package from the site (https://launchpad.net/~markus-tisoft/+archive/rt3090) again after the dist-upgrade to lucid, then did a modprobe rt3090sta and WLAN works now again on my EeePC1001HA.

Oz Man (ozviewer) wrote :

I have an MSI U230. Wireless not working with Ubuntu 10.04. After d/l and installing the deb from Markus Heberling (ppa not working, had to do a manual download), then a modprobe and voila! wireless working with no problems. Many thanks to Markus and above bug reporters.

madmed (medbelh) wrote :

the solution in comment 21 works perfectly.

Xan (dxpublica) wrote :

Does anyone want to make a patch following comment # 21? I think it could be very easy to write for experts....
This bug should be fixed out the box (when people upgrade the lucid installation).

Regards,
Xan.

Himanshu Sharma (s-himanshu9) wrote :

The Solution in comment #21 did not work for me.
My network adapter is Ralink 3090, MSI Wind.
I recently switched from Windows 7 starter to the Netbook Edition 10.04. Are we expecting any future update to resolve it ?

Thanks
Himanshu

ahambidge (ahambidge) wrote :

Hello,

If you go to the Ralink website you can download the Linux driver for
the 3090 Wireless card.

I am sure that Ubuntu will patch this in the immediate future.

                                Regards,

                             Allan Hambidge

Neil L. Jackson (neil-jackson) wrote :

The steps in Comment #21 provided an effective workaround for this bug for me. They worked on a SONY VAIO M (Model VPCM111AX/W (Atom N450)) with a RaLink RT3090 on Ubuntu 10.04 (64-bit). Initially I was booting from USB so the steps worked fine but had to be repeated each time the system was restarted. Then I installed to the hard drive and the steps again worked fine and the fix is persistent.

Neil L. Jackson (neil-jackson) wrote :

Sorry. Further to my Comment #35, I should add that I received the following reports before I created the empty copy of the "missing" /etc/Wireless/RT2860STA/RT2860STA.dat.

ubuntu@ubuntu:~$ dmesg | grep -i RT3
[ 38.443096] rt3090sta: module is from the staging directory, the quality is unknown, you have been warned.
[ 38.545357] rt3090 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[ 38.545410] rt3090 0000:01:00.0: setting latency timer to 64

ubuntu@ubuntu:~$ dmesg | grep -i RT2
[ 39.363324] RtmpOSFileOpen(): Error 2 opening /etc/Wireless/RT2860STA/RT2860STA.dat
[ 39.363335] Open file "/etc/Wireless/RT2860STA/RT2860STA.dat" failed!
[ 39.368619] !!! rt28xx Initialized fail !!!
[ 39.708075] RtmpOSFileOpen(): Error 2 opening /etc/Wireless/RT2860STA/RT2860STA.dat
[ 39.708086] Open file "/etc/Wireless/RT2860STA/RT2860STA.dat" failed!
[ 39.713495] !!! rt28xx Initialized fail !!!

Xan (dxpublica) wrote :

The output "Open file "/etc/Wireless/RT2860STA/RT2860STA.dat" failed!" suggests that perhaps there are a permission file problem....

Xan.

Carsten Agger (agger) wrote :

No, it really suggests there is a file-related bug in the driver. There should not be a "Wireless" directory in /etc/, and if the driver needs to store a "dat" file somewhere, /etc/ is hardly the place to put it. Since it doesn't seem to be needed for persistence, it might as well be placed in /tmp.

So, the driver should be changed to not need the "RT2860STA.dat" file OR to look for it somewhere else, AND if it really needs it, to create it if it doesn't find it. In /tmp, e.g.

If someone can point me in the direction of the correct source code I think I can fix it.

Xan (dxpublica) wrote :

@Carsten: best in the /usr/share/drivers or something else. The /tmp is for temporally save files I think.
@Others: please help Carsten. At least we could mark this bug as "triaged" if we know what fails exactly.

Regards,

Joshua O'Leary (jmoleary) wrote :

The workaround #21 works the best for now, as I have experienced occasional crashing at startup when using the dkms driver.

Changed in linux (Ubuntu):
importance: Undecided → High
silfer (jonathanysp) on 2010-10-14
description: updated
Gary M (garym) on 2010-11-24
tags: added: kernel-wifi rt3090 staging
Changed in linux-2.6 (Debian):
status: Unknown → Fix Released
Andy Whitcroft (apw) on 2011-02-11
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
96 comments hidden view all 176 comments
MMlosh (mmlosh) wrote :

@Linuxexperte

the module is NOT SHIPPED WITH THE KERNEL
there is NO file like rt<anything>sta.ko, modinfo confirms that the module does NOT EXIST.

I was asking whether you know where can one get a kernel package that has this module... nothing else.

Andy Whitcroft (apw) wrote :

@MMlosh -- there seem to be rt*sta.ko modules in Lucid and Maverick kernels, and I am pretty sure Natty too (here are some I
have in old kernels on my disk):

  /lib/modules/2.6.32-11-generic/kernel/drivers/staging/rt2860/rt2860sta.ko
  /lib/modules/2.6.32-11-generic/kernel/drivers/staging/rt3090/rt3090sta.ko

  /lib/modules/2.6.35-22-generic/kernel/drivers/staging/rt2860/rt2860sta.ko
  /lib/modules/2.6.35-22-generic/kernel/drivers/staging/rt2870/rt2870sta.ko

Linuxexperte (andrea-koeth) wrote :

@ Andy Whitcroft nd @ MMlosh:

yes that's right. I even did not have this second driver in my kernel. Here in LinuxMint 10 (based on maverick) I only had these drivers:
rt2870, rt2860/3090sta and rt2800pci. These three drivers were all loaded and this blocked the wifi from working in my case. The reason was, that all three drivers wanted to take over the card. So I had to do what I said in my instruction. In LinuxMint 10 the kernel is the 2.6.35-25-generic. In this kernel, the driver is named rt2860/3090sta.
If you do not unload them from the kernel, they are included. You only need to unload rt2800pci and rt2870 and to blacklist them.

@ MMlosh:

can it be possible, that you have unloaded the rt2860sta-driver from your kernel and that you have blacklisted it?? Then it is clear, that your WLAN does not work properly. The rt2860sta-driver is the best one included in the kernel.

If this is the case (that means if you did the above mentioned thing), then we need to get it out of the blacklist.conf and then follow my posted link to the instruction to get your card run properly.

Greetings
Karmicbastler

Joshua O'Leary (jmoleary) wrote :

@Linuxexperte: The newer kernels which natty use still default to using the rt2800pci driver, which means you still have to do the blacklisting. My kernel still has the rt2800pci module, I just prefer to use rt2860 because its more stable like mentioned earlier.

Also are any of you experiencing freezing/crashing on your ubuntu netbooks at startup? Mine still has occasional freezes when it boots up. Maybe its a hardware fault.

Joshua O'Leary (jmoleary) wrote :

The freezing issues must be related to wifi as when it crashes the word rt2860 is sometimes shown on the screen, along with other debugging info. It seems like a kernel panic.

Linuxexperte (andrea-koeth) wrote :

@ Joshua O'Leary,

I do not use the rt2800pci-driver. I use the rt2860/3090sta-driver. I have blacklisted the rt2800pci and the rt2870. Then I restarted my network-manager as mentioned above and then rebooted my system.

Then I had to go to the menu in network-connections and enter my wifi-connection. My wifi works pretty fine with full speed. Even I do not recognise any desktop-freezes with the rt2860/3090sta-driver in my system when I reboot. These freezes must have another cause. Here LinuxMint 10 runs so smooth, that I admit, that I am just downloading four episodes of the original series of Raumschiff Enterprise in the new digital remastered version!!! Yes, download runs pretty fast and without crashes here in Firefox Namoroka. For the Seamonkey-suit, it is the same!! So this evening, I will have a pretty nice TV-evening on my machine, because my people here are out this evening!! What do I need to use the TV for if I have my Notebook with LinuxMint 10??? My answer is: I do not need it!!

Greetings from the far universe,
Linuxexperte

Joshua O'Leary (jmoleary) wrote :

Thanks Linuxexperte. The problems I'm experiencing must be eee-pc (model 1001ha) hardware specific then.

Linuxexperte (andrea-koeth) wrote :

hi Joshua O'Leary,
you wrote, that you receive desktop-freezes with your eee-pc. One possible (but not the only one) could - perhaps - be a not properly woring driver for your graphiccard. But there are also other possiblities. But this one should be checked first. It could be that it is not hardware-specific, but I driver-specific problem.

For this, better open-up a new thread and there you should post the details of your pc and about your graphiccard. Perhaps the reason can be found there.

But also the error-message displayed on your screen can be helpful to give more detailed diagnose to your problem. Could you copy & past the error-message here on your comment or enclose it to your comment? Therefore, you can copy the error-message to a gedit-document and enclose this document.

Greetings
Linuxexperte

Joshua O'Leary (jmoleary) wrote :

Thanks Linuxexperte, I have spoken to another linux user with the same netbook as me (eee pc 1001ha), and they said it worked perfectly without any freezing issues. The error I'm getting isn't possible to copy and paste - its a long list of messages from a terminal screen, sometimes I don't even get that but just a blank screen. It doesn't seem to be logged either. I would have to take a picture of the screen, but even then I wouldn't get all of the error as it scrolls down past the screen. With all this it does therefore seem like a hardware fault. I'll start another discussion thread somewhere else.

Joshua O'Leary (jmoleary) wrote :

I had posted a thread a while ago about it. There are some screenshots there aswell.
http://ubuntuforums.org/showthread.php?t=1520505

Linuxexperte (andrea-koeth) wrote :

hi Joshua O'Leary,

I looked at this mentioned Thread there and I saw, that you have Intel-technologies. So I can tell you, that a defect of the graphiccard-driver is really not the cause for your freezing-issues. Why? Because I have a similar Intel-graphiccard in my stationary machine. But this stationary machine does not have an onboard-WLAN-Chip.

But for your machine, I can give you a good tipp, if your onboard-WLAN does not work as it shoud, although I think, that your freezing-issues do not come from the rt2860/3090sta-driver. This driver is included in all current kernels, if it is not unloaded.

As I do not have an onboard-WLAN-chip in my stationary machine, I bought this WLAN-Stick for me:

US54EX-WLAN-Stick (usb-WLAN-Stick).
Costs are at 19 €. Quite cheap as you see (this stick works for me since nearly four years now without any incidence).

This WLAN-Stick has a rt2500-WLAN-chip, which works out of the box. Just enter your WLAN-connection in the menu->network-connections and thten go back to the panel to the network-manager icon and klick on it. Then it should see your network and then you are prompted to put in your network-connection-key and then klick on "connect".

But I will try to make a membership with ubuntuforums to look at your screenshots.

Or could you enclose them also here in Launchpad in another Thread?

Greetings
Linuxexperte

Joshua O'Leary (jmoleary) wrote :

Hi Linuxexperte,
Here is the screenshot (this was the best one I could find).
Note: they were before I upgraded to Maverick (Lucid). However, the error is still the same.

Linuxexperte (andrea-koeth) wrote :

hi Joshua O 'Leary,

I have checked your screenshot. There is a bug mentioned in context with plymouth. This happens quite often! The best thing is, to deactivate plymouth.

What you can try: deactivate plymouth and try to reboot. Does this panic happen again??

Please give notice.

Greetings
Linuxexperte

Joshua O'Leary (jmoleary) wrote :

It doesn't really seem possible to disable plymouth. If you try and remove it in synaptic, you would end up removing nearly the whole system due to its dependencies on other things. I've found you can disable the plymouth splash, by removing 'quiet splash' from the grub command line, however the plymouth process still runs as part of the bootup: http://www.linuxquestions.org/questions/linux-mint-84/how-to-disable-plymouth-in-mint-ubuntu-827422/
However I have tried debian on my laptop before, which doesn't use plymouth by default, and the freezing still occurs.

@Andy Whitcroft -- We have identified a fix for the rt3090 freeze on unload bug 662288. It is the single commit 7f6e144fb99a4a already in linux-next - it's the first rt2x00 commit that didn't make it into mainline this time :-\ . This looks like it should be cherry-picked for natty. See bug 662288 for details.

Thanks

 affects ubuntu/linux
 status confirmed

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Lucas G (ljbaumer) wrote :

Hey,

I have this same problem on my hp touchsmart 310 pc....

I am a little lazy and I don't really want to read through all of the comments and posts... is there a simple fix for this problem on ubuntu 10.10?

hrvooje (hrvooje-gmail) wrote :

try solution in comment #103 . It worked for me on hp 4520s on maverick

Eugene Crosser (crosser) wrote :

On both maverick and natty alpha3, 64bit, both rt2800pci and rt2860sta modules get loaded and nothing works. Unloading them and then reloading only rt2860sta (or blacklisting) works on both systems. (Except Bluetooth that uses the same hardware does not work, but that's a matter for a separate bug report.)

Also affected on a hp Pavilion dv5-2133la. Tried to compile drivers from source, network card is recognized, but can´t connect. Tried with wpa, wep and no security at all, and it never connects. My ubuntu is 10.10 32 bits.

Joshua O'Leary (jmoleary) wrote :

If you are using ubuntu 10.10 then you can just use the rt2860sta driver that comes with the ubuntu kernel. Just add the following to the end of /etc/modprobe.d/blacklist.conf:

blacklist rt2800pci
blacklist rt3090sta

That should prevent the other drivers from loading so that only the working driver loads. This should then let you connect.

Hi Joshua. i've just make what you said. Now the wireless manager doesn't show any network.

Joshua O'Leary (jmoleary) wrote :

Try sudo modprobe rt2860sta. If that doesn't work, remove 'blacklist rt3090sta' from /etc/modprobe.d/blacklist.conf and install the dkms driver instead (download and install the lucid one):https://launchpad.net/~markus-tisoft/+archive/rt3090

None of those options worked. I still can't see any network.

After several minutes network manager started to show some routers, All routers are detected with almost 0 level signal, and my home router is not detected at all.

Joshua O'Leary (jmoleary) wrote :

Go to System>Preferences>Network Connections>Wireless>Add. Enter your network details, and tick the box that says 'Auto Connect'. Also, the driver works better if your computer logs into your user account from bootup (i.e no login screen, just loading straight into ubuntu - you can change this by going into System>Administration>Login Screen>Unlock and set it to 'Login As (your username) automatically. Untick 'allow..seconds for everyone else to login first'. Then reboot and see if the network connects from bootup.

Tim Gardner (timg-tpi) wrote :

There are -backports packages for both Lucid and Maverick. For example:

apt-cache search linux-backports-modules-wireless
sudo apt-get install linux-backports-modules-wireless-2.6.38-lucid-generic

You'll likely have to enable -backports and -proposed before the 2.6.38 packages show up.

Changed in linux (Ubuntu Natty):
status: Confirmed → Fix Released
Changed in baltix:
status: New → Invalid
1 comments hidden view all 176 comments
Florian Heyer (heyho-flanto) wrote :

I have a Lenovo IdeaPad S205 with RaLink RT3090 wireless interface.

With Ubuntu 11.04 "Natty Narwal" wifi doesn't work after install. The modules rt2860sta and rt2800pci are conflicting. Manually blacklisting one module and using the other one didn't work either.

However after upgrading to ubuntu mainline kernel v2.3.39-rc3 wifi works using module rt2800pci which contains significant updates by the manufacturer in 2.3.39.

There is a problem left in combination with module ideapad_laptop which processes acpi events to activate/deactivate wifi. However a workaround for this problem exists.

Florian Heyer (heyho-flanto) wrote :

ups, i obviously meant kernel v2.6.39 above...sorry.

Karl Wilde (geidorei) wrote :

Stupid question but why is the status 'Fix released'? This isnt fixed! Albiet there is a .deb it doesnt work for most people.

hrvooje (hrvooje-gmail) wrote :

I have Ralink rt3090 wifi chip on my hp 4520s. On openSUSE 11.4 it uses module rt2860 and it works out of box. Maybe this info could help Ubuntu developers

It is semi-broken in [64 bit] 11.04:
1) connection to WPA2 is highly unstable and often is lost with no reason;
2) connection with WEP works fine;
3) connection is *always* lost when switching from AC to battery.

On [64 bit] 10.10 it works fine using Markus Heberling PPA.

I have this chip on MSI U210.

Frenzel (f-heinen-nl) wrote :

I seem to have exactly the same problems as Andriy. Please help how to fix this.

@Andriy, @Frenzel, @Karl

please open separate bug reports for remaining problems with this driver (rt2800pci) with (in a terminal):
ubuntu-bug linux

Subscribe me to your reports and make a comment that you have done so (so that I get a mail about this).

Thanks

MMlosh (mmlosh) wrote :

The "Fixed" Natty is complete gibberish and broken. ( 2.6.38-11-generic #50-ubuntu)
RFkill ability has been added to rt3090pci and hp_wmi.. result - the wifi is hard-blocked and cannot be unblocked
removing rt2800pci and loading rt2860sta no longer fixes the issues.. the wifi is RFkilled.

Maybe it deserves a separate ticket.. filled here: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/877949

NA (napperley) wrote :

Why is the driver not included in the kernel (Ubuntu version)? Also why is the fix blocked from being included in Ubuntu Lucid and Maverik, yet it is included in Natty?

Linuxexperte (andrea-koeth) wrote :

hi NA (napperley),

yep, this fix is included in Natty as well as in Oneiric. For me, this WLAn-Chip work out of the box again in LinuxMint 12 (based on oneiric and it also did in LinuxMint 11. So I am happy, that this has been solved there. It would really be good, if this fix would be backported to maverick and Lucid.

But I would also recommend, that users, who are affected by this upgrade to Natty or even to Oneiric.

Since I used LinuxMint 11 (codenamed Katya) and now LinuxMint 12 (codenamed Lisa; based on Oneiric), this WLAN-Chip has come back to live for me.

Greetings
Linuxexperte

Linuxexperte (andrea-koeth) wrote :

What I wanted to say is:

there are thousands of Users affected, who still use Lucid or even Maverick. So I would really badly recommend to the developers, that they backport this fix, so that this WLAN-Chip comes back to work there. This is really a high regression-potential!!! Please be fair, developers!!! This is no deal, to leave these users with a broken WLAN.

But as development goes on, I would recommend to the affected users, that they switch over to LinuxMint 11 or even to LinuxMint 12. There you do not notice this bug anymore. This is the only way out of this.

Greetings
Linuxexperte

MMlosh (mmlosh) wrote :

Not as easy for me in Oneiric as for you, Linuxexperte.

I had to disable "lan/wlan toggling" in my BIOS/uEFI (which looks like removing rfkill ability)
to get the wifi working.

And the computer completely froze when I tried to disconnect from radius-managed wifi. (Tried once, failed once)

Displaying first 40 and last 40 comments. View all 176 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.