Ralink RT3090 Wireless Not Supported in Lucid

Bug #541620 reported by darren on 2010-03-19
412
This bug affects 70 people
Affects Status Importance Assigned to Milestone
Baltix
Undecided
Unassigned
linux (Ubuntu)
High
Unassigned
Declined for Lucid by Leann Ogasawara
Declined for Maverick by Leann Ogasawara
Natty
High
Unassigned
linux-2.6 (Debian)
Fix Released
Unknown

Bug Description

Installed Lucid Alpha 2 and the daily build but the RT3090 Wireless chip isn't supported.

This works in Karmic using this PPA: https://launchpad.net/~markus-tisoft/+archive/rt3090

In Lucid it seems to want to try to use the chip, and it creates a device and loads the rt3090sta module but iwlist scanning doesn't return any results.

lspci -vvv (from karmic):

02:00.0 Network controller: RaLink RT3090 Wireless 802.11n 1T/1R PCIe
 Subsystem: Device 1a3b:1087
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0, Cache Line Size: 32 bytes
 Interrupt: pin A routed to IRQ 17
 Region 0: Memory at fbff0000 (32-bit, non-prefetchable) [size=64K]
 Capabilities: [40] Power Management version 3
  Flags: PMEClk- DSI- D1- D2- AuxCurrent=375mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
 Capabilities: [50] Message Signalled Interrupts: Mask- 64bit+ Queue=0/5 Enable-
  Address: 0000000000000000 Data: 0000
 Capabilities: [70] Express (v2) Endpoint, MSI 00
  DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <512ns, L1 unlimited
   ExtTag- AttnBtn- AttnInd- PwrInd- RBE+ FLReset-
  DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
   RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop-
   MaxPayload 128 bytes, MaxReadReq 512 bytes
  DevSta: CorrErr+ UncorrErr- FatalErr- UnsuppReq+ AuxPwr- TransPend-
  LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Latency L0 <512ns, L1 <64us
   ClockPM+ Suprise- LLActRep- BwNot-
  LnkCtl: ASPM L0s L1 Enabled; RCB 64 bytes Disabled- Retrain- CommClk+
   ExtSynch- ClockPM+ AutWidDis- BWInt- AutBWInt-
  LnkSta: Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
 Capabilities: [100] Advanced Error Reporting <?>
 Capabilities: [140] Device Serial Number 1c-4b-d6-2d-3a-4d-00-00
 Kernel driver in use: rt2860
 Kernel modules: rt3090sta

Sorry not sure what package this driver is from (Linux-firmware?) but let me know if you need any more info.

This chip is in an Asus EEE 1001HA.

Philip Muškovac (yofel) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage. I have classified this bug as a bug in the linux kernel.

When reporting bugs in the future please use apport, either via the appropriate application's "Help -> Report a Problem" menu or using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

affects: ubuntu → linux (Ubuntu)
tags: added: kernel-series-unknown
Gary M (garym) on 2010-03-22
tags: added: iso-testing lucid
Gary M (garym) on 2010-03-22
tags: added: ubuntu-une
Gary M (garym) on 2010-03-22
tags: added: hw-specific
tags: removed: kernel-series-unknown
Neo (reminraphael) wrote :

lspci -vvv Report in #Lucid Beta, installed rt3090-dkms successfully but am not able to enable the wifi key...

02:00.0 Network controller: RaLink RT3090 Wireless 802.11n 1T/1R PCIe
 Subsystem: Device 1a3b:1087
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0, Cache Line Size: 32 bytes
 Interrupt: pin A routed to IRQ 17
 Region 0: Memory at fbff0000 (32-bit, non-prefetchable) [size=64K]
 Capabilities: [40] Power Management version 3
  Flags: PMEClk- DSI- D1- D2- AuxCurrent=375mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
 Capabilities: [50] Message Signalled Interrupts: Mask- 64bit+ Queue=0/5 Enable-
  Address: 0000000000000000 Data: 0000
 Capabilities: [70] Express (v2) Endpoint, MSI 00
  DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <512ns, L1 unlimited
   ExtTag- AttnBtn- AttnInd- PwrInd- RBE+ FLReset-
  DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
   RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop-
   MaxPayload 128 bytes, MaxReadReq 512 bytes
  DevSta: CorrErr+ UncorrErr- FatalErr- UnsuppReq+ AuxPwr- TransPend-
  LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Latency L0 <512ns, L1 <64us
   ClockPM+ Suprise- LLActRep- BwNot-
  LnkCtl: ASPM L0s L1 Enabled; RCB 64 bytes Disabled- Retrain- CommClk+
   ExtSynch- ClockPM+ AutWidDis- BWInt- AutBWInt-
  LnkSta: Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
 Capabilities: [100] Advanced Error Reporting <?>
 Capabilities: [140] Device Serial Number 1c-4b-d6-2e-7d-8a-00-00
 Kernel driver in use: rt2860
 Kernel modules: rt3090sta

Gary M (garym) wrote :

I was also using an Asus Eee PC 1001HA, and lucid beta 1's inbuilt staging driver module was failing. The logs showed an error due to a missing configuration file: /etc/Wireless/RT2860/RT2860.dat .

This file is available from the dkms package at https://launchpad.net/~markus-tisoft/+archive/rt3090 (which I've used in karmic), or from the vendor's original source at http://www.ralinktech.com/support.php?s=2 .

Creating the missing folders as root and placing the file there allowed the module to load and function.

I found that replacing the configuration with an empty file also worked (in karmic at least).

Below is the relevant extract from syslog during the startup of NetworkManager :

Mar 22 02:50:00 ubuntu kernel: [ 39.811101] RtmpOSFileOpen(): Error 2 opening /etc/Wireless/RT2860STA/RT2860STA.dat
Mar 22 02:50:00 ubuntu kernel: [ 39.811112] Open file "/etc/Wireless/RT2860STA/RT2860STA.dat" failed!
Mar 22 02:50:00 ubuntu kernel: [ 39.811120] 1. Phy Mode = 0
Mar 22 02:50:00 ubuntu kernel: [ 39.811125] ERROR!!! NICReadRegParameters failed, Status[=0x00000001]
Mar 22 02:50:00 ubuntu NetworkManager: <info> (wlan0): deactivating device (reason: 2).
Mar 22 02:50:00 ubuntu kernel: [ 39.816384] !!! rt28xx Initialized fail !!!
Mar 22 02:50:00 ubuntu NetworkManager: supplicant_interface_acquire: assertion `mgr_state == NM_SUPPLICANT_MANAGER_STATE_IDLE' failed

I'll try patching this next.

blusa (corsiandr-libero) wrote :

I tried creating /etc/Wireless/RT2860 and coping the .dat file but it didn't work. Changing the name of the directory in /etc/Wireless/RT2860STA and coping the RT2869STA.dat file do the job.

I didn't try using an empty .dat file.

Miguel (miguel-glug) wrote :

I have seen this bug too in the latest Lucid. Even after installing the rt3090-dkms of karmic from https://launchpad.net/~markus-tisoft/+archive/rt3090 no change has shown. The module rt3090sta is loaded but the mac80211 module can't use it, so the wireless isn't running at all. It has to be said in Karmic all went fine with this package, but in Lucid I can't find the way to make it works.

Xan (dxpublica) wrote :
Xan (dxpublica) wrote :

Confirmed. For example in xubuntu live cd of today, I can't see any wifi nets.

Xan.

Changed in linux (Ubuntu):
status: New → Confirmed
Xan (dxpublica) wrote :

What output you need for fixing that?

Rodrigo Donado (frezeeer) wrote :

Hi:
The link by Markus Heberling used to work in Karmic, after the last kernel update (2.6.31-21-generic) doesn't any more.
Same happen to me trying the Betas from Lucid.
Wifi is something everybody needs, please come up with a solution!!!
If someone needs outputs of both, the driver working and not working, please let me know.
By the way the Markus patch used to work flawlessly!

Alan (mrintegrity) wrote :

This affects me on latest lucid beta updates and eeepc 1001ha.

/A

linuxnoob18 (hotwheels-12-12) wrote :

The driver also works on the MSI U130 in Karmic however since lucid beta's this no longer works I would be extremeley happy if this is fixed in the RC version

Gary M (garym) wrote :

The kernel's staging driver module rt3090sta disappeared between lucid kernel versions 2.6.32-19 (beta 2) and 2.6.32-20. Please bring it back!

FWIW, an empty /etc/Wireless/RT2860STA/RT2860STA.dat file worked in lucid kernel 2.6.32-19 also.

I'm currently upgrading my system to lucid and will try to find a fix for the rt3090 driver.

Can't promise anything, since I have basically only packaged the ralink driver and have no experience in driver development myself.

darren (darrenm) wrote :

Cheers Markus! Your driver works perfectly in Karmic so I hope it should be simple to fix.

Hmm. The karmic driver works for me in lucid. I had to completely remove the package and install it again though. Otherwise I got an obscure error message.

markus@ubuntu-media-server:~$ uname -a
Linux ubuntu-media-server 2.6.32-21-generic #31-Ubuntu SMP Tue Apr 13 20:34:00 UTC 2010 i686 GNU/Linux

markus@ubuntu-media-server:~$ ifconfig ra0
ra0 Link encap:Ethernet Hardware Adresse 00:0d:f0:6d:47:0c
          inet Adresse:192.168.178.29 Bcast:192.168.178.255 Maske:255.255.255.0
          inet6-Adresse: XXXXXX/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metrik:1
          RX packets:2211 errors:97 dropped:0 overruns:0 frame:0
          TX packets:243 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:1000
          RX bytes:293955 (293.9 KB) TX bytes:45263 (45.2 KB)
          Interrupt:17

markus@ubuntu-media-server:~$ iwlist ra0 scanning
ra0 Scan completed :
          Cell 01 - Address: XXXXXXX
                    Protocol:802.11b/g
                    ESSID:"XXXXX"
                    Mode:Managed
                    Frequency:2.432 GHz (Channel 5)
                    Quality:100/100 Signal level:-25 dBm Noise level:-92 dBm
                    Encryption key:on
                    Bit Rates:54 Mb/s
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (1) : TKIP
                        Authentication Suites (1) : PSK
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK

markus@ubuntu-media-server:~$ modinfo rt3090sta
filename: /lib/modules/2.6.32-21-generic/updates/dkms/rt3090sta.ko
version: 2.3.1.3
srcversion: FFE8374362ED5B734E14328
alias: pci:v00001814d00003092sv*sd*bc*sc*i*
alias: pci:v00001814d00003091sv*sd*bc*sc*i*
alias: pci:v00001814d00003090sv*sd*bc*sc*i*
depends:
vermagic: 2.6.32-21-generic SMP mod_unload modversions 586
parm: mac:rt28xx: wireless mac addr (charp)

On Fri, 16 Apr 2010 20:33:28 -0000
Markus Heberling <email address hidden> wrote:

> Hmm. The karmic driver works for me in lucid. I had to completely
> remove the package and install it again though. Otherwise I got an
> obscure error message.
>
> markus@ubuntu-media-server:~$ uname -a
> Linux ubuntu-media-server 2.6.32-21-generic #31-Ubuntu SMP Tue Apr 13
> 20:34:00 UTC 2010 i686 GNU/Linux
>
> markus@ubuntu-media-server:~$ ifconfig ra0
> ra0 Link encap:Ethernet Hardware Adresse 00:0d:f0:6d:47:0c
> inet Adresse:192.168.178.29 Bcast:192.168.178.255
> Maske:255.255.255.0 inet6-Adresse: XXXXXX/64
> Gültigkeitsbereich:Verbindung UP BROADCAST RUNNING MULTICAST
> MTU:1500 Metrik:1 RX packets:2211 errors:97 dropped:0 overruns:0
> frame:0 TX packets:243 errors:0 dropped:0 overruns:0 carrier:0
> Kollisionen:0 Sendewarteschlangenlänge:1000
> RX bytes:293955 (293.9 KB) TX bytes:45263 (45.2 KB)
> Interrupt:17
>
> markus@ubuntu-media-server:~$ iwlist ra0 scanning
> ra0 Scan completed :
> Cell 01 - Address: XXXXXXX
> Protocol:802.11b/g
> ESSID:"XXXXX"
> Mode:Managed
> Frequency:2.432 GHz (Channel 5)
> Quality:100/100 Signal level:-25 dBm Noise
> level:-92 dBm Encryption key:on
> Bit Rates:54 Mb/s
> IE: WPA Version 1
> Group Cipher : TKIP
> Pairwise Ciphers (1) : TKIP
> Authentication Suites (1) : PSK
> IE: IEEE 802.11i/WPA2 Version 1
> Group Cipher : TKIP
> Pairwise Ciphers (1) : CCMP
> Authentication Suites (1) : PSK
>
> markus@ubuntu-media-server:~$ modinfo rt3090sta
> filename: /lib/modules/2.6.32-21-generic/updates/dkms/rt3090sta.ko
> version: 2.3.1.3
> srcversion: FFE8374362ED5B734E14328
> alias: pci:v00001814d00003092sv*sd*bc*sc*i*
> alias: pci:v00001814d00003091sv*sd*bc*sc*i*
> alias: pci:v00001814d00003090sv*sd*bc*sc*i*
> depends:
> vermagic: 2.6.32-21-generic SMP mod_unload modversions 586
> parm: mac:rt28xx: wireless mac addr (charp)
>
I installed your driver from the ppa and still haven't been able to get
things going. I tried all of your commands and the only one that works
is the last with the same output.

The iwlist ra0 scanning tells me that the interface does not support
scanning.

ifconfig ra0 gives me "device not found"

I'm going to reinstall and see if that makes any difference

Shelagh

--

----------------------------------------------------------------
Jabber: <email address hidden>
Wave: <email address hidden>

There's a thin line between fishing and standing on the shore
looking foolish.
----------------------------------------------------------------

Robert Nasiadek (robzon) wrote :

I had the same issue on Lucid. Creating an empty file, which was reported missing in dmesg (/etc/Wireless/RT2860STA/RT2860STA.dat) resolved the issue and my wifi works now.

Lucid Lynx Beta 2, MSI CX500 notebook with Ralink RT3090.

darren (darrenm) wrote :

Just done a dist-upgrade to Lucid on my EEE 1001HA. The /etc/Wireless/RT2860STA/RT2860STA file was already there. I touched it anyway and still didn't work so I did a dpkg-reconfigure rt3090-dkms and it rebuilt the kernel module. Didn't even need to reboot, just modprobed rt3090sta and network-manager connected right away. Thanks again Markus, just wish this could be sorted out without requiring 3rd party packages.

Carsten Agger (agger) wrote :

Just installed Lucid Lynx Beta 2 on an MSI Wind U135 - wireless with this chipset does not work. Will try tips given above, hope it will be fixed in the repos before release so it can work out of the box.

Carsten Agger (agger) wrote :

Situation report on my MSI Wind U135 with Lucid Beta 2:

Touch /etc/Wireless/RT2860STA/RT2860STA.dat

This file is empty!

update & upgrade

reboot

Wireless works

There should not be any "Wireless" directory in /etc, i believe - and the file is not needed. This mus be a bug in the driver - it should not look for this file since it isn't need it. How do I locate the driver and do we have the source code for it? I'm not familiar with Ubuntu development but with plenty experience with C I think I could easliy fix it. Maybe better leave it to upstream, tho

Alan (mrintegrity) wrote :

I would just like to confirm that the workaround suggested by Carsten seems to work perfectly (so far).

As root:

mkdir -p /etc/Wireless/RT2860STA/
touch /etc/Wireless/RT2860STA/RT2860STA.dat
service network-manager restart

It is then possible to connect via network manager.

/Alan

Neo (reminraphael) wrote :

WIFI hotkeys does not run (for example Fn + F2). Lucid 10.04 final on my eeepc 1001HA

Downloaded rt3090 driver from

http://www.ralinktech.com/download.php?t=U0wyRnpjMlYwY3k4eU1ERXdMekF5THpJekwyUnZkMjVzYjJGa09Ea3pOalE1TlRBd09DNWllakk5UFQxU1ZETXdPVEJmVEdsdWRYaFRWRUZmVmpJdU15NHhMalJmTWpBeE1EQXlNakl1ZEdGeUM=

installed successfully but hotkey is not working. wifi cant enable.

cheers,
Neo

Jeremy Visser (jeremy-visser) wrote :

Neo, if your Eee 1001 is anything like my Eee 901, you can enable WiFi
in the BIOS setup screen (F2 on boot).

djbmister (db260179) wrote :

Comment 22 is the solution, but there is also more that is causing the problem.

In the new kernel there is an early version of rt3090sta.ko in /lib/modules/2.6.32.21-generic/drivers/staging/rt3090
2.1.0 i believe. You need to remove this first before updating.

Using Ralink driver, the Wifi kill switch no longer works, which is a bummer.

Hope this helps

Xan (dxpublica) wrote :

Neo,

There is a problem with hotkeys in eeepc 1001ha. See the bug https://bugs.launchpad.net/ubuntu/+source/udev/+bug/558628
Perhaps it's a related bug, I don't know. I report the bug #558628 because some hotkeys does not run in my eeepc (1001ha). Please, follow the guide https://wiki.ubuntu.com/Hotkeys/Troubleshooting and add wifi hotkeys if there is a real problem....

Regards,
Xan.

Hi,

Having the same hardware (Asus Eeepc 1001HA) with UNR 9.10 karmic installed, I upgraded to lucid lynx and did exactly what darren proposed in comment #18. It worked perfectly.

Laurent

Xan (dxpublica) wrote :

I think the problem is that there is no feature "out-of-the-box" in 10.04

Neo (reminraphael) wrote :

many thanks 2 Jeremy Visser comment #23 work fine on lucid asus eeepc 1001HA wifi

cheers,
Neo

Sam St. James (samsaintjames) wrote :

I simply installed the package from the site (https://launchpad.net/~markus-tisoft/+archive/rt3090) again after the dist-upgrade to lucid, then did a modprobe rt3090sta and WLAN works now again on my EeePC1001HA.

Oz Man (ozviewer) wrote :

I have an MSI U230. Wireless not working with Ubuntu 10.04. After d/l and installing the deb from Markus Heberling (ppa not working, had to do a manual download), then a modprobe and voila! wireless working with no problems. Many thanks to Markus and above bug reporters.

madmed (medbelh) wrote :

the solution in comment 21 works perfectly.

Xan (dxpublica) wrote :

Does anyone want to make a patch following comment # 21? I think it could be very easy to write for experts....
This bug should be fixed out the box (when people upgrade the lucid installation).

Regards,
Xan.

Himanshu Sharma (s-himanshu9) wrote :

The Solution in comment #21 did not work for me.
My network adapter is Ralink 3090, MSI Wind.
I recently switched from Windows 7 starter to the Netbook Edition 10.04. Are we expecting any future update to resolve it ?

Thanks
Himanshu

ahambidge (ahambidge) wrote :

Hello,

If you go to the Ralink website you can download the Linux driver for
the 3090 Wireless card.

I am sure that Ubuntu will patch this in the immediate future.

                                Regards,

                             Allan Hambidge

Neil L. Jackson (neil-jackson) wrote :

The steps in Comment #21 provided an effective workaround for this bug for me. They worked on a SONY VAIO M (Model VPCM111AX/W (Atom N450)) with a RaLink RT3090 on Ubuntu 10.04 (64-bit). Initially I was booting from USB so the steps worked fine but had to be repeated each time the system was restarted. Then I installed to the hard drive and the steps again worked fine and the fix is persistent.

Neil L. Jackson (neil-jackson) wrote :

Sorry. Further to my Comment #35, I should add that I received the following reports before I created the empty copy of the "missing" /etc/Wireless/RT2860STA/RT2860STA.dat.

ubuntu@ubuntu:~$ dmesg | grep -i RT3
[ 38.443096] rt3090sta: module is from the staging directory, the quality is unknown, you have been warned.
[ 38.545357] rt3090 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[ 38.545410] rt3090 0000:01:00.0: setting latency timer to 64

ubuntu@ubuntu:~$ dmesg | grep -i RT2
[ 39.363324] RtmpOSFileOpen(): Error 2 opening /etc/Wireless/RT2860STA/RT2860STA.dat
[ 39.363335] Open file "/etc/Wireless/RT2860STA/RT2860STA.dat" failed!
[ 39.368619] !!! rt28xx Initialized fail !!!
[ 39.708075] RtmpOSFileOpen(): Error 2 opening /etc/Wireless/RT2860STA/RT2860STA.dat
[ 39.708086] Open file "/etc/Wireless/RT2860STA/RT2860STA.dat" failed!
[ 39.713495] !!! rt28xx Initialized fail !!!

Xan (dxpublica) wrote :

The output "Open file "/etc/Wireless/RT2860STA/RT2860STA.dat" failed!" suggests that perhaps there are a permission file problem....

Xan.

Carsten Agger (agger) wrote :

No, it really suggests there is a file-related bug in the driver. There should not be a "Wireless" directory in /etc/, and if the driver needs to store a "dat" file somewhere, /etc/ is hardly the place to put it. Since it doesn't seem to be needed for persistence, it might as well be placed in /tmp.

So, the driver should be changed to not need the "RT2860STA.dat" file OR to look for it somewhere else, AND if it really needs it, to create it if it doesn't find it. In /tmp, e.g.

If someone can point me in the direction of the correct source code I think I can fix it.

Xan (dxpublica) wrote :

@Carsten: best in the /usr/share/drivers or something else. The /tmp is for temporally save files I think.
@Others: please help Carsten. At least we could mark this bug as "triaged" if we know what fails exactly.

Regards,

Joshua O'Leary (jmoleary) wrote :

The workaround #21 works the best for now, as I have experienced occasional crashing at startup when using the dkms driver.

darren (darrenm) wrote :

Marcus's version in the PPA works perfectly on my Asus 1001HA, suspends and resumes fine with no issues. The solution in comment 21 didn't work for me.

Hi Darren,

thanks for the link but I must be really stupid coz I don't understand
any of it. The last programming I did was using BBC basic!!! YEP that
long ago!

Is there a simple step by step guide or am I making it more complicated
than it really is?

Thanks again,
Keith

darren (darrenm) wrote :

No problem Keith.

Just click this https://launchpad.net/~markus-tisoft/+archive/rt3090/+files/rt3090-dkms_2.3.1.3-0ubuntu0~ppa1_all.deb and choose to open with the package installer then reboot.

darren (darrenm) wrote :

actually just thought, it may fail dependencies. If so, just open a terminal and type:

sudo apt-get -f install
then
sudo dpkg --configure -a
and then reboot

THANK YOU ALL VERY MUCH.

ALL WORKING ON WI FI!!!

ME HAPPY, STUFF WINDOWS!

Pedro Perez (gargollassa-c) wrote :

To me on my Asus eeePC 1001ha, this worked
[QUOTE]as root (or sudo before each line):
mkdir -p /etc/Wireless/RT2860STA/
touch /etc/Wireless/RT2860STA/RT2860STA.dat
service network-manager restart[/QUOTE]

wireless is active and looks for wireless networks... BUT
I cannot connect to my own hidden network with WPA

What did I do wrong? What should I do?

Ralemy (reza.alemy) wrote :

Just confirming that comment #21 works on Acer Aspire Revo R3610, Running Lucid Lynx Desktop 64 bit.
Thank you all

Gangelies (gangelies) wrote :

Hi
my Pc is a Eee 1001Ha.
After an upgrade from Karmic to Lucid I enconutered the same problem with the Wifi chipset, but the solution suggested in comment #18 worked perfectly for me.
Thank you all

Xan (dxpublica) wrote :

I did:

mkdir -p /etc/Wireless/RT2860STA/
touch /etc/Wireless/RT2860STA/RT2860STA.dat
service network-manager restart
restart
modprobe rt3090sta

After that, the network-manager see the wifi networks avaliable. So it seems it works.
I suspect that this trick _only_ works for asus eeepc 1001 ha. For the other computers with Ralink RT3090, I think you have to try solution on comment #41.

Regards,

Neil L. Jackson (neil-jackson) wrote :

Re #49, Note that the workaround summarised in #21 and #49 does not _only_ work for Asus eeepc 1001ha.

It worked for me (#35 above) on a SONY VAIO M (Model VPCM111AX/W (Atom N450)) with a RaLink RT3090 on Ubuntu 10.04 (64-bit).

And in #47 ralemi reports it worked "on Acer Aspire Revo R3610".

I apologise for disagreeing, Xan, but felt I should help keep the record straight.

Regards,
Neil.

ajstrobus (ajstrobus) wrote :

mkdir -p /etc/Wireless/RT2860STA/
touch /etc/Wireless/RT2860STA/RT2860STA.dat
service network-manager restart
------------------------------------------------------------
also works for me on HP Touchsmart 600-1005xt with RT3092 chipset

Xan (dxpublica) wrote :

@Neil, no apologies ;-) Good if there is different laptop in which this solution works. Better.
@ajstrobus, thank you too
@both: thanks for confirming that my intuition was wrong.

Regards,

How different is an RT2860 driver from an RT3090 driver? Is it better to use the built-into-lucid 2860 driver or try to install Markus' 3090 package?

BTW, Markus' PPA doesn't work for Lucid even if the .deb does. It needs a populated lucid directory.

mohamodenuhafiza (nofiza) wrote :

hello darren

Can you please write a little clear on #44?
I've tried apt-get -f install and nothing happen...I use 10.04 Remix.

gustavo (gdrama) wrote :

I tried all the workarounds and still not working.
I have an msi u130, with RT3090 Wireless chip.

Andy Brandt (andy-andybrandt) wrote :
Download full text (3.9 KiB)

Have same problem. MSI Wind U160, RT3090. Lucid:
Linux pawhare 2.6.32-21-generic #32-Ubuntu SMP Fri Apr 16 08:10:02 UTC 2010 i686 GNU/Linux

Tried Marcus driver, tried empty RT2860STA.dat and one that came with the package. No success, no WiFi, still stuck with Windows 7. Any help appreciated - have been two months since I have this netbook, haven't been able to really use Linux at all since then.

Output from lshw -c net:
  *-network DISABLED
       description: Wireless interface
       product: RT3090 Wireless 802.11n 1T/1R PCIe
       vendor: RaLink
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: ra0
       version: 00
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=RALINK WLAN driverversion=2.3.1.3 latency=0 multicast=yes wireless=Ralink STA
       resources: irq:17 memory:fd600000-fd60ffff

Relevant messages from dmesg:

[ 9.747436] rt3090sta: module license 'unspecified' taints kernel.
[ 9.747446] Disabling lock debugging due to kernel taint
[ 9.768003] rt2860 0000:03:00.0: Refused to change power state, currently in D3
[ 9.768023] rt2860 0000:03:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17

Not sure this one is relevant, but appears when manually trying to get the driver into kernel (modprobe rt3090sta):
[ 1655.566344] RX DESC c6d62000 size = 2048
[ 1655.566827] <-- RTMPAllocTxRxRingMemory, Status=0
[ 1655.774965] ERROR!!! H2M_MAILBOX still hold by MCU. command fail
[ 1655.776357] ERROR!!! BBP(viaMCU=1) read R0 fail
[ 1655.776610] ERROR!!! BBP(viaMCU=1) read R0 fail
[ 1655.776849] ERROR!!! BBP(viaMCU=1) read R0 fail
[ 1655.777104] ERROR!!! BBP(viaMCU=1) read R0 fail
[ 1655.777339] ERROR!!! BBP(viaMCU=1) read R0 fail
[ 1655.777572] ERROR!!! BBP(viaMCU=1) read R0 fail
[ 1655.777806] ERROR!!! BBP(viaMCU=1) read R0 fail
[ 1655.778040] ERROR!!! BBP(viaMCU=1) read R0 fail
[ 1655.778274] ERROR!!! BBP(viaMCU=1) read R0 fail
[ 1655.778507] ERROR!!! BBP(viaMCU=1) read R0 fail
[ 1655.778742] ERROR!!! BBP(viaMCU=1) read R0 fail
[ 1655.778975] ERROR!!! BBP(viaMCU=1) read R0 fail
[ 1655.779208] ERROR!!! BBP(viaMCU=1) read R0 fail
[ 1655.779442] ERROR!!! BBP(viaMCU=1) read R0 fail
[ 1655.779675] ERROR!!! BBP(viaMCU=1) read R0 fail
[ 1655.779909] ERROR!!! BBP(viaMCU=1) read R0 fail
[ 1655.780300] ERROR!!! BBP(viaMCU=1) read R0 fail
[ 1655.780552] ERROR!!! BBP(viaMCU=1) read R0 fail
[ 1655.780802] ERROR!!! BBP(viaMCU=1) read R0 fail
[ 1655.781062] ERROR!!! BBP(viaMCU=1) read R0 fail
[ 1655.991791] ERROR!!! H2M_MAILBOX still hold by MCU. command fail
[ 1655.993193] ERROR!!! BBP(viaMCU=1) read R0 fail
[ 1655.993431] ERROR!!! BBP(viaMCU=1) read R0 fail
[ 1655.993665] ERROR!!! BBP(viaMCU=1) read R0 fail
[ 1655.993897] ERROR!!! BBP(viaMCU=1) read R0 fail
[ 1655.994131] ERROR!!! BBP(viaMCU=1) read R0 fail
[ 1655.993665] ERROR!!! BBP(viaMCU=1) read R0 fail
[ 1655.993897] ERROR!!! BBP(viaMCU=1) read R0 fail
[ 1655.994131] ERROR!!! BBP(viaMCU=1) read R0 fail
[ 1655.994363] ERROR!!! BBP(viaMCU=1) read R0 fail
[ 1655.994596] ERROR!!! BBP(viaMCU=1) read R0 fail
[ 1655.994828] ERROR!!! BBP(viaMCU...

Read more...

Joshua O'Leary (jmoleary) wrote :

Ignore comment #40, I experience freezing when using the workaround, the dkms driver does this also. Freezing occurs if you boot up the system without the router turned on. If you reboot it, it loads fine, but freezing happens regularly and boot time.

Will this bug be fixed in a newer kernel or update?

Tim Comport (timcomport) wrote :

MSI Wind U160
Experiencing the same as Andy with the numerous
ERROR!!! BBP(viaMCU=1) read R0 fail
lines in the log.
I have also tried all posted solutions here and elsewhere to get wifi working without success (including adding the line "pciehp pciehp_force=1 pciehp_poll_mode=1" to /etc/modules as suggested here: http://blog.f-seidel.de/ for the U110) It seems that these messages may be related to a BIOS issue. I have tried the following BIOS versions:
0.07 - No indication that wireless device even present, unable to load manually (didn't try for long)
1.02 - Same results as Andy (post #56)
1.06 - Same results as 1.02
Could those that have working setups with the MSI Wind U160 please report their BIOS version.
Any ideas?
Thanks.

Joshua O'Leary (jmoleary) wrote :

Did you try doing Ubuntu updates over ethernet before installing the driver? I installed the updates over ethernet and then installed the driver, and my eeepc (1001ha) works fine now apart from a few freezing issues.

Tim Comport (timcomport) wrote :

Installing updates first has no effect and does not solve the issue on the MSI Wind U160. Note that the errors in post #56 are logged even when running off the live cd only. Any ideas? Any Wind U160 users with wifi working? What BIOS / software versions are you running? What was your install process? I believe there is more than 1 bug discussed in this thread, as I haven't seen the logged error regarding the missing .dat file at all.

John McCourt (butterman) wrote :

I can confirm this bug. I cannot conntect to a WPA2 router, even with the ralink 3090 package installed it just wont connect.

 This is a big problem because this wi-fi card is sold as part of the the EEEPC 1001HA by a major retailer in the UK (Argos)Asus EEEPC 1001 which has these installed. Argos are one of the biggest sellers of computer in the UK and Ireland. Alot of people are buying this model of computer because it has got alot of good reviews and the price is very good compared to other models with similar specs.

If there is no fix for these machines then people who own them probably wont use Ubuntu.

Andy Brandt (andy-andybrandt) wrote :

Same applies to MSI U160. It is a great little machine, but since I purchased it I had to abandon using Linux - without WiFi support I can't use the net most of the time, which would render the machine useless. I'm using Windows 7 instead hoping that one day this will be solved.

I have an Acer Revo R1600 with one of these wireless devices. Out of the box, Lucid's driver didn't work. To fix it, I created an empty file in as described in #12 and elsewhere. It works for me.

I don't have the machine at hand to check exactly what I did, but I do have the output of dmesg. I'll quote some bits.

[ 0.000000] Linux version 2.6.32-24-generic (buildd@yellow) (gcc version 4.4.3 (Ubuntu 4.4.3-4ubuntu5) ) #38-Ubuntu SMP Mon Jul 5 09:20:59 UTC 2010 (Ubuntu 2.6.32-24.38-generic 2.6.32.15+drm33.5)

I think that this shows I'm running the up to date kernel. It is a 64-bit one. Netbooks will have to run 32-bit ones but that should not be important.

[ 15.865117] rt3090sta: module is from the staging directory, the quality is unknown, you have been warned.

[ 16.257484] Read file "/etc/Wireless/RT2860STA/RT2860STA.dat" failed(errCode=0)!
[ 16.257505] 1. Phy Mode = 0
[ 16.257509] 2. Phy Mode = 0
[ 16.257514] NVM is Efuse and its size =2d[2d0-2fc]
[ 16.258830] 3. Phy Mode = 0
[ 16.281866] RTMPSetPhyMode: channel is out of range, use first channel=1
[ 16.281873] MCS Set = 00 00 00 00 00
[ 16.292025] <==== rt28xx_init, Status=0
[ 16.292099] 0x1300 = 00073200
[ 16.292121] AUX_CTRL = 0x c02
[ 16.292129] Read AUX_CTRL = 0xc02
[ 16.292134] Write AUX_CTRL = 0x1c02
[ 16.292140] OSC_CTRL = 0x3ff11
[ 16.344049] ====> rt30xx Read PowerLevelMode = 0x3.
[ 16.344056] ====> rt30xx F Write 0x83 Command = 0x3.

Just for record. The workaround sugested in #21 also works for Asus EEEPC 1000h, Bios version 2.2.04, wireless RaLink RT2860, Kubuntu Netbook 10.04.

martin met linux (b-uffel) wrote :

I bought a msi wind u23o with the ralink rt3090 driver.
Got tired of windows 7 rather quickly and installed ubuntu 10.04 netbookversion from usb.
On live and after installation I had no wifi access, although windows7 did.
With the above information however and the ubuntu help pages I managed to get it running.
Followed advice in #43, and that seemed to do the trick.
Thx a lot, I registered just to say that!

zandgreen (zandgreen) wrote :

Confirm the same bug on my MSI U160. No solutions mentioned above would solve the matter. Any idea?

I have this working under the previous kernel, but the update that I took to the kernel overnight broke it and none of the workaround can get it back. I am trying to access a Hidden Network, like Pedro.

2 Tech2010:
I had the same problem. I fixed it by removing the driver and installing it again.

cshong (cshong87) wrote :

I am using HP Mini 110 netbook with Ralink RT3090 wireless chipset.

I also faced this problem. However, I fixed it by downloading and installing the latest driver from http://www.ralinktech.com/support.php?s=2 .

Before building and installing the driver, you need to ensure the packages "build-essential" (or at least GCC) are installed. If you did not install it before, and cannot connect to the internet by using wired LAN, you have windows and can boot to Windows, or you can access another computer which can access internet, follow these steps:

1. Run Synaptic Package Manager, mark the package "build-essential", the other required packages will be automatically marked for you.
2. Then, in Synaptic Package Manager, click file -> Generate package download script, then save the generated script into either your USB Flash Drive or external hard disk drive.
3. If you can boot to Windows, and your windows can access internet, you open the generated script file, you will see a lot of URL inside the files. Paste those URL on your web browser or any download manager software to download the required packages. You can also open the script files and download the packages on another computer that can access internet.
4. Save all those downloaded packages into your USB Flash Drive or external hard disk drive.
5. Also download the RT3090 driver source files from the above website to your USB drive.
6. Back to the Ubuntu on your computer, run Synaptic Package Manager again, click File -> Add downloaded packages, then go to the directory of your downloaded packages, click OK. The packages will be installed. You can now proceed to build the new driver.
7. Extract the downloaded driver source files to any directory.
8. Open terminal, go to the directory where you extracted the files to, then run "sudo make" to build the driver.
9. Run "sudo make install".
10. Either restart the networking services or reboot your Ubuntu.
11. Enjoy your wireless internet.

To be more clear, the workaround sugested in #21 also works for Asus EEEPC 1000h, Bios version 2.204, wireless RaLink RT2860, Kubuntu Netbook 10.04, using WPA-PSK - announced SSID.

About comment #69, but at every Kernel update the wireless will be broken, so you're gonna have to redo step 9.

RealGomer (kep3) wrote :

Question on this bug. Would it also effect a usb wireless adapter that uses the rt2870.sta driver? It seems I can't use WPA / WPA2 security on my router. I haven't tried the fixes / patches suggested at
http://www.linuxquestions.org/questions/linux-networking-3/ubuntu-10-04-wont-actually-connect-to-wireless-network-822323/
(It's 5 pages long, so have patience.) Thank you.

Lionel BASTET (lionel-bastet) wrote :

Workaround as described in comment #21 works on a COMPAQ Mini CQ10-410SF netbook (Atom N450 processor) with Ubuntu 10.04 and WIFI link working with WPA/WPA2 encryption.
Ubuntu 10.04 installed today from the Canonical free CD, all updates ( 250 modified files) performed through wire LAN before trying to set up the WIFI link , without success, although the WIFI LED could be turned ON/OFF through the relevant key.
When looking at the existing /etc/Wireless folder before trying any workaround, it was not empty: there was (and still is) a RT2860A empty subfolder.
Using the workaround from comment #21 added in /etc/Wireless the RT2860STA subfolder containing the RT2860STA.dat empty file.
Then the WIFI networks detection worked fine, and setting my own WIFI link with its WPA/WPA2 encryption was easy.
Hope this can help other users of this COMPAQ netbook.

Lionel BASTET (lionel-bastet) wrote :

Sorry, I forgot:
COMPAQ Mini CQ10-410SF uses a Ralink RT3090 wireless chipset,
Ubuntu 10.04 : 2-6-32.24-generic

I have updated my PPA to Ralink driver 2.3.1.7 for lucid.

https://launchpad.net/~markus-tisoft/+archive/rt3090/

Oreste (angelo-benoit) wrote :

Thanks Markus, it's work on my eeepc 1001ha and the 2.6.32-24 kernel. :)

Declining the Lucid and Maverick specific nominations for now and leaving this open against the actively developed Ubuntu kernel (which happens to be Maverick at this time). Will re-open the nominations should a driver be included which specifically resolves this issue in Lucid and Maverick and qualifies for a Stable Release Update.

Joshua O'Leary (jmoleary) wrote :

This bug seems to be fixed so wifi is working out of the box in Ubuntu Maverick beta, testing on eeepc, as the driver in Maverick has been switched to rt2800pci.

Not fixed in Maverick beta. Testing on MSI u210. Here is related dmesg output:
$dmesg | grep rt2
[ 25.509218] rt2800pci 0000:02:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[ 25.509243] rt2800pci 0000:02:00.0: setting latency timer to 64
[ 25.784921] Registered led device: rt2800pci-phy0::radio
[ 25.784946] Registered led device: rt2800pci-phy0::assoc
[ 25.784968] Registered led device: rt2800pci-phy0::quality
[ 25.935704] rt2860sta: module is from the staging directory, the quality is unknown, you have been warned.
[ 29.380084] phy0 -> rt2800pci_load_firmware: Error - PBF system register not ready.
[ 29.380678] phy0 -> rt2x00pci_regbusy_read: Error - Indirect register access failed: offset=0x00007010, value=0x2bac4b2c
[ 30.220054] phy0 -> rt2800pci_load_firmware: Error - PBF system register not ready.
[ 30.220648] phy0 -> rt2x00pci_regbusy_read: Error - Indirect register access failed: offset=0x00007010, value=0x2bac4b2c

Workaround for Maverick beta:
1) Install Markus driver for *lucid* (comment #75)
2) balcklist rt2800pci

P.S. Many thanks to Markus!

Fabián Rodríguez (magicfab) wrote :

Raising to high - from https://wiki.ubuntu.com/Bugs/Importance:
* Has a severe impact on a small portion of Ubuntu users (estimated)
* A problem with an essential hardware component (disk controller, laptop built-in wireless, video card, keyboard, mouse)

Changed in linux (Ubuntu):
importance: Undecided → High
Yuriy Vidineev (adeptg) wrote :

I have the same problem as Andriy Tsykholyas on MSI X410

Alex Moldovan (alexmoldovan) wrote :

I can confirm that the solution in comment #43 works with the following hardware:
03:00.0 Network controller [0280]: RaLink RT3090 Wireless 802.11n 1T/1R PCIe [1814:3090]
Using the rt3090-dkms_2.3.1.3-0ubuntu0~ppa1_all.deb package solved the problem.

Alex, Markus updated the driver to version 2.3.1.7. See comment #75.

Alex Moldovan (alexmoldovan) wrote :

Oups! Sorry guys, the driver I used was the "rt3090-dkms_2.3.1.7-0ubuntu0~ppa2_all.deb". In my previous comment I copied the wrong version number.

Yuriy Vidineev (adeptg) wrote :

I build linux 2.6.35.4 from kernel.org (with config from 2.6.35-21-generic) and problem is still here. So it is not ubuntu-specific bug. Can someone, plz, write to kernel-developers mailing list or bugzilla?
P.S. Sorry for my english

Rodrigo Donado (frezeeer) wrote :

Comment #80 worked for me.
But since I am testing Maverick every time the Kernel gets updated I have to reboot twice to have the wireless working again.
Any possibility of adding the patch to the kernel?

Yuriy Vidineev (adeptg) wrote :

On 2.6.36-rc4 i have the same problem:

user@user-laptop:~$ uname -a
Linux user-laptop 2.6.36-rc4-git3 #1 SMP Fri Sep 17 23:03:36 YEKST 2010 x86_64 GNU/Linux

user@user-laptop:~$ dmesg | grep rt2
[ 19.951749] rt2800pci 0000:03:00.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
[ 19.951762] rt2800pci 0000:03:00.0: setting latency timer to 64
[ 20.011109] Registered led device: rt2800pci-phy0::radio
[ 20.011137] Registered led device: rt2800pci-phy0::assoc
[ 20.011161] Registered led device: rt2800pci-phy0::quality
[ 20.150069] phy0 -> rt2800_load_firmware: Error - PBF system register not ready.
[ 20.250032] phy0 -> rt2800_load_firmware: Error - PBF system register not ready.

Steve Jackson (aearenda) wrote :

Just noting that on a friend's MSI Wind U160, updating the BIOS from version 102 to 108 made the RT3090STA driver work, where previously it would not. The /etc/Wireless/RT2860STA/RT2860STA.dat workaround is still in place, and the updated rt3090sta driver from Markus' PPA is installed. The BIOS version is obviously significant on this machine.

MMlosh (mmlosh) wrote :

Workaround seems to fix trouble on HP620 as well

I was having a lot of trouble with my RT3090 PCIe..
I was going to compile drivers from ralink.. and found out, that it's usb+wifi combo => the "wireless key" actually controlls both wifi&bt

timo (playsansara) wrote :

Hi Everyone,
I hope this is the right spot for my problem
I can't get my rt3090pci to work on an msi cr600 under lucid 64bit.
It did work on earlier kernel versions, but after installing 2.6.32-22-generic Markus' PPA won't do the trick any more... I also did create /etc/Wireless/RT2860STA containing the .dat file.
The strange thing about it is that I actually can find access points with rt3090-dkms installed, but I can't connect to them! And it's not some WPA issue since I'm trying to connect to an open network.
When I manually configure the connection with a static IP, the network-manager reports as having established a connection, but I still can't browse the internet or ping anything. (I should add that no one else is having problems with this network, and the wifi is working properly under windows 7).
On kernels prior to 2.6.32-22-generic I couldn't get my wifi to work at all until I installed Markus' driver, now it seems to work half way only with the driver...
Is anyone experiencing similar problems?

timo (playsansara) wrote :

Me again. I just wondered:
Should I attach information via

$ apport-collect -p linux 541620

or should I open a new bug report for this, or is none of this appropriate?

timo, some kernel updates break rt3090 driver. The easiest approach to re-enable the driver is to uninstall it and install it again.

timo (playsansara) wrote :

I did install, uninstall, and reinstall the rt3090-dkms package several times already; I tried $ sudo dpkg-reconfigure rt3090-dkms but nothing changes at all...

Linuxexperte (andrea-koeth) wrote :

Hi people,
I just got me a new Notebook from MSI (modell is CR500x). This machine also uses this WLAN-Chip.

Because of the harddrive being empty without any system installed on it, I installed LinuxMint64bit Gnome-Edition. But then I found, that the same thing affects me too also like the others.

The kernel-module 3090 is loaded, but can't be used for some reason. So I also can't see any wireless networks.

So I would be happy, if anybody could get me a solution.

For more information, I enclose you the output of the Script "CollectNWdata".

Perhaps this will give you more information and somebody could perhaps help me to make wireless working again, because this chip is an onboard- wireless-chip without any hardware-switch on it.
I also have checked BIOS already to find a possible hint. But BIOS on this machine does not offer any option for enabeling or even disabling of wireless.

Thank you in advance,
Linuxexperte

Linuxexperte (andrea-koeth) wrote :

hi people,
I tired the soultion in comment 49. The first command for creating this file, copying the .dat-file into this folder and touching it run well if you put the word sudo before these commands.

But then if I want to restart the network-manager, then I get an error.

The output says this:
andrea@andrea-laptop $ service network-manager restart
restart: Rejected send message, 1 mastched rules; type="method_call", sender=":1.
48" (uuid=1000 pid=1885 comm="restart) interface="com.ubuntu.Upstart0_6.Job"memb
er="Restart" error-name="(unset)" requested_reply=0 destination="com.ubuntu.Upst
art" (uid=0 pid1 comm="/sbin/init"))

Can someone tell me, what I have to do, for fixing this error??

Thank you

Linuxexperte (andrea-koeth) wrote :

hi together, I am it again.
I regret to tell you, that this package mentioned in comment 43 does not bring the solution for me. A few minutes ago, I went online via Cable (Network-Cable) and di all updates and upgrades, installed this ppa mentioned in comment 43. Installation went well without problems.

But: still no wirless networks to see.

Also this other solution wich I tried before (look my comments), did not bring any solution.

What can I do for getting this wireless run??

Greetings
Linuxexperte

silfer (jonathanysp) on 2010-10-14
description: updated
Linuxexperte (andrea-koeth) wrote :

Hi people,
I found another way for getting rid of this problem.

Solution for me was: changing the distro on my Notebook to OpenSuse11.4. This Distro brings the driver already included in the Kernel and you only need to activate a repositroy and install the firmware.

Then it worked out for me without any more problems.

Test this way.

In LinuxMint and Ubuntu, it still does not work. I think this problem is because of the driver.

Greetings
Linuxexperte

MMlosh (mmlosh) wrote :

It works for me with rt2860sta (if the file /etc/Wireless/RT2860STA/RT2860STA.dat is downloaded rt3900 firmware)

Unfortunately rt2800pci takes over the card in maverick, blocking rt2800sta (which is loaded too) from working
rt2800pci fails, shows one noexistent network called "SMC" with 100% signal and no encryption

blacklisting it gave me working wifi again (I know.. staging modules are quite bad idea, although my X11 sometimes fail to start with the maverick-preferred rt2800)

Would a few of you care to check the following hypothesis about the current state of affairs on current maverick with rt3090 hardware:
rt2800pci driver works on 32 bit systems (but may freeze on shut down)
rt2800pci driver fails on 64 bit systems with something like: "phy0 -> rt2800pci_load_firmware: Error - PBF system register not ready. in syslog"

(since maverick the rt2800pci is supposed to drive the rt3090 hardware)

MMlosh (mmlosh) wrote :

my system reports "i686", so I guess it's 32bit, hardware itself should be 64-bit capable.

the driver didn't work, I blame it even for the fact, that login manager didn't show up - usually on 1st boot after longer downtime.

I think it produced a different message.. I'll check something like dmesg.1.gz

this is what grep -i rt2800pci found the day when I tried to list networks and connect

[ 17.290621] rt2800pci 0000:02:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[ 17.290649] rt2800pci 0000:02:00.0: setting latency timer to 64
[ 17.392481] Registered led device: rt2800pci-phy0::radio
[ 17.392500] Registered led device: rt2800pci-phy0::assoc
[ 17.392519] Registered led device: rt2800pci-phy0::quality
[ 21.607448] phy0 -> rt2800pci_mcu_status: Error - MCU request failed, no response from hardware

the days before (I just turned the wifi on and off) the last line is not present

also: rt2800pci makes HP620's blue/orange rfkill led rapidly change colors when wifi is active, orange when inactive..
Is is distracting and damages user's concentration on the work

rt3900 is bluetooth+wifi combo.. unless it's possible to turn on only one of them, it is useless to blink the LED.

MMlosh (mmlosh) wrote :

oops.. rt3090 of course

also: It managed to detect network the first boot after upgrade (at first with hidden ssid, second time with visible one), but it refused to obey networkmanager and connect, and eventually froze the computer. + iwconfig listed it with mode=master

Linuxexperte (andrea-koeth) wrote :

hi people,
I found an easy solution for LinuxMint, which should also work in Ubuntu and ubuntubased Distros.

Go to your terminal and type in this command: lsmod | grep rt

Your output will lokk something similar to this one:

rt2860sta 488820 0
rt2800usb 37372 0
[...]

This gives the hint to the solution:

Steps to the solution:

open your Terminal and first type in this: sudo modprobe rf rt2800pci

Then afterwards type in this: sudo modprobe -rf rt2860sta

As the next step follows this command in your terminal: sudo modprobe rt2860sta

Just as you type in this, your networkmanager connects automaticly and comes back to work!!!

But to close the whole thing up, you need tot ype in this command, for finishing up:

echo blacklist rt2800pci | sudo tee -a /etc/modprobe.d/blacklist.conf

Then you are d one and your networkmanager will work for you again.

Greetings
Linuxexperte

clonejo (a-admin-clonejo-de) wrote :

@Linuxexperte: (#103)
Great, works for me in Maverick (rebooting not tested, but should work, too).

Linuxexperte (andrea-koeth) wrote :

@ clonecho,

have tested this solution for a time now and it works perfect. I got my complete WLAN-speed back and connection runs fine!!!
@ all: this solution works in LinuxMint, in Ubuntu/Xubuntu/Kubuntu/Lubuntu and it should also work with Kanotix and Parsix (which is the Gnome-Version of Kanotix).

So this bug can be seen as solved and can be closed.

Greetings
Linuxexperte

MMlosh (mmlosh) wrote :

@Linuxexperte

No, it cannot be closed. Placeholder kernel modules from staging tree that require firmware file in nonstandart /etc/Wireless do not count.

RT3090 still needs to be ported to rt28xx infrastructure to make maintenace bearable.

Also: disabling correct-but-broken rt28xx-based module is only a workaround (and was already mentioned in the scrollback. And not only once)

Gary M (garym) on 2010-11-24
tags: added: kernel-wifi rt3090 staging
Changed in linux-2.6 (Debian):
status: Unknown → Fix Released
Tim Brody (tim-brody) wrote :

In response to #100

maverick 10.10:
rt2800pci driver works on 32 bit systems (but may freeze on shut down)

Finds network, connects to WPA but hard-locks as soon as the module is unloaded (not even a kernel stack trace).

       description: Network controller
       product: RT3090 Wireless 802.11n 1T/1R PCIe
       vendor: RaLink
       physical id: 0
       bus info: pci@0000:02:00.0
       version: 00
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: memory:febf0000-febfffff

Thanks Tim

This does look like bug 662288. Have you also tried getting a trace on a text console? (see e.g. https://help.ubuntu.com/community/DebuggingSystemCrash for more info)

Thanks

Tim Gardner (timg-tpi) wrote :

There are 2 Lucid compat-wireless packages you can try: linux-backports-modules-wireless-2.6.35-lucid-generic and linux-backports-modules-wireless-2.6.36-lucid-generic. Or, you can install the Natty backport kernel from https://launchpad.net/~kernel-ppa/+archive/ppa

Basico (bcolligris) wrote :

I'm not sure if it was mentioned above but installing Ubuntu 10.10 NETBOOK edition, solves the problem. Then if you like, you can change the Login option and use the classic Ubuntu Desktop. I use this with my Sony Vaio VPCM12M1E and works perfectly.

Carsten Agger (agger) wrote :

But, of course, such a workaround as installing the netbook edition instead is just strange. It would be nice and easier to fix if it could be understood why installing the netbook edition produces a different result.

Presumably the ubuntu 10.10 netbook edition works because it is 32 bit while the 64 bit version (desktop) fails with bug 659143.

It would be interesting to see more reports from users of the rt2800pci driver, both for working and non-working cases. But please with the output from the following commands:

uname -rvm
lspci -knn |grep Network --after-context 3

in addition to information about where the driver came from (built in or extra install with compat-wireless, linux-backports-modules-wireless, ...)

Linuxexperte (andrea-koeth) wrote :

hi Wolfgang,
for me, the rt2860-driver works after this Terminal-commands I mentioned in my earlier comment. The other drivers do not work for me.
I will give you thie output you wished to see...

The output of the Terminal-command uname -rvm is in my case this:

2.6.35-24-generic #42-Ubuntu SMP Thu Dec 2 02:41:37 UTC 2010 x86_64

and the other command brings this output:

lspci -knn |grep Network --after-context 3

06:00.0 Network controller [0280]: RaLink RT3090 Wireless 802.11n 1T/1R PCIe [1814:3090]
 Subsystem: Micro-Star International Co., Ltd. Device [1462:6891]
 Kernel driver in use: rt2860

I have this dirver from the system itself and did not install any foreign drivers on my Laptop. The only proprietary driver I have installed here on my Laptop is the nvidia-driver for the display. The system suggests to install this driver, as the graphic-card on my Laptop is an nvidia-graphic-card.

On my stationary machine, I do not have these problems, because it has a wifi-usb-stick with rt2500-driver and this stick runs out-of-the-box so that I cannot blame this driver for not working. Only the one for rt2800pci and rt3090 have to be blamed for not working.
IO alwayw have to blacklist them and then the rt2860sta-driver runs as it should.

Greetings
Linuxexperte
 Kernel modules: rt2860sta, rt2800pci

DanielRoesler (diafygi) wrote :

Question:
I used the blacklist fix to get my RT3090 wireless card working in Ubuntu 10.10 (thanks!). However, I can only connect to 802.11b/g wireless networks and cannot connect to 802.11n networks. I can connect to wireless n networks in my Windows 7 partition. How can I troubleshoot this in Ubuntu?

Here's my output from iwconfig, lsmod, and lshw:

diafygi@diafygi-revo:~$ iwconfig wlan0
wlan0 Ralink STA ESSID:"I use Ubuntu, so should you!" Nickname:"RT2860STA"
          Mode:Managed Frequency=2.457 GHz Access Point: 1C:AF:F7:D7:0B:0B
          Bit Rate=54 Mb/s
          RTS thr:off Fragment thr:off
          Link Quality=100/100 Signal level:-43 dBm Noise level:-83 dBm
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0

diafygi@diafygi-revo:~$ lsmod | grep ^rt
rt2860sta 559618 1

diafygi@diafygi-revo:~$ sudo lshw
*-network
                description: Wireless interface
                product: RT3090 Wireless 802.11n 1T/1R PCIe
                vendor: RaLink
                physical id: 0
                bus info: pci@0000:02:00.0
                logical name: wlan0
                version: 00
                serial: 1c:65:9d:59:a4:dd
                width: 32 bits
                clock: 33MHz
                capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
                configuration: broadcast=yes driver=rt2860 ip=192.168.2.100 latency=0 multicast=yes wireless=Ralink STA
                resources: irq:18 memory:febf0000-febfffff

hrvooje (hrvooje-gmail) wrote :

the solution from comment #103 worked for me on hp 4520s on ubuntu 10.10 . thank you so much!

DanielRoesler (diafygi) wrote :

@hrooje, are you able to connect to a 802.11n wireless network?

hrvooje (hrvooje-gmail) wrote :

@DaniekRoesler, I will have to check that. I'm not at home right now. I think my router is set to 802.11b/g. I will try 802.11n too and let you know.

Joshua O'Leary (jmoleary) wrote :

I have found 802.11n from a bt home hub works fine with my eeepc (1001ha). If you are having problems then I suggest trying one of the mainline kernels (http://kernel.ubuntu.com/~kernel-ppa/mainline/), as they have much improved ralink wireless drivers.

The solution from comment #103 worked for me too on my HP dv6-3196sf, on Ubuntu 10.10. It is connected with a 802.11 b/g/n router.

giddyup (dninuk) wrote :

Got every thing working, except 802.11n. Anyone have any ideas?

DanielRoesler (diafygi) wrote :

@Joshua O'Leary, I added the kernal-ppa to my repository list and installed:
linux-backports-modules-compat-wireless-2.6.37-maverick-generic

However, the driver for the wireless card is still rt2860, and I am still unable to connect to a wireless 802.11n network. Do you know which specific package to install?

@Daniel

I think you were misled by the "ppa" in the link Joshua gave you. This is not like the standard ppa's on launchpad. Don't add it to your list.

Download the one or three debs that you need by hand and install them by hand.
http://kernel.ubuntu.com/~kernel-ppa/mainline/daily/current/
Details: https://wiki.ubuntu.com/Kernel/MainlineBuilds

The current mainline you get that way has wireless drivers about 3 month younger than backports 2.6.37.

Lionel BASTET (lionel-bastet) wrote :

On a Compaq Mini CQ10-410SF (Atom N450) using RT3090 hardware:
After upgrade to 2.6.32-28 generic, WIFI link does not work anymore.

On a terminal output of "uname -rvm" is:
2.6.32-28-generic #55-Ubuntu SMP Mon Jan 10 21:21:01 UTC 2011 i686

and output of "lspci -knn | grep Network --after context 3" is:
02:00.0 Network controller [0280]: Ralink RT3090 Wireless 802.11n 1T/1R PCIe [1814:3090]
    Kernel modules: rt3090sta

Had no time yet to test all the workarounds since the beginning of this thread.
I just mention that the "simple" workaround I used and mentioned earlier her in comment #72 does not work anymore.
I am in the feeling that going to Ubuntu 10.10 as suggested by some people is NOT the solution, or else, what is then a "long term support version" as the 10.04 is supposed to be?

If any other information is needed, please tell.

There is indeed no need to upgrade to Ubuntu 10.10 just for WLAN drivers. All newer drivers are also available to Ubuntu 10.04.

As mentioned in comment 109 there are linux-backports-modules-wireless packages. The 2.6.35 backports package will give you the wireless drivers that come with the 2.6.35 kernel, which is the kernel that Ubuntu 10.10 shipped with. Those backports packages become available some time after the corresponding kernels become stable. I don't know whether backports of 2.6.37 are out yet. Try the newest one available.

If the newest wireless backports package does not work for you then you can try the Natty backport kernel, currently from 2011-01-27. That will give you a pretty current development (2.6.38) kernel.

Let us know how it goes.

Andy Whitcroft (apw) wrote :

Looking to the future I would like to get some testing on the Natty alphas for this wireless card to ensure we at least have support there nativly. Could someone with this card test the latest Natty LiveCD and see if wireless works for you. Please report any testing here.

Also as suggested by Wolfgang we are also offering wireless backports to Lucid. Could we confirm whether installing linux-backports-modules-wireless-2.6.35, -2.6.36, or -2.6.37 fix things for this card on Lucid. Again please report any testing back here.

Andy Whitcroft (apw) on 2011-02-11
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
MMlosh (mmlosh) wrote :

Well.. not the thing you wanted.. but:

I am using 2.6.37-trunk kernel (packaged in debian experimental)
3090STA module is not present, I was forced to use rt2800

wifi connection is slow, even with 50% signal quality stuck to 1M or 2M (802.11b AP)
disonnecting the wifi by the rfkill key breaks the module and it won't connect anymore.

Davide Ferrero (davideferre) wrote :

I've installed rt3090 package on my hp probook 4520s with Ubuntu 10.04.1 (32bit) and the wifi card works correctly. After a dist-upgrade (to 2.6.32-28-generic-pae) it stops working, so I've tried to completely remove the package and re-install it. After the reboot it returns working.

Joshua O'Leary (jmoleary) wrote :

@MMlosh: rt3090sta is not present because in the newer kernels rt2860sta is used instead, as it provides rt3090 and rt2860 chipset support in one driver, as mentioned here:
http://wiki.debian.org/rt2860sta
Try using rt2860sta instead.

Joshua O'Leary (jmoleary) wrote :

@Andy Whitcroft: I have tested the 2.6.37 kernels, in which the rt2800pci driver is loaded for the rt3090 card by default. The rt2800pci driver works ok, but is still very buggy, as there are a number of issues with it, including a system hang on shutdown,

Joshua O'Leary (jmoleary) wrote :

@DanielRoesler: It is better to stay with the rt2860sta driver on the newer kernels for now, as rt2800pci is rather glitchy. What I meant was it works fine on rt2860sta, with the newer kernels.

MMlosh (mmlosh) wrote :

@Joshua O'Leary
Is it possible to get that module for a .37 kernel without compiling?
The debian experimental package does not have the module

Linuxexperte (andrea-koeth) wrote :

Hi Joshua,

are you sure, that your kernel does not have this module?

What does this terminal-command say: lsmod | grep rt

And then I wanted to add a question:
how will things be in the new ubuntu-natty-version?? Will the rt3090-driver be available there or do I have to use blacklisting again as I have it right at the time?? Because the rt2860sta-driver works fine after unloading the both other drivers from the kernel and blacklisting them.

Greetings
Linuxexperte

MMlosh (mmlosh) wrote :

@Linuxexperte
was that message ment for me?

for the sake of completeness: the lsmod command only lists *currently loaded* modules.
In my case it lists rt2800pci and its friends.. and the wifi is limited to 2M speed and rfkill button breaks it.

both rt2800sta and rt3900sta modules are not present
If you read what I posted earlier: the kernel is from debian experimental repository (.37-trunk)

You may need to blacklist once more if this does not get fixed PROPERLY (not by using the single-purpose and unmaintainable module)

giddyup (dninuk) wrote :

If you post saying that you have managed to get your rt3090 to work, can you please state if that is with 802.11b/g or 802.11n. A lot of people are having problems getting n to work.

Nigel Pallett (nigelp) wrote :

I Have the RT3090 in my laptop working reliably using the rt2860sta driver module in 802.11g mode with WPA2 security and controlled by NetWorkManager under Ubuntu 10.10 64 Bit with the "2.6.35-27-generic" kernel. I had to blacklist the rt2800pci module.

FWIW - In my experience with a variety of WiFi cards and routers/access points, if the router/ap is configured for multiple wireless modes e.g 802.11b and 802.11g and 802.11n and multiple security protocols e.g WEP and WPA and WPA2, then wireless connections from many linux drivers can be less reliable. On a number of occasions, I have solved such problems by configuring the router/ap to use a single network mode (802.11g) and a single security mode WPA2.

Additionally, unless you need to roam between multiple access points which have the same name (e.g. university campus), connection stability can be further improved by adding the access point's MAC address to the BSSID field in your linux client configuration for that access point.

I've also encountered situations where linux wireless drivers will not connect to access points on channels 12 and 13.

Linuxexperte (andrea-koeth) wrote :

No MMlosh,
as I stated at the beginning of my posting, this comment was meant for Joshua.

Then it seems, that one can only get this rt3090 wifi-card running, if the other drivers are unloaded from the Kernel and blacklisted. I di so for my Notebook and since then, the rt2860sta-driver works fine for me. The rt2800pci-driver does not work properly.

@ MMlosh: if you do not have this driver present in your kernel, then try the following command in your terminal:

sudo modprobe rt2860sta

Does this work?? And is this driver loaded into the Kernel-modules then? If so, then unload your current driver by this command:

sudo modprobe -rf rt2800pci

Then unload the other present drivers by this command:

sudo modprobe -rf <driver-name>

Then blacklist thert2800pci-driver by this command:

echo blacklist rt2800pci | sudo tee -a /etc/modprobe.d/blacklist.conf

and do so for the other present drivers (except the rt2860sta!!) too.

Then restart your network-manager by this command:

sudo service network-manager restart.

Then reboot your machine and then go to network-settings and set your network-connection. After having done that, go back to your panel and click on the network-manager icon. Then you will be prompted to put in your netowork-key and then connection should be established.

@ giddyup: it seems that my network is an 802.11b/g. But where can I find that out?? Can I see that anywhere on my router??

Then if you need an instruction, how to get it work, then follow my Tutorial, which can be found here:

http://www.linuxmint-forum.de/rt3090-wlan-chip-in-linuxmint-ubuntu-ubuntu-derivaten-knoppix-und-parsix-zum-laufen-bringen-tutorials-howtos/allgemeines-f5/t1671-f11/

But I would be happy, if the driver, which is also used in the OpenSuse-version would be ported to ubuntu. In the current OpenSuse-version, this card runs out-of-the-box because the rt3090-driver is already in the kernel and there this problem does not occure. But I personally prefer LinuxMint (which I use since some time already).

Greetings
Linuxexperte

MMlosh (mmlosh) wrote :

@Linuxexperte

the module is NOT SHIPPED WITH THE KERNEL
there is NO file like rt<anything>sta.ko, modinfo confirms that the module does NOT EXIST.

I was asking whether you know where can one get a kernel package that has this module... nothing else.

Andy Whitcroft (apw) wrote :

@MMlosh -- there seem to be rt*sta.ko modules in Lucid and Maverick kernels, and I am pretty sure Natty too (here are some I
have in old kernels on my disk):

  /lib/modules/2.6.32-11-generic/kernel/drivers/staging/rt2860/rt2860sta.ko
  /lib/modules/2.6.32-11-generic/kernel/drivers/staging/rt3090/rt3090sta.ko

  /lib/modules/2.6.35-22-generic/kernel/drivers/staging/rt2860/rt2860sta.ko
  /lib/modules/2.6.35-22-generic/kernel/drivers/staging/rt2870/rt2870sta.ko

Linuxexperte (andrea-koeth) wrote :

@ Andy Whitcroft nd @ MMlosh:

yes that's right. I even did not have this second driver in my kernel. Here in LinuxMint 10 (based on maverick) I only had these drivers:
rt2870, rt2860/3090sta and rt2800pci. These three drivers were all loaded and this blocked the wifi from working in my case. The reason was, that all three drivers wanted to take over the card. So I had to do what I said in my instruction. In LinuxMint 10 the kernel is the 2.6.35-25-generic. In this kernel, the driver is named rt2860/3090sta.
If you do not unload them from the kernel, they are included. You only need to unload rt2800pci and rt2870 and to blacklist them.

@ MMlosh:

can it be possible, that you have unloaded the rt2860sta-driver from your kernel and that you have blacklisted it?? Then it is clear, that your WLAN does not work properly. The rt2860sta-driver is the best one included in the kernel.

If this is the case (that means if you did the above mentioned thing), then we need to get it out of the blacklist.conf and then follow my posted link to the instruction to get your card run properly.

Greetings
Karmicbastler

Joshua O'Leary (jmoleary) wrote :

@Linuxexperte: The newer kernels which natty use still default to using the rt2800pci driver, which means you still have to do the blacklisting. My kernel still has the rt2800pci module, I just prefer to use rt2860 because its more stable like mentioned earlier.

Also are any of you experiencing freezing/crashing on your ubuntu netbooks at startup? Mine still has occasional freezes when it boots up. Maybe its a hardware fault.

Joshua O'Leary (jmoleary) wrote :

The freezing issues must be related to wifi as when it crashes the word rt2860 is sometimes shown on the screen, along with other debugging info. It seems like a kernel panic.

Linuxexperte (andrea-koeth) wrote :

@ Joshua O'Leary,

I do not use the rt2800pci-driver. I use the rt2860/3090sta-driver. I have blacklisted the rt2800pci and the rt2870. Then I restarted my network-manager as mentioned above and then rebooted my system.

Then I had to go to the menu in network-connections and enter my wifi-connection. My wifi works pretty fine with full speed. Even I do not recognise any desktop-freezes with the rt2860/3090sta-driver in my system when I reboot. These freezes must have another cause. Here LinuxMint 10 runs so smooth, that I admit, that I am just downloading four episodes of the original series of Raumschiff Enterprise in the new digital remastered version!!! Yes, download runs pretty fast and without crashes here in Firefox Namoroka. For the Seamonkey-suit, it is the same!! So this evening, I will have a pretty nice TV-evening on my machine, because my people here are out this evening!! What do I need to use the TV for if I have my Notebook with LinuxMint 10??? My answer is: I do not need it!!

Greetings from the far universe,
Linuxexperte

Joshua O'Leary (jmoleary) wrote :

Thanks Linuxexperte. The problems I'm experiencing must be eee-pc (model 1001ha) hardware specific then.

Linuxexperte (andrea-koeth) wrote :

hi Joshua O'Leary,
you wrote, that you receive desktop-freezes with your eee-pc. One possible (but not the only one) could - perhaps - be a not properly woring driver for your graphiccard. But there are also other possiblities. But this one should be checked first. It could be that it is not hardware-specific, but I driver-specific problem.

For this, better open-up a new thread and there you should post the details of your pc and about your graphiccard. Perhaps the reason can be found there.

But also the error-message displayed on your screen can be helpful to give more detailed diagnose to your problem. Could you copy & past the error-message here on your comment or enclose it to your comment? Therefore, you can copy the error-message to a gedit-document and enclose this document.

Greetings
Linuxexperte

Joshua O'Leary (jmoleary) wrote :

Thanks Linuxexperte, I have spoken to another linux user with the same netbook as me (eee pc 1001ha), and they said it worked perfectly without any freezing issues. The error I'm getting isn't possible to copy and paste - its a long list of messages from a terminal screen, sometimes I don't even get that but just a blank screen. It doesn't seem to be logged either. I would have to take a picture of the screen, but even then I wouldn't get all of the error as it scrolls down past the screen. With all this it does therefore seem like a hardware fault. I'll start another discussion thread somewhere else.

Joshua O'Leary (jmoleary) wrote :

I had posted a thread a while ago about it. There are some screenshots there aswell.
http://ubuntuforums.org/showthread.php?t=1520505

Linuxexperte (andrea-koeth) wrote :

hi Joshua O'Leary,

I looked at this mentioned Thread there and I saw, that you have Intel-technologies. So I can tell you, that a defect of the graphiccard-driver is really not the cause for your freezing-issues. Why? Because I have a similar Intel-graphiccard in my stationary machine. But this stationary machine does not have an onboard-WLAN-Chip.

But for your machine, I can give you a good tipp, if your onboard-WLAN does not work as it shoud, although I think, that your freezing-issues do not come from the rt2860/3090sta-driver. This driver is included in all current kernels, if it is not unloaded.

As I do not have an onboard-WLAN-chip in my stationary machine, I bought this WLAN-Stick for me:

US54EX-WLAN-Stick (usb-WLAN-Stick).
Costs are at 19 €. Quite cheap as you see (this stick works for me since nearly four years now without any incidence).

This WLAN-Stick has a rt2500-WLAN-chip, which works out of the box. Just enter your WLAN-connection in the menu->network-connections and thten go back to the panel to the network-manager icon and klick on it. Then it should see your network and then you are prompted to put in your network-connection-key and then klick on "connect".

But I will try to make a membership with ubuntuforums to look at your screenshots.

Or could you enclose them also here in Launchpad in another Thread?

Greetings
Linuxexperte

Joshua O'Leary (jmoleary) wrote :

Hi Linuxexperte,
Here is the screenshot (this was the best one I could find).
Note: they were before I upgraded to Maverick (Lucid). However, the error is still the same.

Linuxexperte (andrea-koeth) wrote :

hi Joshua O 'Leary,

I have checked your screenshot. There is a bug mentioned in context with plymouth. This happens quite often! The best thing is, to deactivate plymouth.

What you can try: deactivate plymouth and try to reboot. Does this panic happen again??

Please give notice.

Greetings
Linuxexperte

Joshua O'Leary (jmoleary) wrote :

It doesn't really seem possible to disable plymouth. If you try and remove it in synaptic, you would end up removing nearly the whole system due to its dependencies on other things. I've found you can disable the plymouth splash, by removing 'quiet splash' from the grub command line, however the plymouth process still runs as part of the bootup: http://www.linuxquestions.org/questions/linux-mint-84/how-to-disable-plymouth-in-mint-ubuntu-827422/
However I have tried debian on my laptop before, which doesn't use plymouth by default, and the freezing still occurs.

@Andy Whitcroft -- We have identified a fix for the rt3090 freeze on unload bug 662288. It is the single commit 7f6e144fb99a4a already in linux-next - it's the first rt2x00 commit that didn't make it into mainline this time :-\ . This looks like it should be cherry-picked for natty. See bug 662288 for details.

Thanks

 affects ubuntu/linux
 status confirmed

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Lucas G (ljbaumer) wrote :

Hey,

I have this same problem on my hp touchsmart 310 pc....

I am a little lazy and I don't really want to read through all of the comments and posts... is there a simple fix for this problem on ubuntu 10.10?

hrvooje (hrvooje-gmail) wrote :

try solution in comment #103 . It worked for me on hp 4520s on maverick

Eugene Crosser (crosser) wrote :

On both maverick and natty alpha3, 64bit, both rt2800pci and rt2860sta modules get loaded and nothing works. Unloading them and then reloading only rt2860sta (or blacklisting) works on both systems. (Except Bluetooth that uses the same hardware does not work, but that's a matter for a separate bug report.)

Also affected on a hp Pavilion dv5-2133la. Tried to compile drivers from source, network card is recognized, but can´t connect. Tried with wpa, wep and no security at all, and it never connects. My ubuntu is 10.10 32 bits.

Joshua O'Leary (jmoleary) wrote :

If you are using ubuntu 10.10 then you can just use the rt2860sta driver that comes with the ubuntu kernel. Just add the following to the end of /etc/modprobe.d/blacklist.conf:

blacklist rt2800pci
blacklist rt3090sta

That should prevent the other drivers from loading so that only the working driver loads. This should then let you connect.

Hi Joshua. i've just make what you said. Now the wireless manager doesn't show any network.

Joshua O'Leary (jmoleary) wrote :

Try sudo modprobe rt2860sta. If that doesn't work, remove 'blacklist rt3090sta' from /etc/modprobe.d/blacklist.conf and install the dkms driver instead (download and install the lucid one):https://launchpad.net/~markus-tisoft/+archive/rt3090

None of those options worked. I still can't see any network.

After several minutes network manager started to show some routers, All routers are detected with almost 0 level signal, and my home router is not detected at all.

Joshua O'Leary (jmoleary) wrote :

Go to System>Preferences>Network Connections>Wireless>Add. Enter your network details, and tick the box that says 'Auto Connect'. Also, the driver works better if your computer logs into your user account from bootup (i.e no login screen, just loading straight into ubuntu - you can change this by going into System>Administration>Login Screen>Unlock and set it to 'Login As (your username) automatically. Untick 'allow..seconds for everyone else to login first'. Then reboot and see if the network connects from bootup.

Tim Gardner (timg-tpi) wrote :

There are -backports packages for both Lucid and Maverick. For example:

apt-cache search linux-backports-modules-wireless
sudo apt-get install linux-backports-modules-wireless-2.6.38-lucid-generic

You'll likely have to enable -backports and -proposed before the 2.6.38 packages show up.

Changed in linux (Ubuntu Natty):
status: Confirmed → Fix Released
Changed in baltix:
status: New → Invalid
Florian Heyer (heyho-flanto) wrote :

I have a Lenovo IdeaPad S205 with RaLink RT3090 wireless interface.

With Ubuntu 11.04 "Natty Narwal" wifi doesn't work after install. The modules rt2860sta and rt2800pci are conflicting. Manually blacklisting one module and using the other one didn't work either.

However after upgrading to ubuntu mainline kernel v2.3.39-rc3 wifi works using module rt2800pci which contains significant updates by the manufacturer in 2.3.39.

There is a problem left in combination with module ideapad_laptop which processes acpi events to activate/deactivate wifi. However a workaround for this problem exists.

Florian Heyer (heyho-flanto) wrote :

ups, i obviously meant kernel v2.6.39 above...sorry.

Karl Wilde (geidorei) wrote :

Stupid question but why is the status 'Fix released'? This isnt fixed! Albiet there is a .deb it doesnt work for most people.

hrvooje (hrvooje-gmail) wrote :

I have Ralink rt3090 wifi chip on my hp 4520s. On openSUSE 11.4 it uses module rt2860 and it works out of box. Maybe this info could help Ubuntu developers

It is semi-broken in [64 bit] 11.04:
1) connection to WPA2 is highly unstable and often is lost with no reason;
2) connection with WEP works fine;
3) connection is *always* lost when switching from AC to battery.

On [64 bit] 10.10 it works fine using Markus Heberling PPA.

I have this chip on MSI U210.

Frenzel (f-heinen-nl) wrote :

I seem to have exactly the same problems as Andriy. Please help how to fix this.

@Andriy, @Frenzel, @Karl

please open separate bug reports for remaining problems with this driver (rt2800pci) with (in a terminal):
ubuntu-bug linux

Subscribe me to your reports and make a comment that you have done so (so that I get a mail about this).

Thanks

MMlosh (mmlosh) wrote :

The "Fixed" Natty is complete gibberish and broken. ( 2.6.38-11-generic #50-ubuntu)
RFkill ability has been added to rt3090pci and hp_wmi.. result - the wifi is hard-blocked and cannot be unblocked
removing rt2800pci and loading rt2860sta no longer fixes the issues.. the wifi is RFkilled.

Maybe it deserves a separate ticket.. filled here: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/877949

NA (napperley) wrote :

Why is the driver not included in the kernel (Ubuntu version)? Also why is the fix blocked from being included in Ubuntu Lucid and Maverik, yet it is included in Natty?

Linuxexperte (andrea-koeth) wrote :

hi NA (napperley),

yep, this fix is included in Natty as well as in Oneiric. For me, this WLAn-Chip work out of the box again in LinuxMint 12 (based on oneiric and it also did in LinuxMint 11. So I am happy, that this has been solved there. It would really be good, if this fix would be backported to maverick and Lucid.

But I would also recommend, that users, who are affected by this upgrade to Natty or even to Oneiric.

Since I used LinuxMint 11 (codenamed Katya) and now LinuxMint 12 (codenamed Lisa; based on Oneiric), this WLAN-Chip has come back to live for me.

Greetings
Linuxexperte

Linuxexperte (andrea-koeth) wrote :

What I wanted to say is:

there are thousands of Users affected, who still use Lucid or even Maverick. So I would really badly recommend to the developers, that they backport this fix, so that this WLAN-Chip comes back to work there. This is really a high regression-potential!!! Please be fair, developers!!! This is no deal, to leave these users with a broken WLAN.

But as development goes on, I would recommend to the affected users, that they switch over to LinuxMint 11 or even to LinuxMint 12. There you do not notice this bug anymore. This is the only way out of this.

Greetings
Linuxexperte

MMlosh (mmlosh) wrote :

Not as easy for me in Oneiric as for you, Linuxexperte.

I had to disable "lan/wlan toggling" in my BIOS/uEFI (which looks like removing rfkill ability)
to get the wifi working.

And the computer completely froze when I tried to disconnect from radius-managed wifi. (Tried once, failed once)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.