Ralink RT3090 cannot be un-RFkilled on HP notebook

Bug #877949 reported by MMlosh on 2011-10-19
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Can't get my RT3090 wifi out of RFKilled state
using kernel 2.6.38-11-generic #50-Ubuntu, rfkill ability was added to rt2800pci and hp_wmi.

hp_wmi's rfkill controls change their hard-block status as the rfkill button is pressed.

but rt2800pci controls say "unblocked" until I try to set wlan0's link up. Then it figures out it has no response and marks itself Hard-RFkilled. It completely ignores what hp-wmi says.

This bug may be resolved in Oneiric, I would test that sooner, but everybody around said "Don't, graphics is borked"

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 877949

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: natty
MMlosh (mmlosh) wrote :

Ah.. I forgot.. my bad

I don't really want to upload my sound and video configuration, so I uploaded the relevant info manually.
current dmesg, syslog, lspci (will be) attached
These logs are from clean boot, the only thing being done is "sudo ip link set wlan0 up" after logging in

note: I erased PAM-related lines from the syslog

MMlosh (mmlosh) wrote :
MMlosh (mmlosh) wrote :
Changed in linux (Ubuntu):
status: Incomplete → Confirmed

MMlosh, thank you for reporting this and helping make Ubuntu better. Natty reached EOL on October 2012.
Please see this document for currently supported Ubuntu releases:
https://wiki.ubuntu.com/Releases

We were wondering if this is still an issue in a supported release? If so, could you please test for this with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the kernel in the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested and remove the tag:
needs-upstream-testing

This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the text:
needs-upstream-testing

If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested.

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested.

If you are unable to test the mainline kernel, please comment as to why specifically you were unable to test it and add the following tags:
kernel-unable-to-test-upstream
kernel-unable-to-test-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested.

Please let us know your results. Thank you for your understanding.

Helpful Bug Reporting Tips:
https://help.ubuntu.com/community/ReportingBugs

tags: added: needs-kernel-logs needs-upstream-testing
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
MMlosh (mmlosh) wrote :

Oh, this bug is so old.. Totally forgot about it.
I am not even sure whether it worked back in Oneiric or not!

But I am sure it worked without glitches in Precise and so it does in Quantal.

I have no idea whether such bugs should be marked "Fixed" or "Invalid".
Whoever comes by and knows, please....

Changed in linux (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers