Comment 16 for bug 541620

On Fri, 16 Apr 2010 20:33:28 -0000
Markus Heberling <email address hidden> wrote:

> Hmm. The karmic driver works for me in lucid. I had to completely
> remove the package and install it again though. Otherwise I got an
> obscure error message.
>
> markus@ubuntu-media-server:~$ uname -a
> Linux ubuntu-media-server 2.6.32-21-generic #31-Ubuntu SMP Tue Apr 13
> 20:34:00 UTC 2010 i686 GNU/Linux
>
> markus@ubuntu-media-server:~$ ifconfig ra0
> ra0 Link encap:Ethernet Hardware Adresse 00:0d:f0:6d:47:0c
> inet Adresse:192.168.178.29 Bcast:192.168.178.255
> Maske:255.255.255.0 inet6-Adresse: XXXXXX/64
> Gültigkeitsbereich:Verbindung UP BROADCAST RUNNING MULTICAST
> MTU:1500 Metrik:1 RX packets:2211 errors:97 dropped:0 overruns:0
> frame:0 TX packets:243 errors:0 dropped:0 overruns:0 carrier:0
> Kollisionen:0 Sendewarteschlangenlänge:1000
> RX bytes:293955 (293.9 KB) TX bytes:45263 (45.2 KB)
> Interrupt:17
>
> markus@ubuntu-media-server:~$ iwlist ra0 scanning
> ra0 Scan completed :
> Cell 01 - Address: XXXXXXX
> Protocol:802.11b/g
> ESSID:"XXXXX"
> Mode:Managed
> Frequency:2.432 GHz (Channel 5)
> Quality:100/100 Signal level:-25 dBm Noise
> level:-92 dBm Encryption key:on
> Bit Rates:54 Mb/s
> IE: WPA Version 1
> Group Cipher : TKIP
> Pairwise Ciphers (1) : TKIP
> Authentication Suites (1) : PSK
> IE: IEEE 802.11i/WPA2 Version 1
> Group Cipher : TKIP
> Pairwise Ciphers (1) : CCMP
> Authentication Suites (1) : PSK
>
> markus@ubuntu-media-server:~$ modinfo rt3090sta
> filename: /lib/modules/2.6.32-21-generic/updates/dkms/rt3090sta.ko
> version: 2.3.1.3
> srcversion: FFE8374362ED5B734E14328
> alias: pci:v00001814d00003092sv*sd*bc*sc*i*
> alias: pci:v00001814d00003091sv*sd*bc*sc*i*
> alias: pci:v00001814d00003090sv*sd*bc*sc*i*
> depends:
> vermagic: 2.6.32-21-generic SMP mod_unload modversions 586
> parm: mac:rt28xx: wireless mac addr (charp)
>
I installed your driver from the ppa and still haven't been able to get
things going. I tried all of your commands and the only one that works
is the last with the same output.

The iwlist ra0 scanning tells me that the interface does not support
scanning.

ifconfig ra0 gives me "device not found"

I'm going to reinstall and see if that makes any difference

Shelagh

--

----------------------------------------------------------------
Jabber: <email address hidden>
Wave: <email address hidden>

There's a thin line between fishing and standing on the shore
looking foolish.
----------------------------------------------------------------