Ubuntu

fglrx-updates broken dependency with xorg-video-abi-12 (Quantal)

Reported by Angel Guzman Maeso on 2012-08-03
384
This bug affects 76 people
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Critical
Unassigned
fglrx-installer-updates (Ubuntu)
Critical
Alberto Milone

Bug Description

fglrx needs updated in quantal for the xserver 1.13 API.

[Workaround]
Use the FOSS -ati driver.

[Original Report]
I run updates today on my quantal box.

I have a ATI Madison [Radeon HD 5000M Series] and the updates removes the xserver-xorg-video-radeon and xserver-xorg-video-ati

When I restart, all xserver is broken because /usr/bin/X cannot be found. I even don't have vesa or fbdev for start with "startx" command.

I install with recovery mode xserver-xorg-video-vesa and xserver-xorg-video-fbdev and now I have a crappy 1024 resolution and no second monitor support.

If I install the packages xserver-xorg-video-radeon and xserver-xorg-video-ati I still have the same problem.

So I try to install fglrx-updates, and it conflicts with a dependency of a virtual package that it is not provided anymore

sudo apt-get install fglrx-updates fglrx-amdcccle-updates
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 fglrx-updates : Depends: xorg-video-abi-12
E: Unable to correct problems, you have held broken packages.

 sudo apt-get install xorg-video-abi-12
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package xorg-video-abi-12 is a virtual package provided by:
  xserver-xorg-core 2:1.12.1.902-1ubuntu1 [Not candidate version]

E: Package 'xorg-video-abi-12' has no installation candidate

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: fglrx-updates (not installed)
ProcVersionSignature: Ubuntu 3.5.0-7.7-generic 3.5.0
Uname: Linux 3.5.0-7-generic i686
ApportVersion: 2.4-0ubuntu6
Architecture: i386
Date: Fri Aug 3 16:54:41 2012
InstallationMedia:

ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: fglrx-installer-updates
UpgradeStatus: Upgraded to quantal on 2012-06-05 (59 days ago)

Angel Guzman Maeso (shakaran) wrote :
Angel Guzman Maeso (shakaran) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in fglrx-installer-updates (Ubuntu):
status: New → Confirmed
Shanekpiper (shanekpiper) wrote :

This affects me to but I have NVIDIA Drivers

E: Package 'xorg-video-abi-12' has no installation candidate

I tried to reinstall nvidia-current but the above package depends on it.

Personally I think this is all to do with updating the Alpha 3 release to Beta 1. I would suggest holding out for a little longer for the devs to sort this, they must have something up their sleve.

Affects me too.
From what I have noticed, pakcage `xserver-xorg-core` provides `xorg-video-abi-13`, while driver packages require 'xorg-video-abi-12'. Maybe this is a simple dependency mismatch that can be easily fixed?

Changed in fglrx-installer-updates (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
bash321 (bash321) on 2012-08-08
summary:
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in fglrx-installer (Ubuntu):
status: New → Confirmed
Ralph Wabel (rwabel) wrote :

Same here, hope that dependency can be fixed soon

This happens with nvidia drivers too. Try install nvidia-current at quantal.
The solution here is purge all nvidia packages and install from binary.

Cavsfan (cavsfan) wrote :

I have the same exact problem. I installed Quantal Alpha 3 and cannot install any nvidia driver.
I get this when trying to sudo apt-get install nvidia-current-updates:
The following packages have unmet dependencies:
 nvidia-current-updates : Depends: xorg-video-abi-11 but it is not installable or
                                   xorg-video-abi-12 but it is not installable

Lockal (lockal) wrote :

Actually there is much bigger problem problem with nvidia driver, see bug 1037896. Even the latest stable nvidia drivers (304.37) will break unity, gnome shell, firefox or any other glx application and crash xserver.

Bryce Harrington (bryce) wrote :

The move to xserver 1.13 is what brought the new API version. We'll have to wait until AMD provides a 1.13 compliant driver, which typically occurs late in the cycle but some time before final freeze.

summary: - fglrx-updates broken dependency with xorg-video-abi-12
+ fglrx-updates broken dependency with xorg-video-abi-12 (Quantal)
description: updated
Changed in fglrx-installer-updates (Ubuntu):
importance: Undecided → Critical
Changed in fglrx-installer (Ubuntu):
importance: Undecided → Critical
novak (hedgeslam) wrote :

Same problem here, but with Nvidia GT230M.

xorg-video-abi-12 dependencies can't be met.

nvidia-current : Afhængigheder: xorg-video-abi-11 men den kan ikke installeres eller
                                  xorg-video-abi-12 men den kan ikke installeres

So it's up to Nvidia to fix this with an update that supports xserver 1.13?

Rocko (rockorequin) on 2012-08-25
Changed in nvidia-drivers-ubuntu:
status: New → Confirmed
Rocko (rockorequin) wrote :

For the nvidia-graphics-drivers package, commenting out this VIDEODEP line in debian/rules fixes the problem:

# Comment out the following line to re-enable automatic ABI detection
VIDEODEP = xorg-video-abi-11|xorg-video-abi-12|xorg-video-abi-13, xserver-xorg-core (>= 2:1.11.99.901)

Rocko (rockorequin) wrote :

I have reported this issue for nvidia-graphics-drivers in bug #1041652, since this bug is about fglrx.

Hanmac (hanmac) wrote :

there are two new versions of amd-driver: 970 and 982
but both do errors on "Building initial module for 3.5.0-13-generic"
>> error: implicit declaration of function ‘do_mmap’

i think both are still not ready for linux, or i am wrong?

I'm trying to install display driver for my Advanced Micro Devices [AMD] nee ATI RS880 [Radeon HD 4250] [1002:9715] card in Ubuntu Quantal and I was un-successful and getting this:

The following packages have unmet dependencies:
 fglrx : Depends: xorg-video-abi-12 but it is not installable
E: Unable to correct problems, you have held broken packages.

consolation (midden-heap) wrote :

fglrx-updates: Depends: xorg-video-abi-12 but it is not installable

Synaptic asks to fix broken packages.

Ivan (ivanp) wrote :

Got the same problem with my Radeon HD 6620G. The -ati driver is very slow for Unity.

My temporary workaround:
- Downgrade xserver-xorg-core to precise (1.11), and then
- download Catalyst 12.8 from http://support.amd.com/us/gpudownload/linux/Pages/radeon_linux.aspx and create build for quantal

consolation (midden-heap) wrote :

Would installing xorg-video-abi-12 concurrently with xorg-video-abi-13 cause problems? Is there any progress with fixing the bug? {OT: The FOSS drivers make Unity painfully slow and cause the laptop fan to run 100% all the time. Radeon 5650M. (Yep, I did set the clocks to dynamic; the fan speed is still is stuck at full.)}

lunarok (lunarok) wrote :

Is there any news ?
I'm affected too, using FOSS driver will not be better, I use the proprietary driver to get the HDMI sound transportation.

madbiologist (me-again) wrote :

@consolation - Radeon dynpm (dynamic) power mangement is not working on some cards. Try profile-based power management instead and use the mid or low profile. See http://www.x.org/wiki/radeonBuildHowTo#radeon-KMS_power-management

@lunarok - if you have a Radeon HD 6000 series card or earlier you can enable HDMI audio by adding "radeon.audio=1" to your GRUB boot options. (HDMI audio on ATI Radeon cards/chips was disabled by default by the upstream kernel developers as it causes blank screens on a lot of systems).

In addition to this, support for Radeon HD 6000 series HDMI audio (other than the HD 6900 series) was only added in the upstream 3.5 kernel. The kernel in Quantal is based on the 3.5 kernel, and possibly will end up based on the 3.6 kernel.

I hope AMD release an fglrx update that is compatible with the new ABI soon.

lunarok (lunarok) wrote :

@madbiologist (s-j-turner) : thanks a lot for this information, I was not aware hdmi output is possible in 3.5 with FOSS driver. So for me, that's a complete solving way. No need closed driver anymore, everything is working fine.

consolation (midden-heap) wrote :

@madbiologist tried profile based management; the results were unfortunately even worse. After fluffing around with dynpm I got fan speed down to ~80% which is annoying by usable - profiles get it stuck back at 100%, it starts low but just keeps climbing and doesn't seem to be able to drop back down. I think the problem is that being a crappy laptop the single fan is responsible for the thermal control of the whole system and it all gets bit tangled up. Thanks for the hint though. Also, thanks for the "radeon.audio=1" tip, that's made movie night hell of a lot less annoying. ;-)

Ugh, wish someone would squash this bug...

Angel Guzman Maeso (shakaran) wrote :

Using FOSS ati driver (uninstalling fglrx) also produce crash. I try running:

sudo apt-get purge xorg-driver-fglrx fglrx-*
sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri
sudo dpkg-reconfigure xserver-xorg
sudo apt-get install --reinstall xserver-xorg-core

Then you get a crash running glxinfo.

See: https://bugs.launchpad.net/ubuntu/+source/mesa-demos/+bug/1055236

Related: https://bugs.launchpad.net/ubuntu/+source/nux/+bug/958212

Please, after two months reported, I think that this bug must be taken more seriously for fix the critical bug before to quantal be released.

deuce (azinas) wrote :

It's almost release time for Quantal and still overheating my laptop and shutting down because of this bug. Just like https://launchpad.net/~shakaran said, it is high time this is taken more seriously.

Jaromir Obr (jaromir-obr) wrote :

In reply to deuce:
I agree.
I tried using the OSS driver "radeon" in Unity, but compiz takes 100% of CPU when using it.
So I was forced to start using Xubuntu which is uncomfortable for me.

There's nothing that can be done until AMD release a driver that is compatible with xserver 1.13. Until then we have to either:

1) Live with the open-source driver
2) Downgrade to xserver 1.11 from precise or 1.12 from Launchpad's quantal builds
3) Find a patch that provides 1.13 compatibility.

I'm happily running xserver 1.12 with the Catalyst 12.9 embedded beta driver (fglrx 9.00). While 9.00 doesn't have 1.13 support it does have kernel 3.6 support. ;)

madbiologist (me-again) wrote :

@Jaromir - compiz using 100% of CPU sounds like your system is falling back to software rendering. That would be a separate bug but lets do a quick check here. Please attach the output of glxinfo |grep render

madbiologist, please do not solicit Ubuntu Community members to submit attachments to this report, as this report is about "
fglrx-updates broken dependency with xorg-video-abi-12 (Quantal)".

Instead, we would want Jaromir Obr to file a new report by executing the following in a terminal:
ubuntu-bug compiz

For more on this, please see the Ubuntu Bug Control and Ubuntu Bug Squad article:
https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue

and Ubuntu Community article:
https://help.ubuntu.com/community/ReportingBugs#Bug_Reporting_Etiquette

Thank you for your understanding.

Helpful Bug Reporting Links:
https://help.ubuntu.com/community/ReportingBugs#A3._Make_sure_the_bug_hasn.27t_already_been_reported
https://help.ubuntu.com/community/ReportingBugs#Adding_Apport_Debug_Information_to_an_Existing_Launchpad_Bug
https://help.ubuntu.com/community/ReportingBugs#Adding_Additional_Attachments_to_an_Existing_Launchpad_Bug

Jaromir Obr (jaromir-obr) wrote :

madbiologist, Christopher:
Thank you for your help, the issue with compiz is tracked as bug #1046497

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fglrx-installer-updates - 2:9.000-0ubuntu1

---------------
fglrx-installer-updates (2:9.000-0ubuntu1) quantal; urgency=low

  * New upstream release (LP: #1032672).
  * debian/dkms.conf.in:
    - Do not apply any kernel patch
  * debian/rules:
    - Make it possible to set the xserver ABIs in debian/substvars.
  * Merge fixes from the upstream installer:
    - Fix openCL issues running x86 binaries on x86_64.
    - Make sure that dh_shlibdeps doesn't complain about missing qt
      libraries.
 -- Alberto Milone <email address hidden> Wed, 26 Sep 2012 16:49:27 +0200

Changed in fglrx-installer-updates (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fglrx-installer - 2:9.000-0ubuntu1

---------------
fglrx-installer (2:9.000-0ubuntu1) quantal; urgency=low

  * New upstream release (LP: #1032672).
  * debian/dkms.conf.in:
    - Do not apply any kernel patch.
  * debian/rules:
    - Make it possible to set the xserver ABIs in debian/substvars.
  * Merge fixes from the upstream installer:
    - Fix openCL issues running x86 binaries on x86_64.
    - Make sure that dh_shlibdeps doesn't complain about missing qt
      libraries.
 -- Alberto Milone <email address hidden> Wed, 26 Sep 2012 16:40:59 +0200

Changed in fglrx-installer (Ubuntu):
status: Confirmed → Fix Released

Loving it! 2:9.000-0ubuntu1 is working great for me with xserver-xorg-core 2:1.13.0-0ubuntu4. :)

Unfortunately, it doesn't work for me. The new driver does not identify my hardware.

# lspci|grep VGA
01:05.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RS780L [Radeon HD 3000]
# modprobe fglrx
FATAL: Error inserting fglrx (/lib/modules/3.5.0-15-generic/updates/dkms/fglrx.ko): No such device
# dmesg|tail -n3
[ 6785.693869] [fglrx] Maximum main memory to use for locked dma buffers: 7132 MBytes.
[ 6785.694089] [fglrx:firegl_init_device_list] *ERROR* No supported display adapters were found
[ 6785.694091] [fglrx:firegl_init_module] *ERROR* firegl_init_devices failed
# dpkg --list|grep fglrx
ii fglrx 2:9.000-0ubuntu1 amd64 Video driver for the AMD graphics accelerators
ii fglrx-amdcccle 2:9.000-0ubuntu1 amd64 Catalyst Control Center for the AMD graphics accelerators

@34 This is an issue with "legacy" (HD2000-4000) cards being unsupported by the latest Catalyst/fglrx releases. Those cards need the "legacy" release drivers which at the moment are based on Catalyst 12.6. Unfortunately these also don't support xserver 1.13.

I've filed a separate bug for this: https://bugs.launchpad.net/ubuntu/+source/fglrx-installer/+bug/1058040

Julien Olivier (julo) wrote :

The i386 package is still v2:8.982 while the amd64 package has been upgraded to v2:9.000. Is it normal or is there a problem with the i386 version?

madbiologist (me-again) wrote :

Julien - the page at https://launchpad.net/ubuntu/quantal/+package/fglrx confirms your comment. I'm pretty sure that is not normal. Can someone reopen this bug report until the issue is fixed on both architectures? (I don't have the privelages to do so).

Alberto Milone, thank you for working on this bug report.

As a Ubuntu Community volunteer who marked themselves affected by this bug for i386, it was noticed that the original reporter reported this against i386. However, most recently we have the following i386 failed to builds:
https://launchpad.net/ubuntu/+source/fglrx-installer/2:9.000-0ubuntu1/+build/3860479
https://launchpad.net/ubuntu/+source/fglrx-installer/2:9.000-0ubuntu2/+build/3861780
https://launchpad.net/ubuntu/+source/fglrx-installer-updates/2:9.000-0ubuntu1/+build/3860477
https://launchpad.net/ubuntu/+source/fglrx-installer-updates/2:9.000-0ubuntu2/+build/3861782

Yet, this bug is marked Fix Released for fglrx-installer and fglrx-installer-updates. I am very confused. Could you please clarify if this bug report should be Status In Progress, or remain Fix Released and why?

Thank you for your time and consideration in this matter and I look forward to your response.

Alberto Milone (albertomilone) wrote :

2:9.000-0ubuntu3 fixes the build issue on i386.

affects: nvidia-drivers-ubuntu → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Confirmed → New
no longer affects: linux (Ubuntu)

Hello Angel, or anyone else affected,

Accepted fglrx-installer-updates into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/fglrx-installer-updates/2:9.000-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
tags: added: verification-done
removed: verification-needed
Chris Halse Rogers (raof) wrote :

Not relevant to precise.

Angel Guzman Maeso (shakaran) wrote :

Hello Chris, I cannot test in precise anymore. I upgrade my machine to quantal time ago, maybe someone can verify in precise.

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers