unity_support_test crashed with SIGSEGV in xcb_glx_query_server_string_string_length()

Bug #958212 reported by Jaime Otero on 2012-03-17
190
This bug affects 27 people
Affects Status Importance Assigned to Milestone
Nux
Won't Fix
High
Unassigned
nux (Ubuntu)
High
Unassigned

Bug Description

Crashed

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: nux-tools 2.6.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-19.30-generic 3.2.11
Uname: Linux 3.2.0-19-generic x86_64
ApportVersion: 1.94.1-0ubuntu2
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
Date: Sat Mar 17 18:50:57 2012
DistUpgraded: Log time: 2012-03-10 18:39:34.252418
DistroCodename: precise
DistroVariant: ubuntu
ExecutablePath: /usr/lib/nux/unity_support_test
GraphicsCard:
 Advanced Micro Devices [AMD] nee ATI RV620 [Mobility Radeon HD 3400 Series] [1002:95c4] (prog-if 00 [VGA controller])
   Subsystem: Sony Corporation Device [104d:9035]
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120309)
MachineType: Sony Corporation VGN-FW139E
ProcCmdline: /usr/lib/nux/unity_support_test -p -f
ProcEnviron:
 LANG=en_US.UTF-8
 TERM=unknown
 SHELL=/bin/bash
 PATH=(custom, no user)
 LC_MESSAGES=C
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-19-generic root=UUID=09eab524-eff0-4d80-b4a3-0137db2e7ac8 ro quiet splash vt.handoff=7
SegvAnalysis:
 Segfault happened at: 0x7f41a2a0f100 <xcb_glx_query_server_string_string_length>: mov 0xc(%rdi),%eax
 PC (0x7f41a2a0f100) ok
 source "0xc(%rdi)" (0x0000000c) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: nux
StacktraceTop:
 xcb_glx_query_server_string_string_length () from /usr/lib/x86_64-linux-gnu/libxcb-glx.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/mesa/libGL.so.1
 ?? () from /usr/lib/x86_64-linux-gnu/mesa/libGL.so.1
 ?? () from /usr/lib/x86_64-linux-gnu/mesa/libGL.so.1
 glXGetConfig () from /usr/lib/x86_64-linux-gnu/mesa/libGL.so.1
Title: unity_support_test crashed with SIGSEGV in xcb_glx_query_server_string_string_length()
UnitySupportTest: Error: command ['/usr/lib/nux/unity_support_test', '-p', '-f'] failed with exit code -11:
UpgradeStatus: Upgraded to precise on 2012-03-10 (6 days ago)
UserGroups:

dmi.bios.date: 10/07/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: R0270Y0
dmi.board.asset.tag: N/A
dmi.board.name: VAIO
dmi.board.vendor: Sony Corporation
dmi.board.version: N/A
dmi.chassis.asset.tag: N/A
dmi.chassis.type: 10
dmi.chassis.vendor: Sony Corporation
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrR0270Y0:bd10/07/2009:svnSonyCorporation:pnVGN-FW139E:pvrC600CM9R:rvnSonyCorporation:rnVAIO:rvrN/A:cvnSonyCorporation:ct10:cvrN/A:
dmi.product.name: VGN-FW139E
dmi.product.version: C600CM9R
dmi.sys.vendor: Sony Corporation
version.compiz: compiz 1:0.9.7.0+bzr3035-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.30-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.1-0ubuntu5
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.1-0ubuntu5
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Jaime Otero (jotero001) wrote :

StacktraceTop:
 xcb_glx_query_server_string_string_length (R=0x0) at glx.c:2445
 __glXQueryServerString (dpy=<optimized out>, opcode=<optimized out>, screen=0, name=2) at glx_query.c:58
 AllocAndFetchScreenConfigs (priv=0x1f804e0, dpy=0x1f75010) at glxext.c:770
 __glXInitialize (dpy=0x1f75010) at glxext.c:885
 __glXInitialize (dpy=0x1f75010) at glxext.c:803

Changed in nux (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nux (Ubuntu):
status: New → Confirmed
tags: added: bugpattern-needed
visibility: private → public
Changed in nux (Ubuntu):
importance: Medium → High

I got this error after uninstalling fglxr package. After reinstalling it, everything is back to a normal state.

tags: added: quantal
Angel Guzman Maeso (shakaran) wrote :

I get the same error uninstalling fglxr and running glxinfo, steps for reproduce:

sudo apt-get purge xorg-driver-fglrx fglrx-*
sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri
sudo dpkg-reconfigure xserver-xorg
sudo apt-get install --reinstall xserver-xorg-core

Then run:

glxinfo

This crash will appear.

Changed in nux:
importance: Undecided → High
status: New → Confirmed
Will Cooke (willcooke) wrote :

As part of the big bug clear up for 16.04 LTS I am marking this bug as Wont Fix.
These types of crasher are better handled by errors.ubutnu.com which can collate similar crash reports to help us identify persitent bugs rather than one-off crashes.
Sorry we are not able to help with this specific issue. If you are still experiencing this crash, please re-open the bug and add the tag "desktop-bugscrub-reopened". See https://wiki.ubuntu.com/BigDesktopBugScrub for more information.

Changed in nux:
status: Confirmed → Won't Fix
Changed in nux (Ubuntu):
status: Confirmed → Won't Fix
tags: added: desktop-bugscrub-autoclosed
To post a comment you must log in.