Comment 34 for bug 1032672

Unfortunately, it doesn't work for me. The new driver does not identify my hardware.

# lspci|grep VGA
01:05.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RS780L [Radeon HD 3000]
# modprobe fglrx
FATAL: Error inserting fglrx (/lib/modules/3.5.0-15-generic/updates/dkms/fglrx.ko): No such device
# dmesg|tail -n3
[ 6785.693869] [fglrx] Maximum main memory to use for locked dma buffers: 7132 MBytes.
[ 6785.694089] [fglrx:firegl_init_device_list] *ERROR* No supported display adapters were found
[ 6785.694091] [fglrx:firegl_init_module] *ERROR* firegl_init_devices failed
# dpkg --list|grep fglrx
ii fglrx 2:9.000-0ubuntu1 amd64 Video driver for the AMD graphics accelerators
ii fglrx-amdcccle 2:9.000-0ubuntu1 amd64 Catalyst Control Center for the AMD graphics accelerators