glxinfo crashed with SIGSEGV in xcb_glx_query_server_string_string_length()

Bug #1055236 reported by Angel Guzman Maeso on 2012-09-24
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
mesa-demos (Ubuntu)
Medium
Unassigned

Bug Description

I get this error uninstalling fglxr and running glxinfo, steps for reproduce:

sudo apt-get purge xorg-driver-fglrx fglrx-*
sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri
sudo dpkg-reconfigure xserver-xorg
sudo apt-get install --reinstall xserver-xorg-core

Then run:

glxinfo

This crash will appear.

Related:
https://bugs.launchpad.net/ubuntu/+source/nux/+bug/958212
https://bugs.launchpad.net/bugs/1032672

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: mesa-utils 8.0.1+git20110129+d8f7d6b-0ubuntu2
ProcVersionSignature: Ubuntu 3.5.0-15.22-generic 3.5.4
Uname: Linux 3.5.0-15-generic i686
ApportVersion: 2.5.2-0ubuntu4
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
Date: Mon Sep 24 03:04:00 2012
DistUpgraded: 2012-06-05 11:27:02,271 DEBUG enabling apt cron job
DistroCodename: quantal
DistroVariant: ubuntu
DkmsStatus:
 virtualbox, 4.1.18, 3.5.0-10-generic, i686: installed
 virtualbox, 4.1.18, 3.5.0-13-generic, i686: installed
 virtualbox, 4.1.18, 3.5.0-14-generic, i686: installed
 virtualbox, 4.1.18, 3.5.0-15-generic, i686: installed
 virtualbox, 4.1.18, 3.5.0-1-generic, i686: installed
ExecutablePath: /usr/bin/glxinfo
GraphicsCard:
 Advanced Micro Devices [AMD] nee ATI Madison [Radeon HD 5000M Series] [1002:68c1] (prog-if 00 [VGA controller])
   Subsystem: Acer Incorporated [ALI] Device [1025:042f]
InstallationMedia:

MachineType: Acer Aspire 5943G
ProcCmdline: glxinfo
ProcEnviron:
 TERM=xterm
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=es_ES.UTF-8
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-15-generic root=UUID=793921c9-c002-4400-9dd5-e0879b4061fb ro quiet splash vt.handoff=7
SegvAnalysis:
 Segfault happened at: 0xb741ba74 <xcb_glx_query_server_string_string_length+4>: mov 0xc(%eax),%eax
 PC (0xb741ba74) ok
 source "0xc(%eax)" (0x0000000c) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: mesa-demos
StacktraceTop:
 xcb_glx_query_server_string_string_length () from /usr/lib/i386-linux-gnu/libxcb-glx.so.0
 __glXQueryServerString () from /usr/lib/i386-linux-gnu/mesa/libGL.so.1
 ?? () from /usr/lib/i386-linux-gnu/mesa/libGL.so.1
 ?? () from /usr/lib/i386-linux-gnu/mesa/libGL.so.1
 glXChooseVisual () from /usr/lib/i386-linux-gnu/mesa/libGL.so.1
Title: glxinfo crashed with SIGSEGV in xcb_glx_query_server_string_string_length()
UnitySupportTest: Error: command ['/usr/lib/nux/unity_support_test', '-p', '-f'] failed with exit code -11:
UpgradeStatus: Upgraded to quantal on 2012-06-05 (110 days ago)
UserGroups: adm admin audio cdrom dialout dip fax floppy fuse lpadmin netdev plugdev sambashare tape vboxusers video
dmi.bios.date: 05/07/2010
dmi.bios.vendor: Acer
dmi.bios.version: V1.06
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Aspire 5943G
dmi.board.vendor: Acer
dmi.board.version: V1.06
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: V1.06
dmi.modalias: dmi:bvnAcer:bvrV1.06:bd05/07/2010:svnAcer:pnAspire5943G:pvrV1.06:rvnAcer:rnAspire5943G:rvrV1.06:cvnAcer:ct10:cvrV1.06:
dmi.product.name: Aspire 5943G
dmi.product.version: V1.06
dmi.sys.vendor: Acer
version.compiz: compiz 1:0.9.8.2+bzr3377-0ubuntu1
version.libdrm2: libdrm2 2.4.39-0ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.0~git20120917.7cfd42ce-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.0~git20120917.7cfd42ce-0ubuntu3
version.xserver-xorg-core: xserver-xorg-core 2:1.13.0-0ubuntu4
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.99.99~git20120913.8637f772-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel N/A
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A

Angel Guzman Maeso (shakaran) wrote :
visibility: private → public

StacktraceTop:
 xcb_glx_query_server_string_string_length (R=R@entry=0x0) at glx.c:2445
 __glXQueryServerString (dpy=dpy@entry=0x8c7d008, opcode=153, screen=screen@entry=0, name=name@entry=2) at glx_query.c:58
 AllocAndFetchScreenConfigs (priv=0x8c87178, dpy=0x8c7d008) at glxext.c:773
 __glXInitialize (dpy=0x8c7d008) at glxext.c:888
 __glXInitialize (dpy=dpy@entry=0x8c7d008) at glxext.c:806

Changed in mesa-demos (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mesa-demos (Ubuntu):
status: New → Confirmed
Changed in mesa-demos (Ubuntu):
status: Confirmed → Incomplete
Chris Halse Rogers (raof) wrote :

It seems that you haven't restarted the X server between running your apt commands and getting the crash. That won't work; the running X server is still using fglrx's GLX, which is (as you have found) incompatible with mesa.

Also, that's not the supported way of switching to the free drivers; the Additional Drivers tab of Software Sources is the supported method. What you did should work, though, after a reboot.

Does it?

Angel Guzman Maeso (shakaran) wrote :

I didn't know the method using software-properties-gtk (Additional Drivers tab). When I search in google I don't see any useful reference to this, so maybe it is not very aware for other users.

As you mention, I run this command after apt commands without restart. Restarting solves the problem. But maybe could be useful add a couple of lines to glxinfo source code detecting previously if calling to xcb_glx_query_server_string_string_length() has a X server enabled or need a restart. So you can get this output for example:

$ glxinfo
Could not run the program. A X server restart is required.

This is huge useful for the user and avoid related crashes or duplicates that will spend QA time (IMHO).

Chris Halse Rogers (raof) wrote :

I don't think it's particularly useful to fix this; there can be, and are, arbitrary differences between the free libglx and the proprietary drivers' libglxes, any one of which could cause a mismatched client to crash.

I don't think this is common enough to invest resources in to fix.

Changed in mesa-demos (Ubuntu):
status: Incomplete → Invalid
status: Invalid → Won't Fix
To post a comment you must log in.