Ubuntu

ubuntu desktop unity. Mouse at the left side doesn't reveal launcher

Reported by vassilis karamitros on 2011-08-23
482
This bug affects 96 people
Affects Status Importance Assigned to Milestone
Unity
High
Unassigned
compiz (Ubuntu)
High
Sam Spilsbury
Oneiric
High
Sam Spilsbury

Bug Description

TEST CASE:
1. Start a session (restarting Unity didn't do the trick).
2. Start gnome-terminal or gedit and maximize it (doesn't matter how, also works with other applications).

RESULT:
* The launcher does not reveal (hide mode 2 - "Dodge Window").

I'm not sure how, but it will eventually start working again after some window dragging/maximizing.

Using Nux r483 and Unity r1628.

=====Original Report=====

Hello

i am testing Ubuntu 11.10 alpha3 and i have a problem with unity. When i open a window, firefox for example, i cannot see the launcher when i move my cursor on the left side as i used to. This problem is not happening when i use unity2d. I can see the launcher by pressing alt+f1. I didn't had a clean install, i mean i upgraded to Ubuntu 11.10. Unity's package version is 4.8.2-0ubuntu4.

Thank you in advance

Vassilis

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity 4.8.2-0ubuntu4
ProcVersionSignature: Ubuntu 3.0.0-9.13-generic 3.0.3
Uname: Linux 3.0.0-9-generic i686
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,resize,gnomecompat,imgpng,vpswitch,commands,grid,obs,compiztoolbox,place,mousepoll,move,regex,wall,session,unitymtgrabhandles,wobbly,animation,workarounds,expo,ezoom,staticswitcher,fade,scale,unityshell]
Date: Tue Aug 23 19:14:50 2011
InstallationMedia: Ubuntu 10.04.2 LTS "Lucid Lynx" - Release i386 (20110211.1)
SourcePackage: unity
UpgradeStatus: Upgraded to oneiric on 2011-08-23 (0 days ago)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Jan Rathmann (kaiserclaudius) wrote :

I'm seeing this too on a freshly installed Oneric Beta 2.
It happens sometimes (but not everytime!) that I can't reveal the launcher via mouse when I have a maximized window (which should work by just moving the mouse to left screen side), only Alt+F1/Super works. I have never seen this in Unity 2D so far.

tags: added: iso-testing
Changed in unity:
status: New → Confirmed
Hernando Torque (htorque) wrote :

I can reliably reproduce this.

TEST CASE:
1. Start a session (restarting Unity didn't do the trick).
2. Start gnome-terminal or gedit and maximize it (doesn't matter how, also works with other applications).

RESULT:
* The launcher does not reveal (hide mode 2 - "Dodge Window").

I'm not sure how, but it will eventually start working again after some window dragging/maximizing.

Using Nux r483 and Unity r1628.

Didier Roche (didrocks) wrote :

This happens with the default mode as well.

Changed in unity:
milestone: none → 4.20.0
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Changed in unity:
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
tags: added: didrocks-oneiric-list
Neil J. Patel (njpatel) on 2011-09-29
Changed in unity:
assignee: nobody → Jason Smith (jassmith)
status: Triaged → Fix Committed
Changed in unity (Ubuntu):
status: Triaged → Fix Committed
Changed in unity:
status: Fix Committed → Triaged
Changed in unity (Ubuntu):
status: Fix Committed → Triaged
Didier Roche (didrocks) on 2011-09-29
Changed in unity:
milestone: 4.20.0 → 4.22.0
Omer Akram (om26er) wrote :

thanks for the test case ;-)

description: updated
Changed in unity (Ubuntu):
assignee: nobody → Jason Smith (jassmith)
milestone: none → ubuntu-11.10
Les Lamb (kernelles) wrote :

This bug affects me as well, and happens with all apps when they are fullscreen, though the problem is intermittent. Happens on both my machines, and has since 11.04. I just didn't report it earlier because I knew Unity was new and I figured they were aware of it, but the problem has still not been resolved in 11.10. Thanks.

Upstairs printer only prints bar code test sheet

Downstairs one keeps freezing

Will linux work? Need drivers for elo touch screen and dymo printer. Also need database and checkin program to work with wine, play on linux, or some other emulator
Sent wirelessly from my BlackBerry device on the Bell network.
Envoyé sans fil par mon terminal mobile BlackBerry sur le réseau de Bell.

Also, it needs to automatically see the network on login. Forget it, too many hurtles! We will need to update machines with hardware and newer Windows then.
Sent wirelessly from my BlackBerry device on the Bell network.
Envoyé sans fil par mon terminal mobile BlackBerry sur le réseau de Bell.

-----Original Message-----
From: Les Lamb <email address hidden>
Sender: <email address hidden>
Date: Sun, 02 Oct 2011 15:29:44
To: <email address hidden>
Reply-To: Bug 832150 <email address hidden>
Subject: [Bug 832150] Checkin stations

Upstairs printer only prints bar code test sheet

Downstairs one keeps freezing

Will linux work? Need drivers for elo touch screen and dymo printer. Also need database and checkin program to work with wine, play on linux, or some other emulator
Sent wirelessly from my BlackBerry device on the Bell network.
Envoyé sans fil par mon terminal mobile BlackBerry sur le réseau de Bell.

--
You received this bug notification because you are subscribed to a
duplicate bug report (863479).
https://bugs.launchpad.net/bugs/832150

Title:
  ubuntu desktop unity. Mouse at the left side doesn't reveal launcher

Status in Unity:
  Triaged
Status in “unity” package in Ubuntu:
  Triaged

Bug description:
  TEST CASE:
  1. Start a session (restarting Unity didn't do the trick).
  2. Start gnome-terminal or gedit and maximize it (doesn't matter how, also works with other applications).

  RESULT:
  * The launcher does not reveal (hide mode 2 - "Dodge Window").

  I'm not sure how, but it will eventually start working again after
  some window dragging/maximizing.

  Using Nux r483 and Unity r1628.

  =====Original Report=====

  Hello

  i am testing Ubuntu 11.10 alpha3 and i have a problem with unity. When
  i open a window, firefox for example, i cannot see the launcher when i
  move my cursor on the left side as i used to. This problem is not
  happening when i use unity2d. I can see the launcher by pressing
  alt+f1. I didn't had a clean install, i mean i upgraded to Ubuntu
  11.10. Unity's package version is 4.8.2-0ubuntu4.

  Thank you in advance

  Vassilis

  ProblemType: Bug
  DistroRelease: Ubuntu 11.10
  Package: unity 4.8.2-0ubuntu4
  ProcVersionSignature: Ubuntu 3.0.0-9.13-generic 3.0.3
  Uname: Linux 3.0.0-9-generic i686
  Architecture: i386
  CompizPlugins: [core,bailer,detection,composite,opengl,decor,resize,gnomecompat,imgpng,vpswitch,commands,grid,obs,compiztoolbox,place,mousepoll,move,regex,wall,session,unitymtgrabhandles,wobbly,animation,workarounds,expo,ezoom,staticswitcher,fade,scale,unityshell]
  Date: Tue Aug 23 19:14:50 2011
  InstallationMedia: Ubuntu 10.04.2 LTS "Lucid Lynx" - Release i386 (20110211.1)
  SourcePackage: unity
  UpgradeStatus: Upgraded to oneiric on 2011-08-23 (0 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/unity/+bug/832150/+subscriptions

eric (obrowny06) wrote :

will it be solved for the release ?
It is a bit annoying to see that launcher can't reveal itself when a window is maximised...

Didier Roche (didrocks) on 2011-10-04
Changed in unity:
milestone: 4.22.0 → 4.24.0
Mirco Müller (macslow) wrote :

I can't reproduce this with unity 4.20.0. The launcher revealing works correctly with maximized application-windows... no matter if just logged in or in a session already running for some time.

Jan Rathmann (kaiserclaudius) wrote :

@Mirco
Could the problem be architecture dependent? My installation where I see this bug is an AMD64 one, I could check if the bug is also present on the i386 version.

Les Lamb (kernelles) wrote :

My apologies for comments 8 and 9 above. For some reason, I replied to a bug from my blackberry once, and now every email I send gets posted as a comment on one of my launchpad bugs. If any of you developers know how this could have happened, I'd love to hear from you. I've checked my email settings, and they seem to be fine. Thanks.

Ioannis Ramfos (isr81) wrote :

I first noticed it when running the live cd (20111006) and still happens. After logging in, the launcher does not appear with the mouse on the left side of the screen.
I managed to make it appear, and work thereafter by using the Meta key. It worked until I logged out and in again.

Omer Akram (om26er) wrote :

'Dodge window' is the default option, some argue it to still be problematic vs always shown and when the launcher wont reveal at all thats a problem, I raised the priority.

Changed in unity (Ubuntu):
importance: High → Critical
Changed in unity:
importance: High → Critical
nuttzo33 (slucas1979) wrote :

I'm also getting this happening on and off.Im using amd64 version of oneiric and nouveau driver at the moment.I will install nvidia proprietary driver and see if this is still happening.

nuttzo33 (slucas1979) wrote :

I installed proprietary driver and rebooted and the problem was still there initially but now it is working properly again.I had something crash and restart and after that it seemed to fix the problem.Which log file is responsible for logging app crashes, i tried to open log file viewer from the launcher but it was empty as i run into this bug https://bugs.launchpad.net/ubuntu/oneiric/+source/gnome-utils/+bug/841085

nuttzo33 (slucas1979) wrote :

I can reproduce this if i log into a guest session,start nautilus and maximize it.I found this out here
https://bugs.launchpad.net/ubuntu/+source/unity/+bug/865913
maybe this bug is a duplicate of that one or vice versa.

nuttzo33 (slucas1979) wrote :

I just restarted and had the launcher refuse to come up again and so i right clicked on the desktop to bring a menu up and that fixed the problem with the launcher and it was working again but when i opened up a guest session and tried it the launcher would not come up without pressing the super key.

nuttzo33 (slucas1979) wrote :

Ok i seem to be able to reproduce this 100 percent of the time like this.

1.login to a new guest session
2.click on firefox launcher icon and maximize it.
3.mouse to the left and launcher will not reveal.

to fix
1.minimize firefox
2.right click on the desktop a few times in a couple of different spots.
3.Launcher should return now

I also noticed that the aero snap like feature doesn't always work properly when you drag a window up.It sort of jerks and maximizes instead of that orange border that slowly fills the screen as you mouse higher.I don't know if the problem is related or not?

Jan Rathmann (kaiserclaudius) wrote :

@shayne
I can also reproduce it reliably the way you described.

Doug McMahon (mc3man) wrote :

If the grid plugin is enabled it happens here, if it's disabled then it doesn't

nuttzo33 (slucas1979) wrote :

I also confirm this doesn't happen with the grid plugin disabled

Hernando Torque (htorque) wrote :

Maybe related to bug 862339?

Jan Rathmann (kaiserclaudius) wrote :

For me deactivating the Grid plugin makes _no_ difference (=doesn't help).

I tried to deactivate as much of the plugins as possible, but nothing made the bug disappear.

Didier Roche (didrocks) on 2011-10-10
affects: unity (Ubuntu) → compiz (Ubuntu)
Changed in compiz (Ubuntu):
assignee: Jason Smith (jassmith) → Sam Spilsbury (smspillaz)
importance: Critical → High
Changed in unity:
importance: Critical → High
Matteo Pagliazzi (paglia) wrote :

This happend to me more or less always, especially when i hav e a maximixed window there isn't a way to reveal the launcher while if i have only an unmaximixed window and i move it out of the "launcher zone" the launcher appear

Hello vassilis, or anyone else affected,

Accepted compiz into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in compiz (Ubuntu Oneiric):
status: Triaged → Fix Committed
tags: added: verification-needed
Jan Rathmann (kaiserclaudius) wrote :

@Martin
Tested it here, and I couldn't reproduce the bug anymore so far :-)

Hernando Torque (htorque) wrote :

Works fine here too.

Martin Pitt (pitti) on 2011-10-11
tags: added: verification-done
removed: verification-needed
nuttzo33 (slucas1979) wrote :

I also can no longer reproduce this in a guest session or in my username.

Works fine for me here ( today's compiz proposed update done ;) )

Jan Rathmann (kaiserclaudius) wrote :

I have to correct myself - the bug is still there with compiz from proposed installs.
It appeared again after I installed Oneric as my main system and reusing my home directory from Natty for it. However, it has become trickier to reproduce, starting a new guest session and maximizing window works fine now. (That's why I first thought it was fixed). But I'm bitten by the bug nearly everytime I login to my normal user account.

If I can do anything to help debugging, please let me know.

Ngassam Nkwenga (cyrildz) wrote :

 Fixed here.
I'm on the proposed Repository

eric (obrowny06) wrote :

Seems to be fixed for me as well but it may need more testing as it was not happening all the time.

meist3r (meist3r) wrote :

This is broken for me on a vanilla Oneiric install from ISO image released on launch day and required updates as of 14/10/2011. How is this happening? You're forcing Unity on the users and it has a flaw as severe as this. I enjoy using Unity ... as long as it works.

nuttzo33 (slucas1979) wrote :

meist3r
I think the update for this is still in proposed updates and hasn't been put in the main update repo yet.I hardly think it is a severe flaw as it usually only happens when you first log in.The fix for compiz in propsed works for me but i also reinstalled the official iso and noticed that this bug wasn't patched in time for the official release.Just be patient or enable the proposed updates and update yourself.

Didier Roche (didrocks) on 2011-10-14
Changed in unity:
status: Triaged → Fix Released
Changed in compiz (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Martin Pitt (pitti) on 2011-10-14
Changed in compiz (Ubuntu Oneiric):
status: Fix Released → Fix Committed
madbiologist (me-again) wrote :

According to comment #7 and bug #789689 this fix is also needed on Natty.

Omer Akram (om26er) on 2011-10-15
Changed in unity:
assignee: Jason Smith (jassmith) → nobody
Omer Akram (om26er) wrote :

madbiologist, this particular bug is *specific* to oneiric plz dont mark any of the non-related bugs as duplicates of this one.

Mark Bokil (mark-bokil) wrote :

This bug seems similar to issues with compiz not using plugin values at login. When the launcher fails to show I use compizconfig to toggle Dodge Windows and the launcher starts working again. Same issue for compiz edge bindings. Hot corners for expose or workspace switcher are disabled at login. I have to pull up compizconfig and disable/enable commands and then refresh unity with unity --replace. There is already a bug filed for compiz edge bindings in oneiric.

Jan Rathmann (kaiserclaudius) wrote :

Sorry, my last post was obviously some kind of false alert, unsure what was the cause. During the last days I have worked with Oneiric all the time and fortunately couldn't see the bug anymore. Thus sorry for the confusion.

Kind regards,
Jan

Spirehuset (5-karsten) on 2011-10-17
Changed in compiz (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.6+bzr20110929-0ubuntu5

---------------
compiz (1:0.9.6+bzr20110929-0ubuntu5) oneiric-proposed; urgency=low

  * debian/patches/fix-864330.patch:
    - fix windows which can have towed moving (LP: #864330)
  * debian/patches/fix-864478.patch:
    - Window shading is broken (LP: #864478)

compiz (1:0.9.6+bzr20110929-0ubuntu4) oneiric-proposed; urgency=low

  * debian/control:
    - don't suggest nvidia-glx, it's part of the old initial packaging
      and probably a bad hint on non nvidia system (LP: #844218)
  * Cherry-pick upstream patches:
    - Windows should not automatically be focused when opened if the focus
      is on another application (LP: #748840)
    - Launcher - If a spread contains minimised windows, when the spread
      exits, the minimised windows momentarily appear on the desktop
      before disappearing (LP: #863328)
    - reproducible stacking bug in compiz (LP: #869316)
    - Click-dragging a window that's stacked above a fullscreen window will
      cause it to go underneath the fullscreen window (LP: #869919)
    - sometimes the keyboard input doesn't go to the apparently focussed
      dialog (LP: #869967)
    - Opening mumble can cause it to be stacked above the dash if you
      open the dash at the same time (LP: #865863)
    - Sometimes configure events are missed and windows move slow as a result
      (LP: #866752)
    - Workaround ubuntu desktop unity. Mouse at the left side doesn't reveal
      launcher (LP: #832150)
 -- Didier Roche <email address hidden> Wed, 12 Oct 2011 10:44:49 +0200

Changed in compiz (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Lyle Waldman (ertai87-r) wrote :

Bug is not fixed for me. Steps to repro:

On boot, login. Run Firefox in maximized window. Move mouse to left side. Unity launchbar doesn't appear.

Run compiz --replace &. Maximize Firefox again. Move mouse over to left side. Launchbar appears.

Output of compiz --version: Compiz 0.9.6.

No updates to install in apt, so I should have the most recent compiz. Please reopen.

Colin Law (colin-law) wrote :

@Lyle: Perhaps "This bug was fixed in the package compiz - 1:0.9.6+bzr20110929-0ubuntu5" means that the version it is fixed in 0.9.6+ so that it will not appear in the repos till 0.9.7 is released.

BigJules (julianstockwin) wrote :

Still a problem for me with clean install of 11.10 alternate: not only with Dodge Active Window but also with Dodge Window.

N.B. for me, disturbing additional - seems that if the area on the maximized window where the launcher should be is clicked for any reason, it is treated as if the launcher were there, and it executes the app as if the icon were invisible but active...

Lyle Waldman (ertai87-r) wrote :

@Colin: Ah, understood. When it got marked "Fix Released" I expected it to have been...released... =X But I understand now, thanks =D

Martin Pitt (pitti) wrote :

Lyle, your understanding is correct. BigJules, did you install the updates after installing 11.10?

Colin Law (colin-law) wrote :

@Martin, sorry I think your comment is ambigous. Do you mean Lyle was correct in thinking that he should see the fix in 0.9.6, or that he is correct in his response to my comment that it will not be till 0.9.7.
In other words which version is the fix in please?
Thanks.

Martin Pitt (pitti) wrote :

As comment 41 says, the fix was released in version 1:0.9.6+bzr20110929-0ubuntu5, which is in oneiric-updates (but not in oneiric final, so you'll see the bug in a fresh install).

Lyle Waldman (ertai87-r) wrote :

@Martin: The fix does not appear to be in apt, or at least I'm not getting it when I run apt-get. What should I see when I run compiz --version if I have the update?

Lyle Waldman [2011-10-18 16:57 -0000]:
> @Martin: The fix does not appear to be in apt, or at least I'm not
> getting it when I run apt-get. What should I see when I run compiz
> --version if I have the update?

This:

$ dpkg -s compiz|grep ^Version
Version: 1:0.9.6+bzr20110929-0ubuntu5

compiz --version isn't sufficient.
--
Martin Pitt | http://www.piware.de
Ubuntu Developer (www.ubuntu.com) | Debian Developer (www.debian.org)

Lyle Waldman (ertai87-r) wrote :

Version: 1:0.9.6+bzr20110929-0ubuntu3

Why do you have a 5 and I have a 3?

BigJules (julianstockwin) wrote :

Martin - yes I did update immediately after 11.10 with no result.

BUT have just got a bunch of updates thru the standard update channel and AFAIK this bug seems squashed. Have been working continually and rebooted a couple of times without a single launcher misbehaviour. Gratifying side-effect is that Compiz key bindings are now instant and stable.

Doug McMahon (mc3man) wrote :

Lyle -
either the mirror you are using hasn't sync'ed up yet or you haven't updated your sources
If it's the former than wait it out or open software-properties & switch to the main server
Then update your sources & you'll be good to go to upgrade compiz*

Jakub Gocławski (jgoclawski) wrote :

I can confirm that the bug is fixed. I am running ubuntu 11.10 upgraded from 11.04 and was experiencing it as others (very annoying).
I have just installed updates and the bug is gone.

version:
dpkg -s compiz|grep ^Version
Version: 1:0.9.6+bzr20110929-0ubuntu5

Lyle Waldman (ertai87-r) wrote :

@Doug: Yup, the mirror wasn't synced up yet. Got the update just now. In case anyone cares, my mirror is South Korea.

chud (richud.com) wrote :

Update (went from ubuntu3 to ubuntu5 in below) - now better but still not entirely 'ok'

 dpkg -s compiz|grep ^Version
Version: 1:0.9.6+bzr20110929-0ubuntu5

Launch chrome, move mouse to left, nothing happens. Go to a web page, then works.

chud (richud.com) wrote :

Actually it's not fixed at all, launching anything - it wont appear (Chrome was first thing I tried), Nautilus, libreoffice, firefox launch stop bar appearing :(

Holger Knust (hknust) wrote :

Laucher still gets stuck. See attached screenshot.

How do you reopen the issue?

dpkg -s compiz|grep ^Version
Version: 1:0.9.6+bzr20110929-0ubuntu6

Ezra Morris (ezramorris) wrote :

Seems to be a different issue, Holger. This bug is about it not appearing. Yours seems to be about it staying open.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers