compiz crashed with SIGSEGV in g_closure_invoke() if unity-settings-daemon goes away

Bug #1366351 reported by mustangtyson on 2014-09-06
764
This bug affects 85 people
Affects Status Importance Assigned to Milestone
Compiz
Undecided
Unassigned
Unity
Fix Released
Critical
Marco Trevisan (Treviño)
compiz (Ubuntu)
High
Unassigned
unity (Ubuntu)
Critical
Unassigned

Bug Description

Compiz crashes when unity-settings-daemon goes away. Simple reproducer: "killall -SEGV unity-settings-daemon".

ProblemType: Crash
DistroRelease: Ubuntu 14.10
Package: compiz-core 1:0.9.12+14.10.20140812-0ubuntu1
ProcVersionSignature: Ubuntu 3.16.0-13.19-generic 3.16.1
Uname: Linux 3.16.0-13-generic x86_64
NonfreeKernelModules: fglrx
.tmp.unity.support.test.0:

ApportVersion: 2.14.7-0ubuntu2
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Sat Sep 6 10:48:43 2014
Disassembly: => 0x0: Cannot access memory at address 0x0
DistUpgraded: 2014-09-01 18:03:23,330 DEBUG enabling apt cron job
DistroCodename: utopic
DistroVariant: ubuntu
ExecutablePath: /usr/bin/compiz
GraphicsCard:
 Advanced Micro Devices, Inc. [AMD/ATI] Curacao XT [Radeon R9 270X] [1002:6810] (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:04a1]
InstallationDate: Installed on 2014-03-24 (166 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
MachineType: MSI MS-7640
ProcCmdline: compiz
ProcEnviron:
 PATH=(custom, no user)
 SHELL=/bin/bash
 LD_LIBRARY_PATH=<set>
 LANG=en_US.UTF-8
 XDG_RUNTIME_DIR=<set>
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.16.0-13-generic root=UUID=2696ea28-d88b-431c-a1fa-1e0f297ee664 ro quiet splash vt.handoff=7
SegvAnalysis:
 Segfault happened at: 0x0: Cannot access memory at address 0x0
 PC (0x00000000) not located in a known VMA region (needed executable region)!
SegvReason: executing NULL VMA
Signal: 11
SourcePackage: compiz
StacktraceTop:
 ?? ()
 g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_signal_emit_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_signal_emit () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: compiz crashed with SIGSEGV in g_closure_invoke()
UpgradeStatus: Upgraded to utopic on 2014-09-01 (4 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 10/31/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: V1.15
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: 890FXA-GD70 (MS-7640)
dmi.board.vendor: MSI
dmi.board.version: 1.0
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: MSI
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrV1.15:bd10/31/2012:svnMSI:pnMS-7640:pvr1.0:rvnMSI:rn890FXA-GD70(MS-7640):rvr1.0:cvnMSI:ct3:cvr1.0:
dmi.product.name: MS-7640
dmi.product.version: 1.0
dmi.sys.vendor: MSI
version.compiz: compiz 1:0.9.12+14.10.20140812-0ubuntu1
version.fglrx-installer: fglrx-installer N/A
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.56-1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.2.6-1ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.2.6-1ubuntu3
version.xserver-xorg-core: xserver-xorg-core 2:1.15.1-0ubuntu9
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.9.0-1ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.4.0-2ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.914-1~exp1ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.10-1ubuntu2
xserver.bootTime: Sat Sep 6 10:48:05 2014
xserver.configfile: default
xserver.errors:
 open /dev/dri/card0: No such file or directory
 AIGLX error: failed to open /usr/X11R6/lib64/modules/dri/fglrx_dri.so, error[/usr/X11R6/lib64/modules/dri/fglrx_dri.so: cannot open shared object file: No such file or directory]
 AIGLX error: failed to open /usr/lib64/dri/fglrx_dri.so, error[/usr/lib64/dri/fglrx_dri.so: cannot open shared object file: No such file or directory]
 AIGLX error: failed to open /usr/X11R6/lib/modules/dri/fglrx_dri.so, error[/usr/X11R6/lib/modules/dri/fglrx_dri.so: cannot open shared object file: No such file or directory]
xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.15.1-0ubuntu9
xserver.video_driver: fglrx

Related branches

mustangtyson (tysonsmith) wrote :

StacktraceTop:
 ?? ()
 g_closure_invoke (closure=0x2408270, return_value=0x0, n_param_values=2, param_values=0x7fffa48fea60, invocation_hint=0x7fffa48fea00) at /build/buildd/glib2.0-2.41.3/./gobject/gclosure.c:768
 signal_emit_unlocked_R (node=node@entry=0x110aeb0, detail=detail@entry=1298, instance=instance@entry=0x183df50, emission_return=emission_return@entry=0x0, instance_and_params=instance_and_params@entry=0x7fffa48fea60) at /build/buildd/glib2.0-2.41.3/./gobject/gsignal.c:3553
 g_signal_emit_valist (instance=<optimized out>, signal_id=<optimized out>, detail=<optimized out>, var_args=var_args@entry=0x7fffa48febf0) at /build/buildd/glib2.0-2.41.3/./gobject/gsignal.c:3309
 g_signal_emit (instance=<optimized out>, signal_id=<optimized out>, detail=<optimized out>) at /build/buildd/glib2.0-2.41.3/./gobject/gsignal.c:3365

Changed in compiz (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
tags: added: bugpattern-needed
Stephen M. Webb (bregma) on 2014-09-15
information type: Private → Public
jerrylamos (jerrylamos) wrote :

Got this bug or one with similar description bugs/1369746 on Acer wide screen desktop at utopic 3.16.0-13. Updated to 3.16.0-14 and hasn't repeated yet, only a couple boots so far so we'll see.

Where you running any ppas? I see you're running a compiz version that wasn't released into main until the 23rd of Sept...

ignore comment, was looking at the wrong version/numbers!

Stephen M. Webb (bregma) on 2014-10-05
Changed in compiz (Ubuntu):
importance: Medium → High
status: Confirmed → Triaged
jerrylamos (jerrylamos) wrote :

3.16.0-21 still has the bug.

Anyone who has reproduced the issue could you attach this file:

~/.cache/upstart/unity7.log

Possibly compiz could be outputing something just before it goes down.

Thanks!

Copy attached as requested. Error has occurred three times now. Still
no idea what use case triggers the error to occur.

Thanks,

Roy

Find more about Weather in Toogoolawah, AU
<http://www.wunderground.com/cgi-bin/findweather/getForecast?query=zmw:00000.1.94568&bannertypeclick=wu_bluestripes>
Click for weather forecast
<http://www.wunderground.com/cgi-bin/findweather/getForecast?query=zmw:00000.1.94568&bannertypeclick=wu_bluestripes>
On 09/10/14 09:44, Brandon Schaefer wrote:
> Anyone who has reproduced the issue could you attach this file:
>
> ~/.cache/upstart/unity7.log
>
> Possibly compiz could be outputing something just before it goes down.
>
> Thanks!
>

Changed in compiz:
status: New → Confirmed

As requested in comment #11, here's the unity7.log

jerrylamos (jerrylamos) wrote :

Installed 3.17 on top of the 3.16.0-21
3.17 got a compiz failure too, see
https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/1379073

Both 3.16.0-21 and 3.17 get compiz failures.

Note after the failure occurs, intrepid recovers and keeps on running.
Reboot and may run without getting the bug to repeat.

Install a new kernels and bug may occur again.

jerrylamos (jerrylamos) wrote :

Oops, just did restart and got the compiz error again on kernel 3.17.

wgroiss (wolfgang-groiss-gmx) wrote :

Bug appears every day after boot and (automatic) login:
My unity7.log:
wolfgang@wolfgang-Latitude-E5530-non-vPro:~/.cache/upstart$
22807627 12 -rw-r----- 1 wolfgang wolfgang 12243 Okt 9 22:23 unity7.log

Hmm i just cant reproduce this issue :(.

Do you have multi monitors? Do you still get the crash when you have a password? Anything else you have set up that is different then a default install?

We have some ideas, but we cant really confirm a fix at all until we have someone who can reproduce it!

Also if anyone is able to reproduce this issue and is willing to test some ppas out we could possibly fix this!

I'm running multiple monitors and can reproduce. I would be willing to test
out PPAs
On Oct 9, 2014 4:11 PM, "Brandon Schaefer" <email address hidden>
wrote:

> Also if anyone is able to reproduce this issue and is willing to test
> some ppas out we could possibly fix this!
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1374146).
> https://bugs.launchpad.net/bugs/1366351
>
> Title:
> compiz crashed with SIGSEGV in g_closure_invoke()
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/compiz/+bug/1366351/+subscriptions
>

Brandon Clark (web-brandon) wrote :
Download full text (5.3 KiB)

One monitor and have issue.

Brandon Clark | Support

-----Original Message-----
From: Brandon Schaefer <email address hidden>
Date: Thu, 09 Oct 2014 21:03:18
To: <email address hidden>
Reply-To: Bug 1366351 <email address hidden>
Subject: [Bug 1366351] Re: compiz crashed with SIGSEGV in g_closure_invoke()

Hmm i just cant reproduce this issue :(.

Do you have multi monitors? Do you still get the crash when you have a
password? Anything else you have set up that is different then a default
install?

We have some ideas, but we cant really confirm a fix at all until we
have someone who can reproduce it!

--
You received this bug notification because you are subscribed to a
duplicate bug report (1367088).
https://bugs.launchpad.net/bugs/1366351

Title:
  compiz crashed with SIGSEGV in g_closure_invoke()

Status in Compiz:
  Confirmed
Status in “compiz” package in Ubuntu:
  Triaged

Bug description:
  Issue on booting into unity

  ProblemType: Crash
  DistroRelease: Ubuntu 14.10
  Package: compiz-core 1:0.9.12+14.10.20140812-0ubuntu1
  ProcVersionSignature: Ubuntu 3.16.0-13.19-generic 3.16.1
  Uname: Linux 3.16.0-13-generic x86_64
  NonfreeKernelModules: fglrx
  .tmp.unity.support.test.0:

  ApportVersion: 2.14.7-0ubuntu2
  Architecture: amd64
  CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: compiz
  CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
  CompositorUnredirectFSW: true
  CurrentDesktop: Unity
  Date: Sat Sep 6 10:48:43 2014
  Disassembly: => 0x0: Cannot access memory at address 0x0
  DistUpgraded: 2014-09-01 18:03:23,330 DEBUG enabling apt cron job
  DistroCodename: utopic
  DistroVariant: ubuntu
  ExecutablePath: /usr/bin/compiz
  GraphicsCard:
   Advanced Micro Devices, Inc. [AMD/ATI] Curacao XT [Radeon R9 270X] [1002:6810] (prog-if 00 [VGA controller])
     Subsystem: ASUSTeK Computer Inc. Device [1043:04a1]
  InstallationDate: Installed on 2014-03-24 (166 days ago)
  InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
  MachineType: MSI MS-7640
  ProcCmdline: compiz
  ProcEnviron:
   PATH=(custom, no user)
   SHELL=/bin/bash
   LD_LIBRARY_PATH=<set>
   LANG=en_US.UTF-8
   XDG_RUNTIME_DIR=<set>
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.16.0-13-generic root=UUID=2696ea28-d88b-431c-a1fa-1e0f297ee664 ro quiet splash vt.handoff=7
  SegvAnalysis:
   Segfault happened at: 0x0: Cannot access memory at address 0x0
   PC (0x00000000) not located in a known VMA region (needed executable region)!
  SegvReason: executing NULL VMA
  Signal: 11
  SourcePackage: compiz
  StacktraceTop:
   ?? ()
   g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
   ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
   g_signal_emit_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
   g_signal_emit () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
  Title: compiz crashed with SIGSEGV in g_closure_invoke()
  UpgradeStatus: Upgraded to utopic on 2014-09-01 (4 days ago)
  UserGroups: adm cdrom dip lpadmin plugd...

Read more...

"Anyone who has reproduced the issue could you attach this file: ~/.cache/upstart/unity7.log"

I have 4 monitors running on one card. The crash only happened on restart after install. Has not happened since.

[2892:2892:1009/183441:ERROR:extension_downloader.cc(679)] Invalid URL: '' for extension fkmopoamfjnmppabeaphohombnjcjgla
[2892:2918:1009/183442:ERROR:cert_verify_proc_nss.cc(868)] CERT_PKIXVerifyCert for 192.168.1.143 failed err=-8179
[2892:2984:1009/183446:ERROR:get_updates_processor.cc(240)] PostClientToServerMessage() failed during GetUpdates
[2892:2892:1009/183447:ERROR:extension_downloader.cc(679)] Invalid URL: '' for extension fkmopoamfjnmppabeaphohombnjcjgla

jerrylamos (jerrylamos) wrote :

Been getting this bug nearly every day. Yes I'd be willing to try a ppa.
I've already tried 3.17 gets same error. (as far as I can tell).

That's on 64 bit with built-in monitor off and external monitor on.

Just got a compiz error on 32 bit, different pc
compiz crashed with SIGSEGV in g_cclosure_marshal_VOID__PARAM()
https://bugs.launchpad.net/bugs/1379592

DISTRIB_DESCRIPTION="Ubuntu Utopic Unicorn (development branch)"
Linux Compaq 3.16.0-21-generic #28-Ubuntu SMP Mon Oct 6 16:05:26 UTC 2014 i686 i686 i686 GNU/Linux
model name : Intel(R) Celeron(R) D CPU 3.33GHz
01:05.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RC410 [Radeon Xpress 200/1100]

SlugiusRex (slugiusrex) wrote :

I get this every time I power on the VM

All my info is detailed in bug# 1376022
 https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/1376022

Download full text (5.3 KiB)

Hi

Nothing out of the ordinary going on here and it doesn’t happen every time. Don’t you just love intermittent faults.

Sent from Windows Mail

From: Brandon Schaefer
Sent: ‎Thursday‎, ‎9‎ ‎October‎ ‎2014 ‎22‎:‎11
To: ICE - Fran

Hmm i just cant reproduce this issue :(.

Do you have multi monitors? Do you still get the crash when you have a
password? Anything else you have set up that is different then a default
install?

We have some ideas, but we cant really confirm a fix at all until we
have someone who can reproduce it!

--
You received this bug notification because you are subscribed to a
duplicate bug report (1368807).
https://bugs.launchpad.net/bugs/1366351

Title:
  compiz crashed with SIGSEGV in g_closure_invoke()

Status in Compiz:
  Confirmed
Status in “compiz” package in Ubuntu:
  Triaged

Bug description:
  Issue on booting into unity

  ProblemType: Crash
  DistroRelease: Ubuntu 14.10
  Package: compiz-core 1:0.9.12+14.10.20140812-0ubuntu1
  ProcVersionSignature: Ubuntu 3.16.0-13.19-generic 3.16.1
  Uname: Linux 3.16.0-13-generic x86_64
  NonfreeKernelModules: fglrx
  .tmp.unity.support.test.0:

  ApportVersion: 2.14.7-0ubuntu2
  Architecture: amd64
  CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: compiz
  CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
  CompositorUnredirectFSW: true
  CurrentDesktop: Unity
  Date: Sat Sep 6 10:48:43 2014
  Disassembly: => 0x0: Cannot access memory at address 0x0
  DistUpgraded: 2014-09-01 18:03:23,330 DEBUG enabling apt cron job
  DistroCodename: utopic
  DistroVariant: ubuntu
  ExecutablePath: /usr/bin/compiz
  GraphicsCard:
   Advanced Micro Devices, Inc. [AMD/ATI] Curacao XT [Radeon R9 270X] [1002:6810] (prog-if 00 [VGA controller])
     Subsystem: ASUSTeK Computer Inc. Device [1043:04a1]
  InstallationDate: Installed on 2014-03-24 (166 days ago)
  InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
  MachineType: MSI MS-7640
  ProcCmdline: compiz
  ProcEnviron:
   PATH=(custom, no user)
   SHELL=/bin/bash
   LD_LIBRARY_PATH=<set>
   LANG=en_US.UTF-8
   XDG_RUNTIME_DIR=<set>
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.16.0-13-generic root=UUID=2696ea28-d88b-431c-a1fa-1e0f297ee664 ro quiet splash vt.handoff=7
  SegvAnalysis:
   Segfault happened at: 0x0: Cannot access memory at address 0x0
   PC (0x00000000) not located in a known VMA region (needed executable region)!
  SegvReason: executing NULL VMA
  Signal: 11
  SourcePackage: compiz
  StacktraceTop:
   ?? ()
   g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
   ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
   g_signal_emit_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
   g_signal_emit () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
  Title: compiz crashed with SIGSEGV in g_closure_invoke()
  UpgradeStatus: Upgraded to utopic on 2014-09-01 (4 days ago)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  dmi.bios.date: 10/31/2012
  dmi.bios.ven...

Read more...

Download full text (10.5 KiB)

Hi

This occurs whenever I turn my laptop on, whether I have my monitor plugged
in or not.

Thanks

On 10 October 2014 07:11, John Manning <email address hidden> wrote:

> Hi
>
>
> Nothing out of the ordinary going on here and it doesn’t happen every
> time. Don’t you just love intermittent faults.
>
>
>
>
> Sent from Windows Mail
>
>
>
> From: Brandon Schaefer
> Sent: ‎Thursday‎, ‎9‎ ‎October‎ ‎2014 ‎22‎:‎11
> To: ICE - Fran
>
>
>
> Hmm i just cant reproduce this issue :(.
>
> Do you have multi monitors? Do you still get the crash when you have a
> password? Anything else you have set up that is different then a default
> install?
>
> We have some ideas, but we cant really confirm a fix at all until we
> have someone who can reproduce it!
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1368807).
> https://bugs.launchpad.net/bugs/1366351
>
> Title:
> compiz crashed with SIGSEGV in g_closure_invoke()
>
> Status in Compiz:
> Confirmed
> Status in “compiz” package in Ubuntu:
> Triaged
>
> Bug description:
> Issue on booting into unity
>
> ProblemType: Crash
> DistroRelease: Ubuntu 14.10
> Package: compiz-core 1:0.9.12+14.10.20140812-0ubuntu1
> ProcVersionSignature: Ubuntu 3.16.0-13.19-generic 3.16.1
> Uname: Linux 3.16.0-13-generic x86_64
> NonfreeKernelModules: fglrx
> .tmp.unity.support.test.0:
>
> ApportVersion: 2.14.7-0ubuntu2
> Architecture: amd64
> CompizPlugins: No value set for
> `/apps/compiz-1/general/screen0/options/active_plugins'
> CompositorRunning: compiz
> CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
> CompositorUnredirectFSW: true
> CurrentDesktop: Unity
> Date: Sat Sep 6 10:48:43 2014
> Disassembly: => 0x0: Cannot access memory at address 0x0
> DistUpgraded: 2014-09-01 18:03:23,330 DEBUG enabling apt cron job
> DistroCodename: utopic
> DistroVariant: ubuntu
> ExecutablePath: /usr/bin/compiz
> GraphicsCard:
> Advanced Micro Devices, Inc. [AMD/ATI] Curacao XT [Radeon R9 270X]
> [1002:6810] (prog-if 00 [VGA controller])
> Subsystem: ASUSTeK Computer Inc. Device [1043:04a1]
> InstallationDate: Installed on 2014-03-24 (166 days ago)
> InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64
> (20131016.1)
> MachineType: MSI MS-7640
> ProcCmdline: compiz
> ProcEnviron:
> PATH=(custom, no user)
> SHELL=/bin/bash
> LD_LIBRARY_PATH=<set>
> LANG=en_US.UTF-8
> XDG_RUNTIME_DIR=<set>
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.16.0-13-generic
> root=UUID=2696ea28-d88b-431c-a1fa-1e0f297ee664 ro quiet splash vt.handoff=7
> SegvAnalysis:
> Segfault happened at: 0x0: Cannot access memory at address 0x0
> PC (0x00000000) not located in a known VMA region (needed executable
> region)!
> SegvReason: executing NULL VMA
> Signal: 11
> SourcePackage: compiz
> StacktraceTop:
> ?? ()
> g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
> ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
> g_signal_emit_valist () from
> /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
> g_signal_emit () from /usr/lib/x86_64-linux-gnu/libg...

Another question: does anyone who sees this bug have their desktop scaling factor set to 1?

I have scaling set to 1
On Oct 10, 2014 5:46 AM, "Stephen M. Webb" <email address hidden>
wrote:

> Another question: does anyone who sees this bug have their desktop
> scaling factor set to 1?
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1374146).
> https://bugs.launchpad.net/bugs/1366351
>
> Title:
> compiz crashed with SIGSEGV in g_closure_invoke()
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/compiz/+bug/1366351/+subscriptions
>

As far as I know, I haven't changed it from the default, so I assume mine's set to 1 as well?

Alex Stanev (realender) wrote :

Also hitting this.
Since I'm on yoga2 pro, default resolution 3200x1800 set to 1920x1080, scale 1.25 and theme Radiance.
Some relevant(?) lines from dmesg:
[ 314.839463] systemd-logind[868]: Failed to start unit user@1000.service: Unknown unit: user@1000.service
[ 314.839470] systemd-logind[868]: Failed to start user service: Unknown unit: user@1000.service
[ 314.842558] systemd-logind[868]: New session c2 of user alex.
[ 314.842574] systemd-logind[868]: Linked /tmp/.X11-unix/X0 to /run/user/1000/X11-display.
[ 318.865537] compiz[2436]: segfault at 0 ip (null) sp 00007fff0d9422a8 error 14 in compiz[400000+3000]

Download full text (5.8 KiB)

Is "Desktop Scaling" the setting "Scale for menu and title bars"? If so
mine is set to 1

On 12 October 2014 07:43, Alex Stanev <email address hidden> wrote:

> Also hitting this.
> Since I'm on yoga2 pro, default resolution 3200x1800 set to 1920x1080,
> scale 1.25 and theme Radiance.
> Some relevant(?) lines from dmesg:
> [ 314.839463] systemd-logind[868]: Failed to start unit user@1000.service:
> Unknown unit: user@1000.service
> [ 314.839470] systemd-logind[868]: Failed to start user service: Unknown
> unit: user@1000.service
> [ 314.842558] systemd-logind[868]: New session c2 of user alex.
> [ 314.842574] systemd-logind[868]: Linked /tmp/.X11-unix/X0 to
> /run/user/1000/X11-display.
> [ 318.865537] compiz[2436]: segfault at 0 ip (null) sp
> 00007fff0d9422a8 error 14 in compiz[400000+3000]
>
> ** Attachment added: "unity7 crashlog"
>
> https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/1366351/+attachment/4232163/+files/unity7.log
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1376574).
> https://bugs.launchpad.net/bugs/1366351
>
> Title:
> compiz crashed with SIGSEGV in g_closure_invoke()
>
> Status in Compiz:
> Confirmed
> Status in “compiz” package in Ubuntu:
> Triaged
>
> Bug description:
> Issue on booting into unity
>
> ProblemType: Crash
> DistroRelease: Ubuntu 14.10
> Package: compiz-core 1:0.9.12+14.10.20140812-0ubuntu1
> ProcVersionSignature: Ubuntu 3.16.0-13.19-generic 3.16.1
> Uname: Linux 3.16.0-13-generic x86_64
> NonfreeKernelModules: fglrx
> .tmp.unity.support.test.0:
>
> ApportVersion: 2.14.7-0ubuntu2
> Architecture: amd64
> CompizPlugins: No value set for
> `/apps/compiz-1/general/screen0/options/active_plugins'
> CompositorRunning: compiz
> CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
> CompositorUnredirectFSW: true
> CurrentDesktop: Unity
> Date: Sat Sep 6 10:48:43 2014
> Disassembly: => 0x0: Cannot access memory at address 0x0
> DistUpgraded: 2014-09-01 18:03:23,330 DEBUG enabling apt cron job
> DistroCodename: utopic
> DistroVariant: ubuntu
> ExecutablePath: /usr/bin/compiz
> GraphicsCard:
> Advanced Micro Devices, Inc. [AMD/ATI] Curacao XT [Radeon R9 270X]
> [1002:6810] (prog-if 00 [VGA controller])
> Subsystem: ASUSTeK Computer Inc. Device [1043:04a1]
> InstallationDate: Installed on 2014-03-24 (166 days ago)
> InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64
> (20131016.1)
> MachineType: MSI MS-7640
> ProcCmdline: compiz
> ProcEnviron:
> PATH=(custom, no user)
> SHELL=/bin/bash
> LD_LIBRARY_PATH=<set>
> LANG=en_US.UTF-8
> XDG_RUNTIME_DIR=<set>
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.16.0-13-generic
> root=UUID=2696ea28-d88b-431c-a1fa-1e0f297ee664 ro quiet splash vt.handoff=7
> SegvAnalysis:
> Segfault happened at: 0x0: Cannot access memory at address 0x0
> PC (0x00000000) not located in a known VMA region (needed executable
> region)!
> SegvReason: executing NULL VMA
> Signal: 11
> SourcePackage: compiz
> StacktraceTop:
> ?? ()
> g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.s...

Read more...

Its "Scale for menu and title bars" set to 1.25 on my PC.

Logan Rosen (logan) on 2014-10-12
tags: removed: bugpattern-needed
tags: added: bugpattern-written
Download full text (5.2 KiB)

Retrieved 9/15 nightly Gnome and reinstalled.Then used synaptic and
retrieved unity 7. No problems now. I have gnome, cairo, lxde, and unity
desktop environments. All running perfectly!!!

On Sun, Oct 12, 2014 at 4:53 PM, Logan Rosen <email address hidden> wrote:

> ** Tags removed: bugpattern-needed
>
> ** Tags added: bugpattern-written
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1366602).
> https://bugs.launchpad.net/bugs/1366351
>
> Title:
> compiz crashed with SIGSEGV in g_closure_invoke()
>
> Status in Compiz:
> Confirmed
> Status in “compiz” package in Ubuntu:
> Triaged
>
> Bug description:
> Issue on booting into unity
>
> ProblemType: Crash
> DistroRelease: Ubuntu 14.10
> Package: compiz-core 1:0.9.12+14.10.20140812-0ubuntu1
> ProcVersionSignature: Ubuntu 3.16.0-13.19-generic 3.16.1
> Uname: Linux 3.16.0-13-generic x86_64
> NonfreeKernelModules: fglrx
> .tmp.unity.support.test.0:
>
> ApportVersion: 2.14.7-0ubuntu2
> Architecture: amd64
> CompizPlugins: No value set for
> `/apps/compiz-1/general/screen0/options/active_plugins'
> CompositorRunning: compiz
> CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
> CompositorUnredirectFSW: true
> CurrentDesktop: Unity
> Date: Sat Sep 6 10:48:43 2014
> Disassembly: => 0x0: Cannot access memory at address 0x0
> DistUpgraded: 2014-09-01 18:03:23,330 DEBUG enabling apt cron job
> DistroCodename: utopic
> DistroVariant: ubuntu
> ExecutablePath: /usr/bin/compiz
> GraphicsCard:
> Advanced Micro Devices, Inc. [AMD/ATI] Curacao XT [Radeon R9 270X]
> [1002:6810] (prog-if 00 [VGA controller])
> Subsystem: ASUSTeK Computer Inc. Device [1043:04a1]
> InstallationDate: Installed on 2014-03-24 (166 days ago)
> InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64
> (20131016.1)
> MachineType: MSI MS-7640
> ProcCmdline: compiz
> ProcEnviron:
> PATH=(custom, no user)
> SHELL=/bin/bash
> LD_LIBRARY_PATH=<set>
> LANG=en_US.UTF-8
> XDG_RUNTIME_DIR=<set>
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.16.0-13-generic
> root=UUID=2696ea28-d88b-431c-a1fa-1e0f297ee664 ro quiet splash vt.handoff=7
> SegvAnalysis:
> Segfault happened at: 0x0: Cannot access memory at address 0x0
> PC (0x00000000) not located in a known VMA region (needed executable
> region)!
> SegvReason: executing NULL VMA
> Signal: 11
> SourcePackage: compiz
> StacktraceTop:
> ?? ()
> g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
> ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
> g_signal_emit_valist () from
> /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
> g_signal_emit () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
> Title: compiz crashed with SIGSEGV in g_closure_invoke()
> UpgradeStatus: Upgraded to utopic on 2014-09-01 (4 days ago)
> UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
> dmi.bios.date: 10/31/2012
> dmi.bios.vendor: American Megatrends Inc.
> dmi.bios.version: V1.15
> dmi.board.asset.tag: To Be Filled By O.E.M.
> dmi.board.name: 890FXA-GD70 (MS-7640)
> dmi.board.vend...

Read more...

The problem for me seems to be the nouveau -video driver, and after i suspend my laptop does not wake up. A hard reboot is the only option. With the Nvidia Proprietary Driver this problem does not appear.

.tmp.unity.support.test.0:

ApportVersion: 2.14.7-0ubuntu5
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
DistUpgraded: Fresh install
DistroCodename: utopic
DistroRelease: Ubuntu 14.10
DistroVariant: ubuntu
DkmsStatus: fwts-efi-runtime-dkms, 14.09.00, 3.16.0-22-generic, x86_64: installed
GraphicsCard:
 Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: CLEVO/KAPOK Computer Device [1558:2702]
MachineType: System76, Inc. Gazelle Professional
Package: compiz 1:0.9.12+14.10.20140918-0ubuntu1
PackageArchitecture: all
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.16.0-22-generic root=UUID=064d0a3c-fd57-42ec-9109-05c068698848 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.16.0-22.29-generic 3.16.4
Tags: utopic utopic ubuntu compiz-0.9
Uname: Linux 3.16.0-22-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 05/16/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 4.6.5
dmi.board.asset.tag: Tag 12345
dmi.board.name: Gazelle Professional
dmi.board.vendor: System76, Inc.
dmi.board.version: gazp7
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 9
dmi.chassis.vendor: No Enclosure
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr4.6.5:bd05/16/2012:svnSystem76,Inc.:pnGazelleProfessional:pvrgazp7:rvnSystem76,Inc.:rnGazelleProfessional:rvrgazp7:cvnNoEnclosure:ct9:cvrN/A:
dmi.product.name: Gazelle Professional
dmi.product.version: gazp7
dmi.sys.vendor: System76, Inc.
version.compiz: compiz 1:0.9.12+14.10.20140918-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.56-1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.3.0-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.3.0-0ubuntu3
version.xserver-xorg-core: xserver-xorg-core 2:1.16.0-1ubuntu1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.9.0-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.4.0-2ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.914-1~exp1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.11-1ubuntu2
xserver.bootTime: Mon Oct 13 10:33:02 2014
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 16562
 vendor LEN
xserver.version: 2:1.16.0-1ubuntu1

tags: added: apport-collected

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Jason, please don't run an apport-collect if you're not asked to. This adds a lot of clutter to the bug (and a lot of notification emails).

Jason Gerard DeRose (jderose) wrote :

@Logan: gotcha, applogies!

Marco Trevisan mentioned on Google+ that a trace made when the glib and gtk dbg packages were installed would be helpul, but I probably didn't submit the trace in the way he intended.

He also said to install compiz and unity dbg packages, but I can't seem to find them. Are they built for Utopic, or do I need to build them myself?

Here's how you can get these symbols: https://wiki.ubuntu.com/DebuggingProgramCrash#Debug_Symbol_Packages

Also, it looks like that no stacktrace has been generated for you.

jerrylamos (jerrylamos) wrote :

Got the internal failure again on latest upgrade. Wondering about RC in a few days...

DISTRIB_DESCRIPTION="Ubuntu Utopic Unicorn (development branch)"
Linux Acer5253 3.16.0-22-generic #29-Ubuntu SMP Thu Oct 9 16:26:18 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Wrestler [Radeon HD 6310]
model name : AMD E-350 Processor
model name : AMD E-350 Processor

jerrylamos (jerrylamos) wrote :

Updated utopic beta today 13 Oct and compiz crashed again
Intel Core 2 Duo

Some sort of Xserver 64 bit update I don't know what log to look in to see the details?

Anyway, still crashed.
This is an Intel desktop crash see below, my AMD ATI notebook crashed earlier today Commnt #60

DISTRIB_DESCRIPTION="Ubuntu Utopic Unicorn (development branch)"
Linux Lenovo2 3.16.0-22-generic #29-Ubuntu SMP Thu Oct 9 16:26:18 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
model name : Intel(R) Core(TM)2 Duo CPU E8400 @ 3.00GHz
model name : Intel(R) Core(TM)2 Duo CPU E8400 @ 3.00GHz
00:02.0 VGA compatible controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)

Martin Pitt (pitti) wrote :

I'm being haunted by this for two days now, since I use my laptop's internal display (conference). This never happens at home with the external monitor. It crashes every few minutes and is unbearable; I found that disabling multiple workspaces helps a lot to calm it down.

Martin Pitt (pitti) on 2014-10-14
description: updated
summary: - compiz crashed with SIGSEGV in g_closure_invoke()
+ compiz crashed with SIGSEGV in g_closure_invoke() if unity-settings-
+ daemon goes away
Radu (radunem) on 2014-10-14
Changed in compiz (Ubuntu):
status: Triaged → Confirmed
affects: compiz → compiz-core-ubuntu
affects: compiz-core-ubuntu → nouveau
Martin Pitt (pitti) on 2014-10-14
affects: nouveau → compiz
Changed in compiz (Ubuntu):
status: Confirmed → Triaged
Stephen M. Webb (bregma) on 2014-10-15
Changed in unity:
importance: Undecided → Critical
status: New → In Progress
Changed in unity (Ubuntu):
importance: Undecided → Critical
status: New → In Progress
Changed in compiz:
status: Confirmed → Invalid
Changed in compiz (Ubuntu):
status: Triaged → Invalid
Changed in unity:
assignee: nobody → Brandon Schaefer (brandontschaefer)
Stephen M. Webb (bregma) wrote :

Note: this is likely triggered by bug #1380278

Changed in unity:
assignee: Brandon Schaefer (brandontschaefer) → Marco Trevisan (Treviño) (3v1n0)
jerrylamos (jerrylamos) wrote :

Whoopsie, got another crash after the update in comment #14 in bug # 1380278 which on the surface looks like comment #12 in Bug # 1380278 ......

So whatever may be in:

"This bug was fixed in the package unity-settings-daemon - 14.04.0+14.10.20141014-0ubuntu1"

after shutdown, boot I still got another crash....

Buzzing Robot (buzzingrobot) wrote :

Just happened here changing font settings in Unity Tweak Tool. On a fresh install of 14.10 using today's (15 Oct) daily and fully updated. unity-settings-daemon = 14.04.0+14.10.20141014.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.3.1+14.10.20141015-0ubuntu1

---------------
unity (7.3.1+14.10.20141015-0ubuntu1) utopic; urgency=low

  [ Iain Lane ]
  * When grabbing keys, try prefixing "XF86" if the key isn't found.
    GNOME gives us unprefixed keys sometimes. (LP: #1302885)

  [ Brandon Schaefer ]
  * Remove bad tests that randomly fail

  [ handsome_feng<email address hidden> ]
  * added support for getting the distro name from /etc/os-release (LP:
    #1329584)

  [ Marco Trevisan (Treviño) ]
  * LockScreenController: wait the primary shield to get the grab before
    setting the session locked
  * GLibSignal: don't call callback function if the object_ value is not
    matching the CB (LP: #1366351)
 -- Ubuntu daily release <email address hidden> Wed, 15 Oct 2014 12:56:50 +0000

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Changed in unity:
status: In Progress → Fix Committed
jerrylamos (jerrylamos) wrote :

vivid .iso boots to black screen.
Ctrl-Alt-F1 sign in,
ls /var/crash
_usr_bin_compiz.1000.crash

sudo service lightdm restart
was able to install.

Booted after install, got intermittently flashing wallpaper.
Ctrl-Alt-F1 sign in
ls /var/crash
_usr_bin_compiz.1000.crash

up and running. Tried a
sudo ubuntu-bug _usr_bin_compiz.1000.crash
got the drop down message about an internal error
Asked to report the bug.
that's all. Ubuntu-bug never went to launchpad.

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=15.04
DISTRIB_CODENAME=vividVGA compatible controller: Intel Corporation Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics Controller
DISTRIB_DESCRIPTION="Ubuntu Vivid Vervet (development branch)"
3.16.0-24-generic #32-Ubuntu SMP Tue Oct 28 13:07:32 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
VGA compatible controller: Intel Corporation Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics Controller

Has been running utopic fine since mid September.

Does this look like similar unity problems as in Bug #1366351 comment #66?

Thanks.

Jerry,

If you still have that crash file, install unity debug symbols (see https://wiki.ubuntu.com/DebuggingProgramCrash#Debug_Symbol_Packages) and do:

apport-unpack /var/crash/_usr_bin_compiz.1000.crash /tmp/unity-crash

Then:
  gdb /usr/bin/compiz /tmp/unity-crash/CoreDump

At this point, do:
  bt full

And post the output here

jerrylamos (jerrylamos) wrote :
Download full text (4.3 KiB)

Thanks for looking at the bug. Following your instructions, got this:

jerry@jerry-AOD255E:~$ sudo gdb /usr/bin/compiz /tmp/unity-crash/CoreDump
GNU gdb (Ubuntu 7.8-1ubuntu4) 7.8.0.20141001-cvs
Copyright (C) 2014 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from /usr/bin/compiz...(no debugging symbols found)...done.
[New LWP 2018]
[New LWP 2023]
[New LWP 2045]
[New LWP 2534]
[New LWP 2046]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
Core was generated by `compiz'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0 0x00007f4ebcc67439 in unity::UnityScreen::paintDisplay (this=this@entry=0xb0f000)
    at /build/buildd/unity-7.3.1+14.10.20141016/plugins/unityshell/src/unityshell.cpp:837
837 /build/buildd/unity-7.3.1+14.10.20141016/plugins/unityshell/src/unityshell.cpp: No such file or directory.

(gdb) bt full
#0 0x00007f4ebcc67439 in unity::UnityScreen::paintDisplay (this=this@entry=0xb0f000)
    at /build/buildd/unity-7.3.1+14.10.20141016/plugins/unityshell/src/unityshell.cpp:837
        blur_region = {priv = 0x1cdee60}
        gpu_device = <optimized out>
        backup_texture_id = <optimized out>
        surface_target = <optimized out>
        output = 0x65fa20
        current_draw_binding = 1
        old_read_binding = 1
        outputGeo = <optimized out>
#1 0x00007f4ebcc6779a in unity::UnityScreen::glPaintOutput (this=0xb0f000, attrib=..., transform=..., region=..., output=0x65fa20, mask=3)
    at /build/buildd/unity-7.3.1+14.10.20141016/plugins/unityshell/src/unityshell.cpp:1421
        ret = true
        force = false
#2 0x00007f4ec7bdc7c8 in GLScreen::glPaintOutput(GLScreenPaintAttrib const&, GLMatrix const&, CompRegion const&, CompOutput*, unsigned int)
    () from /usr/lib/compiz/libopengl.so
No symbol table info available.
#3 0x00007f4ec7be4415 in PrivateGLScreen::paintOutputs(std::list<CompOutput*, std::allocator<CompOutput*> >&, unsigned int, CompRegion const&) () from /usr/lib/compiz/libopengl.so
No symbol table info available.
#4 0x00007f4ed42f81d6 in CompositeScreen::paint(std::list<CompOutput*, std::allocator<CompOutput*> >&, unsigned int) ()
   from /usr/lib/compiz/libcomposite.so
---Type <return> to continue, or q <return> to quit---
No symbol table info available.
#5 0x00007f4ed42fb92c in CompositeScreen::handlePaintTimeout() () from /usr/lib/compiz/libcomposite.so
No symbol table info available.
#6 0x00007f4edc5a31ed in CompTimer::triggerCallback() () from /usr/lib/libcompiz_core.so.ABI-20140123...

Read more...

Thanks, it seems indeed another problem.

Can you please open another bug (like "unity crashes in unity::UnityScreen::paintDisplay", using ubuntu-bug /var/crash/_usr_bin_compiz.1000.crash)?

It would also be nice, if you could (from gdb), do:
  print gpu_device
  print *gpu_device
  print gpu_device->backup_texture0_
  print *(gpu_device->backup_texture0_)
  print gpu_device->backup_texture0_->_NumMipLevel
  print gpu_device->backup_texture0_->_SurfaceArray

jerrylamos (jerrylamos) wrote :

Will do. Thanks for the directions.

jerrylamos (jerrylamos) wrote :

Will try to generate another bug. Meanwhile here's the printout from the gdb commands:

.... similar to above....
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
Core was generated by `compiz'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0 0x00007f4ebcc67439 in unity::UnityScreen::paintDisplay (
    this=this@entry=0xb0f000)
    at /build/buildd/unity-7.3.1+14.10.20141016/plugins/unityshell/src/unityshell.cpp:837
837 /build/buildd/unity-7.3.1+14.10.20141016/plugins/unityshell/src/unityshell.cpp: No such file or directory.
(gdb) print gpu_deviceUsing host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
Core was generated by `compiz'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0 0x00007f4ebcc67439 in unity::UnityScreen::paintDisplay (
    this=this@entry=0xb0f000)
    at /build/buildd/unity-7.3.1+14.10.20141016/plugins/unityshell/src/unityshell.cpp:837
837 /build/buildd/unity-7.3.1+14.10.20141016/plugins/unityshell/src/unityshell.cpp: No such file or directory.
(gdb) print gpu_device
$1 = <optimized out>
(gdb) print *gpu_device
value has been optimized out
(gdb) print gpu_device->backup_texture0_
value has been optimized out
(gdb) print *(gpu_device->backup_texture0_)
value has been optimized out
(gdb) print gpu_device->backup_texture0_->_NumMipLevel
value has been optimized out
(gdb) print gpu_device->backup_texture0_->_SurfaceArray
value has been optimized out
(gdb)

$1 = <optimized out>
(gdb) print *gpu_device
value has been optimized out
(gdb) print gpu_device->backup_texture0_
value has been optimized out
(gdb) print *(gpu_device->backup_texture0_)
value has been optimized out
(gdb) print gpu_device->backup_texture0_->_NumMipLevel
value has been optimized out
(gdb) print gpu_device->backup_texture0_->_SurfaceArray
value has been optimized out
(gdb)

?

BTW, zsync daily build on 11/06, iso booted to same symptoms.

jerrylamos (jerrylamos) wrote :

Tried
sudo ubuntu-bug /var/crash/_usr_bin_compiz.1000.crash
get a drop down message that ubuntu has experienced an internal error.

Nothing else.

Tried removing the *upload and *uploaded files, same thing. Nothing past the first drop down...

Any ideas?

Maybe install the new .iso and try ubuntu-bug on that one. Too late tonight.

Thanks

jerrylamos (jerrylamos) wrote :

I downloaded a new .iso. same bug occurred on both booting the .iso and booting the install.

In Comment #70 Marco suggested:

"Can you please open another bug (like "unity crashes in unity::UnityScreen::paintDisplay", using ubuntu-bug /var/crash/_usr_bin_compiz.1000.crash)?"

Does not work. I get the drop down window "Sorry. ubuntu has experienced an internal error..."
I select Continue, and nothing visible happens.
There are two new files:

_usr_bin_compiz.1000.upload
_usr_bin_compiz.1000.uploaded

but a bug is never processed.

I think ubuntu-bug has found a way to reduce the number of bugs reported....

Thanks anyway, Jerry

Changed in unity:
status: Fix Committed → Fix Released
Derrick (derrick-j3000) wrote :

I'm still getting this issue, every time the computer turns on. This is Ubunutu 14.04.1 . Attached is my unity7.log . Let me know if there's anything I can do to help....

Frank (starcmn) wrote :

I had this issue after booting into Unity very often but not all the time with an AMD Athlon(tm) 5350 APU with Radeon(tm) R3.

At first I connected a second monitor to the system (first monitor is connected via DVI port, second monitor via HDMI port). Thereafter I realized that this monitor was not necessary for all my work and decided to temporarily turn off the second monitor in the unity system settings (via section "Displays").
Later, I disconnected the second monitor completely and left the "disabled" setting unchanged for this monitor in the Unity system settings (section "Displays"). Thereafter, I observed this issue on the computer and the pain started.

A few days ago, I reconnected the second monitor again, changed the Unity system settings back to "enabled", and disconnected the monitor again. Until now, I have not observed this issue any more. I will keep an eye on it.

Is it possible that there is a race condition in the code and Unity tries to disable a monitor that is not connected to the system at that time?

Maybe this comment will help other people. I will add a line to this comment if I see this issue again within the next few days.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers