compiz crashed with SIGSEGV in g_closure_invoke()

Bug #1377919 reported by Tarmo on 2014-10-06
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

Every time I start Ubuntu, system reports crash. I have 3-monitor setup, 2 external monitors+ laptop screen.

ProblemType: Crash
DistroRelease: Ubuntu 14.10
Package: compiz-core 1:0.9.12+14.10.20140918-0ubuntu1
ProcVersionSignature: Ubuntu 3.16.0-20.27-generic 3.16.3
Uname: Linux 3.16.0-20-generic x86_64
NonfreeKernelModules: wl
.tmp.unity.support.test.0:

ApportVersion: 2.14.7-0ubuntu3
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CrashCounter: 1
CurrentDesktop: Unity
Date: Mon Oct 6 15:36:45 2014
Disassembly: => 0x0: Cannot access memory at address 0x0
DistUpgraded: 2014-09-24 16:00:24,522 ERROR SystemError from cache.commit(): installArchives() failed
DistroCodename: utopic
DistroVariant: ubuntu
DkmsStatus:
 bcmwl, 6.30.223.248+bdcom, 3.16.0-18-generic, x86_64: installedError! Could not locate dkms.conf file.
 File: does not exist.

 bcmwl, 6.30.223.248+bdcom, 3.16.0-20-generic, x86_64: installed
ExecutablePath: /usr/bin/compiz
GraphicsCard:
 Intel Corporation Haswell-ULT Integrated Graphics Controller [8086:0a16] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Device [103c:1991]
InstallationDate: Installed on 2014-05-20 (138 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
MachineType: Hewlett-Packard HP EliteBook 820 G1
ProcCmdline: compiz
ProcEnviron:
 PATH=(custom, no user)
 LANGUAGE=et
 XDG_RUNTIME_DIR=<set>
 LANG=et_EE.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.16.0-20-generic root=UUID=4b016ce0-70b4-42f6-859c-aeaf06807b02 ro quiet splash vt.handoff=7
SegvAnalysis:
 Segfault happened at: 0x0: Cannot access memory at address 0x0
 PC (0x00000000) not located in a known VMA region (needed executable region)!
SegvReason: executing NULL VMA
Signal: 11
SourcePackage: compiz
StacktraceTop:
 ?? ()
 g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_signal_emit_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_signal_emit () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: compiz crashed with SIGSEGV in g_closure_invoke()
UpgradeStatus: Upgraded to utopic on 2014-09-24 (11 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo vboxusers
dmi.bios.date: 02/19/2014
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: L71 Ver. 01.08
dmi.board.name: 1991
dmi.board.vendor: Hewlett-Packard
dmi.board.version: KBC Version 15.54
dmi.chassis.asset.tag: CNU3489QPJ
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvrL71Ver.01.08:bd02/19/2014:svnHewlett-Packard:pnHPEliteBook820G1:pvrA3009DD10303:rvnHewlett-Packard:rn1991:rvrKBCVersion15.54:cvnHewlett-Packard:ct10:cvr:
dmi.product.name: HP EliteBook 820 G1
dmi.product.version: A3009DD10303
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz 1:0.9.12+14.10.20140918-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.56-1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.3.0-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.3.0-0ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.16.0-1ubuntu1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.9.0-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.4.0-2ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.914-1~exp1ubuntu3
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.11-1ubuntu2
xserver.bootTime: Mon Oct 6 15:36:29 2014
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 8300
 vendor AUO
xserver.version: 2:1.16.0-1ubuntu1

Tarmo (tarmo-palm) wrote :
information type: Private → Public

Thank you for taking the time to report this crash and helping to make this software better. This particular crash has already been reported and is a duplicate of bug #1366351, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

tags: removed: need-amd64-retrace
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers