compiz crashed with SIGSEGV in g_closure_invoke()

Bug #1378135 reported by Trevor Wermund on 2014-10-06
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

I logged in with a secondary monitor attached and compiz crashed and reloaded

Description: Ubuntu Utopic Unicorn (development branch)
Release: 14.10

compiz:
  Installed: 1:0.9.12+14.10.20140918-0ubuntu1
  Candidate: 1:0.9.12+14.10.20140918-0ubuntu1
  Version table:
 *** 1:0.9.12+14.10.20140918-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ utopic/main amd64 Packages
        100 /var/lib/dpkg/status

ProblemType: Crash
DistroRelease: Ubuntu 14.10
Package: compiz-core 1:0.9.12+14.10.20140918-0ubuntu1
ProcVersionSignature: Ubuntu 3.16.0-20.27-generic 3.16.3
Uname: Linux 3.16.0-20-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.14.7-0ubuntu3
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CrashCounter: 1
CurrentDesktop: Unity
Date: Mon Oct 6 18:06:33 2014
Disassembly: => 0x0: Cannot access memory at address 0x0
DistUpgraded: 2014-09-21 21:51:51,194 DEBUG failed to SystemUnLock() (E:Not locked)
DistroCodename: utopic
DistroVariant: ubuntu
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/compiz
GraphicsCard:
 Intel Corporation Haswell-ULT Integrated Graphics Controller [8086:0a16] (rev 0b) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:060a]
InstallationDate: Installed on 2014-09-04 (32 days ago)
InstallationMedia: Ubuntu 14.04.1 LTS "Trusty Tahr" - Release amd64 (20140722.2)
MachineType: Dell Inc. XPS13 9333
ProcCmdline: compiz
ProcEnviron:
 PATH=(custom, no user)
 LANGUAGE=en_US
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/zsh
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.16.0-20-generic root=UUID=a58ae31a-d9e6-41cb-a3be-3944688fa6a8 ro quiet splash vt.handoff=7
SegvAnalysis:
 Segfault happened at: 0x0: Cannot access memory at address 0x0
 PC (0x00000000) not located in a known VMA region (needed executable region)!
SegvReason: executing NULL VMA
Signal: 11
SourcePackage: compiz
StacktraceTop:
 ?? ()
 g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_signal_emit_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_signal_emit () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: compiz crashed with SIGSEGV in g_closure_invoke()
UpgradeStatus: Upgraded to utopic on 2014-09-22 (14 days ago)
UserGroups: adm cdrom dip docker lpadmin plugdev sambashare sudo
dmi.bios.date: 03/19/2014
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A04
dmi.board.name: 0D13CR
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: 0.1
dmi.modalias: dmi:bvnDellInc.:bvrA04:bd03/19/2014:svnDellInc.:pnXPS139333:pvr:rvnDellInc.:rn0D13CR:rvrA00:cvnDellInc.:ct8:cvr0.1:
dmi.product.name: XPS13 9333
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.12+14.10.20140918-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.56-1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.3.0-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.3.0-0ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.16.0-1ubuntu1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.9.0-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.4.0-2ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.914-1~exp1ubuntu3
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.11-1ubuntu2
xserver.bootTime: Mon Oct 6 18:06:02 2014
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 4933
 vendor CMN
xserver.version: 2:1.16.0-1ubuntu1

Trevor Wermund (twermund) wrote :

Thank you for taking the time to report this crash and helping to make this software better. This particular crash has already been reported and is a duplicate of bug #1366351, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

information type: Private → Public
tags: removed: need-amd64-retrace
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers