Comment 24 for bug 1366351

Hi

Nothing out of the ordinary going on here and it doesn’t happen every time. Don’t you just love intermittent faults.

Sent from Windows Mail

From: Brandon Schaefer
Sent: ‎Thursday‎, ‎9‎ ‎October‎ ‎2014 ‎22‎:‎11
To: ICE - Fran

Hmm i just cant reproduce this issue :(.

Do you have multi monitors? Do you still get the crash when you have a
password? Anything else you have set up that is different then a default
install?

We have some ideas, but we cant really confirm a fix at all until we
have someone who can reproduce it!

--
You received this bug notification because you are subscribed to a
duplicate bug report (1368807).
https://bugs.launchpad.net/bugs/1366351

Title:
  compiz crashed with SIGSEGV in g_closure_invoke()

Status in Compiz:
  Confirmed
Status in “compiz” package in Ubuntu:
  Triaged

Bug description:
  Issue on booting into unity

  ProblemType: Crash
  DistroRelease: Ubuntu 14.10
  Package: compiz-core 1:0.9.12+14.10.20140812-0ubuntu1
  ProcVersionSignature: Ubuntu 3.16.0-13.19-generic 3.16.1
  Uname: Linux 3.16.0-13-generic x86_64
  NonfreeKernelModules: fglrx
  .tmp.unity.support.test.0:

  ApportVersion: 2.14.7-0ubuntu2
  Architecture: amd64
  CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: compiz
  CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
  CompositorUnredirectFSW: true
  CurrentDesktop: Unity
  Date: Sat Sep 6 10:48:43 2014
  Disassembly: => 0x0: Cannot access memory at address 0x0
  DistUpgraded: 2014-09-01 18:03:23,330 DEBUG enabling apt cron job
  DistroCodename: utopic
  DistroVariant: ubuntu
  ExecutablePath: /usr/bin/compiz
  GraphicsCard:
   Advanced Micro Devices, Inc. [AMD/ATI] Curacao XT [Radeon R9 270X] [1002:6810] (prog-if 00 [VGA controller])
     Subsystem: ASUSTeK Computer Inc. Device [1043:04a1]
  InstallationDate: Installed on 2014-03-24 (166 days ago)
  InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
  MachineType: MSI MS-7640
  ProcCmdline: compiz
  ProcEnviron:
   PATH=(custom, no user)
   SHELL=/bin/bash
   LD_LIBRARY_PATH=<set>
   LANG=en_US.UTF-8
   XDG_RUNTIME_DIR=<set>
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.16.0-13-generic root=UUID=2696ea28-d88b-431c-a1fa-1e0f297ee664 ro quiet splash vt.handoff=7
  SegvAnalysis:
   Segfault happened at: 0x0: Cannot access memory at address 0x0
   PC (0x00000000) not located in a known VMA region (needed executable region)!
  SegvReason: executing NULL VMA
  Signal: 11
  SourcePackage: compiz
  StacktraceTop:
   ?? ()
   g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
   ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
   g_signal_emit_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
   g_signal_emit () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
  Title: compiz crashed with SIGSEGV in g_closure_invoke()
  UpgradeStatus: Upgraded to utopic on 2014-09-01 (4 days ago)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  dmi.bios.date: 10/31/2012
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: V1.15
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: 890FXA-GD70 (MS-7640)
  dmi.board.vendor: MSI
  dmi.board.version: 1.0
  dmi.chassis.asset.tag: To Be Filled By O.E.M.
  dmi.chassis.type: 3
  dmi.chassis.vendor: MSI
  dmi.chassis.version: 1.0
  dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrV1.15:bd10/31/2012:svnMSI:pnMS-7640:pvr1.0:rvnMSI:rn890FXA-GD70(MS-7640):rvr1.0:cvnMSI:ct3:cvr1.0:
  dmi.product.name: MS-7640
  dmi.product.version: 1.0
  dmi.sys.vendor: MSI
  version.compiz: compiz 1:0.9.12+14.10.20140812-0ubuntu1
  version.fglrx-installer: fglrx-installer N/A
  version.ia32-libs: ia32-libs N/A
  version.libdrm2: libdrm2 2.4.56-1
  version.libgl1-mesa-dri: libgl1-mesa-dri 10.2.6-1ubuntu3
  version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
  version.libgl1-mesa-glx: libgl1-mesa-glx 10.2.6-1ubuntu3
  version.xserver-xorg-core: xserver-xorg-core 2:1.15.1-0ubuntu9
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.9.0-1ubuntu1
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.4.0-2ubuntu1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.914-1~exp1ubuntu1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.10-1ubuntu2
  xserver.bootTime: Sat Sep 6 10:48:05 2014
  xserver.configfile: default
  xserver.errors:
   open /dev/dri/card0: No such file or directory
   AIGLX error: failed to open /usr/X11R6/lib64/modules/dri/fglrx_dri.so, error[/usr/X11R6/lib64/modules/dri/fglrx_dri.so: cannot open shared object file: No such file or directory]
   AIGLX error: failed to open /usr/lib64/dri/fglrx_dri.so, error[/usr/lib64/dri/fglrx_dri.so: cannot open shared object file: No such file or directory]
   AIGLX error: failed to open /usr/X11R6/lib/modules/dri/fglrx_dri.so, error[/usr/X11R6/lib/modules/dri/fglrx_dri.so: cannot open shared object file: No such file or directory]
  xserver.logfile: /var/log/Xorg.0.log
  xserver.version: 2:1.15.1-0ubuntu9
  xserver.video_driver: fglrx

To manage notifications about this bug go to:
https://bugs.launchpad.net/compiz/+bug/1366351/+subscriptions