Ubuntu

[regression] Unmaximized windows can't be closed, minimized, moved

Reported by Alfred Neumayer on 2013-03-21
524
This bug affects 114 people
Affects Status Importance Assigned to Milestone
Compiz
Critical
Unassigned
0.9.9
Critical
Unassigned
compiz (Ubuntu)
Critical
Unassigned

Bug Description

Problems with MAXIMIZED windows are tracked in bug 1158267. If you still experience problems with UNMAXIMIZED windows, please report a new bug.

----

Revision #3635 or #3636 must have introduced a regression that causes the titlebar and borders to not respond to actions like minimizing, maximizing, closing and resizing.

REGRESSION cause by this merge:
https://code.launchpad.net/~compiz-team/compiz/compiz.fix_1138517/+merge/152623

How to reproduce:
1) Open a Nautilus window.
2) Maximize the window either by pressing the maximize button or dragging the window up to the top
3) Unmaximize the window either through the minimize button or dragging the window
4) Resizing, Closing, Moving etc fails

However, moving the window by holding [Alt] works.
This bug occurs even after resetting the compiz configuration.
Tested on an Acer TimelineU M5-481TG, display resolution 1366x768.

Shadows also don't work for some reason.

It's fixed for Unity, but for some reason it's not for the rest of desktop environments: confirmed under GNOME Fall-back and MATE.

lsb_release:
Description: Ubuntu Raring Ringtail (development branch)
Release: 13.04

apt-cache policy compiz:
compiz:
  Installiert: 1:0.9.9~daily13.03.20-0ubuntu1
  Installationskandidat: 1:0.9.9~daily13.03.20-0ubuntu1
  Versionstabelle:
 *** 1:0.9.9~daily13.03.20-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ raring/main amd64 Packages
        100 /var/lib/dpkg/status

ProblemType: BugDistroRelease: Ubuntu 13.04
Package: compiz 1:0.9.9~daily13.03.20-0ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-13.23-generic 3.8.3
Uname: Linux 3.8.0-13-generic x86_64
.tmp.unity.scope.gourmet: Error: [Errno 21] Ist ein Verzeichnis: '/tmp/unity-scope-gourmet'
.tmp.unity.support.test.0:

ApportVersion: 2.9.2-0ubuntu2
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
Date: Thu Mar 21 08:14:58 2013
DistUpgraded: Fresh install
DistroCodename: raring
DistroVariant: ubuntu
DkmsStatus:
 bbswitch, 0.6, 3.8.0-13-generic, x86_64: installed
 nvidia-313-updates, 313.26, 3.8.0-13-generic, x86_64: installed
 vboxhost, 4.2.10, 3.8.0-13-generic, x86_64: installed
GraphicsCard:
 Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Acer Incorporated [ALI] Device [1025:0713]
 NVIDIA Corporation Device [10de:0fd3] (rev ff) (prog-if ff)
MachineType: Acer Aspire M5-481TG
MarkForUpload: True
PackageArchitecture: all
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.8.0-13-generic root=UUID=d67047dc-d9af-4097-8c13-0c46dc017014 ro quiet splash i915_enable_rc6=1 pcie_aspm=force acpi_backlight=vendor acpi_osi=LinuxSourcePackage: compiz
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/23/2012
dmi.bios.vendor: Insyde Corp.
dmi.bios.version: V1.05
dmi.board.asset.tag: Type2 - Board Asset Tag
dmi.board.name: MA40_HX
dmi.board.vendor: Acer
dmi.board.version: Type2 - Board Version
dmi.chassis.type: 10
dmi.chassis.vendor: Chassis Manufacturer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnInsydeCorp.:bvrV1.05:bd08/23/2012:svnAcer:pnAspireM5-481TG:pvrV1.05:rvnAcer:rnMA40_HX:rvrType2-BoardVersion:cvnChassisManufacturer:ct10:cvrChassisVersion:
dmi.product.name: Aspire M5-481TG
dmi.product.version: V1.05
dmi.sys.vendor: Acer
version.compiz: compiz 1:0.9.9~daily13.03.20-0ubuntu1
version.ia32-libs: ia32-libs 20090808ubuntu36
version.libdrm2: libdrm2 2.4.42-0ubuntu2
version.libgl1-mesa-dri: libgl1-mesa-dri 9.0.3-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.0.3-0ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.13.3-0ubuntu2b1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu2b2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.1.0-0ubuntu1b1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.21.4-0ubuntu1b1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.6-0ubuntu3b1
xserver.bootTime: Thu Mar 21 08:01:35 2013
xserver.configfile: /etc/X11/xorg.conf
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.13.3-0ubuntu2b1
xserver.video_driver: intel

Related branches

lp:~compiz-team/compiz/compiz.fix_1158161
Merged into lp:compiz/0.9.9 at revision 3635
MC Return: Needs Fixing on 2013-03-23
PS Jenkins bot: Approve (continuous-integration) on 2013-03-23
Łukasz Zemczak: Approve on 2013-03-22
Alfred Neumayer (community): Approve on 2013-03-22
Sam Spilsbury: Pending requested 2013-03-22
lp:~mterry/compiz/unmaximize-regression
Merged into lp:compiz/raring at revision 3639
PS Jenkins bot: Approve (continuous-integration) on 2013-03-22
Łukasz Zemczak: Approve on 2013-03-22
Alfred Neumayer (beidl) wrote :
description: updated
description: updated
Alfred Neumayer (beidl) on 2013-03-21
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Changed in compiz (Ubuntu):
importance: Undecided → High
summary: - Unmaximized windows can't be closed, minimized, moved
+ [regression] Unmaximized windows can't be closed, minimized, moved
Changed in compiz (Ubuntu):
status: Confirmed → Triaged
Changed in compiz:
status: New → Triaged
importance: Undecided → High
milestone: none → 0.9.9.2
description: updated
Sam Spilsbury (smspillaz) wrote :

Gosh the decoration code is such a disaster. I'll get on to this ASAP.

Changed in compiz:
importance: High → Critical
assignee: nobody → Sam Spilsbury (smspillaz)
description: updated
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:compiz/raring at revision 3639, scheduled for release in compiz, milestone Unknown

Changed in compiz:
status: Triaged → Fix Committed
Changed in compiz (Ubuntu):
importance: High → Critical
status: Triaged → Fix Committed
assignee: nobody → Sam Spilsbury (smspillaz)

Thanks for taking care of this fast Sam!

PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:compiz at revision None, scheduled for release in compiz, milestone 0.9.9.2

ettore (sonbello) wrote :

hello, I confirm the bug installed yesterday, when I open a window and I minimize and then does not move more, not maximize.
bye

ettore (sonbello) wrote :

 i have installed raring.

Adam Bruce (brucey-99) wrote :

ettore, please make sure you have all latest updates applied.

Adam Bruce (brucey-99) wrote :

Hmm, after thinking this was fixed I seem to have hit the bug again..

Nate Wiebe (natew) wrote :

You guys do realized, the fix has been comitted, but not released right?

You have to build compiz yourself at this point for you to have the fix, or wait until the new version is released. The bug status will change to "Fix Released" when it is released.

Adam Bruce (brucey-99) wrote :

Oh, sorry, just realised it says Fix Committed, not Released

Rafael Medina (gex-ux64) wrote :

Cannot close, Minimize or unmaximize windows Like "Terminal" or "Firefox", this is happening randomly. When mouse icon pass over the controls, they cant "light". When i press over them, the windows lose the focus and if there are others behind, the focus change to them.

WorkArroud.

Unmaximize Window. After doing this the controls can respond in the window affected by this bug.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/1158161

tags: added: package-qa-testing
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.9~daily13.03.25-0ubuntu1

---------------
compiz (1:0.9.9~daily13.03.25-0ubuntu1) raring; urgency=low

  [ Michael Terry ]
  * [regression] Unmaximized windows can't be closed, minimized, moved
    (LP: #1158161)

  [ MC Return ]
  * Multimonitor: Grid plugin: Wrong calculation of top left mouse-grid-
    resize corner coordinates (LP: #1139835)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 3639
 -- Ubuntu daily release <email address hidden> Mon, 25 Mar 2013 04:02:57 +0000

Changed in compiz (Ubuntu):
status: Fix Committed → Fix Released
Mike L (helgalo) wrote :

Fix works great! issue 100% gone. Thanks for the timely fix. Just saying it's fixed so we can hear it from a human being. The code may be fixed, but the experience is what matters. Sometimes one thinks a bug is gone in the code and it can persist. Make sure you log off and back in to get it working after the update.

V. A. (nyappy) wrote :

Windows don't resize now. ç_ç

Jacek Nykis (jacekn) wrote :

Latest updates also fixed the problem for me, windows can be moved and resized without any problems.

Luis Alvarado (luisalvarado) wrote :

Windows are working correctly now. Resizing, moving, closing, opening multiple windows and resizing/moving each one on top of another. Everything is normal now.

Rainer Rohde (rainer-rohde) wrote :

Not quite normal, as now it somewhat breaks Guake. Before, Guake was firmly attached to the top of the screen, and now there's a noticeable gap between the top of the screen and Guake's terminal window. See screenshot attached.

This gap wasn't there before.

ctrl (dario-dariocorti) wrote :

As of 1:0.9.9~daily13.03.25-0ubuntu1, I have the exact opposite behaviour, but same issue. If an app if opened already maximized, the title bar and buttons are inaccessible (mouse clicks are handled by the underlying window or by the desktop). If I unmaximize (alt+drag) and remaximized the window, the issue disappears. If I open an app unmaximized and then maximize it, there is no issue.

Ubuntu 13.04 x64. nvidia drivers 304.84

ctrl (dario-dariocorti) wrote :

Uploaded this vid to illustrate how it behaves in my case... http://www.youtube.com/watch?v=0UotRRxGj5M

Alfred Neumayer (beidl) wrote :

I haven't tested this on any desktop environment other than Unity, so this appears to be a problem with basically any other DE when Compiz is being used as the compositor.
Has anyone tested this with an environment other that Unity or Gnome?

ctrl (dario-dariocorti) wrote :

I'm using gnome fallback

I have the same problem as ctrl on Unity in Ubuntu 13.04 x64. The problem is with qBittorrent that autostarts on system boot. It starts maximized and it's window borders are inactive

Colin Law (colin-law) wrote :

ctrl and Dmitriy: the bug described here has been fixed. The issue you are describing seems to be a different problem so there is no point mentioning it here. If you cannot find a bug that matches your symptom then report a new bug.

ctrl (dario-dariocorti) wrote :

I filed #1162447, thanks.

Changed in compiz:
milestone: 0.9.9.2 → 0.9.10.0
Simon Groot Bramel (z-simon-l) wrote :

Guys,

I'm sorry to write into this bug...

I have a similar YET DIFFERENT problem described here:
https://bugs.launchpad.net/compiz/+bug/1158267

it was marked as a duplication of this bug here but IT IS NOT!

can someone "umount" these two bugs please? I recieve emails about this one which don't solve my problems, while my own bug can't be dealt with.

thank you!

Sorry, but the bug some of you are trying to report is not the one listed here. This bug is about Compiz with Unity, not with GNOME Fallback Mode. For Unity it's fixed yet.

s0undt3ch (ufs) wrote :

I'm using compiz with KDE, no Unity, and I also have the same issue, since my recent upgraded to 13.04.

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately it's possible your problem to be of a very different nature than the one described in this bug report. Please execute the following command in a terminal, as it will automatically open a new bug and gather debugging information:
ubuntu-bug compiz

Later we will be able to check if it's a duplicate of this one.

Felix Moreno (felix-justdust) wrote :

I have the same issue win ubuntu 13.04 gnome-panel desktop, I upgraded from a 12.10 ubuntu,

Epifani Andrea (st4nny) wrote :

i have compiz 0.9.9~daily13.04.18.1~13.04-0ubuntu1 installed, gnome-panel and i have also the same issue.

Since many users are still experiencing the bug, the fix need to be reviewed.

VPablo (villumar) wrote :

I have the same problem as described on bug #1158361 with MATE as desktop and Compiz.

Strelok (who-) wrote :

I have similar but inverse problem: bug #1179247. Unlike bug #1158361, i know its not randomly, but only then application maximized.

Juan Báez Rojas (juanbaezr) wrote :

I've the same problem but on Ubuntu Gnome 13.04 + Gnome Fallback + Compiz
Workaround: use dconf-editor to change org.compiz.gwd use-metacity-theme > false

Since:

- Many users are still experiencing the bug
- The fix is only working in specific contexts, but not in all of them

The fix needs to be reviewed.

Changed in compiz (Ubuntu):
assignee: Sam Spilsbury (smspillaz) → nobody
Changed in compiz:
assignee: Sam Spilsbury (smspillaz) → nobody
Changed in compiz (Ubuntu):
status: Fix Released → Confirmed
Changed in compiz:
status: Fix Committed → Confirmed
Changed in compiz (Ubuntu):
status: Confirmed → Triaged
Adam Cajander (cajander1111) wrote :

@Juan Báez Rojas

I am also using Gnome 13.04 + Gnome Fallback + Compiz. I tried the workaround you suggested but it did not work for me. Any other suggestions? Is there something else I must do?

Thanks.

@ Alberto Salvia Novella

I too am still experiencing this issue and have been dealing with it for months. It's starting to get ridiculous. Why is the compiz team not working on this? This bug affects my notebook and my desktop. It certainly must be affecting a far greater number of users than 478. That is just a small sample. Something needs to be done about this BS. I wish I was technical enough to do it myself.

Since this bug seems so critical and overlooked for many time, I have wrote to Compiz Maintainers about it.

Sam Spilsbury (smspillaz) wrote :

I suspect that the fix for this probably hasn't been backported to 0.9.9.

Sam Spilsbury (smspillaz) wrote :

Hmm, it has been actually.

I've not run into this for a long time however though. I can do another rebuild and see if its still a problem (on the initially maximized condition)

Luis Alvarado (luisalvarado) wrote :

I am using 13.04 64 bit with Unity 7.0.0 and Compiz 0.9.9.0

It is working correctly. Tried several times to make the error appear with no luck. For the users that still have a problem, can you please provide the hardware you are using and add to this bug by issuing the following command:

apport-collect 1158161

That should help the developers narrow the problem down to your specific hardware.

As said before, it's not affecting Unity but GNOME Fall-back and MATE; so it has no relation with hardware at all, specially when I was able to reproduce the original bug with any hardware.

description: updated
Sami Jaktholm (sjakthol) wrote :

This bug is about unmaximized windows having click-trough decorations. If you really see click-trough decorations on unmaximized or user-maximized windows, this bug is not fixed. I have personally tested this with both trunk and raring version of compiz and this bug does not exist there, with or without Unity.

Now, then there's bug 1158267. If the following points apply, that's the bug you're seeing:
1) You use a non-Unity session
2) The application with click-trough decorations is _started_ maximized ("started" is is the important part here)

That's a corner case with a fix available in lp:~mar-kolya/compiz/fix-for-1158267. However, that fix is currently blocked on lack of proper test suite for the decor plugin. Once the decor has a test suite in place (bug 1188900), we can be more certain that the fix doesn't cause new regressions and it's ready to go in.

Hamed Abdy (hamed-abdy) wrote :

I'm using Ubuntu 13.04 (with Unity). The following steps causes the same problem for me:
1- Maximize a window.
2- Minimize the window using the minimize button in its titlebar.
3- Do not click anywhere! By moving your mouse on the titlebar, you can see that its still there and menus appear while the window is minimized.
4- Click on the restore window button. The window restores (but not in maximize mode) and you can not use its titlebar to move it nor can close, minimize or maximize it.

To fix the window, move it using alt + dragging it to the top of the screen to maximize it.

Nate Wiebe (natew) wrote :

@Hamed Abdy: Unable to reproduce here. Plus this if it is a bug, it's a different bug. Please file a new one.

Hamed Abdy (hamed-abdy) wrote :

Thank you.
I was not sure about filing a new bug and thought if it would be a duplicate.

New bug is filed here:
https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/1192340

Josh Holmes (thesoundman20) wrote :

Using Xubuntu 13.04 XFCE having same issue. maximized windows have click-through title bars.

Mark (markcortbass) wrote :

I confirm this bug. It affects Ubuntu 13.04 Unity and also with Gnome fallbacksession with Metacity. (on the same PC)
http://ubuntuone.com/6Da3U357eefcxekpjbgHdK

Changed in compiz:
milestone: 0.9.10.0 → 0.9.10.2
MC Return (mc-return) on 2013-07-24
Changed in compiz:
milestone: 0.9.10.2 → 0.9.11.0

Confirmed for me, too.
Using Ubuntu 13.04 + gnome session fallback + compiz on an ATI onboard video chipset on a Compaq notebook.

Some (randomly) maximized windows can't be controlled, unmaximize them to recover control (via left click on the windows bar)

Looks like window decoration positioning (relative to desktop size) goes "out of the usable screen" and compiz can't manage them. Comment based in the fact that in some no maximized windows use to have the same problem (IE vertically extended windows loose the function of the controls too, some times)

Sami Jaktholm (sjakthol) wrote :

Most of the comments indicate that the bug they are experiencing are about controlling MAXIMIZED windows (bug 1158267) or completely different bugs. To best of my knowledge, this bug is fixed by Compiz 0.9.9 release and shouldn't occur in releases made before 8 September 2013. So I'm marking the bug as fixed.

If someone still experiences problems with UNMAXIMIZED windows, please report a new bug. For MAXIMIZED windows check bug 1158267.

description: updated
Changed in compiz:
status: Confirmed → Fix Released
Changed in compiz (Ubuntu):
status: Triaged → Fix Released
dimovnike (dimovnike) wrote :

updated from 13.04 to 13.10 and this problem appeared seems to affect all kind of apps like terminal, browsers, etc. I can help with logs if needed.

Changed in compiz (Ubuntu):
status: Fix Released → Triaged

Instead of reopening this bug, let's leave it Fix Released and use the newly reported bug #1228915 to track the regression.

Changed in compiz (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.