Desktop takes a long time to initialize

Bug #1596377 reported by Ahmad Mukhtar
568
This bug affects 128 people
Affects Status Importance Assigned to Milestone
elementary OS
In Progress
Undecided
Cody Garver

Bug Description

on every boot, the desktop takes some time to load up all the things

ProblemType: Bug
DistroRelease: elementary 0.4
Package: elementary-desktop 1.412+467~daily~ubuntu0.4.1 [origin: LP-PPA-elementary-os-daily]
ProcVersionSignature: Ubuntu 4.4.0-24.43-generic 4.4.10
Uname: Linux 4.4.0-24-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
CrashDB: elementary_meta
CurrentDesktop: Pantheon
Date: Mon Jun 27 04:16:12 2016
InstallationDate: Installed on 2016-06-26 (0 days ago)
InstallationMedia: elementary OS 0.4 "Loki" - Daily amd64 (20160613)
SourcePackage: elementary-meta
SuspiciousXErrors:

ThirdParty: True
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Ahmad Mukhtar (ahmadmukhtarofficial) wrote :
Revision history for this message
Zisu Andrei (matzipan) wrote :

I think we have discussed this bug a few times before.

Basically, after login, you are looking at an empty wallpaper for about 1-2 minutes until Plank and Wingpanel show up.

It seems like it's waiting for a certain timeout or something. I don't know where to find the logs for the session, to have a look around.

Changed in elementaryos:
status: New → Confirmed
Zisu Andrei (matzipan)
summary: - desktop loads too slow on boot
+ Desktop takes a long time to initialize
Revision history for this message
Ahmad Mukhtar (ahmadmukhtarofficial) wrote :

Yes, exactly that happens. Sorry if I wasn't clear in description.

Revision history for this message
Zisu Andrei (matzipan) wrote :

I can't find any other reports this might be a duplicate of, even though Rico suggested there might be some.

Rico also suggested the problem might stem from Slingshot.

Revision history for this message
Ahmad Mukhtar (ahmadmukhtarofficial) wrote :

Well, duplicate or not, it should get fixed asap as no one likes to wait even 1 minute for their Desktop to initialize.

Revision history for this message
Zisu Andrei (matzipan) wrote :

Everything should be fixed :P But the number of volunteers is limited, so any help would be greatly appreciated!

Revision history for this message
Ahmad Mukhtar (ahmadmukhtarofficial) wrote :

Hahaha yeah :p I'll report if I find something else.. I installed the beta last night as my primary os.

Revision history for this message
Timo Reimerdes (timorei) wrote :

Still waiting over a minute on current loki build (22.07.2016).

Revision history for this message
Jodie Robinson (jodiematthewrobinson) wrote :

Still waiting quite a while with all updates as of now. How can I look into these sorts of things? I'm coming from embedded programming environments with debugging and such. Any pointers as to where to start?

Revision history for this message
Jakub Klos (9v-ka2ub-3y) wrote :

I also have this issue but it is intermittent. Sometimes it works right away and sometimes I need to wait those 1-2 mins for the desktop to appear. I would love to help debug/troubleshoot this issue not sure where to start. Maybe some logs somewhere?

Revision history for this message
ToucheD157 (tocado-157) wrote :

Same here, i'm with a laptop Dell inspiron 5459

i noted in logs (/var/log/lightdm/seat0-greeter.log)
----------------------------------------------------------------------------------------------
tty2
tailf /var/log/lightdm/seat0-greeter.log
tty7 (waiting for login)

tty7 login
tty2
** Message: PantheonGreeter.vala:214: restore user timeout: 600
** Message: Authenticator.vala:251: Starting session pantheon
** Message: PantheonGreeter.vala:446: SIGTERM received, exiting...
** Message: PantheonGreeter.vala:464: Gtk.main exited - shutting down.

** (gnome-settings-daemon:2997): WARNING **: Name taken or bus went away - shutting down

(gnome-settings-daemon:2997): GLib-CRITICAL **: Source ID 505 was not found when attempting to remove it
----------------------------------------------------------------------------------------------

¿What's is this ...?
** Message: PantheonGreeter.vala:214: restore user timeout: 600

Revision history for this message
Sundar (sundar-ima) wrote :

I can confirm this bug. It is very annoying day by day. I am running loki release version and updated the system as on today wed sep 21 2016. I have attached the '/var/log/lightdm/seat0-greeter.log' file for your review. If any other info required please let me know.

Revision history for this message
Fidtiriadi Hadiman (fid3adi) wrote :

Have the same issue too. On login after boot, it will take a long time for the desktop to load. If logout/login without rebooting/shutdown, the desktop load immediately.

But now the issue gone for me. Did few things but not sure which is the one that help me on the issue. Things I did before it gone;

1. sudo apt-get purge modemmanager (not needed by me)
2. sudo apt-get purge bluez (on desktop, so i dont need it)
3. sudo apt-get purge switchboard-plug-gcc-wacom
4. sudo apt-get purge switchboard-plug-gcc-bluetooth
5. sudo apt-get purge switchboard-plug-parental-controls (not needed too)
6. sudo apt-get install intel-microcode (intel driver. But i don't think this is what fixed the issue)

Did a few apt-get upgrade too in addition to the above before noticing the issue is gone.

Revision history for this message
Sundar (sundar-ima) wrote :

Finally, I have managed to solve this issue.

I had not noticed the the reported bug was noticed only a one week ago. Therefore, I used history command to look at the command I used after installing OS. I also monitored the log for each click on the wingpanel indicators at "/var/log/syslog" using this command "tailf /var/log/syslog". When I clicked session indicator, it showed "systemd-logind.service start request repeated too quickly, refusing to start" and last line ended with "Failed to start Login Service".

That gave me the lead. I remember that I had an issue of system going to sleep mode before entering in to desktop. To prevent this issue I used "sudo systemctl mask sleep.target suspend.target hibernate.target hybrid-sleep.target" to solve the problem (the same issue I had in Debian 8 and solved in the same way).

To know the status of systemd-logind.service I issued this command "systemctl status systemd-logind.service" and "journalctl _PID=4821" (PID taken from previous command). It all lead to login services error. Therefore, I tried unmaking the sleep/hibernating with this command "sudo systemctl unmask sleep.target suspend.target hibernate.target hybrid-sleep.target". When I tried again by clicking the session indicator it did not show any error. The wingpanel indicator problem is solved now.

But the issue of system going to sleep during boot time has come back again :-((

Revision history for this message
Peter Pan (peterpan575859) wrote :

I'm not good at English

But I found a way to solve this issue by:

 + Update graphic driver by type:

       sudo ubuntu-drivers autoinstall

 + Then type:
       prime-select query

(I use Nvidia card)

 + Switch default graphic card by type:
       sudo prime-select intel or sudo prime-select nvidia

When I reboot laptop, the desktop load immediately. :))

Revision history for this message
Zisu Andrei (matzipan) wrote :

Fidtiriadi Hadiman you seem to be on the right track.

Peter Pan, I don't know if this is related to driver cards, since there are other users (including me) which are using integrated Intel exclusively.

Revision history for this message
Peter Pan (peterpan575859) wrote :

Zisu Andrei,
I tried using command "sudo ubuntu-drivers autoinstall" on several Systems installed eOS Loki including just have only onboard card. And they login smooth.
You tried using that command yet?

Revision history for this message
Zisu Andrei (matzipan) wrote :

@Peter Pan, I believe it is a coincidence. Please tell me if the issue doesn't appear in the next few weeks.

Revision history for this message
satyendrax (satyendrax) wrote :

After installation, it was fast and smooth, but after using it for 5 to 6 days its slugish.

Revision history for this message
Carlos Renê (slipttees) wrote :

here too, take 1-2 minutes desktop done for use after login! :/

Revision history for this message
thisara kasun (thisu) wrote : Re: [Bug 1596377] Re: Desktop takes a long time to initialize

I had this for about a week and had gone away suddenly.. But still this
happens randomly.

On Thu, Oct 6, 2016 at 4:39 PM, Carlos Renê <email address hidden> wrote:

> here too, take 1-2 minutes desktop done for use after login! :/
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1629621).
> https://bugs.launchpad.net/bugs/1596377
>
> Title:
> Desktop takes a long time to initialize
>
> Status in elementary OS:
> Confirmed
>
> Bug description:
> on every boot, the desktop takes some time to load up all the things
>
> ProblemType: Bug
> DistroRelease: elementary 0.4
> Package: elementary-desktop 1.412+467~daily~ubuntu0.4.1 [origin:
> LP-PPA-elementary-os-daily]
> ProcVersionSignature: Ubuntu 4.4.0-24.43-generic 4.4.10
> Uname: Linux 4.4.0-24-generic x86_64
> NonfreeKernelModules: wl
> ApportVersion: 2.20.1-0ubuntu2.1
> Architecture: amd64
> CrashDB: elementary_meta
> CurrentDesktop: Pantheon
> Date: Mon Jun 27 04:16:12 2016
> InstallationDate: Installed on 2016-06-26 (0 days ago)
> InstallationMedia: elementary OS 0.4 "Loki" - Daily amd64 (20160613)
> SourcePackage: elementary-meta
> SuspiciousXErrors:
>
> ThirdParty: True
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/elementaryos/+bug/1596377/+subscriptions
>

Revision history for this message
Vishal Rao (vishalrao) wrote :

I noticed in journalctl command (at least a couple of times that I checked) the following log line when there is an approx 90 second delay in my login:

Oct 11 20:50:18 skybird gnome-session[2743]: gnome-session-binary[2743]: WARNING: Application 'at-spi-dbus-bus.desktop' failed to register before timeout

Apparently this is AT-SPI something to do with gnome assistive/a11y technology. Will try disabling the .desktop file in /etc/xdg/autostart folder and report back.

Revision history for this message
Vishal Rao (vishalrao) wrote :

Yup, seems like renaming (disabling) the file to at-spi-dbus-bus.desktop.disabled in /etc/xdg/autostart and the login delay no longer occurs after a few reboots and lightdm service restarts too.

Revision history for this message
Vishal Rao (vishalrao) wrote :

And seems someone else came across the same issue with the same workaround: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1599110/comments/17

Revision history for this message
Nils Röhrig (nroehrig) wrote :

I'm affected by this bug but not on a regular basis. It seems to happen just randomly. Most of the time the desktop loads quickly, other times I can only see the wallpaper.

Revision history for this message
Jakub Klos (9v-ka2ub-3y) wrote :

I used to suffer from this issue sometimes but since yesterday I keep getting it each time 100%. I have checked this bug and it is based on the same issue as I can see the timeout in the journalctl.

https://bugs.launchpad.net/ubuntu/+source/gnome-session/+bug/1595383

This bug is affecting me a lot. It would be nice to decrease this timeout but also find out why the issue occurs at first.

Revision history for this message
Hannes Fuchs (hannesfuchs1) wrote :

I think the related problem is explained and fixed here:
https://mail.gnome.org/archives/commits-list/2016-July/msg02793.html

OS Loki is running dbus-daemon 1.10.6 from 2015-12-1 while the problem was fixed in July 2016. An update to newer dbus version (one after 1.10.10) should fix the issue.

To fix the issue for now:
Rename the file to at-spi-dbus-bus.desktop

Revision history for this message
Nazmul Sabuz (naz-sabuz) wrote :

Same problem here. This problem arise after update.

Revision history for this message
Zisu Andrei (matzipan) wrote :

Hello,

Can people who have reported to see this bug try the solutions proposed by Hannes and Vishal above and report if it fixes the issue?

Revision history for this message
Harish (harish-myemails) wrote :

I am having /etc/xdg/autostart/at-spi-dbus-bus.desktop

I opened it and changed the X-GNOME-AutoRestart from true to false.

But it didn't solve the problem.

1 comments hidden view all 105 comments
Revision history for this message
Marc (noviluni) wrote :

#29 A week ago I changed in /etc/xdg/autostart/ the name of this file: "AT-SPI D-Bus Bus" to "AT-SPI D-Bus Bus.disabled" and I can confirm that it has worked perfectly all the week (about 14 times), so this could be accepted in my case as the solution (it was proposed by Hannes and Vishal).

Maybe it's a good idea to give the solution more visibility.

Thank you all

Revision history for this message
Eldar (fahreeve) wrote :

I can confirm that renaming /etc/xdg/autostart/at-spi-dbus-bus.desktop has solved my problem

Daniel Fore (danrabbit)
Changed in elementaryos:
status: Confirmed → In Progress
milestone: none → juno-beta1
assignee: nobody → Cody Garver (codygarver)
Zisu Andrei (matzipan)
Changed in elementaryos:
status: In Progress → Fix Committed
Revision history for this message
Daniel Fore (danrabbit) wrote :

Marking as "in progress" since there is an os patch in staging

Zisu Andrei (matzipan)
Changed in elementaryos:
status: Fix Committed → In Progress
Revision history for this message
Victor (v-barnar) wrote :

On my system it has gone a step further. It's not just a delay anymore. Since a couple of days it just never finishes loading the statusbar en the dock. It's just my wallpaper and that's it.

Revision history for this message
Hellie (hellie) wrote :

What a fucked up problem, I have reinstalled ubuntu. I couldn't take it anymore.

Revision history for this message
Martin Blagoev (reppair) wrote :

Hi folks, renaming the /etc/xdg/autostart/at-spi-dbus-bus.desktop fixed the problem for me as well.
Thank you!

Revision history for this message
Max (maxkerp) wrote :

Hi there. I'm running into the same problem but I might be able to deliver some new information.

So I'm running a Thinkpad T460 with integrated Intel graphics. I use this Notebook for work and free time with multiple users for work, college, and free time. The issue that the only two things showing after login are the wallpaper and the cursor only occurs with one user! Unfortunately it's the work user and I couldn't log in for the last 15 times (This is how I ended up here).

I can log on easily to my free time user (the one using right now), but if I try logging in to the work user only the wallpaper and the cursor is showing. Same on a fresh start logging directly into the work user. How come this is only a problem for one user?

I have not yet checked if the DE actually starts after a couple of minutes, but I will try this out after I posted this and come back.

Some Thoughts:

Could it be that this problem has something to do with a multi-monitor setup?
Something about the settings which get persisted?

At work I use both, my external monitor and the laptop screen. At home I only use my external monitor. When I login with my free time user it remembers the settings and automatically turns of the laptop screen and only outputs to the external monitor.
Same at work (when it did work), both screens were just like I arranged them.

Right now when i try to log in to my work user at home, either only with the laptop screen, or with an external monitor the described bug appears. The free time user works just fine.

Revision history for this message
Max (maxkerp) wrote :

Well this is Murphy's Law at its best. The last 5 times I was able to seamlessly login to my work user, by fresh start and by logging in from my free time user. So right now I can't confirm that the DE will eventually load, but I will when the bug happens again. I hope some of the information given will help in hunting down this bug.

And by the way, thank you guys so much for your hard work! I've been using ElementaryOS for more than four years now (,since the arrival of Luna) and it's the greatest Distro out there! And this is definitely because of folks like you.

Revision history for this message
Igor Ferrero (cerealkillerway) wrote :

I confirm renaming /etc/xdg/autostart/at-spi-dbus-bus.desktop worked for me (don't know what kind of side effects this can have anyway)

25 comments hidden view all 105 comments
Revision history for this message
arterhacker (arterhacker) wrote :

It happened again today.. So, the problem is still here. I want to help you. How can I do debug for session when eOS is opening?

Revision history for this message
arterhacker (arterhacker) wrote :

I've restarted the computer but doesn't happen this time. Also, it occurs sometimes when your computer awake from sleep (suspend) mode. I'm still searcing the problem.

Revision history for this message
Luís Henrique Faria (luish-faria) wrote :

rename /etc/xdg/autostart/at-spi-dbus-bus.desktop to /etc/xdg/autostart/at-spi-dbus-bus.disabled worked for me too.
Thanks!

Revision history for this message
Rodrigo (rodrigolopezguerra) wrote :

I can confirm that renaming /etc/xdg/autostart/at-spi-dbus-bus.desktop to /etc/xdg/autostart/at-spi-dbus-bus.disabled fixed the issue for me as well.

Revision history for this message
Rob Bosch (rob-bosch) wrote :

I have this issue too. I just renamed /etc/xdg/autostart/at-spi-dbus-bus.desktop and rebooted without a problem. Since the issue was happening like random, I will have to see if this is fix or not in the next couple of days.

Revision history for this message
derdaani (derdaani) wrote :

I can confirm that renaming /etc/xdg/autostart/at-spi-dbus-bus.desktop to /etc/xdg/autostart/at-spi-dbus-bus.disabled fixed the issue for me.
Before, the issue happend at least 3-4 times per week. Now it hasn't occured in 2+ weeks.
Thanks for the advice!

Revision history for this message
Igor (igor-msk) wrote :

Same problem here on Loki.
In my case it occurs unpredictably, though: most often the system boot up fine, while sometimes it shows the login screen and then only the wallpaper.

Revision history for this message
Chris (cnizzardini) wrote :

Can also confirm renaming /etc/xdg/autostart/at-spi-dbus-bus.desktop solved the problem.

sudo mv /etc/xdg/autostart/at-spi-dbus-bus.desktop /etc/xdg/autostart/at-spi-dbus-bus.desktop.rename.chris.2017-05-30

Revision history for this message
luigi (007-lva) wrote :

Renaming /etc/xdg/autostart/at-spi-dbus-bus.desktop doesn't work for me. My laptop is a Lenovo X200, Debian Stretch with Pantheon(http://gandalfn.ovh/)

Revision history for this message
Mohd Hafizul Afifi Abdullah (hafizul94) wrote :

Agreed with #68, renaming:
/etc/xdg/autostart/at-spi-dbus-bus.desktop to /etc/xdg/autostart/at-spi-dbus-bus.disabled

solves the problem for me.

Revision history for this message
Richard Danter (radanter) wrote :

Not sure if this is related or not, but I noticed the system load is high at login and in my case it seems to be due to mlocate running in the background. Since I don't use locate I removed the package and login seems to be much faster now.

Revision history for this message
Gabriel Alcântara (alcantariel) wrote :

rename /etc/xdg/autostart/at-spi-dbus-bus.desktop to /etc/xdg/autostart/at-spi-dbus-bus.disabled worked for me too.
Thanks!

Revision history for this message
Grant (gsupp) wrote :

I've also experienced this issue. Renaming /etc/xdg/autostart/at-spi-dbus-bus.desktop to /etc/xdg/autostart/at-spi-dbus-bus.disabled worked for me as well. Wish this could be fixed by the devs somehow.

Revision history for this message
Florian Stalzer (gofurygo) wrote :

It has been 1 year since bug appeared and yet, the only workaround is to rename a file...??

Strangely enough, after the clean install of the lastest elemantaryOS (0.4.1 Loki), I did not have this problem. Today, 1 week after turning on my computer again, it appeared and I went through 2 forced shutdowns until I realized what is going on.

Anyway, I really hope this could be fixed, because this is quite annoying...

Revision history for this message
Florian Stalzer (gofurygo) wrote :

In addition to my previous comment, I would like to add that the workaround works for me, too. What the workaround kills though, is the A2D2 audio profile when using bluetooth headsets... which I do.

In other words, I had to reverse the file renaming to use proper audio via bluetooth... so yes, it is a workaround if you don't use any bluetooth headset...otherwise, no.

Revision history for this message
Muluneh Awoke (mulunehawoke) wrote :

Tried a few things but the only solution that worked is renaming /etc/xdg/autostart/at-spi-dbus-bus.desktop to /etc/xdg/autostart/at-spi-dbus-bus.disabled

Revision history for this message
Luke Mackenzie (luke-lukem) wrote :

Why does renaming this file work?

Revision history for this message
Ujjwal Verma (ujjwal96) wrote :

I'm started experiencing this again. I have renamed the file and it was fixed but from past 2-3 days it's loading very slow. Any other solutions?

Revision history for this message
seanleroy (seanleroy77-deactivatedaccount) wrote :

Can confirm the same...system updated to latest and greatest and its about a minute and a half to fully load.

Revision history for this message
ovdeathiam (ovdeathiam) wrote :

Suddenly I started to encounter this bug too.

It affected more than 2/3 of all my cold boots on my Lenovo x201. I noticed that it started after I installed remmina and redshift-gtk. Both add a file to ~/.config/autostart/ on first run. Even if we tick the autostart option off in their GUI the files are still there. Just their content is changed to be skipped.

After playing with it a bit I noticed that whenever I have 3 or more files in ~/.config/autostart I am very likely to encouter an error (>66% chance). The contents of the files don't seem to be important as I've tested with multiple files copying them in and out of the folder and rebooting.

I was able to replicate it on a new installation by simply adding three pantheon-terminal's into autostart apps via system options.

If anyone encouters the bug please do a:
ls ~/.config/autostart/
and for testing purposes please move these files somewhere else or simply remove them.

Revision history for this message
Dustin LeBlanc (dustin-m-leblanc) wrote :

I ran into this morning on a fairly fresh (day old) build. There is nothing in ~/.config/autostart/

Revision history for this message
mervin de oliveira (de1) wrote :

I tried both fixed by @ovdeathiam and @vishalrao, the rename worked better.

but i noticed if the wifi is still trying to joined the network while login-in i get the issue again but this time only wallpaper and mouse on screen.

Revision history for this message
Vishal Rao (vishalrao) wrote :

Correlation does not imply causation (or something like that) :-) so maybe your wifi is another coincidental issue? Or another issue affecting your desktop loading?

Revision history for this message
Vishal Rao (vishalrao) wrote :
Revision history for this message
Dustin LeBlanc (dustin-m-leblanc) wrote :

#22 did the trick for me. Time to functioning desktop is sub 10 seconds now after renaming the file.

Revision history for this message
jegjessing (jarlgjessing) wrote :

I too experience this in a degree that makes the computer unusable.
I experience this more often now that a successfull login.
If I do a CTRL+ALT+F2 and execute sudo killall Xorg try to login kill it again then after some tries I'm finally able to log in :-(

Revision history for this message
Florian Thaler (thaflo) wrote :

#22 did the trick for me. Time to functioning desktop is acceptable now after deleting the file. The file is still not present after that the desktop is fully loaded.

Revision history for this message
Davide Aguiari (gorghino) wrote :

I had this bug but #22 fixed it.
> sudo mv /etc/xdg/autostart/at-spi-dbus-bus.desktop /etc/xdg/autostart/at-spi-dbus-bus.desktop.backup

Revision history for this message
Yellow Gh0st (ylwghst) wrote :

I'm affected by this too.
Used same workaround to fix it (removed at-spi-dbus-bus.desktop).

OS: elementary OS 0.4.1 loki

Pothi Kalimuthu (pothi)
information type: Public → Public Security
information type: Public Security → Public
Revision history for this message
Alexander Noyle (notalexnoyle) wrote :

I'm also affected by this, on every machine I use with elementaryOS on (virtual machines and dedicated alike).

Is there a plan in the works to fix this for good? Renaming a file is sort of a hack, and it breaks certain bluetooth headsets.

Revision history for this message
Stelios (mpouxa) wrote :

I'm also affected by this bug. Yesterday i downloaded several gpu updates from repositories and then after reboot came up this problem. I fixed it with the proposed solution but maybe it is necessary to fix it officially. Is there any plan ?

Revision history for this message
zen sir (zensir) wrote :

I suddenly had this bug on my HP Probook 6560b but #22 fixed it.
> sudo mv /etc/xdg/autostart/at-spi-dbus-bus.desktop /etc/xdg/autostart/at-spi-dbus-bus.desktop.backup

Revision history for this message
Gabe Onesource (gabe.onesource) wrote :

I'm also affected by this.

sudo mv /etc/xdg/autostart/at-spi-dbus-bus.desktop /etc/xdg/autostart/at-spi-dbus-bus.desktop.disabled

solved the problem for me as well.

Revision history for this message
Wojciech Sokołowski (armatorix) wrote :

Solution similar to above works for me as well:
sudo mv /etc/xdg/autostart/at-spi-dbus-bus.desktop /etc/xdg/autostart/at-spi-dbus-bus.disabled.desktop

Revision history for this message
Tyler Daniels (sparrowstune) wrote :

Thank you so much guys. This solution worked for me.

sudo mv /etc/xdg/autostart/at-spi-dbus-bus.desktop /etc/xdg/autostart/at-spi-dbus-bus.disabled.desktop

Revision history for this message
Adilson Soares (adilsonsoares) wrote :

This solution worked for me too. thanks a lot.

sudo mv /etc/xdg/autostart/at-spi-dbus-bus.desktop /etc/xdg/autostart/at-spi-dbus-bus.disabled.desktop

Revision history for this message
Gayan Kalinga (bg15407) wrote :

When i check journalctl i get strange entries with evolution calendar data server or something

And above fix not worked as well

Revision history for this message
Harry (harry-milne) wrote :

I've attempted renaming `at-spi-dbus-bus.desktop`, the first reboot didn't hang however the bug is random so I will update this thread If I experience the bug again after trying this fix.

Revision history for this message
Gayan Kalinga (bg15407) wrote :

I have recreated this bug when i add google calendar to elementary calendar or Iinstall evolution and add it to evolution calender. this happens

Revision history for this message
Emerson Joucoski (joucoski) wrote :

I tried to rename the file "at-spi-dbus-bus.desktop", but the problem persists. The boot time has not changed much.

Displaying first 40 and last 40 comments. View all 105 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers