Desktop doesn't fully load in Freya Beta 1

Bug #1368504 reported by Jason Anderson on 2014-09-12
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
elementary OS
New
Undecided
Unassigned

Bug Description

When I login my desktop fades in, and then loads only the wallpaper. Nothing else is active; the plank doesn't load and the status bar at the top of the screen doesn't load. On occasion the cursor loads, but that's it. I am able to switch over to another terminal, though (by pressing ctrl + alt + F4).

I installed Freya, Beta 1 on my Dell Inspiron 15 laptop. I was able to install it, but only after disabling the Secure Boot, as well as the fast boot option from Windows 8. Then I had to use the Ubuntu repair boot program just to get it to boot properly. After that I could only load up the desktop when I added "nomodeset" to my kernel boot options. It was only after installing a 3.17 kernel I found off of this entry on freedesktop.org: https://bugs.freedesktop.org/show_bug.cgi?id=73567

As per usual, here's a readout of some information:

dmesg output: http://pastebin.com/EXFVGdD0
lspci output: http://pastebin.com/8qBiJng5
Xorg.0.log: http://pastebin.com/pUQWCN6X

Jason Anderson (ertain) wrote :

I forgot to mention: that 3.17 kernel I used helped me to actually load the desktop and gain hardware acceleration.

tags: added: dell desktop elementary-os freya inspiron intel-drm
Jason Anderson (ertain) on 2014-09-13
tags: added: driver graphics intel

This bug happens on the recently released Loki

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers