Comment 14 for bug 1596377

Sundar (sundar-ima) wrote :

Finally, I have managed to solve this issue.

I had not noticed the the reported bug was noticed only a one week ago. Therefore, I used history command to look at the command I used after installing OS. I also monitored the log for each click on the wingpanel indicators at "/var/log/syslog" using this command "tailf /var/log/syslog". When I clicked session indicator, it showed "systemd-logind.service start request repeated too quickly, refusing to start" and last line ended with "Failed to start Login Service".

That gave me the lead. I remember that I had an issue of system going to sleep mode before entering in to desktop. To prevent this issue I used "sudo systemctl mask sleep.target suspend.target hibernate.target hybrid-sleep.target" to solve the problem (the same issue I had in Debian 8 and solved in the same way).

To know the status of systemd-logind.service I issued this command "systemctl status systemd-logind.service" and "journalctl _PID=4821" (PID taken from previous command). It all lead to login services error. Therefore, I tried unmaking the sleep/hibernating with this command "sudo systemctl unmask sleep.target suspend.target hibernate.target hybrid-sleep.target". When I tried again by clicking the session indicator it did not show any error. The wingpanel indicator problem is solved now.

But the issue of system going to sleep during boot time has come back again :-((