laptop overheats and suddenly shuts down/off

Bug #370173 reported by Igor Starikov on 2009-05-01
This bug affects 84 people
Affects Status Importance Assigned to Milestone
acpi (Debian)
linux (Ubuntu)
Nominated for Dapper by Andreas Summerauer
Nominated for Hardy by Andreas Summerauer
Nominated for Intrepid by Andreas Summerauer
Nominated for Jaunty by ana
Nominated for Karmic by Andreas Summerauer
Nominated for Lucid by Andreas Summerauer
Nominated for Maverick by Abdelrahman

Bug Description

Ubuntu 9.04, fresh install on Acer Aspire 5005 / Toshiba Satellite.
(confirmed also with 9.10 and 10.04)

Not sure about package, but it seems the problem is:
  * with CPU frequency adjustment,
  * fan control,
  * thermal sensors,
  * control of cooling itself.

Laptop shuts down right in the middle of CPU-greedy operation overheated. I haven't seen it before (since 7.10).
The issue is discussed at several forums (eg. )

          product: AMD Turion(tm) 64 Mobile Technology ML-37
          vendor: Advanced Micro Devices [AMD]
          physical id: 1
          bus info: cpu@0
          version: 15.4.2
          size: 2GHz
          capacity: 2GHz
          width: 64 bits
          capabilities: fpu fpu_exception wp vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 syscall nx mmxext fxsr_opt x86-64 3dnowext 3dnow up pni lahf_lm cpufreq

also: AMD Turion Ultra 64 X2 RM-80 @ 2.1 GHz, AMD Turion 64 X2 TL-60, Intel(R) Celeron(R) CPU 540 @ 1.86GHz


You can try:
# sudo apt-get install stress
# stress --cpu 16 --vm 2 --vm-bytes 128M

But it may be the graphics card (gpu), connected to the same heat sink as the cpu, that causes the shutdown. And the gpu will only overheat when cpu is not getting very stressed/hot and thus the fan is not running fast enough to keep the gpu from overheating.

It may also be reproducable by installing the ubunu alternate CD into virtualbox (without guest additions).


Hint 1: Make sure the heatsink/vent system is not dusty. (Do clean it with pressured air/vacuum at own risk.)
Hint 2: Using your laptop standing on its side or front edge (even if opened), i.e. when it is connected to external monitor etc., can change the heat flow and make parts like the gpu overheat which won't get so hot in normal orientation.

In some cases using some additional kernel modules (or other cpu throttling packages) seem to work around the problem.

Comment #308 points out how with ati graphics cards supported by the fglrx driver you can disable its acpi functions as a workaround. Bug #488152 and Bug #570589 deal with the many ATI cards that overheat.

An example /etc/X11/xorg.conf to keep the gpu cooler in general is the following:

        Section "Screen"
   Identifier "Configured Screen Device"
       Device "Configured Video Device"

        Section "Device"
   Identifier "Configured Video Device"
   Option "ClockGating" "true"
   Option "DynamicPM" "true"
   Option "DynamicClocks" "on"

Comment #327 points to the "server" edition which does not use acpi and does not suffer from this bug.

Comment #328 hinted that adding the "acpi.power_nocheck=1" AND "acpi_osi=linux" boot options can help, if your (updated) BIOS supports it. (Making nocheck=1 the default was proposed but it is not upstream as of april 2010.)


If your fan does not start at all, but in emergency overheating conditions, you may be seeing an (source code wise) unrelated issue/bug, that can be worked around however by the same acpi.power_nocheck=1 boot option as well, though. (Or by staying 10 seconds or so in the grub boot menu until the fan starts controlled by the bios can help.)

Igor Starikov (idlesign) on 2009-05-01
tags: added: laptop
Simon Castillo (simoncastillo) wrote :

I can confirm this issue in a Sony Vaio VGN-NS150J.

Also, battery time has been considerably reduced from Ubuntu 8.10. Powertop output:

Top causes for wakeups:
  96.1% (43222.2) <interrupt> : extra timer interrupt
   2.0% (887.4) pidgin : hrtimer_start_range_ns (hrtimer_wakeup)
   0.6% (286.6) firefox : hrtimer_start_range_ns (hrtimer_wakeup)
   0.5% (229.4) <kernel core> : hrtimer_start_range_ns (tick_sched_timer)
   0.3% (115.8) amarok : hrtimer_start_range_ns (hrtimer_wakeup)
   0.2% ( 98.6) <interrupt> : HDA Intel
   0.0% ( 21.6) gnome-panel : hrtimer_start_range_ns (hrtimer_wakeup)
   0.0% ( 21.0) skype : hrtimer_start_range_ns (hrtimer_wakeup)
   0.0% ( 20.0) <interrupt> : ahci
   0.0% ( 15.2) <interrupt> : iwlagn
   0.0% ( 10.0) async/0 : timer_action (ehci_watchdog)
   0.0% ( 5.6) python : schedule_timeout_uninterruptible (process_timeout)
   0.0% ( 5.4) <interrupt> : i915@pci:0000:00:02.0
   0.0% ( 4.2) VBoxSVC : hrtimer_start_range_ns (hrtimer_wakeup)
   0.0% ( 3.6) <interrupt> : acpi
   0.0% ( 2.4) <kernel core> : hrtimer_start (tick_sched_timer)

Bitrot (yoyo42) wrote :

I have seen this behaviour for the first time today. I've had Jaunty running for a couple of weeks on my Compaq Armada M700 (PIII-800). Today I installed the latest batch of updates (I usually update whenever it tells me, so it should only be the last day or so's worth of updates) and then noticed that after gentle web browsing (not even video clips/flash) the laptop was insanely hot and the fan wasn't running.

I also had constant notification popups saying something about not being able to read 'sensor CPU C19A' from /proc/cpu/therm...(? from memory).

When it's cooled down I'll try it again and add more detail.

Is there any way to find out what updates have just been installed in the latest batch?

If I hadn't spotted it this could have been nasty for the laptop, or for any heat-damageable furniture it was sat on.

Bitrot (yoyo42) wrote :

OK, after a cool down and reboot:

It was /proc/acpi/thermal_zone/C19A/<something> it was popping up and complaining about. After the reboot it hasn't been warning me. It also seems to be running cooler, and I've felt the fan well.

I guess the update left it in an odd state.

I've now tested it with cpuburn (actually burnMMX) and it went up to 78C with the fan going full belt, then cooled immediately when I stopped burnMMX. It felt *a lot* hotter when it overheated than it did after running at 78C for a few minutes...

I've attached syslog for the time from when I did the update (19:10) to when I manually shut it down as it overheated (19:30) then the next boot (19:58) to now. Some interesting messages in there.

If you need any other files let me know.

Igor Starikov (idlesign) on 2009-05-11
affects: ubuntu → linux (Ubuntu)
Changed in linux (Ubuntu):
assignee: nobody → Ubuntu Kernel ACPI Team (ubuntu-kernel-acpi)
status: New → Confirmed
J_Wesker (wesker-report2) wrote :

I had this issue last week when I installed Ubuntu 9.04, on my Gateway laptop. My specifications are:

Gateway T-1625
AMD Turio 64 X2 TL-60
Ubuntu 9.04 Jaunty Jackalope 32 bits

But I followed this thread and at least my laptop doesn't suddenly shutdown anymore, it's hot sometimes anyway, but now, I'm constantly monitoring the activity of the CPU to prevent that from happening. I hope in the future we don't have to adjust this and look for help with everyone. I love Ubuntu but I will try others Linux distros that support better my laptop.

Hope this can help anyone who go through the same issue.

Marcos Jr (junalmeida) wrote :

I can confirm this issue on my hp tx2110us, using Jaunty 64.

When using some intensive app for a minute or two, processor temp goes over 90 Celsius. When using the same app on Intrepid 64, everything works fine.

David (david-skagersten) wrote :

My acer aspire 5315 runs at 80 celsius idle. After watching videos or using flash it shuts down giving an overheated promt. Having a dualboot with intrepid, hardy and vista, but I only encounter this problem in jaunty.

William Woolrich (wwoolrich) wrote :

Acer Aspire One D150--Fresh install
Same issue

Maurizio (mauriziosilverii) wrote :

I have the same problem with Acer Aspire 5315. I installed Ubuntu 9.04.

yuruba (yuruba) wrote :

Same problem with MSI Megabook L715
AMD Turion 64 mobile ML-40
Ubuntu 9.04 Jaunty Jackalope 64 bits

Marcos Jr (junalmeida) wrote :

Just a comment: i've downgraded to intrepid 64 and it does not overheat anymore.

AMD Turion 64 X2 TL-62

ehuang (erichuang03) wrote :

same with lenovo x200s with jaunty

lavinog (lavinog) wrote :

My laptop has not reached a critical temp yet, but I can feel alot of heat coming from the keyboard when idle. This was not the case with hardy-32bit (Clean install of jaunty-32bit currently)
AMD Turion 64 ML-32
ATI 200m (currently using xorg-ati drivers, while in hardy I was using fgrlx, which is no longer available for my video card now)

CapnBoost (capnboost) wrote :

My HP dv1430us has done it about 4-5 times a day (acpi critical_trip_point) despite me altering the fan points, frequency stepping, etc. It did it this morning while I was reading text on a non-cpu intensive website. It also seems to have corrupted grub and made my entire installation useless, so I can't even post system logs.

I would like to note that this is *not* a hardware issue, I ran 8.10 for months without a hiccup.

Igor Starikov (idlesign) on 2009-06-02
Changed in linux (Ubuntu):
assignee: Ubuntu Kernel ACPI Team (ubuntu-kernel-acpi) → Ubuntu Laptop Team (ubuntu-laptop)
CharlieAshford (chezzo) wrote :

got this with a dell inspiron 640m, intel core solo processor with integrated graphics

abhiroopb (abhiroopb241088) wrote :

Having the same problem:

Could it be nVidia graphics card?

Specs: HP dv5242ea | Core Duo 1.60GHz | 2GB RAM | 320GB SATA | DVD-RAM Matshita UJ 840S | nVidia GeForce Go 7400 256mb | Intel PRO 3945ABG

ehuang (erichuang03) wrote :

i don't think its nVidia because my x200s has intel integrated

CylnZ (cylnzz) wrote :

Heat issues partially solved on 2 laptops both have Intel 965 chips

gateway 6860 fx w/ 9.04 64bit

acer extensa 5620-6830 w/ 9.04 64bit

both have custom DSDT files w/ 0,0,0 problems reported in iasl

both use acpi_osi="Linux" permanently added to /boot/grub/menu.list

both have been taken down to motherboard for cleaning and re-assembled

6860 video is nvidia 185.18.10

5620 video is integrated 965

Same slow fan issue on both systems, the fans NEVER STEP HIGHER THAN 66%

I can reboot the 6860 from JJ64 with sensors reading 78C on 8800m video with fan barely blowing boot into vista 64 ultmt where the fan immediately comes on and stays on for 5-6 minutes then slows down to JJ64 like speeds, I reboot into JJ64 and within 1/2 hour the temps are back up.

Keep in mind that ntune doesnt support fans on the 8800M so I cant change it in windows either but the fan does spin up to full speed and in JJ64 it never does.

The 5620 fans never seem to get above idle-33% ever for any reason (I just shut it down @ 65C. In my mind no hardware that isnt abused due to neglect or environment should see 75C ).

I'm happy to submit any info for either system that will be helpful.

lavinog (lavinog) wrote :

Like CylnZ said, my fan seems to not spin as fast as it used to.
I don't have a way to get actual numbers, but I can tell by the sound the fan makes that it doesn't reach its maximum speed now when at 100% cpu for a couple of mins.

pampistell (pampistell) wrote :

I can confirm on two different laptops:
After upgrading to jaunty 9.04 they both run overheat even when closed
Acer aspire 5630 with | intel core duo 1.66GHz
Acer aspire 5730Z with | intel core duo 2.16GHz
both are integrated video

This is definitely an os issue. Both were fine running on gutsy and intrpid.
Both do not overheat when I boot into windows.

David (david-skagersten) wrote :

I found a very clumsy workaround. Either I unplug the battery or the AC and the temperature stays around 55-65 celsius. So could this be a charging issue mainly?

Linux 2.6.28-11-generic
Intel(R) Celeron(R) CPU 540 @ 1.86GHz
ACER aspire 5315

CharleyS (charley-socci-com) wrote :

This is the same bug mentioned above (e13) -

The issue is the fan speed. NOT that the processor is working at capacity (set to performance, etc). My Lenovo T61 frequently serves as a desktop replacement. Even with the cpu throttled it runs not. Overnight backups, or software like BOINC or even a flashy screen saver can all send the laptop into thermal shutdown. If I want to run my cpu at it's full speed, the laptop should be capable of that without overheating. Dumbing it down is not the answer.

Here is the workaround for Lenovo, which involves disengaging acpi control of the fan so that it runs at the correct speed. If you look at your fan speed, you will see that it is *slow* and that it gets *delayed* turning on when the cpu overheats. This is why the cpu overheats - the fan is too slow and does not turn on soon enough - at least in my case.

A person should be able to run cpu intensive applications overnight without causing their laptop to go into thermal shutdown!

 I found a work around, which is to let the fan run full speed all the time. (This can also be adjusted easily)

The laptop is now running at 44C as I surf and write this post, and goes to 94-95C under a cpu stress test but no higher.

1. you can monitor your fan speed from the thinkpad-acpi module: cat /proc/acpi/ibm/fan (check path under /proc for your laptop)

2. you can adjust the fan speed to stay on at full speed by executing the following command as root: echo level disengaged > /proc/acpi/ibm/fan

(you will need to uninstall any other fan control applications or scripts you may have tried, including tpfand)

One I did that, the fan kicked up to 4000+ rpm and stayed there. The CPU temp stays at 94C under full load and goes no higher. There are additional options, and scripts you can run if you wish to control the fan based on temperature and load.

With the fan running between 4000-5000 rpm cooling is not a problem.

When fan control is engaged in the thinkpad-acpi module, the fan spins *only* between 0 and about 3000 rpm and takes quite a while to kick in - usually too late

Note that I tested the same software on my wife's T61 running 8.04 and did *NOT* have any thermal issue. I have replicated my heat problem on the T61 using both the 64-bit and 32-bit kernels.

For more info, see the following:

abhiroopb (abhiroopb241088) wrote :


Your fix sounds encouraging, but are there any side-effects of leaving it on all the time like that?

Is there no way of using a different setting in Jaunty that controls the fan a bit better. I mean I had no such problem in Intrepid?

Igor Starikov (idlesign) wrote :

Yeah, seems the same bug, but not only on Lenovo, so I marked #361123 as a duplicate, even though it was registered earlier.

This might be weird and subjective, but I've noticed that if the battery is unplugged temperature rises fast and high. With the battery laptop is more stable. Need to check and confirm that though.

Bitrot (yoyo42) wrote :

I think you may have something with the battery. After reporting this a while ago, my Compaq Armada M700 has not drastically over heated again - although it has been running 10 degrees or so hotter than it did with Gutsy-Intrepid (58 not 48 when idling).

Until last night. I usually run it plugged in, with the battery in place. I noticed the orange 'battery charge' light was on which is rare, then a few minutes later there was a 'pop' (I think just the speakers) and it froze. When I held it to turn it off it didn't respond to the keyboard, mouse or soft power button, and it was scorching hot.

After a hard reset, then a cool down, it's been fine again. No charging light.

Nathan Valentine (nrvale0) wrote :

Just to confuse things even more...

Since I created the original bug report I've not witnessed the behavior EXCEPT when I have the laptop plugged in w/ battery and connected to a 2nd monitor with Xinerma enabled. I have a feeling that, in that situation, the temperature increase is probably more due to the video card working extra hard for dual-monitor rather than any CPU freq scaling issues.

CharleyS (charley-socci-com) wrote :

Again - This is NOT a "cpu scaling" problem. Unless you are OVER clocking your cpu, you are running it at the speed it was DESIGNED to operate at.

The issue is cooling.

The FAN is not running fast enough, or often enough, or at the right time, to sufficiently cool the processor.

This is NOT a CPU "scaling" issue.

It is a heat issue caused by the fan control (ACPI).

CharleyS (charley-socci-com) wrote :

You also need to REPLICATE the issue with a CONTROL.

If you just "wait" for the bug to "happen" you will ge nowhere.

I can replicate the issue EVERY time by running stress.

sudo apt-get install stress

Then run it: stress --cpu 16 --vm 2 --vm-bytes 128M

Watch your laptop shutdown.

1 comments hidden view all 376 comments
Marcos Jr (junalmeida) wrote :

I guess that it can be a cpu scaling problem, 'cause Jaunty always boot in PERFORMANCE governor, instead of the default ondemand.

CharleyS (charley-socci-com) wrote :

The bug is labled as an overheat and shutdown issue. Normal CPU's do not overheat when run at their designed speed. "Performance" does NOT mean "over clock". It simply means the cpu is running at it's highest (and least battery friendly) mode.

This should have nothing to do with an overheating problem.

The cpu is designed to run comfortably at it's rated speed so long as the cooling is adequate as designed.

No, it is NOT a cpu scaling problem. It is a head problem.

Booting in one mode or another is an entirely different issue. The laptop should NOT be overheating in ANY mode. Period.

Alex Cockell (alcockell) wrote :

I'm also affected; a Thinkpad R61i model 7650-range, preinstalled Ubuntu 8.04, currently running kernel 2.6.24-23, as had boot issues with -24.
(probably got the most recent ACPI patches for Hardy)
Fan running slowly - was cooking my laptop more.

I have had to buy a laptop cooler so I can safely use it.

PLEASE fix it for us on Hardy as well!

Igor Starikov (idlesign) wrote :

I can successfully replicate the issue with three or four opened Flash pages in browser, or Skype with video. So no 'stress' need for me. Who could do the same?

@Alex Cockell
Hmm, we should somehow ascertain that in Hardy you have the same issue, because we experience this only since Jaunty. When your Hardy started to cook your laptop, Alex, — since the beginning or not so long ago?

Alex Cockell (alcockell) wrote :

@ Idle sign - since not so long ago. So it's definitely recent changes that came down.

Being a "regular user", I generally trust the release people to get it right - I am currently running the machine atop a cooler - which at least makes it usable.

Temperatures are still around what I quoted... but before I bought the machine - it would freeze up... or not boot due to heat during the last mini-heatwave...

Although I did notice it getting rather warm around the CPU fan outlet.. but I would have expected that to ramp the fan if it WAS getting warm...

When was the last batch of acpi patches released?

Alex Cockell (alcockell) wrote :

What was VERY scary was that the following lines started showing in my /var/log/messages...

May 30 22:32:21 ubuntu -- MARK --
May 30 22:52:21 ubuntu -- MARK --
May 30 23:10:05 ubuntu kernel: [531782.411921] thinkpad_acpi: unhandled HKEY event 0x6022
May 30 23:32:21 ubuntu -- MARK --
May 30 23:52:21 ubuntu -- MARK --

Jun 2 23:52:22 ubuntu -- MARK --
Jun 3 00:12:22 ubuntu -- MARK --
Jun 3 00:32:22 ubuntu -- MARK --
Jun 3 00:50:15 ubuntu kernel: [644574.555901] thinkpad_acpi: unhandled HKEY event 0x6022
Jun 3 01:06:48 ubuntu kernel: [645562.273688] thinkpad_acpi: unhandled HKEY event 0x6022
Jun 3 01:07:44 ubuntu exiting on signal 15

... and *didn't* shut down.

This happened a lot when the lappie overheated... I've got Linux Emporium investigating it as well (preinstalled machine from them).

Looks as though it's known about...

In both cases - the fan ought to kick in and run at close to max speed - it doesn't. Only speed up from, say 3003rpm to 3050 for a few seconds. I'd have expected to feel the fan really ramp up and run at abotu 4000-5000 or even max out (I think they're rated to approx 5500rpm for a long time ot get the temp right back down before slowing back down again. Hence the cooler...

I use this thing as a desktop replacement, so often run it without the battery on mains, and often all day.

Alex Cockell (alcockell) wrote :

From the above - possible leads - thinkpad_acpi.. needs to be released to ALL VERSIONS.


abhiroopb (abhiroopb241088) wrote :

I have collated all the various posts into one ubuntuforums post...please help advice there...

pampistell (pampistell) wrote :

This is NOT just a thinkpad issue. Both my laptops are overheating and they are not thinkpads. It happens every time, with battery or without. I don't even have to run any programs, just walk away from it and it gets so hot you can't touch it.

I have to work in windows until this is fixed #@$%
There are many who are affected by this bug. It should be marked as high importance.

Please, pretty please! with cherries on top

arsenix (arsenix) wrote :

   I also see this issue on my lenovo t61p. Hard for me to tell if it happens all the time or just occassionally. I will notice the keyboard burning up and realize that my temps are at 90C even though I am not doing anything processor intensive. No 3D (I don't use compiz or other compositing). Fan is sitting at a fairly low speed. When I switch the fans to manual unlocked mode the temps settle down to 58/69 (temp1 and temp2 respectively) which still seems pretty hot especially for max cooling.

   I think this might be a contributor to the periodic instabilities I see under Jaunty. I'll start paying more attention to the temps.


abhiroopb (abhiroopb241088) wrote :

The fan fix suggested sounds interesting...but there is nothing under the /proc/acpi/fan folder.

Changed in linux (Ubuntu):
assignee: Ubuntu Laptop Team (ubuntu-laptop) → Ubuntu Kernel ACPI Team (ubuntu-kernel-acpi)
Andy Whitcroft (apw) on 2009-06-18
Changed in linux (Ubuntu):
importance: Undecided → High
status: Confirmed → In Progress
Andy Whitcroft (apw) on 2009-06-25
Changed in linux (Ubuntu):
assignee: Ubuntu Kernel ACPI Team (ubuntu-kernel-acpi) → Andy Whitcroft (apw)
Jagmax (wateranimal) on 2009-10-05
Changed in linux (Ubuntu):
status: In Progress → Fix Committed
Jagmax (wateranimal) on 2009-10-05
Changed in linux (Ubuntu):
status: Fix Committed → In Progress
timoun (timoundiep) on 2009-10-18
Changed in linux (Ubuntu):
status: In Progress → Fix Committed
status: Fix Committed → In Progress
Gonzalo (gonzpk) on 2009-10-18
Changed in linux (Ubuntu):
status: In Progress → Fix Committed
status: Fix Committed → In Progress
ceg (ceg) on 2010-04-15
description: updated
ceg (ceg) on 2010-04-15
description: updated
ceg (ceg) on 2010-04-15
description: updated
ceg (ceg) on 2010-04-15
description: updated
ceg (ceg) on 2010-04-15
description: updated
ceg (ceg) on 2010-04-15
description: updated
ceg (ceg) on 2010-04-15
description: updated
ceg (ceg) on 2010-04-15
description: updated
ceg (ceg) on 2010-04-15
description: updated
ceg (ceg) on 2010-04-15
summary: - Ubuntu 9.04 laptop overheat and shutdown
+ laptop overheats and suddenly shuts down/off
ceg (ceg) on 2010-04-15
description: updated
ceg (ceg) on 2010-04-16
description: updated
ceg (ceg) on 2010-04-16
description: updated
ceg (ceg) on 2010-04-21
description: updated
ceg (ceg) on 2010-04-26
description: updated
ceg (ceg) on 2010-04-27
description: updated
296 comments hidden view all 376 comments
mulambo (onslaughtishere) wrote :

Reporting this issue as well, I do not know how to apply these patches, I own the Lenovo X200 running 10.04 64-bit.

Flavio Capobianco (norkov) wrote :

Same problem for me, running Lucid with the latest kernel from mainline PPA. My laptop's an aspire 5542. This is my bug report:

Daniele Dellafiore (ildella) wrote :

I can confirm on dell xps 1530 with nvidia 8600m GT, lucid and 256 series driver.

This just happen with an external monitor attached, powermizer is locked to performance level 2 and cpu quickly geoes to 90 degress. As in comment #59.

Disabling the external monitor, I get back to situation you see in the screenshot attached and cpu gets cooler.

just in case, monitor is attached with VGA cable.

ybaruss (yabruss) wrote :

Hello everybody,

This bug look to be strong regarding number of comment related !!

For the little storie, I actually have a Toshiba laptop with AMD Turion(tm) 64 X2 Mobile Technology TL-60 on it and experienced different problems with Ubuntu 8.04, 8.10 and now 10.04. I have to say that people under Ubuntu are performing marvelous job because problems are solved while time passing ... thanks to them all !

For this "Over temperature spurious shutdown" problem I have to say that I have it since Ubuntu 8.04 and still exist on 10.04. I would advise to toggle off temperature check into temporary kernel used on Ubuntu install CD because it can be very annoying while no risk to burn CPU during Ubuntu installation stage.

After taking time to read all those comments on this bug, I would also vote for a fan management issue because I confirm to have nothing into /proc/acpi/fan and that sensors-detect provides no fan sensor for my hardware. So how can the OS manage fan optimization with no input ?!?

I am very interested to have feedbacks on investigation status on this problem and could provide informations if needed.

Abdelrahman (ahamino) wrote :

I have this same problem with my laptop since, 9.04 ... Whenever I start working it hard .. for instance running a virtual machine, or something, the laptop overheats and shuts down automatically... notice that it runs fine on "Windows 7"..

my laptop

hp tx2510
AMD Turion Ultra X2 RM-80, 2.1 GHz, 64 bit
ATI HD3200

I tried to investigate this a bit, gone through installing powernow-k8 (didn't make much of a difference) .. lm_sensors is not able to see the board temperature sensors unless i disable the acpi in grub ... (acpi=off)

I want to help investigate this problem, in order to solve it!!!

ybaruss (yabruss) on 2010-09-24
Changed in linux (Ubuntu):
status: In Progress → Confirmed
ybaruss (yabruss) wrote :

May be related with Bug #96592

ybaruss (yabruss) wrote :

May be related with Bug #563156

ybaruss (yabruss) wrote :

May be related with Bug #508674

ybaruss (yabruss) on 2010-10-17
description: updated
Cody Moniz (unyonotachi) wrote :

Lenovo X61 Tablet - Linux tomato 2.6.32-24-generic #42-Ubuntu SMP Fri Aug 20 14:24:04 UTC 2010 i686 GNU/Linux

For a while, I've been using a workaround that would "echo level 7 > /proc/acpi/ibm/fan" every login to keep it maxed out - unfortunately this would not be high enough while running anything 3D, and my computer would often overheat (to dangerously high, lap SCORCHING levels) and shut down.

My new workaround involves "echo level disengaged > /proc/acpi/ibm/fan", and that boosts my fan levels from ~4500 to ~5700. Thats a lot of missing RPM.

For reference, how to do this hack (based on

sudo apt-get install thinkfan
sudo echo "options thinkpad_acpi fan_control=1" > /etc/modprobe.d/thinkpad_acpi.conf
sudo echo "#!/bin/bash" > /etc/init.d/
sudo echo "echo level disengaged > /proc/acpi/ibm/fan" > /etc/init.d/

dmiller309 (dmiller309) wrote :

I was able to completely solve this computer on my Studio 1555 by doing the following:
1. Run the command "sudo amdcccle" (no quotes)
2. Under the PowerPlay page (left), uncheck the box "Enable PowerPlay"
3. Click "OK"
The problem was that the graphics card on my computer was overheating, not the CPU (I kept a CPU log to be sure of this). If you have an ATI card similar to mine but don't have the ATI settings manager (amdcccle), you can download it from the ATI site:

ybaruss (yabruss) wrote :

Thanks dmiller309 but your solution doesn't work for me. I don't think this bug is about GPU over temperature problem, it seems more due to bad temperature reading that lead to critical shutdown.

I was expecting to have details on what went wrong within system logs when critical shutdown occurs but the only related error is:
[ 14.623699] k8temp 0000:00:18.3: Temperature readouts might be wrong - check erratum #141

There is no evidence of who causes the shutdown. I saw that there is AMD K8 (my and other bug subscribers configuration) problem reported here:

ybaruss (yabruss) wrote :

I am also suspected a fan control problem because when CPU is being used at full speed, fan just go for a little burst but could do it longer in order to cool a bit more.

For me the directory /proc/acpi/fan is empty and /proc/acpi/thermal_zone/*/trip_points has no active trip points (those starting with "AC") then there is no ACPI-based fan control on my system ( Then I am wondering, if not ACPI, what is governing fan management ?

Can those that are concerned by this bug confirm or not if they have a ACPI-based fan control on their system ?

arr (alan-drop-share) wrote :

I have the same problem with Acer 5670. Fan never runs fast enough. XP does not have this problem.
"acpi.power_nocheck=1" AND "acpi_osi=linux" has no effect.
Running 10.10, 2.6.35-22-generic #35-Ubuntu SMP Sat Oct 16 20:36:48 UTC 2010 i686 GNU/Linux

lalimacefolle (lalimace) wrote :

with an acer 5315 and linux mint based in debian, the overheating is stille there.

However, after closing the computer (and putting it in sleep mode) when it returns, the fan works fine: no oeverheating anymore...

Changed in linux (Ubuntu):
assignee: Andy Whitcroft (apw) → nobody
Changed in linux:
status: Unknown → Confirmed
Changed in linux:
importance: Unknown → Medium
Antoine Cotten (antoineco) wrote :

I can confirm this bug still exists in Ubuntu 10.10 (and 10.04).

I have a Toshiba U500-119 and the issue mainly comes from a buggy DSDT table. Vendors are totally unable to compile their DSDT table correctly for non-Windows OS.

After fixing errors in my DSDT table and recompiling it (then include it in my kernel...) I could use my laptop in normal conditions with a working fan.

Please find my DSDT table in attachment, What I needed to do was replacing "L0r" by "And" in PowerResource methods. There are still some warnings but I don't know how to fix them.

The workaround was found here and can be applied to any buggy DSDT tables :

This bug is extremely severe, it was kicked in 2009 and is still not solved, even if it applies to many laptops.

Greya (grreya) wrote :

I had almost the same issue with the only difference that it didn't shut down, but every single program was very-very-very slow and nothing helped.

Computer: DELL Studio 1558 laptop (purchased about 6 months ago)

The error I saw at every boot-reboot-shutdown was:
"Critical temperature reached (110C), shutting down."

Laptop behaviour: everything very slow, hdd temp=42-50 C, ACPI temp = 110C (I monitored it in the gnome-panel applet "computertemp")

System: I was running Ubuntu 10.10 and this bug didn't appear immediately after upgrade (clean reinstall from 10.04).
Last week I moved to Debian 6.0 (squeeze) due to my personal preferences and also hoping this bug to dissapear - but it didn't!

Today I've found the fix: BIOS Update! Just performed the update (I had BIOS version A04 - updated to version A10)
Now, everything looks and feels normal and smooth again! (computertemp shows "ACPI temp=27C")

I found 2 ways to do it:
1) under Linux - through libsmbios package (explanations given for Debian, not Ubuntu, though)

2) via Windows 7 Live CD (not Windows XP, cause the DELL Studio 1558 BIOS doesn't support WinXP and you will have a Blue Screen of death with acpi.sys error!)

I used the second way, cause there is no bios update file for linux for this laptop - why? explained here
("Quite a few desktop and notebook systems don't have a method to update BIOS that's supported by firmware-tools. :-( In particular, this model has its Windows-executable BIOS in a package format that firmware-extract doesn't recognize.")

Hope it will help!

Eloi Espanol (eloiespanol) wrote :

Hi Greya,

I'm having the same problem you had, but in my case the laptop do shut
down. I also have a Dell studio 1558 (bought about 8 months ago) and I
recently installed Debian Squeeze. At first it worked fine, with no
overheating problems. The only thing I did is setting up the wireless
(installing the drivers) and some automatic updates for the packages.

I followed your recommendations and I upgraded the system BIOS from v4
to v11 from Windows 7, but the problem still persists. I can keep the
laptop running if I don't load it with tasks, but when I start working
with 2 or 3 apps at the same time it shutts down.

I don't know why the system began having these problems given that the
fresh installation of Squeeze worked apparently fine.

I googled searching for this, but the closest report to my problem I
found is yours.

I have a dual boot with Windows 7 and windows works goods, so I
discarded a hardware issue (the laptop is also pretty new). Before
Debian Squeeze I had Ubuntu Lenny (10.04) and it also worked good, so
I guess is a problem with Debian.

Did you have the same problem again after upgrading the BIOS? Have you
any clue about what the problem could be?

I'll keep researchig about it, but any idea you could have would be
very helpful to me.

Thank you

Greya (grreya) wrote :
Download full text (3.3 KiB)

Hello Eloi Espanol,

I will describe in details my situation after BIOS upgrade (hope it can help):

After upgrading BIOS I had the sensors applet showing ACPI temperature (110 C) again, but it was different:
- Before upgrade: it was 110C all the time since booting and the laptop was laggy and slow all the time.
- After upgrade: it booted okay, but in one hour or two, when I was working in some "heavy" program (VMware Workstation, Photoshop) - I heard my fan starting to work loudly and I saw again temp-applet showing ACPI 110C.
But! I think this applet doesn's show the temperature quite right - cause there are only two temperatures it showed me - 27C or 110C (and it didn't change for any other throughout the day).

So, I looked through the System Tools > Log File Viewer: and I didn't find the message I saw before BIOS upgrade "Critical temperature reached (110 C), shutting down." Just another message kinda "ACPI ... 110C" (didn't save it).
I also saw this in the syslog:
          fan PNP0C0B:00: registered as cooling_device0
          ACPI: Fan [FAN0] (off)
          fan PNP0C0B:01: registered as cooling_device1
          ACPI: Fan [FAN1] (off)
And I thought maybe something was wrong here, but laptop fan worked OK, since I heard it working and changing the speed sometimes. And now, when everything's fine - this message is still there and the fans work fine.

So, I thought about two variants left to try: either the laptop fans were in dust (I didn't clean it after buying) or maybe it's something connected with VMware Workstation processes (there are many of the running at boot and running all the time when VMware isn't even in use). Cause when I tried to remember when this laggy problem started to occur on my previous system - Ubuntu 10.10 (the one I had before installing Debian, and before Debian I had 3 or 4 previous versions of Ubuntu and it worked OK) - I remembered I had recently upgraded VMware Workstation to the last version (v.7.1.3-324285.).
Also, just after I installed Debian 6.0 - I worked on my laptop for one or two days without having this problem - it took me to finish tuning up my system and installing everything I need. One of the last programs I installed was exactly the last version of VMware. And here the laggy problem began (as fas as I remember)!

So, I tried both:
1) I thouroughly vacuum-cleaned the fans (laptop shut down of course :)
2) AND, I downgraded VMware Workstation to previous version 7.1.2-301548.
And the problem's gone... I worked in Photoshop for couple of hours with large files and everything worked fine, I didn't work in VMware though. But it's already two days I don't have this problem again. And after cleaning the fans - I almost don't hear it working, it's not loud at all - there were pretty much dust in there.

Maybe all this is too much detailed, but I don't really know what helped to solve my problem - maybe it was vmware processes , or maybe it was the dust..

OH, and another note! I upgraded BIOS to v10, not v11. When I was googling this laggy problem, I once read in some bug report that people who upgraded their DELL BIOS to v11 had this problem occur again (on Windows 7 though) - and the solut...


Eloi Espanol (eloiespanol) wrote :

Hi Greya,

Thank you very much for your detailed comments about it, they're really helpful!

When I upgraded the BIOS to v11, I tried leaving the laptop on for some time without running any applications and it apparently worked just fine (although I didn't check the temperature). It was when I started running some applications that it shut down.

Given that before installing all the apps I wanted to have the system worked good for a couple of days, I think it might be something I did, maybe some applications I installed (compiz, cairo-dock or any other) or something in the process of installing the drivers for the wireless (I installed hybrid_wl and the r8168 modules and that also required me to change the initramfs file).

I'm not an expert in Linux, it's a hobby for me (I like this sort of things) so sometimes, to make things work (for instance, installing the wireless modules) I just follow the steps I read about without really understanding what I'm exactly doing. Hence, I guess I probably did something wrong without noticing.

I think I'm going to start a fresh installation to see what the problem could be. I'll start just re-installing the base system, check if it doesn't overheat for a couple of days, then I'll install the wireless modules, check for a couple of days, etc. I think going step by step will help me find out what's wrong. And I'll also clean the fans!

I think I'll also check the temperatures on Windows 7 to make sure the BIOS upgrade to v11 won't cause me any trouble.

Once again, thank you for sharing your experience. I'll keep the list updated about how is everything going, maybe I can find out what package is the problem.

Greya (grreya) wrote :

Thanks, Eloi :)

Yeah, I think the best way to find out is a step-by-step installation anew. I just don't have time for this and if you do - you could probably help many people!

I hope my situation will help someone too.. for vmware processes could be the cause - I'm not a linux expert neither, just advanced user, but I still don't know how to test vmware startup modules to check if they really were the problem..

If someone of the debian development reading this - I'm ready to try and test these things out, just tell me how :)

Good luck!

Todd Smith (td-smith) wrote :

I am running a fully updated Ubuntu 10.10 and this issue is **A SERIOUS PROBLEM**. It appears as though the fan never goes to its max speed. It should be noted that this issue isn't as bad as it was under 9.10, but still very annoying.

Eloi Espanol (eloiespanol) wrote :

I did some research on this issue and I got very confused. As I was looking for the possible reasons, I began finding many issues that could be related:

- May it be a problem with the sensors? I found that the sensors-detect command didn't find any supported sensors in my system. the "sensors" command just show two temperatures 26.8º and 0.0ºC.

- May it be ACPI? I read about some problems with ACPI, but I didn't get anything clear about those readings. Too many issues were involved and it could be anything.

No need to say that I don't know much about linux , so I finally gave up with Debian Squeeze and I tried to go back to Ubuntu, which was working good, with no issues. But, what a surprise, after installing it from scratch, the system overheated and shut down!

I let y laptop cool down and started it again to install the wireless drivers and keep googling about the reasons of the overheat. I got the wireless set up and then a message from Ubuntu's Driver Manager pop up showing the possibility to install the Driver for Broadcom's wireless and ATI's privative FGLRX driver.

I read in several forums that the overheat problem could come from the GPU and not the CPU, and until the moment, after installing the FGLRX driver it seems that the system doesn't overheat anymore (at least not to the point of shutting down).

I'll keep updated about whether the FGLRX driver solved the problem or not. If everything keeps stable, I'll try to reinstall Squeeze and then checking if the FGLRX solves the problem in Debian too.

Crossing fingers!

bfoo (bfoo) wrote :

Same here on my Lenovo X201s (5413FFG, Intel(R) Core(TM) i7 CPU L 640 @ 2.13GHz). It started within three to four of days ago. I received several updates (including new kernel images). So it is hard to trace back. Switching back to an older kernel does not help. My feeling is, that it started when I received some ACPI related packages.

A bug similar to my symptoms is filed at RedHat:

This problem is very serious. I'm not able to use the system for work.

ceg (ceg) on 2011-04-30
description: updated
Whisperity (whisperity) wrote :

For those who are using Acer Aspire 5315 or 5720 and has this problem, here is a possible solution.
You need to put the MEMPAT script to a PATH directory (/usr/bin suggested). Start up the in terminal with root access, and follow the instructions appearing.

mdascanio (mdascan) wrote :

Also seeing this problem on a Toshiba Satellite L515 with Ubuntu 11.04, insyde H20 BIOS (latest version)
Things to note:

1) It wasn't happening on 10.10, only after upgrading to 11.04
2) If I wait until the CPU heats up and then reboot, the fan starts working at full speed and continues to do so until shutdown, even with temperatures around 31 C. I have tried the "wait 30 seconds inside GRUB after cold start before booting the OS", but it didn't work (guess it wasn't enough temp buildup for the fan to start)

madbiologist (me-again) on 2011-05-22
tags: added: karmic lucid maverick natty
madbiologist (me-again) wrote :

@mdascanio - Does the solution in comment #352 work for you? What about the "acpi.power_nocheck=1" and "acpi_osi=linux" boot options?

Please attach the output of sudo dmidecode.

@bfoo - What version of Ubuntu are you using? And what versions of acpi-support and acpid?

madbiologist (me-again) wrote :

@bfoo - Also, what version of udev are you using?

Bob (paul-crapouillou) wrote :

Affects me on my Zotac ZBOX HD-AD02 (AMD Fusion).
It was working fine under 10.10; this bug appeared when switching to 11.04.

mdascanio (mdascan) wrote :

@madbiologist: Tried "acpi.power_nocheck=1" and "acpi_osi=linux", and the situation improved. Now the fan works at a low speed, but at least is cooling better. I'm attaching the output of dmidecode.

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Confirmed → Won't Fix
madbiologist (me-again) wrote :

There is a lot of information in the comments of this bug report describing how and when this bug occurs on Lucid, Maverick and Natty. This information, and particularly it's interconnectedness, would be lost if people filed new bugs.

@Bob - Given that you have AMD (ATI) graphics the example /etc/X11/xorg.conf given in this bug's description should help. Alternatively you can a try the profile-based power management method and then set either high, medium or low profile. See comment #19 in bug 557829. See for further info. Please let us know if either of both of these methods work or not.

Olcay Korkmaz (olci) wrote :

Lastest bios updates solves fan issue on Aspire 5315, Aspire 5320, Aspire 5715Z, Aspire 5720, Aspire 7320, Aspire 7720

Changed in linux:
status: Confirmed → Expired
madbiologist (me-again) wrote :

For anyone with AMD/ATI Radeon graphics hardware, better (than what I mentioned in comment #368) power management for AMD/ATI Radeon R600 and newer hardware is finally available in the upstream 3.11 linux kernel. The first release candidate (3.11-rc1) of the 3.11 kernel is available at and instructions on how to install and uninstall it are available at

To use this power management for the AMD/ATI Radeon you will need to select it at boot by adding radeon.dpm=1 to your GRUB kernel boot options as described at

madbiologist (me-again) wrote :

See the blog post at for further information.

Unlike the older dynpm method, the new DPM method works with multiple monitors and there shouldn't be any flickering as the performance level changes are handled by dedicated hardware rather than the driver.

madbiologist (me-again) wrote :

I neglected to mention that to use the new power management feature on R700 and newer hardware (other than APUs) requires installation of the latest AMD graphics microcode (ucode) files to /lib/firmware/radeon
These are available at
Get the version ending in "smc".

R700 basically means Radeon HD 4000 series and newer. However note that according to Wikipedia and the Mobility Radeon HD 4225/4250 is a RV620 chip, so anyone with one of those shouldn't need the updated firmware files.

christopher (twigs1a) wrote :

Problem solved!!!!!!

I updated the BIOS to the latest version for my Laptop. Ubuntu and another Lynix based OS works fine now.

madbiologist (me-again) wrote :

For anyone with AMD/ATI Radeon graphics hardware, kernel 3.11.0-1.4 (based on the upstream 3.11-rc4 kernel) is now available in Ubuntu 13.10 "Saucy Salamander". Also, kernel 3.11.0-2.5 is in Saucy-proposed, which is based on the upstream 3.11-rc5 kernel, which has some bugfixes for the new DPM method.

Jean Jordaan (jean-jordaan) wrote :

This issue is still ongoing; looks like is the current version of it.

madbiologist (me-again) wrote :

Jean Jordaan - Which version of Ubuntu are you using? Can you paste the output of uname -srm. Please also attach the output of lspci -vvnn and sudo dmidecode

Displaying first 40 and last 40 comments. View all 376 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.