Lenovo T61p is running very hot after Jaunty upgrade

Bug #361123 reported by Nathan Valentine on 2009-04-14
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

Even when sitting on a hard flat surface that should provide adequate ventilation, my Lenovo T61p is running very hot. The left side keyboard is hot to the touch and the underside of the laptop is almost too hot to touch with a bare hand.

I'm more than willing to assist with debugging this issue but I'm not sure what information would be most useful to the devs. Please advise and I will do my best to get the requested information.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: nvidia
Package: firefox-3.0 3.0.8+nobinonly-0ubuntu3
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: firefox-3.0
Uname: Linux 2.6.28-11-generic i686

Nathan Valentine (nrvale0) wrote :
nguerrera (nguerrera) wrote :

I am seeing the same issue on a Z61T after a clean install of Ubuntu 9.04 on my Lenovo ThinkPad Z61T. I ran 8.04 on the same machine since the day it was released and the laptop always stayed nice and cool. Now it is uncomfortably hot.

bchiang (satonmycamera) wrote :

My Lenovo X60 is running much hotter than usual with a clean install of Ubuntu 9.04. XP and 8.04 didn't have any heat problems before, but now the right hand side is uncomfortably (and unusually) hot.

Stratus (saftousmis) wrote :

My Sony Vaio PCV-RS320 desktop is running hotter than usual too.

According to lm-sensors the processor temperature right now is 131 degrees fahrenheit.

I normally see temperatures this high in the middle of compiling a kernel.

Right now I have two Firefox browser windows open (three tabs in one).

T61, same story. After updating 8.10 to 9.04 laptop runs hot as hell. Even with cpufreq-selector set to lowest speed, this thing is unusable as laptop, at least on lap...

seems like cpu freq applet has suddenly started modifying cpu speeds independently for two cores... i kinda remember that at 8.10 changing one changed the other too.

something seems to be changed with thresholds too, setting both cores at ondemand and running my usual set of apps, machine still runs little bit hotter than it used to run just few hours before, at 8.10. way too often one or both cores jump up to 2G. only setting both cores to 800M, will the temp go down to the level where it used to run at 8.10/ondemand.

looks like month old issue, will anybody start being more than undecided, please?

something wrong with cpufreq-selector also. in old days, it just used to work. setting speed, et this for both cores.

sudo cpufreq-selector -f 800000

now this sets one, cpu0(yes, I know I can use -c parameter), and starts to wait something...

CharleyS (charley-socci-com) wrote :

I am experiencing the same issue on T61 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:58:03 UTC 2009 x86_64 GNU/Linux

If I leave a background application running (boinc client, sbackup) the laptop overheats and shuts down.

I have the cpus throttled back from 2.5 GHZ to 800MHz. Currently running sbackup the cpu temp is 85C. If I run the CPU at 2.5GHz the temperature begins to climb and eventually the laptop shuts down.

I have installed tpfand and have manually set the fan to on - however it is not running fast enough at under 3000 rpm.

Temp report from lm-sensors.

It is running extremely hot.

May 10 22:18:48 pluto kernel: [ 2657.519280] thinkpad_acpi: unhandled HKEY event 0x6022
May 10 22:18:48 pluto kernel: [ 2657.520305] ACPI: Critical trip point
May 10 22:18:49 pluto kernel: [ 2657.520308] Critical temperature reached (101 C), shutting down.

Nathan Valentine (nrvale0) wrote :

FWIW, I'm running Jaunty with the latest updates and have not seen this problem for several weeks.

(I'm the original creator of this bug report.)

/me has also latest updates and original problem persists just fine.

CharleyS (charley-socci-com) wrote :

This laptop dual boots XP from another partition and I've not seen an issue with cooling there. My wife runs a nearly identical T61 with 8.04 32-bit and has not experienced the same issue.

Is there a patch? When did the "problem" clear up Nathan? Did you take any action?

CharleyS (charley-socci-com) wrote :

Can anyone install stress from the repos, and replicate this issue? sudo apt-get install stress

/$ stress --cpu 2 --io 1 --vm 1 --vm-bytes 128M --verbose

On a 'normal' laptop that has no heat issue, this takes me to about 70-80C with the CPU running at full speed.

Nathan Valentine (nrvale0) wrote :

CharleyS,

I didn't specifically do anything to fix the problem but, if memory serves, it went away after an 'apt-get upgrade' about a week before Jaunty hit release. I really only realized it had gone away when someone else posted an update to this bug report.

CharleyS (charley-socci-com) wrote :

Thanks for the response. I just came home to my cold laptop. I booted Windows XP SP 3 and ran a prime number calculating application against each cpu core. They ran to 100%, 2.5GHz each, and the temperature averaged right around 90C. I could feel the fan spinning up and pumping heat out of the laptop.

I shut the laptop down and booted the kernel referenced in my first post. I ran the stress app mentioned above, without the io argument.

Both CPUs immediately hit 100% and 2.5GHz, the temperature *immediately* went to over 100C -

This is a fairly new laptop, the fan is clean.

I can't believe I'm the only one still having this issue, or that it has been fixed... I HATE saying "it works in Windows" - but sadly, it does.

May 11 22:14:32 pluto kernel: [ 554.742142] thinkpad_acpi: unhandled HKEY event 0x6022
May 11 22:14:32 pluto kernel: [ 554.744927] ACPI: Critical trip point
May 11 22:14:32 pluto kernel: [ 554.744937] Critical temperature reached (102 C), shutting down.

CharleyS (charley-socci-com) wrote :

A little more data, hope this is helpful:

I ran the same stress test on my wife's T61. Hardy 32-bit 2.6.24-23-generic

Her CPU ran to 100% and after 5 minutes it had still not exceeded 65C

Clearly something is wrong... I'll be pleased to help, but I've about exhausted my personal bag of tricks. I've tried various changes to CPU and Power management in the BIOS to no avail.

I really hope someone can help!

Thanks

CharleyS (charley-socci-com) wrote :

Ok. I found a workaround.

1. you can monitor your fan speed from the thinkpad-acpi module: cat /proc/acpi/ibm/fan
2. you can adjust the fan speed to stay on at full speed by executing the following command as root: echo level disengaged /proc/acpi/ibm/fan

One I did that, the fan kicked up to 4000+ rpm and stayed there. The CPU temp stays at 94C under full load and goes no higher.

For more info, see the following: http://www.thinkwiki.org/wiki/How_to_control_fan_speed

Good luck!

does anybody know, where/how are thresholds managed, when and how much processor speed should be stepped up when they are busy enough? is there any changes made between 8.10 and 9.04?

all the time i was running boinc client under 8.10 and cpu were set to ondemand and no matter what other processes i ran, boinc had no effect to processor speed changes. it just used nice-ly, whatever time processor was idle. only us/sy -processes affected processor speed changes in ondemand mode.

under 9.04, in the other hand, one can stop all the other programs and leave only boinc running and processor speed will jump up and down way too often, staying on top speed too much and heating up the machine. stopping boinc and running my ordinary set of user-programs, speed changes behave normally, stepping up only when i load some website in firefox etc. even tweaking boinc to use only 70% of processor time (used to be set to default setting under 8.10, which was probably 100%) will not restore the usual relaxed way this machine/os/programs used to run.

could it be, that becuase for whatever reason 9.04 changes speeds of two cores independently, it also evaluates busy/idle thresholds independently?

say, threshold for jumping up the speed is/was x (whatever unit of whatever measurement) and when processor@8.10 reached this threshold, speed was stepped to next available speed... at 9.04 the same calculation is applied per core basis, therefor same threshold is twice as frequently/easily

just a thought

anyhow, nice -stuff should change nothing in this department, no matter how these changes are calculated.

Carlos (carlos-lst) wrote :

I found this bug because my t42p was running very hot with Jaunty (I was running Debian/Sid before). After looking around for a while, I noticed that the processor was running at 2 MHz all the time, that is, that the cpu frequency governor was set to 'performance' by default in the kernel. I solved the issue by putting:

echo ondemand > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor

in /etc/rc.local

It really doesn't make sense to have 'performance' as the default governor for laptops!

Cheers.

abhiroopb (abhiroopb241088) wrote :

I have collated all the various posts into one ubuntuforums post...please help advice there...

http://ubuntuforums.org/showthread.php?p=7399158#post7399158

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers