Comment 355 for bug 370173

Greya (grreya) wrote :

Hello Eloi Espanol,

I will describe in details my situation after BIOS upgrade (hope it can help):

After upgrading BIOS I had the sensors applet showing ACPI temperature (110 C) again, but it was different:
- Before upgrade: it was 110C all the time since booting and the laptop was laggy and slow all the time.
- After upgrade: it booted okay, but in one hour or two, when I was working in some "heavy" program (VMware Workstation, Photoshop) - I heard my fan starting to work loudly and I saw again temp-applet showing ACPI 110C.
But! I think this applet doesn's show the temperature quite right - cause there are only two temperatures it showed me - 27C or 110C (and it didn't change for any other throughout the day).

So, I looked through the System Tools > Log File Viewer: and I didn't find the message I saw before BIOS upgrade "Critical temperature reached (110 C), shutting down." Just another message kinda "ACPI ... 110C" (didn't save it).
I also saw this in the syslog:
          fan PNP0C0B:00: registered as cooling_device0
          ACPI: Fan [FAN0] (off)
          fan PNP0C0B:01: registered as cooling_device1
          ACPI: Fan [FAN1] (off)
And I thought maybe something was wrong here, but laptop fan worked OK, since I heard it working and changing the speed sometimes. And now, when everything's fine - this message is still there and the fans work fine.

So, I thought about two variants left to try: either the laptop fans were in dust (I didn't clean it after buying) or maybe it's something connected with VMware Workstation processes (there are many of the running at boot and running all the time when VMware isn't even in use). Cause when I tried to remember when this laggy problem started to occur on my previous system - Ubuntu 10.10 (the one I had before installing Debian, and before Debian I had 3 or 4 previous versions of Ubuntu and it worked OK) - I remembered I had recently upgraded VMware Workstation to the last version (v.7.1.3-324285.).
Also, just after I installed Debian 6.0 - I worked on my laptop for one or two days without having this problem - it took me to finish tuning up my system and installing everything I need. One of the last programs I installed was exactly the last version of VMware. And here the laggy problem began (as fas as I remember)!

So, I tried both:
1) I thouroughly vacuum-cleaned the fans (laptop shut down of course :)
2) AND, I downgraded VMware Workstation to previous version 7.1.2-301548.
And the problem's gone... I worked in Photoshop for couple of hours with large files and everything worked fine, I didn't work in VMware though. But it's already two days I don't have this problem again. And after cleaning the fans - I almost don't hear it working, it's not loud at all - there were pretty much dust in there.

Maybe all this is too much detailed, but I don't really know what helped to solve my problem - maybe it was vmware processes , or maybe it was the dust..

OH, and another note! I upgraded BIOS to v10, not v11. When I was googling this laggy problem, I once read in some bug report that people who upgraded their DELL BIOS to v11 had this problem occur again (on Windows 7 though) - and the solution was to downgrade BIOS to v10. Maybe it could help you too, but I think you should find out more information about this variant before downgrading.

Hope I could help you in some way :)